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Executive summary
IBM Corporation (IBM) commissioned Principled KEY FINDINGS
Technologies (PT) to measure power and performance
with Intel’s vConsolidate OEM version 1 workload using e The IBM x3850 M2 server produced 27.1
VMware ESX Server 3.5 on quad-processor servers using percent better performance per watt than a
the following servers: similarly configured HP ProLiant DL580 G5
server with redundant power supplies active
e HP ProLiant DL580 G5 at five CSUs (see Figure 1).
* IBM System x3850 M2 e The IBM x3850 M2 server delivered 8.0
percent more performance running
The IBM and HP servers were similarly configured with vConsolidate with the optimum number of
four 2.93GHz Intel Xeon X7350 processors, 32 2GB CSUs (five) than the HP ProLiant DL580 G5
DIMMs, and identical PCI-e NICs and HBAs. Figure 1 server (see Figure 2).
provides a normalized comparison for the test servers with - : - -
the optimum vConsolidate work units, which it calls e With redundant power supplies active at five
consolidation stack units (CSUs). (See the Workload CSUs, the IBM x3850 M2 server used 15.1
section and later sections for more on CSUs.) This chart percent less power than the HP ProLiant
normalizes the results to the lowest single one-CSU result. DL580 G5 server (see Figure 2).
That system’s score is thus 1.00. Normalizing makes each

data point in the chart a comparative number, with higher numbers indicating better performance.

In this section, we discuss the best results for all servers. For complete details of the performance of each server
at five CSUs, see the Test results section.

We tested the servers with redundant

vCon relative performance per watt power supplies active. As Figure 1

results at 5 CSUs illustrates, the IBM x3850 M2 server

LE0 delivered higher performance per watt on
the five-CSU vConsolidate workload,
delivering a 27.1 percent performance per
watt increase over the HP ProLiant DL580
BHP ProLiant DL580 G5 G5 server also at five CSUs.
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aIBM x3850 M2 Figure 2 shows the IBM x3850 M2 server
06 | delivered better overall performance than
the HP ProLiant DL580 G5. It offers 8.0
0.40 percent better performance than the HP
ProLiant DL580 G5, and used 15.1 percent
0.20 | less power to do so.

Normalized performance per watt

0.00 Part of the explanation for the higher power

SSey consumption of the HP ProLiant DL580 G5
is that it uses more power supplies than the
IBM x3850 M2. In redundancy mode, it
Figure 1: vConsolidate results at the optimal number of CSUs (five) for the two uses four power supplies, wh'le th? IBM
servers we tested. x3850 M2 uses only two. It is possible to

purchase a four-processor DL580 G5

server with only two power supplies, but that sacrifices redundancy. An experimental run to find out the impact of
these extra power supplies showed that, under load, the DL580 G5 used 25 watts less power with two power
supplies than with four. This means that the IBM x3850 M2 with redundancy delivered 23.7 percent better
performance per watt than the DL580 G5 without redundancy.




Server vCon results | Average power | Idle power 2 EITE ] [P e
per watt
HP ProLiant DL580 G5 2.63 942.6 641.3 1.000
IBM x3850 M2 2.84 800.6 503.8 1.271

Figure 2: A comparison of the two servers in performance, power, and performance per watt at five CSUs.

As Figure 2 shows, with redundant power supplies and running idle, the IBM x3850 M2 server used 21.4 percent
less power than the HP DL580 G5 server.

We calculated performance per watt by dividing the vConsolidate score for each server at five CSUs by the
measured power when running five CSUs for a minimum 30-minute interval. We measured power at 208 V on
both servers.

Workload

Intel defined, implemented, and supplied the vConsolidate OEM version 1 workload. vConsolidate includes four
different performance tests—database, Java, mail, and Web—that run simultaneously in different virtual machines
(VMs) on a server. A fifth, idle VM is also present during the test. vConsolidate refers to a single collection of
these five virtual machines as a consolidate stack unit (CSU). Depending on the type of server and its available
resources, testers can choose to run one or more CSUs. The typical goal is to run enough CSUs to push the
server under test to its maximum capacity by consuming close to 100 percent of the CPU capacity.

vConsolidate sums the throughput results of each type of work across all CSUs in a test. Then it amalgamates the
combined throughputs of all CSUs to create an overall score for the server under test. See the Test results
section for more information on this process.

vConsolidate uses the following four performance tests:

LoadSim

Microsoft Exchange Server 2003 Load Simulator (LoadSim) is a benchmark that measures a server’s
performance handling email. LoadSim uses the MAPI Messaging Benchmark 3 (MMB-3) to simulate MAPI email
clients. The simulated clients issue requests to an Exchange server to generate an email load. LoadSim
measures both the server’s response time and the number of messages it delivers. LoadSim is available for free
download from www.microsoft.com/downloads/details.aspx?Familyld=92EB2EDC-3433-47CA-A5F8-
0483C7DDEA85&displaylang=en.

SPECjbb2005

SPECjbb2005 is an industry-standard benchmark from the Standard Performance Evaluation Corp. (SPEC) that
measures a server’s Java performance. SPEC modeled SPECjbb2005 on the three-tier client/server architecture,
with the middle layer as the primary focus. According to SPEC, “Random input selection represents the first (user)
tier. SPECjbb2005 fully implements the middle tier business logic. The third tier is represented by tables of
objects, implemented by Java Collections, rather than a separate database.” For more information about
SPECjbb2005, see www.spec.org/jbb2005/docs/UserGuide.html.

The results we quote here for this workload are not official SPECjbb2005 results because the vConsolidate
workload uses a slightly modified version of the benchmark. These results are not comparable to SPECjbb2005
results on SPEC’s Web site.

SysBench

The developers at SourceForge.net (www.sourceforge.net) created SysBench to test various aspects of the
performance of servers running database systems. The benchmark’s original target was the MySQL database
system (see www.mysql.com). Intel created a version of SysBench 0.4.0 that would work with Microsoft SQL
Server 2005 Enterprise Edition (www.microsoft.com/sql/editions/enterprise/default.mspx). We ran that version in
our test. In the vConsolidate workload, SysBench created a 100,000-row SQL database and executed a batch of
online transaction processing (OLTP) transactions against that data.
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WebBench

WebBench 5.0 (128-bit US version) is an industry-standard benchmark for Web server software and hardware. It
uses PC clients to send Web requests to the server under test. It generates performance results by incrementally
increasing the number of clients making HTTP 1.0 GET requests to the Web server; the result is a curve showing
the server’s performance under increasing load. The peak of that curve represents the peak throughput of the
server. WebBench reports both the total number of requests per second the server handled and the server’s total
throughput in bytes per second. To be certain that we found the true peak performance in our testing, we verified
that the server’s processor utilization reached or was extremely close to 100 percent during the test.

vConsolidate profiles

The vConsolidate workload comes with four sets of VM specifications, which it calls profiles. These profiles define
five key factors for each workload VM:

number of virtual CPUs (vCPUs) the workload should receive
amount of virtual RAM (vMemory) the workload should receive
the operating system (OS) the workload should run

the key application the workload should run

the workload itself

As we noted earlier, vConsolidate refers to a single collection of these five virtual machines as a consolidate stack
unit (CSU). Depending on the type of server and its available resources, you may choose to run one or more
CSUs. The typical goal is to run enough CSUs to push the server under test to its maximum capacity by
consuming close to 100 percent of the CPU capacity.

vConsolidate offers four profiles; we tested with Profile 2, which we detail in Figure 3.

Profile 2
vCPUs vMemory 0S Application
WebBench (Web) 2 1.5 GB Windows 32-bit s
LoadSim (mail) 1 1.5GB Windows 32-bit Exchange
SysBench (database) 2 1.5GB Windows 64-bit SQL Server
SPECjbb2005 (Java) 2 2.0GB Windows 64-bit BEA JVM
Idle 1 0.4 GB Windows 32-bit

Figure 3: The vConsolidate profile we used in our testing.
For further information on vConsolidate, please contact Intel.

Test results

The result for an execution of the vConsolidate workload amalgamates the results of all four of the workloads it
includes. To calculate a final score for a vConsolidate run, we used the following four steps, as vConsolidate
specifies:

1. Benchmark throughput = benchmark’s raw results/benchmark duration (for each of the four benchmarks)
2. Total benchmark throughput = add benchmark throughput for all CSUs in test

3. Normalized throughput = total benchmark throughput/reference system’s benchmark throughput

4. vConsolidate score = geomean (normalized throughput of all four benchmarks)

The first step in this process uses whatever raw results a benchmark produces, such as number of transactions or
operations, and the benchmark’s duration in seconds. We calculate a benchmark’s duration by subtracting the
start time of the vConsolidate test from its stop time and converting that time to seconds.
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WebBench is an exception to this process because it automatically produces a score in requests per second. For
this benchmark, we calculate the average requests per second for the three WebBench mixes that run while the
other benchmarks are running and record this result as its throughput.

The second step is to sum the throughput for a given benchmark across all CSUs. In the one-CSU case, there is
no need for this step. For the two- , three-, four-, and five- CSU tests, we summed the throughput of each
individual benchmark across all CSUs to obtain that benchmark’s final score.

The third step is to normalize the throughput. We use the one CSU score of one of the systems under test as the
reference system and assign it a normalized score of 1.00. We then divide the summed throughput for a given
type of work by the reference score for that benchmark. This produces the normalized score for that type of work
in this test. In this test, we used as the reference score the one-CSU score on the HP ProLiant DL580 G5.

The last step is to take the geometric mean of the normalized throughput for all four benchmarks.
Figure 4 shows the final score (the median of three runs) and CPU utilization of the test servers by number of

CSUs. The CPU utilization percentage is the average over the period the vConsolidate workload ran. All servers
achieved CPU saturation with five CSUs.

Server 1CSU 2 CSUs 3 CSUs 4 CSUs 5 CSUs
Group 1 Score | CPU | Score | CPU | Score | CPU | Score CPU Score | CPU
HP ProLiant DL580 G5 1.00 32 1.89 65 2.46 87 2.58 94 2.63 98
IBM x3850 M2 1.06 31 1.97 63 2.58 85 2.75 93 2.84 97

Figure 4: vConsolidate median results for the two test systems with one, two, and three, four, and five CSUs. Higher scores are

better.

Figure 5 shows the five-CSU test results, by benchmark and CSU, for the HP ProLiant DL580 G5 server.

HP ProLiant DL580 G5 Ccsu 1 CSU 2 CsuU3 CcsuU 4 CsU5

Java 13,020.69 | 13,102.89 | 13,209.64 | 13,068.36 13,327.47
Database 62.66 61.36 62.84 62.17 62.67
Mail 19.04 18.59 18.45 18.20 19.84
Web 485.25 496.61 496.12 487.68 495.74
Final score 2.63

Figure 5: vConsolidate five-CSU median results, by benchmark and CSU, for the HP ProLiant DL580 G5 server.

Higher scores are better.

Figure 6 shows the five-CSU test results, by benchmark and CSU, for the IBM x3850 M2 server.

IBM x3850 M2 Csu 1 CSU 2 CSuU3 Ccsu 4 CSU S5

Java 15,992.31 15,805.08 | 16,140.85 | 16,258.79 16,299.35
Database 69.40 69.28 69.67 70.13 72.39
Mail 19.79 18.39 19.13 19.88 19.93
Web 487.73 478.43 468.98 468.40 464.40
Final score 2.84

Figure 6: vConsolidate five-CSU median results, by benchmark and CSU, for the IBM x3850 M2 server. Higher

scores are better.
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Test methodology

Figure 7 summarizes some key aspects of the configurations of the two server systems; Appendix A provides
detailed configuration information.

Server HP ProLiant DL580 G5 IBM x3850 M2
(2.93GHz) (2.93GHz)

Processor frequency (GHz) 2.93 2.93

Front-side bus frequency (MHz) 1066 MHz 1066 MHz

Number of processor packages 4 4

Number of cores per processor package 4 4

Number of hardware threads per core 1 1

Motherboard HP ProLiant DL580 (G5) LBR'\Q)’G%O M2 (7141-
. IBM Enterprise X-

Chipset Intel 7300 Architecture v4

RAM PC2-5300 FBDIMM PC2-5300 DDR-2

Figure 7: Summary of some key aspects of the server configurations.

With the following exception we used the default BIOS settings on each server. On the HP ProLiant DL580 G5 we
enabled Intel virtualization technology. If we had not enabled it, then the HP would have been unable to run 64-bit
VMs, and thus unable to successfully complete a vConsolidate run. As the IBM server had Intel virtualization
technology enabled by default, it did not require this change.

To be sure we could push the processors of each of the two system configurations to their maximum capacities,
we tested each server with as many vConsolidate CSUs as the server could handle, starting with one CSU, up to
or extremely close to 100 percent processor utilization. The rest of this section details how we set up the servers
and the vConsolidate workload.

Hardware and software the test involved
Software
We used the following software to configure and run the vConsolidate workload:

VMware ESX Server 3.5.0 build 64607

VMware Virtual Infrastructure Client version 2.5.0
Microsoft Windows Server 2003 R2, Enterprise Edition
Microsoft Windows Server 2003 R2, Enterprise x64 Edition
Microsoft Exchange Server 2003

Microsoft SQL Server 2005

BEA JRockit 1.6.0_02-b05

WebBench 5.0

Microsoft Exchange Server Load Simulator (LoadSim) 06.05.7775
SPECjbb2005 v1.07

SysBench v0.4.0

Intel vConsolidate OEM framework package version 1
VMware Converter 3.0.2
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Hardware
Our test bed consisted of the following hardware:

e The server under test

e Eleven custom-built Intel Desktop Board D915GMH with Intel Pentium 4 3.0GHz w/HT systems, which we
used for all WebBench clients, LoadSim clients, and WebBench controllers (CSU 2 and CSU 3).

e One custom-built Intel Server Board D945GTP system, which we used as both the main vConsolidate
controller and the CSU 1 WebBench controller

e NETGEAR GS724T, which we set up into two VLANSs (one for external network and one for internal
network)

o Network Appliance NetApp FAS960 filer

e Two Network Appliance DS14 Disk Shelves, with 14 x Seagate Cheetah ST373307FC 73.4 GB disk
drives each

e QLogic SANblade QLE2462 Dual Port 4-Gbps Fibre Channel Host Bus Adapter (HBA) installed in the
server under test

Figure 8 illustrates this test bed in its five-CSU configuration.

vConsolidate five-CSU test bed

CSU #2 WebBench CSU #2
External network controller LoadSim client
csu[:;[‘:"::ﬁf:lf;a"d switch Server under test IP address = IP address =
(see additional IP address with six active NICs 192.168.22.210 192.168.21.110
information below) \ CsU #2
WebBench
client
IP address =

External network  G————

192.168.22.211

S
0
Internal network 1 G———— § —

e — |—( Internal network 4 6_|
| CSU #4 WebBench CSU #4 Ccsu #4
. . WebBench
csu #1 csu #1 CSU #3 WebBench csu#3 controller LoadSim client client
LoadSim client  WebBench client controller LoadSim client IP address = IP address = -
IP address
IP address = IP address = IP address = IP address = 192.168.42.210 192.168.41.110 192.168.42.211
192.168.11.110 192.168.12.211 192.168.32.210 192.168.31.110
CSU #3
WebBench
client
IP address = \ NN

ST S

Additional IP address information
Server under test: External network = 192.168.0.250; Internal network (one for each CSU’s

Internal network 5

WebBench and LoadSim traffic) CSU #5 WebBench CSU #5 CSU #5
controller LoadSim client WebBench

Main controller: External network IP address = 192.168.0.100 IP address = IP address = client

Internal network IP address = 192.168.11.100; 192.168.12.100; 192.168.12.210; 192.168.21.100; 192.168.52.210 192.168.51.110 IP address =

192.168.22.100; 192.168.31.100; 192.168.32.100; 192.168.41.100; 192.168.42.100; 192.168.51.100; 192.168.52.211

192.168.52.100

VM IP addresses: JavaServer1 - 5, DBServer1 - 5, IdleServer1 - 5= DHCP

Webserver1 = 192.168.12.215; WebServer2 = 192.168.22.215; WebServer3 = 192.168.32.215;
WebServer4 = 192.168.42.215; WebServer5 = 192.168.52.215

MailServer1 = 192.168.11.115; Mailserver2 = 192.168.21.115; MailServer3 = 192.168.31.115;
MailServer4 = 192.168.41.115; MailServer5 = 192.168.51.115

Figure 8: Our vConsolidate test bed running with five CSUs.
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Server installation

We configured all servers with the same disk setup using the NetApp FAS960 filer. We split the storage into four
volumes, one with 10 GB and five with 130 GB. For each server, we installed VMware ESX Server on the 10GB
volume and installed a CSU on each of the five 130GB volumes. We installed the boot loader on the hard drive
installed in the server’s drive chassis on the server under test.

Installing VMware ESX Server 3.5.0
We performed the following steps to install VMware ESX Server 3.5.0 build 64607 on the server under test:

1. Boot with the VMware ESX Server CD.

2. When prompted, press Enter to boot in graphical mode.

3. Press Enter to skip the media test.

4. Click Next through the following screens (accepting the default options): Welcome, Select Keyboard,
Select Mouse, and License Agreement.

5. Select Recommended for the disk partitioning option, and click Next.

6. When the warning appears that all partitions will be lost, click Yes.

7. Click Next to accept the partition disks settings.

8. At the advanced options screen (the default option is to boot VMware ESX Server from the hard drive),

click Next.
9. Enter the static IP address (192.168.0.250) and subnet mask (255.255.255.0), and click Next.
10. Select the time zone, and click Next.
11. Enter the root password, and click Next.
12. At the About to install screen, click Next to start the installation.
13. When the server installation completes, click Finish to reboot the server.

Installing Virtual Infrastructure Client on the controller

We managed VMware ESX Server with a separate system we call the controller. We ran Microsoft Windows
Server 2003, Enterprise Edition on this system and connected it to the VMware ESX Server with a network
switch. We performed the following steps to install the necessary VMware Infrastructure Client software on this
system:

1. On the remote client, open a Web browser, and type the server’s IP address (http://192.168.0.250) in the
address pane.

2. Atthe VMware ESX Server 3 Welcome page, select Download the VMware Infrastructure Client.

3. When the file download security warning pops up, click Run to install the client software.

4. Install the client software by clicking Next through the installation option windows (which accepts all
default options).

5. When the installation completes, click Finish.

6. Close the Web browser window.

7. Launch the VMware Infrastructure Client application by double-clicking the desktop icon.

8. At the client log in screen, enter the VMware ESX Server IP address (192.168.0.250), root user, and
password, then click Log on.

9. Before you can properly use the VMware ESX Server, you must first install a license file. You can deploy
that file with either host-based or server-based licensing. For our testing, we used the host-based license
method by following these steps:

a. Toinstall the license, click the Configuration tab in the Virtual Infrastructure Client.

b. Under the Software section on the left side of the screen, click Licensed Features.

c. Make sure the license file (which VMware should have provided with the copy of VMware ESX
Server) is on the controller.

d. Click Edit next to the License Sources.

e. In the pop-up window, select Use Host License File.

f. Click Browse, and browse to the location of the license file on the server.

g. Click Open to select the file.

h. Click Edit next to VMware ESX Server License Type.
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i. Select VMware ESX Server Standard, and click OK.

Configuring network adapters with Virtual Infrastructure Client

Before we set up the VMs, we had to configure the network adapters on the VMware ESX Server. To
accommodate all the network traffic the test required, we used six network ports on the VMware ESX Server, as
Figure 10 illustrates.

We assigned the external network port the IP address of 192.168.0.250 during the VMware ESX Server
installation, because this is the network port that the Virtual Infrastructure Client, and the database, Java, and idle
VMs use to communicate.

The remaining five network ports are part of the internal network, on which the Web and mail server traffic travels.
We configured one network port to handle traffic from the Web and mail VMs for only one CSU. Therefore, each
CSU had its own network port for network traffic.

We performed the following steps to configure the VMware ESX Server for the network adapters:

Within the Virtual Infrastructure Client window, select the configuration tab for the VMware ESX Server.
In the hardware section, select networking to view the network setup.
Click Properties for Virtual Switch vSwitchO.

In the vSwitchO Properties window, highlight the Virtual Machine Network, and click Edit.
Rename the Network Label to External Network.

Click OK to close the window.

Click Close to close the Properties window.

On the Networking configuration tab, click Add Networking.
Select Virtual Machine for the connection type, and click Next.
10. Under Create a virtual switch, select vmnic1, and click Next.

11. Change the Network Label to Internal Network 1, and click Next.
12. At the summary page, click Finish.

13. At the Networking configuration tab, click Add Networking.

14. Select Virtual Machine for the connection type, and click Next.
15. Under Create a virtual switch, select vmnic2, and click Next.

16. Change the Network Label to Internal Network 2, and click Next.
17. At the summary page, click Finish.

18. At the Networking configuration tab, click Add Networking.

19. Select Virtual Machine for the connection type, and click Next.
20. Under Create a virtual switch, select vmnic3, and click Next.

21. Change the Network Label to Internal Network 3, and click Next.
22. At the summary page, click Finish.

23. At the Networking configuration tab, click Add Networking.

24. Select Virtual Machine for the connection type, and click Next.
25. Under Create a virtual switch, select vmnic4, and click Next.

26. Change the Network Label to Internal Network 4, and click Next.
27. At the summary page, click Finish.

28. At the Networking configuration tab, click Add Networking.

29. Select Virtual Machine for the connection type, and click Next.
30. Under Create a virtual switch, select vmnic5, and click Next.

31. Change the Network Label to Internal Network 5, and click Next.
32. At the summary page, click Finish.
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Creating a virtual machine

The steps below describe how we created a base virtual machine. We performed the following basic steps to
create each of the VMs the test required. We list the exact parameters we specified for each VM in the section
below on installing and configuring that VM.

In Virtual Infrastructure Client, highlight the VMware ESX Server (localhost.localdomain).
Select File->New->Virtual Machine.

Select Custom on the Select the Appropriate Configuration screen, and click Next.

Enter the Virtual Machine Name, and click Next.

Select the Storage that will hold the VM, and click Next.

Select the Operating System for the VM, and click Next.

Use the drop-down box to select the number of virtual processors for the VM, and click Next.
Select the amount of memory for the VM, and click Next.

Select the Network Connection for the VM, and click Next.

10. Accept the default option for the SCSI Adapter, and click Next.

11. Leave the default option to create a new virtual disk on the Select a Disk screen, and click Next.
12. Enter the virtual disk size, and click Next.

13. Leave the default options for the Specify Advanced Options, and click Next.

14. Review the virtual machine summary, and click Finish to create the virtual machine.

©CoNo>OA~WON =

To create one vConsolidate CSU, we had to create the five virtual machines that CSU describes:

mail server

Web server

Java application server
database server

idle server

The following subsections detail how we created and configured each of these VMs.

Installmg and configuring the 32-bit base VM
Follow the steps in the earlier Creating a virtual machine section using the following VM specifications:
e Name: Base32
e Virtual processors: 1
e Virtual memory: 408 MB
e Virtual disk size: 10 GB
e Virtual network: External Network (keep the default Windows Network DHCP settings)
Install Microsoft Windows Server 2003 R2, Enterprise Edition in the VM.
Install Microsoft Windows Server 2003 Service Pack 2 with default settings.
Right-click the Base32 VM in the Virtual Infrastructure Client window, and select Install VMware tools.
Reboot the VM.
Right-click the desktop, and select Properties.
On the Screen Saver tab, Click the Screen saver drop-down menu, and select (None).
Click Apply.
Click Power.
0. Make sure that the power scheme is set to Always On, and then change the Turn off monitor drop-down
menu to Never.
11. Click OK to exit the configuration windows.
12. To allow the VM to automatically log into the OS after a system reboot, change the following registry key
to have the values shown here:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
e DefaultPassword=password
e AutoAdminLogon=1
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e DefaultUsername=administrator
13. Change the My Computer text so that it displays the host name of the VM by changing the following
Registry key to have the values shown here:
[HKEY_CLASSES_ROOT\CLSID\{20D04FEO0-3AEA-1069-A2D8-08002B30309D}]
e LocalizedString=hex(2):25,00,43,00,4f,00,4d,00,50,00,55,00,54,00,45,00,52,00,\
4¢,00,41,00,4d,00,45,00,25,00,00,00
14. Shut down the VM.

Installing and configuring the 64-bit base VM
1. Follow the steps in the earlier Creating a virtual machine section using the following VM specifications:
a. Name: Base64
b. Virtual processors: 1
c. Virtual memory: 408 MB
d. Virtual Disk Size: 10 GB
e. Virtual Network: External Network (keep the default Windows Network DHCP settings)
Install Microsoft Windows Server 2003 R2, Enterprise x64 Edition in the VM.
3. Install Microsoft Windows Server 2003 Service Pack 2.with default settings.
4. Right-click the JavaServer1 VM in the Virtual Infrastructure Client window, and select Install VMware
tools.
5. Reboot the VM.
6. Right-click the desktop, and select Properties.
7. On the Screen Saver tab, Click the Screen saver drop-down menu, and select (None).
8. Click Apply.
9. Click Power.
10. Make sure that the power scheme is set to Always On, and then change the Turn off monitor drop-down
menu to Never.
11. Click OK to exit the configuration windows.
12. To allow the VM to automatically log into the OS after a system reboot, change the following Registry key
to have the values shown here:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
e DefaultPassword=password
e AutoAdminLogon=1
e DefaultUsername=administrator
13. Change the My Computer text so that it displays the host name of the VM by changing the following
Registry key to have the values shown here:
[HKEY_CLASSES_ROOT\CLSID\{20D04FEO0-3AEA-1069-A2D8-08002B30309D}]
e LocalizedString=hex(2):25,00,43,00,4f,00,4d,00,50,00,55,00,54,00,45,00,52,00,\
4¢,00,41,00,4d,00,45,00,25,00,00,00
14. Shut down the VM.

Cloning the base VMs

To create the VMs for the first CSU, we used VMware Converter to make a copy of the two base VMs we had
already created. We then started each VM and individually configured them for their specific purpose. The
following steps explain how to copy a VM with VMware Converter. They assume you have installed the VMware
Converter on the same machine as the VMware Virtual Infrastructure Client.

Open VMware Converter, and click Import Machine.

At the Welcome screen, click Next.

At the Source screen, click Next.

Select VMware ESX Server for the Source, and click Next.

Enter the IP address, user name, and password of the VMware ESX Server, and click Next.
Select the virtual machine that you want to copy (for example: Base32), and click Next.

For the Source Data, leave the default (Import all disks and maintain size), and click Next.
At the Destination screen, keep the default, and click Next.

For Destination Type, select VMware ESX server, and click Next.

CoNIOR~WN=
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10.
11.

12.
13.
14.
15.
16.

Enter the IP address, user name, and password of the VMware ESX Server, and click Next.

Enter the virtual machine name (for example, if you are copying Base32, the server you are configuring
could be IdleServer1, MailServer1, or WebServer1), and click Next.

Select the host system, and click Next.

Select the Datastore, and click Next.

Select the Network connection for the virtual machine, and click Next.

Leave the default Customization settings, and click Next.

Review the summary, and click Finish to begin copying the virtual machine.

Installing and configuring the mail server VM

1.

Follow the steps in the earlier Cloning the base VMs section using the following VM specifications:

e Base VM: Base32

Name: MailServer1

Virtual processors: 1

Virtual memory: 1.5 GB

Virtual disk size: 10 GB

Virtual network: Internal Network (set the IP address to 192.168.11.115 in Windows within the VM)

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Installing the domain controller

CENO>TRAWLN =

15.

16.
17.
18.
19.
20.

Select Start->Administrative Tools>Manage Your Server.

Click Add or remove a role.

At the Configure Your Server window, click Next.

At the Configuration and Options screen, select Custom Configuration, and click Next.

At the Server Role screen, select Domain Controller, and click Next.

At the Summary of Selections screen, click Next.

At the Welcome pop-up window, click Next.

At the Operating System Compatibility screen, click Next.

For the Domain Controller Type, leave the default option (Domain controller for a new domain), and click
Next.

. At the Create New Domain screen, leave the default (Domain in a new forest), and click Next.

. At the Install or Configure DNS window, select No, and click Next.

. At the New Domain Name screen, type a domain name (vcon . com), and click Next.

. At the NetBIOS Domain Name screen, enter a NETBIOS domain name (vcon), and click Next.

. Click Next through the following screens: Database and Log Folders, Shared System Volume, and

Permissions. Doing so accepts the default options for each of those screens.

At the Directory Services Restore Mode Administrative Password screen, enter a password (password),
and click Next.

When the installation software prompts you to do so, insert the OS CD, and click OK.

At the Completing the Active Directory Installation Wizard screen, click Finish.

When the system prompts you to reboot the VM, click Restart Now.

After the VM reboots, log in to the system.

At the This Server is Now a Domain Controller window, click Finish.

Installing Internet Information Services 6.0

N>R~ ON =

Select Start->Control Panel>Add or Remove Programs.

Click Add/Remove Windows Components.

Select Application Servers, and click Details.

Click ASP.NET, and make sure a check appears in the check box.

Select Internet Information Services (IIS), and click Details.

Click NNTP Services and SMTP Services, make sure a check appears in both check boxes, and click OK.
Click OK to close the Application Server window.

At the Windows Components Wizard, click Next to begin the installation.
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9.

10.
11.

When the system prompts you to do so, insert the OS CD, and click OK.
At the Completing the Windows Components Wizard window, click Finish.
Close the Add or Remove Programs window.

Installing Exchange Server 2003

1.

Nook~wN

10.
11.

12.

T Taemea

Insert the Microsoft Exchange Server 2003 CD. The CD should automatically launch the installation
software.

Choose Exchange Server Enterprise Edition.

Run the Setup application.

Click the Exchange Deployment Tools link.

Click the Deploy the first Exchange 2003 Server link.

Click the New Exchange 2003 Installation link.

Click the Run ForestPrep now link.

a. When the compatibility issue notice appears, click Continue, and check the Don'’t display this
message again box.

At the Welcome screen, click Next.

Accept the End User License Agreement, and click Next.

At Component Selection Screen, keep the defaults, and click Next.

Leave the default account information, and click Next.

Installation should start. (This process may take a while to complete.)

When the installation completes, click Finish.

Return to the Exchange Server Deployment Tools screen, and click the Run DomainPrep now link.
a. Atthe Welcome screen, click Next.

b. Accept the End User License Agreement, and click Next.

c. At Component Selection Screen, keep the defaults, and click Next.

d. Atthe insecure domain notice, click OK.

e. When the installation completes, click Finish.

Return to the Exchange Server Deployment Tools screen, and click Run Setup Now.

a. Atthe Welcome screen, click Next.

b. Accept the End User License Agreement, and click Next.

@*eo0oT

c. Atthe Component Selection screen, the action for Microsoft Exchange should by default be Typical.

(If it is not, use the drop-down box to set it to Typical.)

Click Next.

For the Installation Type, select Create new Exchange Organization, and click Next.
Enter vcon as the Organization Name, and click Next.

Accept the Microsoft Exchange Server Licensing Agreement, and click Next.

Review the installation summary, and click Next.

The installation should start. (This process may take a while to complete.)

When the installation completes, click Finish.

Close the Exchange Server Deployment Tools window.

Install Microsoft Exchange Server 2003 Service Pack 2.

Insert the SP2 CD, and double-click setup exe.

Accept the default location to extract the file, and click OK.

After the extraction finishes, open Windows Explorer, and browse to the update.exe executable.
At the Welcome screen, click Next.

Select | agree to accept the License Agreement, and click Next.

At the Component Selection window, leave the default option (Update), and click Next.
Verify the installation Summary, and click Next.

When the installation completes, click Finish.

In the Virtual Infrastructure Client console, add a new 90GB virtual hard disk to this VM by doing the
following:

a. Right-click the MailServer1 VM, and select Edit Settings from the menu.

b. On the Hardware Tab, click Add.

c. For Select Device Type, choose Hard Disk, and click Next.

d. Select Create a new virtual disk, and click Next.

S@"0o0Tw
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13.
14.
15.
16.
17.
18.
19.
20.
21.
22.
23.
24.
25.
26.

27.
28.
29.
30.
31.
32.
33.
34.
35.
36.
37.
38.
39.
40.
41.
42.
43.
44.
45.
46.
47.
48.
49.
50.
51.
52.
53.
54.
55.

56.
57.
58.
59.

Set the Disk Capacity to 90 GB, and click Next.
At the Specify Advanced Options page, leave the default options, and click Next.
At the Read to Complete screen, click Finish.

S@ ™o

Tasks section, which is at the bottom of the Virtual Infrastructure Client window.)
Restart the VM by selecting Start->Shut down—>Restart inside the MailServer VM.
In the MailServer VM, right-click My Computer, and select Manage.

In the Computer Management Console, select Disk Management.

When a Welcome to Initialize and Convert Disk Wizard window appears, click Next.
Select Disk 1 to initialize.

At the Select Disk to Convert screen, leave the disk unchecked.

At the Completing the Initialize and Convert Disk Wizard screen, click Finish.
Right-click the Disk 1 unallocated box, and select New Partition.

At the Welcome screen, click Next.

Leave the partition type as Primary, and click Next.

Wait for the Reconfigure Virtual Machine task to complete. (The status will appear in the Recent

Accept the default Partition Size, which should be the same as the Maximum disk space, and click Next.

Assign the drive letter E, and click Next.

Format the partition with the NTFS File system, enter Mail Store for the volume label, and click Next.

At the Completing the New Partition Wizard screen, click Finish.

The partition should begin formatting.

When the formatting completes, close the Computer Management console.
Select Start->All Programs->Microsoft Exchange—> System Manager.

In the left window pane, expand Servers and MailServer so the First Storage Group is visible.

Right-click First Storage Group, and select Properties.

Click Browse, and change the Transaction log and System path location to E:\.

Check the Enable circular logging box, and click Apply.

When the pop-up message appears asking if you want to perform this task, click Yes.
When the message appears saying that all mounted stores are back online, click OK.
Right-click Mailbox Store under First Storage Group, and select Properties.

Select the Database tab.

Click Browse, and move the Exchange database and Exchange streaming database to E:\.
Check the This database can be overwritten by a restore box.

Click Customize next to Maintenance interval.

Remove all blue from the boxes so the system will not perform maintenance, and click OK.
At the Mailbox Store Properties window, click Apply.

When a warning message appears, click Yes.

When the message that the database files have been moved appears, click OK.

Click OK to close the Mailbox Store Properties window.

Right-click Public Store under First Storage Group, and select Properties.

Select the Database tab.

Click Browse, and move the Exchange database and Exchange streaming database to E:\.
Check the This database can be overwritten by a restore box.

Click Customize next to Maintenance interval.

Remove all blue from the boxes so the system will not perform maintenance, and click OK.
At the Public Store Properties window, click Apply.

When a warning message appears, click Yes.

When the message that the database files have been moved appears, click OK.

Click OK to close the Public Store Properties window.

In the left pane of the Virtual Infrastructure Client, right-click the MailServer1 VM, and select Install

VMware Tools.
At the Install Tools pop-up window, click OK.

Click Next through the Installation Wizard to install the VMware Tools. This process accepts all defaults.

When the installation completes, click Finish.
Click Yes to reboot the virtual machine.
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Installing and configuring the Web server VM

1.

Follow the steps in the earlier Cloning the base VMs section using the following VM specifications:

e Source VM: Base32

Name: WebServer1 (use WebServer for the Host Name in the VM)

Virtual processors: 2

Virtual memory: 1.5 GB

Virtual Disk Size: 10GB

Virtual Network: Internal Network (set the IP address to 192.168.12.215 in Windows within the VM)

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Installing Microsoft Internet Information Server

1.
2
3
4
5.
6.
7
8
9.
1

0.

Select Start->Administrative Tools>Manage Your Server.

Select Add or remove a role.

At the Configure Your Server window, click Next.

At the Configuration Options screen, select Custom configuration, and click Next.

At the Server Role screen, select Application Server, and click Next.

At the Application Server Options screen, select Enable ASP.NET, and click Next.

At the Summary of Selections screen, click Next.

When the installation software prompts you to do so, insert the Operating System CD, and click OK.
When the installation completes, click Finish.

Close the Manage Your Server window.

Installing WebBench 5.0

1.
2.

Insert the WebBench 5.0 CD into the Virtual Client, and connect with the Virtual CDROM.
Copy wbtree.exe from the \wb50\workload directory on the CD to C:\inetpub\wwwroot.

3. Double-click wbtree.exe to expand the workload. (This step will create a wbtree folder with all the test
data WebBench required.)

4. Create a cgi-bin folder in c:\inetpub\wwwroot.

5. After installing the WebBench controller, copy simcgi.exe from the controller machine in
C:\WebBench\Controller\Suites\WebBench\Examples directory to the Web server VM’s
C:\Inetpub\wwwroot\cgi-bin\ directory.

6. Right-click My Computer, and select Manage.

7. Expand Services and Applications, Internet Information Services, and Web Sites in the left window pane.

8. Click Default Web Sites.

9. Right-click the cgi-bin directory in the right pane, and select Properties from the drop-down menu.

10. In the Execute permissions field, select Scripts and Executables, and click OK.

11. Using Windows Explorer, browse to C:\Inetpub\wwwroot\cgi-bin, right-click simcgi.exe, and select
Properties from the drop-down menu.

12. Select the Security tab, and grant Read/Read & Execute permissions to the user, Internet Guest Account.

13. Click OK to close simcgi.exe properties.

14. Close Windows Explorer.

15. In the Computer Management window, right-click the Default Web Server, and select properties from the
drop-down menu.

16. Select the HTTP Headers tab, and click MIME Types.

17. In the MIME Types window, click New.

18. In the Extension text box, enter . ex.

19. In the MIME type text box, enter application/octet-stream, and click OK.

20. Click OK again to close the MIME Types window and the Default Web Site Properties window.

21. In the Computer Management console, select Web Service Extension.

22. Select All unknown CGI Extensions in the right pane, and click Allow.

23. Click Yes, you do want to allow All Unknown CGI Extensions in the pop-up window.
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24.

Open a Web browser, and type the URL http://localhost/cgi-bin/simcgi.exe to verify you correctly installed
the WebBench files. Text about the system should appear in the browser window.

25. Close the Web browser.

Installing Certificate Server

1.
2
3
4
5.
6.
7
8
9.
1

0.

Select Start->Control Panel->Add or Remove Programs.

Click Add/Remove Windows Components.

Select Certificate Servers, and accept the CA Service warning.

Click Next.

Select Standalone root CA in the CA Type Windows, and click Next.

Enter WEBBENCH in the common name field, and click Next.

At the Certificate Database Settings screen, leave the default options, and click Next.
When the warning about stopping IS appears, click Yes.

Click Yes to enable Active Server Pages.

When the installation completes, click Finish.

Creating a certificate request

In the Computer Management Console, right-click the Default Web site, and select Properties.

Select the Directory Security tab, and then click Server Certificate under Secure Communications to start
the Web Server Certificate Wizard.

At the Welcome screen, click Next.

Select Create a new certificate, and click Next.

Select Prepare the request now, but send it later, and click Next.

Type Default Web Site for the certificate name.

Use the default bit length (1024), and click Next.

Type MyWeb for the organization name and Development Dept for the organizational unit, and click
Next.

Type the server name as the common name, and click Next.

. Enter your location information, and click Next.
. Save the certificate information to the default path and file name, and click Next.
. Verify the information that you have typed, and then click Next to complete the process and create the

certificate request.

. Click Finish to close the IIS Certificate Wizard.
. Click OK to close the Default Web Site Properties window.

Submitting a certificate request

PN~
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0.

Open a Web browser, navigate to http://localhost/CertSrv/, and press Enter.

Click Request a certificate.

Click Advanced certificate request.

Click Submit a certificate request by using a base-64-encoded CMC or PKCS #10 file, or submit a
renewal request by using a base-64-encoded PKCS #7 file.

Open the request document that you created in the Create a certificate request section.

Copy the contents of the document to a text box with the following format.

I BEGIN NEW CERTIFICATE REQUEST-----

I END NEW CERTIFICATE REQUEST-------

Note: If you saved the document with the default name and location, it is located at C:\Certreq.txt. Be sure
to copy all of the content as we illustrated above.

Paste the contents of the document into the Web form’s Base64 Encoded Certificate Request text box.
Click Submit.

You should receive a Certificate Pending message in the Web browser.

Close the Web browser window.

Issuing and downloading a certificate

1.

Select Start->All Programs->Administrative Tools-> Certificate Authority.
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In the Certificate Authority window, expand the server name.

Click the Pending Requests folder.

In the pending request folder, right-click the pending certificate request that you just submitted, select All
Tasks, and then click Issue. (Note: After you select Issue, the certificate no longer appears in this window
and folder. It now resides in the Issued Certificate folder.)

Close the Certificate Authority window.

Open a Web browser, and type http://localhost/CertSrv/.

Click View the status of a pending certificate request.

Click the certificate request that you can see.

Click Download Certificate.

. Click Save in the File Download window.

. Save the certificate to C:\.

. Close the download complete pop-up window.
. Close the Web browser window.

Installing the certificate and setting up an SSL Web site

1.

2.
3.
4

Noou

8.
9.
10.
11.
12.

Open the Computer Management console by right-clicking My Computer, and selecting Manage.
Right-click the Default Web site, and select Properties.

Select the Directory Security tab.

Under Secure Communications, click Server Certificate. This step will start the Certificate Installation
Wizard.

At the Welcome screen, click Next.

Select Process the pending request and install the certificate, and click Next.

Browse to the location of the certificate that you downloaded in the Issue and download a certificate
section, and click Next.

Keep the default SSL Port, and click Next.

Verify the information is correct on the Certificate Summary page, and click Next.

Click Finish to complete the installation.

Click OK to close the Default Web Site Properties window.

Close the Computer Management window.

Configuring and testing the certificate

1.
2.

3.
4.

Open a Web browser, and type https://webserver/cgi-bin/simcgi . exe.

You may receive a security alert that states that the certificate is not from a trusted root CA. Click Yes to
continue to the Web page.

If the page appears, you have successfully installed the certificate.

Close the Web browser.

Installing and configuring the Java application server VM

1.

Follow the steps in the earlier Cloning the base VMs section using the following VM specifications:
e Base VM: Base64

Name: JavaServer1

Virtual processors: 2

Virtual memory: 2 GB

Virtual Disk Size: 10 GB

Virtual Network: External Network (keep the default Windows Network DHCP settings)

To finish setting up this VM for vConsolidate, we had to install and modify an additional software component. The
following subsections detail the necessary installation processes.
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Installing SPECjbb2005

1.
2.
3

seeNoas

Copy the BEA JRockit JVM 1.6.0_02 folder to the root of C: in the VM.
Install SpecJBB2005 in the VM directory: c:\vSpecJBB2005.
Add the BEA JRockit JVM to the Windows system path by doing the following:
a. Right-click My Computer, and select Properties.
b. Select the Advanced tab, and click Environment Variables.
c. Inthe System variables section, select Path, and click Edit.
d. Add the following to the end of the Variable value string: C:\jrockit-jdk1.6.0_02 \bin (jrockit-
jdk1.6.0_02 is the folder name of the JVM installation).
e. Click OK to close the Edit System Variable, Environment Variables, and System Properties
windows.
Open a command prompt by selecting Start>Run.
Type cmd, and click OK.
Change to the vSpecdBB2005 directory by typing cd C:\vSpecdBB2005, and then press Enter.
Type runit .bat, and press Enter to verify SPECjbb2005 starts.
Press Ctrl-C to stop the benchmark.
Confirm that you do want to stop the run by typing Y and pressing Enter.

0 Copy the following files from the vConsolidate package to the VM directory C:\:

e Daemon.exe
o killapp.exe.

Modifying SPECjbb2005
To run the vConsolidate benchmark, you must modify SPECjbb2005 as follows:

1. Modify the following three original source files in the SPECjbb directory (C:\SPECjbb2005\src\spec\jbb\)
by opening each file with WordPad and making the changes below. Save each file after you have made
the changes.

e Company.java
Change private long measurement time; to public long measurement time;
Change JBButil.SecondsToSleep ( (int) measurement time); to
JBButil.SecondsToSleep (Long.MAX VALUE/1000) ;
e DeliveryTransaction.java
After the line customerPtr.adjustBalance (matchingOrder.getTotalAmount ()) ;, add the
following lines:
int timerCount = 0;
timerCount = (short)JBButil.random(1,100);
if (timerCount == 1)
JBButil.milliSecondsToSleep (company.measurement time) ;
e TransactionManager.java
Change myTimerData.updateTimerData (txntype, txntime) ; to the following lines:
myTimerData.updateTimerData (txntype, txntime) ;
if (txntype==0 && myTimerData.getTransactionCount (0) %1000 == 0)
int sum = 0;
for (int k=0; k<=5; k++)
sum += myTimerData.getTransactionCount (k) ;
System.out.println ("===="+this+":"+"===="+sum) ;

2. Open the command prompt by clicking Start->Run, type cmd, and press Enter.

3. Atthe command prompt, type cd C:\SPECjbb2005\src\spec\jbb\.

4. At the command prompt, type the following commands. Press Enter after each command:

e mkdir class
e "C:\Program Files\Java\jrockit-jdkl.5.0\bin\javac" -cp "C:\Program
Files\Java\jrockit-jdk1.5.0\jre\lib\rt.jar" -d class\ *.java
infra\Util\*.java validity\*.java ..\reporter\*.java
Principled Technologies, Inc.: vConsolidate performance 17

on IBM and HP aquad-core multiprocessor Intel processor-based servers



e cd class\
e "C:\Program Files\Java\jrockit-jdkl.5.0\bin\jar" -cf jbb.jar
spec\jbb\*.class spec\jbb\infra\Util\*.class spec\reporter\*.class
e "C:\Program Files\Java\jrockit-jdk1l.5.0\bin\jar" -cf check.jar
spec\jbb\validity\*.class
Type exit to close the command prompt.
Open Windows Explorer from the start menu.
Copy the jbb.jar and check jar files from C:\SPECjbb2005\src\spec\jbb\class to C:\vSpecJBB2005\.
When the system asks if you want to overwrite files, click Yes to overwrite the original jbb.jar and
check.jar files.
Using Windows Explorer, navigate to C:\vSpecJBB2005, and open the SPECjbb.props file.
0. Make the following changes to the SPECjbb.props file:
e Change input.starting number warehouses=1to
#input.starting number warehouses=1
e Change input.increment number warehouses=1 to
#input.increment number warehouses=1
° Change#input.sequence_of_number_of_warehouses=1 2 3 456 7 8to
input.sequence of number of warehouses=2
Note: Set the above parameter to be equal to the number of vCPUs you configured for Java
server VM.
e Change input.measurement seconds=240 t0 input .measurement seconds=10
11. In the C:\vSpecJBB2005 directory, right-click runit.bat, and change set JAVAOPTIONS=-Xms256m -
Xmx256mto set JAVAOPTIONS=-Xmsl000m -Xmx1000m -Xxthroughputcompaction -
XXallocprefetch -XXallocRedoPrefetch -XXcompressedRefs -XxlazyUnlocking -
XXtlasizel28k

©®NoO
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Installing and configuring the database server VM
1. Follow the steps in the earlier Cloning the base VMs section using the following VM specifications.
e Base VM: Base64
Name: DBServer1
Virtual processors: 2
Virtual memory: 1.5 GB
Virtual disk size: 10 GB
Virtual network: External Network (keep the default Windows Network DHCP settings)

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Installing Microsoft Internet Information Server

Select Start->Administrative Tools>Manage Your Server.

Select Add or remove a role.

At the preliminary steps screen, click Next.

At the Server Role screen, select Application Server, and click Next.

At the Summary of Selections screen, click Next.

When the installation software prompts you to do so, insert the OS CD, and click OK.
When the installation completes, click Finish.

Close the Manage Your Server window.

N>R~ LN =

Installing Microsoft SQL Server 2005

Insert the SQL Server 2005 CD into the controller, and connect with the Virtual CD ROM.
Click the Server Components link under the Install section to begin the installation.
Accept the license agreement, and click Next.

Click Next to install the prerequisites.

After the prerequisites complete installing screen, click Next.

arON=
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At the Welcome screen, click Next.

At the System Configuration Check, assuming everything has a status of success click Next.
Enter the registration information, and click Next.

At the Components to Install screen, select SQL Server Database Services, then click Advanced.

. Instruct the software to install both the Database Services and Client Components by clicking the drop-

down arrow on both and selecting Entire feature will be installed on local hard drive.

. Click Next to start the installation.

. For Instance Name, leave the default option, and click Next.

. At the Service Account screen, select Use the built-in system account (Local account), and click Next.
. Keep the default option for Authentication Mode, and click Next.

. For Collation Settings, leave the defaults, and click Next.

. Accept the default Error and Usage Report Settings, and click Next.

. At the Ready to Install screen, click Install to begin the installation.

. When the installation software prompts you to do so, insert Microsoft SQL Server 2005 disk 2. Use the

Virtual CDROM to connect it to the VM, and click OK.

. When the setup process completes, click Next.

. Click Finish to complete the initial installation.

. Install Service pack 2 by copying SQLServer2005SP2-KB921896-x64-ENU.exe to the virtual machine
. Double-click the executable to launch the installer.

. At the Welcome screen, click Next.

. At the License Terms screen, accept the license agreement.

. At the Feature Selection screen, click Next to accept all defaults.

. At the Authentication screen, click Next to accept all defaults.

. At the Error and Usage Reporting Settings screen, click Next to accept all defaults.

. At the Running Processes screen, click Next.

. Click install on the Ready To Install screen.

. Click OK, on the Computer Reboot Requires message box.

. Click Next at the Installation Complete Screen.

. At the Additional Information screen, deselect Launch the User Provisioning Tool for Windows Vista after

SP2 installation completes.

. Click Finish.

Creating the test database and generating data

1.

Select Start->Microsoft SQL Server 2005->SQL Server Management Studio.

2. In the Connect to Server window, use the drop-down menu next to Server name to select <Browse for
more>.

3. Inthe Browse for Server window, select the Network Servers tab, and wait for it to retrieve data.

4. When Database Engine appears, expand the menu, select DBSERVER1, and click OK.

5. Atthe Connect to Server window, the server name should be present.

6. Click Connect to connect to the server.

7. Right-click the Database folder in the left window, and select New Database from the pop-up menu.

8. Inthe Database name field, type sbtest, and click OK.

9. Copy the following files from the vConsolidate package to the VM C:\ directory:
e vSysbench.exe
e Daemon.exe
e killapp.exe

10. Open a command prompt by selecting Start->Run, type cmd, and click OK.

11. In the command prompt, type cd \ to change to C:\.

12. To prepare the database, type vsysbench.exe --test=oltp --oltp-table-size=100000
prepare, and press Enter.

13. When the command finishes, the C:\ prompt appears.

14. Type exit, and press Enter to close the command prompt.

15. In SQL Server 2005 Management Studio, stop the database service by right-clicking DBSERVERT1 in the
left window pane, and then select Stop from the drop-down menu.

16. Using Windows Explorer, create the folder C:\backup.
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17. With Windows Explorer, copy all sbtest files from C:\Program File\Microsoft SQL
Server\MSSQL.1\MSSQL\Data\ to c:\backup. (You should see two files: sbtest.mdf and sbtest_log.ldf.)

18. Close Windows Explorer once the copy completes.

19. Restart the database service using SQL Server 2005 Management Studio by right-clicking DBSERVER1
and selecting start.

Installing and configuring the idle server VM
1. Follow the steps in the earlier Cloning the base VMs section using the following VM specifications.
2. Use the VM Specifications below:
o Base VM: Base32
Name: IdleServer1
Virtual processors: 1
Virtual memory: 0.4 GB
Virtual disk size: 5 GB
Virtual network: External Network (keep the default Windows Network DHCP settings)

Installing and configuring the second CSU

To create the VMs the second CSU requires, we used VMware Converter to make a copy of the five VMs we had
already created. We then started each VM and entered a new IP address and Host name. The following steps
explain how to copy a VM with VMware Converter. They assume you have installed the VMware Converter on the
same machine as the VMware Virtual Infrastructure Client.

Open VMware Converter, and click Import Machine.

At the Welcome screen, click Next.

At the Source screen, click Next.

Select VMware ESX Server for the Source, and click Next.

Enter the IP address, user name, and password of the VMware ESX Server, and click Next.

Select the virtual machine that you want to copy (for example: JavaServer1), and click Next.

For the Source Data, leave the default (Import all disks and maintain size), and click Next.

At the Destination screen, keep the default, and click Next.

. For Destination Type, select VMware ESX server, and click Next.

0. Enter the IP address, user name, and password of the VMware ESX Server, and click Next.

1. Enter the virtual machine name (for example, if you are copying JavaServer1, the name of the second
one should be JavaServer2), and click Next.

12. Select the host system, and click Next.

13. Select the Datastore, and click Next.

14. Select the Network connection for the virtual machine, and click Next.

15. Leave the default Customization settings, and click Next.

16. Review the summary, and click Finish to begin copying the virtual machine.

TN N =

Client installation

In addition to setting up the server under test, we also had to set up the client systems we show in Figure 11. Both
the WebBench and LoadSim workloads require test clients.

Installing the WebBench 5.0 test client systems

To run WebBench, you need two types of test systems. WebBench clients use WebBench software engines to
send HTTP requests to stress the server under test. A single WebBench controller system manages the clients
during as the benchmark runs.

Installing a WebBench 5.0 client
1. Install Windows 2003 Enterprise Edition 32-bit. Use mailclient as the system name.
2. Install Windows Server 2003 Service Pack 2 with the default settings.
3. Open the Network Connections window by right-clicking My Network Places and selecting Properties from
the menu.
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Right-click the network connection, and click Properties.
Highlight TCP/IP, and select Properties.
Select Use the following IP address, and enter the following information: IP address 192.168.12.211,
Subnet 255.255.255.0.
Click OK to close the two Properties windows.
Insert the WebBench CD, and open it with Windows Explorer.
Run setup.exe from the location /wb50/client/setup.exe.
. Click Next through all screens, a process that accepts the defaults.
. When the installation completes, copy the WebBench shortcut icon from the open window to the system’s
desktop.
12. Close the open windows, and eject the CD.
13. With WordPad, open the file c:\Windows\system32\drivers\etc\hosts.
14. After the last text in that file, enter the following additional lines, and click Save.
e 192.168.12.210 controller
e 192.168.12.215 server
15. Close the hosts file and Windows Explorer.

ook~
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Installing the WebBench 5.0 controller

We used a single system as both the WebBench 5.0 controller and the vConsolidate controller. We discuss the
specifics of the vConsolidate controller in a later section. We performed the following steps to set up that system
as the WebBench 5.0 controller:

Install Windows 2003 Enterprise Edition 32-bit. Use mailclient as the system name.
Install Windows Server 2003 Service Pack 2 with the default settings.
Insert the WebBench 5.0 CD.
Run /wb50/controlr/setup.exe.
Click Next through the installation, which accepts all default options.
With Windows Explorer, open C:\WebBench\Controller\Clientids\client.cdb.
Add the client’s IP address to the top of the file. Enter Tab twice, and type the number 1.
Click File>Save, and close the client.cdb file.
Copy vConsolidate.tst file from the vVCON\WebBench directory to
C:\WebBench\controller\suites\WebBench.
. Copy ecommerce_cgi_template_w2k3.tst and ecommerce_cgi_template_w2k3.wl files from
vCON\WebBench directory to C:\WebBench\controller\suites\WebBench.
11. Copy all files from \vCON_framework\WebBench_daemon in the vConsolidate package to C:\.
12. Select Start->All Programs—->PC Magazine Benchmarks—->WebBench 5.0 Controller.
13. Click Create/Edit from the Suites drop-down menu.
14. Browse to the vConsolidate.tst file, and click Open.
15. Highlight the first Mix, and click Edit.
16. On the General tab, change Engines per client to 8.
17. Select the Workload tab.
18. Change the number of threads to 1.
19. Click Copy across.
20. Select the Engines per client and Number of threads check boxes, and click OK.
21. Click OK to close the suites windows.
22. Close the WebBench Controller window.
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Installing the mail test client
Each mail server VM requires one physical test client system. We performed the following steps to set up each
such system:

1. Install Windows 2003 Enterprise Edition 32-bit. Use mailclient as the system name.
2. Install Windows Server 2003 Service Pack 2 with the default settings.
3. Open the Network Connections window by right-clicking My Network Places and selecting Properties.
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7.

9

10.
11.
12.
13.
14.
15.
16.
17.
18.
19.
20.
21.

Right-click the network connection, and click Properties.

Highlight TCP/IP, and select Properties.

Select Use the following IP address, and enter the following information: IP address 192.168.11.110,
Subnet 255.255.255.0, Preferred DNS server 192.168.11.115 (MailServer1 IP address).

Click OK to close the two Properties windows.

Right-click My Computer, and select Properties.

Click the Computer Name tab.

Click Change.

Select Domain in the member of section, and type the domain vcon . com into the text box.

In the pop-up window, enter administrator for user name, password for password, and click OK.

At the Welcome to the domain screen, click OK.

When the warning that you must restart dialog appears, click OK.

Click OK to close the System Properties window.

Click Yes to the pop-up message to restart the computer.

Login to the domain by using administrator and password.

Install Microsoft Outlook 2003 with the default settings. (Outlook 2003 doesn’t require any configuration.)
Install LoadSim 2003 by double-clicking the loadsim.msi installation file. Accept all defaults.

Open LoadSim 2003, and make sure no error messages appear.

Copy c:\Program Files\LoadSim\Islog.exe file to a floppy disk or USB thumb drive. You will need this file
during the vConsolidate controller installation.

Configuring LoadSim 2003

OCOENO>ORA~LON =

14.
15.
16.
17.
. From the LoadSim menu bar, select Run->Create Topology, and wait until the Creating Users and

19.
20.

Start LoadSim by clicking Start Menu->All Programs->Exchange LoadSim->LoadSim 2003.
From the LoadSim menu bar, select Configuration->Topology Properties.

Click the Servers tab.

In the left pane, click the + next to the name of this server.

In the left pane, select the First Storage Group.

In the right pane, set the number of users to 500.

Select the Security and Credentials tab.

Leave the Credentials choice set to Login to users using the account LoadSim is running on.
In the password portion of the tab, enter the password Passwordi1, and click OK.

. From the LoadSim menu bar, select Configuration-> Test Properties, and click Add.
. Click Customize Tasks.

. Select the Initialization tab.

. Enter the following settings:

e Number of messages in Inbox: 150

Number of messages in Deleted items: 1

Number of new folders: 2

Messages per new folder: 100

Number of Smart Folders: 3

Number of Rules in Inbox: 5

Initialize Free/Busy Information: Leave it unselected
Number of appointments: 25

e Number of contacts: 64

Click OK.

In the Test Properties window, change the run time to 7 hours, and click OK.
From the LoadSim menu bar, choose File->Save As.

Save a backup copy of the simulation file as C:\loadsim.sim.

Creating DLs tasks complete.

From the LoadSim menu bar, select Run—>Initialize Test.

When a dialog box appears with the question Do you want to initialize Public Folders from this client
machine?, click Yes.
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21. The run is complete when the bottom left corner of the LoadSim window shows Status: Idle. This task
typically takes about 2 to 3 hours to complete.

22. From the LoadSim menu bar, select Run->Run Simulation.

23. The run is complete when the bottom left corner of the LoadSim window shows Status: Idle. This task
typically takes a little over 7 hours to complete.

24. Go to the main controller and open the console of the mail server VM.

25. Select Start>All Programs—>Microsoft Exchange—> System Manager.

26. In the left window pane, expand Servers, MailServer, and First Storage group so the Mailbox Store and
Public Store are visible.

27. Right-click Mailbox Store under First Storage Group, and select Properties.

28. Select the Database tab.

29. Click Customize next to Maintenance interval.

30. Add blue boxes so that the server performs maintenance for the next 8 hours, and click OK.

31. At the Mailbox Store Properties window, click Apply.

32. Click OK to close the Mailbox Store Properties window.

33. Right-click Public Store under First Storage Group, and select Properties.

34. Select the Database tab.

35. Click Customize next to Maintenance interval.

36. Add blue boxes so that the server performs maintenance for the next 8 hours, and click OK.

37. At the Public Store Properties window, click Apply.

38. Click OK to close the Public Store Properties window.

39. Allow the mail server to perform maintenance for 8 hours.

40. After maintenance is complete, disable maintenance again on the VM.

Back up the mail database

Once you’ve set up LoadSim and created its initial mail database, you need to back up that database so you can
have clean copies for each test. For testing we use NetApp Snapshot to create a copy of all VMs. This allows us
to replace the snapshot after each test run and return to the original state.

vConsolidate controller

You use a separate physical system, the controller, to manage the vConsolidate workload. We used a single
section both for this function and as the controller system for the first CSU’s WebBench benchmark. This
controller offers a graphical user interface (GUI) to start and stop the vConsolidate workload. After the workload
finishes, the controller copies the independent benchmark result files from all the VMs and combines their results
into a single file, results.txt. We performed the following steps to set up this vConsolidate controller:

1.  With Windows explore, create a C:\vCON directory.
2. Copy all files from the \vCON _ framework\controller directory of the vConsolidate package to c:\vCON.
3. Copy the Islog.exe file the mail client installation created to c:\vCON.

The vCON directory contains a Profiles sub-directory. The Profiles directory contains four sample profiles,
1CSU.profile, 2CSU.profile, 3CSU.profile, 4CSU.profile and a blank template, Profile.template. vConsolidate uses
these files to identify the number and name of the VMs a test should include. An example 1CSU.profile contains
the following:

<Profile>

<Name>1 CSU</Name>
<CSUNum>1</CSUNum>
<Servers>

<DB>

<0S>Win</0S>
<Host>DBServerl</Host>
</DB>

<Loadsim>
<Host>192.168.202.110</Host>
</Loadsim>

<Java>

Principled Technologies, Inc.: vConsolidate performance 23
on IBM and HP quad-core multiprocessor Intel processor-based servers



<0S>Win</0S>
<Host>JavaServerl</Host>
</Java>

<WebBench>
<Host>192.168.202.210</Host>
</WebBench>

</Servers>

</Profile>

Running vConsolidate

To run vConsolidate and get consistent results, you must first prepare the VMs with clean copies of the test data.
We outline below the process for getting ready to run the workload. We then explain how to start and stop the
workload. Finally, we detail how to find its results.

Preparing the vConsolidate run
Prior to running vConsolidate we restore the NetApp Snapshot with the Network Appliance NetApp FAS960 filer,
SO we can ensure consistent results.

Verify connectivity and setting profiles
1. Open a command prompt by selecting Start->Run, type cmd, and click OK.
2. Type the following commands at command prompt:

net use \\loadsim client IP Address\c$

net use \\JavaServerl\c$

net use \\DBServerl\c$

net use \\WebBench Controller IP Address\c$

3. Verify that the vConsolidate controller can read and write remote files to all VMs with the following

commands:

e With Windows Explorer, create an empty file, dummy.txt.

e copy dummy.txt \\loadsim client IP Address\c$
e copy dummy.txt \\JavaServerl\c$

e copy dummy.txt \\DBServerl\c$

copy dummy.txt \\WebBench Controller IP Address\c$

4. Modify the profile file by entering the VM name or IP address appropriate to each VM in the test. For the
one-CSU test, enter four server names or IP addresses; for the two-CSU test, enter eight.

Startlng and stopping vConsolidate

SorwN

Shut down all VMs by selecting Start->Shutdown and then selecting Shutdown from the window.

In the left pane of the Virtual Infrastructure Client window, highlight localhost.localdomain.

Select the Summary tab in the right pane.

Click Reboot under the Commands section.

While the server is rebooting, reboot all clients in the test bed.

After the VMware ESX Server has rebooted, login using the Virtual Infrastructure Client, and start all VMs

in the test.

® N

Once the VMs are up, log the LoadSim client(s) into the appropriate domain(s).
Double-click Daemon.exe manually on the following VMs and systems:

a. DataServer1

b. JavaServer1

c. LoadSim client

d. WebBench controller

9. Start the WebBench Controller application on the WebBench controller system by selecting Start->All
Programs—->PC Magazine Benchmarks.

10. In the WebBench Controller application, choose the Clients menu, and click Start Log In.

11. Double-click the WebBench 5.0 client shortcut on all the WebBench test client desktops.

12. Once all the client machines are logged into WebBench, click OK.

13. At the Would you like to add a test suite? dialog, click Yes.
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14. In the Select a test suite window, choose vConsolidate.tst, and click OK.

15. When the Would you like to start executing the test suites? window appears, do NOT click Yes or No. The
vConsolidate controller application will handle that task that at the start of the test.

16. Double-click c:\vCON\vconsolidate.exe.

17. Select the profile name you want to run.

18. Wait 10 minutes to allow all virtual machines and VMware ESX Server to load all processes and become
completely idle.

19. Click start.

20. The vConsolidate controller software will immediately start the LoadSim application. LoadSim will take
about 60 to 80 seconds to log 500 users onto the Exchange Server. The remaining benchmarks will start
once all the LoadSim users have logged in.

21. After about 30 minutes, as soon as you see the WebBench workload(s) complete, click Stop!.

22. The vConsolidate controller application will stop all the other benchmarks and collect their results.

Locating and interpreting the results file
vConsolidate places all result data in the following location:

c:\vCON\vCONMM-dd-hh-mm

where MM is the month, dd is the day, hh is the hour, and mm is the minute of the test. The file result.txt in that
directory summarizes all the results. It contains the following information:

Java transaction score
Database transaction score
Mail transaction score

Web server throughput
Start and stop times

Figure 9 shows an example results.txt file for a test with one CSU. We have labeled each score with a brief
description. See the Test results section for more information on how we used these individual results to calculate
each server’s overall score on the workload.

B result.txt [ZI EI g|

File Edit Format Wiew Help

ul
JET sum—32354673 1 Java Score
DB Trans Number=231093— Database Score

’—LuadSim Score
—————————— TEMP. TXT
weighted avg 60 14015 122 215 132 68 <--"score"

—————————— VCONSOLIDATE. RLG

A,4_client, 8,]1706. 959, 6908069, 563, 0,
A,4_client, 8,/1622.183, 6576748, 875, 0,
A,d4_client, 8,[1558. 335, 6241389. 500, 0,

11:44:39.921

12:15:44,140 VWebBench Score

Figure 9: Example of vConsolidate results file.

Power measurement procedure

To record each system’s power consumption during testing, we used an Extech Instruments (www.extech.com)
380803 Power Analyzer/Datalogger. We connected the power cord from the system’s power supply to the Power
Analyzer’s output load power outlet. We then plugged the power cord from the Power Analyzer’s input voltage
connection into a power outlet. We used this setup for each power supply in the server.

Even though each server had a different number of power supplies, we used two Extech Power Analyzers for the
servers by connecting two power supplies per Extech Power Analyzer on the HP server and one power supply
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per Extech Power Analyzer on the IBM server. We connected all Extech Power Analyzers to one monitoring
system to record the power draw of the systems.

We used the Power Analyzer’'s Data Acquisition Software (version 2.11) to capture all recordings. We installed the
software on a separate PC, to which we connected all Power Analyzers via a separated RS-232 cable for each
Extech. We captured power consumption at 1-second intervals.

To gauge the idle power usage, we recorded the power usage for 2 minutes while each server was running the
operating system but otherwise idle.

To compute the total power, we took the wattage sum from both of the meters. We averaged the power usage
during the period the server was running the benchmark. We call this time the power measurement interval. See
Figure 2 for the results of these measurements.
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Appendix A — Test system configuration information

This appendix provides detailed configuration information about each of the test server systems, which we list in

alphabetical order by processor name.

Enabled

Servers HP ProLiant DL580 G5 IBM x3850 M2
General

Number of processor packages 4

Number of cores per processor

package

Number of hardware threads per core | 1 1

CPU

Vendor Intel Intel

Name Xeon X7350 Xeon X7350

Stepping

Socket type FC-mPGAG6 FC-mPGAG6

Core frequency (GHz) 2.93 GHz 2.93 GHz

Front-side bus frequency (MHz) 1,066 MHz 1,066 MHz

L1 cache 32 KB + 32 KB 32 KB + 32 KB

L2 cache 8 MB 8 MB

Platform

Vendor and model number HP ProLiant DL580 (G5) IBM x3850 M2 (7141-4RZ)
Motherboard model number P69200DXQVG1SI 001A64390238
Motherboard chipset Intel 7300 IBM Enterprise X-Architecture v4
Motherboard revision number 013059-001 GAQOW3X5M9Y

BIOS name and version HP P61 12/07/2007 IBM v 1.02 11/12/07
BIOS settings Intel Virtualization Technology Default

Memory module(s)

Vendor and model number

Samsung M395T5750EZ4-CE65

Samsung M393T5660AZA-CE6

Type

PC2-5300 FBDIMM

PC2-5300 DDR2

Speed (MHz) 667 667
Speed in the system currently running

@ (MHz) 667 667
Timing/Latency (tCL-tRCD-iRP-

{RASMIN) 5-5-5-15 5-5-5-15
Size 2 GB 2GB
Number of RAM modules 12 32

Chip organization Double-sided Double-sided
Channel Dual Dual
Additional memory module(s)

Vendor and model number g/léc;ggEl\gTSGHTF%G?ZFY- N/A
Type PC2-5300 FBDIMM N/A
Speed (MHz) 667 N/A
Speed in the system currently running

@ (MHz) 667 N/A
Timing/Latency (tCL-tRCD-iRP-

tRASMIn) 5-5-5-15 N/A
Size 2GB N/A
Number of RAM modules 20 N/A
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Servers HP ProLiant DL580 G5 IBM x3850 M2
Chip organization Double-sided N/A
Channel Dual N/A

Operating system (Windows VMs)

Microsoft Windows Server 2003

Microsoft Windows Server 2003

Name R2, Enterprise Edition R2, Enterprise Edition

Build number 3790 3790

Service Pack SP2 SP2

File system NTFS NTFS

Kernel ACPI Multiprocessor-based PC ACPI Multiprocessor-based PC
Language English English

Microsoft DirectX version 9.0c 9.0c

Operating system (VMware)

Name

VMware ESX Server 3.5.0

VMware ESX Server 3.5.0

Build number

64607

64607

ext3 (server)

ext3 (server)

File system Vmfs3 (virtual machines) Vmfs3 (virtual machines)
Kernel 2.4.21-47.0.1.ELvmnix 2.4.21-47.0.1.EL
Language English English

Graphics

Vendor and model number ATI ES1000 ATI ES1000

Chipset ATI ES1000 ATI ES1000

Type Integrated Integrated

Memory size 32 MB 16 MB

Resolution 800 x 600 800 x 600

Network card/subsystem

Vendor and model number

HP NC373i Multifunction Gigabit
Network Adapter

Broadcom NetXtreme |l Ethernet
Adapter

Type

Integrated

Integrated

Additional cards

3 x Intel PRO/1000 PT Dual-Port
Server Adapter

3 x Intel PRO/1000 PT Dual-Port
Server Adapter

Type PCI Express PCI Express
Optical drive

Vendor and model number DVD/CD Drive DVD/CD Drive
Type Integrated Integrated
Interface IDE IDE

USB ports

Number of ports 4 5

Type of ports (USB 1.1, USB 2.0) USB 2.0 USB 2.0
Power supplies

Total number 4 2

Wattage of each 1,412 1,664
Cooling fans

Dimensions 120mm 120mm
Voltage 12V 12V

Amps 3.24 A 1.5A
Number 6 2

Additional fan dimensions N/A 80mm
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Servers HP ProLiant DL580 G5 IBM x3850 M2

Voltage N/A 12V
Amps N/A 3.24 A
Number N/A 2
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EMPLOYEES AND ITS SUBCONTRACTORS SHALL HAVE NO LIABILITY WHATSOEVER FROM ANY CLAIM OF LOSS OR DAMAGE
ON ACCOUNT OF ANY ALLEGED ERROR OR DEFECT IN ANY TESTING PROCEDURE OR RESULT.

IN NO EVENT SHALL PRINCIPLED TECHNOLOGIES, INC. BE LIABLE FOR INDIRECT, SPECIAL, INCIDENTAL, OR
CONSEQUENTIAL DAMAGES IN CONNECTION WITH ITS TESTING, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

Principled Technologies, Inc.: vConsolidate performance 29
on IBM and HP quad-core multiprocessor Intel processor-based servers



