BETTER EMAIL RESPONSE TIME USING MICROSOFT EXCHANGE 2013 WITH
THE DELL POWEREDGE R730XD

GET YOUR EMAIL FASTER WITH
THE DELL POWEREDGE" R730XD’

B BN
31.7"BETTER
RESPONSE TIME

POWERED BY THE INTEL® XEON® PROCESSOR E5-2600 v3 FAMILY

*versus a Supermicro’ server

Email is a vital part of your organization’s unified communications and
collaboration (UC&C) platform, which includes email, IM, and voice applications. When
selecting hardware for your Microsoft Exchange Server 2013 solution, you need to
select the server that responds quicker to user requests, because shorter wait times
make for a better user experience.

In the Principled Technologies datacenter, we tested the Microsoft Exchange
2013 performance of the Dell PowerEdge R730xd powered by the Intel Xeon processor
E5-2600 v3 family against a Supermicro server in a similar configuration. Due to its
design, the Dell PowerEdge R730xd had four more 3.5” hard-disk drives (HDDs) than did
the Supermicro server. Because the Dell PowerEdge R730xd offers more drive bays, you
have the potential to add storage capacity to your application. When handling Exchange
Server 2013 requests, we found the Dell PowerEdge R730xd delivered 31.7 percent
better response times than the similarly configured Supermicro server did. The benefits
of a better response time are obvious: if your email works faster, user productivity and

overall experience improves, making your UC&C solution a greater success.

‘ AUGUST 2015

»
‘ I A PRINCIPLED TECHNOLOGIES REPORT

Commissioned by Dell Inc.


http://www.principledtechnologies.com/

FASTER EMAIL HELPS USERS AND YOUR BUSINESS

WHAT WE FOUND
About the results

Slow email can hurt user productivity and user experience. As your employee
numbers swell, the negative effects of slow email can affect efficiency. Giving users a
responsive email experience should be a top priority, and to do so you must choose
hardware that can deliver fast response times.

Powered by the Intel Xeon processor E5-2600 v3 family, the Dell PowerEdge
R730xd is a high capacity, storage-dense server with six storage configuration options.
Our particular configuration of the R730xd had twelve front-load 3.5” disks for data,
four internal 3.5” disks for data, and two 2.5” disks in the back for operating system
files. While the Dell offers the extra four disks by way of a special internal drive carrier,
the Supermicro by design offered only the twelve front-load 3.5” disks for data. In our
tested configuration, therefore, the Dell had a greater available disk capacity and disk
count than the Supermicro server.

Both disk count and disk capacity can affect your application’s performance and
design. In this case, having more disks may have contributed to the better response
time of the Dell server. In addition, having more disks of the same capacity increased
the gigabytes available for use by the application.

For more information about the PowerEdge R730xd and our other test
components, see Appendix A. For detailed system configuration, see Appendix B. For
step-by-step testing details, see Appendix C.

We tested both the Dell PowerEdge R730xd and the current-generation
Supermicro server with 4,800 users running the Outlook_450 user profile and 250MB
mailbox size. Our test lasted for two hours and had 20-minute step ups of 1,200 users
each. Over the duration of the test window, the Supermicro server delivered a response
time of 14.75 milliseconds (ms). In contrast, the Dell PowerEdge R730xd provided a
response time of 10.07 ms (see Figure 1), 31.7 percent better. We used Windows
Performance Monitor to record the I/O Database Reads (Attached) Average Latency
Exchange counter during the run. We chose this counter as it indicates the read
response time of the underlying disk system, which directly effects application response
times. We did not include the writes latency counter as the database writes are
asynchronous, and thus it is not a clear indicator of client latency.

When you consider how many emails your users receive every day, that time

difference can add up. Better response time, also referred to as latency, speeds up the
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email process every time your users sends or receives an email, delivering time savings

that contribute to a more positive user experience.

Average 1/O read response time
(Smaller is better)

Figure 1: The Dell PowerEdge Dell 10.07
R730xd delivered a 31.7
percent better response time
than the Supermicro server
did.
Supermicro 14.75

Time (milliseconds)

CONCLUSION

In a market where servers can seem the same at a glance, look for the
differences. Your email infrastructure choices will directly affect end-user experience for
your UC&C applications. Equipped with more drives in its extra drive slots, the Dell
PowerEdge R730xd delivered 31.7 percent better Exchange 2013 response times than a
similarly configured, current-generation Supermicro server did. With better Microsoft
Exchange Server 2013 response times, the PowerEdge R730xd can help deliver an

improved experience for users in your organization.
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APPENDIX A - ABOUT THE COMPONENTS
About the Dell PowerEdge R730xd

Dell designed the two-socket, 2U Dell PowerEdge R730xd rack server to provide the scale-out storage efficiency
needed by big data users, including the option for hybrid internal storage tiering and six distinct storage configurations.
The configuration we tested had 12 3.5" front HDD bays and four 3.5"” internal HDD bays. Powered by the latest Intel®
Xeon® processors E5-2690 v3, the PowerEdge R730xd has 24 DIMM slots to support up to 1.5 TB of memory, and
supports up to four optional NVMe Express™ Flash PCle® SSDs.

With redundant power supply units, hot-swappable hardware, and Dual SDTM card for Failsafe Hypervisors, the
Dell PowerEdge R730xd supports hardware high availability. The PowerEdge R730xd comes standard with iDRAC8 with
Lifecycle Controller and Dell OpenManage™, which all work to streamline management. For more details on the Dell
PowerEdge R730xd, visit www.dell.com/us/business/p/poweredge-r730xd/pd.

About the Intel Xeon processor E5-2600 v3 product family
According to Intel, the Intel Xeon processor E5-2600 v3 product family “helps IT address the growing demands
placed on infrastructure, from supporting business growth to enabling new services faster, delivering new applications in
the enterprise, technical computing, communications, storage, and cloud.” It also delivers benefits in performance,
power efficiency, virtualization, and security. The E5-2600 v3 product family has up to 50 percent more cores and cache
than processors from the previous generation.
Other features include the following:
e Intel Advanced Vector Extensions 2 (AVX2)
o Intel Quick Path Interconnect link
e Upto 18 cores and 36 threads per socket
e Up to 45MB of last level cache
e Next-generation DDR4 memory support
e Intel Integrated I/O providing up to 80 PCle® lanes per two-socket server
e Intel AES-NI data encryption/decryption
The Intel Xeon processor E5-2600 v3 product family also uses Intel Intelligent Power technology and per-core P
states to maximize energy efficiency. Learn more at http://www.intel.com/content/www/us/en/processors/xeon/xeon-
e5-brief.html

About Microsoft Load Generator 2013
To test the solutions’” mail server performance, we used the Microsoft® Load Generator 2013 (LoadGen)
benchmark, performing tasks to simulate a heavy user generating mail activity. For our workloads, we used the following
settings:
e Number of users: 4,800
e Mailbox Profile: 250MB mailboxes
e Action Profile: Outlook_450

For more details about LoadGen, see http://www.microsoft.com/en-us/download/details.aspx?id=40726
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APPENDIX B — SYSTEM CONFIGURATION INFORMATION

Figure 2 provides detailed configuration information for the test systems.

System

Dell PowerEdge R730xd

Supermicro 6028R-E1CR12N

Power supplies

Total number 2 2

Vendor and model number Dell L1100E-S1 SuperMicro PWS-920P-SQ
Wattage of each (W) 1,100 920
Cooling fans

Total number 6 3

Vendor and model number San Ace 60 9GA0612P1J651 Nidec UltraFlo VBOE12BHA5-57
Dimensions (h x w) of each 2.5'x2.25' 3.5x15
Volts 12 12

Amps 1.2 0.6
General

Number of processor packages 2 2

Number of cores per processor 10 10

Number of hardware threads per ) 5

core

System power management policy Performance per Watt (OS) Default
CPU

Vendor Intel Intel

Name Xeon Xeon
Model number E5-2660 v3 E5-2660 v3
Stepping M1 M1

Socket type LGA2011-3 LGA2011-3
Core frequency (GHz) 2.6 2.6

Bus frequency 5 GT/s DM 5 GT/s DM
L1 cache 10 x 32 KB 10 x 32 KB
L2 cache 10 x 256 KB 10 x 256 KB
L3 cache 25 MB 25 MB
Platform

Vendor and model number

Dell PowerEdge R730xd

Supermicro 6028R-E1CR12N

Motherboard model number

0H21J3

SuperMicro X10DRI-T4

BIOS name and version Dell 1.2.10 American Megatrends Inc. 2.17.1245
BIOS settings Default Default

Memory module(s)

Total RAM in system (GB) 128 128

Vendor and model number

Hynix HMA42GR7MFR4N-TF

Micron MTA36ASF2G72PZ-2G1A2K]

Type

PC4-2133P

PC4-2133P

tRASmMIn)

Speed (MHz) 2,133 2,133
Speed running in the system (MHz) 2,133 2,133
Timing/Latency (tCL-tRCD-tRP- 15-15-15-32 15-15-15-32

Better email response time using Microsoft Exchange 2013 with the

Dell PowerEdge R730xd

A Principled Technologies report 5



System Dell PowerEdge R730xd Supermicro 6028R-E1CR12N
Size (GB) 16 16

Number of RAM module(s) 8 8

Chip organization Double-sided Double-sided

Rank Dual Dual

Operating system

Name Windows Server 2012 R2 Datacenter | Windows Server 2012 R2 Datacenter
Build number 9600 9600

File system NTFS NTFS

Language English English

RAID controller #1

Vendor and model number

Dell PERC H730p mini

LSI MegaRAID 3108

Firmware version 25.2.2-004 24.6.0-0023

Driver version 6.602.12.0 (11/03/2014) 12.0.1.1019 (08/09/2013)

Cache size (GB) 2 1

RAID controller #2

Vendor and model number N/A Intel C600 Series Chipset SATA RAID
Adapter

Driver version N/A 12.0.1.1019 (08/09/2013)

Hard disk #1

Vendor and model number

Dell Z4D15M6Q

Seagate ST6000NMO0054

Number of drives 16 12

Size (TB) 6 6

Type SAS SAS

Hard disk #2

Vendor and model number Dell ST91000640NS Dell OWF12F
Number of drives 2 2

Size (TB) 1 1

RPM 7.2k 7.2k

Type SATA SATA
Ethernet adapters #1

Vendor and model number

Intel Ethernet 10G 4P X540/1350

Intel Ethernet 10G 4P X540-AT2

Type

Integrated

Integrated

Driver

3.9.58.9101 (7/17/2014)

3.4.47.2 (06/21/2013)

Figure 2: Detailed system configuration.
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APPENDIX C—- HOW WE TESTED

We installed Windows Server 2012 R2 on both servers and added the Hyper-V role. We configured both servers

with up-to-date drivers, firmware, and Windows updates.

Installing Microsoft Windows Server 2012 R2
1. Insert the installation media into the CD/DVD drive, and restart the server.
Press any key when prompted to boot from DVD.
When the installation screen appears, click My language is English (United States).
Leave language, time/currency format, and input method as default, and click Next.
Click Install now.
When the installation prompts you, enter the product key.
Select Windows Server 2012 R2 Datacenter (Server with a GUI), and click Next.

Check | accept the license terms, and click Next.

L N uv ok WwN

Click Custom: Install Windows only (advanced).
10. Select Drive 0 Unallocated Space, and click Next.
11. When the Settings page appears, fill in the Password and Reenter Password fields with the same password.

12. Log in with the password you set up previously.

Configuring Windows Update
1. Inthe left pane of the Server Manager window, click Local Server.
In the main frame, next to Windows Update, click Not configured.
In the Windows Update window, in the main pane, click Let me choose my settings.
Under Important updates, select Never check for updates (not recommended), and click OK.

In the left pane, click Check for updates, and install all available updates.

o v e wN

Close the Windows Update window.

Installing Hyper-V
1. Open Server Manager, and click Manage—>Add Roles and Features.
At the Before You Begin screen, click Next.
At the Installation Type screen, click Next.
At the Server Selection screen, select one of the servers in the failover cluster.
At the Server Roles screen, check Hyper-V. At the prerequisite pop-up, click Add Features. Click Next.
At the Features screen, click Next.
At the Hyper-V screen, click Next.

At the Virtual Switches screen, click Next.

L 0 Nk WwWwN

At the Migration screen, click Next.
10. At the Default Stores screen, enter the iSCSI storage location. Click Next.

11. At the Confirmation screen, check to automatically restart the server after installation, and click Install.
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Creating the base VM
1. Click Start, type Hyper-V Manager, and press Enter.
In the right pane, click Virtual Machines=>New Virtual Machine.
Select a node on which to install the VM, and click OK.
At the Before You Begin screen, click Next.
At the Specify Name and Location screen, give the VM a name, and click Next.
At the Assign Memory screen, type 8 GB, and click Next.
At the Configure Networking screen, use the drop-down menu to select the virtual switch, and click Next.

At the Connect Virtual Hard Disk screen, create a new disk, enter 50 GB, and click Next.

LW Nk WN

At the Summary screen, click Finish.

Installing the VM operating system on the first VM
1. From the VM console, connect to the ISO image of the installation DVD for Windows Server 2012 R2 Datacenter.
If the ISO image is not stored on the host, start the VM, and connect to the ISO image.
Start the VM.
At the Language Selection Screen, click Next.
Click Install Now.
Select a full installation of the Datacenter edition, and click Next.
Click | accept the license terms, and click Next.
Click Custom.
Click Next.

At the User’s password must be changed before logging on warning screen, click OK.

L N o Uk WN

=
o

. Enter the desired password for the administrator in both fields, and click the arrow to continue.

[y
[any

. At the Your password has been changed screen, click OK.

=
N

. Install the latest Host Integration Tools package on the VM. Restart as necessary.

=
w

. Connect the machine to the Internet, and install all available Windows updates. Restart as necessary.

=
o

. Enable remote desktop access.

=
ui

. Change the hostname, and reboot when prompted.

[EEN
[e)]

. Create a shared folder to store test script files. Set permissions as needed.

=
~N

. Set up networking:
a. Click Start=>Control Panel, right-click Network Connections, and choose Open.
b. Right-click the VM traffic NIC, and choose Properties.
c. Select TCP/IP (v4), and choose Properties.
d. Assign the VM a static IP address.

Configuring the Active Directory server

Installing the Active Directory Domain Services role

Before completing this step, you will need to apply a static IP address for the server. In our case, we used
192.168.1.10.
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Launch Server Manager, and select Add roles and features.
Click Next at the Add Roles and Features Wizard.

Select Role-based or feature-based installation, and click Next.
Select the AD server from the server pool, and click Next.

vk w N

Select Active Directory Domain Services from the list of Roles, click the Add Features button to add features that

are required by Active Directory Domain Services, and click Next.

6. Accept the defaults selected by setup at the Select Features screen, and click Next.

7. Click Next at the AD DS screen.

8. Select Restart the destination server automatically if required at the confirmation screen, and click Install.

9. Click the yellow warning triangle in the server manager window.

10. Click Promote this server to a domain controller.

11. Select Add a new forest, type in the Root domain name (fqdn), and click Next. For our testing, we used
test.local

12. Type in and confirm the password, and click Next.

13. Click Next at the DNS Options screen.

14. Verify the NetBIOS name, and click Next.

15. Accept the default paths, and click Next.

16. Review the options, and click Next.

17. Verify the prerequisite check passes successfully, and click Install.

Preparing AD for Exchange

1. Create areverse lookup zone:
a. Click the start button, and type DNS in the search field.
Open the DNS manager by clicking on it in the results field.
Expand your Active Directory domain, and click on Reverse Lookup Zones.
Click Action>New Zone.
Click Next on the Welcome screen.
Chose Primary Zone, and click Next.
Leave default replication scope, and click Next.
Choose IPv4, and click Next.
Enter the IP address of your domain (192 .168. 1 for our example).

S®m =~ a0 T

j. Choose Allow both nonsecure and secure dynamic updates, and click Next.
k. Click Finish.

Insert the Exchange 2012 R2 Installation ISO in the AD VM DVD drive.
In Windows Explorer, double-click the Exchange DVD icon.

In the Exchange installation folder, hold down shift, and right-click.
Choose Open a command window here.

Run the following command:

No vk wnN

Setup.exe /PrepareSchema /IAcceptExchangeServerLicenseTerms
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10.

When the previous command completes, run the following command:

Setup.exe /PrepareAD /OrganizationName:”organization name”
/IAcceptExchangeServerLicenseTerms
Close the command window when the setup finishes.

Installing Active Directory Certificate Services

1.

W o Nk WN
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16.
17.
18.
19.
20.
21.
22.
23.
24,
25.
26.
27.

Launch Server Manager, and select Add roles and features.

Click Next at the Add Roles and Features Wizard.

Select Role-based or feature-based installation, and click Next.

Choose Active Directory Certificate Services.

Click Add Features, if prompted, to install any required features.

Click Next.

Click Next.

Click Next.

Choose Certificate Authority and Certification Authority Web Enrollment.

. Click Add Features, if prompted, to install any required features.

. Click Next.

. Leave defaults, and click Next.

. Click Install.

. Click Close when the install finishes.

. Click on the yellow warning symbol in the Server Manager, and click Configure Active Directory Certificate

Services.

Leave defaults, and click Next.

Check both Certification Authority and Certification Authority Web Enrollment, and click Next.
Choose Enterprise CA, and click Next.

Choose Root CA, and click Next.

Choose Create a new private key, and click Next.
Leave defaults, and click Next.

Leave defaults, and click Next.

Leave 5 years, and click Next.

Leave default locations, and click Next.

Click Configure.

Close when the configuration finishes.

Open Internet Explorer® and navigate to localhost/certsrv/Default.asp to verify that the installation succeeded.

Installing Exchange Server 2013 SP1 Mailbox and Client Access Server roles

Using the template, clone two VMs: one for the Exchange Client Access Server, or CAS, and the other for the

Exchange Mailbox Server. Edit the hardware settings in each. The Mailbox server should have 16 vCPUs (16 virtual
sockets each with one core) and 64 GB of memory. Using the Exchange datastore, add a 2,048 GB disk and a 20 GB disk
to the Mailbox server for the Exchange mailbox and Exchange logs respectively. Set static IPs on both VMs and join the

domain.
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1. Onthe Exchange Mailbox Server, log into the server using domain administrator credentials.
2. Open Windows PowerShell® and run the following command:

Install-WindowsFeature AS-HTTP-Activation, Desktop-Experience, NET-
Framework-45-Features, RPC-over-HTTP-proxy, RSAT-Clustering, RSAT-
Clustering-CmdInterface, RSAT-Clustering-Mgmt, RSAT-Clustering-
PowerShell, Web-Mgmt-Console, WAS-Process-Model, Web-Asp-Netd5, Web-
Basic-Auth, Web-Client-Auth, Web-Digest-Auth, Web-Dir-Browsing, Web-Dyn-
Compression, Web-Http-Errors, Web-Http-Logging, Web-Http-Redirect, Web-
Http-Tracing, Web-ISAPI-Ext, Web-ISAPI-Filter, Web-Lgcy-Mgmt-Console,
Web-Metabase, Web-Mgmt-Console, Web-Mgmt-Service, Web-Net-Ext45, Web-
Request-Monitor, Web-Server, Web-Stat-Compression, Web-Static-Content,
Web-Windows-Auth, Web-WMI, Windows-Identity-Foundation

3. Restart the server.

Download the Microsoft Unified Communications Managed API 4.0, Core Runtime 64-bit
(go.microsoft.com/fwlink/p/?linkld=258269).
Run UcmaRuntimeSetup.exe.

When the installation completes, click Finish.
Navigate to the location of the Exchange installation media, and double-click Setup.exe.

O N o wu

At the Check for Updates? screen, check the Connect to the Internet and check for updates checkbox, and click
Next.

9. When the updates complete, click Next.

10. At the Introduction screen, click Next.

11. At the License Agreement screen, check the box to accept the terms, and click Next.

12. At the Recommended Settings screen, check the Don’t use recommended settings checkbox, and click Next.
13. At the Server Role Selection, select Mailbox or Client Access role, and click Next.

14. At the Installation Space and Location screen, leave the default location for the installation, and click Next.
15. At the Malware Protection Settings, select Yes to disable, and click Next.

16. At the Readiness Checks screen, allow the verification to complete. If there are no failures, click Install.

17. When the installation completes, click Finish, and restart the server.

18. Repeat steps 1-17 for the Exchange CAS server.

Configuring Exchange
1. On the CAS server, open the Exchange Admin Center by using a browser and navigating to
https://localhost/ecp
Enter the domain administrator credentials, and click Sign in.
If prompted, select the language and time zone, and click Save.
In the left pane, click Mail Flow, and then click Send Connectors.
On the Send Connectors page, click the New icon.
In the New Send Connector wizard, specify SMTP as the name and select Internet as the type. Click Next.

In the Network settings screen, choose MX record associated with recipient domain, and click Next.

© N o Uk WwWN

In the Address space screen, click the Add icon.
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9.

10
11
12
13

In the Add domain window, enter * in the Fully Qualified Domain Name (FQDN) field, and click Save.
. Click Next.
. In the Source Server screen, click the Add icon.
. In the Select a Server window, select the mailbox server, click Add, and click OK.
. Click Finish.

14. In the left pane of the EAC, click servers, select the name of the CAS server, and click Edit.

15

16
17

. Click Outlook Anywhere, and enter the appropriate FQDN of the Client Access Server for the external and
internal hostname field. For example, exchangeserver.test.local
. Choose NTLM as the authentication method, and click Save.

. Click Virtual Directories, and then click the Configure external access domain icon.

18. In the Select the Client Access servers to use with the external URL window, click the Add icon.
19. Select the CAS server, and click Add. Click OK.
20. Type the FQDN of the CAS server in the Enter the domain, and click Save.

21

. Log into the Active Directory server using administrator credentials, and complete the following steps:

a. Open Server Manager, then click Tools=>DNS.

b. In DNS Manager, expand the Active Directory server name—>Forward Lookup Zones—>test.local in
the left pane.

c. Inthe right pane, verify or create the DNS records as presented in Figure 3.

Host or child FQDN of mail

Type domain/alias name AoplE server
Mail Exchanger (MX) | Leave blank domain.com casserver.domain.com
Alias (CNAME) Autodiscover Autodiscover.domain.com | casserver.domain.com
Alias (CNAME) Owa Owa.domain.com casserver.domain.com

Figure 3: DNS records.

22. Log back into your CAS server.

23. In the Exchange PowerShell, run the following commands, replacing SHostName with the host name (not FQDN)

of your CAS server:

Set-EcpVirtualDirectory "S$HostName\ECP (Default Web Site)" -InternalUrl
((Get-EcpVirtualDirectory "S$HostName\ECP (Default Web
Site)") .ExternalUrl)

Set-WebServicesVirtualDirectory "S$HostName\EWS (Default Web Site)" -
InternalUrl ((get-WebServicesVirtualDirectory "S$HostName\EWS (Default Web
Site)") .ExternalUrl)

Set-ActiveSyncVirtualDirectory "S$HostName\Microsoft-Server-ActiveSync
(Default Web Site)" -InternalUrl ((Get-ActiveSyncVirtualDirectory
"SHostName\Microsoft-Server-ActiveSync (Default Web Site)") .ExternalUrl)

Set-OabVirtualDirectory "S$SHostName\OAB (Default Web Site)" -InternalUrl
((Get-OabVirtualDirectory "S$HostName\OAB (Default Web
Site)") .ExternalUrl)
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Set-OwaVirtualDirectory "S$SHostName\OWA (Default Web Site)" -InternalUrl
((Get-OwaVirtualDirectory "S$HostName\OWA (Default Web
Site)") .ExternalUrl)

Set-PowerShellVirtualDirectory "SHostName\PowerShell (Default Web Site)"
-InternalUrl ((Get-PowerShellVirtualDirectory "S$SHostName\PowerShell
(Default Web Site)") .ExternalUrl)

Get-OfflineAddressBook | Set-OfflineAddressBook -
GlobalWebDistributionEnabled $True -VirtualDirectories $Null

Get-OutlookAnywhere | Set-OutlookAnywhere -ExternalHostname mail.ives.lan
-InternalHostname mail.ives.lan -ExternalClientsRequireSsl S$true -
InternalClientsRequireSsl $true -DefaultAuthenticationMethod NTLM

24. Create a folder at the root of C: on the CAS server, and share it to Everyone with read/write permissions.

25. Log back into the Exchange admin center, and navigate to Servers—>certificates.

26. Choose the CAS server in the drop-down menu, and click the plus sign to create a new certificate.

27. Choose Create a request for a certificate from a certification authority, and click Next.

28. Name the certificate, and click Next.

29. Do not request a wildcard certificate, and click Next.

30. Click Browse, choose the CAS server, and click OK. Click Next.

31. Leave defaults, and click Next.

32. Leave defaults, and click Next.

33. Enter your organization information, and click Next.

34. Enter the path to the share you created on the CAS server, and click Finish. Example:
\\cas\share\myrequest.REQ

35. Log into the AD server, and open Internet Explorer.

36. Browse to localhost/CertSrv

37. Click Request a certificate.

38. Choose advanced certificate request.

39. Choose Submit a certificate request by using a base-64-endcoded CMC...

40. Open Windows Explorer and navigate to the share folder on the CAS server where the certificate request is
stored.

41. Open the certificate with Notepad and copy the content between BEGIN NEW CERTIFICATE REQUEST and END
NEW CERTIFICATE REQUEST.

42. Paste the copied content into the Saved Request window.

43. Choose Web Server in the Certificate Template drop-down menu, and click Submit.

44, Choose Base 64 encoded, and download the certificate.

45. Copy the new certificate into the share folder on the CAS server.

46. Log back into the CAS server and open the Exchange Admin Center.
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47.

48.
49.

50.
51.
52.
53.
54.

55.
56.
57.
58.
59.
60.

61.
62.

Go to Servers—>Certificates, and highlight the certificate you began before (should say Pending request in the
status column).
Click Complete on the right side.
Type the path to the certificate, including the certificate name, and click OK. Example:
\\cas\share\certnew.CER
Verify that the status has changed to Valid.
Edit the new entry, and click Edit.
Go to Services, check SMTP and 11S, and click Save.
Click Yes on the warning message.
Run the following steps on the CAS and AD servers:
a. Click Start, and type MMC
Click File>Add/Remove Snap-in.
Choose Certificates, and click Add.
Choose Computer account, and click Next.
Choose Local computer, and click Finish.
Click OK.
Expand Certificates>Trusted Root Certificate Authorities—> Certificates.
Click Action>All Tasks—>Import.
Click Next.
j.  Browse to the share folder on the CAS server, and choose the new certificate you created. Click
Next.
k. Leave defaults, and click Next.
I.  Click Finish.
m. Click OK on the Import was successful message.
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Log into the CAS server and open the Exchange admin center.

Navigate to Servers—>Databases.

Restart the Microsoft Exchange Information Store service on the MB server.

Using the Edit button, disable the maintenance schedule and enable circular logging for each mailbox database.
Dismount and remount the databases.

Open the Exchange Management shell, and enter the following to move the paths of the default mailbox:
Move-Databasepath “DatabaseName” -EdbFilepath “E:\Newlocation\DBname.edb” -
LogFolderpath “F:\Newlocation”

When prompted, type A and press Enter.

Open Exchange Management Shell, and enter the following:

Get-OutlookAnywhere |Set-OutlookAnywhere -ExternalHostname cas.domain.com -
DefaultAuthenticationMethod NTLM -ExternalClientsRequireSsl S$true
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Installing and configuring the Exchange 2013 mail test clients and completing LoadGen
configuration on the Exchange 2013

For our testing, we used one virtual client machine to run LoadGen 2013. To create the mail clients, we installed

several software components. We followed this process for each installation:

Installing Windows Server 2012 R2 SP1

1.
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Insert the installation media into the CD/DVD drive, and restart the server.

Press any key when prompted to boot from DVD.

When the installation screen appears, click My language is English (United States).
Leave language, time/currency format, and input method as default, and click Next.
Click Install now.

When the installation prompts you, enter the product key.

Select Windows Server 2012 R2 Datacenter (Server with a GUI), and click Next.
Check | accept the license terms, and click Next.

Click Custom: Install Windows only (advanced).

. Select Drive 0 Unallocated Space, and click Next.
. When the Settings page appears, fill in the Password and Reenter Password fields with the same password.

. Log in with the password you set up previously.

To set up this server, we had to install several additional software components. The following subsections detail

the necessary installation processes.

Joining the domain

1.

e W

10.

11.

12.
13.

Set a static IP.

Select Start—>Control Panel>Network Connections—>Local Area Connection.

Click Properties.

Highlight Internet Protocol (TCP/IP), and click Properties.

Select the Use the following DNS server addresses radio button, and enter the IP of the DNS server in the
Preferred DNS server field. Click OK.

Right-click My Computer, and select Properties.

Under the Computer Name tab, click Change.

In the Computer Name Changes screen, under the Member of section, select the Domain radial box, and type
test.local

Select OK to start joining the domain.

When the screen appears asking for a person qualified on the domain, type Administrator as the username
and Passwordl as the password.

At the Welcome pop-up window and the window warning that you must reset the computer for the changes to
take effect, click OK.

At the System Properties screen, click OK.

When a pop-up appears asking if you want to restart now, click Yes to restart your computer.
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Installing Internet Information Services
1. Click Start>Administrative Tools—>Server Manager.

2. On the left pane, click Roles.

3. Click Add Roles.

4. Click the Application Server checkbox.

5. When the Add features required for Application Server? screen appears, click Add Required Features.

6. Click Next.

7. Click Next.

8. Atthe Select Role Services page for Application Server, click the Web Server (IIS) Support checkbox.

9. Click Add Required Support Role Services.

10. Click Next.

11. Click Next.

12. At the Select Role Services page for Web Server (IIS), click the IIS 6 Management Compatibility, ASP, and CGl
checkboxes, and click Next.

13. Click Install.

14. Click Close.

Installing Load Generator

Download and install Load Generator 2013 using all defaults.

Importing the certificate and editing the hosts file
1. Click Start, and type MMC

2. Click File=>Add/Remove Snap-in.

3. Choose Certificates, and click Add.

4. Choose Computer account, and click Next.

5. Choose Local computer, and click Finish.

6. Click OK.

7. Expand Certificates>Trusted Root Certificate Authorities—> Certificates.

8. Click Action>All Tasks=>Import.

9. Click Next.

10. Browse to the share folder on the CAS server, and choose the new certificate you created. Click Next.
11. Leave defaults, and click Next.

12. Click Finish.

13. Click OK on the Import was successful message.

14. Open the Notepad program, and use File=>Open to open the hosts file stored at

C:\Windows\System32\drivers\etc.
15. Add the IP and FQDN of the CAS server.

16. Save and close Notepad.

Preparing Load Generator
1. Loginto the mail client.
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10.

11.

12.

13.
14.

Select Start—>All Programs—> Microsoft Exchange—> Exchange Load Generator 2013.

When the Load Generator screen appears, select Start a new test.

Select Create a new test configuration, and click Continue.

Change the total length of simulation to 2.5 hours.

In the Specify test settings screen, type Passwordl as the Directory Access Password and Mailbox Account
Master Password, and click Continue with recipient management.

Create 4,800 users in the Mailbox Database, and click Continue.

To accept defaults for Advanced recipient settings, click Continue.

In the Specify test user groups screen, select the plus sign to add a user group.

Change the Client Type to Outlook 2007 Cached, the action profile to Outlook_450, and the Mailbox size to 250
MB, and click Continue.

In Remote configurations, check the checkbox to enable distributing the workload, enter the computer names of
all of the test clients, and click Continue.

Click Save the configuration file as, and name it testcfg.xml

Click Start the initialization phase (recommended before running the test).

Once you have initialized the database, create a backup copy of the Exchange mailbox databases.
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