A Principled Technologies report: Hands-on testing. Real-world results.

The science behind the report:

Dell CloudlQ provides a single
console for proactive monitoring
and had negligible impact on
network utilization in our tests

0.056 KBps

1 (with o hosts)

This document describes what we tested, how we tested, and what we found. To learn how these facts translate
into real-world benefits, read the report Dell CloudIQ provides a single console for proactive monitoring and had
negligible impact on network utilization in our tests.

We concluded our hands-on testing on January 26, 2022. During testing, we determined the appropriate
hardware and software configurations and applied updates as they became available. The results in this report
reflect configurations that we finalized on January 18, 2022 or earlier. Unavoidably, these configurations may not
represent the latest versions available when this report appears.

Our results

To learn more about how we have calculated the wins in this report, go to http://facts.pt/calculating-and-highlighting-wins.
Unless we state otherwise, we have followed the rules and principles we outline in that document.

Table 1: Network impact for monitoring via OME and CloudlQ with a single host. Source: Principled Technologies.

Enterprise license Datacenter license

Category

Max file size

(bytes)

Min file size
(bytes)

Average
data transfer
(KBps)

Max file size

(bytes)

Min file size
(bytes)

Average
data transfer
(KBps)

Telemetry

693

693

694

691

Health

N/A

N/A

495

495

Alerts

N/A

N/A

641

641

Inventory

415

415

1,618

416

Average OME transmitted over test
(1-hour period)

0.067

0.071

Maximum OME transmitted
(20-second interval average)

Minimum OME transmitted
(20-second interval average)
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Table 2: Network impact for monitoring via OME and CloudIQ with two hosts. Source: Principled Technologies.

Datacenter license

Enterprise license

Max file size | Min file size Average Max file size | Min file size Average

Category (bytes) (bytes) data transfer (bytes) (bytes) data transfer
. . (KBps) i (KBps)

Telemetry 768 764 2,008 1,596
Health 504 502 N/A N/A
Alerts N/A N/A N/A N/A
Inventory 11,503 415 11,748 415
Average OME transmitted over test 0.056 0.078
(1-hour period)
Maximum OME transmitted 2 3
(20-second interval average)
Minimum OME transmitted 0 0

(20-second interval average)

Table 3: Network impact for monitoring via OME and CloudIQ with three hosts. Source: Principled Technologies.

Datacenter license

Enterprise license

Max file size | Min file size LI Max file size | Min file size LI

Category Ty (bytes) data transfer Ty (bytes) data transfer
y (KBps) y (KBps)

Telemetry 1,702 1,486 2,466 2,009
Health 515 494 505 505
Alerts N/A N/A N/A N/A
Inventory 16,694 417 11,744 414
Average OME transmitted over test 0.206 0,089
(1-hour period)
Maximum OME transmitted 8 3
(20-second interval average)
Minimum OME transmitted 0 0

(20-second interval average)
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System configuration information

Table 4: Detailed information on the system we tested.

System configuration information Dell PowerEdge R740

BIOS name and version Dell 2.12.2

Non-default BIOS settings Intel Turbo Boost enabled, Virtualization enabled

Operating system name and version/build number VMware ESXi 7.0.2

Date of last OS updates/patches applied 01/15/22

Power management policy Balanced

Processor

Number of processors 2

Vendor and model Intel® Xeon(®Platinum 8168
Core count (per processor) 24

Core frequency (GHz) 2.70

Stepping HO

Memory module(s)

Total memory in system (GB) 256

Number of memory modules 8

Vendor and model Samsung M393A4K40CB2-CTD
Size (GB) 32

Type PC4-21300V-R

Speed (MHz) 2,666

Speed running in the server (MHz) 2,666

Storage controller

Vendor and model Dell PERC H740P
Cache size 8

Firmware version 50.5.0-1750
Driver version 7.716.03.00

Local storage (type A)

Number of drives 2 2 4

Drive vendor and model TOSHIBA TOSHIBA Seagate
THNSF8120CCSE PX05SVB096Y ST91000640NS

Drive size (GB) 111.25 893.75 931

Drive information (speed, interface, type) SATA SSD 6 Gbps SAS SSD 12Gbps 3 Gbps

Network adapter

Vendor and model Broadcom Gigabit Ethernet BCM5720

Number and type of ports 4 x 1 GbE
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System configuration information Dell PowerEdge R740

Cooling fans

Vendor and model Dell 4VXP3

Number of cooling fans 6

Power supplies

Vendor and model Dell 0Y26KXA02
Number of power supplies 2
Wattage of each (W) 1,100

Dell CloudIQ provides a single console for proactive monitoring and had negligible impact on network bandwidth in our tests April 2022 | 4



How we tested

This methodology assumes all servers under test (SUT) are running VMware ESXi™ 7.0.2 and can host virtual machines for load testing. Each
server connects to a VMware vCenter™ server that controls a separate environment where services such as Active Directory, DNS, NTP, and
other management applications reside.

Installing OpenManage Enterprise (OME)

® NOo Uk wN =

Download the OME appliance archive file from https://downloads.dell.com, and click Save.

Extract the archive file to a directory on your computer.

Open a web browser, and log into your VMware vSphere vCenter instance using administrator credentials.

In vCenter, select your target host in your infrastructure cluster, right-click, and select Deploy OVF Template.
In the Deploy OVF Template wizard, select Local File, and browse to the location of your extracted archive files.
Select all of the files in the extracted directory, and click Open.

In the Deploy OVF Template Wizard, click Next.

Select a location for the OME virtual machine. Provide a custom name or accept the defaults, and click Next.
Select a compute resource or accept the default selection, and click Next.

Review Details, and click Next.

From the drop-down menu, for the virtual disk format, select Thin Provision.

Select the storage location target where you want to install the appliance. Click Next.

Accept the network defaults, and click Next.

Click Finish.

Configuring OME
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21.
22.
23.
24.

Select the newly created VM in vCenter, and power it on.

On the summary screen, click the link to open a console session.

Click the console screen, use tab to select Accept, and press Enter.

To select the default US keyboard, press Enter.

Enter a new password, and confirm it. Press the Tab key, and press Enter.

To confirm the password change, press Enter a second time.

Use the down arrow key to select Set Networking Parameters, and press Enter.

To select the primary network adapter, press Enter.

Enter the administrator password, press Tab, and press Enter.

To enter the IP address information block, press Tab.

Use the arrow keys to change the IP address information to one compatible with your network settings.
Press Tab to select <Apply>, and press Enter.

Enter the administrator password, press Tab, and press Enter.

To confirm the short delay while changes are applied, press Enter.

On the main menu, click up arrow, and select Display Current Appliance Status. Press Enter.

Ensure all services are marked as active, and open a new web browser tab.

In the new browser, enter either the IP address or the DNS name for your OME appliance, and press Enter.
Log into OME with the administrator credentials.

Click Initial settings.

Expand the Time Configuration menu. Use the drop-down menu to select your time zone. We selected (GMT-5:00) Eastern Time. Check
the box for Use NTP. Provide the IP address for your preferred time source, and click Apply. Click Yes.

Click Finish.
Click Discover Devices.
For Device Type, select Server. Accept the default Dell iDRAC as the connection method, and click OK.

Provide the IP address or range for at least one iDRAC to discover. Provide credentials for logging onto the iDRAC. We used the default
credentials for all iDRACs. Check the box for Enable trap reception from discovered iDRAC servers and MX7000 chassis. For Application
Settings, check the Set Community String for trap destination checkbox. Click Finish.

Installing the CloudlQ plugin

1.
2.
3.

On the OME menu bar, select Application Settings>Console and Plugins.
Click Update Settings.
For How to check for updates, select Manual. Click Apply.
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9.

10.
11.
12.
13.
14.
15.
16.
17.
18.
19.

20.
21.
22.
23.
24.
25.

In the list of available plugins that appears, locate CloudIQ, and click Install.

In the pop-up box that appears, click Download Plugin.

Close the window. The CloudIQ status will change to Downloaded. Click Install.

In the pop-up box that appears, click Install Plugin.

Review the End User License Agreement, and click Accept.

Review the Infrastructure Telemetry Notice, and click Accept.

Review and perform the recommended steps. Check the box to confirm you have completed the actions, and click Confirm Install.
When complete, OME will reboot, and you'll be prompted to log in. Log in with admin credentials.

Click Plugins=>CloudIQ->Overview.

Click Activate Now.

Click Generate Access Key. This will open a new browser tab that will connect to a Dell website that requests your account credentials.
Enter the credentials, and click Sign In.

Select the site ID associated with your organization.

Create a 4-digit PIN, and click Generate Access Key. An email with the access key will be delivered to your email account. Click Done.
Navigate to your email inbox, and open the email with the access key. Copy the key from the email.

Switch back to the OME CloudIQ configuration screen, and paste the key from your email into the Access Key field. In the PIN field,
enter the PIN you chose for this key. Click Next. This initiates a secure connection between CloudIQ and OME.

Provide a name for the collector, and click Next. We used OME.

Press Select Groups, and select the groups you want CloudIQ to monitor. Click OK.

Click Next.

Click Finish.

To confirm CloudIQ registration is complete, click OK.

Devices with the proper licenses and entitlements will automatically conntect to CloudIQ via OME.

Creating a DVD Store VM for load generation

Installing Windows Server 2019
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10.
1.
12.
13.
14.
15.
16.
17.
18.
19.
20.
21.

22.
23.
24.

25.
26.

In vCenter, select one of the SUT. Right-click, and select New Virtual machine.

Click Next.

Provide a name for your virtual machine (we used SQL_SUT1). Select the datacenter containing your SUT hosts, and click Next.
Select the target server for the new VM. Click Next.

Select the storage target for the new VM. Click Next.

Click Next.

Accept the defaults for Windows and Server 2019, and click Next.

In the Customize hardware panel, change the CPUs to 8 and the memory to 32 GB. Change the New Hard Disk to utilize Thin Provision
for the Disk Provisioning. Set the New CD/DVD Drive to map to Datastore ISO File.

Select the Windows ISO you want to install the OS from, and click OK.

In the New CD/DVD Drive section, check the box beside Connect..., and click Next.
Click Finish.

Power on the VM, and launch a console session through vCenter.

To boot from the mounted ISO file, press any key.

Click Next.

Click Install now.

Enter the Windows product key, and click Next.

Select Windows Server 2019 Datacenter (Desktop Experience), and click Next.
Check the | accept the license terms checkbox, and click Next.

Click Custom: Install Windows only (advanced).

Click Next.

After installation completes, the system will reboot and prompt you to create an administrator account password. Enter the password
twice, and click Finish.

Log into the Windows Server VM.
Go back to the vCenter, right-click the newly created server, and select Edit settings.

Click Add New Device, and select Hard Disk. Select the New Hard disk, and change the size to 200 GB. Change the provisioning type
to Thin Provision. Click Add New Device, and select Hard Disk again. Select the second New Hard disk, and change the size to 100 GB.
Change the provisioning type to Thin Provision, and click OK.

Go back to the Windows VM. In Server Manager, select Tools>Computer Management.
Click Disk Management.
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27. Right click on the Disk 1 entry and select online. Right click on Disk 1 and select Initialize Disk. Accept the default and click OK. Right
click on the Unallocated space and select New Simple Volume...

28. Click Next.

29. Accept the default value for disk size, and click Next.

30. Accept the default value (D) for the drive letter, and click Next.
31. Change the Volume label to Data, and click Next.

32. Click Finish.

33. Right-click the Disk 2 entry, and select Online. Right-click Disk 2, and select Initialize Disk. Accept the default, and click OK. Right-click
the Unallocated space, and select New Simple Volume...

34. Click Next.

35. Accept the default value for disk size, and click Next.

36. Accept the default value (E) for the drive letter, and click Next.

37. Change the Volume label to Logs, and click Next.

38. Click Finish.

39. Run Windows Update to ensure all patches have been applied and the server is up to date.

Installing SQL Server

1. In vCenter, select the newly created server, right-click, and select Edit settings.

2. Change the CD/DVD drive to point to the SQL Server 2019 iso file.

3. Go back to the VM, and double-click the D: with the SQL Setup DVD loaded.

4. In SQL Server Installation Center, click Installation.

5. Click New SQL Server stand-alone installation or add features to an existing installation.

6.  Enter the product key, and click Next.

7. Check the | accept the license terms checkbox, and click Next.

8.  Check the Use Microsoft Update to check for updates checkbox, and click Next.

9. After install rules have passed, click Next. If any rules fail, mitigate the failures before continuing.
10. Select Database Engine Services, Full-Text and Semantic Extractions for Search, and click Next.
11. Accept the defaults, and click Next.

12. Accept the default Server Configuration, and click Next.

13. Select Mixed Mode, and enter a password for SA. Click Add Current User, and click Next.

14. Click Install.

15. Upon completion, click Close.

16. In the SQL Server Installation Center, click Install SQL Server Management Tools.

17. Click the link to download the latest version of SQL Server Management Studio.

18. After the download completes, run the executable.

19. Click Install.

20. Click Close.

Importing the DVD Store database

1. Open Microsoft SQL Server Management Studio.
2 Using the Windows Authentication, click Connect.
3. Select New Query.

4. Enter the following text into the SQL Query tab:

USE [master]

GO

CREATE LOGIN [ds3user] WITH PASSWORD=N'",
Default Database=[master],

Default Language=[us_english],

Check expiration=0OFF,

Check policy=0FF

GO

5. Click the checkbox to verify no syntax errors or issues.
6.  Click Execute.

We used a previously generated 40GB database. We imported the database from backup files stored on the local server.
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7. In Windows, create two folders named D:\DS3 and E:\DS3.

8. In SQL Server Management Studio, right-click Databases, and select Restore Database.
9.  Select Device, and click the button beside it to add the device location.

10. Click Add.

11. Browse to the location of the backup files on your local device (ours was stored on E drive for loading). Click OK.
12. Click OK.

13. In the upper left, click File.

14. Check the Relocate all files to folder checkbox. Select D:\DS3 for the Data file folder, and select E:\DS3 for the Log file folder.
15. Click OK.

16. In SQL Server Management Studio, right-click Security=>Logins->ds3user, and select Properties.

17. Click user mapping. In the top pane, check the box for DS3, and in the bottom pane check the box for db_owner. Click OK.
18. Copy the ds35-main folder to C:\ on the VM.

Repeat the steps to create a VM on each SUT.

Running the DVD Store load

We used DVD Store 3.5 as a generator for O on each system under test, which in turn reported performance metrics that could be reported
to OME and CloudIQ. We executed the following sequence for generating load on each of our SQL Server database instances running on
Windows Server 2019 hosts:

1. Log into one of the VMs on the SUT with administrator credentials.
2. Open a command prompt.

3. Change the directory to the DVDStore installation directory and locate the sqglserverds35 directory. Our target directory was located at
C:\ds35-main\sglserverds35\

4. Execute the following command:

ds35sqglserverdriver.exe --n_threads=20 --ramp rate=10 --run time=60 --db_size=40GB
--think time=.05

In Windows, open Task Manager.

Click the Performance tab and verify CPU, Memory, and Ethernet are active and showing utilization.
At the bottom of the Task Manager panel, click Open Resource Monitor to verify disk activity.
Repeat steps 1 through 7 on the VMs for each SUT.

® N o

Collecting data

Open a web browser, and log into OME with admin credentials.

Click Plugins=>CloudIQ->Transfer Log.

Record any alert, health, inventory, and telemetry transfers that have occurred in the last hour while the servers were not under load.
Open a new web browser tab, and log onto your VMware vSphere vCenter with administrator credentials.

Select the VM labelled openmanage_eterprise.x86_64-0.0.1.

On the actions panel in the upper right, click Monitor.

Under Performance, click Advanced.

Click Chart Options.

Under Chart Metrics, select Network.

Under counters, select Data Transmit Rate.
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Under target objects, select only openmanage_enterprise.x86_64-0.0.1.
Click OK.
Return to the OME console.

During the duration of the test, select any category of data that is transmitted. Record the category, time stamps, file size, and duration.
These datapoints correlate traffic outbound to CloudlQ with the network transmission data reported by vCenter.
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At the conclusion of the one-hour test, record the Maximum, Minimum, and Average displayed as reported by vCenter for the
transmitted traffic. Screenshot the graph for reference.
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Read the report at https://facts.pt/bPk3zLv >

This project was commissioned by Dell.

‘ Principled

Technologies®

Principled Technologies is a registered trademark of Principled Technologies, Inc.
All other product names are the trademarks of their respective owners.

DISCLAIMER OF WARRANTIES; LIMITATION OF LIABILITY:

Principled Technologies, Inc. has made reasonable efforts to ensure the accuracy and validity of its testing, however, Principled Technologies, Inc. specifically disclaims
any warranty, expressed or implied, relating to the test results and analysis, their accuracy, completeness or quality, including any implied warranty of fitness for any
particular purpose. All persons or entities relying on the results of any testing do so at their own risk, and agree that Principled Technologies, Inc., its employees and its
subcontractors shall have no liability whatsoever from any claim of loss or damage on account of any alleged error or defect in any testing procedure or result.

In no event shall Principled Technologies, Inc. be liable for indirect, special, incidental, or consequential damages in connection with its testing, even if advised of
the possibility of such damages. In no event shall Principled Technologies, Inc.’s liability, including for direct damages, exceed the amounts paid in connection with
Principled Technologies, Inc.’s testing. Customer’s sole and exclusive remedies are as set forth herein.
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