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Executive summary

Intel Corporation (Intel) approached Principled
Technologies (PT) and Dell Inc. (Dell) to
measure performance with Intel’s vConsolidate
workload on VMware ESX Server 3.0.1. Intel
commissioned a test of the following three dual-
processor servers and Dell provided the
PowerEdge 2950 server:

e Dell PowerEdge 2950 with Dual-Core
Intel Xeon processor 5160

e Dell PowerEdge 2950 with Quad-Core
Intel Xeon processor X5355

e HP ProLiant DL385 G2 with Dual-Core
AMD Opteron processor model 2220
(the fastest Opteron processor publicly
available for this server at the time of
this test)

Figure 1 provides a normalized comparison for
each of the test servers with both one and two
vConsolidate work units, which it calls

KEY FINDINGS
The Dell PowerEdge 2950 with Quad-Core Intel Xeon
processor X5355 delivered 48 percent and 95 percent
more performance on the one-CSU and two-CSU
vConsolidate workloads, respectively, than the HP
ProLiant DL385 G2 with Dual-Core AMD Opteron
processor model 2220 (see Figure 1).

The Dell PowerEdge 2950 with Dual-Core Intel Xeon
processor 5160 delivered 22 percent and 8 percent
more performance on the one-CSU and two-CSU
vConsolidate workloads, respectively, than the HP
ProLiant DL385 G2 with Dual-Core AMD Opteron
processor model 2220 (see Figure 1).

The Dell PowerEdge 2950 with Quad-Core Intel Xeon
processor X5355 delivered 21 percent and 80 percent
more performance on the one-CSU and two-CSU
vConsolidate workloads, respectively, than the Dell
PowerEdge 2950 with Dual-Core Intel Xeon processor
5160 (see Figure 1).

consolidate stack units (CSUs). (See the Workload and later sections for more on CSUs.) This chart normalizes
all the results to those of the lowest single result: the one-CSU result for the HP ProLiant DL385 G2 with Dual-
Core AMD Opteron processor model 2220. That system’s score for that test is thus 1.00. Normalizing makes each
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As Figure 1 illustrates, the
Dell PowerEdge 2950 with
Quad-Core Intel Xeon
processor X5355 delivered
the highest performance
with both one- and two-CSU
vConsolidate workloads.
The Dell PowerEdge 2950
with Dual-Core Intel Xeon
processor 5160 also
delivered more performance
on both workloads than the
HP ProLiant DL385 G2 with
Dual-Core AMD Opteron
processor model 2220.

[ Dell PowerEdge 2950
with Dual-Core Intel Xeon
processor 5160

Dell PowerEdge 2950
with Quad-Core Intel
Xeon processor X5355

Figure 1: Normalized vConsolidate median results for the three test systems with one and
two CSUs. Higher scores are better. The numbers at the bottom of each bar indicate the

percentage of processor utilization. Lower numbers are better.



Workload

Intel defined, implemented, and supplied the vConsolidate workload. vConsolidate includes four different
performance tests— database, Java, mail, and Web-that run simultaneously in different virtual machines (VMs) on
a server. A fifth, idle VM is also present during the test. vConsolidate refers to a single collection of these five
virtual machines as a consolidate stack unit (CSU). Depending on the type of server and its available resources,
testers can choose to run one or more CSUs. The typical goal is to run enough CSUs to push the server under
test to its maximum capacity by consuming 100 percent of the CPU capacity or very close to that amount.

vConsolidate amalgamates the throughput results of each of the workloads in a CSU to create an overall score for
that CSU, and it uses the scores of all the CSUs to create an overall score for the server under test. See the Test
results section for more information on this process.

Performance tests vConsolidate uses
vConsolidate uses the following four performance tests:

LoadSim

Microsoft Exchange Server 2003 Load Simulator (LoadSim) is a benchmark that measures a server’s
performance handling email. LoadSim uses the MAPI Messaging Benchmark 3 (MMB-3) to simulate MAPI email
clients. The simulated clients issue requests to an Exchange server to generate an email load. LoadSim
measures both the server’s response time and the number of messages it delivers. LoadSim is available for free
download from www.microsoft.com/downloads/details.aspx?Familyld=92EB2EDC-3433-47CA-A5F 8-
0483C7DDEAS85&displaylang=en.

SPECjbb2005

SPECjbb2005 is an industry-standard benchmark from the Standard Performance Evaluation Corp. (SPEC) that
measures a server’s Java performance. SPEC modeled SPECjbb2005 on the three-tier client/server architecture,
with the middle layer as the primary focus. According to SPEC, “Random input selection represents the first (user)
tier. SPECjbb2005 fully implements the middle tier business logic. The third tier is represented by tables of
objects, implemented by Java Collections, rather than a separate database.” For more information about
SPECjbb2005, see www.spec.org/jbb2005/docs/UserGuide.html.

The results we quote here for this workload are not official SPECjbb2005 results because the vConsolidate
workload uses a slightly modified version of the benchmark. These results are not comparable to SPECjbb2005
results on SPEC's Web site.

SysBench

The developers at SourceForge.net (www.sourceforge.net) created SysBench to test various aspects of the
performance of servers running database systems. The benchmark’s original target was the MySQL database
system (see www.mysql.com). Intel created a version of SysBench 0.4.0 that would work with Microsoft SQL
Server 2005 Enterprise Edition (www.microsoft.com/sql/editions/enterprise/default.mspx). We ran that version in
our test. In the vConsolidate workload, SysBench created a 100,000-row SQL database and executed a batch of
online transaction processing (OLTP) transactions against that data.

WebBench

WebBench 5.0 (128-bit US version) is an industry-standard benchmark for Web server software and hardware. It
uses PC clients to send Web requests to a server under test. It generates performance results by incrementally
increasing the number of clients making HTTP 1.0 GET requests to the Web server; the result is a curve showing
the server’s performance under increasing load. The peak of that curve represents the peak throughput of the
server. WebBench reports both the total number of requests per second the server handled and the server’s total
throughput in bytes per second. To be certain that we found the true peak performance in our testing, we verified
that the server’s processor utilization reached or was extremely close to 100 percent during the test.

vConsolidate profiles
The vConsolidate workload comes with four sets of VM specifications, which it calls profiles. These profiles define
four key factors for each workload VM:

e number of virtual CPUs (vCPUs) the workload should receive
e amount of virtual RAM (vMemory) the workload should receive
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e the operating system (OS) the workload should run
o the key application the workload should run
e the workload itself

As we noted earlier, vConsolidate refers to a single collection of these five virtual machines as a consolidate stack
unit (CSU). Depending on the type of server and its available resources, you may choose to run one or more
CSUs. The typical goal is to run enough CSUs to push the server under test to its maximum capacity by
consuming 100 percent of the CPU capacity or very close to that amount.

vConsolidate offers four profiles; we tested with its profile 2, which targets one- and two-processor servers and
which Figure 2 details.

Profile 2
vCPUs vMemory 0S Application
WebBench (Web) 2 1.5 GB Windows 32-bit s
LoadSim (mail) 1 1.5GB Windows 32-bit Exchange
SysBench (database) 2 1.5GB Windows 64-bit SQL Server
SPECjbb2005 (Java) 2 20GB Windows 64-bit BEA JVM
Idle 1 0.4 GB Windows 32-bit

Figure 2: The vConsolidate profile we used in our testing.

For further information on vConsolidate, please contact Intel.

Test results

The result for an execution of the vConsolidate workload amalgamates the results of all four of the workloads it
includes. To calculate a final score for a vConsolidate run, we used the following three steps, which Intel
specified:

1. Benchmark throughput = benchmark’s raw results / benchmark duration [for each of the four benchmarks]
2. Normalized throughput = benchmark throughput / reference system’s benchmark throughput
3. vConsolidate score = geomean (normalized throughput of all four benchmarks in a CSU)

The first step in this process uses whatever raw results a benchmark produces, such as number of transactions or
operations, and the benchmark’s duration in seconds. We calculate a benchmark’s duration by subtracting the
start time of the vConsolidate test from its stop time and converting that time to seconds.

WebBench is an exception to this process, because it automatically produces a score in requests per second. For
this benchmark, we calculate the average requests per second for the three WebBench mixes that run while the
other benchmarks are running and record this result as its throughput.

The second step is to normalize the throughput. We use the score of one of the systems under test as the
reference system and assign it a normalized score of 1. The last step is to take the geomean of the normalized
throughput for all four benchmarks. In this test, we used as the reference score the one-CSU score on the HP
ProLiant DL385 G2 with Dual-Core AMD Opteron processor model 2220 with the hard disks configured as
independent volumes.

For the two-CSU tests, per Intel's direction we summed the score of the two CSUs to obtain the workload’s final
score.

Figure 3 shows the final score and CPU utilization of each test server with one and two CSUs. The CPU utilization
percentage is the average over the period the vConsolidate workload was running.
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1CSU 2 CSUs
Server vConsolidate % CPU vConsolidate % CPU
score utilization score utilization

Dell PowerEdge 2950 with Dual-Core Intel 122 97 84 118 99.65
Xeon processor 5160

Dell PowerEdge 2950 with Quad-Core

Intel Xeon processor X5355 148 64.49 213 95.94
HP ProLiant DL385 G2 with Dual-Core

AMD Opteron processor model 2220 1.00 89.72 1.09 99.58

Figure 3: vConsolidate median results for the three test systems with one and two CSUs. Higher scores are better. Lower CPU

utilization is better.

Figure 4 shows the one-CSU median results, by benchmark, for the Dell PowerEdge 2950 with Dual-Core Intel
Xeon processor 5160, Dell PowerEdge 2950 with Quad-Core Intel Xeon processor X5355, and HP ProLiant
DL385 with Dual-Core AMD Opteron processor model 2220.

Dell PowerEdge 2950 with Dell PowerEdge 2950 with | HP ProLiant DL385 G2 with
Dual-Core Intel Xeon Quad-Core Intel Xeon Dual-Core AMD Opteron
processor 5160 processor X5355 processor model 2220
Benchmark 1CSU 1CSU 1CSU
Database 1.393 1.868 1.000
Java 1.043 1.100 1.000
Mail 0.953 0.926 1.000
Web 1.587 2.549 1.000
Score 1.218 1.484 1.000

Figure 4: vConsolidate one-CSU median results, by benchmark, for the three test servers. Higher scores are better.

Figure 5 shows the two-CSU test results, by benchmark and CSU, for the Dell PowerEdge 2950 with Dual-Core
Intel Xeon processor 5160, Dell PowerEdge 2950 with Quad-Core Intel Xeon processor X5355, and HP ProLiant
DL385 with Dual-Core AMD Opteron processor model 2220.

Dell PowerEdge 2950 with Dell PowerEdge 2950 with HP ProLiant DL385 G2 with
Dual-Core Intel Xeon Quad-Core Intel Xeon Dual-Core AMD Opteron

processor 5160 processor X5355 processor model 2220

Benchmark CSuU 1 CSU 2 CSuU 1 CSU 2 CSuU 1 CSuU 2
Database 0.648 0.648 1.177 1.213 0.616 0.622
Java 0.526 0.511 0.839 0.860 0.420 0.489
Mail 1.049 0.998 1.090 1.059 1.041 1.001
Web 0.349 0.362 1.127 1.238 0.320 0.307
Score by CSU 0.594 0.588 1.050 1.081 0.542 0.553
Final score 1.182 2.131 1.095

Figure 5: vConsolidate two-CSU median results, by benchmark, for the three test servers. Higher scores are better.
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Test methodology

Figure 6 summarizes some key aspects of the configurations of the three server systems; Appendix A provides

detailed configuration information.

Server

Dell PowerEdge 2950
with Dual-Core Intel
Xeon processor 5160

Dell PowerEdge 2950
with Quad-Core Intel
Xeon processor X5355

HP ProLiant DL385 G2
with Dual-Core AMD
Opteron processor

package

model 2220
Processor frequency (GHz) 3.0 GHz 2.66 GHz 2.8 GHz
System bus 1333 MHz 1333 MHz L2000 Mz

yperTransport
Number of processor packages 2 2 2
Number of cores per processor 2 4 2

Number of hardware threads
per core

1

1

1

Dell PowerEdge 2950

Dell PowerEdge 2950

HP ProLiant DL385 G2

Motherboard DT021 DT021 414109-B21
Serverworks HT-2100
. Northbridge and
Chipset Intel 5000X Intel 5000X HT1000 Southbridge
chipset
Hynix Hynix Hynix
RAM (16 GB in each) HYMP525F72BP4N3- HYMP525F72BP4N3- HYMP525P72BP4-Y5
Y5 PC2-5300 FBDIMM | Y5 PC2-5300 FBDIMM | PC2-5300 DIMM
Hard Drive 5 x Seagate 5 x Seagate 5 x Seagate
ST9146802SS ST9146802SS ST9146802SS

Network adapters

Dual embedded
Broadcom NetXtreme I
5708 Gigabit Server
Adapter (integrated) / 1
x Intel PRO/1000 PT
Dual Port Server
Adapters (PCI Express)

Dual embedded
Broadcom NetXtreme I
5708 Gigabit Server
Adapter (integrated) / 1
x Intel PRO/1000 PT
Dual Port Server
Adapters (PCI Express)

Dual Embedded HP
NC373i Multifunction
Gigabit Server Adapters
(integrated) / 1 x Intel
PRO/1000 PT Dual Port
Server Adapters (PCI
Express)

Figure 6: Key aspects of the server configurations.
To be sure we could push the processors of each of the three system configurations to their maximum capacities,
we tested each server with two vConsolidate CSUs. We installed five identical hard disks in the servers under
test. The rest of this section details how we set up the servers and the vConsolidate workload.

Hardware and software the test involved

Software

We used the following software to configure and run the vConsolidate workload:

WebBench 5.0

VMware ESX Server 3.0.1

VMware Virtual Infrastructure Client version 2.0.1
Microsoft Windows Server 2003, Enterprise Edition
Microsoft Windows Server 2003, x64 Enterprise Edition
Microsoft Exchange Server 2003
Microsoft SQL Server 2005

BEA JRockit 1.5.0_10-b03

Microsoft Exchange Server Load Simulator (LoadSim) 06.05.7775
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¢ SPECjbb2005 v1.07
e SysBench v0.4.0
¢ Intel vConsolidate framework package version Beta-2
e VMware Converter 3.0.0
Hardware

Our test bed consisted of the following hardware:

e The server under test

e Four custom-built Intel Server Board S5000PSL systems, which we used as WebBench and LoadSim

clients

e  One custom-built Intel Server Board S5000PSL system, which we used as both the main vConsolidate

controller and the WebBench controller

¢ One Dell Dimension E520 system, which we used as the second WebBench controller in tests with two

CSUs
e Netgear GS724T, which we set up into two VLans

Figure 7 illustrates this test bed in its two-CSU configuration.

vConsolidate two-CSU test bed

External network N CS_U #1.
CSU #1 WebBench and Q LoadSim client
i IP address =
Internal network CSU #1 main controller 192.168.11.110

(see additional IP address \
information below) %
External network
switch %\

—( _ External network

Internal network CSU #2

= csu#1
Q WebBench client
IP address =

192.168.12.211

Internal network 1

with three active NICs Internal network 2

N
.
Server under test \
Q

N

CSU #2

CSU #2 WebBench WebBench
controller client
IP address =

192.168.22.211

IP address = :
192.168.22.120 %
Additional IP address information 3
Server under test
External network = 192.168.0.250

Internal network (one for each CSU’s WebBench and LoadSim traffic) csuU #2
LoadSim client
IP address =

192.168.21.110

Main controller

External network IP address = 192.168.0.100

Internal network IP address = 192.168.11.100; 192.168.12.100; 192.168.21.100;
192.168.22.100; 192.168.12.210

VM IP addresses

JavaServer1 & 2, DBServer1 & 2, IdleServer1 & 2 = DHCP
WebServer1 = 192.168.12.215; WebServer2 = 192.168.22.215
MailServer1 = 192.168.11.115; MailServer2 = 192.168.21.115

Figure 7: Our vConsolidate test bed.

Internal
network
switch
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Server installation
We configured all servers with the same disk setup: five 146 GB SAS hard drives that we configured as five
independent volumes with no RAID option.

We then installed the VMware ESX Server and all the vConsolidate virtual machines (VMs).

Installing VMware ESX Server 3.0.1
We did the following to install VMware ESX Server 3.0.1 on the server under test (SUT):

PN~

®NoO O

Boot with the VMware ESX Server CD.

When prompted, press Enter to boot in graphical mode.

Press Enter to skip the media test.

Click Next through the following screens (accepting the default options): Welcome, Select Keyboard,
Select Mouse, and License Agreement.

Select Recommended for the disk partitioning option, and click Next.

When the warning appears that all partitions will be lost, click Yes.

Click Next to accept the partition disks settings.

At the advanced options screen (the default option is to boot VMware ESX Server from the hard drive),
click Next.

Enter the static IP address (192.168.0.250) and subnet mask (255.255.255.0), and click Next.

. Select the time zone, and click Next.

. Enter the root password, and click Next.

. At the about to install screen, click Next to start the installation.

. When the server installation completes, click Finish to reboot the server.

Installing Virtual Infrastructure Client on the controller

We managed VMware ESX Server with a separate system we call the controller. We ran Microsoft Windows
Server 2003 Enterprise Edition on this system and connected it to the VMware ESX Server with a network switch.
We followed this process to install the necessary VMware Infrastructure Client software on this system.

1.

Pobd
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On the remote client, open a Web browser, and type the server’s IP address (http://192.168.0.250) in the
address pane.

At the VMware ESX Server 3 Welcome page, select download the VMware Infrastructure Client.

When the file download security warning pops up, click Run to install the client software.

Install the client software by clicking Next through the installation option windows (which accepts all
default options).

When the installation completes, click Finish.

Close the Web browser window.

Launch the VMware Infrastructure Client application by double-clicking the desktop icon.

At the client log in screen, enter the VMware ESX Server IP address (192.168.0.250), root user, and
password, then click Log on.

Before you can properly use the VMware ESX Server, you must first install a license file. You can deploy
that file with either host-based or server-based licensing. For our testing, we used the host-based license
method by following these steps:

a. Toinstall the license, click the Configuration tab in the Virtual Infrastructure Client.

b. Under the Software section on the left side of the screen, click Licensed Features.

c. Make sure the license file (which VMware should have provided with the copy of VMware ESX
Server) is on the controller.

Click Edit next to the License Sources.

In the pop-up window, select Use Host License File.

Click the browse button, and browse to the location of the license file on the server.

Click open to select the file.

Click Edit next to VMware ESX Server License Type.

Select VMware ESX Server Standard, and click OK.

@™o
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Configuring network adapters with Virtual Infrastructure Client

Before we set up the VMs, we had to configure the network adapters on the VMware ESX Server. To
accommodate all the network traffic the test required, we used three network ports on the VMware ESX Server,
as Figure 11 illustrates.

We assigned the External Network port the IP address of 192.168.0.250 during the VMware ESX Server
installation, because this is the network port that the Virtual Infrastructure Client, and the database, Java, and idle
VMs use to communicate.

The remaining two network ports are part of the Internal Network, on which the Web and mail server traffic
travels. We configured one network port to handle traffic from the Web and mail VMs for CSU number 1 and the
other to handle the Web and mail traffic for CSU number 2.

We did the following to configure the VMware ESX Server for the network adapters:

Within the Virtual Infrastructure Client window, select the configuration tab for the VMware ESX Server.
In the hardware section, select networking to view the network setup.
Click Properties for Virtual Switch vSwitchO.

In the vSwitchO Properties window, highlight the Virtual Machine Network, and click Edit.
Rename the Network Label to External Network.

Click OK to close the window.

Click Close to close the Properties window.

On the Networking configuration tab, click Add Networking.

Select Virtual Machine for the connection type, and click Next.

10. Under Create a virtual switch, select vmnic1, and click Next.

11. Change the Network Label to Internal Network, and click Next.

12. At the summary page, click Finish.

13. At the Networking configuration tab, click Add Networking.

14. Select Virtual Machine for the connection type, and click Next.

15. Under Create a virtual switch, select vmnic2, and click Next.

16. Change the Network Label to Internal Network, and click Next.

17. At the summary page, click Finish.

18. At the Networking configuration tab, click Properties next to vSwitch1.
19. Highlight vSwitch under the configuration section, and click Edit.

20. Use the drop-down arrow to change the number of ports to 24.

21. Click OK to close.

22. On the Networking configuration tab, click Properties next to vSwitch2.
23. Highlight vSwitch under the configuration section, and click Edit.

24. Use the drop-down arrow to change the number of ports to 24.

25. Click OK to close.

©CoNoOOA~LON =

Creating a virtual machine

The steps below describe how we created a base virtual machine. We followed these basic steps to create each
of the VMs the test required. We list the exact parameters we specified for each VM in the section below on
installing and configuring that VM.

1. In Virtual Infrastructure Client, highlight the VMware ESX Server (localhost.localdomain).

2. Select File>New->Virtual Machine.

3. Select Custom on the Select the Appropriate Configuration screen, and click Next.

4. Enter the Virtual Machine Name, and click Next.

5. Select the Storage that will hold the VM, and click Next.

6. Select the Operating System for the VM, and click Next.

7. Use the dropdown box to select the number of virtual processors for the VM, and click Next.
8. Select the amount of memory for the VM, and click Next.

9. Select the Network Connection for the VM, and click Next.

10. Accept the default option for the SCSI Adapter, and click Next.

Principled Technologies, Inc.: Virtualization performance of Intel Xeon and AMD Opteron processor- 8
based servers using vConsolidate



11.

Leave the default option to create a new virtual disk on the Select a Disk screen, and click Next.

12. Enter the virtual disk size, and click Next.
13. Leave the default options for the Specify Advanced Options, and click Next.
14. Review the virtual machine summary, and click Finish to create the virtual machine.

To create one vConsolidate CSU, we had to create the five virtual machines that CSU describes:

mail server

Web server

Java application server
database server

idle server

The following subsections detail how we created and configured each of these VMs.

Installing and configuring the mail server VM

1.

aoRrwd

Follow the steps in the earlier Creating a virtual machine section using the following VM specifications:

e Name: MailServer1

e Virtual processors: 1

e Virtual memory: 1.5 GB

e Virtual Disk Size: 10 GB

e Virtual Network: Internal Network (set the IP address to 192.168.11.115 in Windows within the VM)
Install Microsoft Windows Server 2003, x64 Enterprise Edition in the VM.

Install Microsoft Windows Server 2003 Service Pack 2 with default settings.

Right-click the MailServer1 VM in the Virtual Infrastructure Client window, and select Install VMware tools.
Reboot the VM.

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Installing the domain controller

N>R~ LON =

15.

16.
17.
18.
19.
20.

Select Start->Administrative Tools->Manage Your Server.

Click Add or remove a role.

At the Configure Your Server window, click Next.

At the Configuration and Options screen, select Custom Configuration, and click Next.

At the Server Role screen, select Domain Controller, and click Next.

At the Summary of Selections screen, click Next.

At the Welcome pop-up window, click Next.

At the Operating System Compatibility screen, click Next.

For the Domain Controller Type, leave the default option (Domain controller for a new domain), and click
Next.

. At the Create New Domain screen, leave the default (Domain in a new forest), and click Next.

. At the Install or Configure DNS window, select No, and click Next.

. At the New Domain Name screen, type a domain name (vcon.com), and click Next.

. At the NetBIOS Domain Name screen, enter a NETBIOS domain name (vcon), and click Next.

. Click Next through the following screens: Database and Log Folders, Shared System Volume, and

Permissions. Doing so accepts the default options for each of those screens.

At the Directory Services Restore Mode Administrative Password screen, enter a password (password),
and click Next.

When the installation software prompts you to do so, insert the OS CD, and click OK.

At the Completing the Active Directory Installation Wizard screen, click Finish.

When the system prompts you to reboot the VM, click Restart Now.

After the VM reboots, login to the system.

At the This Server is Now a Domain Controller window, click Finish.
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Installing Internet Information Services 6.0

©CoNoOOA~WON =

10
11.

Select Start->Control Panel>Add or Remove Programs.

Click Add/Remove Windows Components.

Select Application Servers, and click Details.

Click ASP.NET, and make sure a check is showing in the check box.
Select Internet Information Services (IIS), and click Details.

Click NNTP Services and SMTP Services, make sure a check appears in both check boxes, and click OK.
Click OK to close the Application Server window.

At the Windows Components Wizard, click Next to begin the installation.
When the system prompts you to do so, insert the OS CD, and click OK.
At the Completing the Windows Components Wizard window, click Finish.
Close the Add or Remove Programs window.

Installing Exchange Server 2003

1.
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10.
11.
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Insert the Microsoft Exchange Server 2003 CD. The CD should automatically launch the installation
software.
Choose Exchange Server Enterprise Edition.
Run the Setup application.
Click the Exchange Deployment Tools link.
Click the Deploy the first Exchange 2003 Server link.
Click the New Exchange 2003 Installation link.
Click the Run ForestPrep now link.
a. When the compatibility issue notice appears, click Continue, and check the Don’t display this
message again box.
At the Welcome screen, click Next.
Accept the End User License Agreement, and click Next.
At Component Selection Screen, keep the defaults, and click Next.
Leave the default account information, and click Next.
Installation should start. (This process may take a while to complete.)
When the installation completes, click Finish.
turn to the Exchange Server Deployment Tools screen, and click the Run DomainPrep now link.
At the Welcome screen, click Next.
Accept the End User License Agreement, and click Next.
At Component Selection Screen, keep the defaults, and click Next.
At the insecure domain notice, click OK.
When the installation completes, click Finish.
eturn to the Exchange Server Deployment Tools screen, and click Run Setup Now.
At the Welcome screen, click Next.
Accept the End User License Agreement, and click Next.
At the Component Selection screen, the action for Microsoft Exchange should by default be Typical.
(If it is not, use the drop-down box to set it to Typical.)
Click Next.
For the Installation Type, select Create new Exchange Organization, and click Next.
Enter vcon as the Organization Name, and click Next.
Accept the Microsoft Exchange Server Licensing Agreement, and click Next.
Review the installation summary, and click Next.
The installation should start. (This process may take a while to complete.)
When the installation completes, click Finish.
Close the Exchange Server Deployment Tools window.
Install Microsoft Exchange Server 2003 Service Pack 2.
Insert the SP2 CD, and double-click setup exe.
Accept the default location to extract the file, and click OK.
After the extraction finishes, open Windows Explorer, and browse to the update.exe executable.
At the Welcome screen, click Next.
Select | agree to accept the License Agreement, and click Next.
At the Component Selection window, leave the default option (Update), and click Next.
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g. Verify the installation Summary, and click Next.
h. When the installation completes, click Finish.

12. In the Virtual Infrastructure Client console, add a new 90 GB virtual hard disk to this VM by doing the
following:

Right-click the MailServer1 VM, and select Edit Settings from the menu.

On the Hardware Tab, click Add.

For Select Device Type, choose Hard Disk, and click Next.

Select Create a new virtual disk, and click Next.

Set the Disk Capacity to 90 GB, and click Next.

At the Specify Advanced Options page, leave the default options, and click Next.

At the Read to Complete screen, click Finish.

Wait for the Reconfigure Virtual Machine task to complete. (The status will appear in the Recent

Tasks section, which is at the bottom of the Virtual Infrastructure Client window.)

13. Restart the VM by selecting Start->Shut down->Restart inside the MailServer VM.

14. In the MailServer VM, right-click My Computer, and select Manage.

15. In the Computer Management Console, select Disk Management.

16. When a Welcome to Initialize and Convert Disk Wizard window appears, click Next.

17. Select Disk 1 to Initialize.

18. At the Select Disk to Convert screen, leave the disk unchecked.

19. At the Completing the Initialize and Convert Disk Wizard screen, click Finish.

20. Right-click the Disk 1 unallocated box, and select New Partition.

21. At the Welcome screen, click Next.

22. Leave the partition type as Primary, and click Next.

23. Accept the default Partition Size, which should be the same as the Maximum disk space, and click Next.

24. Assign the drive letter E, and click Next.

25. Format the partition with the NTFS File system, enter Mail Store for the volume label, and click Next.

26. At the Completing the New Partition Wizard screen, click Finish.

27. The partition should begin formatting.

28. When the formatting completes, close the Computer Management console.

29. Select Start>All Programs—>Microsoft Exchange—> System Manager.

30. In the left-hand window pane, expand Servers and MailServer so the First Storage Group is visible.

31. Right-click First Storage Group, and select Properties.

32. Click Browse, and change the Transaction log and System path location to E:\.

33. Check the Enable circular logging box.

34. Click Apply.

35. When the pop-up message appears asking if you want to perform this task, click Yes.

36. When the message appears saying that all mounted stores are back online, click OK.

37. Right-click Mailbox Store under First Storage Group, and select Properties.

38. Select the Database tab.

39. Click Browse, and move the Exchange database and Exchange streaming database to E:\.

40. Check the This database can be overwritten by a restore box.

41. Click Customize next to Maintenance interval.

42. Remove all blue from the boxes so the system will not perform maintenance, and click OK.

43. At the Mailbox Store Properties window, click Apply.

44. When a warning message appears, click Yes.

45. When the message that the database files have been moved appears, click OK.

46. Click OK to close the Mailbox Store Properties window.

47. In the left-hand pane of the Virtual Infrastructure Client, right-click the MailServer1 VM, and select Install
VMware Tools.

48. At the Install Tools pop-up window, click OK.

49. Click Next through the Installation Wizard to install the VMware Tools. This process accepts all defaults.

50. When the installation completes, click Finish.

51. Click Yes to reboot the virtual machine.

S@moaooTy
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Installing and configuring the Web server VM

1.

4.
5,

6.

Follow the steps in the earlier Creating a virtual machine section using the following VM specifications:
e Name: WebServer1 (use WebServer for the Host Name in the VM)

e Virtual processors: 2

e Virtual memory: 1.5 GB

e Virtual Disk Size: 10GB

e Virtual Network: Internal Network (set the IP address to 192.168.12.215 in Windows within the VM)
Install Microsoft Windows Server 2003, Enterprise Edition in the VM.

Install Microsoft Windows Server 2003 Service Pack 2 with default settings.

Right-click the WebServer1 VM in the Virtual Infrastructure Client window, and select Install VMware
tools.

Reboot the VM.

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Installing Microsoft Internet Information Server
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Select Start->Administrative Tools>Manage Your Server.

Select Add or remove a role.

At the Configure Your Server window, click Next.

At the Configuration Options screen, select Custom configuration, and click Next.

At the Server Role screen, select Application Server, and click Next.

At the Application Server Options screen, select Enable ASP.NET, and click Next

At the Summary of Selections screen, click Next.

When the installation software prompts you to do so, insert the Operating System CD, and click OK.
When the installation completes, click Finish.

Close the Manage Your Server window.

Installing WebBench 5.0

1.

Insert the WebBench 5.0 CD into the Virtual Client, and connect with the Virtual CDROM.

2. Copy wbtree.exe from the \wb50\workload directory on the CD to C:\inetpub\wwwroot.

3. Double-click wbtree.exe to expand the workload. (This step will create a wbtree folder with all the test
data WebBench required.)

4. Create a cgi-bin folder in c:\inetpub\wwwroot.

5. After installing the WebBench controller, copy simcgi.exe from the controller machine in
C:\WebBench\Controller\Suites\WebBench\Examples directory to the Web server VM’s
C:\Inetpub\wwwroot\cgi-bin\ directory.

6. Right-click My Computer, and select Manage.

7. Expand Services and Applications, Internet Information Services, and Web Sites in the left-hand window
pane.

8. Click Default Web Sites.

9. Right-click the cgi-bin directory in the right-hand pane, and select Properties from the drop-down menu.

10. In the Execute permissions field, select Scripts and Executables, and click OK.

11. Using Windows Explorer, browse to C:\Inetpub\wwwroot\cgi-bin, right-click simcgi.exe, and select
Properties from the drop-down menu.

12. Select the Security tab, and grant Read/Read & Execute permissions to the user, Internet Guest Account.

13. Click OK to close simcgi.exe properties.

14. Close Windows Explorer.

15. In the Computer Management window, right-click the Default Web Server, and select properties from the
drop-down menu.

16. Select the HTTP Headers tab, and click the MIME Types button.

17. In the MIME Types window, click New.

18. In the Extension text box, enter .ex.

19. In the MIME type text box, enter application/octet-stream, and click OK.

20. Click OK again to close the MIME Types window and the Default Web Site Properties window.

21. In the Computer Management console, select Web Service Extension.
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22. Select All unknown CGI Extensions in the right pane, and click Allow.
23. Click Yes, you do want to allow All Unknown CGI Extensions in the pop-up window
24. Open a Web browser, and type the URL http://localhost/cgi-bin/simcgi.exe to verify you correctly installed

the WebBench files. You should see text about the system inside the browser window.

25. Close the Web browser.

Installing Certificate Server
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Select Start->Control Panel->Add or Remove Programs.

Click Add/Remove Windows Components.

Select Certificate Servers, and accept the CA Service warning.

Click Next.

Select Standalone root CA in the CA Type Windows, and click Next.

Enter WEBBENCH in the common name field, and click Next.

At the Certificate Database Settings screen, leave the default options, and click Next.
When the warning about stopping 1S appears, click Yes.

Click Yes to enable Active Server Pages.

10 When the installation completes, click Finish.

Creating a certificate request

1.
2.

In the Computer Management Console, right-click the Default Web site, and select Properties.

Select the Directory Security tab, and then click Server Certificate under Secure Communications to start
the Web Server Certificate Wizard.

At the Welcome screen, click Next.

Select Create a new certificate, and click Next.

Select Prepare the request now, but send it later, and click Next.

Type Default Web Site for the certificate name.

Use the default bit length (1024), and click Next.

Type MyWeb for the organization name and Development Dept for the organizational unit, and click Next.
Type the server name as the common name, and click Next.

. Enter your location information, and click Next.
. Save the certificate information to the default path and file name, and click Next.
. Verify the information that you have typed, and then click Next to complete the process and create the

certificate request.

. Click Finish to close the IIS Certificate Wizard.
. Click OK to close the Default Web Site Properties window.

Submitting a certificate request

Pob=

oo

7.
8.
9.
10.

Open a Web browser, navigate to http://localhost/CertSrv/, and press Enter.

Click Request a certificate.

Click Advanced certificate request.

Click Submit a certificate request by using a base-64-encoded CMC or PKCS #10 file, or submit a
renewal request by using a base-64-encoded PKCS #7 file.

Open the request document that you created in the "Create a certificate request” section.

Copy the contents of the document to a text box with the following format.

o - BEGIN NEW CERTIFICATE

REQUEST-----

REQUEST-------

Note: If you saved the document with the default name and location, it is located at C:\Certreq.txt. Be sure
to copy all of the content as we illustrated above.

Paste the contents of the document into the Web form’s Base64 Encoded Certificate Request text box.
Click Submit.

You should receive a Certificate Pending message in the Web browser.

Close the Web browser window.

Issuing and downloading a certificate

1.

Select Start->All Programs->Administrative Tools-> Certificate Authority.
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In the Certificate Authority window, expand the server name.

Click the Pending Requests folder.

In the pending request folder, right-click the pending certificate request that you just submitted, select All
Tasks, and then click Issue. (Note: After you select Issue, the certificate no longer appears in this window
and folder. It now resides in the Issued Certificate folder.)

Close the Certificate Authority window.

Open a Web browser, and type http://localhost/CertSrv/.

Click View the status of a pending certificate request.

Click the certificate request that you can see.

Click Download Certificate.

. Click Save in the File Download window.

. Save the certificate to C:\.

. Close the download complete pop-up window.
. Close the Web browser window.

Installing the certificate and setting up an SSL Web site
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8.
9.
10.
11.
12.

Open the Computer Management console by right-clicking My Computer, and selecting Manage.
Right-click the Default Web site, and select Properties.

Select the Directory Security tab.

Under Secure Communications, click Server Certificate. This step will start the Certificate Installation
Wizard.

At the Welcome screen, click Next.

Select Process the pending request and install the certificate, and click Next.

Browse to the location of the certificate that you downloaded in the Issue and download a certificate
section, and click Next.

Keep the default SSL Port, and click Next.

Verify the information is correct on the Certificate Summary page, and click Next.

Click Finish to complete the installation.

Click OK to close the Default Web Site Properties window.

Close the Computer Management window.

Configuring and testing the certificate

1.
2.

3.
4.

Open a Web browser, and type https://webbench/cgi-bin/simcgi.exe.

You may receive a security alert that states that the certificate is not from a trusted root CA. Click Yes to
continue to the Web page.

If the page appears, you have successfully installed the certificate.

Close the Web browser.

Installing and configuring the Java application server VM

1.

2.
3.
4

5.

Follow the steps in the earlier Creating a virtual machine section using the following VM specifications:
a. Name: JavaServer1
b. Virtual processors: 2
c. Virtual memory: 2 GB
d. Virtual Disk Size: 5 GB
e. Virtual Network: External Network (keep the default Windows Network DHCP settings)
Install Microsoft Windows Server 2003, x64 Enterprise Edition in the VM.
Install Microsoft Windows Server 2003 Service Pack 2.with default settings.
Right-click the JavaServer1 VM in the Virtual Infrastructure Client window, and select Install VMware
tools.
Reboot the VM.

To finish setting up this VM for vConsolidate, we had to install and modify an additional software component. The
following subsections detail the necessary installation processes.

Installing SPECjbb2005

1.

Copy the BEA JRockit JVM 1.5.0_10-b03 folder to the root of C: in the VM.
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Install SpecJBB2005 in the VM directory: ¢c:\vSpecJBB2005.
Add the BEA JRockit JVM to the Windows system path by doing the following:
a. Right click My Computer, and select Properties.
b. Select the Advanced tab, and click Environment Variables.
c. Inthe System variables section, select Path, and click Edit.
d. Add the following to the end of the Variable value string: C:\jrockit-jdk1.5.0_10\bin (jrockit-
jdk1.5.0_10 is the folder name of the JVM installation).
e. Click OK to close the Edit System Variable, Environment Variables, and System Properties
windows.
Open a command prompt by selecting Start->Run.
Type cmd, and click OK.
Change to the vSpecdBB2005 directory by typing cd C:\vSpecJBB2005, and then press Enter.
Type runit.bat, and press Enter to verify SPECjbb2005 starts.
Press Ctrl-C to stop the benchmark.
Confirm that you do want to stop the run by typing Y and pressing Enter.
O Copy the following files from the vConsolidate package to the VM directory C:\:
e Daemon.exe
o Kkillapp.exe.

Modifying SPECjbb2005
To run the vConsolidate benchmark, you must modify SPECjbb2005 as follows:

wn
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1. Modify the following three original source files in the SPECjbb directory (C:\SPECjbb2005\src\spec\jbb\)
by opening each file with WordPad and making the changes below. Save each file after you have made
the changes.

e Company.java
Change “private long measurement_time;” to “public long measurement_time;”.
Change “JBBuitil.SecondsToSleep((int) measurement_time);” to
“JBButil.SecondsToSleep(Long.MAX_VALUE/1000);".
e DeliveryTransaction.java
After the line “customerPtr.adjustBalance(matchingOrder.getTotalAmount());”, add the following lines:
int timerCount = 0;
timerCount = (short)JBButil.random(1,100);
if (timerCount == 1)
JBButil.milliSecondsToSleep(company.measurement_time);
e TransactionManager.java
Change “myTimerData.update TimerData(txntype, txntime);” to the following lines:
{
myTimerData.updateTimerData(txntype, txntime);
if (txntype==0 && myTimerData.getTransactionCount(0)%1000 == 0) {
int sum = 0;
for (int k=0; k<=5; k++)
sum += myTimerData.getTransactionCount(k);
System.out.printin("===="+this+":"+"===="+sum);
}

}
2. Open the command prompt by clicking Start->Run, type cmd, and press Enter.

3. At the command prompt, type cd C:\SPECjbb2005\src\spec\jbb\.
4. At the command prompt, type the following commands. Press Enter after each command:
o mkdir class
e "C:\Program Files\Java\jrockit-jdk1.5.0\bin\javac" -cp "C:\Program Files\Java\jrockit-
jdk1.5.0\jre\lib\rt.jar" -d class\ *.java infra\Util\* java validity\*.java ..\reporter\*.java
e cd class\
o "C:\Program Files\Java\jrockit-jdk1.5.0\bin\jar" -cf jbb.jar spec\jbb\*.class spec\jbb\infra\Util\*.class
spec\reporter\*.class
e "C:\Program Files\Javal\jrockit-jdk1.5.0\bin\jar" -cf check.jar spec\jbb\validity\*.class
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11.

Type exit to close the command prompt.

Open Windows Explore from the start menu.

Copy the jbb.jar and check.jar files from C:\SPECjbb2005\src\spec\jbb\class to C:\vSpecJBB2005\.
When the system asks if you want to overwrite files, click Yes to overwrite the original jbb.jar and
check.jar files.

Using Windows Explorer, navigate to C:\vSpecJBB2005, and open the SPECjbb.props file.

. Make the following changes to the SPECjbb.props file:

e Change “input.starting_number_warehouses=1" to “#input.starting_number_warehouses=1"
e Change “input.increment_number_warehouses=1" to “#input.increment_number_warehouses=1"
e Change “#input.sequence_of number_of warehouses=1234567 8" to
“input.sequence_of _number_of warehouses=2"
Note: Set the above parameter to be equal to the number of vCPUs you configured for Java
server VM.
e Change “input.measurement_seconds=240" to “input.measurement_seconds=10".
In the C:\vSpecdBB2005 directory, right click runit.bat, and change “set JAVAOPTIONS=-Xms256m -
Xmx256m” to “set JAVAOPTIONS=-Xms1000m —Xmx1000m -Xxthroughputcompaction -XXallocprefetch
-XXallocRedoPrefetch -XXcompressedRefs —XxlazyUnlocking -XXtlasize128k”

Installing and configuring the database server VM

1.
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Follow the steps in the earlier Creating a virtual machine section using the following VM specifications.

e Name: DBServer1

e Virtual processors: 2

e Virtual memory: 1.5 GB

e Virtual Disk Size: 10 GB

o Virtual Network: External Network (keep the default Windows Network DHCP settings)

Install Microsoft Windows Server 2003, x64 Enterprise Edition in the VM.

Install Microsoft Windows Server 2003 Service Pack 2.with default settings.

Right-click the DBServer1 VM in the Virtual Infrastructure Client window, and select Install VMware tools.
Reboot the VM.

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Installing Microsoft Internet Information Server
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Select Start->Administrative Tools->Manage Your Server.

Select Add or remove a role.

At the preliminary steps screen, click Next.

At the Server Role screen, select Application Server, and click Next.

At the Summary of Selections screen, click Next.

When the installation software prompts you to do so, insert the OS CD, and click OK.
When the installation completes, click Finish.

Close the Manage Your Server window.

Installing Microsoft SQL Server 2005
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11.

0.

Insert the SQL Server 2005 CD into the controller, and connect with the Virtual CD ROM.

Click the Server Components link under the Install section to begin the installation.

Accept the license agreement, and click Next.

Click Next to install the prerequisites.

After the prerequisites complete installing screen, click Next.

At the Welcome screen, click Next.

At the System Configuration Check, assuming everything has a status of success click Next.
Enter the registration information, and click Next.

At the Components to Install screen, select SQL Server Database Services, then click Advanced.
Instruct the software to install both the Database Services and Client Components by clicking the drop-
down arrow on both and selecting Entire feature will be installed on local hard drive.

Click Next to start the installation.
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12.
13.
14.
15.
16.
17.
18.

19.
20.

For Instance Name, leave the default option, and click Next.

At the Service Account screen, select Use the built-in system account (Local account), and click Next.
Keep the default option for Authentication Mode, and click Next.

For Collation Settings, leave the defaults, and click Next.

Accept the default Error and Usage Report Settings, and click Next.

At the Ready to Install screen, click Install to begin the installation.

When the installation software prompts you to do so, insert Microsoft SQL Server 2005 disk 2. Use the
Virtual CDROM to connect it to the VM, and click OK.

When the setup process completes, click Next.

Click Finish to complete the installation.

Creating the test database and generating data

1.
2.
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10.
11.
12.

13.
14.
15.

16.
17.

18.
19.

Select Start->Microsoft SQL Server 2005->SQL Server Management Studio.

In the Connect to Server window, use the drop-down menu next to Server name to select <Browse for
more>.

In the Browse for Server window, select the Network Servers tab, and wait for it to retrieve data.

When Database Engine appears, expand the menu, select DBSERVER1, and click OK.

At the Connect to Server window, the server name should be present.

Click Connect to connect to the server.

Right-click the Database folder in the left-hand window, and select New Database from the pop-up menu.
In the Database name field, type sbtest, and click OK.

Copy the following files from the vConsolidate package to the VM C:\ directory:

e vSysbench.exe

e Daemon.exe

o Kkillapp.exe.

Open a command prompt by selecting Start->Run, type cmd, and click OK.

In the command prompt, type cd \ to change to C:\.

To prepare the database, type “vsysbench.exe --test=oltp --oltp-table-size=100000 prepare”, and press
Enter.

When the command finishes, you see the C:\ prompt.

Type exit, and press Enter to close the command prompt.

In SQL Server 2005 Management Studio, stop the database service by right-clicking DBSERVER1 in the
left-hand window pane, and then select stop from the drop-down menu.

Using Windows Explorer, create the folder C:\backup.

With Windows Explorer, copy all sbtest files from C:\Program File\Microsoft SQL
Server\MSSQL.1\MSSQL\Data\ to c:\backup. (You should see two files: sbtest.mdf and sbtest_log.Idf.)
Close Windows Explorer once the copy completes.

Restart the database service using SQL Server 2005 Management Studio by right-clicking DBSERVER1
and selecting start.

Installing and configuring the idle server VM

1.
2.
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Follow the steps in the earlier Creating a virtual machine section using the following VM specifications.
Use the VM Specifications below:

e Name: IdleServer1

e Virtual processors: 1

e Virtual memory: 0.4 GB

Virtual Disk Size: 5 GB

Virtual Network: External Network (keep the default Windows Network DHCP settings)

Install Microsoft Windows Server 2003, Enterprise Edition in the VM.

Install Microsoft Windows 2003 Service Packs with the default settings.

Right-click the IdleServer1 VM in the Virtual Infrastructure Client window, and select Install VMware tools.
Reboot the VM.

Installing and configuring the second CSU
To create the VMs the second CSU requires, we used VMware Converter to make a copy of the five VMs we had
already created. We then started each VM and entered a new IP address and Host name. The following steps

Principled Technologies, Inc.: Virtualization performance of Intel Xeon and AMD Opteron processor-

17

based servers using vConsolidate



explain how to copy a VM with VMware Converter. They assume you have installed the VMware Controller on the
same machine as the VMware Virtual Infrastructure Client.

Open VMware Converter, and click Import Machine.

At the Welcome screen, click Next.

At the Source screen, click Next.

Select VMware ESX Server for the Source, and click Next.

Enter the IP address, user name, and password of the VMware ESX Server, and click Next.

Select the virtual machine that you want to copy (for example: JavaServer1), and click Next.

For the Source Data, leave the default (Import all disks and maintain size), and click Next.

At the Destination screen, keep the default, and click Next.

. For Destination Type, select VMware ESX server, and click Next.

0. Enter the IP address, user name, and password of the VMware ESX Server, and click Next.

1. Enter the virtual machine name (for example, if you are copying JavaServer1, the name of the second
one should be JavaServer2), and click Next.

12. Select the host system, and click Next.

13. Select the Datastore, and click Next.

14. Select the Network connection for the virtual machine, and click Next.

15. Leave the default Customization settings, and click Next.

16. Review the summary, and click Finish to begin copying the virtual machine.
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Registry changes
To simplify testing, we made three registry changes to every VM we created.

Auto logon
We changed this entry to allow each VM to automatically log into the OS after a system reboot. We changed the
following Registry key to have the values we show here.

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
o "DefaultPassword"="password"
e "AutoAdminLogon"="1"
e "DefaultUsername"="administrator"

Computer name
We changed this entry to display the host’s name of the system under the My Computer desktop icon. We
changed the following Registry key to have the values we show here.

[HKEY CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002830309D)]
e "LocalizedString"=hex(2):25,00,43,00,4f,00,4d,00,50,00,55,00,54,00,45,00,52,00,\
4e,00,41,00,4d,00,45,00,25,00,00,00

Desktop
We changed this entry to display the OS version on each VM’s desktop in the lower right-hand corner. We
changed the following Registry key to have the values we show here.

[HKEY_CURRENT_USER\Control Panel\Desktop]
¢ "PaintDesktopVersion"=dword:00000001
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Client installation
In addition to setting up the server under test, we also had to set up the client systems we show in Figure 11. Both
the WebBench and LoadSim workloads require test clients.

Installing the WebBench 5.0 test client systems

To run WebBench, you need two types of test systems. WebBench clients use WebBench software engines to
send HTTP requests to stress the server under test. A single WebBench controller system manages the clients
during as the benchmark runs.

Installing a WebBench 5.0 client
1. Install Windows 2003 Enterprise Edition 32-bit. Use mailclient as the system name.
2. Install Windows Server 2003 Service Pack 2 with the default settings.
3. Open the Network Connections window by right clicking My Network Places and selecting Properties from
the menu.
Right-click the network connection, and click Properties.
Highlight TCP/IP, and select Properties.
Select Use the following IP address, and enter the following information: IP address 192.168.12.211,
Subnet 255.255.255.0.
Click OK to close the two Properties windows.
Insert the WebBench CD, and open it with Windows Explorer.
Run setup.exe from the location /wb50/client/setup.exe.
. Click Next through all screens, a process that accepts the defaults.
. When the installation completes, copy the WebBench shortcut icon from the open window to the system’s
desktop.
12. Close the open windows, and eject the CD.
13. With WordPad, open the file c:\Windows\system32\drivers\etc\hosts.
14. After the last text in that file, enter the following additional lines, and click Save.
e 192.168.22.210 controller
e 192.168.22.215 server
15. Close the hosts file and Windows Explorer.
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Installing the WebBench 5.0 controller

We used a single system as both the WebBench 5.0 controller and the vConsolidate controller. We discuss the
specifics of the vConsolidate controller in a later section. We followed this process to set up that system as the
WebBench 5.0 controller.

Install Windows 2003 Enterprise Edition 32-bit. Use mailclient as the system name.
Install Windows Server 2003 Service Pack 2 with the default settings.
Insert the WebBench 5.0 CD.
Run /wb50/controlr/setup.exe.
Click Next through the installation, which accepts all default options.
With Windows Explorer, open C:\WebBench\Controller\Clientids\client.cdb.
Add the client’s IP address to the top of the file. Enter Tab twice, and type the number 1.
Click File>Save, and close the client.cdb file.
Copy vConsolidate.tst file from the vCON\WebBench directory to
C:\WebBench\controller\suites\WebBench.
. Copy ecommerce_cgi_template_w2k3.tst and ecommerce_cgi_template_w2k3.wl files from
vCON\WebBench directory to C:\WebBench\controller\suites\WebBench.
11. Copy all files from \WCON_framework\WebBench_daemon in the vConsolidate package to C:\.
12. Select Start->All Programs—->PC Magazine Benchmarks—->WebBench 5.0 Controller.
13. Click Create/Edit from the Suites drop-down menu.
14. Browse to the vConsolidate.tst file, and click Open.
15. Highlight the first Mix, and click Edit.
16. On the General tab, change Engines per client to 8.
17. Select the Workload tab.
18. Change the number of threads to 1.
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19.
20.
21.
22.

Click the Copy across button.

Select the Engines per client and Number of threads check boxes, and click OK.
Click OK to close the suites windows.

Close the WebBench Controller window.

Installing the mail test client
Each mail server VM requires one physical test client system. We used the following process to set up each such

system.

A e e

7.
8.
9.

10.
11.
12.
13.
14.
15.
16.
17.
18.
19.
20.
21.

Install Windows 2003 Enterprise Edition 32-bit. Use mailclient as the system name.

Install Windows Server 2003 Service Pack 2 with the default settings.

Open the Network Connections window by right-clicking My Network Places and selecting Properties.
Right-click the network connection, and click Properties.

Highlight TCP/IP, and select Properties.

Select Use the following IP address, and enter the following information: IP address 192.168.11.110,
Subnet 255.255.255.0, Preferred DNS server 192.168.11.115 (MailServer1 IP address).

Click OK to close the two Properties windows.

Right-click My Computer, and select Properties.

Click the Computer Name tab.

Click the change button,

Select Domain in the member of section, and type the domain vcon.com into the text box.

In the pop-up window, enter administrator for user name, password for password, and click OK.

At the Welcome to the domain screen, click OK.

When the warning that you must restart dialog appears, click OK.

Click OK to close the System Properties window.

Click Yes to the pop-up message to restart the computer.

Login to the domain by using administrator and password.

Install Microsoft Outlook 2003 with the default settings. (Outlook 2003 doesn’t require any configuration.)
Install LoadSim 2003 by double-clicking the loadsim.msi installation file. Accept all defaults.

Open LoadSim 2003, and make sure no error messages appear.

Copy c:\Program Files\LoadSim\Islog.exe file to a floppy disk or USB thumb drive. You will need this file
during the vConsolidate controller installation.

Conflgurlng LoadSim 2003

Start LoadSim by clicking Start Menu—->All Programs->Exchange LoadSim—->LoadSim 2003.
From the LoadSim menu bar, select Configuration->Topology Properties.

Click the Servers tab.

In the left pane, click the + next to the name of this server.

In the left pane, select the First Storage Group.

In the right pane, set the number of users to 500.

Select the Security and Credentials tab.

Leave the Credentials choice set to Login to users using the account LoadSim is running on.
In the password portion of the tab, enter the password "Password1", and click OK.

. From the LoadSim menu bar, select Configuration->Test Properties, and click Add.
. Click Customize Tasks.

. Select the Initialization tab.

. Enter the following settings:

e Number of messages in Inbox: 150

Number of messages in Deleted items: 1

Number of new folders: 2

Messages per new folder: 100

Number of Smart Folders: 3

Number of Rules in Inbox: 5

Initialize Free/Busy Information: Leave it unselected
Number of appointments: 25

Number of contacts: 64
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14. Click OK.

15. Check Forever (stop manually) in the Test Properties window, and click OK.

16. From the LoadSim menu bar, choose File->Save As.

17. Save a backup copy of the simulation file as C:\loadsim.sim.

18. From the LoadSim menu bar, select Run->Create Topology, and wait until the Creating Users and
Creating DLs tasks complete.

19. From the LoadSim menu bar, select Run—->Initialize Test.

20. When a dialog box appears with the question Do you want to initialize Public Folders from this client
machine?, click Yes.

21. The run is complete when the bottom left corner of the LoadSim window shows Status: Idle. This task
typically takes about two to three hours to complete.

Back up the mail database
Once you’ve set up LoadSim and created its initial mail database, you need to back up that database so you can
have clean copies for each test. Use this process to back up that database.

Select Start->All Programs—>Microsoft Exchange—> System Manager in the MailServer VM.

In the left-hand pane, expand Servers until First Storage Group appears highlighted.

In the right-hand pane, right-click Mailbox Store, and select Dismount Store from the menu.
Click Yes on the Do you want to continue pop-up message.

When you've dismounted the Mailbox Store, a red arrow appears in the window pane.
Right-click Public Folder Store, and select Dismount Store from the menu.

Click Yes on the Do you want to continue pop-up message.

The red arrow will appear when you’ve dismounted the Public Folder Store.

Using Windows Explorer, create a new folder e:\backup.

10. With Windows Explorer, copy all files from E:\ to E:\backup. This process may take several minutes.
11. Close Windows Explorer.

12. In Exchange System Manager, right-click Mailbox Store, and select Mount Store from the menu.
13. Click OK on the pop-up message, The store was successfully mounted.

14. Right-click Public Folder Store, and select Mount Store from the menu.

15. Click OK on the pop-up message, The store was successfully mounted.

16. Close Exchange System Manager.
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vConsolidate controller

You use a separate physical system, the controller, to manage the vConsolidate workload. We used a single
section both for this function and as the controller system for the first CSU’s WebBench benchmark. This
controller offers a graphical user interface (GUI) to start and stop the vConsolidate workload. After the workload
finishes, the controller copies the independent benchmark result files from all the VMs and combines their results
into a single file, results.txt. To set up this vConsolidate controller, we did the following:

1. With Windows explore, create a C:\vCON directory.
2. Copy all files from the \vCON _ framework\controller directory of the vConsolidate package to c:\vCON.
3. Copy the Islog.exe file the mail client installation created to c:\vCON.

The vCON directory contains a Profiles sub-directory. The Profiles directory contains two sample profiles,
1CSU.profile and 2CSU.profile, and a blank template, Profile.template. vConsolidate uses these files to identify
the number and name of the VMs a test should include. An example 1CSU.profile contains the following:

<Profile>

<Name>1 CSU</Name>
<CSUNum>1</CSUNum>
<Servers>

<DB>

<0S>Win</0S>
<Host>DBServer1</Host>
</DB>
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<Loadsim>
<Host>192.168.202.110</Host>
</Loadsim>

<Java>

<0S>Win</0OS>
<Host>JavaServeri1</Host>
</Java>

<WebBench>
<Host>192.168.202.210</Host>
</WebBench>

</Servers>

</Profile>

Running vConsolidate

To run vConsolidate and get consistent results, you must first prepare the VMs with clean copies of the test data.
We outline below the process for getting ready to run the workload. We then explain how to start and stop the
workload. Finally, we detail how to find its results.

Preparing the vConsolidate run
Prior to running vConsolidate we do the following to ensure consistent results.

Database restore

1.

In SQL Server 2005 Management Studio, stop the database service by right-clicking DBSERVER1 in the
left-hand window pane and selecting stop from the drop-down menu.

Using Windows Explorer, copy sbtest.mdf and sbtest_log.Idf from C:\backup.

With Windows Explorer, paste the sbtest files into C:\Program File\Microsoft SQL
Server\MSSQL.1\MSSQL\Data\

Click Yes on the pop-up message asking if you want to replace these files.

Close Windows Explorer once the copy completes.

Restart the database service using SQL Server 2005 Management Studio by right-clicking DBSERVER1
and selecting start.

Mail store restore
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Select Start->All Programs->Microsoft Exchange—> System Manager.

In the left-hand pane, expand Servers until First Storage Group appears highlighted.

In the right-hand pane, right-click Mailbox Store, and select Dismount Store from the menu.

Click Yes on the Do you want to continue pop-up message.

When you've dismounted the Mailbox Store, a red arrow appears in the window pane.

Right-click Public Folder Store, and select Dismount Store from the menu.

Click Yes on the Do you want to continue pop-up message.

When you've dismounted the Public Folder Store, a red arrow appears in the window pane.

Using Windows Explorer, delete all files in E:\, but be sure not to delete the backup directory you created
in the Backup the mail database section.

. With Windows Explorer, copy all files from E:\backup to E:\. This process may take several minutes.
. Close Windows Explorer.

. In Exchange System Manager, right-click Mailbox Store, and select Mount Store from the menu.

. Click OK on the pop-up message, The store was successfully mounted.

. Right click Public Folder Store, and select Mount Store from the menu.

. Click OK on the pop-up message, The store was successfully mounted.

. Close Exchange System Manager.

Verify connectivity and setting profiles

1.

Open a command prompt by selecting Start>Run, type cmd, and click OK.

2. Type the following commands at command prompt:
e net use \\loadsim client IP Address\c$
e net use \\JavaServer1\c$
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e netuse \\DBServer1\c$
e net use \WebBench Controller IP Address\c$

3. Verify that the vConsolidate controller can read and write remote files to all VMs with the following
commands:

With Windows Explorer, create an empty file, dummy.txt.

copy dummy.txt \\loadsim client IP Address\c$

copy dummy.txt \JavaServer1\c$

copy dummy.txt \DBServer1\c$

copy dummy.txt \WebBench Controller IP Address\c$

4. Modify the profile file by entering the VM name or IP address appropriate to each VM in the test. For the
one-CSU test, enter four server names or IP addresses; for the two-CSU test, enter eight.

Starting and stopping vConsolidate

1. Shut down all VMs by selecting Start->Shutdown and then selecting Shutdown from the window.

2. Inthe left-hand pane of the Virtual Infrastructure Client window, highlight localhost.localdomain.

3. Select the Summary tab in the right hand pane.

4. Click Reboot under the Commands section.

5. While the server is rebooting, reboot all clients in the test bed.

6. After the VMware ESX Server has rebooted, login using the Virtual Infrastructure Client, and start all VMs
in the test.

7. Once the VMs are up, log the LoadSim client(s) into the appropriate domain(s).

8. Double-click Daemon.exe manually on the following VMs and systems:

a. DataServer1

b. JavaServer1

c. LoadSim client

d. WebBench controller

9. Start the WebBench Controller application on the WebBench controller system by selecting Start->All
Programs—->PC Magazine Benchmarks.

10. In the WebBench Controller application, choose the Clients menu, and click Start Log In.

11. Double-click the WebBench 5.0 client shortcut on all the WebBench test client desktops.

12. Once all the client machines are log into WebBench, click OK.

13. At the Would you like to add a test suite? dialog, click Yes.

14. In the Select a test suite window, choose vConsolidate.tst, and click OK.

15. When the Would you like to start executing the test suites? window appears, do NOT click Yes or No. The
vConsolidate controller application will handle that task that at the start of the test.

16. Double-click c:\vCON\vconsolidate.exe.

17. Select the profile name you want to run.

18. Wait 10 minutes to allow all virtual machines and VMware ESX Server to load all processes and become
completely idle.

19. Click start.

20. The vConsolidate controller software will immediately start the LoadSim application. LoadSim will take
about 60 to 80 seconds to log 500 users onto the Exchange Server. The remaining benchmarks will start
once all the LoadSim users have logged in.

21. After about 30 minutes, as soon as you see the WebBench workload(s) complete, click Stop!.

22. The vConsolidate controller application will stop all the other benchmarks and collect their results.

Locating and interpreting the results file
vConsolidate places all result data in the following location:

¢:\vCON\vCONMM-dd-hh-mm

where MM is the month, dd is the day, hh is the hour, and mm is the minute of the test. The file result.txt in that
directory summarizes all the results. It contains the following information:

e Java transaction score
e Database transaction score
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e Mail transaction score
o Web server throughput
e Start and stop times

Figure 8 shows an example results.txt file for a test with one CSU. We highlighted each score with a red line and
a brief description. See the Test results section for more information on how we used these individual results to
calculate each server’s overall score on the workload.

B result.txt |i”ﬁ”z|
File Edit Format View Help

L Java 8
IFT sum=32354673 o3 =C0®
DE Trans Number=231093—— .

Database Scare LoadSim Score

—————————— TEMP. TXT
weighted Avg 60 14015 122 215 132 68 <--"score"”

—————————— VCONSOLIDATE. RLG

A,4_client, 8,/1706. 959, 6908069. 563, 0,
A,4_client, 8,/1622.183, 6576748. 875, 0,
A,4_client, 8,/1558. 335, 6241389, 500, 0,
11:24:39,921
12:15:44.140

WebBench Score

Figure 8: vConsolidate results file example for 1 CSU.
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Appendix A — Test system configuration information
This appendix provides detailed configuration information about each of the test server systems, which we list in
alphabetical order.

Systems

Dell PowerEdge 2950
with Dual-Core Intel
Xeon processor 5160

Dell PowerEdge 2950
with Quad-Core Intel
Xeon processor X5355

HP ProLiant DL385 G2
with Dual-Core AMD
Opteron processor
model 2220

General

Number of processor

2 2 2
packages
Number of cores per
2 4 2
processor package
Number of hardware
1 1 1
threads per core
CPU
Vendor Intel Intel AMD
Name Dual-Core Intel Xeon Quad-Core Intel Xeon Dual-core AMD Opteron
processor 5160 processor X5355 processor Model 2220
Stepping 4 7 F2
Socket type LGA 771 LGA 771 F
Core frequency (GHz) 3.0 GHz 2.66 GHz 2.8 GHz
System bus 1333 MHz 1333 MHz 2000 MHz
HyperTransport
L1 Cache 32 KB + 32 KB (per core) | 32 KB + 32 KB (per core) | 64 KB + 64 KB (per core)
L2 Cache 4 MB (shared by 2 2 x4 MB (each 4 MB 2% 1MB
cores) shared by 2 cores)
Platform

Vendor and model number

Dell PowerEdge 2950

Dell PowerEdge 2950

HP ProLiant DL385 G2

Motherboard model number

DT021

DT021

414109-B21

Serverworks HT-2100

Motherboard chipset Intel 5000X Intel 5000X Northbridge and HT1000
Southbridge chipset
Motherboard revision X00 X00 oD
number
Motherboard serial number | 9RL2H91 9RL2H91 USEG642N4CJ
BIOS name and version Dell 1.2.0 Dell 1.2.0 AQ9 08/24/2006
BIOS settings Default Default Default
Memory module(s)
Hynix Hynix Hynix

Vendor and model number

HYMP525F72BP4N3-Y5
AC

HYMP525F72BP4N3-Y5
AC

HYMP525P72BP4-Y5
AB-A

Type

PC2-5300F-555-11

PC2-5300F-555-11

PC2-5300P-555-12

based servers using vConsolidate

FBDIMM FBDIMM DIMM
Speed (MHz) 667 667 667
Speed in the system
currently running @ (MHz) 667 667 667
Timing/Latency (tCL-tRCD-
iRP-tRASMin) 5-5-5-15 5-5-5-15 5-5-5-15
Size 16 GB 16 GB 16 GB
Number of RAM modules 8 (2 GB modules) 8 (2 GB modules) 8 (2 GB modules)
Chip organization Double-sided Double-sided Double-sided
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Hard disk

Vendor and model number | Seagate ST9146802SS | Seagate ST9146802SS | Seagate ST9146802SS
Number of disks in system 5 5 5

Size 146 GB 146 GB 146 GB

Buffer Size 16 MB 16 MB 16 MB

RPM 10,000 10,000 10,000

Type SAS SAS SAS

Controller Dell PERC 5/i Integrated | Dell PERC 5/i Integrated | HP Smart Array E200

Controller driver

scsi0

scsi0

cciss

Operating system

Name VMware ESX Server VMware ESX Server VMware ESX Server

Build number 3.0.1 3.0.1 3.0.1

File system ext3 ext3 ext3

Kernel 2.4.21-37.0.2.ELvmnix 2.4.21-37.0.2.ELvmnix 2.4.21-37.0.2.ELvmnix

Language English English English

Graphics

Vendor and model number | ATI ES1000 ATI ES1000 ATI ES1000

Chipset ES1000 ES1000 ES1000

Type Integrated Integrated Integrated

Memory size 16 MB 16 MB 32 MB

Resolution 800x600 800x600 800x600

Driver VMware 11.2.0.0 VMware 11.2.0.0 VMware 11.2.0.0
(Windows VM) (Windows VM) (Windows VM)

Network card/subsystem

Vendor and model number

Dual embedded
Broadcom NetXtreme I
5708 Gigabit Server

Dual embedded
Broadcom NetXtreme I
5708 Gigabit Server

Dual Embedded HP
NC373i Multifunction

Adapter Adapter Gigabit Server Adapters
Type Integrated Integrated Integrated
Driver eth0, eth1 ethQ, eth1 ethO, eth1
Additional NIC vendor and Intel PRO/1000 PT Dual | Intel PRO/1000 PT Dual | Intel PRO/1000 PT Dual
model number Port Server Adapters Port Server Adapters Port Server Adapters
Type PCI Express PCI Express PCI Express
Driver 1000 1000 1000
Optical drive
HL Data Storage GCR- HL Data Storage GCR-
Vendor and model number 8240N 8240N HP DV-W28E
Type CD-ROM CD-ROM DVD+/-RW
Interface IDE IDE IDE
Dual/Single layer Single Single Single
USB ports
Number 4 4 2
Type 2.0 2.0 2.0

Figure 9: Detailed system configuration information for the test servers.
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