A Principled Technologies report: Hands-on testing. Real-world results.

Lenovo ThinkBook 16p Gen 4:
Spend wisely and be a pacesetter

The science behind the report:

- , Lenovo ThinkBook 16p
m : Gen 4: Spend wisely and
= be a pacesetter

This document describes what we tested, how we tested, and what we found. To learn how these facts translate
into real-world benefits, read the report Lenovo ThinkBook 16p Gen 4: Spend wisely and be a pacesetter.

We concluded our hands-on testing on October 17, 2023. During testing, we determined the appropriate
hardware and software configurations and applied updates as they became available. The results in this report
reflect configurations that we finalized on September 21, 2023 or earlier. Unavoidably, these configurations may
not represent the latest versions available when this report appears.

Our results

To learn more about how we have calculated the wins in this report, go to http://facts.pt/calculating-and-highlighting-wins.
Unless we state otherwise, we have followed the rules and principles we outline in that document.

Performance benchmark results

Table 1: The table below represents our benchmark results in detail. Higher benchmark scores are better. We report the median score of

three runs for each test.

Lenovo ThinkBook 16p Gen 4

16-inch Apple MacBook Pro

Cinebench R23 vR23.200 (score, higher is better)

Multi-core 19,000 14,877

Single-core 2,065 1,718

Multi-core (sustained) 17,922 14,881

Single-core (sustained) 2,065 1,642

WebXPRT 4 on Google Chrome v116.0.5845.140

Overall score (higher is better) 336 298
Subscores (milliseconds, lower is better)
Photo Enhancement 254 242
Organize Album Using Al 1,068 1,681
Stock Option Pricing 66 71
Encrypt Notes and OCR Scan using WASM 658 686
Sales Graphs 162 239
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Lenovo ThinkBook 16p Gen 4

16-inch Apple MacBook Pro

Online Homework ‘ 1,431 ‘ 1,178
CrossMark™ v1.0.1.95 Pro (score, higher is better)
Overall | 1,898 | 1,818
Subscores
Productivity 1,771 1,602
Creativity 2,199 2,274
Responsiveness 1,500 1,356
Procyon® Office Productivity Benchmark v2.6.848 using Microsoft Office v2303 Build 16227.20318
Overall (rating, higher is better) 204,000 219,000
Subscores (higher is better)
Word 260,000 235,000
Excel 190,000 163,000
PowerPoint 172,000 277,000

Procyon Photo Editing Benchmark v2.6.848 using Adobe Photoshop v24.7.0 & Lightroom Classic v12.5 (score, higher is better)

Overall 7,411 7,363
Subscores
Image retouching 8,582 6,341
Batch processing 6,400 8,550
Speedtest® by Ookla® Wireless (Mbps, higher is better)
Download speed 784 721
Upload speed 596 446
Geekbench 6 v6.1.3 (score, higher is better)
CPU Single-core 2,825 2,817
PugetBench Adobe Creative Cloud® (score, higher is better)
5;2%t‘gench for Adobe Photoshop v0.93.7 using Adobe Photoshop 1236 1047
Blender Benchmark v3.5.0 (samples per minute, higher is better)
Monster render 1662.16 951.48
Junkshop render 959.09 515.25
Classroom render 826.89 464.17
HandBrake v1.6.1
Fast 1080p30 preset test
Encode time (mm:ss, lower is better) 2:00 2:01
Average frames per second (higher is better) 62.59 61.23
Hardware 4K H.265 encoder test
Encode time (mm:ss, lower is better) 0:55 1:10
Average frames per second (higher is better) 140.94 108.21
Topaz Video Al 3.3.4 FHD (frames per second, higher is better)
FHD Chronos 6.92 3.71
FHD CHFast 11.16 6.12
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Lenovo ThinkBook 16p Gen 4

16-inch Apple MacBook Pro

Topaz Video Al 3.3.4 4K (Frames per second, higher is better)

4K Artemis 4X 0.42 0.19
4K Proteus 4X 0.45 0.29
4K 4X Slowmow Apollo 3.02 2.53
4K APFast 11.77 10.98
4K Chronos 1.48 0.94
4K CHFast 2.82 1.40
Maxon Redshift 3D Renderer Benchmark v3.5.03

Render time (seconds, lower is better) ‘ 235 ‘ 422
MLPerf v3.1 - ResNet50 v1.5 (Offline)

Samples per second (higher is better) ‘ 8,132.24 ‘ 756.45

System and application responsiveness results

Table 2: The table below represents our hand-timed test findings in detail. Lower times are better. We report the median time of three

runs for each test.

Lenovo ThinkBook 16p Gen 4

16-inch Apple MacBook Pro

System boot and shutdown (seconds, lower is better)

Time to resume from sleep 15.56 19.38
Microsoft Office Word (seconds, lower is better)
Time to open 90MB Word document 0.8 0.9
Time to perform word Find/Replace 0.9 1.1
Microsoft Office Excel (seconds, lower is better)
Time to launch 0.7 0.8
Time to open 92MB Excel spreadsheet containing macro 10.7 12.7
Time to open 650KB 10K row Excel spreadsheet 0.6 0.8
Time to insert 3-D 100% Stacked Column Chart 16.5 21.4
Microsoft Office PowerPoint (seconds, lower is better)
Time to export 180MB PPTX to PDF ‘ 6.5 ‘ 8.3
Adobe Photoshop performance (seconds, lower is better)
Time to process and convert 50 RAW NEF images to JPEG format ‘ 70.6 ‘ 79.0
Zoom video conferencing
Table 3: The table below represents our CPU findings in detail. Lower percentages are better. We report the median
percentage of three runs.
Lenovo ThinkBook 16p Gen 4 16-inch Apple MacBook Pro
System maximum CPU utilization while using Zoom (percent utilization, lower is better)
Host, 1:1 meeting 18
Guest, 1:1 meeting 12
Host, 1:3 meeting 22
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Audio testing

Table 4: The table below represents our audio findings in detail. Lower LUFS are better and lower percentage of maximum volume output to
reach target dB is better. We report the median score of three runs for each test.

Lenovo ThinkBook 16p Gen 4 16-inch Apple MacBook Pro

Microphone noise reduction
Background fan volume (LUFS) ‘ NA (did not register the fan noise)
Speaker volume output required to reach 64 dB

‘ Registered audible noise at -41.6 LUFS

64 ‘ 75

Volume (percent, lower is better)
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System configuration information

Table 5: Detailed information on the systems we tested.

System configuration information

Lenovo ThinkPad 16p

Apple MacBook Pro 16

Processor

Vendor Intel® Apple
Model number Core™ i9-13900H M2
Core frequency (GHz) 4.1-5.40 3.68
Number of cores 14 12
Logical processors 20

Memory

Amount (GB) 32 32
Type DDR5 Unified
Graphics #1

Vendor Intel Apple

Model number

Intel Iris® X° Graphics

M2 38-core GPU

Graphics #2

Vendor NVIDIA® N/A
Model number GeForce RTX™ 4060 N/A
Driver 31.0.15.3734 N/A
Storage

Amount (TB) 1 1
Type SSD SSD

Connectivity/expansion

Wireless internet

Intel Wi-Fi 6E AX211

Wi-Fi 6E (802.11ax)

Bluetooth 5.2 53
usB 1 x SD card reader 1 x SDXC card slot
1xUSB-C 3.2 1x HDMI port
1 x Thunderbolt® 4 ports 3 x Thunderbolt 4 ports
2x USB-A 3.2
1x HDMI® port
1x pogo-pin connector (for Magic Bay
accessories)
1 x Kensington Nano Security Slot
Battery
Type Integrated Lithium-polymer Integrated Lithium-polymer
Rated capacity (Whr) 84 100
Display
Size (in.) 16.3 16.2
Resolution 3,200 x 2,000 3,456 x 2,234
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System configuration information

Lenovo ThinkPad 16p

Apple MacBook Pro 16

Operating system

Vendor Microsoft Apple

Name Windows 11 Pro macOS Ventura
Version 22H2 Build 22621.2134 13.5.1

BIOS

BIOS name and version Lenovo LRCN34WW 8422.141.2
Dimensions

Height (in.) 0.78 0.44

Width (in.) 13.96 11.97

Depth (in.) 10.03 8.46

Weight (system) lbs. 4.85 2.70
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How we tested

Setting up the system (Windows)

Setting up and updating the OEM image

AN

Boot the system under test (SUT).

Follow the on-screen instructions to complete installation, using the default selections when appropriate.
Set the Windows (plugged in) Power Mode to Best Performance.

Set Screen and Sleep options to Never:

a. Right-click the desktop, and select Display settings.

b. From the left column, select System.

c. Click Power & Battery.

d. For all power options listed under Screen and Sleep, select Never.

Disable User Account Control notifications:

a. Select Windows Start, type UAC, and press Enter.
b. Move the slider control to Never notify, and click OK.

Run Windows Update, and install all updates available.
Verify the date and time are correct, and synchronize the system clock with the time server.
Pause Automatic Windows Updates:

a. Click the Windows Start button.
Type Windows Update settings and press Enter.

a. From the Pause updates drop-down menu, select Pause for 5 weeks.

Setting up the system (macOS)

Setting up and updating the OEM image

1.
2.
3.

Boot the SUT.
Follow the on-screen instructions to complete installation, using the default selections when appropriate.
Set Screen and Sleep options to Never:

Select System Settings.

Select Screensaver.

Set Lock Screen Settings to Never.

Return to System Settings, and select Battery.

oo oo

Set On power adapter setting to High Power.
Disable Automatically adjust brightness:

a. Select System Settings.
b. Select Display.
c. Disable Automatically adjust brightness.

Run Software Update, and install all updates available.
Verify the date and time are correct.
Enable Automatic log in:

a. Select System Settings.
b. Click Users & Groups.
c. Select the drop-down menu next to the Automatically log in as setting, and select the User account.

Disable Automatic Mac Updates:

Select System Settings.

Click General.

Click Software Update.

Click the information icon next to Automatic updates.
Disable Check for updates.

e a0 oo
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Performance benchmark testing

Cinebench R23 benchmark testing

Setting up the Cinebench R23 test (Windows & macOS)

1. Download and install Cinebench from https://www.maxon.net/en/downloads/cinebench-r23-downloads.

Running the Cinebench R23 benchmark (Windows & macOS)

Launch Cinebench.

Select File>Advanced benchmark.

Set the Minimum Test Duration to Off.

Select either CPU (Multi Core) or CPU (Single Core), and click Start.
Record the result.

Wait 15 minutes before re-running.

Nooakrwbd-=

Repeat steps 1 through 6 two more times.

BAPCo CrossMark benchmark testing

Setting up the test (Windows & macOS)
1. Download and install CrossMark from the Microsoft Store or Apple App Store.

Running the test (Windows & macOS)

Launch CrossMark.

Click Settings.

For Number of Iterations, choose 1.

Enter a valid email address, and click Back.
Click Run Benchmark.

Record the result.

Noah~wDd =~

Repeat steps 1 though 6 two more times.

WebXPRT 4 benchmark testing (Google Chrome)

Running the test (Windows & macOS)

Open the Web browser under test, and go to https://www.principledtechnologies.com/benchmarkxprt/webxprt/.
Click Run WebXPRT 4.

At the Ready to test your browser screen, click Continue.

Click Start.

When the test completes, record the results.

Click Run Again, and click Start to rerun WebXPRT. Record the results.

Repeat step 6 two more times.

No ok~ wh =

Speedtest by Ookla testing

Setting up the test (Windows & macOS)

1. Download and install the Chrome web browser from https://www.google.com/chrome/downloads/.

Running the test (Windows & macOS)

Open the Chrome web browser, and go to https://www.speedtest.net/.
Verify that the systems under test are using the same server.

To start the benchmark, click Go.

Record the result.

areDN -

Repeat steps 1 through 4 twice more.
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Maxon Redshift 3D Renderer benchmark testing

Setting up the test (Windows & macOS)

1. Download and install the Maxon App from https://www.maxon.net/en/try.
2. Click the Maxon One 14-day trial, download it, and install the RedShift application.

Running the test (Windows)

Open a command prompt by clicking the Windows icon on the bottom left of your desktop, typing cmd and then pressing enter.
Inside the command prompt, type cd C:\ProgramData\Redshift\bin and press Enter.

To start the benchmark, type RunBenchmark.bat and press Enter.

Record the results.

Wait 5 minutes before performing the next run.

Repeat steps 1 through 5 twice more.

ok wbhN =~

Running the test (macOS)

Open a terminal window by opening the Launchpad, typing Terminal and pressing enter.
Inside the terminal, type cd /Applications/redshift/bin and press Enter.

To start the benchmark, type sh runBenchmark. sh and press Enter.

Record the results.

Wait 5 minutes before performing the next run.

Repeat steps 1 through 5 twice more.

S e

PugetBench Adobe Creative Cloud benchmark testing

Puget Systems Adobe CC benchmarks are designed to thoroughly test many of Adobe’s most popular software packages using real world
projects and workflows.

PugetBench for Photoshop testing

We used the following application:

* Adobe Photoshop

Setting up the test (Windows & macOS)

1. Launch Adobe Photoshop.

2. Click through the Tutorial pop-up tips.

3. Close Adobe Photoshop.

4. Purchase and download the PugetBench for Photoshop license from https://www.pugetsystems.com/labs/articles/PugetBench-for-
Adobe-Creative-Cloud-1642/.

5. Click Get on Adobe Marketplace, and log into your Adobe account.

6.  Click the PugetBench Photoshop Plug-in to install it.

7.  Open Adobe Photoshop.

8.  Click Window->Extensions>PugetBench for Photoshop.

9. Next to License Key, click Change, and enter your license key. Click Save.

Running the test (Windows & macOS)

Boot the system.

Open Adobe Photoshop.

Click Window->Extensions—>PugetBench for Photoshop.
Click Run Benchmark.

Record the overall score when the benchmark finishes.
Close Adobe Photoshop, and restart the SUT.

Wait 15 minutes before performing the next run.

® NOo Uk whN =

Repeat steps 1 through 7 twice more, and record the median result.
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Blender benchmark testing

Setting up the test (Windows & macOS)

1. Download the Blender Benchmark from https://opendata.blender.org/.

Running the test (Windows & macOS)

Launch the Blender Benchmark.

At the Welcome screen, click Next.

Select Blender version 3.5.0, and click Next.

At the Benchmark Scenes screen, click Next.

At the Benchmark Device screen, select the GPU option, and click Start Benchmark.
Record the results.

Wiait 15 minutes before performing the next run.

© Nk wbh =

Repeat steps 1 through 7 two more times.
HandBrake video encoding testing

Setting up the Fast 1080p30 preset and Hardware 4K H.265 encoder tests

Download HandBrake from https://handbrake.fr/downloads.php
Install HandBrake with default options.

Copy the 4K file to be transcoded to the test system.

Launch HandBrake.

Browse to the 4K source file, click Open.

AR

Running the Fast 1080p30 preset test (Windows & macOS)

Click the Chapters tab, and uncheck the Create chapter markers box.

Click Start Encode.

When complete, click the Show Queue menu item to view the encoding statistics.
Repeat steps 1 through 3 two more times.

Hwnd -

Hardware 4K H.265 encoder test

The Lenovo tested with NVENC due to the NVIDIA graphics chip. The Mac tested with QSV encoder because NVENC is an
NVIDIA-only encoder.

Running the Hardware4K H.265 encoder test (Windows)

Click the Preset drop-down menu, and select H.265 NVENC 2160p 4K.

On the Video tab, change the Framerate (FPS) to 60.

Set the preset to Fast.

On the Chapters tab, uncheck the Create chapter markers box.

Click Start.

When complete, click the Show Queue menu item to view the encoding statistics.
Repeat steps 1 through 6 two more times.

No ok~ wh =

Running the Hardware4K H.265 encoder test (macOS)

Click the Preset drop-down menu, and select H.265 MKV 2160p 60.

Change the Format to MP4.

On the Filters tab, set all to Off.

On the Video tab, change the Video Encoder to H.265 (VideoToolbox).

Set the preset to Speed.

On the Chapters tab, uncheck the Create chapter markers box.

Click Start.

When complete, click the Show Queue menu item to view the encoding statistics.
Repeat steps 1 through 8 two more times

Vo Nk WD =
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Topaz Video Al testing

Setting up the test (Windows & macOS)

1. Purchase a Pro license, and download and install Topaz Video Al 3.3.4 from https://www.topazlabs.com/downloads.

Running the test in 3,480x2,160 (4K) (Windows & macOS)

Launch Topaz Al.

Close the activation window.

Select Process> Benchmark.

from the Input Resolution drop-down menu, select 3840x2160 (4K).
Click Benchmark.

When the test completes, record the results.

Wait 15 minutes before retesting.

© Nk wbh =

Repeat steps 1 through 7 two more times.

Hand-timed custom Microsoft 365 workflow scenarios

Time to complete the hand-timed Microsoft PowerPoint scenario

We recorded how long it took to launch PowerPoint, open a 180MB PowerPoint PPTX file, start a slideshow task, and export a PPTX to PDF.
A stopwatch is required for this test.

We used the following application:

® Microsoft PowerPoint (Windows v16.0.16731.20194 & macOS v16.76.1.23082301)

Running the test (Windows & macOS)

Simultaneously start the timer and launch PowerPoint.

Stop the timer when PowerPoint has loaded.

Browse to where the test PowerPoint file is located.

Simultaneously start the timer and open the PowerPoint file.

Stop the timer when the PowerPoint file has loaded, as indicated by all 33 slides appearing in the side bar, and record the results.
Simultaneously start the timer and press F5 to start the slide show.
Stop the timer when the slide show starts to play.

Exit the slide show.

9. Click File>Export->Create PDF/XPS.

10. Simultaneously start the timer and click Publish.

11. Stop the timer when the PDF has been created, and record the results.
12. Repeat steps 1 through 11 two more times.

© Nk wbd =

Time to complete the hand-timed Microsoft Excel scenario

We recorded how long it took to launch Excel, open a 92MB macro Excel XLSX file, open a 650KB 10K row Excel XLSX and insert a 3D 100%
stacked column chart into the 10K row spreadsheet. A stopwatch is required for this test.

We used the following application:

* Microsoft Excel (Windows v16.0.16731.20194 & macOS v16.76.23081101)

Running the test (Windows & macOS)

Simultaneously start the timer and launch Excel.

Stop the timer when Excel has loaded.

Browse to where the test Excel macro file is located.
Simultaneously start the timer and open the Excel macro file.
Stop the timer when the Excel file has loaded.

Close the macro test file.

Browse to where the test Excel 10K row file is located.

® NOo Uk wN =

Simultaneously start the timer and open the 10K row file.
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9. Stop the timer when the Excel file has loaded.

10. Click Insert, and select the drop-down menu next to the Insert Column or Bar Chart icon.
11. At the bottom of the drop-down menu, select More Column Charts.

12. Under the Column section, choose 3-D 100% Stacked Column.

13. Simultaneously start the timer and click Ok.

14. Stop the timer when the 3-D 100% Stacked Column Chart appears.

15. Repeat steps 1 through 14 two more times.

Time to complete the hand-timed Microsoft Word scenario

We recorded how long it took to launch Word, open a 90MB Word DOCX file, perform a find/replace task, and export a DOCX file to PDF. A
stopwatch is required for this test.

We used the following application:

* Microsoft Word (Windows v16.0.16731.20194 & macOS v16.49.23082301)

Running the test (Windows & macOS)

Simultaneously start the timer and launch Word.

Stop the timer when Word has loaded.

Locate the test Word file.

Simultaneously start the timer and open the Word file.

Stop the timer when the Word document has fully loaded.

Press CTRL + H/Control + H to bring up the Find/Replace dialog box.
In the Find What field, type I

In the Replace With field, type TEST

9. Simultaneously start the timer and select Replace All.

O NGO WN =

10. Stop the timer when Word has replaced every I.

11. Click File>Export->Create PDF/XPS.

12. Simultaneously start the timer and click Publish.

13. Stop the timer when the Word has exported the document to PDF.
14. Close the Word document. Do not save changes.

15. Repeat steps 1 through 14 two more times.
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Machine learning testing

Configuring Ubuntu 20.04 on Windows 11 WSL2 using NVIDIA CUDA

1. Confirm that hardware virtualization is enabled in the system BIOS.
2. Enable Hyper-V and Virtual Machine Platform in Windows:

a. Open an elevated PowerShell terminal.
b. Run the following commands, but decline the reboot until the final step.

Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V-All
Enable-WindowsOptionalFeature -Online -FeatureName VirtualMachinePlatform
shutdown /r /t 0

Download and install drivers from NVIDIA.com: https://www.nvidia.com/download/index.aspx.

If a professional GPU is installed, enable Error Correction Code in the NVIDIA Control Panel.

Confirm GPU configuration. From an elevated terminal session, run nvidia-smi to validate GPUs and drivers are recognized.
Verify ECC is enabled:

ok~ w

‘ nvidia-smi -g -d ECC ‘

7. Install Ubuntu 20.04:

‘ wsl.exe --install Ubuntu-20.04 ‘

8.  Follow the prompts to create an Ubuntu user name and password.
9. Exit the Ubuntu session.
10. Set default WSL instance to the new installation:

wsl --set-default Ubuntu-20.04

11. Update WSL2 to latest release:

wsl --update --pre-release

12. Reboot the system:

shutdown /r /t 0O

13. Open a new Terminal session to Ubuntu 20.04.
14. Update Ubuntu:

sudo apt update && sudo apt upgrade

Configuring the CM machine learning environment

1. Install prerequisites:

sudo apt install python3 python3-pip python3-venv git wget curl zliblg unzip

2. Modify the /etc/profile file by adding the following lines:

export PATH="/home/ptuser/.local/bin:$PATH"

export PATH="/usr/local/cuda-11.8/bin:$PATH"

export LD_LIBRARY PATH="/usr/local/cuda-11.8/1ib64"
export CUDA MODULE LOADING=LAZY
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3. Install CM:

‘ python3 -m pip install cmind

4. Exit, and restart terminal to add paths to environment.
5. TestCM:

‘ cm test core ‘

6. Use CM to pull the MLCommons GitHub repository:

‘ cm pull repo mlcommons@ck

Configuring WSL NVIDIA support
1. Install CUDA for Linux:

mkdir nvidia-prereq

cd nvidia-prereq

wget https://developer.download.nvidia.com/compute/cuda/11.8.0/1local_installers/
cuda_11.8.0_520.61.05 linux.run

sudo sh cuda_11.8.0_520.61.05_ linux.run

2. Test CUDA support:

‘ cmr "get cuda-devices"

3. Install CUDA into CM:

‘ cmr "get cuda"

4.  Install cuDNN & TensorRT:

cmr "get cudnn" --tar file=~/nvidia-prereg/cudnn-linux-x86_64-8.9.5.29 cudall-archive.tar.xz
cmr "get tensorrt _dev" --tar file=~/nvidia-prereq/TensorRT-8.6.1.6.Linux.x86_ 64-gnu.cuda-11.8.tar.gz

5. Install system dependencies:

cm run script "get sys-utils-cm" --quiet
cm run script "get python" --version _min=3.8
pip install packaging tgdm

Confirming GPUs are recognized by the CM environment

1. Run cmr get-cuda-devices
2. Confirm the devices listed match the system configuration.
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Configuring macOS

Installing Brew

1. Open a Terminal window.
2. Run /bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/HEAD/install.sh)"
3. Run these two commands in your terminal to add Homebrew to your PATH:

(echo; echo 'eval "$(/opt/homebrew/bin/brew shellenv)"') >> /Users/ptuser/.zprofile
eval "$(/opt/homebrew/bin/brew shellenv)"

Configuring the CM machine learning environment

1. Install Python prerequisites:

brew install python3 git wget curl

2. Install GCC:

brew install gcc

3. Install CM:

python3 -m pip install cmind

4. Add CM to path:

a. Runnano ~/.zprofile
b. Add the following line:

export PATH="$PATH:./Library/Python/3.9/bin"

c. Activate the new path: source ~/.zprofile
d. Close and reopen Terminal to ensure paths take effect.

5. Update pip:

/Library/Developer/CommandLineTools/usr/bin/python3 -m pip install --upgrade pip

6. Create the Python virtual environment:

python3 -m venv ~/venv-metal
source ~/venv-metal/bin/activate
python -m pip install -U pip

7. Install tensorflow and tensorflow-metal into the Python virtual environment:

python -m pip install tensorflow
python -m pip install tensorflow-metal

8.  Pull mlcommons CM repo:

cm pull repo mlcommons@ck
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Verifying installation
1. Run Python:

python

2. Input and execute the following code block. If results return, the test was successful.

import tensorflow as tf
cifar = tf.keras.datasets.cifar100
(x_train, y train), (x_test, y test) = cifar.load data()
model = tf.keras.applications.ResNet50 (
include_top=True,
weights=None,
input_shape=(32, 32, 3),
classes=100,)
loss_fn = tf.keras.losses.SparseCategoricalCrossentropy(from logits=False)
model.compile (optimizer="adam", loss=loss fn, metrics=["accuracy"])
model.fit (x_train, y train, epochs=5, batch_size=64)

The ML testing scripts

ResNet-50 - CUDA

cmr "generate-run-cmds inference _find-performance" \

--model=resnet50 \
--implementation=nvidia-original \
--device=cuda \

--backend=tensorrt \
--category=edge \

--division=open \
--execution-mode=valid \
--results_dir=$HOME/MLPerf OOB \
--quiet \

--clean

ResNet-50 - Metal

cmr "generate-run-cmds inference _find-performance" \
--model=resnet50 \
--backend=tf \
--category=edge \
--division=open \
--execution-mode=valid \
--results_dir=$HOME/MLPerf OOB \
-—quiet \
--clean
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Video-conferencing testing

Preparing to install Zoom (Windows)

Open Edge.
Navigate to https://zoom.us/downloads.
Under Zoom Desktop Client, click Download.

N

When the file is done downloading, click Open File to begin the installation.

Installing Zoom (Windows)

1. Inthe Installer, click Continue.
2. Click Yes to allow Zoom to install on Allow this program to make changes to your device.
3. When the installation finishes, click Done.

Configuring Zoom (Windows)

1. Right-click the Zoom icon in the tray, and click Check for Updates.

2. Click Ok to download updates.

3. Click Install to install updates.

4. If there are no updates, click Close.

5. Right-click the Zoom icon in the tray, and click Settings.

6. Under General, enable Enter full screen when starting or joining a meeting.
7. Under Preferences, click Video.

8. Click OK to allow Zoom access to the Camera.

9. Click Audio.

10. Click OK to allow Zoom access to the microphone.
11. Enable Automatically join computer audio when joining.
12. Click Share Screen.

Preparing to install Zoom (macOS)

Open Safari.

Navigate to https://zoom.us/downloads.

Under Zoom Desktop Client, click Download.

When prompted to allow downloads from zoom.us, click Allow.

When the download is complete, click the download icon on the Mac taskbar, and select zoomuslnstallerFull.pkg.

a e~

Installing Zoom (macOS)

In the Installer, click Continue.

Click Install.

If prompted to enter user password, do so, and press enter. Otherwise, click Install.
Click OK to allow Installer to access files.

ok W=

When the installation completes, click Done.

Configuring Zoom (macOS)

Navigate to the menu at the top of the screen, and click Check for Updates.
Click Ok to download updates.

Click Install to install updates.

Under General, enable Enter full screen when starting or joining a meeting.
Under Preferences, click Video.

Click OK to allow Zoom access to the Camera.

Click Audio.

Click OK to allow Zoom access to the microphone.

Enable Automatically join computer audio when joining.

Click Share Screen.

Enable Side-by-Side Mode.

TSV NO O~ WDN =
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Configuring the Zoom account on the Zoom.com portal

Navigate to Zoom.us, and sign into the admin account you will use to host the Zoom calls.
Navigate to Settings, under Personal.

Click Meeting.

Scroll down and enable the following:

AN

* Start meetings with host video on.

e Start meetings with participant video on. Participants can change this during the meeting.

Configuring the host for a Zoom call

Click Sign in to log into Zoom.

Enter Username.

Enter Password.

Check Keep me signed in.

Click Sign in.

Close out of the Zoom experience by pressing the X in the top right of the pop-up window.

On the Zoom landing page, click the down arrow under New Meeting, and check to enable Use my Personal Meeting ID (PMI).

No ok~ wh =

Notes on testing

* Once in the call, we used screen share to display a PowerPoint.
* To simulate talking that all devices could hear, we played audio from a YouTube video in the background.
* We pointed all devices at an oscillating fan to simulate movement for the duration of the test.

® The call lasted 10 minutes, starting from the time all devices were in the call, all cameras were on, a user had turned on screenshare,
and audio was playing .

Joining a Zoom call as a guest

1. Click Join a Meeting.
2. Enter the Personal Meeting ID of the host meeting.
3. Click Join.
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Audio quality testing
Note: We conducted testing in an audio room with an enclosed sound booth. In addition to the SUTs, we used one additional system,
located in the audio room. We connected this system to the speaker in the sound booth.

Pre-test setup

Install Audacity on each SUT, and confirm that there are no issues with on-board mic recording.
Install VLC media player as a consistent media player on all SUTs.
Trim the sample song so that a roughly 20-second sample of the loudest part of the song remains.

PwON =

Load the sample song file onto each SUT using a USB drive.
Microphone noise reduction

Setup

1. Place the Yamaha speaker in the sound booth, near the position where a laptop user would be speaking. Connect the speaker to the
audio room computer, on which you have loaded a speaking sample representative of normal conversation. Use this same sample for
each test for consistency.

2. Set the input volume of the onboard microphone to approximately 98%.

Place the SUT on the desk in the sound booth, and open Audacity. Measure the angle of screen tilt to maintain consistency across all
SUTs. Press Record, and exit the sound booth.

On the audio room computer, press Play to play the speaking sample (roughly 20 seconds long).
Enter the sound booth, and stop recording in Audacity.
Transfer the recorded file to the audio room computer to analyze in Pro tools.

No gk

To match the stereo format of the Lenovo device recording, duplicate the Mac's mono audio file and combine the two mono duplicates
into a single stereo track.

8.  Use FabFilter Pro L2 in the Integrated setting in Loudness mode to measure the average loudness of both clips. Using clip gain as
needed, level match clips to -21.1 LUFS. Note the volume difference of each system.

9. Add a fan in back corner of the sound booth, roughly 5 feet from the speaker. Keep the fan on and running at consistent
speed during tests.

Testing

1. Place the SUT on the desk in the sound booth, and open Audacity. Measure the angle of screen tilt to maintain consistency across all
SUTs. Press Record, and exit the sound booth.

Record at least 20 seconds of only fan noise.

Enter the sound booth, and stop recording in Audacity.

Transfer the recorded file to the audio room computer to analyze in Pro tools.

Level match recordings from both SUTs using the adjustment parameter from the “Setup” section.

Measure the volume level of fan noise using FabFilter Pro L2 using the Integrated setting in Loudness mode.

ok~ wN

Maximum speaker volume output

Setup

1. Load VLC on each of the 12 SUTs with the file comprising the sample song clip.
2. Place Cirrus SPL meter in the audio booth in the same location as the speaker from Test 1.

Testing

1. Place the SUT on the desk in the sound booth. Measure the angle of screen tilt to maintain consistency across all SUTs.

2. Using the sample song clip and Cirrus SPL meter, adjust the output volume of each SUT to 64 dB. Measure SPL of all SUTs from the
same distance and position. Document volume output level of SUT (0 percent to 100 percent).
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Read the report at https://facts.pt/8gAjkYB >

This project was commissioned by Lenovo.

‘ Principled

Technologies®

Principled Technologies is a registered trademark of Principled Technologies, Inc.
All other product names are the trademarks of their respective owners.

DISCLAIMER OF WARRANTIES; LIMITATION OF LIABILITY:

Principled Technologies, Inc. has made reasonable efforts to ensure the accuracy and validity of its testing, however, Principled Technologies, Inc. specifically disclaims
any warranty, expressed or implied, relating to the test results and analysis, their accuracy, completeness or quality, including any implied warranty of fitness for any
particular purpose. All persons or entities relying on the results of any testing do so at their own risk, and agree that Principled Technologies, Inc., its employees and its
subcontractors shall have no liability whatsoever from any claim of loss or damage on account of any alleged error or defect in any testing procedure or resullt.

In no event shall Principled Technologies, Inc. be liable for indirect, special, incidental, or consequential damages in connection with its testing, even if advised of
the possibility of such damages. In no event shall Principled Technologies, Inc.’s liability, including for direct damages, exceed the amounts paid in connection with
Principled Technologies, Inc.’s testing. Customer's sole and exclusive remedies are as set forth herein.
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