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vConsolidate performance and power on quad- and dual-
processor Intel- and AMD-based servers

Executive summary

Intel® Corporation (Intel) commissioned Principled
Technologies® (PT) to measure power and performance
with Intel's vConsolidate version 2.0 workload using
Windows Server 2008 Hyper-V on quad- and dual-
processor servers using the following processors:

Intel Xeon® processor X7460

Intel Xeon processor X7350

AMD® Opteron® processor 8360 SE
Intel Xeon processor X5470

The quad-processor servers were similarly configured with
four processors, 16 4GB DIMMs, and identical PCl-e NICs
and HBAs. The dual-processor server had similar NIC’s
and HBAs, but had 16 2GB DIMMs. Figure 1 shows the
vConsolidate results for all four servers. It provides a
comparison for the test servers with the optimal number of
vConsolidate work units, consolidation stack units (CSUs).
For the quad-processor servers, the Intel Xeon processor
X7460-based server achieved optimal performance with
six CSUs. The Intel Xeon processor X7350-based server
achieved optimal performance with five CSUs, while the
AMD Opteron processor 8360 SE-based server achieved
optimal performance with seven CSUs. The dual-

e The Intel Xeon processor X7460-based

KEY FINDINGS

server delivered 44.3 percent more
performance running vConsolidate with the
optimum number of CSUs than the AMD
Opteron processor 8360 SE-based server,
105.1 percent more performance than the
Intel Xeon processor X5470-based server,
and 39.8 percent more performance than the
Intel Xeon processor X7350-based server
(see Figure 1).

The Intel Xeon processor X7460-based
server produced 37.7 percent better
performance per watt with the optimal
number of CSUs than the AMD Opteron
processor 8360 SE-based server, 31.4
percent more performance per watt than the
Intel Xeon processor X5470-based server,
and 52.5 percent more performance per watt
than the Intel Xeon processor X7350-based
server. (see Figure 2).

processor Intel Xeon processor X5470-based server achieved optimal performance with three CSUs. (See the

Workload section and later sections for more on CSUs.)
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of CSUs, see the Test results
section.

As Figure 1 illustrates, the
Intel Xeon processor X7460-
based server delivered 44.3
percent more performance
running vConsolidate with the
optimum number of CSUs
than the AMD Opteron
processor 8360 SE-based
server, 105.1 percent more
performance than the Intel
Xeon processor X5470-
based server, and 39.8
percent more performance

Figure 1: vConsolidate results at the optimal number of CSUs for the four servers we tested.

than the Intel Xeon processor
X7350-based server.



As Figure 2 shows, the Intel Xeon processor X7460-based server produced 37.7 percent better performance per
watt at the optimal number of CSUs than the AMD Opteron processor 8360 SE-based server, 31.4 percent more
performance per watt than the Intel Xeon processor X5470-based server, and 52.5 percent more performance per
watt than the Intel Xeon processor X7350-based server.

This chart normalizes the results to the lower-performing server, the Intel Xeon processor X7350-based server.
That system’s score is thus 1.00. Normalizing makes each data point in the chart a comparative number, with
higher numbers indicating better performance per watt.

We calculated performance per watt by dividing the vConsolidate score for each server at the optimal number of
CSUs by the measured power when running the optimal number of CSUs for a minimum 30-minute interval. We
measured power at 208 V on all servers.

Workload
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Figure 2: Relative vConsolidate performance/watt results at the optimal number of CSUs for the resources, testers can
four servers we tested. choose to run one or more
CSUs. The typical goal is to
run enough CSUs to push the server under test to its maximum capacity by consuming close to 100 percent of
the CPU capacity.
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vConsolidate sums the throughput results of each type of work across all CSUs in a test. Then it amalgamates the
combined throughputs of all CSUs to create an overall score for the server under test. See the Test results
section for more information on this process.

vConsolidate uses the following four performance tests:

LoadSim

Microsoft Exchange Server 2003 Load Simulator (LoadSim) is a benchmark that measures a server’s
performance handling email. LoadSim uses the MAPI Messaging Benchmark 3 (MMB-3) to simulate MAPI email
clients. The simulated clients issue requests to an Exchange server to generate an email load. LoadSim
measures both the server’s response time and the number of messages it delivers. LoadSim is available for free
download from www.microsoft.com/downloads/details.aspx?Familyld=92EB2EDC-3433-47CA-A5F 8-
0483C7DDEA85&displaylang=en.
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SPECjbb2005

SPECjbb2005 is an industry-standard benchmark from the Standard Performance Evaluation Corp. (SPEC) that
measures a server’s Java performance. (Note: SPEC and SPECjbb2005 are trademarks of the Standard
Performance Evaluation Corporation.) SPEC modeled SPECjbb2005 on the three-tier client/server architecture,
with the middle layer as the primary focus. According to SPEC, “Random input selection represents the first (user)
tier. SPECjbb2005 fully implements the middle tier business logic. The third tier is represented by tables of
objects, implemented by Java Collections, rather than a separate database.” For more information about
SPECjbb2005, see www.spec.org/jbb2005/docs/UserGuide.html.

The results we quote here for this workload are not official SPECjbb2005 results because the vConsolidate
workload uses a slightly modified version of the benchmark. These results are not comparable to SPECjbb2005
results on SPEC’s Web site.

SysBench

The developers at SourceForge.net (www.sourceforge.net) created SysBench to test various aspects of the
performance of servers running database systems. The benchmark’s original target was the MySQL database
system (see www.mysql.com). Intel created a version of SysBench 0.4.0 that would work with Microsoft SQL
Server 2005 Enterprise Edition (www.microsoft.com/sql/editions/enterprise/default.mspx). We ran that version in
our test. In the vConsolidate workload, SysBench created a 100,000-row SQL database and executed a batch of
online transaction processing (OLTP) transactions against that data.

WebBench

WebBench 5.0 (128-bit US version) is an industry-standard benchmark for Web server software and hardware. It
uses PC clients to send Web requests to the server under test. It generates performance results by incrementally
increasing the number of clients making HTTP 1.0 GET requests to the Web server; the result is a curve showing
the server’s performance under increasing load. The peak of that curve represents the peak throughput of the
server. WebBench reports both the total number of requests per second the server handled and the server’s total
throughput in bytes per second. To be certain that we found the true peak performance in our testing, we verified
that the server’s processor utilization reached or was extremely close to 100 percent during the test.

vConsolidate profiles
The vConsolidate workload comes with four sets of VM specifications, which it calls profiles. These profiles define
five key factors for each workload VM:
e number of virtual CPUs (vCPUs) the workload should receive
amount of virtual RAM (vMemory) the workload should receive
the operating system (OS) the workload should run
the key application the workload should run
the workload itself

As we noted earlier, vConsolidate refers to a single collection of these five virtual machines as a consolidate stack
unit (CSU). Depending on the type of server and its available resources, you may choose to run one or more
CSUs. The typical goal is to run enough CSUs to push the server under test to its maximum capacity by
consuming close to 100 percent of the CPU capacity. vConsolidate offers four profiles; we tested with Profile 2,
which we detail in Figure 3.

Profile 2

vCPUs vMemory 0S Application
WebBench (Web) 2 1.5 GB Windows 32-bit 1S
LoadSim (mail) 1 1.5 GB Windows 32-bit Exchange
SysBench (database) 2 1.5 GB Windows 64-bit SQL Server
SPECjbb2005 (Java) 2 2.0GB Windows 64-bit BEA JVM
Idle 1 0.4 GB Windows 32-bit NA
Figure 3: The vConsolidate profile we used in our testing.
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For further information on vConsolidate, please contact Intel.

Test results
The result for an execution of the vConsolidate workload amalgamates the results of all four of the workloads it
includes. To calculate a final score for a vConsolidate run, we used the following four steps, as vConsolidate
specifies:
1. Benchmark throughput = benchmark’s raw results/benchmark duration (for each of the four benchmarks)
2. Total benchmark throughput = add benchmark throughput for all CSUs in test
3. Normalized throughput = total benchmark throughput/reference system’s benchmark throughput
4. vConsolidate score = geomean (normalized throughput of all four benchmarks)

The first step in this process uses whatever raw results a benchmark produces, such as number of transactions or
operations, and the benchmark’s duration in seconds. We calculate a benchmark’s duration by subtracting the
start time of the vConsolidate test from its stop time and converting that time to seconds. WebBench is an
exception to this process because it automatically produces a score in requests per second. For this benchmark,
we calculate the average requests per second for the three WebBench mixes that run while the other benchmarks
are running and record this result as its throughput.

The second step is to sum the throughput for a given benchmark across all CSUs. In the one-CSU case, there is
no need for this step. For the two-, three-, four-, five-, and six- CSU tests, we summed the throughput of each
individual benchmark across all CSUs to obtain that benchmark’s final score.

The third step is to normalize the throughput. We use the one-CSU score of one of the systems under test as the
reference system and assign it a normalized score of 1.00. We then divide the summed throughput for a given
type of work by the reference score for that benchmark. This produces the normalized score for that type of work
in this test. In this test, we used as the reference score the one-CSU score on the Intel Xeon processor X7350-
based server. The last step is to take the geometric mean of the normalized throughput for all four benchmarks.

Figure 4 shows the final score (the median of three runs) and CPU utilization of the test servers by number of
CSUs. The CPU utilization percentage is the average over the period the vConsolidate workload ran.

The optimum CSU for all systems is the number of CSUs that produce the peak score. For example, the Intel
Xeon processor X7460-based server produced a peak score of 4.34 at six, seven, and eight CSUs. This means
its optimum is six CSUs. The score stays the same for the higher numbers of CSUs, which means it can still
handle the load of more virtual machines; however, its optimum score remains six CSUs. For the AMD Opteron
processor 8360 SE-based server we performed one run at eight CSUs to ensure it did not get a better score; that
run produced worse results, so we present results through only seven CSUs for that system.

Server AMD Opteron Intel Xeon processor | Intel Xeon processor | Intel Xeon processor
processor 8360 SE X5470 X7350 X7460

0T 118 Score CPU Score CPU Score CPU Score CPU

of CSUs
1 1.13 33% 1.38 59% 1.17 33% 1.22 22%
2 2.08 64% 2.03 92% 2.23 65% 2.33 43%
3 2.56 91% 2.12 98% 2.85 89% 3.26 65%
4 2.70 96% 3.03 96% 3.92 86%
5 2.78 98% 3.10 98% 4.23 94%
6 2.94 99% 3.10 99% 4.34 97%
7 3.01 100% 3.03 100% 4.34 98%
8 4.34 99%

Figure 4: vConsolidate results for the four test systems with varying numbers of CSUs with corresponding CPU utilizations.
Higher scores are better.
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Figure 5 details the power consumption, in watts, of the test servers while idle and during the median peak

number of CSUs.
Server Idle power (watts) Average power (watts)
AMD Opteron processor 8360 SE 519.91 723.09
Intel Xeon processor X5470 385.88 485.44
Intel Xeon processor X7350 539.38 824.60
Intel Xeon processor X7460 534.77 757.91

Figure 5: Average power usage (in watts) of the test servers while idle and during the median peak CSU runs. Lower numbers

are better.

Figure 6 shows the seven-CSU test results, by benchmark and CSU, for the AMD Opteron processor 8360 SE-

based server.

':3“23 gg_ts::; dpg:::for Database Java Mail Web Final score
CSuU 1 40.31 7,628.59 14.77 253.95
CSU 2 40.89 9,327.90 14.34 258.47
CSU 3 39.18 7,860.90 14.34 259.81
CSU 4 40.52 8,152.39 14.68 250.38
CSuU 5 48.66 8,202.46 15.12 261.44
CSU 6 48.89 8,206.49 13.91 253.08
CSuU7 39.08 8,185.22 10.58 257.39 3.01

Figure 6: vConsolidate seven-CSU median results, by benchmark and CSU, for the AMD Opteron processor 8360 SE-based server.

Higher scores are better.

Figure 7 shows the three-CSU test results, by benchmark and CSU, for the Intel Xeon processor X5470-based

server.
Intel Xeon processor . .
X5470-based server Database Java Mail Web Final score
CSuU 1 76.65 17,307.78 15.37 460.31
CSuU 2 74.35 17,411.25 14.91 456.11
CSU 3 77.03 17,516.81 15.06 447.16 2.12

Figure 7: vConsolidate three-CSU median results, by benchmark and CSU, for Intel Xeon processor X5470-based server. Higher

scores are better.

Figure 8 shows the five-CSU test results, by benchmark and CSU, for the Intel Xeon processor X7350-based

server.
?;ggz(_eb:r;:;oscee:segr Database Java Mail Web Final score
CSU 1 60.61 15,208.48 15.29 383.43
CSuU 2 60.02 15,270.64 15.18 380.69
CSU3 59.99 15,209.45 15.14 388.93
CsSu 4 60.63 15,307.38 15.67 380.86
CSuU 5 61.38 15,346.50 15.56 389.91 3.10

Figure 8: vConsolidate five-CSU median results, by benchmark and CSU, for the Intel Xeon processor X7350-based server. Higher

scores are better.

Figure 9 shows the six-CSU test results, by benchmark and CSU, for the 6-Core Intel Xeon processor X7460-

based server.
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Q?tz:iz)(?b(:;:;oscee:?:r Database Java Mail Web Final score
CSu 1 80.80 18,247.28 14.67 445.98

Csu 2 80.99 18,186.89 14.86 444 86

CSuU3 81.10 18,319.26 16.18 454.22

CSu 4 82.69 18,249.15 15.51 448.64

CSuU 5 80.70 18,305.59 14.01 445.79

CSU 6 81.58 18,343.71 15.35 451.73 4.34

Figure 9: vConsolidate six-CSU median results, by benchmark and CSU, for the 6-Core Intel Xeon processor X7460-based server.
Higher scores are better.

We include complete results for all three runs on the four test systems in Appendix B.

Note: Due to the complexity and number of components the vConsolidate benchmark uses (e.g., network
interfaces, client computers, storage sub-system, configuration of VMs and benchmark components), Intel does
not recommend directly comparing test results from this report with results from other vConsolidate reports.
Unless the benchmark and its components have identical configurations, results may vary, providing an
inadequate basis for direct comparison.

Test methodology

Intel configured and provided all servers.

With the following exception, we used the default BIOS settings on each server: we enabled Intel Virtualization
Technology on all Intel based servers. On the AMD Opteron processor 8360 SE-based server we enabled AMD
Virtualization and No-Execute Page-Protection, and set Power Regulator for ProLiant to Static Performance
mode.

To be sure we could push the processors of each of the four system configurations to their maximum capacities,

we tested each server with as many vConsolidate CSUs as the server could handle, starting with one CSU, up to
or extremely close to 100 percent processor utilization. The rest of this section details how we set up the servers

and the vConsolidate workload.

Hardware and software the test involved

Software

We used the following software to configure and run the vConsolidate workload:
e Windows Server 2008 Hyper-V

Microsoft Windows Server 2003 R2, Enterprise Edition

Microsoft Windows Server 2003 R2, Enterprise x64 Edition

Microsoft Exchange Server 2003

Microsoft SQL Server 2005

BEA JRockit 1.6.0_02-b05

WebBench 5.0

Microsoft Exchange Server Load Simulator (LoadSim) 06.05.7775

SPECjbb2005 v1.07

SysBench v0.4.0

Intel vConsolidate OEM framework package version 1

Hardware
Our test bed consisted of the following hardware:
e The server under test
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Eleven custom-built Intel Desktop Board D915GMH with Intel Pentium 4 3.0GHz w/HT systems, which we
used for all WebBench clients, LoadSim clients, and WebBench controllers (CSU 2 and CSU 3).

One custom-built Intel Server Board D945GTP system, which we used as both the main vConsolidate
controller and the CSU 1 WebBench controller

NETGEAR GS724T, which we set up into two VLANs (one for external network and one for internal
network)

EMC CLARIiion CX3 storage

Three EMC CX-4PDAE-FD disk enclosures, with 15 x Hitachi HUS151473VLF4EQ 73.4 GB disk drives
each

QLogic SANblade QLE2462 Dual Port 4-Gbps Fibre Channel Host Bus Adapter (HBA) installed in the
server under test

Figure 10 illustrates the test bed.

Wt

vConsolidate test bed

CSU #n Combined |IP addresses

Internal network client Server under test
switch (WebBench « External network IP address: 192.168.0.250
controller,
WebBench client, |Main controller
and LoadSim « External network |IP address: 192.168.0.100

client) « Internal network IP address for each CSU's

> LoadSim and WebBench traffic: in form
192.168.n1.100, where n is CSU number (e.g.,
CSU #1 = 192.168.11.100)

[
i Internal network n e—

External network

[
\

Internal network IP addresses
« Combined client: in form 192.168.n1.110, where n
is CSU # (e.q., CSU #1 =192.168.11.110)

VM IP addresses

. « Mail server VMs: in form 192.168.n1.115, where n

Main controller is CSU # (e.g., CSU #1 = 192.168.11.115)

« Web server VMs: in form 192.168.n1.215, where n
is CSU# (e.g., CSU #1 = 192.168.11.215)

« JavaServer1 - n, DBServer1 - n, ldleServer1 —n
(where n is highest CSU#) = DHCP

Server under test
with one active NIC for
external network and one
NIC per CSU for
WebBench and LoadSim
traffic

Figure 10: Our vConsolidate test bed.

Server installation

We configured all servers with the same disk setup using the EMC CLARiion CX3. We split the storage into four
volumes, one with 10 GB and five with 130 GB. For each server, we installed Windows Server 2008 Hyper-V on
the 10GB volume and installed a CSU on each of the five 130GB volumes. We installed the boot loader on the
hard drive installed in the server’s drive chassis on the server under test.

Adding the Hyper-V role to Windows Server 2008

Note: Make sure you have installed all the latest critical and recommended updates for Windows Server 2008
from Windows Update. Specifically, you must install the update that upgrades Hyper-V from beta to release
software. (As of 07/21/2008, this update is KB950050 on 64-bit Windows.)

1.
2.
3.

Click Server Manager->Roles>Add Roles.
Check the box beside the Hyper-V role, and click Next.
Click Next.

Principled Technologies, Inc.: vConsolidate performance and power on quad- and
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9.

Check the box beside the Ethernet card you wish to use, and click Next.

Click Install. Installation begins.

When installation finishes, click Close.

When the system prompts you to restart, click Yes.

Once the system finishes rebooting (this might happen twice), log in.

The Resume Configuration Wizard should start automatically.

Once the Resume Configuration Wizard completes, the installation results should appear with a message
that the installation succeeded.

10. Click Close.
11. Restart the server.

Adding logical unit numbers (LUNs)
Note: Make sure the Fibre Channel/iSCSI LUN is mapped to the card in your system.

1.
2.

Noohsw

®

Click Server Manager—-> Storage—>Disk Management.

When the wizard prompts you to initialize new disks, click OK. Note: If you must select a partition table,
select MBR.

Right-click the first unallocated disk partition, and select New Simple Volume...

Click Next.

Use the entire LUN storage space (this should be the default), and click Next.

Select the drive letter to assign to the new partition, and click Next.

Label the volume appropriately (i.e., LUNO, LUN1, etc.), make sure Perform a quick format is checked,
and click Next.

Click Finish.

Configure Hyper-V default options

1.

2.
3.

4.

5.
6.

Click Start->Administrative Tools>Hyper-V Manager.

From the Actions menu, select Hyper-V Settings...

From the left menu of the Settings screen, select Virtual Hard Disks, and enter the default folder to store
virtual hard disk files (e.g., E:\Hyper-V\Virtual Hard Disks).

From the left menu of the Settings screen, select Virtual Machines, and enter the default folder to store
virtual hard disk files (e.g., E:\Hyper-V).

Click OK.

You may also want to configure any VM network switch settings at this time.

Creating a virtual machine

1.

prODd

©ooNO

Click Start->Administrative Tools->Hyper-V Manager.

From the Actions menu, select New-> Virtual Machine...

Click Next.

Enter a name for the virtual machine, and browse to the location where you want to store the VM files The
New Virtual Machine Wizard will automatically create a subfolder with the name of the VM).

Click Next.

Specify the amount of memory to allocate to the virtual machine, and click Next.

Select the network connection for the virtual machine to use, and click Next.

Select Attach a virtual hard disk later, and click Next.

Click Finish.

Modifying the Virtual Machine (Creating the virtual HDD)

W=

No o s~

Click Start->Administrative Tools->Hyper-V Manager.

Right-click the Virtual Machine on which you want to install Windows, and click “Settings...”

From the menu on the left, select IDE Controller 0, and click Add to add a new hard drive to the IDE
Controller.

Click New to create a new virtual hard disk file.

Click Next.

Select Fixed size, and click Next.

Specify the name and location of the virtual hard disk file.
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8. Specify the size of the new blank virtual hard disk (in GB).
9. Click Finish. The server begins creating the new virtual hard disk.
10. Once it finishes creating the new virtual hard disk, click OK.

Modifying the Virtual Machine (adding an additional hard disk)

Note: Do not use this method to configure the VM primary hard disk; for that you must use a virtual IDE hard disk.
However, we recommend that you perform high-usage 1/O tasks (i.e., database server, file server, mail server,
etc.) on a secondary disk whenever feasible.

Click Start>Administrative Tools=>Hyper-V Manager.

Right-click the Virtual Machine on which you want to install Windows, and click Settings...

From the menu on the left, select Add Hardware.

Choose the “SCSI Controller” device and click Add.

Click “Add” to add a new hard drive to the virtual SCSI Controller.

Click New to create a new virtual hard disk file.

Click Next.

Select “Fixed size” and click Next.

Specify the name and location of the virtual hard disk file.

10 Specify the size of the new blank virtual hard disk (in GB).

11. Click Finish. The server will then begin creating the new virtual hard disk.

12. Once it finishes creating the new virtual hard disk, click OK.

CoNO>ORA~®LN =

Installing Windows on the VM
Note: We have tested this using Windows Server 2003 R2 Enterprise x64 Edition with SP2.

1. Click Start->Administrative Tools->Hyper-V Manager.

2. Right-click the Virtual Machine on which you want to install Windows, and click Connect...

3. From the menu, select Media->DVD Drive—>Insert Disk...

4, Select the ISO image file for the version of Windows you are installing, and click Open.

5. To start the virtual machine, select Start from the Action menu.

6. Click the screen, and begin installing Windows as you normally would.

7. Once installation is complete, select action > Ctrl-Alt-Delete.

8. Enter your password and hit Enter.

9. Select Media->Eject CD.

10. Select Media—~>Insert CD and choose the second installation disk.

11. When the Windows installation completes select Action—>Insert Integration Services Setup Disk from the
menu. Installation should begin automatically.

12. At the prompt to restart, click Yes.

13. Once the system has restarted, log in, and verify that all configured devices (mouse, keyboard, video,
network, etc.) are working.

14. Once you are sure all your devices are working, from the menu select Media->DVD Drive>Eject

vmguest.iso.

Installing vmbus.sys patch
Note: We installed an updated version of vmbus.sys on both systems to provide optimum performance. The
version we installed was 6.0.6001.18018. We did not use this patch on the AMD Opteron processor 8360 SE-
based server for testing. Note: We tried the runs both with and without the patch to ensure best results and found
that on that system we achieved the best results without installing the patch.

1. On both 64-bit and 32-bit virtual machines, copy the vmbus.sys file to C:\WINDOWS\system32\drivers.

2. On all virtual machines, copy the vmbus.sys file to c:\WINDOWS\Virtualizationi\6.0.6001.18016.

3. On the Hyper-V server, open a command prompt and type bcdedit /set testsigning on.

4. Copy the 64-bit vmbus.sys file to c:\WINDOWS\system32\drivers.

To create one vConsolidate CSU, we had to create the five virtual machines that CSU describes:
e mail server
e Web server
e Java application server
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e database server
e idle server

The following subsections detail how we created and configured each of these VMs.

Copying the VMs
Use the following steps to create VMs with the same base OS:

1. Navigate to the Virtual Hard Disk folder on the server where the Virtual Hard Disks are stored.

2. Highlight your base VM, and use the copy/paste method to create the appropriate number of copies for
your VMs.

3. Right click each Hard Disk and rename them according to the VM for which they are to be used.

4. Select Start->Administrative Tools>Hyper-V Manager...

5. Choose New->Virtual Machine.

6. Click Next.

7. Enter a name for the virtual machine, and select the location to store the VM files The New Virtual
Machine Wizard will automatically create a subfolder with the name of the VM).

8. Click Next.

9. Specify the amount of memory to allocate to the virtual machine, and click Next.

10. Select the network connection for the virtual machine to use, and click Next.

11. Select Attach a virtual hard disk later, and click Next.

12. Click Finish.

13. Select the newly created VM and choose Settings—>IDE Controller 0.

14. Choose Add to add a Hard Disk to the VM.

15. Choose Browse.

16. Select the appropriate Hard Disk and click Okay.

17. Click OK.

Installing and configuring the mail server VM
1. Follow the steps in the earlier Copying the VMs section using the following VM specifications:

e Base VM: Base32
Name: MailServer1
Virtual processors: 1
Virtual memory: 1.5 GB
Virtual disk size: 10 GB
Virtual network: Internal Network (set the IP address to 192.168.11.115 in Windows within the VM)

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Installing the domain controller

Select Start->Administrative Tools>Manage Your Server.

Click Add or remove a role.

At the Configure Your Server window, click Next.

At the Configuration and Options screen, select Custom Configuration, and click Next.

At the Server Role screen, select Domain Controller, and click Next.

At the Summary of Selections screen, click Next.

At the Welcome pop-up window, click Next.

At the Operating System Compatibility screen, click Next.

For the Domain Controller Type, leave the default option (Domain controller for a new domain), and click
Next.

10. At the Create New Domain screen, leave the default (Domain in a new forest), and click Next.
11. At the Install or Configure DNS window, select No, and click Next.

12. At the New Domain Name screen, type a domain name (vcon. com), and click Next.

13. At the NetBIOS Domain Name screen, enter a NETBIOS domain name (vcon), and click Next.

CoNO>OR~LON =
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14.

15.

16.
17.
18.
19.
20.

Click Next through the following screens: Database and Log Folders, Shared System Volume, and
Permissions. Doing so accepts the default options for each of those screens.

At the Directory Services Restore Mode Administrative Password screen, enter a password (password),
and click Next.

When the installation software prompts you to do so, insert the OS CD, and click OK.

At the Completing the Active Directory Installation Wizard screen, click Finish.

When the system prompts you to reboot the VM, click Restart Now.

After the VM reboots, log in to the system.

At the This Server is Now a Domain Controller window, click Finish.

Installing Internet Information Services 6.0

CENOITRA~WLN =

10
11.

Select Start->Control Panel->Add or Remove Programs.

Click Add/Remove Windows Components.

Select Application Servers, and click Details.

Click ASP.NET, and make sure a check appears in the check box.
Select Internet Information Services (IIS), and click Details.

Click NNTP Services and SMTP Services, make sure a check appears in both check boxes, and click OK.
Click OK to close the Application Server window.

At the Windows Components Wizard, click Next to begin the installation.
When the system prompts you to do so, insert the OS CD, and click OK.
At the Completing the Windows Components Wizard window, click Finish.
Close the Add or Remove Programs window.

Installing Exchange Server 2003

1. Insert the Microsoft Exchange Server 2003 CD. The CD should automatically launch the installation
software.
2. Choose Exchange Server Enterprise Edition.
3. Run the Setup application.
4. Click the Exchange Deployment Tools link.
5. Click the Deploy the first Exchange 2003 Server link.
6. Click the New Exchange 2003 Installation link.
7. Click the Run ForestPrep now link.
a. When the compatibility issue notice appears, click Continue, and check the Don’t display this
message again box.
b. Atthe Welcome screen, click Next.
c. Accept the End User License Agreement, and click Next.
d. At Component Selection Screen, keep the defaults, and click Next.
e. Leave the default account information, and click Next.
f. Installation should start. (This process may take a while to complete.)
g. When the installation completes, click Finish.
8. Return to the Exchange Server Deployment Tools screen, and click the Run DomainPrep now link.
a. Atthe Welcome screen, click Next.
b. Accept the End User License Agreement, and click Next.
c. At Component Selection Screen, keep the defaults, and click Next.
d. At the insecure domain notice, click OK.
e. When the installation completes, click Finish.
9. Return to the Exchange Server Deployment Tools screen, and click Run Setup Now.
a. Atthe Welcome screen, click Next.
b. Accept the End User License Agreement, and click Next.
c. Atthe Component Selection screen, the action for Microsoft Exchange should by default be Typical.
(If it is not, use the drop-down box to set it to Typical.)
d. Click Next.
e. For the Installation Type, select Create new Exchange Organization, and click Next.
f. Enter vcon as the Organization Name, and click Next.
g. Accept the Microsoft Exchange Server Licensing Agreement, and click Next.
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h. Review the installation summary, and click Next.
i. The installation should start. (This process may take a while to complete.)
j- When the installation completes, click Finish.
10. Close the Exchange Server Deployment Tools window.
11. Install Microsoft Exchange Server 2003 Service Pack 2.
Insert the SP2 CD, and double-click update exe.
Accept the default location to extract the file, and click OK.
After the extraction finishes, open Windows Explorer, and browse to the update.exe executable.
At the Welcome screen, click Next.
Select | agree to accept the License Agreement, and click Next.
At the Component Selection window, leave the default option (Update), and click Next.
Verify the installation Summary, and click Next.
When the installation completes, click Finish.
12. In the Virtual Infrastructure Client console, add a new 40GB virtual hard disk to this VM by doing the
following:
Right-click the MailServer1 VM, and select Settings from the menu.
On the Hardware Tab, click Add Hardware.
Choose the “SCSI Controller” device and click Add.
Click “Add” to add a new hard drive to the virtual SCSI Controller.
Click New to create a new virtual hard disk file.
Click Next.
Select “Fixed size” and click Next.
Specify the name and location of the virtual hard disk file.
Specify the size of the new blank virtual hard disk (in GB).
Click Finish. The server will then begin creating the new virtual hard disk.
Once it finishes creating the new virtual hard disk, click OK.
13. Restart the VM by selecting Start->Shut down—->Restart inside the MailServer VM.
14. In the MailServer VM, right-click My Computer, and select Manage.
15. In the Computer Management Console, select Disk Management.
16. When a Welcome to Initialize and Convert Disk Wizard window appears, click Next.
17. Select Disk 1 to initialize.
18. At the Select Disk to Convert screen, leave the disk unchecked.
19. At the Completing the Initialize and Convert Disk Wizard screen, click Finish.
20. Right-click the Disk 1 unallocated box, and select New Partition.
21. At the Welcome screen, click Next.
22. Leave the partition type as Primary, and click Next.
23. Accept the default Partition Size, which should be the same as the Maximum disk space, and click Next.
24. Assign the drive letter E, and click Next.
25. Format the partition with the NTFS File system, enter Mail Store for the volume label, and click Next.
26. At the Completing the New Partition Wizard screen, click Finish.
The partition should begin formatting.
27. When the formatting completes, close the Computer Management console.
28. Select Start->All Programs->Microsoft Exchange—> System Manager.
29. In the left window pane, expand Servers and MailServer so the First Storage Group is visible.
30. Right-click First Storage Group, and select Properties.
31. Click Browse, and change the Transaction log and System path location to E:\.
32. Check the Enable circular logging box, and click Apply.
33. When the pop-up message appears asking if you want to perform this task, click Yes.
34. When the message appears saying that all mounted stores are back online, click OK.
35. Right-click Mailbox Store under First Storage Group, and select Properties.
36. Select the Database tab.
37. Click Browse, and move the Exchange database and Exchange streaming database to E:\.
38. Check the This database can be overwritten by a restore box.
39. Click Customize next to Maintenance interval.
40. Remove all blue from the boxes so the system will not perform maintenance, and click OK.
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41.
42.
43.
44.
45.
46.
47.
48.
49.
50.
51.
52.
53.
54.
55.

At the Mailbox Store Properties window, click Apply.

When a warning message appears, click Yes.

When the message that the database files have been moved appears, click OK.

Click OK to close the Mailbox Store Properties window.

Right-click Public Store under First Storage Group, and select Properties.

Select the Database tab.

Click Browse, and move the Exchange database and Exchange streaming database to E:\.
Check the This database can be overwritten by a restore box.

Click Customize next to Maintenance interval.

Remove all blue from the boxes so the system will not perform maintenance, and click OK.
At the Public Store Properties window, click Apply.

When a warning message appears, click Yes.

When the message that the database files have been moved appears, click OK.

Click OK to close the Public Store Properties window.

Reboot the virtual machine.

Installing and configuring the Web server VM

1.

Follow the steps in the earlier Cloning the base VMs section using the following VM specifications:

e Source VM: Base32

Name: WebServer1 (use WebServer for the Host Name in the VM)

Virtual processors: 2

Virtual memory: 1.5 GB

Virtual Disk Size: 10GB

Virtual Network: Internal Network (set the IP address to 192.168.11.215 in Windows within the VM)

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Installing Microsoft Internet Information Server

1.
2
3
4
5.
6.
7
8
9.
1

0.

Select Start->Administrative Tools>Manage Your Server.

Select Add or remove a role.

At the Configure Your Server window, click Next.

At the Configuration Options screen, select Custom configuration, and click Next.

At the Server Role screen, select Application Server, and click Next.

At the Application Server Options screen, select Enable ASP.NET, and click Next.

At the Summary of Selections screen, click Next.

When the installation software prompts you to do so, insert the Operating System CD, and click OK.
When the installation completes, click Finish.

Close the Manage Your Server window.

Installing WebBench 5.0

1.

Insert the WebBench 5.0 CD into the Virtual Client, and connect with the Virtual CDROM.

2. Copy wbtree.exe from the \wb50\workload directory on the CD to C:\inetpub\wwwroot.

3. Double-click wbtree.exe to expand the workload. (This step will create a wbtree folder with all the test
data WebBench required.)

4. Create a cgi-bin folder in c:\inetpub\wwwroot.

5. After installing the WebBench controller, copy simcgi.exe from the controller machine in
C:\WebBench\Controller\Suites\WebBench\Examples directory to the Web server VM’s
C:\Inetpub\wwwroot\cgi-bin\ directory.

6. Right-click My Computer, and select Manage.

7. Expand Services and Applications, Internet Information Services, and Web Sites in the left window pane.

8. Click Default Web Sites.

9. Right-click the cgi-bin directory in the right pane, and select Properties from the drop-down menu.

10. In the Execute permissions field, select Scripts and Executables, and click OK.
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11.

12.
13.
14.
15.

16.
17.
18.
19.
20.
21.
22.
23.
24.
25.

26.

Using Windows Explorer, browse to C:\Inetpub\wwwroot\cgi-bin, right-click simcgi.exe, and select
Properties from the drop-down menu.

Select the Security tab, and grant Read/Read & Execute permissions to the user, Internet Guest Account.
Click OK to close simcgi.exe properties.

Close Windows Explorer.

In the Computer Management window, right-click the Default Web Server, and select properties from the
drop-down menu.

Select the HTTP Headers tab, and click MIME Types.

In the MIME Types window, click New.

In the Extension text box, enter . ex

In the MIME type text box, enter application/octet-stream, and click OK.

Click OK again to close the MIME Types window and the Default Web Site Properties window.

If a notification window about a child node pops up, click OK.

In the Computer Management console, select Web Service Extension.

Select All unknown CGI Extensions in the right pane, and click Allow.

Click Yes, you do want to allow All Unknown CGI Extensions in the pop-up window.

Open a Web browser, and type the URL http://localhost/cgi-bin/simcgi.exe to verify you correctly installed
the WebBench files. Text about the system should appear in the browser window.

Close the Web browser.

Installing Certificate Server

N>R~ WLN =

10
11.

Select Start->Control Panel->Add or Remove Programs.

Click Add/Remove Windows Components.

Select Certificate Servers, and accept the CA Service warning.

Click Next.

Select Standalone root CA in the CA Type Windows, and click Next.

Enter WEBBENCH in the common name field, and click Next.

At the Certificate Database Settings screen, leave the default options, and click Next.
When the warning about stopping IS appears, click Yes.

When the installation software prompts you to do so, insert the OS CD, and click OK.
Click Yes to enable Active Server Pages.

When the installation completes, click Finish.

Creating a certificate request

In the Computer Management Console, right-click the Default Web site, and select Properties.

Select the Directory Security tab, and then click Server Certificate under Secure Communications to start
the Web Server Certificate Wizard.

At the Welcome screen, click Next.

Select Create a new certificate, and click Next.

Select Prepare the request now, but send it later, and click Next.

Type Default Web Site for the certificate name.

Use the default bit length (1024), and click Next.

Type MyWeb for the organization name and Development Dept for the organizational unit, and click
Next.

Type the server name as the common name, and click Next.

. Enter your location information, and click Next.
. Save the certificate information to the default path and file name, and click Next.
. Verify the information that you have typed, and then click Next to complete the process and create the

certificate request.

. Click Finish to close the IS Certificate Wizard.
. Click OK to close the Default Web Site Properties window.

Submitting a certificate request

1.
2.

Open a Web browser, navigate to http://localhost/CertSrv/, and press Enter.
Click Request a certificate.
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7.
8.
9.
1

0.

Click Advanced certificate request.

Click Submit a certificate request by using a base-64-encoded CMC or PKCS #10 file, or submit a
renewal request by using a base-64-encoded PKCS #7 file.

Open the request document that you created in the Create a certificate request section.

Copy the contents of the document to a text box with the following format.

I BEGIN NEW CERTIFICATE REQUEST-----

I END NEW CERTIFICATE REQUEST-------

Note: If you saved the document with the default name and location, it is located at C:\Certreq.txt. Be sure
to copy all of the content as we illustrated above.

Paste the contents of the document into the Web form’s Base64 Encoded Certificate Request text box.
Click Submit.

You should receive a Certificate Pending message in the Web browser.

Close the Web browser window.

Issuing and downloading a certificate

PN~

Select Start->All Programs—>Administrative Tools—> Certificate Authority.

In the Certificate Authority window, expand the server name.

Click the Pending Requests folder.

In the pending request folder, right-click the pending certificate request that you just submitted, select All
Tasks, and then click Issue. (Note: After you select Issue, the certificate no longer appears in this window
and folder. It now resides in the Issued Certificate folder.)

Close the Certificate Authority window.

Open a Web browser, and type http://localhost/CertSrv/.

Click View the status of a pending certificate request.

Click the certificate request that you can see.

Click Download Certificate.

. Click Save in the File Download window.

. Save the certificate to C:\.

. Close the download complete pop-up window.
. Close the Web browser window.

Installing the certificate and setting up an SSL Web site

pPON=

No o

8.
9.
10.
11.

12.

Open the Computer Management console by right-clicking My Computer, and selecting Manage.
Right-click the Default Web site, and select Properties.

Select the Directory Security tab.

Under Secure Communications, click Server Certificate. This step will start the Certificate Installation
Wizard.

At the Welcome screen, click Next.

Select Process the pending request and install the certificate, and click Next.

Browse to the location of the certificate that you downloaded in the Issue and download a certificate
section, and click Next.

Keep the default SSL Port, and click Next.

Verify the information is correct on the Certificate Summary page, and click Next.

Click Finish to complete the installation.

Click OK to close the Default Web Site Properties window.

Close the Computer Management window.

Configuring and testing the certificate

2,

Open a Web browser, and type https://webserver/cgi-bin/simcgi.exe.

You may receive a security alert that states that the certificate is not from a trusted root CA. Click Yes to
continue to the Web page.
3. If the page appears, you have successfully installed the certificate.
4. Close the Web browser.
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Installing and configuring the Java application server VM
Follow the steps in the earlier Cloning the base VMs section using the following VM specifications:

1.

Base VM: Base64

Name: JavaServer1

Virtual processors: 2

Virtual memory: 2 GB

Virtual Disk Size: 10 GB

Virtual Network: External Network (keep the default Windows Network DHCP settings)

To finish setting up this VM for vConsolidate, we had to install and modify an additional software component. The
following subsections detail the necessary installation processes.

Installing SPECjbb2005

Copy the BEA JRockit JVM 1.6.0_02 folder to the root of C: in the VM.

Install SpecJBB2005 in the VM directory: ¢c:\vSpecJBB2005.

Add the BEA JRockit JVM to the Windows system path by doing the following:

1.
2.
3.

a. Right-click My Computer, and select Properties.

b. Select the Advanced tab, and click Environment Variables.

c. Inthe System variables section, select Path, and click Edit.

d. Add the following to the end of the Variable value string: C:\jrockit-jdk1.6.0_02 \bin (jrockit-
jdk1.6.0_02 is the folder name of the JVM installation).

e. Click OK to close the Edit System Variable, Environment Variables, and System Properties
windows.

Open a command prompt by selecting Start->Run.

Type cmd, and click OK.

Change to the vSpecdBB2005 directory by typing cd C:\vSpecdBB2005, and then press Enter.
Type runit .bat, and press Enter to verify SPECjbb2005 starts.

Press Ctrl-C to stop the benchmark.

Confirm that you do want to stop the run by typing Y and pressing Enter.

0 Copy the following files from the vConsolidate package to the VM directory C:\:

Daemon.exe
killapp.exe.

Modifying SPECjbb2005

To run the vConsolidate benchmark, you must modify SPECjbb2005 as follows:

Modify the following three original source files in the SPECjbb directory (C:\SPECjbb2005\src\spec\jbb\)
by opening each file with WordPad and making the changes below. Save each file after you have made
the changes.

1.

Company.java
Change private long measurement time; to public long measurement time;
Change JBButil.SecondsToSleep ( (int) measurement time); to
JBButil.SecondsToSleep (Long.MAX VALUE/1000) ;
DeliveryTransaction.java
After the line customerPtr.adjustBalance (matchingOrder.getTotalAmount () ) ;, add the
following lines:
int timerCount = 0;
timerCount = (short)JBButil.random(1,100) ;
if (timerCount == 1)

JBButil.milliSecondsToSleep (company.measurement time) ;
TransactionManager.java
Change myTimerData.updateTimerData (txntype, txntime) ; to the following lines:

myTimerData.updateTimerData (txntype, txntime) ;

if (txntype==0 && myTimerData.getTransactionCount (0)%1000 == 0)
int sum = 0;
for (int k=0; k<=5; k++)
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sum += myTimerData.getTransactionCount (k) ;
System.out.println("===="+this+":"+"===="+sum) ;

2. Open the command prompt by clicking Start>Run, type cmd, and press Enter.
3. Atthe command prompt, type cd C:\SPECjbb2005\src\spec\jbb\.
4. Atthe command prompt, type the following commands. Press Enter after each command:
e mkdir class
e "C:\Program Files\Java\jrockit-jdkl.5.0\bin\javac" -cp "C:\Program
Files\Java\jrockit-jdk1l.5.0\jre\lib\rt.jar" -d class\ *.java
infra\Util\*.java validity\*.java ..\reporter\*.java
cd class\
"C:\Program Files\Java\jrockit-jdk1l.5.0\bin\jar" -cf jbb.jar
spec\jbb\*.class spec\jbb\infra\Util\*.class spec\reporter\*.class
e "C:\Program Files\Java\jrockit-jdk1l.5.0\bin\jar" -cf check.jar
spec\jbb\validity\*.class
5. Type exit to close the command prompt.
6. Open Windows Explorer from the start menu.
7. Copy the jbb.jar and check.jar files from C:\SPECjbb2005\src\spec\jbb\class to C:\vSpecJBB2005\.
8. When the system asks if you want to overwrite files, click Yes to overwrite the original jbb.jar and
check.jar files.
9. Using Windows Explorer, navigate to C:\vSpecJBB2005, and open the SPECjbb.props file.
10. Make the following changes to the SPECjbb.props file:

e Change input.starting number warehouses=1 to
#input.starting number warehouses=1

e Change input.increment number warehouses=1 to
#input.increment number warehouses=1

¢ Change #input.sequence of number of warehouses=1 2 3 4 5 6 7 810
input.sequence of number . “of warehouses 2
Note: Set the above parameter to be equal to the number of vCPUs you configured for Java
server VM.
e Change input.measurement seconds=240 to input .measurement seconds=10
11. In the C:\vSpecJBB2005 directory, right-click runit.bat, and change set JAVAOPTIONS=-Xms256m -
Xmx256mto set JAVAOPTIONS=-Xms1000m -Xmx1000m -Xxthroughputcompaction -
XXallocprefetch -XXallocRedoPrefetch -XXcompressedRefs -XxlazyUnlocking -
XXtlasizel28k

Installing and configuring the database server VM
1. Follow the steps in the earlier Cloning the base VMs section using the following VM specifications.
o Base VM: Base64
Name: DBServer1
Virtual processors: 2
Virtual memory: 1.5 GB
Virtual disk size: 10 GB
Virtual network: External Network (keep the default Windows Network DHCP settings)

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Installing Microsoft Internet Information Server

Select Start->Administrative Tools>Manage Your Server.

Select Add or remove a role.

At the preliminary steps screen, click Next.

At the Server Role screen, select Application Server, and click Next.

At the Summary of Selections screen, click Next.

When the installation software prompts you to do so, insert the OS CD, and click OK.

oAM=

Principled Technologies, Inc.: vConsolidate performance and power on quad- and
dual-processor Intel- and AMD-based servers

17



7.
8.

When the installation completes, click Finish.
Close the Manage Your Server window.

Installing Microsoft SQL Server 2005

SOOONoOORALN =

Insert the SQL Server 2005 CD into the controller, and connect with the Virtual CD ROM.

Click the Server Components link under the Install section to begin the installation.

Accept the license agreement, and click Next.

Click Next to install the prerequisites.

After the prerequisites complete installing screen, click Next.

At the Welcome screen, click Next.

At the System Configuration Check, assuming everything has a status of success click Next.
Enter the registration information, and click Next.

At the Components to Install screen, select SQL Server Database Services, then click Advanced.

. Instruct the software to install both the Database Services and Client Components by clicking the drop-

down arrow on both and selecting Entire feature will be installed on local hard drive.

. Click Next to start the installation.

. For Instance Name, leave the default option, and click Next.

. At the Service Account screen, select Use the built-in system account (Local system), and click Next.

. Keep the default option for Authentication Mode, and click Next.

. For Collation Settings, leave the defaults, and click Next.

. Accept the default Error and Usage Report Settings, and click Next.

. At the Ready to Install screen, click Install to begin the installation.

. When the installation software prompts you to do so, insert Microsoft SQL Server 2005 disk 2. Use the

Virtual CDROM to connect it to the VM, and click OK.

. When the setup process completes, click Next.

. Click Finish to complete the initial installation.

. Install Service pack 2 by copying SQLServer2005SP2-KB921896-x64-ENU.exe to the virtual machine
. Double-click the executable to launch the installer.

. At the Welcome screen, click Next.

. At the License Terms screen, accept the license agreement.

. At the Feature Selection screen, click Next to accept all defaults.

. At the Authentication screen, click Next to accept all defaults.

. At the Error and Usage Reporting Settings screen, click Next to accept all defaults.

. At the Running Processes screen, click Next.

. Click install on the Ready To Install screen.

. Click OK, on the Computer Reboot Requires message box.

. Click Next at the Installation Complete Screen.

. At the Additional Information screen, deselect Launch the User Provisioning Tool for Windows Vista after

SP2 installation completes.

. Click Finish.

Creating the test database and generating data

1.
2.

©COEND>O AW

Select Start->Microsoft SQL Server 2005>SQL Server Management Studio.

In the Connect to Server window, use the drop-down menu next to Server name to select <Browse for
more>.

In the Browse for Server window, select the Network Servers tab, and wait for it to retrieve data.
When Database Engine appears, expand the menu, select DBSERVER1, and click OK.

At the Connect to Server window, the server name should be present.

Click Connect to connect to the server.

Right-click the Database folder in the left window, and select New Database from the pop-up menu.
In the Database name field, type sbtest, and click OK.

Copy the following files from the vConsolidate package to the VM C:\ directory:

e vSysbench.exe

e Daemon.exe

e killapp.exe
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10.
. In the command prompt, type cd \ to change to C:\.
12.

13.
14.
15.

16.
17.

18.
19.

Open a command prompt by selecting Start>Run, type cmd, and click OK.

To prepare the database, type vsysbench.exe --test=oltp --oltp-table-size=100000
prepare, and press Enter.

When the command finishes, the C:\ prompt appears.

Type exit, and press Enter to close the command prompt.

In SQL Server 2005 Management Studio, stop the database service by right-clicking DBSERVER1 in the
left window pane, and then select Stop from the drop-down menu.

Using Windows Explorer, create the folder C:\backup.

With Windows Explorer, copy all sbtest files from C:\Program File\Microsoft SQL
Server\MSSQL.1\MSSQL\Data\ to c:\backup. (You should see two files: sbtest. mdf and sbtest_log.Idf.)
Close Windows Explorer once the copy completes.

Restart the database service using SQL Server 2005 Management Studio by right-clicking DBSERVER1
and selecting start.

Installing and configuring the idle server VM

1.
2.

Follow the steps in the earlier Cloning the base VMs section using the following VM specifications.
Use the VM Specifications below:

e Base VM: Base32

Name: IdleServer1

Virtual processors: 1

Virtual memory: 0.4 GB

Virtual disk size: 5 GB

Virtual network: External Network (keep the default Windows Network DHCP settings)

Installing and configuring the second CSU

To create the VMs the second CSU requires, we copied the existing virtual Hard Disks from the first CSU and
directed the new VMs to point to the copied hard disks. We then started each VM and entered a new IP address
or name depending on the need of each VM.

9

10.
11.
12.
13.
14.
15.
16.
17.
18.

Navigate to the Virtual Hard Disk folder on the server where the Virtual Hard Disks are stored.
Highlight the first VM hard disk, and use the copy/paste method to create the appropriate number of
copies for your CSUs.

Right click each Hard Disk and rename them according to the CSU for which they are to be used.
Select Start->Administrative Tools>Hyper-V Manager...

Choose New~>Virtual Machine.

Click Next.

Enter a name for the virtual machine, and select the location to store the VM files The New Virtual
Machine Wizard will automatically create a subfolder with the name of the VM).

Click Next.

Specify the amount of memory to allocate to the virtual machine, and click Next.

Select the network connection for the virtual machine to use, and click Next.

Select Attach a virtual hard disk later, and click Next.

Click Finish.

Select the newly created VM and choose Settings—>IDE Controller 0.

Choose Add to add a Hard Disk to the VM.

Choose Browse.

Select the appropriate Hard Disk and click Okay.

Click OK.

Repeat the steps for each VM for the appropriate number of CSUs.

Client installation
In addition to setting up the server under test, we also had to set up the client systems we show in Figure 10. Both
the WebBench and LoadSim workloads require test clients. Each CSU requires one consolidated test client.
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Installing the WebBench 5.0 test client system
To run WebBench, you need two types of test systems. WebBench clients use WebBench software engines to
send HTTP requests to stress the server under test. A WebBench controller system manages the clients during
as the benchmark runs. Both systems run on the same physical client.

Installing a WebBench 5.0 client

1.
2.
3.

oo A

- = © 00 N

14.
15.
16.
17.
18.
19.
20.

21.

22.
23.
24.
25.
26.
27.
28.
20.
30.
31.
32.
33.

Install Windows 2003 Enterprise Edition 32-bit. Use mailclient as the system name.

Install Windows Server 2003 Service Pack 2 with the default settings.

Open the Network Connections window by right-clicking My Network Places and selecting Properties from
the menu.

Right-click the network connection, and click Properties.

Highlight TCP/IP, and select Properties.

Select Use the following IP address, and enter the following information: IP address 192.168.11.211,
Subnet 255.255.255.0.

Click OK to close the two Properties windows.

Insert the WebBench CD, and open it with Windows Explorer.

Run setup.exe from the location /wb50/client/setup.exe.

. Click Next through all screens, a process that accepts the defaults.
. When the installation completes, copy the WebBench shortcut icon from the open window to the system’s

desktop.

. With WordPad, open the file c:\Windows\system32\drivers\etc\hosts.
13.

After the last text in that file, enter the following additional lines, and click Save.

e 192.168.11.211 controller

o 192.168.11.215 server

Close the hosts file and Windows Explorer.

Run /wb50/controlr/setup.exe.

Click Next through the installation, which accepts all default options.

With Windows Explorer, open C:\WebBench\Controller\Clientids\client.cdb.

Add the client’s IP address to the top of the file. Enter Tab twice, and type the number 1.
Click File>Save, and close the client.cdb file.

Copy vConsolidate.tst file from the vCON\WebBench directory to
C:\WebBench\controller\suites\WebBench.

Copy ecommerce_cgi_template_w2k3.tst and ecommerce_cgi_template_w2k3.wl files from
vCON\WebBench directory to C:\WebBench\controller\suites\WebBench.

Copy all files from \vCON_framework\WebBench_daemon in the vConsolidate package to C:\.
Select Start->All Programs—>PC Magazine Benchmarks>WebBench 5.0 Controller.
Click Create/Edit from the Suites drop-down menu.

Browse to the vConsolidate.tst file, and click Open.

Highlight the first Mix, and click Edit.

On the General tab, change Engines per client to 8.

Select the Workload tab.

Change the number of threads to 1.

Click Copy across.

Select the Engines per client and Number of threads check boxes, and click OK.

Click OK to close the suites windows.

Close the WebBench Controller window.

Installing the mail test client
Install the mail client on the same consolidated client at WebBench client and controller. We performed the
following steps to set up the system:

agrON =

Right-click My Computer, and select Properties.

Click the Computer Name tab.

Click Change.

Select Domain in the member of section, and type the domain vcon. com into the text box.

In the pop-up window, enter administrator for user name, password for password, and click OK.
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At the Welcome to the domain screen, click OK.

When the warning that you must restart dialog appears, click OK.
Click OK to close the System Properties window.

Click Yes to the pop-up message to restart the computer.

. Login to the domain by using administrator and password.
. Install Microsoft Outlook 2003 with the default settings. (Outlook 2003 doesn’t require any configuration.)
. Install LoadSim 2003 by double-clicking the loadsim.msi installation file. Accept all defaults.
. Open LoadSim 2003, and make sure no error messages appear.

. Copy c:\Program Files\LoadSim\Islog.exe file to a floppy disk or USB thumb drive. You will need this file

during the vConsolidate controller installation.

Configuring LoadSim 2003

©CoNooA~WON =

14.
15.
16.
17.
18.

19.
20.

21.

22.
23.

Start LoadSim by clicking Start Menu—->All Programs—->Exchange LoadSim->LoadSim 2003.
From the LoadSim menu bar, select Configuration->Topology Properties.

Click the Servers tab.

In the left pane, click the + next to the name of this server.

In the left pane, select the First Storage Group.

In the right pane, set the number of users to 500.

Select the Security and Credentials tab.

Leave the Credentials choice set to Login to users using the account LoadSim is running on.
In the password portion of the tab, enter the password Passwordil, and click OK.

. From the LoadSim menu bar, select Configuration-> Test Properties, and click Add.
. Click Customize Tasks.

. Select the Initialization tab.

. Enter the following settings:

e Number of messages in Inbox: 150

Number of messages in Deleted items: 1

Number of new folders: 2

Messages per new folder: 100

Number of Smart Folders: 3

Number of Rules in Inbox: 5

Initialize Free/Busy Information: Leave it unselected

Number of appointments: 25

e Number of contacts: 64

Click OK.

In the Test Properties window, change the run time to 2 hours, and click OK.

From the LoadSim menu bar, choose File->Save As.

Save a backup copy of the simulation file as C:\loadsim.sim.

From the LoadSim menu bar, select Run->Create Topology, and wait until the Creating Users and
Creating DLs tasks complete.

From the LoadSim menu bar, select Run—>Initialize Test.

When a dialog box appears with the question Do you want to initialize Public Folders from this client
machine?, click Yes.

The run is complete when the bottom left corner of the LoadSim window shows Status: Idle. This task
typically takes about 2 to 3 hours to complete.

From the LoadSim menu bar, select Run—>Run Simulation.

The run is complete when the bottom left corner of the LoadSim window shows Status: Idle. This task
typically takes a little over 2 hours to complete.

Back up the mail and database server files
For test consistency we made backup copies of the Mail and Database Server’s database files. Once you've set
up LoadSim and created its initial mail database, you need to back up that database so you can have clean

copies for each test. Do the same on the database server. We created a folder called backup on the C: drive of
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each VM for the backup files. For testing we used scripts to perform a restore before each run so we started at

the same point for each run. An example of the scripts we used for an 8-CSU restore follows:

Restore 8 CSU script
Set CSU_COUNT=8

Set SHUTDOWN_ CMD=-r

Set PREPEXCHANGE=restore reboot exchange.bat
Set PREPSYSBENCH=restore sysbench.bat

Set DBSERVER_WAIT=90

Set /A I=1
pause
: CSU_LOOP

copy %PREPSYSBENCH% \\DBServer%I%\C$\servicecontent.bat /y
copy %PREPEXCHANGE% \\192.168.%I%1.115\CS$S\servicecontent.bat /y

shutdown %SHUTDOWN CMD% -f -t %DBSERVER WAIT% -m \\DBServer$I%
shutdown $SHUTDOWN CMD% -f -t 5 -m \\JavaServer%I%

shutdown $SHUTDOWN CMD% -f -t 5 -m \\IdleServer%I%

shutdown $SHUTDOWN CMD% -f -t 5 -m \\192.168.%I%1.110

shutdown $%SHUTDOWN CMD% -f -t 5 -m \\192.168.%I%1.215

Set /A T+=1
if $I% LEQ $CSU _COUNT$ GOTO _CSU_LOOP

pause

Restore SysBench script

net stop mssglserver

sleep 1

del /F /Q "C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data\sbtest*"
sleep 1

copy /Y /V C:\sysbench backup\sbtest* "C:\Program Files\Microsoft SQL
Server\MSSQL.1\MSSQL\Data\"

sleep 1

net start mssqglserver

Restore Exchange script
dismount.vbs
sleep 5

del /F /Q E:\publ.*
del /F /Q E:\privil.~*

copy /Y "E:\backup\publ.*" E:\
copy /Y "E:\backup\privli.*" E:\

mount .vbs

REM - While we are waiting for the main Exchange services to stop,
REM - Some peripheral services will be closed in the background.
start /min net stop MSExchangeMGMT /yes

start /min net stop RESvc /yes
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start /min net stop POP3Svc /yes
start /min net stop IMAP4Svc /yes
start /min net stop NntpSvec /yes
start /min net stop SMTPSVC /yes

REM - Stop Exchange main services before shutdown to avoid timing conflicts.

net stop MSExchangeES /yes
net stop MSExchangeIS /yes
net stop MSExchangeMTA /yes
net stop MSExchangeSA /yes

REM - Well, why not stop other services in the background just for fun?
REM - Stopping IISADMIN will stop other dependant services like W3SVC, and
HTTPFilter (SSL).

start /min net stop IISADMIN /yes

start /min net stop MSSEARCH /yes

start /min net stop Spooler /yes

shutdown -r -f -t 15

vConsolidate controller
You use a separate physical system, the controller, to manage the vConsolidate workload. We used a single
section both for this function and as the controller system for the first CSU’s WebBench benchmark. This
controller offers a graphical user interface (GUI) to start and stop the vConsolidate workload. After the workload
finishes, the controller copies the independent benchmark result files from all the VMs and combines their results
into a single file, results.txt. We performed the following steps to set up this vConsolidate controller:

1. With Windows explore, create a C:\vCON directory.

2. Copy all files from the \wvCON_framework\controller directory of the vConsolidate package to c:\vCON.

3. Copy the Islog.exe file the mail client installation created to c:\vCON.

The vCON directory contains a Profiles sub-directory. The Profiles directory contains four sample profiles,
1CSU.profile, 2CSU.profile, 3CSU.profile, 4CSU.profile and a blank template, Profile.template. vConsolidate uses
these files to identify the number and name of the VMs a test should include. An example 1CSU.profile contains
the following:

<Profile>

<Name>1 CSU</Name>
<CSUNum>1</CSUNum>

<Servers>

<DB>

<0S>Win</0S>
<Host>DBServerl</Host>

</DB>

<Loadsim>
<Host>192.168.202.110</Host>
</Loadsim>

<Java>

<0S>Win</0S>
<Host>JavaServerl</Host>
</Java>

<WebBench>
<Host>192.168.202.210</Host>
</WebBench>

</Servers>

</Profile>
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Running vConsolidate

To run vConsolidate and get consistent results, you must first prepare the VMs with clean copies of the test data.
We outline below the process for getting ready to run the workload. We then explain how to start and stop the
workload. Finally, we detail how to find its results.

Preparing the vConsolidate run
Prior to running vConsolidate we restore the backup Mail and Database Server backup files, so we can ensure
consistent results.

Verify connectivity and setting profiles

1.
2.

Open a command prompt by selecting Start->Run, type cmd, and click OK.

Type the following commands at command prompt:

e net use \\loadsim client IP Address\c$

e net use \\JavaServerl\c$

e net use \\DBServerl\c$

e net use \\WebBench Controller IP Address\c$

Verify that the vConsolidate controller can read and write remote files to all VMs with the following
commands:

With Windows Explorer, create an empty file, dummy.txt.

copy dummy.txt \\loadsim client IP Address\c$

copy dummy.txt \\JavaServerl\c$

copy dummy.txt \\DBServerl\c$

e copy dummy.txt \\WebBench Controller IP Address\c$

Modify the profile file by entering the VM name or IP address appropriate to each VM in the test. For the
one-CSU test, enter four server names or IP addresses; for the two-CSU test, enter eight.

Startlng and stopping vConsolidate

oAM=

®© N

9.

10.
11.
12.
13.
14.
15.

16.
17.
18.

19.

Shut down all VMs by selecting Start->Shutdown and then selecting Shutdown from the window.
In the left pane of the Virtual Infrastructure Client window, highlight localhost.localdomain.
Select the Summary tab in the right pane.
Click Reboot under the Commands section.
While the server is rebooting, reboot all clients in the test bed.
After the Hyper-V Server has rebooted, login using the Virtual Infrastructure Client, and start all VMs in
the test.
Once the VMs are up, log the LoadSim client(s) into the appropriate domain(s).
Double-click Daemon.exe manually on the following VMs and systems:
a. DataServer1
b. JavaServer1
c. LoadSim client
d. WebBench controller
Start the WebBench Controller application on the WebBench controller system by selecting Start->All
Programs—->PC Magazine Benchmarks.
In the WebBench Controller application, choose the Clients menu, and click Start Log In.
Double-click the WebBench 5.0 client shortcut on all the WebBench test client desktops.
Once all the client machines are logged into WebBench, click OK.
At the Would you like to add a test suite? dialog, click Yes.
In the Select a test suite window, choose vConsolidate.tst, and click OK.
When the Would you like to start executing the test suites? window appears, do NOT click Yes or No. The
vConsolidate controller application will handle that task that at the start of the test.
Double-click c:\vCON\vconsolidate.exe.
Select the profile name you want to run.
Wait 10 minutes to allow all virtual machines and Hyper-V Server to load all processes and become
completely idle.
Click start.
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20. The vConsolidate controller software will immediately start the LoadSim application. LoadSim will take
about 60 to 80 seconds to log 500 users onto the Exchange Server. The remaining benchmarks will start
once all the LoadSim users have logged in.

21. After about 30 minutes, vConsolidate controller application will stop the benchmark and collect their
results.

Locating and interpreting the results file
vConsolidate places all result data in the following location:

¢:\vCON\vCONMM-dd-hh-mm

where MM is the month, dd is the day, hh is the hour, and mm is the minute of the test. The file result.txt in that
directory summarizes all the results. It contains the following information:

Java transaction score

Database transaction score

Mail transaction score

Web server throughput

Start and stop times

Figure 11 shows an example results.txt file for a test with one CSU. We have labeled each score with a brief
description. See the Test results section for more information on how we used these individual results to calculate
each server’s overall score on the workload.

B result.txt [ZI @I E|

File Edit Format View Help

UL
T L ) e

DB T Number=231093—— .
als Rl Database Score LoadSim Score
—————————— TEMP. TXT
weighted avg &0 14015 122 215 132 68 <--"score"

—————————— VCONSOLIDATE.RLG

A,4_client, 8,/1706. 959, 6908069, 563, 0,
A,4_client, 8,/1622.183, 6576748, 875, 0,
A,4_client, 8,[1558. 335, 6241389. 500, 0,

11:44:39.921
12:15:44.140

VWebBench Score

Figure 11: Example of vConsolidate results file.

Power measurement procedure

To record each server’s power consumption during each test, we used an Extech Instruments (www.extech.com)
380803 Power Analyzer / Datalogger. We connected the power cord from the server under test to the Power
Analyzer’s output load power outlet. We then plugged the power cord from the Power Analyzer’s input voltage
connection into a power outlet.

We used the Power Analyzer’'s Data Acquisition Software (version 2.11) to capture all recordings. We installed the
software on a separate Intel-processor-based PC, which we connected to the Power Analyzer via an RS-232
cable. We captured power consumption at one-second intervals.

To gauge the idle power usage, we recorded the power usage while each server was running the operating
system but otherwise idle. To ensure the server was idle, we allowed the server to boot and power on all virtual
machines. Once the virtual machines had booted, we waited for 15 minutes to allow everything to stabilize. Then
we recorded two minutes of idle power (in watts) at one-second intervals.
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To compute the average power usage, we averaged the power usage during the time the server was producing
its peak performance results. We call this time the power measurement interval. See Figure 5 (idle and average
peak power) for the results of these measurements.
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Appendix A — Test system configuration information
Figure 12 provides detailed configuration information about each of the test server systems, which we list in

alphabetical order by processor name.

AMD Opteron Intel Xeon Intel Xeon Intel Xeon
Servers processor processor processor processor
8360 SE- X5470-based X7350-based X7460-based
based server server server server
General processor setup
Number of processor packages 4 2 4 4
Number of cores per processor 4 4 4 6
package
Number of hardware threads per core | 1 1 1 1
System Power Management Policy Always On Always On Always on Always on
CPU
Vendor AMD Intel Intel Intel
N Opteron 8360 Intel Xeon Intel Xeon Intel Xeon
ame SE processor processor processor
X5470 X7350 X7460
Stepping 3 A B 1
Socket type (8102%(% F fgcAket 771 Socket P (478) | Socket P (478)
Core frequency (GHz) 2.50 3.33 2.93 2.66
Front-side bus frequency (MHz) 2,000 with 1,333 1,066 1,066
HyperTransport | "’ ’ ’
L1 64KBx64 KB |32KB+32KB | 32KB+32KB | 32KB + 32 KB
cache
(per core) (per core) (per core) (per core)
4 x 512 KB 2x6 MB (each | 2x4 MB (each | 3x3 MB (each
L2 cache (512 KB per 6 MBs shared 4 MBs shared 3 MB shared by
core) by 2 cores) by 2 cores) 2 cores)
L3 cache 2MB N/A N/A 16 MB
Platform
Vendor and model number HP DL585 G5 Intel Intel Fox Cove | Intel Fox Cove
PAAXHOHI9SW | Supermicro
Motherboard model number 30B1 X7DB8 S7000FC4UR S7000FC4UR
Motherboard chipset EV'D'A NFOrce | |ntel 6321ESB | Intel ID3600 | Intel ID3600
ro 2050
Motherboard revision number OH 92 01 01
Phoenix Intel Intel
BIOS name and version HP AQ7 Technologies SFC4UR.868.0 | SFC4UR.868.0
(06/27/2008) LTD 2.1 1.00.0024.0613 | 1.00.0024.0613
(06/23/2008) 20082253 20082253
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AMD Opteron Intel Xeon Intel Xeon Intel Xeon
Servers processor processor processor processor
8360 SE- X5470-based X7350-based X7460-based
based server server server server
Power
Regulator for
ProLiant set to
Static
Performance Enabled Intel Enabled Intel Enabled Intel
BIOS settings Mode, enable Virtualization Virtualization Virtualization
AMD Technology Technology Technology
Virtualization
and No-
Execute Page-
Protection
Memory module(s)
ELPIDA Kingston Kingston Kingston
Vendor and model number EBE41AE4ACF | KVR667D2D4F | KVR667D2D4F | KVR667D2D4F
A-6E-E 5/2G 5/4Gl 5/4Gl
Type PC2-5300 PC2-5300 FB- | PC2-5300 FB- | PC2-5300 FB-
DDR2 DDR2 DDR2 DDR2
Speed 667 667 MHz 667 MHz 667 MHz
Speed in the system currently 667 667 MHz 667 MHz 667 MHz
running @
Timing/Latency (tCL-ARCD-IRP- 5-5-5-15 5-5-5-11 5-5-5-15 5-5-5-15
tRASmiIn)
RAM Module Size 4 GB 2GB 4 GB 4 GB
Number of RAM modules 16 16 16 16
Chip organization Double-sided Double-Sided Double-sided Double-sided
Total System Memory 64 GB 32 GB 64 GB 64 GB
Hard drive
HP Seagate Seagate
Vendor and model number pGo72eABCE | WP740ADFD | 5197340155 | ST973401SS
Number of disks in system 2 2 2 2
Size 72 GB 74 GB 73.4 GB 73.4 GB
Buffer size 16 MB 16 MB 8 MB 8 MB
RPM 10,000 10,000 10,000 10,000
Type SAS SAS SAS SAS
Smart Array Intel ESB2 Integrated Intel | Integrated Intel
Controller P400 Controller SATA RAID RAID Controller | RAID Controller
Controller SROMBSASFC | SROMBSASFC
Driver HP 6.12.4.64 Intel 8.2.0.1001 | LSI 2.13.0.64 LSI 2.13.0.64
Operating system
Microsoft Microsoft Microsoft Microsoft
Windows Windows Windows Windows
Name Server 2008 Server 2008 Server 2008 Server 2008
Enterprise x64 | Enterprise x64 | Enterprise x64 | Enterprise x64
Edition Edition Edition Edition
Build number 6001 6001 6001 6001

Service Pack

Service Pack 1

Service Pack 1

Service Pack 1

Service Pack 1

File system

NTFS

NTFS

NTFS

NTFS
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AMD Opteron Intel Xeon Intel Xeon Intel Xeon
Servers processor processor processor processor
8360 SE- X5470-based X7350-based X7460-based
based server server server server
Kernel ACPI x64- ACPI x64- ACPI x64- ACPI x64-
based PC based PC based PC based PC
Language English English English English
Microsoft DirectX version 10 10 10 10
Graphics
Vendor and model number ATI ES1000 ATI ES 1000 ATI ES1000 ATI ES1000
Chipset ATI ES1000 ATI ES1000 ES1000 ES1000
BK-ATI BK-ATI BK-ATI BK-ATI
BIOS version VERO008.005.0 | VERO008.005.0 | VERO008.005.0 | VERO008.005.03
13.000 07.001 31.000 1.000
Type Integrated Integrated Integrated Integrated
Memory size 32 MB 16 MB 32 MB 32 MB
Resolution 1,280 x 1,024 1,280 x 1,024 1,024 x 768 1,024 x 768
Network card/subsystem
Broadcom
Vendor and model number BCM5706C Intel PRO/1000 | Intel PRO/1000 | Intel PRO/1000
NetXtreme Il EB EB EB
GigE
Type Integrated Integrated Integrated Integrated
. . Microsoft
Driver version 37190 Intel 9.12.17.0 Intel 1.2.79.9 Intel 1.2.79.9

Vendor and model number

Intel PRO/1000
PT

Intel PRO/1000
PT

Intel PRO/1000
PT

Intel PRO/1000
PT

Type PCle PCle PCle PCle
Driver version Intel 10.2.28.0 Intel 10.2.28.0 Intel 10.2.28.0 Intel 10.2.28.0
Optical drive
HL-DT-ST MATSHITA Optiarc DVD- Optiarc DVD-
Vendor and model number RW/DVD GCC- | SR-8178 ROM ROM
C10N DVD/CD-ROM | DDU810A DDU810A
USB ports
Number 4 4 5 5
Type USB 2.0 USB 2.0 USB 2.0 USB 2.0
Power supplies
Total number 2 2 2 2
Wattage of each 1,300W 700W 1,570W 1,570W
Cooling fans
Total number 6 3 8 8
Dimensions 5"x5” 1-1/2” x 3-1/8” 4x80mm +4 | 4x80 mm+4
X 120 mm X 120 mm
Voltage 12V 12V 12V 12V
4x176 A+4x | 4x1.76 A+4x
Amps 3.3A 1.1A 33A 33A

Figure 12: Detailed system configuration information for the test servers.

Principled Technologies, Inc.: vConsolidate performance and power on quad- and
dual-processor Intel- and AMD-based servers

29



Appendix B — Complete test and power results

Figures 13 through 16 show the complete results for all three runs on the two test systems.

AMD Opteron processor 8360 SE

Score | CPU utilization | Idle power | Average power

1CSU

Run 1 33 518.08 642.97

Run 2 33 511.21 643.73

Run 3 33 507.07 643.86
2 CSUs

Run 1 2.08 63 509.68 683.13

Run 2 2.09 64 511.12 682.00

Run 3 2.08 64 515.18 681.64
3 CSUs

Run 1 2.58 90 517.62 706.68

Run 2 2.56 91 517.25 705.99

Run 3 2.56 91 517.81 705.04
4 CSUs

Run 1 2.67 96 518.92 714.90

Run 2 2.70 96 520.69 718.09

Run 3 2.70 96 524.30 711.91
5 CSUs

Run 1 2.80 98 513.91 709.72

Run 2 2.78 98 520.24 711.31

Run 3 2.78 98 529.90 714.38
6 CSUs

Run 1 2.94 99 526.51 712.93

Run 2 2.94 99 523.54 712.15

Run 3 2.95 99 517.43 711.63
7 CSUs

Run 1 3.01 100 519.91 723.09

Run 2 3.04 100 521.62 720.03

Run 3 2.70 100 528.07 720.12

Figure 13: Complete results for all three runs on the HP DL585 G5 server.
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Intel Xeon processor X5470

Score | CPU utilization | Idle power | Average power
1CSU
Run 1 1.40 59 384.89 465.93
Run 2 1.38 59 384.99 467.44
Run 3 1.38 59 385.26 467.29
2 CSUs
Run 1 2.05 92 384.66 483.84
Run 2 2.03 92 384.82 484.66
Run 3 2.03 92 385.63 485.01
3 CSUs
Run 1 213 98 386.07 485.87
Run 2 2.12 98 385.88 485.44
Run 3 2.09 98 386.20 485.65

Figure 14: Complete results for all three runs on the Intel Xeon processor X5470-based server.

Intel Xeon processor X7350

Score | CPU utilization | Idle power | Average power

1CsSU

Run 1 33 547.72 683.32

Run 2 33 546.21 679.45

Run 3 33 544.13 676.94
2CSUs

Run 1 2.22 65 543.13 784.24

Run 2 2.23 65 542.63 785.49

Run 3 2.23 65 547.43 793.12
3 CSUs

Run 1 2.86 89 538.52 820.38

Run 2 2.82 89 538.78 822.12

Run 3 2.85 89 546.18 833.54
4 CSUs

Run 1 3.03 96 543.11 830.11

Run 2 3.02 96 542.03 827.24

Run 3 3.05 96 539.63 826.62
5 CSUs

Run 1 3.12 97 547.32 840.38

Run 2 3.10 98 539.38 824.60

Run 3 3.07 98 539.97 823.53
6 CSUs

Run 1 3.12 99 524.50 802.92

Run 2 3.10 99 524.48 801.04

Run 3 3.09 99 525.82 805.72
7 CSUs

Run 1 3.04 100 525.05 799.08

Run 2 3.03 100 525.97 799.59

Run 3 2.73 100 528.53 798.60

Figure 15: Complete results for all three runs on the Intel Xeon processor X7350 server.

Principled Technologies, Inc.: vConsolidate performance and power on quad- and
dual-processor Intel- and AMD-based servers

31




Intel Xeon processor X7460

Score | CPU utilization | Idle power | Average power

1CSU

Run 1 1.19 22 534.13 606.41

Run 2 1.23 22 532.80 603.64

Run 3 1.22 22 536.38 606.73
2CSUs

Run 1 2.33 42 532.27 662.59

Run 2 2.33 43 531.68 663.83

Run 3 2.32 42 532.02 664.06
3 CSUs

Run 1 3.26 65 536.93 719.03

Run 2 3.26 65 533.15 715.86

Run 3 3.30 65 531.45 715.54
4 CSUs

Run 1 3.92 86 537.52 770.09

Run 2 3.92 85 568.33 794.08

Run 3 3.95 86 535.99 754.53
5 CSUs

Run 1 4.20 93 533.06 756.23

Run 2 4.23 94 534.18 754.68

Run 3 4.26 93 532.89 752.03
6 CSUs

Run 1 4.33 97 534.18 757.49

Run 2 4.34 97 534.77 757.91

Run 3 4.37 97 533.18 755.18
7 CSUs

Run 1 4.35 98 536.42 757.85

Run 2 4.34 98 537.30 758.29

Run 3 3.91 98 537.25 758.17
8 CSUs

Run 1 4.34 99 536.89 757.01

Run 2 4.31 99 537.47 757.03

Run 3 4.34 99 537.45 756.79

Figure 16: Complete results for all three runs on the Intel Xeon processor X7460 server.
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