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vConsolidate performance on dual-processor
Intel- and AMD-based servers

Executive summary

Intel Corporation (Intel) commissioned Principled
Technologies (PT) to measure performance with Intel’s
vConsolidate OEM version 1 workload on dual-processor
servers using the following processors:

¢ Quad-Core AMD Opteron 2347 (1.9GHz)
e Quad-Core Intel Xeon X5365 (3.0GHz)
¢ Quad-Core Intel Xeon X5460 (3.16GHz)

Figure 1 provides a normalized comparison for the test
servers with the optimum vConsolidate work units, which it
calls consolidation stack units (CSUs). (See the Workload
and later sections for more on CSUs.) This chart
normalizes the results to the lowest single one-CSU result.

KEY FINDINGS

e The Quad-Core Intel Xeon X5460-based
server delivered 103.28 percent more
performance with the optimum number of
CSUs than the Quad-Core AMD Opteron
2347-based server (see Figure 1).

e The Quad-Core Intel Xeon X5460-based
server delivered 18.39 percent more
performance with the optimum number of
CSUs than the Quad-Core Intel Xeon X5365-
based server (see Figure 1).

That system’s score is thus 1.00. Normalizing makes

each data point in the chart a comparative number, with higher numbers indicating better performance.

In this section, we discuss the best results for all servers. For complete details of the performance of each server

with varying CSUs, see the Test results section.

As Figure 1 illustrates, the Quad-Core Intel Xeon X5460-based server delivered the highest performance at the
three-CSU vConsolidate workload, delivering a 103.28 percent performance increase over the Quad-Core AMD
Opteron 2347-based server, which delivered its highest results with two CSUs. Furthermore, the Quad-Core Intel
Xeon X5460-based server delivered an 18.39 percent performance increase over the Quad-Core Intel Xeon
X5365-based server, which delivered maximum performance with two CSUs.
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consuming 100 percent of the CPU capacity or very close to that amount.

vConsolidate sums the throughput results of each type of work across all CSUs in a test. Then it amalgamates the
combined throughputs of all CSUs to create an overall score for the server under test. See the Test results
section for more information on this process.

vConsolidate uses the following four performance tests:

LoadSim

Microsoft Exchange Server 2003 Load Simulator (LoadSim) is a benchmark that measures a server’s
performance handling email. LoadSim uses the MAPI Messaging Benchmark 3 (MMB-3) to simulate MAPI email
clients. The simulated clients issue requests to an Exchange server to generate an email load. LoadSim
measures both the server’s response time and the number of messages it delivers. LoadSim is available for free
download from www.microsoft.com/downloads/details.aspx?Familyld=92EB2EDC-3433-47CA-A5F8-
0483C7DDEAS85&displaylang=en.

SPECjbb2005

SPECjbb2005 is an industry-standard benchmark from the Standard Performance Evaluation Corp. (SPEC) that
measures a server’s Java performance. SPEC modeled SPECjbb2005 on the three-tier client/server architecture,
with the middle layer as the primary focus. According to SPEC, “Random input selection represents the first (user)
tier. SPECjbb2005 fully implements the middle tier business logic. The third tier is represented by tables of
objects, implemented by Java Collections, rather than a separate database.” For more information about
SPECjbb2005, see www.spec.org/jbb2005/docs/UserGuide.html.

The results we quote here for this workload are not official SPECjbb2005 results because the vConsolidate
workload uses a slightly modified version of the benchmark. These results are not comparable to SPECjbb2005
results on SPEC’s Web site.

SysBench

The developers at SourceForge.net (www.sourceforge.net) created SysBench to test various aspects of the
performance of servers running database systems. The benchmark’s original target was the MySQL database
system (see www.mysql.com). Intel created a version of SysBench 0.4.0 that would work with Microsoft SQL
Server 2005 Enterprise Edition (www.microsoft.com/sql/editions/enterprise/default.mspx). We ran that version in
our test. In the vConsolidate workload, SysBench created a 100,000-row SQL database and executed a batch of
online transaction processing (OLTP) transactions against that data.

WebBench

WebBench 5.0 (128-bit US version) is an industry-standard benchmark for Web server software and hardware. It
uses PC clients to send Web requests to the server under test. It generates performance results by incrementally
increasing the number of clients making HTTP 1.0 GET requests to the Web server; the result is a curve showing
the server’s performance under increasing load. The peak of that curve represents the peak throughput of the
server. WebBench reports both the total number of requests per second the server handled and the server’s total
throughput in bytes per second. To be certain that we found the true peak performance in our testing, we verified
that the server’s processor utilization reached or was extremely close to 100 percent during the test.

vConsolidate profiles
The vConsolidate workload comes with four sets of VM specifications, which it calls profiles. These profiles define
five key factors for each workload VM:

number of virtual CPUs (vCPUs) the workload should receive
amount of virtual RAM (vMemory) the workload should receive
the operating system (OS) the workload should run

the key application the workload should run

the workload itself
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As we noted earlier, vConsolidate refers to a single collection of these five virtual machines as a consolidate stack
unit (CSU). Depending on the type of server and its available resources, you may choose to run one or more
CSUs. The typical goal is to run enough CSUs to push the server under test to its maximum capacity by
consuming 100 percent of the CPU capacity or very close to that amount.

vConsolidate offers four profiles; we tested with Profile 2, which we detail in Figure 2.

Profile 2
vCPUs vMemory 0S Application
WebBench (Web) 2 1.5 GB Windows 32-bit s
LoadSim (mail) 1 1.5GB Windows 32-bit Exchange
SysBench (database) 2 1.5GB Windows 64-bit SQL Server
SPECjbb2005 (Java) 2 2.0GB Windows 64-bit BEA JVM
Idle 1 0.4 GB Windows 32-bit

Figure 2: The vConsolidate profile we used in our testing.

For further information on vConsolidate, please contact Intel.

Test results

The result for an execution of the vConsolidate workload amalgamates the results of all four of the workloads it
includes. To calculate a final score for a vConsolidate run, we used the following four steps, as vConsolidate
specifies:

1. Benchmark throughput = benchmark’s raw results/benchmark duration (for each of the four benchmarks)
2. Total benchmark throughput = add benchmark throughput for all CSUs in test

3. Normalized throughput = total benchmark throughput / reference system’s benchmark throughput

4. vConsolidate score = geomean (normalized throughput of all four benchmarks)

The first step in this process uses whatever raw results a benchmark produces, such as number of transactions or
operations, and the benchmark’s duration in seconds. We calculate a benchmark’s duration by subtracting the
start time of the vConsolidate test from its stop time and converting that time to seconds.

WebBench is an exception to this process, because it automatically produces a score in requests per second. For
this benchmark, we calculate the average requests per second for the three WebBench mixes that run while the
other benchmarks are running and record this result as its throughput.

The second step is to sum the throughput for a given benchmark across all CSUs. In the one-CSU case, there is
no need for this step. For the two- and three-CSU tests, we summed the throughput of each individual benchmark
across all CSUs to obtain that benchmark’s final score.

The third step is to normalize the throughput. We use the one CSU score of one of the systems under test as the
reference system and assign it a normalized score of 1.00. We then divide the summed throughput for a given
type of work by the reference score for that benchmark. This produces the normalized score for that type of work
in this test. In this test, we used as the reference score the one-CSU score on the Quad-Core AMD Opteron
2347-based server.

The last step is to take the geometric mean of the normalized throughput for all four benchmarks.
Figure 3 shows the final score (the median of three runs) and CPU utilization of the test servers by number of

CSUs. The CPU utilization percentage is the average over the period the vConsolidate workload ran. All servers
achieved CPU saturation with three CSUs.
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1CSU 2 CSUs 3 CSUs
Server vCon | % CPU | vCon % CPU vCon % CPU
score | utilization | score utilization score utilization
Quad-Core AMD Opteron 2347-based server | 1.00 | 68.84 140 | 98.57 1.34 99.41
Quad-Core Intel Xeon X5365-based server 1.66 | 58.76 2.40 93.03 2.34 98.67
Quad-Core Intel Xeon X5460-based server 1.78 | 54.41 2.80 89.98 2.84 98.21

Figure 3: vConsolidate median results for the three test systems with one, two, and three CSUs. Higher scores are better.

Figure 4 shows the one-CSU median results, by benchmark, for the test servers.

Quad-Core AMD Opteron Quad-Core Intel Xeon Quad-Core Intel Xeon
2347-based server X5365-based server X5460-based server
Benchmark 1CSU 1CSU 1CSU
Database 16,103.287 28,277.154 32,800.921
Java 168.974 314.220 339.324
Mail 6.173 10.633 10.614
Web 875.672 1,190.113 1,242.496
Score 1.00 1.66 1.78

Figure 4: vConsolidate one-CSU median results, by benchmark, for the three test servers. Higher scores are better.

Figure 5 shows the two-CSU test results, by benchmark and CSU, for the test servers.

Quad-Core AMD Opteron Quad-Core Intel Xeon Quad-Core Intel Xeon

2347-based server X5365-based server X5460-based server

Benchmark CSu 1 CSU 2 CSu 1 CSU 2 CSu 1 CSU 2
Database 11,579.322 11,861.682 21,785.874 22,568.157 28,817.261 28,317.321
Java 99.380 86.566 175.194 187.932 238.259 217.864
Mail 6.080 6.367 9.844 11.339 10.578 10.625
Web 492.747 535.424 722.909 697.909 842.117 801.556
Final score 1.40 2.40 2.80

Figure 5: vConsolidate two-CSU median results, by benchmark and CSU, for the three test servers. Higher scores are better.
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Figure 6 shows the three-CSU test results, by benchmark and CSU, for the Quad-Core AMD Opteron 2347-based

server.
Quad-Core AMD Opteron 2347-based server
Benchmark CSuU 1 CSU 2 CSU 3
Database 5,786.471 5,968.933 6,112.663
Java 50.459 54.225 53.335
Mail 6.202 6.531 6.312
Web 284.651 297.066 296.542
Final score 1.34

Figure 6: vConsolidate three-CSU median results, by benchmark and CSU, for the

Quad-Core AMD Opteron 2347-based server. Higher scores are better.

Figure 7 shows the three-CSU test results, by benchmark and CSU, for the Quad-Core Intel Xeon X5365-based

server.
Quad-Core Intel Xeon X5365-based server

Benchmark CSu 1 CSU 2 CSuU 3

Database 13,668.235 14,117.045 14,590.649
Java 81.467 79.549 90.617
Mail 10.154 11.732 11.767
Web 414.254 406.130 410.936
Final score 2.34

Figure 7: vConsolidate three-CSU median results, by benchmark and CSU, for the

Quad-Core Intel Xeon X5365-based server. Higher scores are better.

Figure 8 shows the three-CSU test results, by benchmark and CSU, for the Quad-Core Intel Xeon X5460-based

server.
Quad-Core Intel Xeon X5460-based server

Benchmark Csu 1 CSU 2 CSuU 3

Database 18,784.989 18,992.171 19,252.407
Java 114.772 108.185 109.621
Mail 10.717 11.526 12.567
Web 485.352 474.369 482.932
Final score 2.84

Figure 8: vConsolidate three-CSU median results, by benchmark and CSU, for the

Quad-Core Intel Xeon X5460 -based server. Higher scores are better.
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Test methodology

Figure 9 summarizes some key aspects of the configurations of the three server systems; Appendix A provides

detailed configuration information.

Quad-Core AMD Quad-Core Intel Quad-Core Intel
Server Opteron 2347 Xeon X5365 Xeon X5460
(1.9GHz) (3.0GHz) (3.16GHz)
Processor frequency (GHz) 1.9 3.0 3.16
. 2,000
Front-side bus frequency (MHz) HyperTransport 1,333 1,333
Number of processor packages 2 2 2
Number of cores per processor
4 4 4
package
Number of hardware threads per core 1 1 1
Supermicro Supermicro Supermicro
Motherboard H8DMU+ X7DBE+ X7DBE+
Chipset nForce Pro 3600 Intel 5000P Intel 5000P
PC2-5300 FB- PC2-5300 FB-
RAM PC2-5300 DIMM DIMM DIMM
Hard drive Western Digital Western Digital Western Digital
WD1600YD WD1600YD WD1600YD

Figure 9: Summary of some key aspects of the server configurations.

With the following exceptions we used the default BIOS settings on each server. On the Quad-Core Intel Xeon
X5365-based server we disabled Hardware Prefetcher and High Bandwidth FSB and enabled Intel Virtualization
Technology. On the Quad-Core Intel Xeon X5460-based server we disabled Hardware Prefetcher and enabled
Intel Virtualization Technology. We changed the ACPI Version Features to ACPI v3.0 on the Quad-Core AMD
Opteron 2347-based server.

To be sure we could push the processors of each of the three system configurations to their maximum capacities,
we tested each server with as many vConsolidate CSUs as the server could handle, starting with one CSU, up to
or extremely close to 100 percent processor utilization. The rest of this section details how we set up the servers

and the vConsolidate workload.

Hardware and software the test involved

Software
We used the following software to configure and run the vConsolidate workload:

VMware ESX Server 3.5.0 build 59330

VMware Virtual Infrastructure Client version 2.5.0
Microsoft Windows Server 2003 R2, Enterprise Edition
Microsoft Windows Server 2003 R2, Enterprise x64 Edition
Microsoft Exchange Server 2003

Microsoft SQL Server 2005

BEA JRockit 1.5.0_10-b03

WebBench 5.0

Microsoft Exchange Server Load Simulator (LoadSim) 06.05.7775
SPECjbb2005 v1.07

SysBench v0.4.0
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e Intel vConsolidate OEM framework package version 1
e VMware Converter 3.0.2

Hardware
Our test bed consisted of the following hardware:

e The server under test

e Eight custom-built Intel Desktop Board D915GMH with Intel Pentium 4 3.0GHz w/HT systems, which we
used for all WebBench clients, LoadSim clients, and WebBench controllers (CSU 2 and CSU 3).

e One custom-built Intel Server Board S5000PSL system, which we used as both the main vConsolidate
controller and the CSU 1 WebBench controller

e Netgear GS724T, which we set up into two VLANs (one for external network and one for internal network)

o Network Appliance NetApp FAS960 filer

e Two Network Appliance DS14 Disk Shelves, with 14 x Seagate Cheetah ST373307FC 73.4 GB disk
drives each

e QLogic SANblade QLE2462 Dual Port 4-Gbps Fibre Channel Host Bus Adapter (HBA) installed in the
server under test

Figure 10 illustrates this test bed in its three-CSU configuration.

vConsolidate three-CSU test bed

CSU #2 WebBench Ccsu#2
External network controller LoadSim client
CSUnTa‘Iir\:‘J::"B;:ItI::rand switch Server under test IP address = IP address =

(see additional IP address

with four active NICs 192.168.22.211 192.168.21.110
information below) - .

CsuU #2
WebBench
client
IP address =
192.168.22.211

CSU# CsuU #1
LoadSim client WebBench client
IP address = IP address = CSU #3 WebBench CSU #3
192.168.11.110 192.168.12.211 client LoadSim client
IP address = IP address =
192.168.32.211 192.168.31.110
CSU #3 WebBench
controller
IP address =

192.168.32.211

Additional IP address information
Server under test: External network = 192,168.0.250; Internal network (one for each CSU's WebBench and LoadSim traffic)

Main controller: External network IP address = 192.168.0.100
Internal network IP address = 192.168.11.100; 192.168.12.100; 192.168.21.100; 192.168.22.100; 192.168.31.100; 192.168.32.100

VM IP addresses: JavaServer1 - 3, DBServer1 - 3, IdleServer1 - 3= DHCP

WebServer! = 192.168.12.215; WebServer2 = 192.168.22.215; WebServerd = 192.168.32.215
MailServer1 = 192.168.11.115; MailServer2 = 192.168.21.115; MailServer3 = 192.168.31.115

Figure 10: Our vConsolidate test bed.
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Server installation

We configured all servers with the same disk setup using the NetApp FAS960 filer. We split the storage into four
volumes, one with 10 GB and three with 130 GB. For each server, we installed VMware ESX Server on the 10GB
volume and installed a CSU on each of the three 130GB volumes. We installed the boot loader on the hard drive
installed in the server’s drive chassis on the server under test.

Installing VMware ESX Server 3.5.0
We did the following to install VMware ESX Server 3.5.0 build 59330 on the server under test (SUT):

Pob=

® N O

9.

10.
11.
12.
13.

Boot with the VMware ESX Server CD.

When prompted, press Enter to boot in graphical mode.

Press Enter to skip the media test.

Click Next through the following screens (accepting the default options): Welcome, Select Keyboard,
Select Mouse, and License Agreement.

Select Recommended for the disk partitioning option, and click Next.

When the warning appears that all partitions will be lost, click Yes.

Click Next to accept the partition disks settings.

At the advanced options screen (the default option is to boot VMware ESX Server from the hard drive),
click Next.

Enter the static IP address (192.168.0.250) and subnet mask (255.255.255.0), and click Next.
Select the time zone, and click Next.

Enter the root password, and click Next.

At the About to install screen, click Next to start the installation.

When the server installation completes, click Finish to reboot the server.

Installing Virtual Infrastructure Client on the controller

We managed VMware ESX Server with a separate system we call the controller. We ran Microsoft Windows
Server 2003, Enterprise Edition on this system and connected it to the VMware ESX Server with a network
switch. We followed this process to install the necessary VMware Infrastructure Client software on this system.

1.

pOD

®NoOO»

On the remote client, open a Web browser, and type the server’s IP address (http://192.168.0.250) in the
address pane.

At the VMware ESX Server 3 Welcome page, select download the VMware Infrastructure Client.

When the file download security warning pops up, click Run to install the client software.

Install the client software by clicking Next through the installation option windows (which accepts all
default options).

When the installation completes, click Finish.

Close the Web browser window.

Launch the VMware Infrastructure Client application by double-clicking the desktop icon.

At the client log in screen, enter the VMware ESX Server IP address (192.168.0.250), root user, and
password, then click Log on.

Before you can properly use the VMware ESX Server, you must first install a license file. You can deploy
that file with either host-based or server-based licensing. For our testing, we used the host-based license
method by following these steps:

a. Toinstall the license, click the Configuration tab in the Virtual Infrastructure Client.

b. Under the Software section on the left side of the screen, click Licensed Features.

c. Make sure the license file (which VMware should have provided with the copy of VMware ESX
Server) is on the controller.

Click Edit next to the License Sources.

In the pop-up window, select Use Host License File.

Click the browse button, and browse to the location of the license file on the server.

Click open to select the file.

Click Edit next to VMware ESX Server License Type.

Select VMware ESX Server Standard, and click OK.

@™o o
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Configuring network adapters with Virtual Infrastructure Client

Before we set up the VMs, we had to configure the network adapters on the VMware ESX Server. To
accommodate all the network traffic the test required, we used four network ports on the VMware ESX Server, as
Figure 10 illustrates.

We assigned the external network port the IP address of 192.168.0.250 during the VMware ESX Server
installation, because this is the network port that the Virtual Infrastructure Client, and the database, Java, and idle
VMs use to communicate.

The remaining three network ports are part of the internal network, on which the Web and mail server traffic
travels. We configured one network port to handle traffic from the Web and mail VMs for only one CSU.
Therefore, each CSU had its own network port for network traffic.

We did the following to configure the VMware ESX Server for the network adapters:

Within the Virtual Infrastructure Client window, select the configuration tab for the VMware ESX Server.
In the hardware section, select networking to view the network setup.
Click Properties for Virtual Switch vSwitchO.

In the vSwitchO Properties window, highlight the Virtual Machine Network, and click Edit.
Rename the Network Label to External Network.

Click OK to close the window.

Click Close to close the Properties window.

On the Networking configuration tab, click Add Networking.

Select Virtual Machine for the connection type, and click Next.

10. Under Create a virtual switch, select vmnic1, and click Next.

11. Change the Network Label to Internal Network 1, and click Next.

12. At the summary page, click Finish.

13. At the Networking configuration tab, click Add Networking.

14. Select Virtual Machine for the connection type, and click Next.

15. Under Create a virtual switch, select vmnic2, and click Next.

16. Change the Network Label to Internal Network 2, and click Next.

17. At the summary page, click Finish.

18. At the Networking configuration tab, click Add Networking.

19. Select Virtual Machine for the connection type, and click Next.

20. Under Create a virtual switch, select vmnic3, and click Next.

21. Change the Network Label to Internal Network 3, and click Next.

22. At the summary page, click Finish.

©CoNoOOA~LON =

Creating a virtual machine

The steps below describe how we created a base virtual machine. We followed these basic steps to create each
of the VMs the test required. We list the exact parameters we specified for each VM in the section below on
installing and configuring that VM.

In Virtual Infrastructure Client, highlight the VMware ESX Server (localhost.localdomain).
Select File>New->Virtual Machine.

Select Custom on the Select the Appropriate Configuration screen, and click Next.

Enter the Virtual Machine Name, and click Next.

Select the Storage that will hold the VM, and click Next.

Select the Operating System for the VM, and click Next.

Use the dropdown box to select the number of virtual processors for the VM, and click Next.
Select the amount of memory for the VM, and click Next.

Select the Network Connection for the VM, and click Next.

10 Accept the default option for the SCSI Adapter and click Next.

11. Leave the default option to create a new virtual disk on the Select a Disk screen, and click Next.

CoNO>OA~LON =
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12. Enter the virtual disk size, and click Next.
13. Leave the default options for the Specify Advanced Options, and click Next.
14. Review the virtual machine summary, and click Finish to create the virtual machine.

To create one vConsolidate CSU, we had to create the five virtual machines that CSU describes:

mail server

Web server

Java application server
database server

idle server

The following subsections detail how we created and configured each of these VMs.

Installing and configuring the mail server VM

1.

aobhwd

Follow the steps in the earlier Creating a virtual machine section using the following VM specifications:

e Name: MailServer1

e Virtual processors: 1

e Virtual memory: 1.5 GB

e Virtual disk size: 10 GB

e Virtual network: Internal Network (set the IP address to 192.168.11.115 in Windows within the VM)
Install Microsoft Windows Server 2003 R2, Enterprise Edition in the VM.

Install Microsoft Windows Server 2003 Service Pack 2 with default settings.

Right-click the MailServer1 VM in the Virtual Infrastructure Client window, and select Install VMware tools.
Reboot the VM.

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Installing the domain controller

1. Select Start->Administrative Tools->Manage Your Server.

2. Click Add or remove a role.

3. Atthe Configure Your Server window, click Next.

4. At the Configuration and Options screen, select Custom Configuration, and click Next.

5. Atthe Server Role screen, select Domain Controller, and click Next.

6. Atthe Summary of Selections screen, click Next.

7. At the Welcome pop-up window, click Next.

8. At the Operating System Compatibility screen, click Next.

9. For the Domain Controller Type, leave the default option (Domain controller for a new domain), and click
Next.

10. At the Create New Domain screen, leave the default (Domain in a new forest), and click Next.

11. At the Install or Configure DNS window, select No, and click Next.

12. At the New Domain Name screen, type a domain name (vcon.com), and click Next.

13. At the NetBIOS Domain Name screen, enter a NETBIOS domain name (vcon), and click Next.

14. Click Next through the following screens: Database and Log Folders, Shared System Volume, and
Permissions. Doing so accepts the default options for each of those screens.

15. At the Directory Services Restore Mode Administrative Password screen, enter a password (password),
and click Next.

16. When the installation software prompts you to do so, insert the OS CD, and click OK.

17. At the Completing the Active Directory Installation Wizard screen, click Finish.

18. When the system prompts you to reboot the VM, click Restart Now.

19. After the VM reboots, login to the system.

20. At the This Server is Now a Domain Controller window, click Finish.
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Installing Internet Information Services 6.0

CoNO>ORA®N =

Select Start->Control Panel->Add or Remove Programs.

Click Add/Remove Windows Components.

Select Application Servers, and click Details.

Click ASP.NET, and make sure a check appears in the check box.

Select Internet Information Services (IIS), and click Details.

Click NNTP Services and SMTP Services, make sure a check appears in both check boxes, and click OK.
Click OK to close the Application Server window.

At the Windows Components Wizard, click Next to begin the installation.

When the system prompts you to do so, insert the OS CD, and click OK.

10 At the Completing the Windows Components Wizard window, click Finish.
11. Close the Add or Remove Programs window.

Installing Exchange Server 2003

1.

Noohr~®ON
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Insert the Microsoft Exchange Server 2003 CD. The CD should automatically launch the installation
software.
Choose Exchange Server Enterprise Edition.
Run the Setup application.
Click the Exchange Deployment Tools link.
Click the Deploy the first Exchange 2003 Server link.
Click the New Exchange 2003 Installation link.
Click the Run ForestPrep now link.
a. When the compatibility issue notice appears, click Continue, and check the Don’t display this
message again box.
At the Welcome screen, click Next.
Accept the End User License Agreement, and click Next.
At Component Selection Screen, keep the defaults, and click Next.
Leave the default account information, and click Next.
Installation should start. (This process may take a while to complete.)
When the installation completes, click Finish.
turn to the Exchange Server Deployment Tools screen, and click the Run DomainPrep now link.
At the Welcome screen, click Next.
Accept the End User License Agreement, and click Next.
At Component Selection Screen, keep the defaults, and click Next.
At the insecure domain notice, click OK.
When the installation completes, click Finish.
eturn to the Exchange Server Deployment Tools screen, and click Run Setup Now.
At the Welcome screen, click Next.
Accept the End User License Agreement, and click Next.
At the Component Selection screen, the action for Microsoft Exchange should by default be Typical.
(If it is not, use the drop-down box to set it to Typical.)
Click Next.
For the Installation Type, select Create new Exchange Organization, and click Next.
Enter vcon as the Organization Name, and click Next.
Accept the Microsoft Exchange Server Licensing Agreement, and click Next.
Review the installation summary, and click Next.
The installation should start. (This process may take a while to complete.)
When the installation completes, click Finish.

CoPBIOLOTD QTR R0DT

10. Close the Exchange Server Deployment Tools window.

11. Install Microsoft Exchange Server 2003 Service Pack 2.
a. Insertthe SP2 CD, and double-click setup exe.
b. Accept the default location to extract the file, and click OK.
c. After the extraction finishes, open Windows Explorer, and browse to the update.exe executable.
d. Atthe Welcome screen, click Next.
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e. Select | agree to accept the License Agreement, and click Next.
f. At the Component Selection window, leave the default option (Update), and click Next.
g. Verify the installation Summary, and click Next.
h. When the installation completes, click Finish.
12. In the Virtual Infrastructure Client console, add a new 90GB virtual hard disk to this VM by doing the
following:
Right-click the MailServer1 VM, and select Edit Settings from the menu.
On the Hardware Tab, click Add.
For Select Device Type, choose Hard Disk, and click Next.
Select Create a new virtual disk, and click Next.
Set the Disk Capacity to 90 GB, and click Next.
At the Specify Advanced Options page, leave the default options, and click Next.
At the Read to Complete screen, click Finish.
Wait for the Reconfigure Virtual Machine task to complete. (The status will appear in the Recent
Tasks section, which is at the bottom of the Virtual Infrastructure Client window.)
13. Restart the VM by selecting Start->Shut down->Restart inside the MailServer VM.
14. In the MailServer VM, right-click My Computer, and select Manage.
15. In the Computer Management Console, select Disk Management.
16. When a Welcome to Initialize and Convert Disk Wizard window appears, click Next.
17. Select Disk 1 to Initialize.
18. At the Select Disk to Convert screen, leave the disk unchecked.
19. At the Completing the Initialize and Convert Disk Wizard screen, click Finish.
20. Right-click the Disk 1 unallocated box, and select New Partition.
21. At the Welcome screen, click Next.
22. Leave the partition type as Primary, and click Next.
23. Accept the default Partition Size, which should be the same as the Maximum disk space, and click Next.
24. Assign the drive letter E, and click Next.
25. Format the partition with the NTFS File system, enter Mail Store for the volume label, and click Next.
26. At the Completing the New Partition Wizard screen, click Finish.
27. The partition should begin formatting.
28. When the formatting completes, close the Computer Management console.
29. Select Start->All Programs->Microsoft Exchange—> System Manager.
30. In the left-hand window pane, expand Servers and MailServer so the First Storage Group is visible.
31. Right-click First Storage Group, and select Properties.
32. Click Browse, and change the Transaction log and System path location to E:\.
33. Check the Enable circular logging box.
34. Click Apply.
35. When the pop-up message appears asking if you want to perform this task, click Yes.
36. When the message appears saying that all mounted stores are back online, click OK.
37. Right-click Mailbox Store under First Storage Group, and select Properties.
38. Select the Database tab.
39. Click Browse, and move the Exchange database and Exchange streaming database to E:\.
40. Check the This database can be overwritten by a restore box.
41. Click Customize next to Maintenance interval.
42. Remove all blue from the boxes so the system will not perform maintenance, and click OK.
43. At the Mailbox Store Properties window, click Apply.
44. When a warning message appears, click Yes.
45. When the message that the database files have been moved appears, click OK.
46. Click OK to close the Mailbox Store Properties window.
47. Right-click Public Store under First Storage Group, and select Properties.
48. Select the Database tab.
49. Click Browse, and move the Exchange database and Exchange streaming database to E:\.
50. Check the This database can be overwritten by a restore box.
51. Click Customize next to Maintenance interval.
52. Remove all blue from the boxes so the system will not perform maintenance, and click OK.

S@r0Q0 oD
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53.
54.
55.
56.
57.

58.
59.
60.
61.

At the Public Store Properties window, click Apply.

When a warning message appears, click Yes.

When the message that the database files have been moved appears, click OK.

Click OK to close the Public Store Properties window.

In the left-hand pane of the Virtual Infrastructure Client, right-click the MailServer1 VM, and select Install
VMware Tools.

At the Install Tools pop-up window, click OK.

Click Next through the Installation Wizard to install the VMware Tools. This process accepts all defaults.
When the installation completes, click Finish.

Click Yes to reboot the virtual machine.

Installing and configuring the Web server VM

1.

4.
5.

6.

Follow the steps in the earlier Creating a virtual machine section using the following VM specifications:
e Name: WebServer1 (use WebServer for the Host Name in the VM)

e Virtual processors: 2

e Virtual memory: 1.5 GB

e Virtual Disk Size: 10GB

e Virtual Network: Internal Network (set the IP address to 192.168.12.215 in Windows within the VM)
Install Microsoft Windows Server 2003 R2, Enterprise Edition in the VM.

Install Microsoft Windows Server 2003 Service Pack 2 with default settings.

Right-click the WebServer1 VM in the Virtual Infrastructure Client window, and select Install VMware
tools.

Reboot the VM.

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Installing Microsoft Internet Information Server

1.
2
3
4
5.
6.
7
8
9.
1

0.

Select Start->Administrative Tools->Manage Your Server.

Select Add or remove a role.

At the Configure Your Server window, click Next.

At the Configuration Options screen, select Custom configuration, and click Next.

At the Server Role screen, select Application Server, and click Next.

At the Application Server Options screen, select Enable ASP.NET, and click Next

At the Summary of Selections screen, click Next.

When the installation software prompts you to do so, insert the Operating System CD, and click OK.
When the installation completes, click Finish.

Close the Manage Your Server window.

Installlng WebBench 5.0

Insert the WebBench 5.0 CD into the Virtual Client, and connect with the Virtual CDROM.

2. Copy wbtree.exe from the \wb50\workload directory on the CD to C:\inetpub\wwwroot.

3. Double-click wbtree.exe to expand the workload. (This step will create a wbtree folder with all the test
data WebBench required.)

4. Create a cgi-bin folder in c:\inetpub\wwwroot.

5. After installing the WebBench controller, copy simcgi.exe from the controller machine in
C:\WebBench\Controller\Suites\WebBench\Examples directory to the Web server VM’s
C:\Inetpub\wwwroot\cgi-bin\ directory.

6. Right-click My Computer, and select Manage.

7. Expand Services and Applications, Internet Information Services, and Web Sites in the left-hand window
pane.

8. Click Default Web Sites.

9. Right-click the cgi-bin directory in the right-hand pane, and select Properties from the drop-down menu.

10. In the Execute permissions field, select Scripts and Executables, and click OK.
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11.

12.
13.
14.
15.

16.
17.
18.
19.
20.
21.
22.
23.
24.

25.

Using Windows Explorer, browse to C:\Inetpub\wwwroot\cgi-bin, right-click simcgi.exe, and select
Properties from the drop-down menu.

Select the Security tab, and grant Read/Read & Execute permissions to the user, Internet Guest Account.
Click OK to close simcgi.exe properties.

Close Windows Explorer.

In the Computer Management window, right-click the Default Web Server, and select properties from the
drop-down menu.

Select the HTTP Headers tab, and click the MIME Types button.

In the MIME Types window, click New.

In the Extension text box, enter .ex.

In the MIME type text box, enter application/octet-stream, and click OK.

Click OK again to close the MIME Types window and the Default Web Site Properties window.

In the Computer Management console, select Web Service Extension.

Select All unknown CGI Extensions in the right pane, and click Allow.

Click Yes, you do want to allow All Unknown CGI Extensions in the pop-up window.

Open a Web browser, and type the URL http://localhost/cgi-bin/simcgi.exe to verify you correctly installed
the WebBench files. You should see text about the system inside the browser window.

Close the Web browser.

Installing Certificate Server

1.
2
3
4
5.
6.
7
8
9.
1

0.

Select Start->Control Panel->Add or Remove Programs.

Click Add/Remove Windows Components.

Select Certificate Servers, and accept the CA Service warning.

Click Next.

Select Standalone root CA in the CA Type Windows, and click Next.

Enter WEBBENCH in the common name field, and click Next.

At the Certificate Database Settings screen, leave the default options, and click Next.
When the warning about stopping 1S appears, click Yes.

Click Yes to enable Active Server Pages.

When the installation completes, click Finish.

Creating a certificate request

1.
2.

In the Computer Management Console, right-click the Default Web site, and select Properties.

Select the Directory Security tab, and then click Server Certificate under Secure Communications to start
the Web Server Certificate Wizard.

At the Welcome screen, click Next.

Select Create a new certificate, and click Next.

Select Prepare the request now, but send it later, and click Next.

Type Default Web Site for the certificate name.

Use the default bit length (1024), and click Next.

Type MyWeb for the organization name and Development Dept for the organizational unit, and click Next.
Type the server name as the common name, and click Next.

. Enter your location information, and click Next.
. Save the certificate information to the default path and file name, and click Next.
. Verify the information that you have typed, and then click Next to complete the process and create the

certificate request.

. Click Finish to close the IIS Certificate Wizard.
. Click OK to close the Default Web Site Properties window.

Submitting a certificate request

1.

Open a Web browser, navigate to http://localhost/CertSrv/, and press Enter.

2. Click Request a certificate.
3. Click Advanced certificate request.
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0.

Click Submit a certificate request by using a base-64-encoded CMC or PKCS #10 file, or submit a
renewal request by using a base-64-encoded PKCS #7 file.

Open the request document that you created in the "Create a certificate request” section.

Copy the contents of the document to a text box with the following format.

o BEGIN NEW CERTIFICATE

REQUEST-----

o - END NEW CERTIFICATE

REQUEST-------

Note: If you saved the document with the default name and location, it is located at C:\Certreq.txt. Be sure
to copy all of the content as we illustrated above.

Paste the contents of the document into the Web form’s Base64 Encoded Certificate Request text box.
Click Submit.

You should receive a Certificate Pending message in the Web browser.

Close the Web browser window.

Issuing and downloading a certificate

PN~

Select Start->All Programs—>Administrative Tools—> Certificate Authority.

In the Certificate Authority window, expand the server name.

Click the Pending Requests folder.

In the pending request folder, right-click the pending certificate request that you just submitted, select All
Tasks, and then click Issue. (Note: After you select Issue, the certificate no longer appears in this window
and folder. It now resides in the Issued Certificate folder.)

Close the Certificate Authority window.

Open a Web browser, and type http://localhost/CertSrv/.

Click View the status of a pending certificate request.

Click the certificate request that you can see.

Click Download Certificate.

. Click Save in the File Download window.

. Save the certificate to C:\.

. Close the download complete pop-up window.
. Close the Web browser window.

Installlng the certificate and setting up an SSL Web site

N

No o

8.
9.
10.
11.

12.

Open the Computer Management console by right-clicking My Computer, and selecting Manage.
Right-click the Default Web site, and select Properties.

Select the Directory Security tab.

Under Secure Communications, click Server Certificate. This step will start the Certificate Installation
Wizard.

At the Welcome screen, click Next.

Select Process the pending request and install the certificate, and click Next.

Browse to the location of the certificate that you downloaded in the Issue and download a certificate
section, and click Next.

Keep the default SSL Port, and click Next.

Verify the information is correct on the Certificate Summary page, and click Next.

Click Finish to complete the installation.

Click OK to close the Default Web Site Properties window.

Close the Computer Management window.

Configuring and testing the certificate

1.

Open a Web browser, and type https://webbench/cgi-bin/simcgi.exe.

2. You may receive a security alert that states that the certificate is not from a trusted root CA. Click Yes to
continue to the Web page.
3. If the page appears, you have successfully installed the certificate.
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4.

Close the Web browser.

Installing and configuring the Java application server VM

1.

3.
4.

5.

Follow the steps in the earlier Creating a virtual machine section using the following VM specifications:
a. Name: JavaServer1
b. Virtual processors: 2
c. Virtual memory: 2 GB
d. Virtual Disk Size: 10 GB
e. Virtual Network: External Network (keep the default Windows Network DHCP settings)
Install Microsoft Windows Server 2003 R2, Enterprise x64 Edition in the VM.
Install Microsoft Windows Server 2003 Service Pack 2.with default settings.
Right-click the JavaServer1 VM in the Virtual Infrastructure Client window, and select Install VMware
tools.
Reboot the VM.

To finish setting up this VM for vConsolidate, we had to install and modify an additional software component. The
following subsections detail the necessary installation processes.

Installing SPECjbb2005

1.
2.
3

geeNoos

Copy the BEA JRockit JVM 1.5.0_10-b03 folder to the root of C: in the VM.
Install SpecJBB2005 in the VM directory: c:\vSpecJBB2005.
Add the BEA JRockit JVM to the Windows system path by doing the following:
Right click My Computer, and select Properties.
b. Select the Advanced tab, and click Environment Variables.
c. Inthe System variables section, select Path, and click Edit.
d. Add the following to the end of the Variable value string: C:\jrockit-jdk1.5.0_10\bin (jrockit-
jdk1.5.0_10 is the folder name of the JVM installation).
e. Click OK to close the Edit System Variable, Environment Variables, and System Properties
windows.
Open a command prompt by selecting Start>Run.
Type cmd, and click OK.
Change to the vSpecdBB2005 directory by typing cd C:\vSpecJBB2005, and then press Enter.
Type runit.bat, and press Enter to verify SPECjbb2005 starts.
Press Ctrl-C to stop the benchmark.
Confirm that you do want to stop the run by typing Y and pressing Enter.

o

0 Copy the following files from the vConsolidate package to the VM directory C:\:

e Daemon.exe
e killapp.exe.

Modifying SPECjbb2005
To run the vConsolidate benchmark, you must modify SPECjbb2005 as follows:

1.

Modify the following three original source files in the SPECjbb directory (C:\SPECjbb2005\src\spec\jbb\)
by opening each file with WordPad and making the changes below. Save each file after you have made
the changes.
e Company.java
Change “private long measurement_time;” to “public long measurement_time;”.
Change “JBButil.SecondsToSleep((int) measurement_time);” to
“JBButil.SecondsToSleep(Long.MAX_VALUE/1000);".
e DeliveryTransaction.java
After the line “customerPtr.adjustBalance(matchingOrder.getTotalAmount());”, add the following lines:
int timerCount = 0;
timerCount = (short)JBButil.random(1,100);
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11.

if (timerCount == 1)
JBButil.milliSecondsToSleep(company.measurement_time);
e TransactionManager.java
Change “myTimerData.update TimerData(txntype, txntime);” to the following lines:
{
myTimerData.updateTimerData(txntype, txntime);
if (txntype==0 && myTimerData.getTransactionCount(0)%1000 == 0) {
int sum = 0;
for (int k=0; k<=5; k++)
sum += myTimerData.getTransactionCount(k);
System.out.printin("===="+this+";"+"===="+sum);

}

Open the command prompt by clicking Start->Run, type cmd, and press Enter.

At the command prompt, type cd C:\SPECjbb2005\src\spec\jbb\.

At the command prompt, type the following commands. Press Enter after each command:

e mkdir class

e "C:\Program Files\Java\jrockit-jdk1.5.0\bin\javac" -cp "C:\Program Files\Java\jrockit-
jdk1.5.0\jre\lib\rt.jar" -d class\ *.java infra\Util\*.java validity\*.java ..\reporter\*.java

e cd class\

e "C:\Program Files\Java\jrockit-jdk1.5.0\bin\jar" -cf jbb.jar spec\jbb\*.class spec\jbb\infra\Util\*.class
spec\reporter\*.class

e "C:\Program Files\Java\jrockit-jdk1.5.0\bin\jar" -cf check.jar spec\jbb\validity\*.class

Type exit to close the command prompt.

Open Windows Explorer from the start menu.

Copy the jbb.jar and check.jar files from C:\SPECjbb2005\src\spec\jbb\class to C:\vSpecJBB2005\.

When the system asks if you want to overwrite files, click Yes to overwrite the original jbb.jar and

check.jar files.

Using Windows Explorer, navigate to C:\vSpecJBB2005, and open the SPECjbb.props file.

. Make the following changes to the SPECjbb.props file:

e Change “input.starting_number_warehouses=1" to “#input.starting_number_warehouses=1"
e Change “input.increment_number_warehouses=1" to “#input.increment_number_warehouses=1"
e Change “#input.sequence_of number_of warehouses=1234567 8" to
“input.sequence_of _number_of warehouses=2"
Note: Set the above parameter to be equal to the number of vCPUs you configured for Java
server VM.
e Change “input.measurement_seconds=240" to “input.measurement_seconds=10".
In the C:\vSpecJBB2005 directory, right click runit.bat, and change “set JAVAOPTIONS=-Xms256m -
Xmx256m” to “set JAVAOPTIONS=-Xms1000m —Xmx1000m -Xxthroughputcompaction -XXallocprefetch
-XXallocRedoPrefetch -XXcompressedRefs —XxlazyUnlocking -XXtlasize128k”

Installing and configuring the database server VM

1.

Follow the steps in the earlier Creating a virtual machine section using the following VM specifications.
e Name: DBServer1

e Virtual processors: 2

e Virtual memory: 1.5 GB

o Virtual disk size: 10 GB

e Virtual network: External Network (keep the default Windows Network DHCP settings)

2. Install Microsoft Windows Server 2003 R2, Enterprise x64 Edition in the VM.
3. Install Microsoft Windows Server 2003 Service Pack 2.with default settings.
4. Right-click the DBServer1 VM in the Virtual Infrastructure Client window, and select Install VMware tools.
5. Reboot the VM.
Principled Technologies, Inc.: vConsolidate performance on dual-processor Intel- and 17

AMD-based servers



To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Installing Microsoft Internet Information Server

Select Start->Administrative Tools>Manage Your Server.

Select Add or remove a role.

At the preliminary steps screen, click Next.

At the Server Role screen, select Application Server, and click Next.

At the Summary of Selections screen, click Next.

When the installation software prompts you to do so, insert the OS CD, and click OK.
When the installation completes, click Finish.

Close the Manage Your Server window.

NGO ALON =

Installmg Microsoft SQL Server 2005

Insert the SQL Server 2005 CD into the controller, and connect with the Virtual CD ROM.

Click the Server Components link under the Install section to begin the installation.

Accept the license agreement, and click Next.

Click Next to install the prerequisites.

After the prerequisites complete installing screen, click Next.

At the Welcome screen, click Next.

At the System Configuration Check, assuming everything has a status of success click Next.
Enter the registration information, and click Next.

At the Components to Install screen, select SQL Server Database Services, then click Advanced.

SOoNooRALN =

down arrow on both and selecting Entire feature will be installed on local hard drive.
11. Click Next to start the installation.
12. For Instance Name, leave the default option, and click Next.

13. At the Service Account screen, select Use the built-in system account (Local account), and click Next.

14. Keep the default option for Authentication Mode, and click Next.

15. For Collation Settings, leave the defaults, and click Next.

16. Accept the default Error and Usage Report Settings, and click Next.
17. At the Ready to Install screen, click Install to begin the installation.

18. When the installation software prompts you to do so, insert Microsoft SQL Server 2005 disk 2. Use the

Virtual CDROM to connect it to the VM, and click OK.
19. When the setup process completes, click Next.
20. Click Finish to complete the initial installation.

21. Install Service pack 2 by copying SQLServer2005SP2-KB921896-x64-ENU.exe to the virtual machine

22. Double click the executable to launch the installer.

23. At the Welcome screen, click Next.

24. At the License Terms screen, accept the license agreement.

25. At the Feature Selection screen, click Next to accept all defaults.

26. At the Authentication screen, click Next to accept all defaults.

27. At the Error and Usage Reporting Settings screen, click Next to accept all defaults.
28. At the Running Processes screen, click Next.

29. Click install on the Ready To Install screen.

30. Click OK, on the Computer Reboot Requires message box.

31. Click Next at the Installation Complete Screen.

0. Instruct the software to install both the Database Services and Client Components by clicking the drop-

32. At the Additional Information screen, deselect “Launch the User Provisioning Tool for Windows Vista after

SP2 installation completes.”
33. Click Finish.

Creating the test database and generating data
1. Select Start->Microsoft SQL Server 2005->SQL Server Management Studio.
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10.
11.
12.

13.
14.
15.

16.
17.

18.
19.

In the Connect to Server window, use the drop-down menu next to Server name to select <Browse for
more>.

In the Browse for Server window, select the Network Servers tab, and wait for it to retrieve data.

When Database Engine appears, expand the menu, select DBSERVER1, and click OK.

At the Connect to Server window, the server name should be present.

Click Connect to connect to the server.

Right-click the Database folder in the left-hand window, and select New Database from the pop-up menu.
In the Database name field, type sbtest, and click OK.

Copy the following files from the vConsolidate package to the VM C:\ directory:

e vSysbench.exe

e Daemon.exe

e killapp.exe

Open a command prompt by selecting Start->Run, type cmd, and click OK.

In the command prompt, type cd \ to change to C:\.

To prepare the database, type “vsysbench.exe --test=oltp --oltp-table-size=100000 prepare”, and press
Enter.

When the command finishes, you see the C:\ prompt.

Type exit, and press Enter to close the command prompt.

In SQL Server 2005 Management Studio, stop the database service by right-clicking DBSERVER1 in the
left-hand window pane, and then select stop from the drop-down menu.

Using Windows Explorer, create the folder C:\backup.

With Windows Explorer, copy all sbtest files from C:\Program File\Microsoft SQL
Server\MSSQL.1\MSSQL\Data\ to c:\backup. (You should see two files: sbtest.mdf and sbtest_log.Idf.)
Close Windows Explorer once the copy completes.

Restart the database service using SQL Server 2005 Management Studio by right-clicking DBSERVER1
and selecting start.

Installing and configuring the idle server VM

1.
2.

L

Follow the steps in the earlier Creating a virtual machine section using the following VM specifications.
Use the VM Specifications below:

e Name: IdleServer1

e Virtual processors: 1

e Virtual memory: 0.4 GB

e Virtual disk size: 5 GB

e Virtual network: External Network (keep the default Windows Network DHCP settings)

Install Microsoft Windows Server 2003 R2, Enterprise Edition in the VM.

Install Microsoft Windows 2003 Service Pack 2 with the default settings.

Right-click the IdleServer1 VM in the Virtual Infrastructure Client window, and select Install VMware tools.
Reboot the VM.

Installing and configuring the second CSU

To create the VMs the second CSU requires, we used VMware Converter to make a copy of the five VMs we had
already created. We then started each VM and entered a new IP address and Host name. The following steps
explain how to copy a VM with VMware Converter. They assume you have installed the VMware Controller on the
same machine as the VMware Virtual Infrastructure Client.

CoNO>O kWD =

Open VMware Converter, and click Import Machine.

At the Welcome screen, click Next.

At the Source screen, click Next.

Select VMware ESX Server for the Source, and click Next.

Enter the IP address, user name, and password of the VMware ESX Server, and click Next.
Select the virtual machine that you want to copy (for example: JavaServer1), and click Next.
For the Source Data, leave the default (Import all disks and maintain size), and click Next.
At the Destination screen, keep the default, and click Next.

For Destination Type, select VMware ESX server, and click Next.
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10. Enter the IP address, user name, and password of the VMware ESX Server, and click Next.

11. Enter the virtual machine name (for example, if you are copying JavaServer1, the name of the second
one should be JavaServer2), and click Next.

12. Select the host system, and click Next.

13. Select the Datastore, and click Next.

14. Select the Network connection for the virtual machine, and click Next.

15. Leave the default Customization settings, and click Next.

16. Review the summary, and click Finish to begin copying the virtual machine.

Registry changes
To simplify testing, we made two registry changes to every VM we created.

Auto logon
We changed this entry to allow each VM to automatically log into the OS after a system reboot. We changed the
following Registry key to have the values we show here.

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
o "DefaultPassword"="password"
e "AutoAdminLogon"="1"
e "DefaultUsername"="administrator"

Computer name
We changed this entry to display the host’s name of the system under the My Computer desktop icon. We
changed the following Registry key to have the values we show here.

[HKEY CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002830309D)]
e "LocalizedString"=hex(2):25,00,43,00,4f,00,4d,00,50,00,55,00,54,00,45,00,52,00,\
4e,00,41,00,4d,00,45,00,25,00,00,00

Client installation

In addition to setting up the server under test, we also had to set up the client systems we show in Figure 11. Both
the WebBench and LoadSim workloads require test clients.

Installing the WebBench 5.0 test client systems

To run WebBench, you need two types of test systems. WebBench clients use WebBench software engines to
send HTTP requests to stress the server under test. A single WebBench controller system manages the clients
during as the benchmark runs.

Installlng a WebBench 5.0 client
Install Windows 2003 Enterprise Edition 32-bit. Use mailclient as the system name.

2. Install Windows Server 2003 Service Pack 2 with the default settings.

3. Open the Network Connections window by right clicking My Network Places and selecting Properties from
the menu.
Right-click the network connection, and click Properties.
Highlight TCP/IP, and select Properties.
Select Use the following IP address, and enter the following information: IP address 192.168.12.211,
Subnet 255.255.255.0.
Click OK to close the two Properties windows.
Insert the WebBench CD, and open it with Windows Explorer.
Run setup.exe from the location /wb50/client/setup.exe.
0. Click Next through all screens, a process that accepts the defaults.
1. When the installation completes, copy the WebBench shortcut icon from the open window to the system’s

desktop.

12. Close the open windows, and eject the CD.

ook
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13.
14.

15.

With WordPad, open the file c:\Windows\system32\drivers\etc\hosts.

After the last text in that file, enter the following additional lines, and click Save.
e 192.168.22.210 controller

e 192.168.22.215 server

Close the hosts file and Windows Explorer.

Installing the WebBench 5.0 controller

We used a single system as both the WebBench 5.0 controller and the vConsolidate controller. We discuss the
specifics of the vConsolidate controller in a later section. We followed this process to set up that system as the
WebBench 5.0 controller.
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11.
12.
13.
14.
15.
16.
17.
18.
19.
20.
21.
22.

Install Windows 2003 Enterprise Edition 32-bit. Use mailclient as the system name.
Install Windows Server 2003 Service Pack 2 with the default settings.

Insert the WebBench 5.0 CD.

Run /wb50/controlr/setup.exe.

Click Next through the installation, which accepts all default options.

With Windows Explorer, open C:\WebBench\Controller\Clientids\client.cdb.

Add the client’s IP address to the top of the file. Enter Tab twice, and type the number 1.
Click File=>Save, and close the client.cdb file.

Copy vConsolidate.tst file from the vCON\WebBench directory to
C:\WebBench\controller\suites\WebBench.

. Copy ecommerce_cgi_template_w2k3.tst and ecommerce_cgi_template_w2k3.wl files from

vCON\WebBench directory to C:\WebBench\controller\suites\WebBench.

Copy all files from \vCON_framework\WebBench_daemon in the vConsolidate package to C:\.
Select Start->All Programs—>PC Magazine Benchmarks>WebBench 5.0 Controller.
Click Create/Edit from the Suites drop-down menu.

Browse to the vConsolidate.tst file, and click Open.

Highlight the first Mix, and click Edit.

On the General tab, change Engines per client to 8.

Select the Workload tab.

Change the number of threads to 1.

Click the Copy across button.

Select the Engines per client and Number of threads check boxes, and click OK.
Click OK to close the suites windows.

Close the WebBench Controller window.

Installing the mail test client
Each mail server VM requires one physical test client system. We used the following process to set up each such

system.

oAM=

7.
8.
9.
10.
11.
12.
13.

Install Windows 2003 Enterprise Edition 32-bit. Use mailclient as the system name.

Install Windows Server 2003 Service Pack 2 with the default settings.

Open the Network Connections window by right-clicking My Network Places and selecting Properties.
Right-click the network connection, and click Properties.

Highlight TCP/IP, and select Properties.

Select Use the following IP address, and enter the following information: IP address 192.168.11.110,
Subnet 255.255.255.0, Preferred DNS server 192.168.11.115 (MailServer1 IP address).

Click OK to close the two Properties windows.

Right-click My Computer, and select Properties.

Click the Computer Name tab.

Click Change.

Select Domain in the member of section, and type the domain vcon.com into the text box.

In the pop-up window, enter administrator for user name, password for password, and click OK.

At the Welcome to the domain screen, click OK.
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14. When the warning that you must restart dialog appears, click OK.

15. Click OK to close the System Properties window.

16. Click Yes to the pop-up message to restart the computer.

17. Login to the domain by using administrator and password.

18. Install Microsoft Outlook 2003 with the default settings. (Outlook 2003 doesn’t require any configuration.)

19. Install LoadSim 2003 by double-clicking the loadsim.msi installation file. Accept all defaults.

20. Open LoadSim 2003, and make sure no error messages appear.

21. Copy c:\Program Files\LoadSim\Islog.exe file to a floppy disk or USB thumb drive. You will need this file
during the vConsolidate controller installation.

Configuring LoadSim 2003
1. Start LoadSim by clicking Start Menu—->All Programs—>Exchange LoadSim->LoadSim 2003.
2. From the LoadSim menu bar, select Configuration->Topology Properties.
3. Click the Servers tab.
4. In the left pane, click the + next to the name of this server.
5. Inthe left pane, select the First Storage Group.
6. In the right pane, set the number of users to 500.
7. Select the Security and Credentials tab.
8. Leave the Credentials choice set to Login to users using the account LoadSim is running on.
9. In the password portion of the tab, enter the password "Password1", and click OK.
10. From the LoadSim menu bar, select Configuration—> Test Properties, and click Add.
11. Click Customize Tasks.
12. Select the Initialization tab.
13. Enter the following settings:
e Number of messages in Inbox: 150
Number of messages in Deleted items: 1
Number of new folders: 2
Messages per new folder: 100
Number of Smart Folders: 3
Number of Rules in Inbox: 5
Initialize Free/Busy Information: Leave it unselected
Number of appointments: 25
Number of contacts: 64
14. Clle OK.
15. Check Forever (stop manually) in the Test Properties window, and click OK.
16. From the LoadSim menu bar, choose File>Save As.
17. Save a backup copy of the simulation file as C:\loadsim.sim.
18. From the LoadSim menu bar, select Run->Create Topology, and wait until the Creating Users and
Creating DLs tasks complete.
19. From the LoadSim menu bar, select Run->Initialize Test.
20. When a dialog box appears with the question Do you want to initialize Public Folders from this client
machine?, click Yes.
21. The run is complete when the bottom left corner of the LoadSim window shows Status: Idle. This task
typically takes about 2 to 3 hours to complete.

Back up the mail database

Once you’ve set up LoadSim and created its initial mail database, you need to back up that database so you can
have clean copies for each test. For testing we use NetApp Snapshot to create a copy of all VMs. This allows us
to replace the snapshot after each test run and return to the original state.

vConsolidate controller

You use a separate physical system, the controller, to manage the vConsolidate workload. We used a single
section both for this function and as the controller system for the first CSU’s WebBench benchmark. This
controller offers a graphical user interface (GUI) to start and stop the vConsolidate workload. After the workload
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finishes, the controller copies the independent benchmark result files from all the VMs and combines their results
into a single file, results.txt. To set up this vConsolidate controller, we did the following:

1.  With Windows explore, create a C:\vCON directory.
2. Copy all files from the \WCON_framework\controller directory of the vConsolidate package to c:\\vCON.
3. Copy the Islog.exe file the mail client installation created to c:\vCON.

The vCON directory contains a Profiles sub-directory. The Profiles directory contains four sample profiles,
1CSU.profile, 2CSU.profile, 3CSU.profile, 4CSU.profile and a blank template, Profile.template. vConsolidate uses
these files to identify the number and name of the VMs a test should include. An example 1CSU.profile contains
the following:

<Profile>

<Name>1 CSU</Name>
<CSUNum>1</CSUNum>
<Servers>

<DB>

<0S>Win</0OS>
<Host>DBServer1</Host>
</DB>

<Loadsim>
<Host>192.168.202.110</Host>
</Loadsim>

<Java>

<0S>Win</0S>
<Host>JavaServer1</Host>
</Java>

<WebBench>
<Host>192.168.202.210</Host>
</WebBench>

</Servers>

</Profile>

Running vConsolidate

To run vConsolidate and get consistent results, you must first prepare the VMs with clean copies of the test data.
We outline below the process for getting ready to run the workload. We then explain how to start and stop the
workload. Finally, we detail how to find its results.

Preparing the vConsolidate run
Prior to running vConsolidate we restore the NetApp Snapshot with the Network Appliance NetApp FAS960 filer,
SO we can ensure consistent results.

Verify connectivity and setting profiles
1. Open a command prompt by selecting Start->Run, type cmd, and click OK.
2. Type the following commands at command prompt:
e net use \\loadsim client IP Address\c$
e net use \JavaServer1\c$
e netuse \\DBServer1\c$
e net use \WebBench Controller IP Address\c$
3. Verify that the vConsolidate controller can read and write remote files to all VMs with the following
commands:
e With Windows Explorer, create an empty file, dummy.txt.
e copy dummy.txt \\loadsim client IP Address\c$
e copy dummy.txt \JavaServer1\c$
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4.

e copy dummy.txt \DBServer1\c$

e copy dummy.txt \WebBench Controller IP Address\c$

Modify the profile file by entering the VM name or IP address appropriate to each VM in the test. For the
one-CSU test, enter four server names or IP addresses; for the two-CSU test, enter eight.

Startlng and stopping vConsolidate

oorwN

o N

9.

10.
11.
12.
13.
14.
15.

16.
17.
18.

19.
20.

21.
22.

Shut down all VMs by selecting Start->Shutdown and then selecting Shutdown from the window.
In the left-hand pane of the Virtual Infrastructure Client window, highlight localhost.localdomain.
Select the Summary tab in the right pane.
Click Reboot under the Commands section.
While the server is rebooting, reboot all clients in the test bed.
After the VMware ESX Server has rebooted, login using the Virtual Infrastructure Client, and start all VMs
in the test.
Once the VMs are up, log the LoadSim client(s) into the appropriate domain(s).
Double-click Daemon.exe manually on the following VMs and systems:
a. DataServer1
b. JavaServer1
c. LoadSim client
d. WebBench controller
Start the WebBench Controller application on the WebBench controller system by selecting Start>All
Programs—->PC Magazine Benchmarks.
In the WebBench Controller application, choose the Clients menu, and click Start Log In.
Double-click the WebBench 5.0 client shortcut on all the WebBench test client desktops.
Once all the client machines are logged into WebBench, click OK.
At the Would you like to add a test suite? dialog, click Yes.
In the Select a test suite window, choose vConsolidate.tst, and click OK.
When the Would you like to start executing the test suites? window appears, do NOT click Yes or No. The
vConsolidate controller application will handle that task that at the start of the test.
Double-click c:\vCON\vconsolidate.exe.
Select the profile name you want to run.
Wait 10 minutes to allow all virtual machines and VMware ESX Server to load all processes and become
completely idle.
Click start.
The vConsolidate controller software will immediately start the LoadSim application. LoadSim will take
about 60 to 80 seconds to log 500 users onto the Exchange Server. The remaining benchmarks will start
once all the LoadSim users have logged in.
After about 30 minutes, as soon as you see the WebBench workload(s) complete, click Stop!.
The vConsolidate controller application will stop all the other benchmarks and collect their results.

Locating and interpreting the results file
vConsolidate places all result data in the following location:

c:\vCON\vCONMM-dd-hh-mm

where MM is the month, dd is the day, hh is the hour, and mm is the minute of the test. The file result.txt in that
directory summarizes all the results. It contains the following information:

Java transaction score
Database transaction score
Mail transaction score

Web server throughput
Start and stop times
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Figure 11 shows an example results.txt file for a test with one CSU. We have labeled each score with a brief
description. See the Test results section for more information on how we used these individual results to calculate
each server’s overall score on the workload.

B result.txt

File Edit Format View Help

Ul
FTES Ly [
DB Trans Number=231093—— Datahase Score

LoadSim Score
—————————— TEMP. TXT
weighted Avg &0 14015 122 215 132 11 <--"score"

—————————— VCONSOLIDATE. RLG

A,4_client, 8,/1706. 959, 6908069. 563, 0,
A,4_client, 8,/1622.183|, 6576748, 875, 0,
A,4_client, 8,1558. 335|, 6241389. 500, 0,
11:44:39.921
12:15:44.140

Figure 11: Example of vConsolidate results file.

WebBench Score
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Appendix A — Test system configuration information

This appendix provides detailed configuration information about each of the test server systems, which we list in
alphabetical order by processor name.

Quad-Core AMD

Quad-Core Intel

Quad-Core Intel

(MHZz)

Servers Opteron 2347 Xeon X5365 Xeon X5460
(1.9GHz) (3.0GHz) (3.16GHz)
General processor setup
Number of processor packages
Number of cores per processor
package
Number of hardware threads 1 1 y
per core
gys_tem Power Management Always on Always on Always on
olicy
CPU
Vendor AMD Intel Intel
Name Opteron 2347 Xeon X5365 Xeon X5460
Stepping BA G C
Socket type Socket F (1207) 771 LGA 771 LGA
Core frequency (GHz) 1.9 3.0 3.16
Front-side bus frequency 2,000 HyperTransport | 1,333 1,333

64 KB + 64 KB (per

32 KB + 32 KB (per

32 KB + 32 KB (per

four cores)

L1 cache

core) core) core)

4 x 512 KB (512 KB 2x4 MB (each4 MB | 2 x 6 MB (each 6 MB
L2 cache

per core) shared by two cores) shared by two cores)
L3 cache 2MB (shared by all N/A N/A

Thermal design power (TDP, in

95 120 120
watts)
Platform

Supermicro Supermicro Supermicro
Vendor and model number SuperServer 2021M- SuperServer 6025B- SuperServer 6025B-

UR+B TR+ TR+
Motherboard model number H8DMU+ X7DBE+ X7DBE+
Motherboard chipset nForce Pro 3600 Intel 5000P Intel 5000P
Motherboard revision number 1.00 2.01 2.01

. American Megatrends | Phoenix Technologies | Phoenix Technologies

BIOS name and version

(2.0c) (1.3c) (1.3¢c)

BIOS settings

ACPI Version

Disabled Hardware
Prefetcher and High
Bandwidth FSB,

Disabled Hardware
Prefetcher, enabled

Features to ACPI v3.0 | enabled Intel Intel Virtualization
Virtualization Technology
Technology
Chipset INF driver NVIDIA 4.57 Intel 8.2.0.1008 Intel 8.2.0.1008
Memory module(s)
Vendor and model number Hyundai Kingston Kingston
HYMP525P72BP4-Y5 | KVR667D2D4F5/2G KVR667D2D4F5/2G

Type

PC-5300 DDR2

PC2-5300 FB-DDR2

PC2-5300 FB-DDR2

Speed (MHz)

667 MHz

667 MHz

667 MHz
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Quad-Core AMD Quad-Core Intel Quad-Core Intel

Servers Opteron 2347 Xeon X5365 Xeon X5460
(1.9GHz) (3.0GHz) (3.16GHz)
Speed in the system currently 667 MHz 667 MHz 667 MHz
running @ (MHz)
Timing/Latency (tCL-tRCD-
iRP-tRASmMin) 5-5-5-15 5-5-5-15 5-5-5-15
Size 16,384 MB 16,384 MB 16,384 MB
Number of RAM modules 8 8 8
Chip organization Double-sided Double-sided Double-sided
Hard disk
Vendor and model number Western Digital Western Digital Western Digital
WD1600YD WD1600YD WD1600YD
Number of disks in system 1 1 1
Size 160 GB 160 GB 160 GB
Buffer size 16 MB 16 MB 16 MB
RPM 7,200 7,200 7,200
Type SATA-II SATA-II SATA-II
Intel Intel
Controller NVIDIA MCP55 SATA 631?<ESB/6321 ESB 631_XESB/6321 ESB
Controller Serial ATA Storage Serial ATA Storage
Controller Controller
Operating system (Windows VMs)
Microsoft Windows Microsoft Windows Microsoft Windows
Name Server 2003 R2, Server 2003 R2, Server 2003 R2,
Enterprise Edition Enterprise Edition Enterprise Edition
Build number 3790 3790 3790
Service Pack SP2 SP2 SP2
File system NTFS NTFS NTFS
Kernel ACPI Multiprocessor- | ACPI Multiprocessor- | ACPI Multiprocessor-
based PC based PC based PC
Language English English English
Microsoft DirectX version 9.0c 9.0c 9.0c

Operating system (VMware)

Name VMware ESX Server VMware ESX Server VMware ESX Server

3.5.0 3.5.0 3.5.0
Build number 59330 59330 59330
ext3 (server) ext3 (server) ext3 (server)
File system Vmfs3 (virtual Vmfs3 (virtual Vmfs3 (virtual
machines) machines) machines)
Kernel 2.4.21-47.0.1.ELvmnix | 2.4.21-47.0.1.EL 2.4.21-47.0.1.EL
Language English English English
Graphics
Vendor and model number ATI ES1000 (RN50) ATI ES1000 (RN50) ATI ES1000 (RN50)
Chipset ES1000 ES1000 ES1000
BIOS version BK-ATI BK-ATI BK-ATI
VERO008.005.007.001 | VER008.005.007.001 | VER008.005.007.001
Type Integrated Integrated Integrated
Memory size 16 MB 16 MB 16 MB
Resolution 800 x 600 800 x 600 800 x 600
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Servers

Quad-Core AMD
Opteron 2347
(1.9GHz)

Quad-Core Intel
Xeon X5365
(3.0GHz)

Quad-Core Intel
Xeon X5460
(3.16GHz)

Network card/subsystem

Vendor and model number

NVIDIA nForce
Networking Controller

Intel PRO/1000 EB
Network Connection
with 1/0O Acceleration

Intel PRO/1000 EB
Network Connection
with 1/0 Acceleration

Type

Integrated

Integrated

Integrated

Additional cards

2 x Intel PRO/1000 PT
Dual-Port Server

2 x Intel PRO/1000 PT
Dual-Port Server

2 x Intel PRO/1000 PT
Dual-Port Server

Adapter Adapter Adapter
Type PCI Express PCI Express PCI Express
Optical drive
Vendor and model number MATSHITA DVD- MATSHITA DVD- MATSHITA DVD-
ROM SR-8178 ROM SR-8178 ROM SR-8178
USB ports
Number 4 4 4
Type USB 2.0 USB 2.0 USB 2.0
Power supplies
Total number 2 2 2
Wattage of each 700W 700W 700W
Cooling fans
Total number 3 3 3
Dimensions 80mm 80mm 80mm
Voltage 12V 12V 12V
Amps 1.1A 1.1A 1.1A

Figure 12: Detailed system configuration information for the three test servers.
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