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multiprocessor Intel- and AMD-based servers

Executive summary

Intel® Corporation (Intel) commissioned Principled
Technologies (PT) to compare virtualized Exchange
Server (e-mail) performance of three servers, all using
Fibre Channel connected storage. To provide a baseline
target score, we used a fourth system as a representative
three-year-old server. We used the following hardware

platforms:

The AMD Opteron 2384- and Intel Xeon processor E5450-
based server both contained 64 GB of RAM, while the Intel

AMD* Opteron* 2384-based server

Intel® Xeon® processor X5570-based server

Intel Xeon processor E5450-based server

64-bit Intel Xeon processor with 2MB L2 cache 3.6
GHz-based server (Intel Xeon processor 3.6 GHz)

® The Intel Xeon processor X5570-based

KEY FINDINGS

server had an 80 percent performance
advantage over both the Xeon processor
E5450-based server and the AMD Opteron
2384-based server (see Figure 1).

The Intel Xeon processor X5570-based
server delivered 108 percent more virtual
servers/watt than the Intel Xeon processor
E5450-based server, 50 percent more virtual
servers/watt than the AMD Opteron 2384-
based server, and 761 percent more than
the baseline Intel Xeon processor 3.6 GHz-
based server (see Figure 2).

Xeon processor E5570-based server contained 72 GB of RAM. These three comparison servers used an EMC
CX3-40f Fibre Channel storage area network (SAN) for all virtual machine (VM) and database storage. The
baseline server, the Intel Xeon processor 3.6 GHz-based server, contained 4 GB of RAM and also used the EMC

SAN.

For this comparison, we used Microsoft Exchange Load Simulator (LoadSim), a Microsoft-provided tool for
benchmarking an Exchange Mail Server. We defined the peak number of virtual machines (VM) per server as the
maximum number of concurrent VMs under load where each VM had acceptable performance.

Figure 1 compares the peak
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Virtualized Exchange 2003 workload results

Number of virtual servers supported

number of virtual machines
running a Microsoft
Exchange 2003 workload
that each solution ran with
acceptable performance.

Olintel Xeon 3.6GHz-
based server

BAMD Opteron 2384-
based server

Olintel Xeon E5450-
based server

B Intel Xeon X5570-
based server

The Intel Xeon processor
X5570-based server ran
nine such simultaneous
VMs, while both the Xeon
processor E5450-based
server and the AMD
Opteron 2384-based server
ran five such simultaneous

VMs. Each VM contained
8,000 users, for a total of
72,000 users on the Intel
Xeon processor X5570-
based server and 40,000
users on both the Intel
Xeon processor E5450-

Figure 1: Virtualized Exchange 2003 workload performance results for the four servers. Higher
numbers are better. (The Intel Xeon 3.6 GHz-based server ran a single, non-virtual version of the

database test.)
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As Figure 2 shows, the Intel
Xeon processor X5570-
based server delivered 108
Figure 2: Virtual server/watt results for the four servers. Higher numbers are better. percent more virtual

servers/watt than the Intel

Xeon processor E5450-
based server, 50 percent more virtual servers/watt than the AMD Opteron 2384-based server, and 761 percent
more than the baseline Intel Xeon processor 3.6 GHz-based server.

We installed and ran the LoadSim client on physical machines, using six machines per server VM.

Workload

Our goal was to see how many virtual machines running this workload on Microsoft Server 2003 with Exchange
2003 the server could handle with acceptable performance. We configured all virtual machines with two virtual
processors and 4 GB of virtual memory. For complete configuration details, see the test methodology section. To
reach that goal, we used Microsoft Exchange Load Simulator's MAPI Messaging Benchmark 3 (MMB3) workload
to test the systems. We tuned the workload to in such a way as to stress CPU and memory. Our workload
consisted of 8,000 users per VM. During the tests, LoadSim performs tasks to simulate a standard user
generating mail activity. When the workload finishes, LoadSim reports the response time, which is the number of
seconds necessary to complete the task. We ran this workload on all virtual machines simultaneously for 30
minutes. Figure 3 shows an example testbed set up for six Exchange Server VMs.

Principled Technologies, Inc.: Virtualized Exchange performance and power consumption on 2
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Figure 3: Example test bed for a virtualized Exchange Server workload with six VMs. Orange lines indicate network
connections.

Test results

Figure 3 shows the total number of virtual machines each solution could handle during testing and the average
total CPU utilization across all VMs. For a solution to earn an acceptable score, all VMs needed a transaction
latency of less than one second. We define transaction latency here to be the 95th percentile latency for all MS
Exchange requests (meaning 95 percent of all transactions have a latency equal to or less than the latency
number provided). To determine the maximum number of simultaneous virtual machines each solution could
handle, we added virtual machines until one or more had a transaction latency greater than one second. We then
subtracted one VM to identify the total number of VMs the solution could handle. We performed three runs at the
total number to verify the transaction response time always remained below one second.

S Peak number of Average total CPU
erver g B
VMs utilization
AMD Opteron 2384-based server 5 90%
Intel Xeon processor E5450-based server 5 93%
Intel Xeon processor X5570-based server 5 34%
Intel Xeon processor X5570-based server 9 75%
Intel Xeon processor 3.6 GHz-based server (baseline) N/A 73%

Figure 3: The total number of virtual machines and average CPU utilization for the four servers. Higher numbers of virtual
machines are better. The Intel Xeon processor 3.6 GHz-based server was the baseline with the workload running natively and
therefore ran as a standalone server with no virtual machines.
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Figure 4 shows the 95th percentile transaction latency, in milliseconds, from the median run for each virtual
machine.

:)nrtoecl:;esoor; Lr}'i)eclti(sioor: AMD Opteron Intel Xeon
X5570-based E5450-based 2384-based processor 3.6
server server server GHz-based server

Client (ms) (ms) i) ()
Virtual machine 1 902 642 632 323
Virtual machine 2 548 652 575

Virtual machine 3 728 713 571

Virtual machine 4 527 663 533

Virtual machine 5 668 679 642

Virtual machine 6 581

Virtual machine 7 631

Virtual machine 8 457

Virtual machine 9 898

Figure 4: Transaction latency from median run for each virtual machine for the four servers. Lower numbers are better.

We tested the Intel Xeon processor X5570-based server with five VMs so we could compare its transaction
latency with that of the Intel Xeon processor E5450-based and AMD Opteron 2384-based servers also with five
VMs. As Figure 5 shows, the Intel Xeon processor X5570-based server at five VMs has much lower transaction
latency (and lower CPU utilization; see Figure 3), than the other servers we tested, and as Figure 4 shows, it can
go all the way to nine VMs with acceptable transaction latency.

Intel Xeon processor Intel Xeon processor AMD Opteron 2384-
X5570-based server E5450-based server based server

Client (ms) (ms) (ms)

Virtual machine 1 374 642 632

Virtual machine 2 319 652 575

Virtual machine 3 370 713 571

Virtual machine 4 356 663 533

Virtual machine 5 373 679 642

Figure 5: Transaction latency from median run for each virtual machine for the three comparison servers when all of them ran
with five VMs. Lower numbers are better.

Figure 6 details the power consumption, in watts, of the server while idle and during the median run of the
virtualized Exchange 2003 workload.

Server Idle power (watts) Average power (watts)
AMD Opteron 2384-based server 213 308
Intel Xeon processor E5450-based server 347 426
Intel Xeon processor X5570-based server 255 369
Intel Xeon processor 3.6 GHz-based server 272 353

Figure 6: Average power usage (in watts) of the four servers while idle and during the median run of the Microsoft Exchange 2007
workload. Lower numbers are better.
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Note: Microsoft Windows Server 2008 Hyper-V (v1.0) does not take advantage of the C6 power state feature in
the Intel Xeon processor X5570-based server. If the next release of Windows Server 2008 Hyper-V takes
advantage of this feature, as Microsoft predicts, Intel expects the idle power for this server to decrease by
approximately 30 to 50 watts. (Intel bases idle power reduction estimates on power savings they have seen on
other operating systems that support the X5570’s C6 power state.)

Test methodology

Setting up and configuring EMC storage

We used an EMC CX3-40f Fibre Channel SAN in testing the AMD Opteron 2384, Intel Xeon processor X5570,
and Intel Xeon processor E5450 servers. Figure 7 illustrates the configuration we used. The SAN had two storage
processors, SP A and SP B. We used a dual port Fibre Channel host bus adapter (HBA) card in each server. We
cabled one HBA port to each SP (A and B) on the SAN to balance the load between SPs. We used seven
enclosures of disks on the SAN; with one exception, each enclosure had 15 disks. We designated RAID O for all
RAID group configurations.

We created 1 RAID group on the enclosure that had only 12
disks. We then created two logical unit numbers (LUNSs) on this
RAID group, one for the virtual hard drives (VHDSs) that would
hold the Exchange mail databases and one for the VHDs that
would hold the virtual machine system drives and operating
system data.

ML1
Drive F:

We created six RAID groups for Exchange data. Each of these
six RAID groups was composed of 15 disks (an entire
enclosure). We then created one 250GB LUN per RAID group,
for a total of six LUNs dedicated to VHDs that would hold
Exchange data. We used the EMC MetalLUN feature and
assigned three LUNs to MetaLUN-A (which would handle our
even mail server VM databases) and three LUNS to MetaLUN-B
TS (which would handle our odd mail server VM databases). To
balance processing load and disk transfers, we assigned
MetaLUN-A to SP A and MetaLUN-B to SP B.

ML2
Drive G:

Figure 7: The EMC storage configuration we used. After installing EMC PowerPath software, we then accessed

each LUN and MetalUN through the Disk Management utility in
Windows Server 2008. We then proceeded with test setup, creation of VHDs and virtual machines, and so on.

Adjusting BIOS settings
To maximize performance for each server, we adjusted the BIOS settings as follows:

¢ Intel Xeon processor X5570 system: We disabled Turbo Mode and enabled Virtualization Technology.
e Intel Xeon processor E5450 systems: We enabled Virtualization Technology.
e Intel Xeon processor 3.6 GHz-based system: We disabled HyperThreading Technology.

We made no adjustments to the AMD Opteron 2384-based system.

Installing and configuring Windows Server 2008, Enterprise x64 Edition

We installed a fresh copy of Windows Server 2008, Enterprise x64 Edition on the three comparison systems.
(Note: For the baseline Intel Xeon processor 3.6 GHz system, we installed a fresh copy of Windows Server 2003
x86 R2 with SP2 using the steps outlined for the Master VM below.)

We followed this process for each installation:
1. Boot the server and insert the Windows Server 2008 x64 installation CD in the DVD-ROM drive.
2. Atthe Language Selection Screen, click Next.

Principled Technologies, Inc.: Virtualized Exchange performance and power consumption on 5
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Click Install Now.

Select Windows Server 2008 Enterprise (Full Installation) x64, and click Next.
Click the | accept the license terms check box, and click Next.

Click Custom.

Click Drive options (advanced).

Click New.

Click Apply.

. Click Next.

. At the warning that the user’'s password must be changed before logging on screen, click OK.
. Type Passwordl as the new password in both fields, and click the arrow to continue.

13.

At the Your password has been changed screen, click OK.

Setting up the Hyper-V server
Following the installing of Windows Server 2008, Enterprise x64 Edition, we proceeded to set up the host server,
which included installing Hyper-V Manager and setting up the SAN.

Setting up network configuration on the host server

1.

2.
3.

4.
5.

6.

Click Start>Control Panel->Network and Internet->Network Connections, and double-click the Local
Area Connection.

Select Internet Protocol Version 4 (TCP/IPv4), and click Properties.

In the Internet Protocol Version 4 (TCP/IPv4) Properties screen, select the Use the following IP address
radio button.

Enter a valid static IP address, subnet mask, and default gateway.

Select the Use the following DNS server addresses radio button, and enter at least one valid DNS server
address.

Click OK, and then click Close to exit.

Installing system updates in Windows Server 2008 x64
We installed the following updates on the three comparison systems using the Microsoft Windows Update feature:

Security Update for Windows Server 2008 x64 Edition (KB958687)

Update for Windows Server 2008 x64 Edition (KB957388)

Security Update for Windows Server 2008 x64-based Systems (KB938464)

Update for Windows Server 2008 Server Manager x64 Edition (KB940518)

Update for Windows Server 2008 x64 Edition (KB949189)

Security Update for Windows Server 2008 x64 Edition (KB955069)

Cumulative Security Update for ActiveX Killbits for Windows Server 2008 x64 Edition (KB956391)
Security Update for Windows Server 2008 x64 Edition (KB954459)

Security Update for Windows Server 2008 x64 Edition (KB957097)

Security Update for Windows Server 2008 x64 Edition (KB958623)

Update for Windows Server 2008 x64 Edition (KB959130)

Cumulative Security Update for Internet Explorer 7 in Windows Server 2008 x64 Edition (KB958215)
Update for Windows Server 2008 x64 Edition (KB957200)

Security Update for Windows Server 2008 x64 Edition (KB953733)

Security Update for Windows Server 2008 x64 Edition (KB950762)

Update for Windows Server 2008 x64 Edition (KB955839)

Security Update for Windows Server 2008 x64 Edition (KB958624)

Security Update for Windows Server 2008 x64 Edition (KB950974)

Update for Windows Server 2008 x64 Edition (KB951978)

Update for Windows Server 2008 for x64-based Systems (KB955020)

Security Update for Windows Server 2008 x64 Edition (KB954211)

Windows Malicious Software Removal Tool x64 — January 2009 (KB890830)
Security Update for Windows Mail for Windows Server 2008 x64 Edition (KB951066)
Security Update for Windows Server 2008 x64 Edition (KB956841)

Principled Technologies, Inc.: Virtualized Exchange performance and power consumption on
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Security Update for Windows Server 2008 x64 Edition (KB956802)

Update for Windows Server 2008 x64 Edition (KB957321)

Update for Windows Server 2008 x64 Edition (KB952287)

Security Update for Windows Server 2008 x64 Edition (KB958644)

Security Update for Internet Explorer 7 in Windows Server 2008 x64 Edition (KB960714)
Security Update for Windows Server 2008 x64 Edition (KB951698)

Update for Windows Server 2008 x64 Edition (KB950050)

Update for Windows Server 2008 x64 Edition (KB955302)

Windows Update Agent 7.2.6001.788

Windows Update software 7.2.6001.788

Installing Hyper-V in Windows Server 2008

Note: Be sure you have installed all the latest critical and recommended updates for Windows Server 2008 from
Windows Update. Specifically, you must install the update that upgrades Hyper-V from beta to release software.
(As of this writing, this update is KB950050 on Windows Server 2008 Enterprise Edition x64.)

Click Start->Administrative Tools-> Server Manager.
Click Roles.
Click Add Roles.
Click Next.
Select the Hyper-V role by checking the box beside it, and click Next.
Check the box beside the Ethernet Card you wish to use, and click Next.
Click Install to begin the Hyper-V installation.
When the installation finishes, click Close.
When prompted to restart now, click Yes.
. Follow the prompt to log on to the system.
. Enter the password, and click the arrow to continue. The Resuming Configuration Wizard should start
automatically.
. Once the Resuming Configuration Wizard completes, the installation results should appear with a
message that the installation succeeded.
13. Click Close.
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Setting up the storage area network (SAN)

1. Install the dual-port QLogic FC card in the server.

2. Connect two fibre cables from the dual-port QLogic FC card in the server to the SAN, with each cable
connecting to one storage processor (SP) on the EMC.

3. Install EMC Powerpath software x64 on the server with all defaults except for the following: select the CX
SAN, not the AX.

4. When prompted to reboot at the end of the Powerpath installation, do so.

5. Click Start.

6. Right-click My Computer, and select Manage.

7. Select Disk Management.

8. When the wizard prompts you to initialize new disks, click OK. Note: If you must select a patrtition table,

select MBR.
9. Right-click the first unallocated disk partition, and select New Simple Volume...
10. Click Next.

11. Use the entire LUN storage space, and click Next.

12. Select the drive letter to assign to the new partition, and click Next.
13. Label the volume appropriately (i.e., LUNO, LUN1, etc.).

14. Confirm that Perform a quick format is checked, and click Next.
15. Click Finish.

16. Repeat steps 8 through 15 for each volume.

Principled Technologies, Inc.: Virtualized Exchange performance and power consumption on 7
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Creating the master virtual machine

Note: We performed these following steps on only the first server. For subsequent servers, we used the same
VHD files. We created three fixed-size virtual hard drives per VM, one on each volume in the appropriately named
folders. Using Hyper-V manager, we assigned the VHD file containing the operating system to IDE Controller O

and assigned the remaining two VHD files to the SCSI controller.

Create the virtual machines with the following VM parameters:
e Virtual processor: 2
e Virtual memory: 4,096 MB

Virtual disk size: 8 GB

Create a folder for the Master VM on each LUN (i.e., MailServerl).

Click Start>Administrative Tools>Hyper-V Manager.

Click Connect to Server, and click OK.

Click Action>Virtual Network Manager...

Select New virtual network.

Select External, and click Add.

From the Actions menu, select New->Virtual Machine...

Click Next.

Enter a name for the virtual machine.

10. Click Next.

11. Specify the amount of memory to allocate to this virtual machine (4096 MB), and click Next.
12. Select Not Connected on the Configure Networking screen, and click Next.
13. Select the Attach a virtual hard disk later radio button, and click Next.

14. Click Finish.

15. Close Hyper-V Manager.

Setting up the Master VM
After creating the Master VM through the Hyper-V interface, we proceeded to set up the Master VM, which
included installing and configuring Windows Server 2003 x86 R2 with SP2.

CoNOOA~A®ONE

Configuring the Master VM
1. Click Start->Administrative Tools->Hyper-V Manager.
2. Right-click the Master VM, and select Settings...
3. Select Processor.
4. Change the number of logical processors to 2, and click Apply.
5. Select Network Adapter.
6. Select the appropriate configuration from the drop-down menu, and click Apply.
7. Select Add Hardware.
8. Select SCSI Controller, and click Add.
9. Click Apply.
10. Select IDE Controller O.
11. Select Disk Drive, and click Add.
12. Click New.
13. Click Next.
14. Click the Fixed size radio button, and click Next.
15. Enter a name for the VHD file.
16. Browse to MailServerl folder on the OS LUN, and select Next.
17. Select the Create a new blank virtual hard disk radio button.
18. Enter 8 for the number of GB for the virtual hard disk, and click Next.
19. Click Finish.
20. Click Apply.
21. Select SCSI Controller.
22. Select Disk Drive, and click Add.
23. Click New.

Principled Technologies, Inc.: Virtualized Exchange performance and power consumption on
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24,
25.
26.
27.
28.
29.
30.
31.
32.
33.
34.
35.
36.
37.
38.
39.
40.
41.
42.
43.

Click Next.

Click the Fixed size radio button, and click Next.

Enter a name for the VHD file.

Browse to MailServerl folder on the MailDB LUN, and select Next.
Select the Create a new blank virtual hard disk radio button.

Enter 45for the number of GB for the virtual hard disk, and click Next.
Click Finish.

Click Apply.

Select SCSI Controller.

Select Disk Drive, and click Add.

Click New.

Click Next.

Click the Fixed size radio button, and click Next.

Enter a name for the VHD file.

Browse to MailServerl folder on the MailBackup LUN, and select Next.
Select the Create a new blank virtual hard disk radio button.

Enter 45 for the number of GB for the virtual hard disk, and click Next.
Click Finish.

Click Apply.

Click OK.

Installing Windows Server 2003 x86 R2 with SP2 on the Master VM

We installed a fresh copy of Windows Server 2003 x86 R2 with SP2 on the three comparison systems using the
steps below. (Note: We also installed Windows Server 2003 x86 R2 with SP2 on the baseline Intel Xeon
processor 3.6 GHz server, beginning with step 12.)

oukhwnE

7.
8.
9.

10.
11.
12.
13.
14.
15.
16.
17.

18.
19.
20.
21.

22.
23.

24,

Click Start>Administrative Tools->Hyper-V Manager.

Right-click the Master VM, and select Settings...

Select IDE Controller 1.

Select DVD Drive.

Select the Physical CD/DVD drive: radio button, and click Apply.

Select BIOS and confirm that CD is at the top of the Startup order list. If this is not the case, adjust the list
appropriately, and click Apply.

Click OK.

Right-click the Master VM, and select Connect...

Click Menu->DVD Drive->Capture appropriate DVD-ROM drive (i.e., D).

Insert the Windows Server 2003 R2 installation CD in the DVD-ROM drive.

Click Action—>Start to start the Master VM.

At the Welcome to Set up screen, press Enter to begin the installation.

At the Windows Licensing Agreement screen, press F8 to agree to the terms.

Press Enter to install in the default location.

Select Format the partition using the NTFS file system (Quick), and press Enter to continue.

At the Regional and Language Options screen, click Next.

Enter Name and Organization, and click Next. Note: Organization is an optional field, while username is
required.

At the Your Product Key screen, enter your product key, and click Next.

At the Licensing Modes screen, click Next.

At the Computer Name and Administrator Password screen, type Passwordl as the new password in
both fields, and click Next.

At the Date and Time Settings screen, change the Date & Time and Time Zone if appropriate, and click
Next.

After the system restarts automatically, follow the prompt to log in to the server.

At the Windows Setup screen, you will be prompted to insert the second installation CD. Insert the
appropriate CD, and click OK.

At the Windows Server 2003 R2 Setup Wizard Welcome screen, click Next.

Principled Technologies, Inc.: Virtualized Exchange performance and power consumption on
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25.
26.
27.

28.
29.
30.
31.
32.
33.

34.
35.
36.
37.
38.
39.
40.
41.

Setting
1.
2.
3.
4,

5.
6.

7.

At the Windows Server 2003 R2 Setup Wizard Summary screen, click Next.

When prompted, click Finish to end the installation.

Once the installation completes, on the Hyper-V Manager menu, click Action—=>Insert Integration Services
Setup Disk.

At the prompt to restart, click Yes.

Log back in to the Master VM at the prompt.

Click Start.

Right-click My Computer and select Manage.

Select Disk Management.

If the wizard prompts you to initialize new disks, click OK. Note: If you must select a partition table, select
MBR.

Right-click the first unallocated disk partition, and select New Simple Volume...

Click Next.

Use the entire VHD storage space, and click Next.

Select the drive letter to assign to the new partition, and click Next.

Label the volume appropriately (i.e., MailDB, MailBackup, etc.).

Confirm that Perform a quick format is checked, and click Next.

Click Finish.

Repeat steps 34 through 40 for the remaining volumes.

up network configuration on the Master VM

Click Start->Control Panel->Network Connections, and Local Area Connection.

At the Local Area Connection Status screen, click Properties.

At the Local Area Connection Properties screen, select Internet Protocol Version 4 (TCP/IPv4), and click
Properties.

In the Internet Protocol Version 4 (TCP/IPv4) Properties screen, select the Use the following IP address
radio button.

Enter a valid static IP address, subnet mask, and default gateway.

Select the Use the following DNS server addresses radio button, and enter at least one valid DNS server
address.

Click OK and then click Close twice. Close the Network Connections window.

Installing system updates in Windows Server 2003 R2 on the Master VM
We installed the following updates using the online Windows Update feature. Note: Reboot the VM as requested.

Windows Server 2003 Security Update for Internet Explorer 7 for Windows Server 2003 (KB960714)
Windows Server 2003 Security Update for Internet Explorer 7 for Windows Server 2003 (KB938127)
Windows Server 2003 Windows Malicious Software Removal Tool - January 2009 (KB890830)
Windows Server 2003 Security Update for Windows Server 2003 (KB958687)

Windows Server 2003 Security Update for Windows Server 2003 (KB956803)

Windows Server 2003 Security Update for Internet Explorer 6 for Windows Server 2003 (960714
Windows Server 2003 Security Update for Windows Server 2003 (KB925902)

Windows Server 2003 Update for Windows Server 2003 (KB955839)

Windows Server 2003 Cumulative Security Update for Internet Explorer 6 for Windows Server 2003
(KB958215)

Windows Server 2003 Security Update for Windows Server 2003 (KB956802)

Windows Server 2003 Security Update for Windows Server 2003 (KB954600)

Windows Server 2003 Security Update for Windows Server 2003 (KB952069)

Windows Server 2003 Security Update for Windows Server 2003 (KB957097)

Windows Server 2003 Security Update for Windows Server 2003 (KB955069)

Windows Server 2003 Security Update for Windows Server 2003 (KB958644)

Windows Server 2003 Security Update for Windows Server 2003 (KB956841)

Windows Server 2003 Cumulative Security Update for ActiveX Killbits for Windows Server 2003
(KB956391)
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Windows Server 2003 Security Update for Windows Server 2003 (KB954211)
Windows Server 2003 Security Update for Windows Server 2003 (KB938464)
Windows Server 2003 Security Update for Windows Server 2003 (KB944338)
Windows Server 2003 Security Update for Windows Server 2003 (KB950974)
Windows Server 2003 Security Update for Windows Server 2003 (KB952954)
Windows Server 2003 Security Update for Outlook Express for Windows Server 2003 (KB951066)
Windows Server 2003 Security Update for Windows Server 2003 (KB951748)
Windows Server 2003 Security Update for Windows Server 2003 (KB951698)
Windows Server 2003 Security Update for Windows Server 2003 (KB950762)
Windows Server 2003 Security Update for Windows Server 2003 (KB945553)
Windows Server 2003 Update for Windows Server 2003 (KB948496)

Windows Server 2003 Security Update for Windows Server 2003 (KB943055)
Windows Server 2003 Security Update for Windows Server 2003 (KB946026)
Windows Server 2003 Security Update for Windows Server 2003 (KB943485)
Windows Server 2003 Security Update for Windows Server 2003 (KB941569)
Windows Server 2003 Security Update for Windows Server 2003 (KB944653)
Windows Server 2003 Security Update for Windows Server 2003 (KB943460)
Windows Server 2003 Windows Internet Explorer 7 for Windows Server 2003
Windows Server 2003 Update for Windows Server 2003 (KB936357)

Windows Server 2003 Security Update for Windows Server 2003 (KB933729)
Windows Server 2003 Security Update for Microsoft .NET Framework, Version 1.1 Service Pack 1
(KB933854)

Windows Server 2003 Security Update for Windows Server 2003 (KB938127)
Windows Server 2003 Security Update for Windows Server 2003 (KB936782)
Windows Server 2003 Security Update for Windows Server 2003 (KB926122)
Windows Server 2003 Security Update for Windows Media Player 6.4 (KB925398)
Windows Server 2003 Security Update for Windows Server 2003 (KB935839)
Windows Server 2003 Security Update for Windows Server 2003 (KB935840)
Windows Server 2003 Cumulative Security Update for Outlook Express for Windows Server 2003
(KB929123)

Windows Server 2003 Security Update for Windows Server 2003 (KB924667)
Windows Server 2003 Update for Windows Server 2003 (KB927891)

Windows Server 2003 Security Update for Windows Server 2003 (KB932168)
Windows Server 2003 Security Update for Windows Server 2003 (KB930178)

The following subsections detail how we created and configured each of these VMs.

Copying the VMs
Use the following steps to create VMs with the same base OS:

9.

10.
11.
12.
13.

Navigate to the Virtual Hard Disk folder on the server where the Virtual Hard Disks are stored.
Highlight your base VM, and use the copy/paste method to create the appropriate number of copies for
your VMs.

Right click each Hard Disk and rename them according to the VM for which they are to be used.
Select Start-> Administrative Tools->Hyper-V Manager...

Choose New->Virtual Machine.

Click Next.

Enter a name for the virtual machine, and select the location to store the VM files The New Virtual
Machine Wizard will automatically create a subfolder with the name of the VM.

Click Next.

Specify the amount of memory to allocate to the virtual machine, and click Next.

Select the network connection for the virtual machine to use, and click Next.

Select Attach a virtual hard disk later, and click Next.

Click Finish.

Select the newly created VM and choose Settings—>IDE Controller 0.
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14.
15.
16.
17.

Choose Add to add a Hard Disk to the VM.
Choose Browse.

Select the appropriate Hard Disk and click Okay.
Click OK.

Installing and configuring the mail server VM

1.

Follow the steps in the earlier Copying the VMs section using the following VM specifications:
Base VM: Base32

Name: MailServerl

Virtual processors: 2

Virtual memory: 4 GB

Virtual disk size: 8 GB

Virtual network: Internal Network (set the IP address to 192.168.1.1 in Windows within the VM)

To finish setting up this VM, we had to install several additional software components. The following subsections
detail the necessary installation processes.

Installing the domain controller

CoNoOOA~WNE

15.

16.
17.
18.
19.
20.

Select Start->Administrative Tools->Manage Your Server.

Click Add or remove a role.

At the Configure Your Server window, click Next.

At the Configuration and Options screen, select Custom Configuration, and click Next.

At the Server Role screen, select Domain Controller, and click Next.

At the Summary of Selections screen, click Next.

At the Welcome pop-up window, click Next.

At the Operating System Compatibility screen, click Next.

For the Domain Controller Type, leave the default option (Domain controller for a new domain), and click
Next.

. At the Create New Domain screen, leave the default (Domain in a new forest), and click Next.

. At the Install or Configure DNS window, select No, and click Next.

. At the New Domain Name screen, type a domain name (loadsim.com ), and click Next.

. At the NetBIOS Domain Name screen, enter a NETBIOS domain name (loadsim ), and click Next.
. Click Next through the following screens: Database and Log Folders, Shared System Volume, and

Permissions. Doing so accepts the default options for each of those screens.

At the Directory Services Restore Mode Administrative Password screen, enter a Password1, and click
Next.

When the installation software prompts you to do so, insert the OS CD, and click OK.

At the Completing the Active Directory Installation Wizard screen, click Finish.

When the system prompts you to reboot the VM, click Restart Now.

After the VM reboots, log in to the system.

At the This Server is Now a Domain Controller window, click Finish.

Installing Internet Information Services 6.0

CoNoOOA~WNE

10
11.

Select Start->Control Panel->Add or Remove Programs.

Click Add/Remove Windows Components.

Select Application Servers, and click Details.

Click ASP.NET, and make sure a check appears in the check box.

Select Internet Information Services (11S), and click Details.

Click NNTP Services and SMTP Services, make sure a check appears in both check boxes, and click OK.
Click OK to close the Application Server window.

At the Windows Components Wizard, click Next to begin the installation.
When the system prompts you to do so, insert the OS CD, and click OK.
At the Completing the Windows Components Wizard window, click Finish.
Close the Add or Remove Programs window.
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Installing Exchange Server 2003

Insert the Microsoft Exchange Server 2003 CD. The CD should automatically launch the installation
software.

Choose Exchange Server Enterprise Edition.

Run the Setup application.

Click the Exchange Deployment Tools link.

Click the Deploy the first Exchange 2003 Server link.

Click the New Exchange 2003 Installation link.

Click the Run ForestPrep now link.

1.

Nogakwn

el
[Ny )

12.

a.

copDOLOTEDRTOROT

T TSsemeo

When the compatibility issue notice appears, click Continue, and check the Don't display this
message again box.
At the Welcome screen, click Next.
Accept the End User License Agreement, and click Next.
At Component Selection Screen, keep the defaults, and click Next.
Leave the default account information, and click Next.
Installation should start. (This process may take a while to complete.)
When the installation completes, click Finish.
turn to the Exchange Server Deployment Tools screen, and click the Run DomainPrep now link.
At the Welcome screen, click Next.
Accept the End User License Agreement, and click Next.
At Component Selection Screen, keep the defaults, and click Next.
At the insecure domain notice, click OK.
When the installation completes, click Finish.
eturn to the Exchange Server Deployment Tools screen, and click Run Setup Now.
At the Welcome screen, click Next.
Accept the End User License Agreement, and click Next.

At the Component Selection screen, the action for Microsoft Exchange should by default be Typical.

(If it is not, use the drop-down box to set it to Typical.)

Click Next.

For the Installation Type, select Create new Exchange Organization, and click Next.
Leave the default Organization Name, and click Next.

Accept the Microsoft Exchange Server Licensing Agreement, and click Next.
Review the installation summary, and click Next.

The installation should start. (This process may take a while to complete.)

When the installation completes, click Finish.

. Close the Exchange Server Deployment Tools window.
. Install Microsoft Exchange Server 2003 Service Pack 2.

a. Insertthe SP2 CD, and double-click update exe.

b. Accept the default location to extract the file, and click OK.

c. After the extraction finishes, open Windows Explorer, and browse to the update.exe executable.
d. Atthe Welcome screen, click Next.

e. Select | agree to accept the License Agreement, and click Next.

f. At the Component Selection window, leave the default option (Update), and click Next.

g. Verify the installation Summary, and click Next.

h. When the installation completes, click Finish.

In the Virtual Infrastructure Client console, add a new 40GB virtual hard disk to this VM by doing the
following:

a. Right-click the MailServerl VM, and select Settings from the menu.

b. On the Hardware Tab, click Add Hardware.

c. Choose the “SCSI Controller” device and click Add.

d. Click “Add” to add a new hard drive to the virtual SCSI Controller.

e. Click New to create a new virtual hard disk file.

f. Click Next.

g. Select “Fixed size” and click Next.

h. Specify the name and location of the virtual hard disk file.
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13.
14.
15.
16.
17.
18.
19.
20.
21.
22.
23.
24,
25.
26.

27.
28.
29.
30.
31.
32.
33.
34.
35.
36.
37.
38.
39.
40.
41.
42.
43.
44,
45.
46.
47.
48.
49.
50.
51.
52.
53.
54.
55.

i. Specify the size of the new blank virtual hard disk (in GB).

j-  Click Finish. The server will then begin creating the new virtual hard disk.

k. Once it finishes creating the new virtual hard disk, click OK.

Restart the VM by selecting Start->Shut down->Restart inside the MailServer VM.
In the MailServer VM, right-click My Computer, and select Manage.

In the Computer Management Console, select Disk Management.

When a Welcome to Initialize and Convert Disk Wizard window appears, click Next.
Select Disk 1 to initialize.

At the Select Disk to Convert screen, leave the disk unchecked.

At the Completing the Initialize and Convert Disk Wizard screen, click Finish.
Right-click the Disk 1 unallocated box, and select New Partition.

At the Welcome screen, click Next.

Leave the partition type as Primary, and click Next.

Accept the default Partition Size, which should be the same as the Maximum disk space, and click Next.

Assign the drive letter E, and click Next.

Format the partition with the NTFS File system, enter Mail Store for the volume label, and click Next.

At the Completing the New Partition Wizard screen, click Finish.

The partition should begin formatting.

When the formatting completes, close the Computer Management console.
Select Start->All Programs-> Microsoft Exchange—> System Manager.

In the left window pane, expand Servers and MailServer so the First Storage Group is visible.

Right-click First Storage Group, and select Properties.

Click Browse, and change the Transaction log and System path location to E:\.

Check the Enable circular logging box, and click Apply.

When the pop-up message appears asking if you want to perform this task, click Yes.
When the message appears saying that all mounted stores are back online, click OK.
Right-click Mailbox Store under First Storage Group, and select Properties.

Select the Database tab.

Click Browse, and move the Exchange database and Exchange streaming database to E:\.
Check the This database can be overwritten by a restore box.

Click Customize next to Maintenance interval.

Remove all blue from the boxes so the system will not perform maintenance, and click OK.
At the Mailbox Store Properties window, click Apply.

When a warning message appears, click Yes.

When the message that the database files have been moved appears, click OK.

Click OK to close the Mailbox Store Properties window.

Right-click Public Store under First Storage Group, and select Properties.

Select the Database tab.

Click Browse, and move the Exchange database and Exchange streaming database to E:\.
Check the This database can be overwritten by a restore box.

Click Customize next to Maintenance interval.

Remove all blue from the boxes so the system will not perform maintenance, and click OK.
At the Public Store Properties window, click Apply.

When a warning message appears, click Yes.

When the message that the database files have been moved appears, click OK.

Click OK to close the Public Store Properties window.

Reboot the virtual machine.

Installing the mail test client
We performed the following steps to set up the systems:

1.

2
3.
4,
5

Install Microsoft Windows XP Professional with Service Pack 3 using all defaults.
Install relevant drivers on the machine.

Right-click My Computer, and select Properties.

Click the Computer Name tab.

Click Change.
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Select Domain in the member of section, and type the domain 1oadsim. com into the text box.
In the pop-up window, enter Administrator for user name, Password1 for password, and click OK.
At the Welcome to the domain screen, click OK.

When the warning that you must restart dialog appears, click OK.

. Click OK to close the System Properties window.

. Click Yes to the pop-up message to restart the computer.

. Login to the domain by using Administrator and Password1.

. Install Microsoft Outlook 2003 with the default settings. (Outlook 2003 doesn’t require any configuration.)
. Install LoadSim 2003 by double-clicking the loadsim.msi installation file. Accept all defaults.

. Open LoadSim 2003, and make sure no error messages appear.

. Repeat steps 1-15 five times on new machines to form the client cluster.

Configuring LoadSim 2003

oukrwNE

10.
11.
12.
13.
14.

15.
16.
17.

18.
19.
20.
21.

22.
23.
24,

Start LoadSim by clicking Start Menu->All Programs->Exchange LoadSim—>LoadSim 2003 with Remote.
From the LoadSim menu bar, select Configuration->Topology Properties.

Click the Servers tab.

In the left pane, click the + next to the name of this server.

In the left pane, select the First Storage Group.

In the right pane, you will see four databases. Set the number of users to 2000 for each database.

Select the Security and Credentials tab.

Leave the Credentials choice set to Login to users using the account LoadSim is running on.
In the password portion of the tab, enter the password Passwordil, and click OK.
From the LoadSim menu bar, select Configuration-> Test Properties, and click Add.
In the number of users box, select 1333 users, click OK.

Click Customize Tasks.

Select the Initialization tab.

Enter the following settings:

e Number of messages in Inbox: 10

Number of messages in Deleted items: 1

Number of new folders: 3

Messages per new folder: 10

Number of Smart Folders: 3

Number of Rules in Inbox: 5

Initialize Free/Busy Information: Leave it unselected

Number of appointments: 10

e Number of contacts: 32

Click OK.

In Test Properties, select that first mailserver and click Copy five times.

Arrange the other machines in this manner;

e Client 2: First user: 1333, Number of users: 1333

e Client 3: First user: 2666. Number of users: 1334

e Client 4: First user: 4000. Number of users: 1333

e Client 5: First user: 5333. Number of users: 1333

e Client 6: First user: 6666. Number of users: 1334

In the Test Properties window, change the run time to 30 minutes, and click OK.
From the LoadSim menu bar, choose File->Save As.

Save a backup copy of the simulation file as C:\loadsim.sim.

From the LoadSim menu bar, select Run->Create Topology, and wait until the Creating Users and
Creating DLs tasks complete.

From the LoadSim menu bar, select Remote Control->Control.

From the LoadSim menu bar, select Remote Control->Share SIM file.

From the LoadSim menu bar, select Remote Control->Initialize>All.
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25.

26.
27.

The run is complete when the bottom LoadSim window shows Status: Idle. This task typically takes about
2 to 3 hours to complete.

From the LoadSim menu bar, select Run->Run Simulation.

The run is complete when the bottom LoadSim window shows Status: Idle. This task typically takes a little
over 2 hours to complete.

Changing servers between tests

We performed the following steps between tests on subsequent servers to minimize the amount of time required
for setting up each subsequent server. Note: This eliminates the need to create and configure the master VM and
clone the VM on each server.

1. Click Start>Administrative Tools->Hyper-V Manager.

2. Confirm that all VMs are in the Off State. If all VMs are in the Off State, skip to Step 5.

3. To shut down a VM that is not in the Off State, right-click the VM.

4. Select Shut down...

5. Right-click the VM, and select Settings...

6. Select Network Adapter.

7. Click Remove, and click Apply.

8. Select Disk Drive under IDE Controller 0.

9. Click Remove, and click Apply.

10. Select Disk Drive under SCSI Controller.

11. Click Remove, and click Apply.

12. Select next Disk Drive under SCSI Controller.

13. Click Remove, and click Apply.

14. Select last Disk Drive under SCSI Controller.

15. Click Remove, and click Apply.

16. Repeat Steps 5 through 15 for the remaining VMs.

17. Click OK to finish.

18. Close Hyper-V Manager.

19. Click Start->Administrative Tools—>Computer Management.

20. Click Disk Management.

21. With the exception of the C: drive, right-click each volume and select offline. This cleanly unmounts the
SAN drives.

22. Shut down the server.

23. Switch the QLogic FC HBA to the next server, using the steps outlined above in the section Setting up the
Storage Area Network (SAN). Note: You will not need to initialize the disks, as they have already been
initialized.

24. Click Start->Administrative Tools->Computer Management.

25. Click Disk Management.

26. With the exception of the C: drive, right-click each volume, and select Online.

27. Click Start->Administrative Tools>Hyper-V Manager.

28. Right-click each VM, and select Settings...

29. Select Add Hardware.

30. Select Network Adapter, and click Add.

31. Select the appropriate configuration from the drop-down menu and click Apply.

32. Select Add Hardware.

33. Select SCSI Controller, and click Add.

34. Click Apply.

35. Select IDE Controller 0.

36. Select Disk Drive, and click Add.

37. Browse to the appropriate location for the appropriate VHD file (i.e., OS LUN, MailServerl folder), and
click Apply.

38. Select SCSI Controller.

39. Select Disk Drive, and click Add.

40. Browse to the appropriate location for the appropriate VHD file (i.e., MailDB LUN, MailServerl folder),
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41. Click Apply.

42. Select SCSI Controller.

43. Select Disk Drive, and click Add.

44. Browse to the appropriate location for the appropriate VHD file (i.e., MailBackup LUN, MailServerl
folder),

45. Repeat steps 28 through 44 for the remaining VMs.

46. Click OK to finish.

Power measurement procedure

To record each server’s power consumption during each test, we used an Extech Instruments (www.extech.com)
380803 Power Analyzer/Datalogger. We connected the power cord from the server under test to the Power
Analyzer’s output load power outlet. We then plugged the power cord from the Power Analyzer’s input voltage
connection into a power outlet.

We used the Power Analyzer’'s Data Acquisition Software (version 2.11) to capture all recordings. We installed the
software on a separate Intel processor-based PC, which we connected to the Power Analyzer via an RS-232
cable. We captured power consumption at one-second intervals.

To gauge the idle power usage, we recorded the power usage for two minutes while each system was running
Hyper-V and the appropriate number of VMs, but otherwise idle, meaning they were not running any test
workload.

We then recorded the power usage (in watts) for each system during the testing at one-second intervals. To
compute the average power usage, we averaged the power usage during the time the system was producing its
peak performance results. We call this time the power measurement interval. See Figure 7 (idle and average
peak power) for the results of these measurements.
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Appendix A — Server configuration information

This appendix provides detailed configuration information about the servers, which we present in alphabetical

order in Figure 8.

Servers

AMD Opteron 2384-
based server

General processor setup

Intel Xeon processor

X5570-based server

Intel Xeon
processor E5450-
based server

64-bit Intel Xeon
processor with
2MB L2 cache 3.6

‘ GHz-bas_ed server

|

Number of
processor 2 2 2 2
packages
Number of cores
per processor 4 4 4 1
package
Number of
hardware threads | 1 2 1 2
per core
CPU
Vendor AMD Intel Intel Intel
Opteron 2384 Xeon X5570 Xeon E5450 3.6 GHz Xeon with
Name (Shanghai) (Nehalem) (Harpertown) ZMB L2 cache
(Irwindale)
Stepping 2 5 CO RO
Socket type Socket F LGA 1366 LGA 771 Socket 604
feogez;req“ency 2.7GHz 2.93 GHz 3.0 GHz 3.60GHz
Front-side bus 2.0 GT/s
frequency (MHz) HyperTransport 6.4 GTs (QPI) 1,333 MHz 800
L1 cache 64KB + 64KB (per 32 KB + 32 KB (per 32KB+32KB (Per | 1o1p + 16KB
core) core) core)
L2 cache 2MB (4 x 512 MB) 1 MB (4 x 256 KB) bZB';"B (2x6,144 2 MB (1 x 2,048 MB)
L3 cache 1 x 6MB 1x8 MB N/A N/A
Platform
Vendor and model Supermicro A+ Supermicro Supermicro
number Server 2021M- SuperServer SuperServer 6025B- | Supermicro 6024H-T
T2R+V P TR+
Motherboard H8DME-2 X8DTN+ X7DBE+ X6DHT-G
model number
('\:"h?g;i;board NVIDIA MCP55 Intel 5520 Intel 5000P Intel E7520
Motherboard 01 1.02 B1 01
revision number
Phoenix

BIOS name and

AMIBIOS 08.00.14

American Megatrends

PhoenixBios v2.1

Technologies LTD

version (10/13/08) v4.6.3.2 (01/13/2009) | (06/23/08) 6.00 (08/16/2007)
Turbo Mode Disabled . o .
BIOS settings Default Intel Virtualization Intel Virtualization HyperThreading

Technology Enabled

Technology Enabled

Technology Disabled
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Servers

AMD Opteron 2384-
based server

Intel Xeon processor

X5570-based server

Intel Xeon
processor E5450-
based server

64-bit Intel Xeon
processor with

2MB L2 cache 3.6

GHz-based server

Memory module

Vendor and model | Kingston Micron Kingston Samsung
MT36JSZF51272PY- | KVR667D2D4F5/4G | M312L5720DZ3-
number KVR667D2S4P5/4G
1G1D1 I CB3
Type DDR2 PC2-5300 DDR3 PC3-8500 EBDF\IS?I\/TI\SIZ 2-5300 DDR PC2700R
Speed (MHz) 667 1,066 666 333
Speed in the
system currently 533 800 666 333
running @ (MHz)
Timing/Latency
(tCL-tRCD-iRP- 4-4-4-12 6-6-6-16 5-5-5-15 2.5-3-3-10
tRASmIN)
Size 64 GB (16 x 4 GB) 72 GB (18 x 4 GB) 64 GB (16 x 4 GB) 4GB (2 x 2 GB)
Number of RAM 16 16 16 5
modules
Chip organization | Double-sided Double-sided Double-sided Double-sided
Hard disk

Vendor and model

Western Digital

Western Digital

Western Digital

Western Digital

number WD1601ABYS WD1600AAJS- WD1600AAJS WD1600YD
00B4A0
Number of disks 1 1 1 6
in system
Size (GB) 160 160 160 160
Buffer size (MB) 16 8 8 8
RPM 7,200 7,200 7,200 7,200
Type SATA SATA SATA SATA
Intel Corporation .
NVIDIA nForce Intel ESB2 RAID Adaptec Serial ATA
Controller SATA controller ICH10 SATA AHCI Controller HostRAID
Controller
NVIDIA Microsoft Microsoft
Driver version 5.10.2600.830 6.0.6001.18000 6.0.6001.18000 (Aodl"’/‘i’gigolo'éf735'o
(04/23/2007) (06/21/2006) (06/21/2006)

Operating system

Name

Microsoft Windows
Server 2008
Enterprise Edition

Microsoft Windows
Server 2008
Enterprise Edition

Microsoft Windows
Server 2008
Enterprise Edition

Microsoft Windows
Server 2003 R2
Enterprise Edition

Build number

6001

6001

6001

3790

Service pack SP1 SP1 SP1 SP2

File system NTFS NTFS NTFES NTFS

Kernel ACPI x64-based PC | ACPI x64-based PC ACPI x64-based PC ggPl Multiprocessor
Language English English English English

Graphics

Vendor and model |\ £51000 ATI ES1000 ATI ES1000 ATl Rage XL SVGA
number PCI Video

Chipset ES1000 ES1000 ES1000 ATI Rage XL

Type Integrated Integrated Integrated Integrated
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Servers

AMD Opteron 2384-
based server

Intel Xeon processor

X5570-based server

Intel Xeon
processor E5450-
based server

64-bit Intel Xeon
processor with

2MB L2 cache 3.6

GHz-based server

Memory size (MB)

16

32

16

8

Resolution

1,024 x 768

1,024 x 768

1,024 x 768

1,024 x 768

Network card/subsystem

Vendor and model
number

Intel Pro/1000

Intel 82576 Gigabit
Ethernet

Intel Pro/1000 EB

Intel PRO/1000 MT

Type Integrated Integrated Integrated Integrated

Driver version Microsoft 6.2.0.126 Intel 10.3.49.400 Intel 9.12.36.0 Intel 8.10.3.0
(6/21/2008) (12/11/2008) (12/04/2008) (8/20/2008)

Optical drive

Vendor and model | Matshita DVD-ROM | Slimtype DVD A Matshita DVD-ROM

number UJDA780 Dsst/i/fp SR-8178 TEAC CD-224E-N

USB ports

Number 4 4 4 2

Type USB 2.0 USB 2.0 USB 2.0 USB 2.0

Power supplies

Total number 2 2 2 1

Wattage of each 700W 805W 700W 550W

Cooling fans

Total number 3 3 3 4

Dimensions 3"x3 3"x3 3"x 3 3.25" x 3.25"

Voltage 12v 12v 12v 12v

Amps 1.1A 1.1A 1.1A 1.1A

Figure 8: Detailed system configuration information for the four test servers.
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