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Performance of three Intel®-based SMB servers
using WebBench, LoadSim, and SysBench

Executive summary

Intel® Corporation (Intel) commissioned Principled
Technologies (PT) to measure the performance while
running multiple benchmarks simultaneously on three
dual- and quad-core small and medium-sized
business (SMB) focused servers:

Intel Pentium® Dual-core processor E2160-
based server

Quad-Core Intel Xeon® processor X3220-
based server

Quad-Core Intel Xeon processor E5335-
based server

We ran benchmarks that simulated three aspects of a
typical small business server workload: Web, email,
and database. We used WebBench* to simulate Web
traffic, Microsoft* Exchange Server* 2003 Load
Simulator* (LoadSim) to simulate email activity, and SysBench to simulate the database activity. The Workload
section provides more information on each of the benchmarks.

KEY FINDINGS
The Quad-Core Intel® Xeon® processor
E5335-based server delivered an average of
204.7 percent better performance across the
three benchmarks than did the Intel Pentium®
Dual-core processor E2160-based server (see
Figure 1) at an additional cost of about $966
(see Appendix B).

The Quad-Core Intel Xeon processor X3220-
based server delivered an average of 96.8
percent better performance across the three
benchmarks than did the Intel Pentium Dual-
core processor E2160-based server (see
Figure 1) at an additional cost of about $256
(see Appendix B).

Figure 1 presents averaged results for the three servers on the three benchmarks relative to the poorest-
performing server, the Intel Pentium Dual-core processor E2160-based server. For each benchmark, we assigned
a value of 100 percent to that server’s results and then calculated the percentage performance improvement of
both the Quad-Core Intel Xeon processor E5335-based server and the Quad-Core Intel Xeon processor E5335-
based server. This approach makes each data point a comparative number, with higher numbers indicating better
performance. Finally, for each server, we took the percentage performance improvement over the Intel Pentium
Dual-core processor E2160-based server for the three benchmarks and averaged them.
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Figure 1: Averaged performance of the three test servers across the three benchmarks relative

to the Intel Pentium Dual-core processor E2160-based server. Higher numbers are better.

As Figure 1 illustrates, the
Quad-Core Intel Xeon
processor E5335-based
server delivered an
average of 204.7 percent
better performance across
the three benchmarks than
did the Intel Pentium Dual-
core processor E2160-
based server.

The Quad-Core Intel Xeon
processor X3220-based
server delivered an
average of 96.8 percent
better performance across
the three benchmarks
than did the Intel Pentium
Dual-core processor
E2160-based server.
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Figure 2: Normalized price per performance result of the test servers across the three core processor E2160-
benchmarks. Lower numbers are better. based server.

The Quad-Core Intel Xeon processor E5335-based server produced a 9 percent lower price per performance
result than the Intel Pentium Dual-core processor E2160-based server.

Workload

WebBench

WebBench 5.0 (128-bit US version) is an industry-standard benchmark for Web server software and hardware. It
uses PC clients to send Web requests to a server under test. It generates performance results by incrementally
increasing the number of clients making HTTP 1.0 GET requests to the Web server; the result is a curve showing
the server’s performance under increasing load. The peak of that curve represents the peak throughput of the
server. WebBench reports both the total number of requests per second the server handled and the server’s total
throughput in bytes per second. To be certain that we found the true peak performance in our testing, we verified
that the server’s processor utilization reached or was extremely close to 100 percent during the test.

LoadSim

Microsoft Exchange Server 2003 Load Simulator is a benchmark that measures a server’s performance handling
email. LoadSim uses the MAPI Messaging Benchmark 3 (MMB-3) to simulate MAPI email clients. The simulated
clients issue requests to an Exchange server to generate an email load. LoadSim measures both the server’s
response time and the number of messages it delivers. LoadSim is available for free download from
www.microsoft.com/downloads/details.aspx?Familyld=92EB2EDC-3433-47CA-A5F 8-
0483C7DDEA85&displaylang=en.

SysBench

The developers at SourceForge.net (www.sourceforge.net) created SysBench to test various aspects of the
performance of servers running database systems. The benchmark’s original target was the MySQL database
system (see www.mysqgl.com). Intel created a version of SysBench 0.4.0 that would work with Microsoft SQL
Server 2005 Enterprise Edition (www.microsoft.com/sql/editions/enterprise/default.mspx). We ran that version in
our test. SysBench created a 100,000-row SQL database and executed a batch of online transaction processing
(OLTP) transactions against that data.

Test results

For testing, we staggered the starting times of the benchmarks to allow the server to ramp up slowly. We began
with WebBench, which we started and let run for 15 minutes. Then we started Microsoft LoadSim and allowed it to
run for another 15 minutes before starting SysBench. This allowed the server to address each benchmark load
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before the next one started. We set all benchmarks to run for one hour. To obtain the final results, we removed
the first and last 15 minutes of the hour run, leaving the middle 30 minutes of the run.

Figure 3 presents results for the three servers on the three benchmarks relative to the poorest-performing server,
the Intel Pentium Dual-core processor E2160-based server. For each benchmark, we assigned a value of 100
percent to that server’s results and then calculated the percentage performance improvement of both the Quad-
Core Intel Xeon processor E5335-based server and the Quad-Core Intel Xeon processor E5335-based server.
This approach makes each data point a comparative number, with higher numbers indicating better performance.
Finally, for each server, we took the percentage performance improvement over the Intel Pentium Dual-core
processor E2160-based server for the three benchmarks and averaged them.

Average of
Web Email Database Web, email,
requests per response transactions and
second time per second database
Percentage (relative to (relative to (relative to scores
Server CPU Intel Intel Intel (relative to
utilization Pentium Pentium Pentium Intel
Dual-core Dual-core Dual-core Pentium
processor processor processor Dual-core
E2160-based | E2160-based | E2160-based processor
server) server) server) E2160-based
server)
Intel Pentium Dual-core
processor E2160-based 94.5 100% 100% 100% 100%
server
Quad-Core Intel Xeon
processor X3220-based 99.2 323% 122% 145% 197%
server
Quad-Core Intel Xeon
processor E5335-based 99.4 388% 124% 402% 305%
server

Figure 3: Performance relative to the Intel Pentium Dual-core processor E2160-based server for the three servers on the
three benchmarks. Higher numbers are better.

As Figure 3 shows, the Quad-Core Intel Xeon processor E5335-based server achieved more Web requests per
second, faster email response time, and more database transactions per second than the other two servers. It
achieved these wins with less processor utilization.

WebBench results

We ran WebBench'’s default ecommerce API test suite, which generates both secure and non-secure static and
dynamic HTTP 1.0 GET requests. While running the ecommerce suite, the clients must negotiate to a secure
Web server port using the Secure Socket Layer (SSL) protocol. A default WebBench test suite incrementally
increases the number of clients making the HTTP 1.0 GET requests to the Web server. As the workload
increases the number of clients, the Web server’s processor utilization also increases, until the processor in the
Web server is saturated with work. Each workload point with a fixed number of clients is a WebBench “mix.” The
ecommerce API test suite begins with a mix that involves one client; the next mix has four clients, and each
subsequent mix increases the number of clients by four to a total of 60 clients. We modified the test suite so it
would run 20 clients with 10 engines per client for the entire test. This allowed us to keep a constant Web load on
the server. We performed the standard 16 mixes for testing.

A WebBench run reports the total requests per second a server can perform and the total throughput, in bytes per
second, that the server delivered. WebBench reports these results for each mix. To obtain the results below we
averaged the requests per second and throughput from the mixes that ran during the middle 30 minutes of the
benchmark run.
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Figure 4 shows the WebBench peak results in requests per second and in throughput (bytes per second) for the
three test servers. Each result below is the median of three runs.

Requests per Requests per second
Server Throughput second (relative to Intel Pentium
(bytes per second) (raw) Dual-core processor
E2160-based server)
Intel Pentium Dual-core
processor E2160-based 30,546,722.7 7,534.8 100%
server
Quad-Core Intel Xeon
processor X3220-based 98,636,204.2 24,3555 323%
server
Quad-Core Intel Xeon
processor E5335-based 118,406,599.7 29,231.3 388%
server

Figure 4: Median WebBench results for the three servers. Higher numbers are better.

LoadSim results

LoadSim results shows the response time each for each server, the time in milliseconds it took to complete a
request. Since the object of the server is to handle as many requests as possible, lower scores, which show a
server able to handle more requests in a given time, are better. Generally the most important point is the median
95th percentile, which means 95 percent of the time the server handled request at that level.

People usually run LoadSim tests on servers with large disk storage systems, i.e., a large number of total disk
drives. Since our testing focused on small business servers, which do not typically have a large number of disks,
the scaling between the servers was not as good as the other benchmarks. The systems were mostly
bottlenecked waiting on the disk, prohibiting a large amount of scaling.

For testing we used 100 Microsoft Exchange mailboxes; all of the servers could handle the load while performing
other tasks. However, the Quad-Core Intel Xeon processor E5335-based server handled the load better than the
other two servers.

Median 95th percentile
Median 50th Median 95th Median (relative to Intel Pentium
percentile percentile mean Dual-core processor

E2160-based server)

Server

Intel Pentium Dual-core
processor E2160-based 116 208 126 100%
server

Quad-Core Intel Xeon
processor X3220-based 102 162 105 122%
server

Quad-Core Intel Xeon
processor E5335-based 100 158 103 124%
server

Figure 5: Median LoadSim results for the three servers. Lower numbers are better.
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SysBench results

For testing, each system performed 10,000 transactions as quickly as possible. The output shows the completion
time in seconds for the system to perform the task. We calculated the transactions per second by using the

following formula:

10,000 transactions

completion time in seconds

= transactions per second

Figure 6 shows the median SysBench results and processor utilization for the three test servers. Worth noting, the
Quad-Core Intel Xeon processor E5335-based server and Quad-Core Intel Xeon processor X3220-based server
performed more transactions per second with less processor utilization that the Intel Pentium Dual-core processor

E2160-based server. This means both systems had resources available to perform additional tasks.

Transactions per
s Completion Transactions Transactions FEee (rela_t U
erver . Intel Pentium
time (seconds) completed per second D
ual-core processor
E2160-based server)
Intel Pentium Dual-core
processor E2160- 30:00 133,701 74.3 100%
based server
Quad-Core Intel Xeon
processor X3220- 30:00 194,094 107.8 145%
based server
Quad-Core Intel Xeon
processor E5335- 30:00 537,471 298.6 402%
based server

Figure 6: Median SysBench results for the three servers. Higher numbers are better.

Test methodology

Figure 7 summarizes some key aspects of the configurations of the three server systems; Appendix A provides

detailed configuration information.

Intel Pentium Dual- Quad-Core Intel Xeon Quad-Core Intel Xeon
Server core processor processor X3220- processor E5335-based
E2160-based server based server server
Processor frequency (GHz) 1.8 GHz 2.4 GHz 2.0 GHz
System bus 800 MHz 1,066 MHz 1,333 MHz
Dual/Quad-Core processors Dual Quad Quad
Motherboard S3000AH S3000AH S5000PSL
Chipset Intel 3000 Chipset Intel 3000 Chipset Intel 5000P Chipset
Kingston* Kingston Kingston
RAM KVR667D2E5K2/1G KVR667D2E5/1G KVR667D2D8F5/1G
2 x 512 MB SDRAM 2 x 1024 MB SDRAM 4 x 1024 MB FBDIMM
Hard drive Samsung* SP2004C Samsung SP2004C Samsung SP2004C
Intel PRO/1000 PM & Intel PRO/1000 PM &
NICs Intel PRO/1000 MT Intel PRO/1000 MT | 2 X Intel PRO/000 EB

Figure 7: Key aspects of the server configurations.

Intel configured and provided all three servers.
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We began our testing by installing a fresh copy of Microsoft* Windows* Server 2003 R2, Enterprise Edition
Service Pack 2 on each server. We followed this process for each installation:

oAM=

Assign a computer name of “Server”.

For the licensing mode, use the default setting of five concurrent connections.
Enter a password for the administrator log on.

Select Eastern Time Zone.

Use typical settings for the Network installation.

Use “Testbed” for the workgroup.

We applied the following updates from the Microsoft Windows Update site:

Windows Server 2003 Cumulative Security Update for Internet Explorer8 7 for Windows Server 2003
(KB937143)

Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB936021)

Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB938127)

Windows Update Windows Server 2003 Cumulative Security Update for Internet Explorer 6 for Windows
Server 2003 (KB937143)

Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB921503)

Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB936782)

Windows Update Windows Server 2003 Windows Malicious Software Removal Tool - August 2007
(KB890830)

Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB926122)

Windows Update Windows Server 2003 Security Update for Microsoft .NET Framework, Version 1.1
Service Pack 1 (KB933854)

Windows Update Windows Server 2003 Security Update for Windows Media Player 6.4 (KB925398)
Windows Update Windows Server 2003 Update for Windows Server 2003 (KB936357)

Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB935839)

Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB935840)

Windows Update Windows Server 2003 Cumulative Security Update for Outlook Express for Windows
Server 2003 (KB929123)

Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB924667)

Windows Update Windows Server 2003 Update for Windows Server 2003 (KB927891)

Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB932168)

Windows Update Windows Server 2003 Windows Internet Explorer 7.0 for Windows Server 2003
Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB931784)

Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB930178)

Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB925902)

Windows Update Windows Server 2003 Update for Windows Server 2003 Service Pack 2 (KB931836)

Installing and configuring the mail server
To set up this server we had to install several additional software components. The following subsections detail
the necessary installation processes.

Installing the domain controller

Nogohr~wdh =

Select Start->Administrative Tools->Manage Your Server.

Click Add or remove a role.

At the Configure Your Server window, click Next.

At the Configuration and Options screen, select Custom Configuration, and click Next.
At the Server Role screen, select Domain Controller, and click Next.

At the Summary of Selections screen, click Next.

At the Welcome pop-up window, click Next.
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8.
9.

10.
11.
12.
13.
14.

15.

16.
17.
18.
19.
20.

At the Operating System Compatibility screen, click Next.

For the Domain Controller Type, leave the default option (Domain controller for a new domain), and click
Next.

At the Create New Domain screen, leave the default (Domain in a new forest), and click Next.

At the Install or Configure DNS window, select No, and click Next.

At the New Domain Name screen, type a domain name (loadsim.com), and click Next.

At the NetBIOS Domain Name screen, enter a NETBIOS domain name (loadsim), and click Next.

Click Next through the following screens: Database and Log Folders, Shared System Volume, and
Permissions. Doing so accepts the default options for each of those screens.

At the Directory Services Restore Mode Administrative Password screen, enter a password (password),
and click Next.

When the installation software prompts you to do so, insert the OS CD, and click OK.

At the Completing the Active Directory Installation Wizard screen, click Finish.

When the system prompts you to reboot the server, click Restart Now.

After the server reboots, login to the system.

At the This Server is Now a Domain Controller window, click Finish.

Installing Internet Information Services 6.0

©CoNO>ORA~®ON =

10
11.

Select Start->Control Panel->Add or Remove Programs.

Click Add/Remove Windows Components.

Select Application Servers, and click Details.

Click ASP.NET, and make sure a check is showing in the check box.
Select Internet Information Services (IIS), and click Details.

Click NNTP Services and SMTP Services, make sure a check appears in both check boxes, and click OK.
Click OK to close the Application Server window.

At the Windows Components Wizard, click Next to begin the installation.
When the system prompts you to do so, insert the OS CD, and click OK.
At the Completing the Windows Components Wizard window, click Finish.
Close the Add or Remove Programs window.

Installing Exchange Server 2003

1.

Noo~WN

Insert the Microsoft Exchange Server 2003 CD. The CD should automatically launch the installation

software.

Choose Exchange Server Enterprise Edition.

Run the Setup application.

Click the Exchange Deployment Tools link.

Click the Deploy the first Exchange 2003 Server link.

Click the New Exchange 2003 Installation link.

Click the Run ForestPrep now link.

a. When the compatibility issue notice appears, click Continue, and check the Don’t display this
message again box.

b. Atthe Welcome screen, click Next.

c. Accept the End User License Agreement, and click Next.

d. At Component Selection Screen, keep the defaults, and click Next.

e. Leave the default account information, and click Next.

f. Installation should start. (This process may take a while to complete.)

g. When the installation completes, click Finish.

Return to the Exchange Server Deployment Tools screen, and click the Run DomainPrep now link.

a. Atthe Welcome screen, click Next.

b. Accept the End User License Agreement, and click Next.

c. At Component Selection Screen, keep the defaults, and click Next.

d. Atthe insecure domain notice, click OK.

e. When the installation completes, click Finish.

Return to the Exchange Server Deployment Tools screen, and click Run Setup Now.

a. Atthe Welcome screen, click Next.

b. Accept the End User License Agreement, and click Next.
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10.
11.

12.
13.
14.
15.
16.
17.
18.
19.
20.

T Taemoea

o

At the Component Selection screen, the action for Microsoft Exchange should by default be Typical.
(If it is not, use the drop-down box to set it to Typical.)

Click Next.

For the Installation Type, select Create new Exchange Organization, and click Next.

Enter loadsim as the Organization Name, and click Next.

Accept the Microsoft Exchange Server Licensing Agreement, and click Next.

Review the installation summary, and click Next.

The installation should start. (This process may take a while to complete.)

When the installation completes, click Finish.

Close the Exchange Server Deployment Tools window.

Install Microsoft Exchange Server 2003 Service Pack 2.

Insert the SP2 CD, and double-click setup exe.

Accept the default location to extract the file, and click OK.

After the extraction finishes, open Windows Explorer, and browse to the update.exe executable.
At the Welcome screen, click Next.

Select | agree to accept the License Agreement, and click Next.

At the Component Selection window, leave the default option (Update), and click Next.

Verify the installation Summary, and click Next.

When the installation completes, click Finish.

Select Start->All Programs->Microsoft Exchange->System Manager.

In the left-hand window pane, expand Servers and MailServer so the First Storage Group is visible.
Right-click First Storage Group, and select Properties.

Check the Enabile circular logging box.

Click Apply.

Right-click Mailbox Store under First Storage Group, and select Properties.

Select the Database tab.

Click Customize next to Maintenance interval.

Remove all blue from the boxes so the system will not perform maintenance, and click OK.

SQ 000 oD

Installing and configuring the Web server

Deploying WebBench data
WebBench includes data that must reside on the server and that the Web server must use. We loaded that data
and set the Web server to use it with the following procedure:

1.

2

© oo N

Copy the file wbtree.exe from the WebBench CD to the wwwroot directory on the server under test. (The
wbtree.exe file is on the WebBench CD at \wb50\workload).

On the server, execute the wbtree.exe file. This program will copy the WebBench workload to the server.
In the wwwroot folder on the server, create a new folder with the name CGI-BIN.

Copy the file simisapi.dll to the CGI-BIN folder.

Click Start button->Programs->Administrative Tools->Computer Management to open the management
console.

Go to Services and Application—>Internet Information Services—> Default Web Site>CGI-BIN, and right
click to bring up a menu. Select Properties.

Go to the Directory Tab, and Set Execute Permissions to Scripts and Executables.

When the 1IS WWW Configuration popup window displays, click Yes.

Close the Computer Management window.

Configuring Internet Information Services (lIS)
We configured the Windows Internet Information Services Web server as follows:

1.
2.
3.

Open Computer Management.
Go to Services and Application->Internet Information Services.
Right click to bring up a menu. Select Properties.
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21.

22.

Click the MIME Types button.

In the MIME Types window, click the New button.

In the Extension field, type “*”.

In the MIME type field, type “application/octet-stream”. Click the OK button.

Click the OK button to exit the MIME Types window.

Click the OK button to exit the Internet Information Services (l1S) Manager Properties window.

. In the Computer Management window, go to Web Sites—>Default Web Site under Internet Information

Services. Right click it to bring up a menu. Select Properties.

. Select the Home Directory tab.

. Check the following boxes: Script source access, Read, Write, and Directory browsing.

. Uncheck the following boxes: Log visits and Index this resource.

. In the Execute permissions field, select Scripts and Executables.

. Click the Apply button.

. Select the Web Site tab.

. Uncheck Enable Logging.

. Click the OK button to close the Default Web Site Properties window.

. In the Computer Management window, go to the Web Service Extensions item under Internet Information

Services.

. In the right panel, highlight All Unknown ISAPI Extensions and click the Allow button. Acknowledge the

[IS Manager warning that appears by clicking the Yes button.

In the right panel, highlight All Unknown CGI Extensions and click the Allow button. Acknowledge the I1IS
Manager warning that appears by clicking the Yes button.

Close the Computer Management window.

Installing certificate services
Because WebBench includes tests that involve security, we installed Windows Certificate Services as follows:

Nogohr~wN =

8.
9.
10.
11.
12.
13.

Click Start->Control Panel->Add/Remove Programs.

Select Add/Remove Windows Components.

Put a check mark by Certificate Services.

Accept the notice that the server's name cannot be changed after you install this service.

Press Next.

Select Stand Alone Root CA, and click Next.

On the CA Identifying Information window, enter the server name in the Common name for this CA field,
and click Next.

Leave the default Certificate Database Settings as they are, and click Next.

Click Yes at the prompt asking if you want to enable Active Server Pages (ASP) in IIS.

Click yes at the prompt that explains that Internet information Services will be temporarily stopped.
Click Next.

Click Finish.

Click Close.

Setting up Internet Explorer
We had to set up Internet Explorer on the server as follows to be able to get the necessary certificates:

agrON=

Click the Internet Explorer icon on the Quick Launch toolbar.
Select the Tools—> Internet Options menu item.

On the Connections tab, click the LAN Settings button.
Check Automatically detect settings, and click OK.

Click OK to exit the Internet Options window.

Requesting the server certificate
We had to set up Internet Explorer on the server as follows to be able to get the necessary certificates:
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1. Open Internet Explorer and enter the following website, http://server/certsrv. This should bring up a page
entitled “Microsoft Certificate Services — server”.
Select Request a Certificate link.
Select Advanced Certificate Request link.
Select “Create and submit a certificate request to this CA” link.
Fill out the appropriate Identifying Information details on the Advanced Certificate Request.
e Name: Performance
e Company: PT
o Type of certificate needed: Server Authentication Certificate
e Key Options:
o CSP: Microsoft Base Cryptographic Provider v1.0
o Usage: Exchange and Signature — select both
o Key size: 512
O
O

aoRrwd

Check “Automatic key container name”
Check “Store certificate in the local computer certificate store”
e Additional Options:
o Hash Algorithm: SHA-1
e Otherwise use default
6. Click [Submit]. Acknowledge the “Potential Scripting Violation” by clicking the [Yes] button.
7. There should now be a page informing that there is a Certificate Pending.

Issuing the server certificate
Next we had to issue a server certificate as follows:

Select Start->Programs—>Administrative Tools—> Certification Authority.
Click the server’s name.

Select Pending Requests.

Right click Pending Requests, select All Tasks, and choose Issue.
Close Certification Authority.

RN

Installing the server certificate
We then installed the server certificate as follows:

Open Internet Explorer.

Go to the page http://server/certsrv again.

Click the View the status of a pending certificate link.

Click the Server Authentication Certificate link.

Click the Install this Certificate link.

Acknowledge the Potential Scripting Violation warning by clicking the OK button.
A message will note that a certificate has been successfully installed.

Close Internet Explorer.

NGO ALON =

Setting IIS to use the server certificate
We then set IS to use the server certificate as follows:

1. Click Start>Programs->Administrative Tools>Computer Management to open the management console.
2. Select Services and Applications—>Internet Information Services>Web Sites.
3. Right click the Default Web site, and select Properties.
4. Select the Directory Security tab, and Click the Server Certificate button.
5. The Welcome to the Web Server Certificate Wizard window appears. Click Next.
6. Select Assign an Existing Certificate, and click Next.
7. Select your server certificate (Intended Purpose: Server Authentication). Click Next.
8. Accept the default SSL port (443) in the next window that appears, and click Next.
9. On the Certificate Summary screen click Next.
Principled Technologies, Inc.: Performance of three Intel®-based SMB servers 10
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10. Click Finish.

Creating SSL Communication
Finally, we had to enable SSL communication as follows:

1. Go to Computer management->Services and Application—=>Internet Information Services.
2. Expand the Default Web site.

3. Expand wbtree.

4. Right click Wbssl, and select properties.

5. Select the Directory Security tab.

6. Click the Edit button under Secure communications.

7. Check Require secure channel (SSL).

8. Check Require 128-bit encryption.

9. Click OK.

10. Click OK.

We then set the following operating system tuning parameters to reflect the WebBench recommendation in the
Microsoft performance Tuning Guidelines for Windows Server 2003 document, which is available on Microsoft’'s
Web site. When creating the following parameters, ensure that they are DWORD files, with Decimal coding
(rather than Hexadecimal)

HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters\MaxCachesFileSize to 1048576
HKLM\System\CurrentControlSet\Services\HT TP\Parameters\UriMaxUriBytes to 1048576
HKLM\System\CurrentControlSet\Control\FileSystem\NtfsDisableLastAccess to 1
HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\MaxHashTableSize to 65535

Installing and configuring the database server

Installing Microsoft Internet Information Server

Select Start->Administrative Tools>Manage Your Server.

Select Add or remove a role.

At the preliminary steps screen, click Next.

At the Server Role screen, select Application Server, and click Next.

At the Summary of Selections screen, click Next.

When the installation software prompts you to do so, insert the OS CD, and click OK.
When the installation completes, click Finish.

Close the Manage Your Server window.

Installing Microsoft SQL Server 2005

Insert the SQL Server 2005 CD into the server.

Click the Server Components link under the Install section to begin the installation.

Accept the license agreement, and click Next.

Click Next to install the prerequisites.

After the prerequisites complete installing screen, click Next.

At the Welcome screen, click Next.

At the System Configuration Check, assuming everything has a status of success click Next.

Enter the registration information, and click Next.

At the Components to Install screen, select SQL Server Database Services, then click Advanced.

0. Instruct the software to install both the Database Services and Client Components by clicking the drop-
down arrow on both and selecting Entire feature will be installed on local hard drive.

11. Click Next to start the installation.

12. For Instance Name, leave the default option, and click Next.

13. At the Service Account screen, select Use the built-in system account (Local account), and click Next.

14. Keep the default option for Authentication Mode, and click Next.
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15. For Collation Settings, leave the defaults, and click Next.

16. Accept the default Error and Usage Report Settings, and click Next.

17. At the Ready to Install screen, click Install to begin the installation.

18. When the installation software prompts you to do so, insert Microsoft SQL Server 2005 disk 2, and click
OK.

19. When the setup process completes, click Next.

20. Click Finish to complete the installation.

Creating the test database and generating data
1. Select Start>Microsoft SQL Server 2005>SQL Server Management Studio.
2. In the Connect to Server window, use the drop-down menu next to Server name to select <Browse for
more>.
In the Browse for Server window, select the Network Servers tab, and wait for it to retrieve data.
When Database Engine appears, expand the menu, select Server, and click OK.
At the Connect to Server window, the server name should be present.
Click Connect to connect to the server.
Right-click the Database folder in the left-hand window, and select New Database from the pop-up menu.
In the Database name field, type sbtest, and click OK.
Open a command prompt by selecting Start>Run, type cmd, and click OK.
. In the command prompt, type cd to change to C:\.
. To prepare the database, type “vsysbench.exe --test=oltp --oltp-table-size=100000 prepare”, and press
Enter.
12. When the command finishes, you see the C:\ prompt.
13. Type exit, and press Enter to close the command prompt.
14. In SQL Server 2005 Management Studio, stop the database service by right-clicking server in the left-
hand window pane, and then select stop from the drop-down menu.
15. Using Windows Explorer, create the folder C:\backup.
16. With Windows Explorer, copy all sbtest files from C:\Program File\Microsoft SQL
Server\MSSQL.1\MSSQL\Data\ to c:\backup. (You should see two files: sbtest.mdf and sbtest_log.Idf.)
17. Close Windows Explorer once the copy completes.
18. Restart the database service using SQL Server 2005 Management Studio by right-clicking server and
selecting start.

220N AW
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Installing the mail test client
Each mail server requires one physical test client system. We used the following process to set up each such
system.

Install Microsoft Windows Server 2003 R2 Enterprise Edition. Use mailclient as the system name.
Install Windows Server 2003 Service Pack 2 with the default settings.

Open the Network Connections window by right-clicking My Network Places and selecting Properties.
Right-click the network connection, and click Properties.

Highlight TCP/IP, and select Properties.

Select Use the following IP address, and enter the correct information

Click OK to close the two Properties windows.

Right-click My Computer, and select Properties.

Click the Computer Name tab.

10. Click Change.

11. Select Domain in the member of section, and type the domain test.com into the text box.

12. In the pop-up window, enter administrator for user name and password for password, and click OK.
13. At the Welcome to the domain screen, click OK.

14. When the warning that you must restart dialog appears, click OK.

15. Click OK to close the System Properties window.

16. Click Yes to the pop-up message to restart the computer.

17. Login to the domain by using administrator and password.

18. Install Microsoft Outlook 2003 with the default settings. (Outlook 2003 doesn’t require any configuration.)
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19.
20.

Install LoadSim 2003 by double-clicking the loadsim.msi installation file. Accept all defaults.
Open LoadSim 2003, and make sure no error messages appear.

Configuring LoadSim 2003

Start LoadSim by clicking Start Menu—->All Programs->Exchange LoadSim—->LoadSim 2003.
From the LoadSim menu bar, select Configuration->Topology Properties.

Click the Servers tab.

In the left pane, click the + next to the name of this server.

In the left pane, select the First Storage Group.

In the right pane, set the number of users to 100.

Select the Security and Credentials tab.

Leave the Credentials choice set to Login to users using the account LoadSim is running on.
In the password portion of the tab, enter the password "Password1", and click OK.

. From the LoadSim menu bar, choose File->Save As
. Save a backup copy of the simulation file as C:\loadsim.sim.
. From the LoadSim menu bar, select Run—>Create Topology, and wait until the Creating Users and

Creating DLs tasks complete.

. From the LoadSim menu bar, select Run—>Initialize Test.
. When a dialog box appears with the question Do you want to initialize Public Folders from this client

machine?, click Yes.

. The run is complete when the bottom left corner of the LoadSim window shows Status: Idle. This task

typically takes about two to three hours to complete.

Back up the mail database
Once you’ve set up LoadSim and created its initial mail database, you need to back up that database so you can
have clean copies for each test. Use this process to back up that database.

PN~
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7.
8.
9.
10.
11.
12.
13.
14.

Select Start->All Programs—>Microsoft Exchange—> System Manager in the mail server.

In the left pane, expand Servers until First Storage Group appears highlighted.

In the right pane, right-click Mailbox Store, and select Dismount Store from the menu.

Click Yes on the Do you want to continue? pop-up message. When you’ve dismounted the Mailbox Store,
a red arrow appears in the window pane.

Right-click Public Folder Store, and select Dismount Store from the menu.

Click Yes on the Do you want to continue? pop-up message. The red arrow will appear when you've
dismounted the Public Folder Store.

Using Windows Explorer, create a new folder e:\backup.

With Windows Explorer, copy all files from C:\ to C:\backup. This process may take several minutes.
Close Windows Explorer.

In Exchange System Manager, right-click Mailbox Store, and select Mount Store from the menu.
Click OK on the pop-up message, The store was successfully mounted.

Right-click Public Folder Store, and select Mount Store from the menu.

Click OK on the pop-up message, The store was successfully mounted.

Close Exchange System Manager.

Network test bed configuration

To generate the workload, we used a network with 22 client PCs. Each PC contained an Intel Pentium 4 3.0GHz
with HT Technology processor, 512MB of system memory, a 40GB hard drive, and a Gigabit Ethernet network
adapter. We configured each client with Windows XP Professional with Service Pack 2 and all critical updates
available as of June 7, 2007.

We split 20 of the clients into two segments, or subnets, of 10 clients each. We connected each segment to the
server under test via one NETGEAR* GS724T Gigabit Smart Switch*. To balance the load on the server and to
prevent a network throughput bottleneck, we connected each segment to a separate network port. We used the
remaining two clients for the WebBench controller and LoadSim client. Figure 8 illustrates the test bed
configuration.
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Figure 8: lllustration of the test network we used to generate the WebBench workload.
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Appendix A — Test system configuration information

This appendix provides detailed configuration information about each of the test server systems, which we list in

alphabetical order.

Intel Pentium Dual-

Quad-Core Intel Xeon

Quad-Core Intel Xeon

(MHz)

Server core processor processor X3220- processor E5335-
E2160-based server based server based server
General
Number of processor 1 1 2
packages
Number of cores per 2 4 4
processor package
Number of hardware
1 1 1
threads per core
ﬁ/l};sr;tzgnezzvxtelr:’olicy Always on Always on Always on
CPU
Vendor Intel Intel Intel
Name Intel Pentium E2160 Intel Xeon X3220 Intel Xeon E5335
Stepping 2 7 7
Socket type Socket 775 LGA Socket 775 LGA Socket 771 LGA
Core frequency (GHz) 1.8 GHz 2.4 GHz 2.0 GHz
Front-side bus frequency | g4 ppp, 1,066 MHz 1,333 MHz

32 KB + 32 KB (per

32 KB + 32 KB (per

32 KB + 32 KB (per

L1 cache
core) core) core)

L2 cache 1 MB (shared) 8 MB (2 x 4 MB) 8 MB (2 x 4 MB)

Platform

Vendor and model Intel Intel Intel

number

Motherboard model S3000AH S3000AH S5000PSL

number

Motherboard chipset Intel 3000 Intel 3000 Intel 5000P

Motherboard revision 00 00 B1

number

Motherboard serial AZAX71300522 AZAXT71200495 QTFMHN63al800588
Intel Corporation Intel Corporation Intel Corporation

BIOS name and version S$3000.86B.02.00.0043 | S3000.86B.02.00.0043 | S5000.86B.07.00.0079
.061820070639 .061820070639 .060520071732

BIOS settings Default Default Default

Chipset INF driver

Intel 8.1.1.1010

Intel 8.1.1.1010

Intel 8.1.1.1010

Memory module(s)

(MHz)

Vendor and model Kingston Kingston Kingston

number KVR667D2E5K2/1G KVR667D2E5/1G KVR667D2D8F5/1G
PC2-5300 DDR2 PC2-5300 DDR2

Type SDRAM ECC SDRAM ECC Egé'lfﬁao DDR2
unbuffered unbuffered

Speed (MHz) 667 MHz 667 MHz 667 MHz

Speed in the system

currently running @ 333 MHz 333 MHz 333 MHz

Principled Technologies, Inc.: Performance of three Intel®-based SMB servers
using WebBench, LoadSim, and SysBench

15



Intel Pentium Dual-

Quad-Core Intel Xeon

Quad-Core Intel Xeon

Server core processor processor X3220- processor E5335-
E2160-based server based server based server

Timing/Latency (tCL- 5.5-5-15 5.5-5-15 5.5-5-15

tRCD-iRP-tRASmin)

Size 1,024 MB 2,048 MB 4,096 MB

Number of RAM modules | 2 x 512 MB 2 x 1024 MB 4 x 1024 MB

Chip organization Single-sided Double-sided Double-sided

Channel Dual Dual Dual

Hard disk

Vendlor and model Samsung SP2004C | Samsung SP2004C | Samsung SP2004C

Number of disks in 2 2 2

system

Size 200 GB 200 GB 200 GB

Buffer size 8 MB 8 MB 8 MB

RPM 7,200 7,200 7,200

Type SATA SATA SATA

Controller Intel 82801GB (ICH7) Intel 82801GB (ICH7) Intel 6321ESB

Controller driver

Intel 7.6.0.1011

Intel 7.6.0.1011

Intel 7.15.209.2007

Operating system

Microsoft Windows

Microsoft Windows

Microsoft Windows

Intel PRO/1000 MT
v8.8.1.0

Intel PRO/1000 MT
v8.8.1.0

Name Server 2003 R2, Server 2003 R2, Server 2003 R2,
Enterprise Edition Enterprise Edition Enterprise Edition

Build number 3790 3790 3790

Service Pack 2 2 2

Microsoft Windows 8/9/07 8/9/07 8/9/07

update date

File system NTFS NTFS NTFS

Kernel ACPI Multiprocessor ACPI Multiprocessor ACPI Multiprocessor
PC PC PC

Language English English English

Microsoft DirectX version | 9.0c 9.0c 9.0c

Graphics

Vendor and model
ATI ES1000 ATI ES1000 ATI ES1000

number

Chipset ATI ES1000 ATI ES1000 ATI ES1000

BIOS version BK-ATI BK-ATI BK-ATI
VER008.005.023.000 VER008.005.023.000 VER008.005.023.000

Type Integrated Integrated Integrated

Memory size 16 MB 16 MB 16 MB

Resolution 1,024x768 1,024x768 1,024x768

Driver ATI 8.24.3.0 ATI 8.24.3.0 ATI 8.24.3.0

Network

card/subsystem

Vendor and model Intel PRO/1000 PM & Intel PRO/1000 PM &

number Intel PRO/1000 MT Intel PRO/1000 MT 2 x Intel PRO/1000 EB

Type Integrated Integrated Integrated
Intel PRO/1000 PM Intel PRO/1000 PM

Driver v9.7.34.0 v9.7.34.0 Intel 9.9.13.0
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Server

Intel Pentium Dual-
core processor
E2160-based server

Quad-Core Intel Xeon
processor X3220-
based server

Quad-Core Intel Xeon
processor E5335-
based server

Additional network
adapter

2 x Intel PRO/1000 PT
Dual Port Server

2 x Intel PRO/1000 PT
Dual Port Server

2 x Intel PRO/1000 PT
Dual Port Server

Adapter Adapter Adapter
Driver Intel 9.9.13.0 Intel 9.9.13.0 Intel 9.9.13.0
Optical drive
Vendor and model Sony* CRX230ED Sony CRX230ED Sony CRX230ED
Type CD-RW CD-RW CD-RW
Interface IDE IDE IDE
Dual/single layer Single layer Single layer Single layer
USB ports
Number
of ports 4 4 6
Type of ports (USB 1.1, | ;55 USB 2.0 USB 2.0

USB 2.0)

Figure 9: Detailed system configuration information for the test servers.
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Appendix B — Price information

Figure 10 presents the price information for the test systems as of September 5, 2007.

Intel Pentium Dual-
core processor

Quad-Core Intel
Xeon processor

Quad-Core Intel
Xeon processor

SR E2160-based X3220-based E5335-based
server server server

Price as of September 5, 2007

Motherboard’ $259.99 $259.99 $579.99
Processor’ 85.99 299.99 707.98
Hard drives? 109.98 109.98 109.98
Memory? 49.99 91.98 329.96
Intel SC5250-E case® 179.00 179.00 179.00
Total price* $684.95 $940.94 $1,906.91

Figure 10: Price information for the test systems.

Notes

! Price from www.cdw.com.

% Price from www.newegg.com.

® Price from www.hypermicro.com.

* Cost does not include shipping or tax.
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Principled Technologies is a registered trademark of Principled Technologies, Inc.
Intel, Xeon, and Pentium are registered trademarks of Intel Corporation or its subsidiaries in the United States
and other countries.*All other product names are the trademarks of their respective owners.

Disclaimer of Warranties; Limitation of Liability:

PRINCIPLED TECHNOLOGIES, INC. HAS MADE REASONABLE EFFORTS TO ENSURE THE ACCURACY AND VALIDITY OF ITS
TESTING, HOWEVER, PRINCIPLED TECHNOLOGIES, INC. SPECIFICALLY DISCLAIMS ANY WARRANTY, EXPRESSED OR
IMPLIED, RELATING TO THE TEST RESULTS AND ANALYSIS, THEIR ACCURACY, COMPLETENESS OR QUALITY, INCLUDING
ANY IMPLIED WARRANTY OF FITNESS FOR ANY PARTICULAR PURPOSE. ALL PERSONS OR ENTITIES RELYING ON THE
RESULTS OF ANY TESTING DO SO AT THEIR OWN RISK, AND AGREE THAT PRINCIPLED TECHNOLOGIES, INC., ITS
EMPLOYEES AND ITS SUBCONTRACTORS SHALL HAVE NO LIABILITY WHATSOEVER FROM ANY CLAIM OF LOSS OR DAMAGE
ON ACCOUNT OF ANY ALLEGED ERROR OR DEFECT IN ANY TESTING PROCEDURE OR RESULT.

IN NO EVENT SHALL PRINCIPLED TECHNOLOGIES, INC. BE LIABLE FOR INDIRECT, SPECIAL, INCIDENTAL, OR
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