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Performance of four Intel®- and AMD*-based SMB
servers using WebBench, LoadSim, and SysBench

Executive summary

Intel® Corporation (Intel) commissioned Principled
Technologies® (PT) to measure the performance
while running multiple benchmarks simultaneously on
four dual- and quad-core small and medium-sized
business (SMB) focused servers:

¢ Intel Pentium® Dual-core processor E2160-
based server (1.80 GHz, 1 MB L2 cache, 800
MHz bus, 65nm)

e Quad-Core AMD* Opteron* processor 1356-
based server (2.30 GHz, 2 MB L2 cache,
2,000 MHz bus, 65nm)

e Quad-Core Intel Xeon® processor X3220-
based server (2.40 GHz, 8 MB L2 cache,
1066 MHz bus, 65nm)

¢ Quad-Core Intel Xeon processor X3350-
based server (2.66 GHz, 12 MB L2 cache,
1333 MHz bus, 45nm)

We ran benchmarks that simulated three aspects of a
typical small business server workload: Web, email,
and database. We used WebBench* to simulate Web
traffic, Microsoft* Exchange Server* 2003 Load
Simulator* (LoadSim) to simulate email activity, and

KEY FINDINGS
The 45nm Quad-Core Intel Xeon processor
X3350-based server delivered an average of
55.7 percent better performance across the
three benchmarks than did the 65nm Quad-
Core AMD Opteron processor 1356-based
server (see Figure 1), while costing $10 less
(see Appendix B).

The 45nm Quad-Core Intel Xeon processor
X3350-based server delivered an average of
161.3 percent better performance across the
three benchmarks than did the 65nm Intel
Pentium Dual-core processor E2160-based
server (see Figure 1) at an additional cost of
about $330 (see Appendix B).

The 45nm Quad-Core Intel Xeon processor
X3350-based server delivered an average of
34.2 percent better performance across the
three benchmarks than did the 65nm Quad-
Core Intel Xeon processor X3220-based
server (see Figure 1) at an additional cost of
about $161 (see Appendix B).

SysBench* to simulate the database activity. The Workload section provides more information on each of the

benchmarks.
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Figure 1: Averaged performance of the four test servers across the three benchmarks
relative to the Intel Pentium Dual-core processor E2160-based server. Higher numbers are

better.

value of 100 percent to that
server’s results and then
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performance improvement of
the Quad-Core AMD Opteron
processor 1356-based server,
the Quad-Core Intel Xeon
processor X3220-based
server, and the Quad-Core
Intel Xeon processor X3350-
based server. This approach
makes each data point a
comparative number, with
higher numbers indicating
better performance. Finally,



for each server, we took the percentage performance improvement over the Intel Pentium Dual-core processor
E2160-based server for the three benchmarks and averaged them.

As Figure 1 illustrates, the Quad-Core Intel Xeon processor X3350-based server delivered an average of 161.3
percent better performance across the three benchmarks than did the Intel Pentium Dual-core processor E2160-
based server. The Quad-Core Intel Xeon processor X3350-based server delivered an average of 55.7 percent
better performance across the three benchmarks than did the Quad-Core AMD Opteron processor 1356-based
server. The Quad-Core Intel Xeon processor X3350-based server delivered an average of 34.2 percent better
performance across the three benchmarks than did the Quad-Core Intel Xeon processor X3220-based server.
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Figure 2: Normalized performance-per-dollar result of the test servers across the three The Quad-Core Intel Xeon
benchmarks. Higher numbers are better. processor X3350-based

server produced a 60.7
percent higher performance-per-dollar result than the Quad-Core AMD Opteron processor 1356-based server and
a 7.9 percent higher performance-per-dollar result than the Quad-Core Intel Xeon processor X3220-based server.
Of the entry servers we tested, the 45nm Intel Xeon processor-based server offers the best SMB value.

Workload

WebBench

WebBench 5.0 (128-bit US version) is an industry-standard benchmark for Web server software and hardware. It
uses PC clients to send Web requests to a server under test. It generates performance results by incrementally
increasing the number of clients making HTTP 1.0 GET requests to the Web server; the result is a curve showing
the server’s performance under increasing load. The peak of that curve represents the peak throughput of the
server. WebBench reports both the total number of requests per second the server handled and the server’s total
throughput in bytes per second. To be certain that we found the true peak performance in our testing, we verified
that the server’s processor utilization reached or was extremely close to 100 percent during the test.

LoadSim

Microsoft Exchange Server 2003 Load Simulator is a benchmark that measures a server’s performance handling
email. LoadSim uses the MAPI Messaging Benchmark 3 (MMB-3) to simulate MAPI email clients. The simulated
clients issue requests to an Exchange server to generate an email load. LoadSim measures both the server’s
response time and the number of messages it delivers. LoadSim is available for free download from
www.microsoft.com/downloads/details.aspx?Familyld=92EB2EDC-3433-47CA-A5F 8-
0483C7DDEA85&displaylang=en.
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SysBench

The developers at SourceForge.net (www.sourceforge.net) created SysBench to test various aspects of the
performance of servers running database systems. The benchmark’s original target was the MySQL database
system (see www.mysql.com). Intel created a version of SysBench 0.4.0 that would work with Microsoft SQL
Server 2005 Enterprise Edition (www.microsoft.com/sql/editions/enterprise/default.mspx). We ran that version in
our test. SysBench created a 100,000-row SQL database and executed a batch of online transaction processing
(OLTP) transactions against that data.

Test results

For testing, we staggered the starting times of the benchmarks to allow each server to ramp up slowly. We began
the benchmarks in the following order: WebBench, Microsoft LoadSim, and SysBench. Figure 3 shows a timeline
for the benchmark runs. To obtain the final results, we removed the first and last parts of each benchmark run,
and computed the results based on the 30 minutes of peak performance during the SysBench run.

Multiple benchmark timeline
1.5 hours total time
AT 00:45-01:15
00:00 01:30
=T KT 00:45 - 01:15
00:15 01:30
00:45 - 01:15
SysBench
00:30 01:30

Figure 3: The timeline we followed when starting the benchmarks for the multiple-benchmark runs on
all servers. The shaded areas from 00:45 to 01:15 represent the period that we measured performance.

Figure 4 presents results for the four servers on the three benchmarks relative to the lowest-performing server,
the Intel Pentium Dual-core processor E2160-based server. For each benchmark, we assigned a value of 100
percent to that server’s results and then calculated the percentage performance improvement of the Quad-Core
AMD Opteron processor 1356-based server, the Quad-Core Intel Xeon processor X3220-based server, and the
Quad-Core Intel Xeon processor X3350-based server. This approach makes each data point a comparative
number, with higher numbers indicating better performance. Finally, for each server, we took the percentage
performance improvement over the Intel Pentium Dual-core processor E2160-based server for the three
benchmarks and averaged them.

As Figure 4 shows, the Quad-Core Intel Xeon processor X3350-based server achieved more Web requests per
second and more database transactions per second than the other three servers. It achieved these wins with less
processor utilization than the Quad-Core Intel Xeon processor X3220-based server and the Intel Pentium Dual-
core processor E2160-based server and only slightly greater processor utilization than the Quad-Core AMD
Opteron processor 1356-based server.
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Figure 4: Performance relative to the Intel Pentium Dual-core processor E2160-based server for the four servers on the three
benchmarks. Higher numbers are better.

WebBench results

We ran WebBench'’s default ecommerce API test suite, which generates both secure and non-secure static and
dynamic HTTP 1.0 GET requests. While running the ecommerce suite, the clients must negotiate to a secure
Web server port using the Secure Socket Layer (SSL) protocol. A default WebBench test suite incrementally
increases the number of clients making the HTTP 1.0 GET requests to the Web server. As the workload
increases the number of clients, the Web server’s processor utilization also increases, until the processor in the
Web server is saturated with work. Each workload point with a fixed number of clients is a WebBench “mix.” The
ecommerce API test suite begins with a mix that involves one client; the next mix has four clients, and each
subsequent mix increases the number of clients by four to a total of 60 clients. We modified the test suite so it
would run 20 clients with 10 engines per client for the entire test. This allowed us to keep a constant Web load on
the server. We performed the standard 16 mixes for testing.

A WebBench run reports the total requests per second a server can perform and the total throughput, in bytes per
second, that the server delivered. WebBench reports these results for each mix. To obtain the results below, we
averaged the requests per second and throughput from the mixes that ran during the peak performance of the
benchmark run as illustrated in Figure 3.

Figure 5 shows the WebBench peak results in requests per second and in throughput (bytes per second) for the
four test servers. Each result below is the median of three runs.
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Figure 5: Median WebBench results for the four servers. Higher numbers are better.

LoadSim results

LoadSim results show the response time each for each server, the time in milliseconds it took to complete a
request. Since the object of the server is to handle as many requests as possible, lower scores, which show a
server able to handle more requests in a given time, are better. Generally the most important point is the median
95th percentile, which means 95 percent of the time the server handled request at that level.

People usually run LoadSim tests on servers with large disk storage systems, i.e., a large number of total disk
drives. Since our testing focused on small business servers, which do not typically have a large number of disks,
the scaling between the servers was not as good as the other benchmarks. The systems were mostly
bottlenecked waiting on the disk, prohibiting a large amount of scaling. This bottleneck created an inverse
relationship between SysBench and LoadSim results: as SysBench scores increased, LoadSim scores dropped
and vice versa.

For testing we used 100 Microsoft Exchange mailboxes; all of the servers could handle the load while performing
other tasks. However, as Figure 6 shows, the Quad-Core Intel Xeon processor X3350-based server handled the
load better than the Intel Pentium Dual-core processor E2160-based server and the Quad-Core AMD Opteron
processor 1356-based server. The Quad-Core Intel Xeon processor X3220-based server handled the load better
than all three other servers. The Quad-Core Intel Xeon processor X3220-based server’s faster response time is
most likely due to the aforementioned disk bottleneck as the Quad-Core Intel Xeon processor X3350-based
server wins SysBench by a large margin.

Median Median : Med!an 95th percent.ile
Server 50th 95th Median (relative to Intel Pentium
percentile | percentile mean g;':"s':_‘t’;:si;?::fvse‘:;
lpr:'t(;eclzepszgt:uErg 1%%?:;:2;% server 116 208 126 100%
Srlcj)?:g-scszg:e‘l QQAGE)bgspet?irggrver 122 288 153 62%
X3z20-based sorver o | 99 162 105 122%
e | | w

Figure 6: Median LoadSim results for the four servers. Lower numbers are better.

SysBench results

For testing, we created a script so each system would perform as many transactions as possible in a given time.
The script processed 10,000 transactions as quickly as possible and then started over again. The output shows
the completion time in seconds for each group of 10,000 transactions. We calculated the transactions per second
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by using the following formula:

total transactions

time in seconds

= transactions per second

Figure 7 shows the median SysBench results and processor utilization for the four test servers. Worth noting, the
Quad-Core Intel Xeon processor X3350-based server, the Quad-Core Intel Xeon processor X3220-based server,
and the Quad-Core AMD Opteron processor 1356-based server all performed more transactions per second with
less processor utilization that the Intel Pentium Dual-core processor E2160-based server. This means all three

systems had resources available to perform additional tasks.

Transactions per
Completion . . second (relative to
. Transactions | Transactions .
Server time Intel Pentium
completed per second
(seconds) Dual-core processor
E2160-based server)
Intel Pentium Dual-core . o
processor E2160-based server 30:00 133,701 74.3 100%
Quad-Core AMD Opteron ) o
processor 1356-based server 30:00 195,625 108.7 146%
Quad-Core Intel Xeon ) o
processor X3220-based server 30:00 194,004 107.8 145%
Quad-Core Intel Xeon . o
processor X3350-based server 30:00 383,328 213.0 287%

Figure 7: Median SysBench results for the four servers. Higher numbers are better.

Test methodology

Figure 8 summarizes some key aspects of the configurations of the four server systems; Appendix A provides
detailed configuration information.

Intel Pentium

Quad-Core Intel

Quad-Core Intel

Quad-Core AMD

PRO/1000 MT

PRO/1000 MT

MT

Server Dual-core Xeon processor Xeon processor Opteron 1356
processor E2160- X3220-based X3350-based processor-based
based server server server server
(Pé?_lcze)ssm frequency 1.8 GHz 2.4 GHz 2.66 GHz 2.3 GHz
2,000 MHz
System bus 800 MHz 1,066 MHz 1,333 MHz HyperTransport
Technology
Dual/Quad-Core
DrOCEsSOrs Dual Quad Quad Quad
Motherboard Intel S3000AH Intel S3000AH Intel S3210SH Tyan S2925G2NR
Chipset Intel 3000 Chipset | Intel 3000 Chipset | Intel 3210 Chipset | NVIDIA n3400B
Kingston Kingston Kingston Kingston
RAM KVR667D2E5K2/1 | KVR667D2E5/1G | KVR800D2E5K2/2 | KVR800D2E5K2/2
G2x512MB 2x1024 MB G 2x 1024 MB G 2x1024 MB
SDRAM SDRAM SDRAM SDRAM
Hard drive Samsung Samsung Samsung Samsung
SP2004C SP2004C SP2004C SP2004C
Intel PRO/1000 Intel PRO/1000
NICs PM and Intel PM and Intel Intel PRO/1000 NVIDIA nForce

Network Controller

Figure 8: Key aspects of the server configurations.
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Intel configured and provided all four servers.

We began our testing by installing a fresh copy of Microsoft* Windows* Server 2003 R2, Enterprise Edition
Service Pack 2 on each server. We followed this process for each installation:

Assign a computer name of “Server”.

For the licensing mode, use the default setting of five concurrent connections.

Enter a password for the administrator log on.

Select Eastern Time Zone.

Use typical settings for the Network installation.

Use “Testbed” for the workgroup.

oAM=

We applied the following updates from the Microsoft Windows Update site:
e Windows Server 2003 Cumulative Security Update for Internet Explorer 7 for Windows Server 2003
(KB937143)
¢ Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB936021)
e Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB938127)
e Windows Update Windows Server 2003 Cumulative Security Update for Internet Explorer 6 for Windows
Server 2003 (KB937143)
e Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB921503)
¢ Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB936782)
e Windows Update Windows Server 2003 Windows Malicious Software Removal Tool - August 2007
(KB890830)
e Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB926122)
Windows Update Windows Server 2003 Security Update for Microsoft .NET Framework, Version 1.1
Service Pack 1 (KB933854)
Windows Update Windows Server 2003 Security Update for Windows Media Player 6.4 (KB925398)
Windows Update Windows Server 2003 Update for Windows Server 2003 (KB936357)
Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB935839)
Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB935840)
Windows Update Windows Server 2003 Cumulative Security Update for Outlook Express for Windows
Server 2003 (KB929123)
Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB924667)
Windows Update Windows Server 2003 Update for Windows Server 2003 (KB927891)
Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB932168)
Windows Update Windows Server 2003 Windows Internet Explorer 7.0 for Windows Server 2003
Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB931784)
Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB930178)
Windows Update Windows Server 2003 Security Update for Windows Server 2003 (KB925902)
Windows Update Windows Server 2003 Update for Windows Server 2003 Service Pack 2 (KB931836)

We updated the X3220 and X3350-based systems as little as possible to make them comparable with the E2160-
based system from August. However, we had to update the BIOS and chipset drivers to make the two new
systems work properly. We also had to update the RAID controller drivers in order to allow the Windows
installation to properly identify the RAID array on the X3220 and X3350-based systems. We did not, however,
update Windows or any other drivers past the August date of the low-end system.

Installing and configuring the mail server

To set up this server, we had to install several additional software components. The following subsections detail
the necessary installation processes. Before following these instructions, make sure to statically assign an IP
address for the server under test, and then plug that port into another system or router. This allows the server to
correctly make the domain server.

Installing the domain controller
1. Select Start->Administrative Tools->Manage Your Server.
2. Click Add or remove a role.
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15.

16.
17.
18.
19.
20.

At the Configure Your Server window, click Next.

At the Configuration and Options screen, select Custom Configuration, and click Next.

At the Server Role screen, select Domain Controller, and click Next.

At the Summary of Selections screen, click Next.

At the Welcome pop-up window, click Next.

At the Operating System Compatibility screen, click Next.

For the Domain Controller Type, leave the default option (Domain controller for a new domain), and click
Next.

. At the Create New Domain screen, leave the default (Domain in a new forest), and click Next.

. At the Install or Configure DNS window, select No, and click Next.

. At the New Domain Name screen, type a domain name (loadsim. com), and click Next.

. At the NetBIOS Domain Name screen, enter a NETBIOS domain name (1oadsim), and click Next.
. Click Next through the following screens: Database and Log Folders, Shared System Volume, and

Permissions. Doing so accepts the default options for each of those screens.

At the Directory Services Restore Mode Administrative Password screen, enter a password (password),
and click Next.

When the installation software prompts you to do so, insert the OS CD, and click OK.

At the Completing the Active Directory Installation Wizard screen, click Finish.

When the system prompts you to reboot the server, click Restart Now.

After the server reboots, log in to the system.

At the This Server is Now a Domain Controller window, click Finish.

Installing Internet Information Services 6.0

COENO>ORA~ON =

10
11.

Select Start->Control Panel>Add or Remove Programs.

Click Add/Remove Windows Components.

Select Application Servers, and click Details.

Click ASP.NET, and make sure a check appears in the check box.
Select Internet Information Services (IIS), and click Details.

Click NNTP Services and SMTP Services, make sure a check appears in both check boxes, and click OK.
Click OK to close the Application Server window.

At the Windows Components Wizard, click Next to begin the installation.
When the system prompts you to do so, insert the OS CD, and click OK.
At the Completing the Windows Components Wizard window, click Finish.
Close the Add or Remove Programs window.

Installing Exchange Server 2003

1.

Nook~ON

Insert the Microsoft Exchange Server 2003 CD. The CD should automatically launch the installation
software.

Select Exchange Server Enterprise Edition.

Run the Setup application.

Click the Exchange Deployment Tools link.

Click the Deploy the first Exchange 2003 Server link.

Click the New Exchange 2003 Installation link.

Click the Run ForestPrep now link.

a. When the compatibility issue notice appears, click Continue, and check Don'’t display this message
again.

At the Welcome screen, click Next.

Accept the End User License Agreement, and click Next.

At Component Selection Screen, keep the defaults, and click Next.

Leave the default account information, and click Next.

Installation should start. (This process may take a while to complete.)

f.  When the installation completes, click Finish.

Return to the Exchange Server Deployment Tools screen, and click the Run DomainPrep now link.
a. Atthe Welcome screen, click Next.

b. Accept the End User License Agreement, and click Next.

c. At Component Selection Screen, keep the defaults, and click Next.

d. At the insecure domain notice, click OK.

cooo
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e. When the installation completes, click Finish.
9. Return to the Exchange Server Deployment Tools screen, and click Run Setup Now.
a. Atthe Welcome screen, click Next.
b. Accept the End User License Agreement, and click Next.
c. Atthe Component Selection screen, the action for Microsoft Exchange should by default be Typical. If
it is not, use the drop-down box to set it to Typical.
Click Next.
For the Installation Type, select Create new Exchange Organization, and click Next.
Enter loadsim as the Organization Name, and click Next.
Accept the Microsoft Exchange Server Licensing Agreement, and click Next.
Review the installation summary, and click Next.
The installation should start. (This process may take a while to complete.)
When the installation completes, click Finish.
10. Close the Exchange Server Deployment Tools window.
11. Install Microsoft Exchange Server 2003 Service Pack 2.
Insert the SP2 CD, and double-click setup exe.
Accept the default location to extract the file, and click OK.
After the extraction finishes, open Windows Explorer, and browse to the update.exe executable.
At the Welcome screen, click Next.
Select | agree to accept the License Agreement, and click Next.
At the Component Selection window, leave the default option (Update), and click Next.
Verify the installation Summary, and click Next.
When the installation completes, click Finish.
12. Select Start>All Programs—->Microsoft Exchange-> System Manager.
13. In the left window pane, expand Servers and MailServer so the First Storage Group is visible.
14. Right-click First Storage Group, and select Properties.
15. Check the Enable circular logging box.
16. Click Apply.
17. Right-click Mailbox Store under First Storage Group, and select Properties.
18. Select the Database tab.
19. Next to Maintenance interval, click Customize.
20. Remove all blue from the boxes so the system will not perform maintenance, and click OK.

T Taemoea
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Installing and configuring the Web server

Deploying WebBench data
WebBench includes data that must reside on the server and that the Web server must use. We loaded that data
and set the Web server to use it with the following procedure:

1. Copy the file wbtree.exe from the WebBench CD to the wwwroot directory on the server under test. (The
wbtree.exe file is on the WebBench CD at \wb50\workload).
On the server, execute the wbtree.exe file. This program copies the WebBench workload to the server.
In the wwwroot folder on the server, create a new folder with the name CGI-BIN.
Copy the file simisapi.dll to the CGI-BIN folder.
Click Start->Programs—->Administrative Tools->Computer Management to open the management console.
Go to Services and Application—>Internet Information Services—> Default Web Site>CGI-BIN, and right-
click to bring up a menu. Select Properties.
7. Go to the Directory Tab, and Set Execute Permissions to Scripts and Executables.
8. When the IIS WWW Configuration popup window displays, click Yes.
9. Close the Computer Management window.

O hAWN

Configuring Internet Information Services (IIS)

We configured the Windows Internet Information Services Web server as follows:
Open Computer Management.

Go to Services and Application->Internet Information Services.
Right-click to bring up a menu, and select Properties.

Click MIME Types.

In the MIME Types window, click New.

agrON =
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In the Extension field, type *.

In the MIME type field, type application/octet-stream, and click OK.

Click OK to exit the MIME Types window.

Click OK to exit the Internet Information Services (1IS) Manager Properties window.

. In the Computer Management window, go to Web Sites—>Default Web Site under Internet Information

Services, right-click it to bring up a menu, and select Properties.

. Select the Home Directory tab.

. Check the following boxes: Script source access, Read, Write, and Directory browsing.

. Uncheck the following boxes: Log visits and Index this resource.

. In the Execute permissions field, select Scripts and Executables.

. Click Apply.

. Select the Web Site tab.

. Uncheck Enable Logging.

. Click OK to close the Default Web Site Properties window.

. In the Computer Management window, go to the Web Service Extensions item under Internet Information

Services.

. In the right panel, highlight All Unknown ISAPI Extensions, and click Allow.
. Acknowledge the 1IS Manager warning that appears by clicking Yes.

. In the right panel, highlight All Unknown CGI Extensions, and click Allow.

. Acknowledge the 1IS Manager warning that appears by clicking Yes.

. Close the Computer Management window.

Installing certificate services
Because WebBench includes tests that involve security, we installed Windows Certificate Services as follows:

Nogoh~wbh =

8.
9.
10.
11.
12.
13.

Click Start->Control Panel->Add/Remove Programs.

Select Add/Remove Windows Components.

Check the box beside Certificate Services.

Accept the notice that the server’'s name cannot be changed after you install this service.

Click Next.

Select Stand Alone Root CA, and click Next.

On the CA Identifying Information window, enter the server name in the Common name for this CA field,
and click Next.

Leave the default Certificate Database Settings as they are, and click Next.

At the prompt asking if you want to enable Active Server Pages (ASP) in IIS, click Yes.

At the prompt that explains that Internet information Services will be temporarily stopped, click Yes.
Click Next.

Click Finish.

Click Close.

Setting up Internet Explorer
We had to set up Internet Explorer on the server as follows to be able to get the necessary certificates:

1.
2.
3.
4.
5.

Click the Internet Explorer icon on the Quick Launch toolbar.
Select the Tools—>Internet Options menu item.

On the Connections tab, click LAN Settings.

Check Automatically detect settings, and click OK.

Click OK to exit the Internet Options window.

Requesting the server certificate
We had to set up Internet Explorer on the server as follows to be able to get the necessary certificates:

1.

aoRrwd

Open Internet Explorer and enter the following website, http://server/certsrv. This should bring up a page
entitled Microsoft Certificate Services — server.

Click Request a Certificate.

Click Advanced Certificate Request.

Click Create and submit a certificate request to this CA.

Fill out the appropriate Identifying Information details on the Advanced Certificate Request.

e Name: Performance

e Company: PT

Principled Technologies, Inc.: Performance of four Intel®- and AMD-based SMB servers 10
using WebBench, LoadSim, and SysBench



o Type of certificate needed: Server Authentication Certificate
e Key Options:
o CSP: Microsoft Base Cryptographic Provider v1.0
o Usage: Exchange and Signature — select both
o Key size: 512
o Check Automatic key container name
o Check Store certificate in the local computer certificate store
e Additional Options:
o Hash Algorithm: SHA-1
e Otherwise use default
6. Click Submit.
7. Acknowledge the “Potential Scripting Violation” by clicking Yes.
A page informing you that there is a Certificate Pending should appear.

Issuing the server certificate
Next we had to issue a server certificate as follows:
1. Select Start->Programs->Administrative Tools—> Certification Authority.
2. Click the server's name.
3. Select Pending Requests.
4. Right-click Pending Requests, select All Tasks, and select Issue.
5. Close Certification Authority.

Installing the server certificate

We then installed the server certificate as follows:

Open Internet Explorer.

Go to the page http://server/certsrv again.

Click the View the status of a pending certificate link.

Click the Server Authentication Certificate link.

Click the Install this Certificate link.

Acknowledge the Potential Scripting Violation warning by clicking OK.
A message notes that a certificate has been successfully installed.
Close Internet Explorer.

N>R~ ®LN =

Setting IIS to use the server certificate
We then set IS to use the server certificate as follows:

Select Services and Applications—> Internet Information Services>Web Sites.
Right-click the Default Web site, and select Properties.

Select the Directory Security tab, and click Server Certificate.

When the Welcome to the Web Server Certificate Wizard window appears, click Next.
Select Assign an Existing Certificate, and click Next.

Select your server certificate (Intended Purpose: Server Authentication), and click Next.
Accept the default SSL port (443) in the next window that appears, and click Next.

. On the Certificate Summary screen, click Next.

10. Click Finish.

Creating SSL Communication
Finally, we had to enable SSL communication as follows:

©CoOoNO>ORA®N =

Expand the Default Web site.

Expand wbtree.

Right-click Wbssl, and select properties.
Select the Directory Security tab.

Under Secure communications, click Edit.
Check Require secure channel (SSL).
Check Require 128-bit encryption.

Click OK.

©COoNO>ORA®LN =

Go to Computer management->Services and Application—>Internet Information Services.

Click Start=>Programs—>Administrative Tools->Computer Management to open the management console.
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10.

Click OK.

We then set the following operating system tuning parameters to reflect the WebBench recommendation in the
Microsoft performance Tuning Guidelines for Windows Server 2003 document, which is available on Microsoft's
Web site. When creating the following parameters, ensure that they are DWORD files, with decimal coding (rather
than hexadecimal):

HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters\MaxCachesFileSize to 1048576
HKLM\System\CurrentControlSet\Services\HT TP\Parameters\UriMaxUriBytes to 1048576
HKLM\System\CurrentControlSet\Control\FileSystem\NtfsDisableLastAccess to 1
HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\MaxHashTableSize to 65535

Installing and configuring the database server

Installing Microsoft Internet Information Server

NGO A~LON =

Select Start->Administrative Tools>Manage Your Server.

Select Add or remove a role.

At the preliminary steps screen, click Next.

At the Server Role screen, select Application Server, and click Next.

At the Summary of Selections screen, click Next.

When the installation software prompts you to do so, insert the OS CD, and click OK.
When the installation completes, click Finish.

Close the Manage Your Server window.

Installing Microsoft SQL Server 2005

SOoNooORALON =

Insert the SQL Server 2005 CD into the server.

Click the Server Components link under the Install section to begin the installation.

Accept the license agreement, and click Next.

Click Next to install the prerequisites.

After the Prerequisites complete installing screen, click Next.

At the Welcome screen, click Next.

At the System Configuration Check, assuming everything has a status of success, click Next.
Enter the registration information, and click Next.

At the Components to Install screen, select SQL Server Database Services, then click Advanced.

. Instruct the software to install both the Database Services and Client Components by clicking the drop-

down arrow on both and selecting Entire feature will be installed on local hard drive.

. Click Next to start the installation.

. For Instance Name, leave the default option, and click Next.

. At the Service Account screen, select Use the built-in system account (Local account), and click Next.

. Keep the default option for Authentication Mode, and click Next.

. For Collation Settings, leave the defaults, and click Next.

. Accept the default Error and Usage Report Settings, and click Next.

. At the Ready to Install screen, click Install to begin the installation.

. When the installation software prompts you to do so, insert Microsoft SQL Server 2005 disk 2, and click

OK.

. When the setup process completes, click Next.
. Click Finish to complete the installation.

Creating the test database and generating data

1.
2.

NGO AW

Select Start->Microsoft SQL Server 2005->SQL Server Management Studio.

In the Connect to Server window, use the drop-down menu next to Server name to select Browse for
more.

In the Browse for Server window, select the Network Servers tab, and wait for it to retrieve data.
When Database Engine appears, expand the menu, select Server, and click OK.

At the Connect to Server window, the server name should be present.

Click Connect to connect to the server.

Right-click the Database folder in the left window, and select New Database from the pop-up menu.
In the Database name field, type sbtest, and click OK.
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9.

10.
11.

12.
13.
14.

15.
16.

17.
18.

Open a command prompt by selecting Start>Run, type cmd, and click OK.

In the command prompt, type cd to change to C:\.

To prepare the database, type vsysbench.exe --test=oltp --oltp-table-size=100000
prepare, and press Enter.

When the command finishes, the C:\ prompt appears.

Type exit, and press Enter to close the command prompt.

In SQL Server 2005 Management Studio, stop the database service by right-clicking server in the left
window pane, and then select Stop from the drop-down menu.

Using Windows Explorer, create the folder C:\backup.

With Windows Explorer, copy all sbtest files from C:\Program File\Microsoft SQL
Server\MSSQL.1\MSSQL\Data\ to c:\sysbench_backup. (You should see two files: sbtest.mdf and
sbtest_log.Idf.)

Close Windows Explorer once the copy completes.

Restart the database service using SQL Server 2005 Management Studio by right-clicking server and
selecting start.

Installing the mail test client
Each mail server requires one physical test client system. We used the following process to set up each such

system.

Install Microsoft Windows Server 2003 R2 Enterprise Edition. Use mailclient as the system name.
Install Windows Server 2003 Service Pack 2 with the default settings.

Open the Network Connections window by right-clicking My Network Places and selecting Properties.
Right-click the network connection, and click Properties.

Highlight TCP/IP, and select Properties.

Select Use the following IP address, and enter the correct information.

Click OK to close the two Properties windows.

Right-click My Computer, and select Properties.

Click the Computer Name tab.

. Click Change.

. Select Domain in the member of section, and type the domain test . com into the text box.

. In the pop-up window, enter administrator for user name and password for password, and click OK.
. At the Welcome to the domain screen, click OK.

. When the warning that you must restart dialog appears, click OK.

. Click OK to close the System Properties window.

. Click Yes to the pop-up message to restart the computer.

. Login to the domain by using administrator and password.

. Install Microsoft Outlook 2003 with the default settings. (Outlook 2003 doesn’t require any configuration.)
. Install LoadSim 2003 by double-clicking the loadsim.msi installation file. Accept all defaults.

. Open LoadSim 2003, and make sure no error messages appeatr.

Conflgurlng LoadSim 2003

Start LoadSim by clicking Start Menu—->All Programs—>Exchange LoadSim->LoadSim 2003.
From the LoadSim menu bar, select Configuration->Topology Properties.

Click the Servers tab.

In the left pane, click the + next to the name of this server.

In the left pane, select the First Storage Group.

In the right pane, set the number of users to 100.

Select the Security and Credentials tab.

Leave the Credentials choice set to Login to users using the account LoadSim is running on.
In the password portion of the tab, type Passwordi, and click OK.

. From the LoadSim menu bar, select File>Save As.
. Save a backup copy of the simulation file as C:\loadsim.sim.
. From the LoadSim menu bar, select Run->Create Topology, and wait until the Creating Users and

Creating DLs tasks complete.

. From the LoadSim menu bar, select Run—>Initialize Test.
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14. When a dialog box appears with the question Do you want to initialize Public Folders from this client
machine?, click Yes.

15. The run is complete when the bottom left corner of the LoadSim window shows Status: Idle. This task
typically takes 2 to 3 hours to complete.

Back up the mail database

Once you’ve set up LoadSim and created its initial mail database, you need to back up that database so you can

have clean copies for each test. Use this process to back up that database.

Select Start->All Programs->Microsoft Exchange—> System Manager in the mail server.

In the left pane, expand Servers until First Storage Group appears highlighted.

In the right pane, right-click Mailbox Store, and select Dismount Store from the menu.

Click Yes on the Do you want to continue? pop-up message. When you've dismounted the Mailbox Store,

a red arrow appears in the window pane.

Right-click Public Folder Store, and select Dismount Store from the menu.

Click Yes on the Do you want to continue? pop-up message. The red arrow appears when you've

dismounted the Public Folder Store.

7. Using Windows Explorer, create a new folder C:\backup.

8. With Windows Explorer, copy all files from C:\Program Files\Exchsrvr\mdbdata to C:\backup. This
process may take several minutes.

9. Close Windows Explorer.

10. In Exchange System Manager, right-click Mailbox Store, and select Mount Store from the menu.

11. Click OK on the pop-up message, The store was successfully mounted.

12. Right-click Public Folder Store, and select Mount Store from the menu.

13. Click OK on the pop-up message, The store was successfully mounted.

14. Close Exchange System Manager.

prON=
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Network test bed configuration

To generate the workload, we used a network with 22 client PCs. Each PC contained an Intel Pentium 4 3.0GHz
with HT Technology processor, 512MB of system memory, a 40GB hard drive, and a Gigabit Ethernet network
adapter. We configured each client with Windows XP Professional with Service Pack 2 and all critical updates
available as of June 7, 2007.

We split 20 of the clients into two segments, or subnets, of 10 clients each. We connected each segment to the
server under test via one NETGEAR* GS724T Gigabit Smart Switch*. To balance the load on the server and to
prevent a network throughput bottleneck, we connected each segment to a separate network port. We used the
remaining two clients for the WebBench controller and LoadSim client. Figure 9 illustrates the test bed
configuration.
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Figure 9: lllustration of the test network we used to generate the WebBench workload.
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Appendix A — Test system configuration information

This appendix provides detailed configuration information about each of the test server systems, which we list in

alphabetical order.

65nm Intel 65nm Quad- 45nm Quad- 65nm Quad-
Pentium Dual- | Core Intel Xeon | Core Intel Xeon Core AMD
Servers core processor processor processor Opteron 1356
E2160-based X3220-based X3350-based processor-
server server server based server
General
Number of processor
1 1 1 1
packages
Number of cores per 2 4 4 4
processor package
Number of hardware
1 1 1 1
threads per core
System power . Always on Always on Always on Always on
management policy
CPU
Vendor Intel Intel Intel AMD
Name Intel Pentium Intel Xeon Intel Xeon AMD Opteron
E2160 X3220 X3350 1356
Stepping 2 7 6 3
Socket type Socket 775 LGA | Socket 775 LGA | Socket 775 LGA | Socket AM2+
Core frequency (GHz) 1.8 GHz 2.4 GHz 2.66 GHz 2.3 GHz
Front-side bus frequency 2,000 MHz
(MHz) 800 MHz 1,066 MHz 1,333 MHz HyperTransport
Technology
32 KB + 32 KB 32 KB + 32 KB 32 KB + 32 KB 64 KB + 64 KB
L1 cache
(per core) (per core) (per core) (per core)
12MB (2x6 2MB (4 x512
L2 cache 1 MB (shared) 8 MB (2 x 4 MB) MB) KB)
L3 cache NA NA NA 2 MB (shared)
Platform
Vendor and model Intel Intel Intel Tyan
number
Motherboard model S3000AH S3000AH $3210SH $2925G2NR
Motherboard chipset Intel 3000 Intel 3000 Intel 3210 NVIDIA n3400B
Motherboard revision 00 00 00 AD
number
Motherboard serial AZAX71300522 | AZAX71200495 | QSSH74600983 | YO3J-PO02SN
Intel Corporation | Intel Corporation | Intel Corporation American
BIOS name and version S3000.86B.02.0 | S3000.86B.02.0 | S3200X38.86B. Megatrends Inc
0.0043.0618200 | 0.0043.0618200 | 00.00.0033.1121 V2 %0 '
70639 70639 20071101 '
. Configure SATA | Configure SATA
BIOS settings Default Default as RAID 1 as RAID 1
Chipset INF driver Intel 8.1.1.1010 | Intel 8.1.1.1010 | Intel 8.3.1.1009 | NVIDIA v6.87
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Controller driver

Intel 7.6.0.1011

Intel 7.6.0.1011

9.24.1018.2007

65nm Intel 65nm Quad- 45nm Quad- 65nm Quad-
Pentium Dual- | Core Intel Xeon | Core Intel Xeon Core AMD
Servers core processor processor processor Opteron 1356
E2160-based X3220-based X3350-based processor-
server server server based server
Memory module(s)
Vendor and model Kingston Kingston Kingston Kingston
number KVR667D2E5K2 | KVR667D2E5 KVR800D2E5K2 | KVR800D2E5K2
1G 1G 12G 12G
PC2-5300 DDR2 | PC2-5300 DDR2 | PC2-6400 DDR2 | PC2-6400 DDR2
Type SDRAM ECC SDRAM ECC SDRAM ECC SDRAM ECC
unbuffered unbuffered unbuffered unbuffered
Speed (MHz) 667 MHz 667 MHz 800 MHz 800 MHz
Speed in the system 667 MHz 667 MHz 800 MHz 800 MHz
currently running @ MHz)
Timing/latency (tCL-
{RCD-iRP-tRASmin) 5-5-5-15 5-5-5-15 5-5-5-16 5-5-5-16
Size 1,024 MB 2,048 MB 2,048 MB 2,048 MB
Number of RAM modules | 2 x 512 MB 2x1,024 MB 2x1,024 MB 2x1,024 MB
Chip organization Single-sided Double-sided Double-sided Double-sided
Channel Dual Dual Dual Dual
Hard disk
Vendor and model Samsung Samsung Samsung Samsung
number SP2004C SP2004C SP2004C SP2004C
Number of disks in 2 2 2 2
system
Size 200 GB 200 GB 200 GB 200 GB
Buffer size 8 MB 8 MB 8 MB 8 MB
RPM 7,200 7,200 7,200 7,200
Type SATA SATA SATA SATA
Controller Intel 82801GB Intel 82801GB Intel Embedded | NVIDIA nForce
(ICH7) (ICH7) Server RAID RAID
LSI NVIDIA

5.10.2600.687

Operating system

Microsoft Microsoft Microsoft Microsoft
Windows Server | Windows Server | Windows Server | Windows Server

Name 2003 R2, 2003 R2, 2003 R2, 2003 R2,
Enterprise Enterprise Enterprise Enterprise
Edition Edition Edition Edition

Build number 3790 3790 3790 3790

Service Pack SP2 SP2 SP2 SP2

Microsoft Windows 08/09/07 08/09/07 08/09/07 08/09/07

update date

File system NTFS NTFS NTFS NTFS
ACPI ACPI ACPI ACPI

Kernel Multiprocessor Multiprocessor Multiprocessor Multiprocessor
PC PC PC PC

Language English English English English

Microsoft DirectX version | 9.0c 9.0c 9.0c 9.0c
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USB 2.0)

65nm Intel 65nm Quad- 45nm Quad- 65nm Quad-
Pentium Dual- | Core Intel Xeon | Core Intel Xeon Core AMD
Servers core processor processor processor Opteron 1356
E2160-based X3220-based X3350-based processor-
server server server based server
Graphics
Vendor and model ATI ES1000 ATI ES1000 Matrox G200e | XGI Volari Z7
Chipset ATI ES1000 ATI ES1000 Matrox G200 XGI Volari Z7
BK-ATI BK-ATI
BIOS version VERO008.005.02 | VER008.005.02 | 3.8.033 SL 1.07.08
3.000 3.000
Type Integrated Integrated Integrated Integrated
Memory size 16 MB 16 MB 8 MB 16 MB
Resolution 1,024 x 768 1,024 x 768 1,024 x 768 1,024 x 768
. XGl
Driver ATI18.24.3.0 ATI18.24.3.0 Matrox 5.95.6.9 6.14.10.1080
Network card/
subsystem
2 x NVIDIA
Vendor and model Intel PRO/1000 Intel PRO/1000 Intel PRO/1000 nForce
number PM & Intel PM & Intel MT Networking
PRO/1000 MT PRO/1000 MT
Controller
Type Integrated Integrated Integrated Integrated
Intel PRO/1000 Intel PRO/1000
. PM v9.7.34.0 PM v9.7.34.0 Intel PRO/1000
Driver Intel PRO/1000 | Intel PRO/1000 | MT v8.8.1.0 NVIDIA 65.31.0
MT v8.8.1.0 MT v8.8.1.0
2 x Intel
" Intel PRO/1000 Intel PRO/1000 Intel PRO/1000
Additional network PT Dual Port | PROMMO0OPT  or'ny i Port | PT Dual Port
adapter Dual Port Server
Server Adapter Adapter Server Adapter Server Adapter
Driver Intel 9.9.13.0 Intel 9.9.13.0 Intel 9.9.13.0 Intel 9.9.13.0
Optical drive
Vendor and model Sony Sony Asus DVD-
number CRX230ED CRX230ED E616A3T SCSI | I extor PX-712A
Type CD-RW CD-RW DVD-ROM DVD-RW
Interface IDE IDE SATA SATA
Dual/single layer Single layer Single layer Dual layer Dual layer
USB ports
Number of ports 4 4 6 6
Type of ports (USB 1.1, | ;qp 9 g USB 2.0 USB 2.0 USB 2.0

Figure 10: Detailed system configuration information for the test servers.
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Appendix B — Price information

Figure 11 presents the price information for the test systems as of August 12, 2008.

System

Intel Pentium
Dual-core
processor E2160-

Quad-Core Intel
Xeon processor
X3220-based

Quad-Core Intel
Xeon processor
X3350-based

Quad-Core AMD
Opteron 1356
processor-based

based server server server server

Price as of August 12, 2008
Motherboard’ $209.99 $209.99 $239.99 $199.99
Processor’ 67.99 219.99 349.99 399.99
Hard drives? x 2 190.00 190.00 190.00 190.00

(95.00 each) (95.00 each) (95.00 each) (95.00 each)
Memory' 25.19 42.58 43.99 43.99
Cooler Master Elite 39.99 39.99 39.99 39.99
330 case'
Total price® $533.16 $702.55 $863.96 $873.96

Figure 11: Price information for the test systems.

Notes

! Price from www.newegg.com.
2 Price from www.serversupply.com
® Cost does not include shipping or tax.
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