MULTIMEDIA REDIRECTION: EFFECT ON SERVER CAPACITY
FOR CITRIX XENDESKTOP VIRTUAL DESKTOPS

Ran 43% more virtual desktops
with multimedia redirection enabled
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*versus the same Intel” Xeon’ Processor X5570-powered server
running virtual desktops with multimedia redirection disabled

OUR FINDINGS

Organizations considering deploying virtual desktops as part
of a Virtual Desktop Infrastructure (VDI) benefit by best
utilizing the server and client resources that are available for
deployment. VDI deployments are often associated with
higher datacenter build-out costs due to the infrastructure
required to deliver virtual desktops to the targeted user
population. An IT department can save money by reducing
the number of servers required to support these users.
Multimedia redirection (MMR) technology can increase the
number of virtual desktops a server can support by offloading
the execution of multimedia content to a capable client.
Principled Technologies put this methodology to the test. In
our tests, a server running VDI sessions using Citrix®
XenDesktop™ 4 and HDX™ (High Definition User Experience),
the Citrix MMR protocol, supported 43.5 percent more virtual
desktops running with MMR turned on. Thus, enabling MMR

is an effective method for reducing server load.

OUR PROCESS

To determine how enabling MMR affected our server’s virtual
desktop capacity, we used the Login Consultants Virtual
Session Indexer (Login VSI) Beta3 benchmark. Login VSI
consists of several workloads that perform a range of tasks to
simulate a typical office user. The results show the maximum
number of virtual desktops a server can support for a
maximum response time of a particular task. In addition to
the performance scores from the Login VSI benchmark, we
measured server and client’ CPU utilization and network

bandwidth.

! See our companion report at
http://www.principledtechnologies.com/clients/reports/Intel/HDX_client pe
rformance 1010.pdf.
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PROJECT OVERVIEW

This report highlights the server capacity impacts and benefits of using multimedia redirection with
Citrix XenDesktop 4. We used Login VSI’s multimedia workload in our tests because its workload reflects what
a typical office user would run on his or her system.

For consistency of performance benchmarking, we added virtual desktops until the server CPU
utilization reached saturation at 100 percent. Please note that we report the maximum number of virtual
desktops a server can support with the specified response times. The actual number of users supported on the

server may be less for a typical production deployment.
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Figure 1: The number of Citrix XenDesktop virtual desktops the test server supported with
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when running with MMR disabled.
WHAT WE TESTED

About multimedia redirection

Multimedia redirection is a technology that lets physical clients use their local CPUs and graphics cards
to format and play media content. Without MMR, this processing demand is on the hosting server, causing the
server to utilize more resources per virtual desktop. Enabling MMR conserves server resources, allowing a

given server to support more virtual desktops than it could without MMR running. In order to enable MMR,
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the physical client must support MMR and have sufficient resources to decode and render the media content.

The user experience is greatly improved when using a more capable intelligent client.’

About Citrix XenDesktop

According to the Citrix Web site, XenDesktop provides a flexible computing experience for users while
helping organizations address key business priorities. Easy access to complete virtualized desktops,
applications, and data from any location, using any device enables more productive and mobile virtual work
styles and inspires innovation throughout the business. For more information on XenDesktop, see

http://www.citrix.com/virtualization/desktop/xendesktop.html.

About Login VSI
For testing, we used the Login Consultants Virtual Session Indexer Beta3 (Login VSI) workload. Login VSI

simulates a typical office user’s work behavior by opening common office-related applications. Specifically, the
multimedia workload of Login VSI opens and closes the following applications and runs their respective tasks:

e Microsoft ®Outlook®: Browsing a message

e Microsoft Word® (TimerDoc): Response timer initiation

e Internet Explorer® instance one: Maximizing, scrolling, and minimizing

e Internet Explorer instance two: Navigating a Web site, maximizing, and scrolling
e Adobe® Flash®: Viewing a movie trailer

e Windows® Media Player: Opening an mp3 file

e Microsoft Word (UserRead): Reading and typing text, and printing to PDF
e Bullzip: Generating a PDF

e Adobe Reader®: Reading a PDF

e Microsoft PowerPoint®: Watching a presentation and adding a slide

e Windows Media Player: Viewing a720p WMV file at full-screen

e 7-Zip: Saving a zipfile

Login VSI benchmarks these virtual desktop sessions to determine how scalable a particular virtualized
system is. Specifically, it benchmarks Terminal Server (TS), Virtual Desktop Infrastructure (VDI), and hypervisor
performance by loading a system with these simulated Windows-based Office user workloads. It reports a
Virtual Session Index (VSI) score as the maximum number of users the system supports while maintaining a
4,000-millisecond (4-second) response time. The workload begins by stressing a single virtual desktop and
then increases the number of virtual desktops by one at 1-minute increments. For testing, we had 90 virtual

desktops powered on and sitting idle before starting the Login VSI multimedia workload.

2 ) o ) ) )
See our companion report at http://www.principledtechnologies.com/clients/reports/Intel/HDX client performance 1010.pdf.
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For more information on Login VSI Beta3, see
http://www.loginconsultants.com/index.php?option=com content&task=view&id=390.

WHAT WE FOUND

To determine the impact of using MMR on a server running VDI sessions, we ran Login VS| on the same

server configured two ways: with MMR enabled and with MMR disabled. We found that enabling MMR
decreased server CPU utilization. We make comparisons of MMR enabled and MMR disabled at 35 virtual
desktops to show how both performed at lower user counts, not just at maximum user counts. Figure 2 shows
the network bandwidth and CPU utilization advantages with 35 users or virtual desktops. It is this reduction in

resource utilization that gives the server the headroom necessary to support more virtual sessions with MMR

enabled.

35 virtual desktops Multimedia redirection enabled Multimedia redirection disabled
MB/s 2.14 1.83

Percentage CPU utilization 50.91% 79.88%

Figure 2: MB/s and percentage CPU utilization with 35 virtual desktops running. Lower numbers are better.

We ran Login VSI while both enabling and disabling MMR to a total of 90 virtual desktops on the same

server. Figures 3 and 4 show

the network bandwidth and
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disabled flattens around 40 Figure 3: The network bandwidth in MB/s for each configuration at different virtual desktop
) o counts. Lower numbers are better.

virtual desktops. This is due

to the server’s CPU utilization reaching saturation and not be able to render and deliver the screen responses

to the users. One should note that this limit of 40 is less than the maximum 46 projected by Login VSI and

represents a more practical maximum limit with MMR disabled. The network bandwidth for the MMR enabled
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configuration continues to increase because the server has yet to reach saturation. This shows that enabling

MMR gives the server more headroom to support more virtual desktops.

Figure 4 shows the
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environment, a VDI server

would be run below saturation to provide ample headroom for variation in user workload. For a typical design
point of 75 percent server CPU utilization, as shown in Figure 4, the server can support 48 virtual desktops
with MMR enabled and can support 33 virtual desktops with MMR disabled. In this case, MMR improves the
server’s virtual desktop loading by 45 percent.
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Figure 5: The average response time for MMR enabled and MMR disable at different virtual

calculates results.
desktop counts. Lower numbers are better.
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The Login VSImax is based off the average response time, but it removes 2 percent from the minimum
and maximum response times before calculating the average. Therefore, the Login VSImax shown on this
graph is slightly higher than the 4-second acceptable response time.

One should also note that Login VSI results are based on average response time. Individual user
response may vary as indicated by the maximum response.

For corresponding results with Microsoft Windows Server® 2008 R2 with Remote Desktop Services,
please refer to
http://www.principledtechnologies.com/clients/reports/Intel/MMR effect VDI RDS 1010.pdf.

SUMMARY

Organizations deploying VDIs often worry about the cost of such deployments. By utilizing Citrix

XenDesktop 4 with HDX and enabling multimedia redirection, organizations can expect to purchase fewer
servers to handle the amount of virtual desktop users they have. In our tests, we found that enabling MMR
increased the amount of virtual desktops an Intel Xeon processor X5570-powered server running Citrix
XenDesktop 4 could support by over 43 percent. By delegating tasks to the client machine instead of the
server and lessening CPU utilization, MMR lessens server load and allows the organization more virtual

desktop users for each server.

HOW WE TESTED
Setting up DC1 (infrastructure server)
Installing Windows Server 2008 R2 Enterprise Edition

1. Boot the infrastructure server, and insert the Windows Server 2008 R2 installation DVD in the DVD-
ROM drive.

2. Atthe Language Selection Screen, click Next.

3. Click Install Now.

4. Select Windows Server 2008 Enterprise Edition R2 (Full Installation), and click Next.

5. Click the I accept the license terms check box, and click Next.

6. Click Custom.

7. Click Drive options (advanced).

8. Ensure you select the proper drive, and click New.

9. Click Apply.

10. Click Next.

11. When the installation completes, open Server Manager-> Configuration—>Local Users and

Computers—> Users, select Administrator, and right-click the Administrator. Set Password to
Passwordl

12. Log out and log in as Administrator.

13. Open Server Manager.
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14. Select Change System Properties.

15. In the Systems Properties dialog box, rename the computer name to DC1
16. Reboot the system.

17. Set the password to Passwordl

18. At the Your password has been changed screen, click OK.

Installing system updates in Windows Server 2008 R2
Using the Windows Update feature, we installed the following updates:

e Security Update for Microsoft .NET Framework 3.5.1, Windows 7, and Windows Server 2008 R2 for
x64-based Systems (KB2416471)

e Update for Internet Explorer 8 for Windows Server 2008 R2 x64 Edition (KB2398632)

e Security Update for Windows Server 2008 R2 x64 Edition (KB2347290)

e Security Update for Windows Server 2008 R2 x64 Edition (KB981550)

e Security Update for .NET Framework 3.5.1 on Windows 7 and Windows Server 2008 R2 for x64-based
Systems (KB983590)

e Security Update for Windows Server 2008 R2 x64 Edition (KB2160329)

e Security Update for Windows Server 2008 R2 x64 Edition (KB2079403)

e Cumulative Security Update for Internet Explorer 8 for Windows Server 2008 R2 x64 Edition
(KB2183461)

e Security Update for Windows Server 2008 R2 x64 Edition (KB978886)

e Security Update for Windows Server 2008 R2 x64 Edition (KB981852)

e Windows Malicious Software Removal Tool x64 - September 2010 (KB890830)

e Update for Windows Server 2008 R2 x64 Edition (KB2158563)

e Security Update for Windows Server 2008 R2 x64 Edition (KB982799)

e Security Update for Windows Server 2008 R2 x64 Edition (KB980436)

e Security Update for Windows Server 2008 R2 x64 Edition (KB982214)

e Security Update for Windows Server 2008 R2 x64 Edition (KB2286198)

e Windows Malicious Software Removal Tool x64 - July 2010 (KB890830)

e Security Update for Windows Server 2008 R2 x64 Edition (KB2032276)

e Rules Update for Active Directory Domain Services Best Practice Analyzer for Windows Server 2008 R2
x64 Editions (KB980360)

e Microsoft .NET Framework 3.5 SP1 Update for Windows 7 and Windows Server 2008 R2 for x64-based
Systems (KB982526)

e Security Update for Windows Server 2008 R2 x64 Edition (KB977894)

e Cumulative Security Update for ActiveX Killbits for Windows Server 2008 R2 x64 Edition (KB980195)

e Cumulative Security Update for Internet Explorer 8 for Windows Server 2008 R2 x64 Edition
(KB982381)

e Update for Windows Server 2008 R2 x64 Edition (KB977074)

e Security Update for Windows Server 2008 R2 x64 Edition (KB979309)

e Security Update for Windows Server 2008 R2 x64 Edition (KB972270)

e Security Update for Windows Server 2008 R2 x64 Edition (KB980232)

e Security Update for Windows Server 2008 R2 x64 Edition (KB979683)

e Update for Windows Server 2008 R2 x64 Edition (KB976662)
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Windows Malicious Software Removal Tool x64 - June 2010 (KB890830)

Security Update for Windows Server 2008 R2 x64 Edition (KB974571)

Security Update for Windows Server 2008 R2 x64 Edition (KB979482)

Security Update for Windows Server 2008 R2 x64 Edition (KB979559)

Update for Best Practices Analyzer for Application Server for Windows Server 2008 R2 x64 Edition
(KB981392)

Update for Best Practices Analyzer for File Services for Windows Server 2008 R2 x64 Edition
(KB981111)

Security Update for Windows Server 2008 R2 x64 Edition (KB975560)

Microsoft .NET Framework 3.5 SP1 Security Update for Windows 7 and Windows Server 2008 R2 for
x64-based Systems (KB979916)

Update for Best Practices Analyzer for HYPER-V for Windows Server 2008 R2 x64 Edition (KB977238)
Security Update for Windows Server 2008 R2 x64 Edition (KB971468)

Microsoft .NET Framework 3.5 SP1 Update for Windows 7 and Windows Server 2008 R2 for x64-based
Systems (KB982526)

Update for Windows Server 2008 R2 x64 Edition (KB981793)

Update for Best Practices Analyzer for DHCP Server for Windows Server 2008 R2 x64 Edition
(KB977236)

Security Update for Windows Server 2008 R2 x64 Edition (KB980218)

Update for Windows Server 2008 R2 x64 Edition (KB982519)

Update for Best Practices Analyzer for Network Policy and Access Services for Windows Server 2008 R2
x64 Edition (NPAS) (KB977239)

Update for Windows Server 2008 R2 x64 Edition (KB974431)

Update for Windows Server 2008 R2 x64 Edition (KB980846)

Security Update for Windows Server 2008 R2 x64 Edition (KB978542)

Update for Windows Server 2008 R2 x64 Edition (KB978637)

Security Update for Windows Server 2008 R2 x64 Edition (KB978601)

Update for Best Practices Analyzer for Windows Server Update Services for Windows Server 2008 R2
x64 Edition (KB981390)

Update for Rights Management Services Client for Windows Server 2008 R2 x64 Edition (KB979099)
Update for Best Practices Analyzer for Active Directory Rights Management Services for Windows
Server 2008 R2 x64 Edition (KB981391)

Security Update for Windows Server 2008 R2 x64 Edition (KB981332)

Update for Windows Server 2008 R2 x64 Edition (KB980408)

Update for Internet Explorer 8 Compatibility View List for Windows Server 2008 R2 x64 Edition
(KB982632)

Security Update for Windows Server 2008 R2 x64 Edition (KB975467)

Setting up network configuration on DC1

1. Click Start>Run, and type ncpa.cpl
2. Right-click the active adaptor, and click Properties.

3.

Select Internet Protocol Version 4 (TCP/IPv4), and click Properties.
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4. Atthe Internet Protocol Version 4 (TCP/IPv4) Properties screen, select the Use the following IP address
radio button.

5. Type 192.168.1.220 for the default subnet mask, and 255.255.254.0and 192.168.1.220
for the gateway.

6. Click OK, and click Close to exit.

Installing Active Directory and DNS services on DC1
To install Active Directory, complete the following steps:

1. Click Start>Run, type dcpromo and click OK.

2. At the Active Directory Domain Services Installation Wizard welcome screen, check the Use advanced
mode installation option, and click Next.

3. Inthe Choose a Deployment Configuration dialog box, select Create a new domain in a new forest, and

click Next.

At the FQDN page, type 1ogin-vsi.com, and click Next.

At the NetBIOS name prompt, leave the name LOGIN-VSI, and click Next.

At the Forest Functionality level, select Windows Server 2008 R2, and click Next.

At the additional Domain Controller Options, leave DNS server selected, and click Next.

At the System Folder Location screen, leave the default options, and click Next.

Assign a Directory Services Restore Mode Administrator account password, and click Next.

10. At the Summary screen, review your selections, and click Next.

11. Once Active Directory Domain Services finishes installing, click Finish, and restart the system.

12. When DC1 restarts, log in as login-vsi\administrator.

13. Click Start>Run, and type dsa.msc to open Active Directory Users and Computers.

14. In the left pane, open Active Directory Users and Computers, and right-click the Login-vsi icon. Select
New->Organization Unit.

15. In the new Object —Organizational Unit Name field, type XendDesktop, and click OK.

16. Close Active Directory Users and Computers.

Creating a static entry in DNS for Xenserver-1 on DC1

1. Click Start>Administrative tools=>DNS manager.

Click DNS->DC1->login-vsi.com.

Right-click, and select New A record.

Type Xenserver-1 for host name,and 192.168.1.230 for the address.

Select Create an associated pointer (PTR) record.

Close DNS.

Verify the record by opening a command prompt (Click Start>Run, type cmd and press Enter).
In the command window, type ping xenserver-1 and press Enter.

9. IF DNS is working, the host should respond 4 times from 192.168.1.230.

Setting up DHCP services on DC1
1. Click Start=>Administrative Tools=>Server Manager—>Add Roles.

O NoUL kA WN

2. Select DHCP Server, and click Next.
3. At the Introduction to DHCP Server screen, click Next.
4. At the Specify IPv4 DNS Settings screen, type 1oginvsi.com for the parent domain.
5. Set the preferred DNS server IPv4 addressto 192.168.1.220 and click Next.
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10.
11.
12.
13.
14.
15.

16.

At the Specify IPv4 WINS Server Settings screen, select WINS is not required for applications on the
network, and click Next.

At the Add or Edit DHCP Scopes screen, click Add.

At the Add Scope screen, enter the Name DHCP Scope name.

In the next box, set the following values, and click OK.

e Starting IP Address: 192.168.0.1

e Ending IP Address: 192.168.1.199

e Subnet mask: 255.255.254.0

Check the Activate This Scope box.

At the Add or Edit DHCP Scopes screen, click Next.

Click the Enable DHCP v6 Stateless Mode radio button, and click Next.

Leave the default IPv6 DNS Settings, and click Next.

At the Authorize DHCP server dialog box, select Use current credentials.

At the Confirm Installation Selections screen, click Next. If the installation is set up correctly, a screen
displays saying that DHCP server install succeeded.

Click Close.

Enabling the Hyper-V role on DC1

=
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o

11

12.

Click Start->Administrative Tools—>Server Manager.

Click Roles.

Click Add Roles, and click Next.

Select the Hyper-V role by checking the box beside it, and click Next.

Check the box beside the Ethernet Card you wish to use for client/server traffic, and click Next.
Click Install to begin the Hyper-V installation.

When the installation finishes, click Close.

When the installer prompts you to restart now, click Yes.

Follow the prompt to log onto the system.

. Enter the password, and click the arrow to continue. The Resuming Configuration Wizard should start

automatically.

. Once the Resuming Configuration Wizard completes, the installation results appear with a message

that the installation succeeded.
Click Close.

Configuring virtual networks on DC1

1. Open Hyper-V Manager.

2. From the Actions menu, click Virtual Network Manager.

3. Under Create virtual network, select External network. Use one physical NIC that is connected to the
private 192.168.0.x network. Click Add, and the New Virtual Network page appears.

4. For the new network, type the name VSI-net

5. Review the other properties and modify them if necessary.

6. Click OK to create the virtual network and close Virtual Network Manager, or click Apply to create the
virtual network and continue using Virtual Network Manager.

7. Repeat steps 1 through 6 and create a public network on the Internet-accessible interface.
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Setting up an ISO repository for install media

=
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Click Start>Computer—->c:\

Right-click, and select New folder.

Type ISO and click Enter.

Right-click ISO, and select Properties.

Click the Sharing tab.

Click Share...

In the dialog box, type everyone and click Add.
Click Share.

Click Done.

. Copy a Windows 7 Enterprise Edition iso file to c:\iso. This will be needed for creating Windows 7 VMs

on XenServer.

Setting up Xenserver-1 (server under test)

Installing XenServer 5.6

Note that XenServer is effectively an operating system, and installing it removes any existing operating

system from a server.

1. Insert the XenServer 5.6 installation disc, and follow the instructions on the installation wizard.

2. Atthe Select Keymap screen, choose your key map or accept the default of QWERTY US, and press
Enter.

3. Atthe Welcome to XenServer screen, accept the default values.

4. Select Install or upgrade XenServer Host, and press Enter.

5. At the Welcome to XenServer Setup screen, read the warning, and press Enter.

6. Atthe End User License Agreement screen, read the agreement, select Accept EULA, and press Enter.

7. If you had installed an earlier version of XenServer, select Perform clean installation on the Installation
Type page, and press Enter. Be aware that doing this will cause XenServer to remove any existing VMs
stored on the server.

8. If the computer you are installing XenServer on has multiple local hard disk drives, the Select Primary
Disk screen will appear. If the computer has only one hard disk drive, this screen will not appear.

9. Select the primary disk (where you will install XenServer), and press Enter.

10. At the Choose a drive to be formatted for use by XenServer for VM storage pop-up, press Enter.

11. At the Select Installation Source screen, press Enter to accept the default setting, which is Local media.

12. At the Linux Pack screen, select No, and press Enter.

13. At the Verify Installation Source screen, press Enter to accept the default setting, which is Verify
installation source. This process may take some time. If you receive a verification error message,
download the software again and restart the installation process.

14. At the Verification Successful screen, press Enter.

15. At the Set Password screen, enter a root password, enter it again to confirm it, and press Enter.

16. At the Networking screen, the application may prompt you to select a management network interface
if your computer has multiple network interface cards (NICs). If so, select a NIC, and press Enter. If your
computer has a single NIC, the application selects this NIC.

17. Select Static configuration, specify the following values:

e |PAddress:192.168.1.230
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e Subnet mask: 255.255.254.0
18. Press Enter.
19. At the Hostname and DNS Configuration screen, specify the name of the server you are installing:
e At the Hostname Configuration section, select Manually specify.
e Type the name xenserver-1
e At the DNS Configuration section, select Manually specify.
o Typel192.168.1.220 forthe IP address of DNS server 1, and press Enter.
20. At the Select Time Zone screen, select your geographical area, and press Enter. Then, select a specific
locale in your time zone, and press Enter.
21. At the System Time screen, select use NTP time server, type 192.168.1.220, and press Enter.
22. At the Confirm Installation screen, select Install XenServer, and press Enter.
23. At the Set Local Time screen, type the correct date and time, and press Enter.
24. At the Installation Complete screen, press Enter. The system will automatically restart.
25. When the server reboots, log in as root.
26. At the command line, type nano etc/hosts
27.Type 192.168.1.230 xenserver-1 xenserver-1.login.vsi.com
28. Type ALT-X and save the new /etc/hosts file.
29. Log off the console.

Installing the Desktop delivery controller: xen-ddc
Creating a Windows 2003 R2 Enterprise Edition (x86) Hyper-V virtual machine, xen-ddc
1. Logonto DCI1.

2. Open Hyper-V Manager, and Click Start->Administrative Tools—>Hyper-V Manager.

3. Inthe left pane, select DC1, right-click and select New Virtual Machine.

4. In the Specify Name and Location screen, name the new virtual machine xen-ddc, select the V:/drive
as the location for storage, and click Next.

5. Inthe Assign memory screen, select 4096 MB for memory, and click Next.

6. Inthe Configure networking screen, select the public network for Network being used, and click Next.

7. Connect virtual hard drive.

8. In the Installation Options screen, select the appropriate media for Windows 2003 Enterprise Edition
R2 (x86) disk 1, and click Next.

9. Click Finish.

10. When completed, right-click the newly created xen-dcc in the virtual machine window and select

Settings.
11. Select Processor, change from 1 to 2 processors, and click OK.

Installing Windows 2003 Enterprise Edition (x86) on the virtual machine xen-ddc

1. Start the Virtual machine xen-ddc, and open a console.

2. Begin the Windows Server 2003 R2 Enterprise Edition (x86) Setup.
3. Press Enter to begin.
4. Read and accept the licensing agreement, and press F8 if you accept it.
5. Select the 40GB partition to install Windows Server 2003 on.
6. Select format in NTFS quick. Setup begins copying necessary files from the installation.
7. The machine will reboot and loads a GUI mode phase.
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8. Change your regional settings to accommodate your location, language, and time zone.

9. Enter your name and organization, and click Next.

10. Enter the appropriate license, and click Next.

11. Type the computer name xen-ddc and password Passwordl

12. Select the date, time, and time zone settings. Setup installs the networking components.

13. Continue with default network settings.

14. The setup process finishes copying files and configuring the setup.

15. Setup finishes and boots Windows Server 2003.

16. Log in as Administrator.

17. Windows Setup will require Windows 2003 Enterprise Edition (x86) R2 CD2 to complete the
installation; insert CD 2 when it prompts you, and click OK.

18. At the Welcome screen, click Next.

19. Accept the End-user License Agreement, and click Next.

20. Setup copies files and completes the installation.

21. Click Finish.

22. Close the Hyper—V manager.

Configuring Windows 2003 Enterprise Edition (x86) on the virtual machine xen-ddc
1. Logonto DC1.

2. Open Hyper-V Manager, and click Start—>Administrative Tools—>Hyper-V Manager.
3. In the virtual machine menu, right-click the xen-ddc virtual machine, and select Connect.
4. On the xen-ddc console menu, select Action—=>Insert Integration Services Setup Disk.
5. When integration services have been installed, select Yes to reboot.
6. After the system has rebooted, log in and click Start->Windows Update.
7. Select Express and install all available patches. We installed the following updates:
e Security Update for Windows Server 2003 (KB981332)
e Update for Windows Server 2003 (KB976662)
e Update for Windows Server 2003 (KB971737)
e Update for Windows Server 2003 (KB970430)
e Security Update for Jscript 5.8 for Windows Server 2003 (KB971961)
e Security Update for Windows Server 2003 (KB2286198)
e Security Update for Windows Server 2003 (KB980436)
e Security Update for Windows Server 2003 (KB2079403)
e Security Update for Windows Server 2003 (KB982214)
e Windows Malicious Software Removal Tool - August 2010 (KB890830)
e Security Update for Windows Server 2003 (KB2115168)
e Security Update for Windows Server 2003 (KB2160329)
e Cumulative Security Update for Internet Explorer 6 for Windows Server 2003 (KB2183461)
e Security Update for Windows Server 2003 (KB2229593)
e Security Update for Windows Server 2003 (KB975562)
e Microsoft .NET Framework 1.1 SP1 Security Update for Windows Server 2003 x86 and Windows
Server 2003 R2 x86 (KB979907)
e Security Update for Windows Server 2003 (KB979482)
e Cumulative Security Update for ActiveX Killbits for Windows Server 2003 (KB980195)
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e Security Update for Windows Media Format Runtime 9.5 for Windows Server 2003 (KB978695)
e Security Update for Windows Server 2003 (KB980218)
e Update for Windows Server 2003 (KB981793)
e Security Update for Windows Server 2003 (KB978542)
e Security Update for Windows Server 2003 (KB978601)
e Security Update for Windows Server 2003 (KB979683)
e Security Update for Windows Server 2003 (KB978338)
e Security Update for Windows Server 2003 (KB979309)
e Security Update for Windows Server 2003 (KB981350)
e Security Update for Windows Server 2003 (KB977816)
e Security Update for Windows Server 2003 (KB980232)
e Security Update for Windows Server 2003 (KB978706)
e Security Update for Windows Server 2003 (KB977914)
e Security Update for Windows Server 2003 (KB975560)
e Security Update for Windows Server 2003 (KB978037)
e Security Update for Windows Server 2003 (KB975713)
e Security Update for Windows Server 2003 (KB972270)
e Security Update for Windows Server 2003 (KB973904)
e Update for Windows Server 2003 (KB955759)
e Security Update for Windows Server 2003 (KB974392)
e Security Update for Windows Server 2003 (KB974318)
e Update for Windows Server 2003 (KB968389)
e Microsoft .NET Framework 1.1 Service Pack 1 Security Update for Windows Server 2003 x86 and
Windows Server 2003 R2 x86 (KB953298)
e Security Update for Windows Server 2003 (KB969059)
e Security Update for Windows Server 2003 (KB958869)
e Security Update for Windows Server 2003 (KB974112)
e Security Update for Windows Server 2003 (KB974571)
e Security Update for Windows Server 2003 (KB975025)
e Security Update for Windows Media Format Runtime 9.5 for Windows Server 2003 (KB954155)
e Security Update for Jscript 5.6 for Windows Server 2003 (KB971961)
e Security Update for Windows Server 2003 (KB967723)
e Security Update for Windows Server 2003 (KB956844)
e Internet Explorer 8 for Windows Server 2003
e Security Update for Windows Server 2003 (KB971657)
e Security Update for Windows Server 2003 (KB973815)
e Security Update for Windows Server 2003 (KB960859)
e Security Update for Windows Server 2003 (KB973507)
e Security Update for Windows Server 2003 (KB958469)
e Security Update for Windows Server 2003 (KB973869)
e Security Update for Windows Server 2003 (KB973540)
e Security Update for Windows Server 2003 (KB971032)
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e Security Update for Windows Server 2003 (KB970238)
e Security Update for Windows Server 2003 (KB961501)
e Security Update for Windows Server 2003 (KB923561)
e Security Update for Windows Server 2003 (KB959426)
e Security Update for Windows Server 2003 (KB960803)
e Security Update for Windows Server 2003 (KB952004)
e Security Update for Windows Server 2003 (KB956572)
e Update for Windows Server 2003 (KB967715)
e Security Update for Windows Server 2003 (KB956803)
e Security Update for Windows Server 2003 (KB925902)
e Security Update for Windows Server 2003 (KB956802)
e Security Update for Windows Server 2003 (KB952069)
e Security Update for Windows Server 2003 (KB958644)
e Security Update for Windows Server 2003 (KB944338)
e Security Update for Windows Server 2003 (KB950974)
e Security Update for Windows Server 2003 (KB952954)
e Security Update for Windows Server 2003 (KB951748)
e Security Update for Windows Server 2003 (KB950762)
e Cumulative Security Update for ActiveX Killbits for Windows Server 2003 (KB950760)
e Security Update for Windows Server 2003 (KB945553)
e Update for Windows Server 2003 (KB948496)
e Security Update for Windows Server 2003 (KB943055)
e Security Update for Windows Server 2003 (KB946026)
e Security Update for Windows Server 2003 (KB941569)
e Security Update for Windows Server 2003 (KB944653)
e Update for Windows Server 2003 (KB936357)
e Security Update for Microsoft .NET Framework, Version 1.1 Service Pack 1 (KB933854)
e Security Update for Windows Server 2003 (KB938127)
e Security Update for Windows Server 2003 (KB926122)
e Security Update for Windows Media Player 6.4 (KB925398)
e Cumulative Security Update for Outlook Express for Windows Server 2003 (KB929123)
e Security Update for Windows Server 2003 (KB924667)
e Update for Windows Server 2003 (KB927891)
e Security Update for Windows Server 2003 (KB932168)
e Security Update for Windows Server 2003 (KB930178)
8. After reboot, go to the Hyper-V console menu, and click File=>Settings=> Network adaptor.
9. Change the current adaptor from the public network to the login-vsi network (private), and click OK.
10. Log in to xen-ddc as Administrator.
11. Click Start=>Control Panel = Network Connections, right-click Local Area Connection, and select
Properties.
12. In the Local Area Connection Properties screen, select Internet Protocol (TCP/IP).
13. At the Internet Protocol Properties screen, complete these fields as follows:
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14.
15.
16.
17.
18.
19.

20.
21.
22.

IP address: 192.168.1.231

Subnetmask: 255.255.254.0

Default Gateway: 192.168.1.220

e Preferred DNS: 192.168.1.220

Click OK.

Go to Start, right-click My Computer, and select Properties.

In the System Properties box, select the Computer Name tab.

On the Computer Name tab, select Change.

To join the login-vsi domain, select Domain, specify login-vsi, and click OK.
When prompted for credentials, use the following, and select OK:

e Username: login-vsiladministrator

e Password: Passwordl

At the Welcome to the login-vsi domain screen, select OK.

Select OK again to exit the Computer Name window.

Select Yes to reboot the xen-ddc server to finish the domain join.

Installing Desktop Delivery Controller

Installing Desktop Delivery Controller automatically installs all the prerequisite Delivery Controller

components. When installing Terminal Services and Internet Information Services (1IS), the installation
program prompts you to insert the Windows Server 2003 installation disc when appropriate.

NouswNe

8.
9.

10.
11.

12.
13.
14.
15.

Log into the xen-ddc as a login-vsi\administrator.

Ensure that the VM has access to the Xen Desktop Delivery Controller media.

From the Desktop Delivery Controller media, run autorun.exe on the installation disc.

At the Welcome screen of the Desktop Delivery Controller installer, select Install Server Components.
Read and accept the license agreement, and click Next.

At the Select Components screen, leave all the options selected, and click Next.

At the Create or Join a Farm screen, select Create new farm, specify XENFARM as the name, and click
Next. Farm names can contain up to 32 characters, including spaces. The following characters cannot
beused:\/;:.*?=<>|[]()'"#

At the Specify Farm Edition screen, select Platinum Edition

At the Optional Server Configuration screen, click Next.

At the Start Installation screen, do not specify a database server, click Next.

Follow the onscreen instructions. Note that when the installation program prompts you to restart the
server, you must log as login-vsi\administrator to continue.

At the Setup Complete page, leave both checkboxes selected, and click Finish.

At all hardware installation notifications, select Continue anyway.

The system will restart again. Login into xen-dcc as login-vsi\administrator again.

Both the Active Directory Configuration Wizard and the License Management Console will start.

Configuring the Active Directory organizational unit

Use the Active Directory Configuration Wizard to configure the default population of the Active

Directory organizational unit (OU) specifically for running Desktop Delivery Controller. The wizard begins
automatically after you complete the previous procedure.

1.

At the first screen of the Active Directory Configuration Wizard, click Next.
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At the Configure Farm OU in Active Directory screen, click Browse, and navigate to the XenDesktop OU.
Click OK, and click Next.

At the Summary screen, click Finish and, once the application has applied the settings, click Close.
When the application prompts you to start the Delivery Services Console, click Yes. Leave the console
running for the next procedure.

Installing the XenDesktop license

To use XenDesktop you must have a valid license or a valid evaluation license. To get a new 90-day evaluation
license, go to http://www.citrix.com/English/ss/downloads/index.asp?ntref=hp nav_US to register and
activate a XenDesktop license file.

1.
2.

© ~Now

Once you have the license file, log into xen-dcc as login-vsi\administrator.

Open the license manager, click Start=> All programs—> Citrix=>Management Console—> License
Manager.

In the License Management Console, select the Configuration tab, and click Step 2: Copy license file to
this license server.

At the Upload license file screen, click Browse, and navigate to the location of your XenDesktop license
file.

To select the required license file, click Open.

To add the license file to the License Management Console, click Upload.

Close the License Management Console.

To start the License Management Console again, click Start—>All Programs—> Citrix>Management
Consoles—>License Management Console.

Configuring the Delivery Services Console

When the Delivery Services Console starts for the first time, the Configure and Run Discovery wizard

starts automatically.

1.
2.

hw

At the Welcome screen, click Next.

At the Select Product or Components screen, ensure that all the check boxes are selected, and click
Next.

At the Select Controllers screen, click Add Local Computer, and click Next.

At the Preview Discovery screen, click Next.

Wait until discovery is complete, and click Finish. In the Delivery Services Console, the Desktop Delivery
Controller VM (xen-dcc) is added to the left pane under Citrix Resources—>Desktop Delivery
Controller- XENFARM —>Controllers—=>xen-dcc

Close the Delivery Services Console.

If you wish to restart the Delivery Services Console, click Start—>All Programs—> Citrix>Management
Consoles—>Delivery Services Console.

Installing XenCenter on xen-ddc

1. Loginto xen-dcc as login-vsi\administrator, open a Web browser, and connect to http://192.168.1.230.
2. Select XenCenter installer.
3. Select Run.
4. After the file downloads, select Run when prompted with the windows security warning.
5. Atthe Welcome to the Citrix XenCenter Setup Wizard screen, click Next.
6. Atthe Custom Setup screen, accept the default features, and click Next.
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7. At the Destination Folder screen, accept the default path of C:\Program Files\Citrix\XenCenter\.
8. Under the Install for tab, select All Users, and click Next.
9. At the Ready to install Citrix XenCenter screen, click Install.
10. When the installation completes, click Finish.
Connecting and configuring Xenserver-1 via XenCenter
1. Start—>All Programs—>Citrix XenCenter.
2. When XenCenter launches, it will ask if you want to check for new versions of XenCenter. Choose No.
3. Inthe left pane, select XenCenter and right-click, and select Add.
4. Inthe add New Server box, enter the following:
e Server name: xenserver-1
e Username: root
e Password: Passwordl
Installing a license to the XenServer
1. Open Tools—>License Manager.
2. Click Assign license.
3. Inthe Apply license box, apply these settings and select OK:
e Licenseserver:Citrix XenServer for XenDesktop
e Name: xen-dcc
e Port number: 27000
Connecting XenServer to the DC1 ISO repository
1. Click xenserver-1.
In the right window, click the Storage tab.
Click New storage repository.
In the New storage repository wizard, click ISO library=>Windows File Sharing (CIFS), and click Next.
Enter the following values, and click Finish:
e Name: ISO
e Share name: \\dc1\ISO
e Username: login-vsiladministrator
e Password: Passwordl
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Configuring the network

1. Click the NIC tab in XenCenter.
2. Verify that there are two NICs:
e One should be a connected to the 192.168.1.0/23 network
e One should have Internet access
Click the Network tab.
To create the vsi-network, click Add Network...
In the new network box, select External Network, and click Next.
Type vsi-net for network, and click Next.
Select the NIC for the 192.168.1.0/23 network, and click Finish.
To create the public network, click Add Network...
In the new network box, select External Network, and click Next.

LN kW
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10. Type vsi-net for network, and click Next.
11. Select the NIC for the Internet-accessible network.
12. Click Finish.

Installing the Windows 7 Enterprise (32 bit) Virtual Machine

1. Loginto xen-dcc.

2. Open XenServer.

3. Right-click xenserver-1, and select New VM.

4. In the Select a VM template box, scroll to the bottom, select Other install media, and click Next.

5. In the Name the new virtual machine box, type win7ee and click Next.

6. Inthe Locate the operating system installation media box, select the Windows 7 Enterprise Edition
x86.is0, and click Next

7. Inthe Select a home server box, click xenserver-1, and click Next.

8. Inthe Allocate processor and memory resources box, select 1 vCPU and 1024 MB and, click Next.

9. In the Configure storage for the new VM box, click Add...

10. In the Add virtual Disk box, type disk0 forname and 14336 MB for Size, then click Add.

11. In the Configure storage for the new VM, click Next.

12. In the Configure Networking box, ensure only the public network is present, delete any others, and
click Next.

13. At the Ready to create the new virtual machine box, click Next.

14. The new VM called win7ee should appear on the left pane of XenServer. Click it and then click the
Console tab.

Windows 7 guest: Installing Windows 7 Enterprise (x68) on the newly created VM

=

When the installation prompts you, press any key to begin setup.
Enter your language preferences, and then click Next.
Click Install.
Accept the license terms, and then click Next.
Select Custom, and select the drive that will contain the OS.
Click Install. Setup begins.
Type username WIN7EE and computer WIN7EE-PC, and click Next.
Enter no password, and click Next.
For system protection Use recommended settings, and click Next.
. Enter time zone, and click Next.
. Select the Work Network setting, and click Next.
. Use Windows Update to patch the Windows 7 installation. We installed the following updates:
e Security Update for Windows 7 (KB978886)
e Security Update for .NET Framework 3.5.1 on Windows 7 x86 (KB983590)
e Update for Windows 7 (KB975496)
e Security Update for Windows 7 (KB975467)
e Security Update for Windows 7 (KB978601)
e Security Update for Windows 7 (KB2347290)
e Update for Windows 7 (KB974332)
e Microsoft .NET Framework 3.5 SP1 Update for Windows 7 x86 (KB982526)
e Security Update for Windows 7 (KB982665)
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e Update for Windows 7 (KB977074)

e Update for Windows 7 (KB2158563)

e Cumulative Security Update for ActiveX Killbits for Windows 7 (KB980195)

e Security Update for Windows 7 (KB974571)

e Update for Windows 7 (KB980408)

e Security Update for Windows 7 (KB982799)

e Security Update for Windows 7 (KB978542)

e Security Update for Windows 7 (KB2079403)

e Definition Update for Windows Defender - KB915597 (Definition 1.91.1370.0)
e Update for Windows 7 (KB980846)

e Update for Windows 7 (KB2272691)

e Update for Windows 7 (KB974431)

e Security Update for Windows 7 (KB979482)

e Security Update for Windows 7 (KB982214)

e Cumulative Update for Media Center for Windows 7 (KB981078)

e Update for Windows 7 (KB976662)

e Security Update for Windows 7 (KB972270)

e Security Update for Windows 7 (KB977165)

e Security Update for Windows 7 (KB975560)

e Security Update for Windows 7 (KB981852)

e Cumulative Security Update for Internet Explorer 8 for Windows 7 (KB2183461)
e Security Update for Windows 7 (KB2286198)

e Windows Malicious Software Removal Tool - September 2010 (KB890830)

e Security Update for Windows 7 (KB981332)

e Update for Rights Management Services Client for Windows 7 (KB979099)

e Security Update for Windows 7 (KB979309)

e Update for Windows 7 (KB979538)

e Security Update for Windows 7 (KB980436)

e Security Update for Windows 7 (KB980232)

e Security Update for Windows 7 (KB2160329)

e Update for Internet Explorer 8 Compatibility View List for Windows 7 (KB2362765)
e Microsoft .NET Framework 3.5 SP1 Security Update for Windows 7 x86 (KB979916)
e Security Update for Windows 7 (KB980218)

Windows 7 guest: Installing Xen tools

1. In XenCenter, click the drop-down menu for DVD Drive 1:, and click xetools.iso.

2. When prompted, click Run xensetup.exe.

3. When The User Account Control notification prompts appears, click Yes.

4. Accept the license agreement, and click Next.

5. Accept the default installation location, and click Install.

6. Click Finish to reboot.

7. When win7ee reboots, it will detect new hardware and prompt you to reboot again. Click OK.
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Windows 7 guest: Turning off system restore

1.

Click Start, right-click Computer, click Properties—>Advanced system settings—> System
Protection—>Configure > Turn off system protection, and click OK.

Windows 7 guest: Adjusting page file

1.
2.
3.
4,

Right-click Computer—>Properties—> Change settings=>Advanced—> Performance-> Settings.
In Performance settings, select the Advanced tab, and select change for Virtual Memory.
Deselect Automatically manage page file.

Select Custom size, enter 2048 for both values, and select Set.

Windows 7 guest: Joining the login-vsi domain

1.
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6.

Right-click Computer—>Properties—> Change settings—> Computer name.
Select Change.

In the Member of section, select Domain.

Enter the domain name: login-vsi.com, and click OK.

Enter the domain admin account and password for the login-vsi domain.
Reboot.

Windows 7 guest: Installing Office 2007 Professional

1.
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6.
7.
8.

From the Office 2007 media, run Setup.

Enter the product key for Office 2007, and click Continue.

Accept the licensing agreement.

Select Custom install.

Al the root of the installation options, ensure that all Office components are set to Run from My
Computer.

Click Install.

Download and run Office 2007 Service Pack 2.

Reboot the system.

Windows 7 guest: Installing the XenDesktop agent

=
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12.

13.

From the Citrix XenDesktop media, run XDE400OVDWX86SP1\xdsagent.msi.
When the Windows Security warning prompts you, click Run.

At the XenDesktop agent welcome screen, click Next.

Accept the license agreement, and click Next.

Accept the default port, 8080, and click Next.

Accept Firewall defaults, and click Next.

In Farm Selection, select XENDESKTOP, and click Next.

In the Ready to install box, click Install.

When the installation completes, click Finish.

. Click Yes to reboot the system.
. You can now use the Windows 7 image with Login VSI. To create multiple sessions, use Windows AIK

and sysprep to create 90 VMs. For more information on how to use sysprep on Windows 7, see
http://technet.microsoft.com/en-us/library/cc766514(WS.10).aspx.

Ensure that are all 90 virtual desktops are members of the login-vsi domain, and are moved to the
login_vsi\computers OU (see step 16, and 17 above)

Reboot the 90 virtual desktops to ensure that the GPO linked to the OU are effective
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Creating a XenDesktop group

1. Loginto xen-ddc as login-vsi\administrator.

Click Start—>All Programs—> Citrix=> Management Consoles—> Delivery Services Console.

Go to Citrix Delivery Services Console—> Citrix Resources—> Desktop Delivery Controller->XENDESKTOP.
Right-click Desktop Groups and click All Tasks—> Create Desktop Group.

In the Welcome screen for Create Desktop Group, click Next.

Select Assigned, and click Assign on first use. Click Next.

For hosting infrastructure, choose Citrix Xen VM infrastructure (included with XenDesktop).

To specify the hosting infrastructure, enter the following values, and click Next:

NV kA WN

e Address:http://xenserver-1
e Username: root
e Password: Passwordl
9. In the Select Virtual Desktops box, select Add..
10. In the Select Virtual Machine box, click each of the Windows 7 VMs created by sysprep, and click OK.
11. With all 90 virtual machines registered in the virtual machine list, verify all Active Directory computer
accounts are correct, and click Next.
12. To add users, click Add..
13. In the Users and Groups box, type domain users; domain admins, and click OK.
14. The two groups should be present in the users box, click Next.
15. For display name, type XenDesktop-pool and click Next.
16. Keep the Default icon, and click Next.
17. Do not select either check box in the publishing options box, and click Finish create the desktop group.
18. Click Citrix Delivery Services Console—> Citrix Resources—> Desktop Delivery
Controller>XENDESKTOP-> Desktop Groups—>XenDesktop pool.
19. In the Virtual desktops screen, verify that win7-pc.login-vsi.com is registered and its status is idle.
20. Close the Desktop Delivery Controller console, and log out.

Setting up Login-VSI components
Setting up Active Directory for Login VSI
1. Loginto DC1, browse the Login VSI media folder open the AD Setup/AD Setup.exe file .

2. Run the Login VSI setup on DC1.

3. Set your amount of users to 250.

4. Setyourusernameto Login VSI

5. For your password, enter the password you set up earlier, Passwordl

6. Click Start. A command prompt appears and you see the setup creating users.

7. Once the script finishes, the command prompt displays AD preparation is completed. Click OK, and
click Exit.

8. Start—>dsa.msc (active directory users and computers).

9. Expand loginvsi.com.

10. Expand Login_VSI.

11. Select Users to make sure that 250 are in place.
12. Right-click Login_VSI.

13. Select New, and select Group.
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14.

15.

16.
17.

18.

Set group name to 1oginvsigroup, select Global for Group Scope, and leave Group Type as
Security. Click OK.

Select all the users, and right-click and select Add to group. Type loginvsigroup forthe name of
the group, and check Name. Click OK, and the users will have joined the group.

Click Start and type GPMC . msc to open Group Policy Manager.

Edit the VSI System Group policy object: Click User Configuration—=>Policy=> Administrative Templates—>
Windows Components—>Desktop Windows Manager—>Edit. Do not allow desktop composition, select
Enabled, and click OK.

Close Group policy editor

Setting up file shares

1.
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6.

On DC1, go to C:, click New Folder, and name it VSI-Share
Right-click the new folder, and select Properties.

Click Sharing—>Advanced sharing, and then check Share this folder.
Open Permissions.

Check Allow Full Control, click Apply, and click OK.

At the Advanced Sharing screen, click Apply, and click OK.

Setting up the target

1.
2.
3.

Lo N

12.
13.

14.

15.

16.

On the Windows 7 guest WIN7EE1-PC, login as Administrator.

Click Start, right-click Computer, and click Manage.

Open User Manager by clicking Local users and Groups—>Groups—2>right-click Administrators, click Add
to Group...

Select Add...

Type loginvsigroup in the Enter the object names to select text box. Click OK to close.
In the User Accounts wizard, add the loginvsigroup from the login-vsi domain.

Launch the /Target setup/setup.exe

Specify the vsi share (//dc1/vsi-share), and select Start.

Before the setup is complete, the setup prompts you to move the computer account to the
Login_VSI\Computers OU and reboot. Do not reboot until this is done

. Log into DC1, and click Start=>Administrative Tools—> Active Directory Users and Computers.
11.

Browse to Active Directory Users and Computers—>Login-vsi.com—>Computers, and move the
WIN7EE1-PC account to the OU located at Active Directory Users and Computers.

Go to the Windows 7 guest, and reboot the system to complete the Login VSI target setup.

When the setup is complete, run services.msc and change Windows Search from Disabled to Automatic
(Delayed Start).

You are ready to use the Windows 7 image with Login VSI. To make multiple sessions, use Windows AIK
and sysprep to create 90 VMs. For more information on how to use sysprep on Windows 7, see
http://technet.microsoft.com/en-us/library/cc766514(WS.10).aspx.

Ensure that are all 90 virtual desktops are members of the login-vsi domain, and are moved to the
login_vsi\computers OU (see Steps 10 and 11 above).

Reboot the 90 virtual desktops to ensure that the GPO linked to the OU are effective.

Login VSI Launchers

1.

Install the VSI media\launcher\setup software on all physical desktop launchers.
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2. For more information on how to use more than Launcher in a master/slave relationship, refer to Page
37 in the Login VSI 2.3 Admin Guide .

3. Each Launcher should have XenDesktop web agent installed. For more information on integration of
XenDesktop and Login-VSI, please refer to
http://support.citrix.com/servilet/KbServlet/download/24130-102-
647344/XenDesktop%20with%20Login%20Consultants%20VS1%20-%20Guide.pdf.

4. We set all Citrix XenDesktop session launchers to view at 1,920x1,200.

Toggling multimedia redirection (MMR enabled and disabled)
Creating two XML files for each MMMR profile
1. Loginto xen-ddc as login-vsi\administrator.

2. Click Start>Run, type cmd, and press Enter.

3. At a command prompt, navigate to C:\Program Files\Citrix\Desktop Delivery Controller.

4. Type PorticaSetDefaults.exe /o MMR-on.xml to create an editable-settings XML file.

5. Click Start->Run, and type notepad.

6. In Notepad, click File=>Open...and browse to C:\Program Files\Citrix\Desktop Delivery
Controller\MMR-on.xml.

7. In Notepad, click Edit->Search, and type SpeedScreen Multimedia

8. Change the entry for <Enabled>true</Enabled> (default) of the SpeedScreen Multimedia section to

<Enabled>false</Enabled>.

9. In Notepad, click File=>Save As, and type C: \Program Files\Citrix\Desktop Delivery
Controller MMR-off

10. Close Notepad.

Disabling multimedia redirection (MMR off)
1. From the command prompt, type "c:\Program Files\Citrix\Desktop Delivery
Controller\PorticaSetDefaults.exe" /i MMR-0ff.xml
Enabling multimedia redirection (MMR on)

1. From the command prompt, type "c:\Program Files\Citrix\Desktop Delivery
Controller\PorticaSetDefaults.exe" /i MMR-on.xml
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APPENDIX A — SERVER CONFIGURATION INFORMATION

Figure 6 provides detailed configuration information about the test server.

System

Intel® Server Board S5520URT

Power supplies

Total number 2

Vendor and model number Delta Electronics —DPS-750PB
Wattage of each (W) 750

Cooling fans

Total number 3

First type of cooling fan

Number 2

Vendor and model number Delta Electronics TFBO812UH3
Dimensions (h x w) of each 3-1/8” x 1-1/2"

Volts 12

Amps 2.34

Second type of cooling fan

Number 1

Vendor and model number Delta Electronics PFC0612DE
Dimensions (h x w) of each 2-3/8” x 1-1/2”

Volts 12

Amps 1.68

General

Number of processor packages 2

Number of cores per processor 4

Number of hardware threads per core 2

CPU

Vendor Intel

Name Xeon®

Model number X5570

Stepping DO

Socket type Socket LGA1366

Core frequency (GHz) 2.93

Bus frequency 6.4 GT/s

L1 cache 32 KB + 32 KB (per core)

L2 cache 256 KB (per core)

L3 cache 8 MB (shared)

Platform

Vendor and model number Intel Server Board S5520URT
Motherboard model number S5520URT

Motherboard chipset Intel 5520
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System

Intel® Server Board S5520URT

BIOS name and version

$5500.86B.01.00.050 (05/06/2010)

BIOS settings

Default

Memory module(s)

Total RAM in system (GB) 24

Vendor and model number Micron MT36JSZ51272PY
Type PC3-10600R
Speed (MHz) 1,333

Speed running in the system (MHz) 1,333
Timing/latency (tCL-tRCD-tRP-tRASmin) 9-9-9-24

Size (GB) 4

Number of RAM module(s) 6x4GB
Chip organization Double-sided
Rank Dual

Hard disk

Vendor and model number

Intel SSDDSA2M160G2GN

Number of disks in system 1

Size (GB) 160
Buffer size (MB) N/A
RPM N/A
Type SATA I

Disk controller

Vendor and model

Integrated Serial ATA-300

Controller cache N/A
Controller firmware 1.2.5
RAID configuration RAID O

Operating system

Name Citrix XenServer 5.6

File system EXT3

Kernel 2.6.27.42-0.1.1.xs5.6.0.44.11158xen
Language English

Graphics

Vendor and model number

Intel Server Engine LLC Pilot Il Controller

Graphics memory

64 MB DDR2 SDRAM

Ethernet
Vendor and model number Intel 82575EB Gigabit Ethernet
Type Integrated

Optical drive(s)

Vendor and model humber

TSSTcorp TS-L633A UOO1

Type

DVD-RW
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System Intel® Server Board S5520URT

USB ports
Number 6
Type 2.0

Figure 6: Test server configuration details.
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