A Principled Technologies report: Hands-on testing. Real-world results.

The science behind the report:

HP ZBook G10 mobile workstations: Get the performance

HP ZBook G10 mobile workstations:
“' Get the performance you need to
take projects and action plans to
the next level

This document describes what we tested, how we tested, and what we found. To learn how these facts translate
into real-world benefits, read the report HP ZBook G10 mobile workstations: Get the performance you need to
take projects and action plans to the next level.

We concluded our hands-on testing on November 22, 2023. During testing, we determined the appropriate
hardware and software configurations and applied updates as they became available. The results in this report
reflect configurations that we finalized on October 30, 2023 or earlier. Unavoidably, these configurations may not
represent the latest versions available when this report appears.

Our results

To learn more about how we have calculated the wins in this report, go to http://facts.pt/calculating-and-highlighting-wins.
Unless we state otherwise, we have followed the rules and principles we outline in that document.

Table 1: Benchmark results. Higher scores are better. We report the median score of three runs for each test.

HP ZBook Firefly 14 G10 HP ZBook Power G10 HP ZBook Fury G10

3DMark Time Spy

Overall score 2,069 8,189 14,087
Graphics score 1,829 7,700 13,988
CPU score 8,196 12,791 14,729
WebXPRT 4 on Microsoft Edge

Overall score ‘ 270 ‘ 285 ‘ 291

Procyon® Video Editing Benchmark

Overall score | 3,058 | 5,836 | 7,187
Basemark® GPU

Vulkan score 1,876 7,739 14,892
DirectX 12 score 1,909 7,558 14,359

Geekbench 6 Pro

GPU Compute OpenGL score 17,422 78,116 147,666
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HP ZBook Firefly 14 G10 HP ZBook Power G10 HP ZBook Fury G10

PugetBench for Creators

® H ®
® .
Blender Benchmark (samples per minute, higher is better)
Monster render 79.69 1,471.42 2,751.66
Junkshop render 45.02 839.73 1,387.96
Classroom render 31.76 736.00 1,345.52

Table 2 presents our content creation workflow results in detail.

Table 2: Content creation workflow results. Less time is better. We report the median score of three runs for each test.

HP ZBook Firefly 14 G10 HP ZBook Power G10 HP ZBook Fury G10

Content creation workflows (time, minutes:seconds)

Rendering a scene from an Autodesk Maya® 2024
video into an image with the Arnold for Maya 0:42 0:13 0:11
rendering tool

Upscaling image resolution 4x using Gigapixel Al 0:34 0:14 0:13
Exporting a 5K video to 1080p using DaVinci 4:33 1:28 116
Resolve 18

Encoding video formats using Handbrake 3:28 1:32 1:22
Creating a panoramic 45MP image using the 0:51 0:49 0:46

Photomerge element in Photoshop

HP ZBook G10 mobile workstations: Get the performance you need to take projects and action plans to the next level January 2024 | 2



System configuration information

Table 3: Detailed information on the systems we tested.

System configuration information HP ZBook Firefly 14 G10 HP ZBook Power G10 HP ZBook Fury G10
Processor

Vendor Intel® Intel Intel

Name Core™ i7-1370P Core i9-13900H Core i9-13950HX

Core frequency (GHz)

3.9-5.2

4.10-5.40

4.0-5.5

Number of cores

6 P-cores, 8 E-cores

6 P-cores, 8 E-cores

8 P-cores, 16 E-cores

Cache (MB) 24 24 36
Memory

Amount (GB) 32 32 32
Type DDR5 DDR5 DDR5
Speed (MHz) 5,200 5,200 5,600
Integrated graphics

Vendor Intel Intel Intel

Model number

Iris Xe Graphics

Iris Xe Graphics

Iris Xe Graphics

Discrete graphics

Vendor N/A NVIDIA® NVIDIA

Model number N/A RTX 2000 Ada RTX 4000 Ada
Storage

Amount (TB) 1 1 1

Type PCle-based flash PCle-based flash PCle-based flash

Connectivity/expansion

Wired internet

N/A

1 x RJ-45

1 x RJ-45

Wireless internet

Intel AX211 Wi-Fi 6E

Intel AX211 Wi-Fi 6E

Intel AX211 Wi-Fi 6E

Bluetooth 53 5.3 53

usB 2x3.2 2 x USB Type-A 5Gbps 2 x USB Type-A 5Gbps
24 Type-C 1 x USB4 Type-C 40Gbps 2 x USB4 Type-C 40Gbps

Thunderbolt 2 1 2

Video 1 x HDMI 1 x HDMI 1 . a%'\i"lgisplaypm

Battery

Type Lithium-polymer Lithium-polymer Lithium-polymer

Integrated Integrated Integrated Integrated

Rated capacity (Wh) 51 83 95
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System configuration information HP ZBook Firefly 14 G10 HP ZBook Power G10 HP ZBook Fury G10
Display

Size (in.) 14.0 15.6 15.6

Type IPS IPS IPS

Resolution 1,920 x 1,200 1,920 x 1,080 3,840 x 2,400
Touchscreen No No No

Operating system

Vendor Windows Windows Windows

Name Windows 11 Pro Windows 11 Pro Windows 11 Pro

Build number or version

22H2

22H2

22H2

BIOS

BIOS name and version

HP 8b41 51.2B.00

HP v97 01.01.03

HP V96 01.02.03

Dimensions

Height (in) 0.75 0.89 1.12
Width (in) 12.40 14.14 14.29
Depth (in) 8.83 9.20 9.86
Weight (Ibs.) 3.2 4.4 5.3
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How we tested

Setting up the system

Setting up and updating the OEM image

AN

Boot the system.

Follow the onscreen instructions to complete installation, using the default selections when appropriate.
Set the Windows (plugged in) Power Mode to Best Performance.

Set Screen and Sleep options to Never:

a. Right-click the desktop, and select Display settings.
b. From the left column, select System.
c. Click Power & Battery.

For all power options listed under Screen and Sleep, select Never.

Q

Disable User Account Control notifications:

a. Select Windows Start, type UAC, and press Enter.
b. Move the slider control to Never notify, and click OK.

Run Windows Update, and install all updates available.
Verify the date and time are correct, and synchronize the system clock with the time server.
Pause Automatic Windows Updates:

a. Click the Windows Start button.
b. Type Windows Update settings, and press Enter.
c. From the Pause updates drop-down menu, select Pause for 5 weeks.

Performance testing

Geekbench 6 Pro GPU OpenCL

Setting up the test

1.

Purchase a Pro license and download and install Geekbench 6 Pro from https://www.geekbench.com/download/.

Running the test

a b wN =

Launch Geekbench.

Click Run Compute Benchmark.

Record the result.

Wait 5 minutes before re-running.

Repeat steps 1 through 4 two more times.

WebXPRT 4 (Microsoft Edge web browser)

Running the test

No ok~ wh =

Open the Web browser under test, and go to https://www.principledtechnologies.com/benchmarkxprt/webxprt/.
Click Run WebXPRT 4.

At the Ready to test your browser screen, click Continue.

Click Start.

When the test completes, record the results.

Click Run Again, and click Start to rerun WebXPRT. Record the results.

Repeat step 6 two more times.
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Blender Benchmark

Setting up the test

1.

Download and install the Blender Benchmark from https://opendata.blender.org/.

Running the test

© Nk wbh =

Launch the Blender Benchmark Launcher.

To accept the agreement, click Next.

Leave the default 3.6.0 Blender Version selected, and click Next.

Confirm the scenes the benchmark will render, and click Next.

Ensure the correct Benchmark Device is selected, and click Start Benchmark.
Record the results.

Wait 5 minutes before re-running.

Repeat steps 1 through 7 two more times.

3DMark: Time Spy

Setting up the test

AN

Download the 3Dmark benchmark from http://www.futuremark.com/benchmarks/3dmark/all.

To install 3DMark with the default options, double-click the 3DMark installer.exe file.

To launch 3DMark, double-click the 3Dmark desktop icon, enter the registration code, and click Regjister.
Exit 3DMark.

Running the test

S o

To launch the benchmark, double-click the 3DMark desktop icon.
At the top of the 3DMark Home screen, click the Benchmarks tab.
Select the desired benchmark to run (Time Spy).

Click Run.

When the benchmark run completes, record the results.

Perform steps 1 through 6 two more times.

Basemark GPU

Setting up the test

1.
2.
3.

Download the Basemark GPU benchmark from https://www.basemark.com/benchmarks/basemark-gpu/.
To install Basemark GPU with the default options, double-click the Basemark GPU installer file.
Follow the installation instructions and install any necessary Microsoft Visual Redistributable components.

Running the test

a ke =

To launch the benchmark, double-click the Basemark GPU desktop icon.

Select the Graphics API, Graphics Device, Texture Compression, and Content Quality.
Click Run Official Test.

When the benchmark run completes, record the results.

Repeat steps 1 through 4 two more times.

Procyon Video Editing Benchmark

Setting up the test

ok wh =

Download and install Procyon.

Open Procyon.

Click Video Editing Benchmark.

Click Register.

Enter the license key for the Video Editing Benchmark, and click Register.

Before running the benchmarks, make sure to install licensed versions of Adobe Premiere Pro 22.0 or higher.
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Running the test

Noak~wDdh =

Boot the system.

Launch Procyon.

Click Video Editing Benchmark.

Click Run.

When the benchmark is complete, record the results.
Wait 15 minutes before rerunning the benchmark.
Repeat steps 1 through 6 twice more.

PugetBench Adobe Content Creation Benchmark

Puget Systems Adobe CC benchmarks are designed to thoroughly test many of the most popular Adobe software packages using real-world
projects and workflows.

PugetBench for Premiere Pro

We used the following application:

e Adobe Premiere Pro

Setting up the test

Hown -

© N oo

9.

10.
1.
12.

Launch Adobe Premiere Pro.
Click through the tutorial pop-up tips.
Close Adobe Premiere Pro.

Purchase a PugetBench for Premiere Pro license from https://www.pugetsystems.com/labs/articles/PugetBench-for-Adobe-
Creative-Cloud-1642/.

Click Get on Adobe Marketplace, and log into your Adobe account.

Click the PugetBench Premiere Pro Plug-in to install it.

Open Adobe Premiere Pro.

Click Create New Project > Create.

Click Window > Extensions > PugetBench for Premiere Pro.

Next to License Key, click Change, and enter your license key. Click Save.

Click Download Project Files, and download the test assets.

Go to the Downloads folder, and extract the PugetBench for Premiere Pro 0.95.7 test assets.

Running the test

Vo NokA WD~

Boot the system.

Open Adobe Premiere Pro.

Go to Downloads = PugetBench for Premiere Pro, and open the Benchmark_Project_23.prproj file.
Click Window > Extensions = PugetBench for Premiere Pro.

Click Run Benchmark.

When the benchmark finishes, record the overall score.

Close Adobe Premiere Pro, and restart the system under test.

Wiait 30 minutes before performing the next run.

Repeat steps 1 through 8 twice more and record the median result.

PugetBench for After Effects

We used the following application:

e Adobe After Effects

Setting up the test

Rl

o

Launch Adobe After Effects.
Click through the tutorial pop-up tips.
Close Adobe After Effects.

Purchase and download the PugetBench for After Effects license from https://www.pugetsystems.com/labs/articles/PugetBench-for-
Adobe-Creative-Cloud-1642/.

Click Get on Adobe Marketplace, and log into your Adobe account.
Click the PugetBench After Effects Plug-in to install it.
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7.
8.
9

10.
1.
12.
13.
14.

15.
16.

Open Adobe After Effects.

Click Edit > Preferences = Scripting & Expressions.

Select Allow Scripts to Write Files and Access Network, and click OK.
Click Edit > Preferences - Memory & Performance.

The benchmark requires After Effects to have 12 GB of RAM space. Adjust the RAM reserved for other applications to get to 12 GB
RAM reserved for After Effects, and click OK.

Click Composition - New Composition.

Accept the default Composition Settings, and click OK.

Click Composition = Preview, and uncheck Cache Frames When Idle.
Click Window = Extensions - PugetBench for After Effects.

Next to License Key, click Change, and enter your license key. Click Save.

Running the test

® NOo Gk wN =

Boot the system.

Open Adobe After Effects.

Click Window - Extensions > PugetBench for After Effects.

Click Run Benchmark.

When the benchmark finishes, record the overall score.

Close Adobe Photoshop, and restart the system under test.

Wait 30 minutes before performing the next run.

Repeat steps 1 through 7 twice more, and record the median result.

Custom workload testing

Conducting Autodesk Maya 2024 with Arnold Renderer tests

Setting up the test

1.

2.

4.

5.

Download and install the Maya 2024 7-day trial from https://www.autodesk.com/products/maya/free-trial. Verify that the installation will
include Arnold Renderer as an additional component.

Launch Maya 2024, and point the Project Window to the correct directory.

a. Go to File & Project Window.

b. Click New, and type Dinner scene

c. Setthe Location to Documents/maya/projects.
d. Click Accept.

Create a Maya 2024 test workload scene named Dinner_scene. We used the YouTube tutorial created by Creative Tap.

Copy the Dinner_scene test workload to the Documents\maya\projects directory onto the other test system. When prompted, select Yes
to overwrite the Dinner_scene directory.

Close Maya 2024.

Running the test

S 00N GAEWN =

Launch Maya 2024, and select the test workload scene by browsing to Documents\maya\projects\Dinner_scene\Dinner_scene_v1.mb.
From the top menu bar, select the Display render settings icon.

Next to the Render Using field, select Arnold Renderer.

Under the System tab, select GPU as the Render Device, if available.

Under the Dinner_scene project, click the folder icon to choose a folder, and click Select.

Close the Render Settings dialog.

From the top menu, select Open Render View.

Start the timer, and click the green arrow to begin rendering the scene.

When the render completes, stop the timer, and record the time.

Repeat steps 1 through 9 two more times.
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Adobe Photoshop

We recorded how long it took to photo merge a panorama to create a 45MP image.

Running the test

Launch Photoshop.

Select File > Automate = Photomerge = Panorama.

Browse to the directory where the images are located, select them, and click OK
Simultaneously start the timer and click OK.

When the panoramic picture appears, stop the timer.

ok wbhN =

Repeat steps 1 through 5 two more times.

DaVinci Resolve 18

We recorded how long it took to export a 5K RED video file to H.264.

Running the test

Launch DaVinci Resolve 18.

Click New Project, name the test project, and click Create.

Drag and drop the test footage into the Media Pool. Click Change to change the project frame rate to match the source footage.
Drag and drop the test footage into the project timeline.

Click Quick Export.

Leave the default options for H.264 Master.

Start the timer, and click Export.

When the export completes, stop the timer, and record the result.

Vo Nk WwN =

Repeat steps 1 through 9 two more times.
Gigapixel Al: Upscale Image 4x

Setting up the test

1. Register, download, and install the Topaz Labs Gigapixel Al free trial from https://www.topazlabs.com/gigapixel-ai.
2. Launch Gigapixel Al and enter the username and password to start the free trial.
3. Close Gigapixel Al.

Running the test

1. Launch DeNoise Al.

2. Open the File > Preferences menu, select the appropriate Al Processor, and set Allowed Memory Consumption to High.
3. Click Browse, and select the test image.

4. Leave the default Scale and Al Model resize options selected.

5. To start the upscale process, click Save.

6. Once the save process is complete, record how long it took, which appears in the box at the bottom of the screen.

7. Wait 5 minutes before performing the next run.

8. Repeat steps 1 through 7 two more times.

HandBrake

Setting up the test

Download HandBrake from https://handbrake.fr/downloads.php.
Install HandBrake with default options.

Copy the 4K file you will be transcoding to the test system.
Launch HandBrake.

Browse to the 4K source file, and click Open.

a s wnN =
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Fast 1080p30 preset test

Running the test

Click the Chapters tab, and uncheck the Create chapter markers box.

Click Start Encode.

When encoding is complete, click the Show Queue menu item to view the encoding statistics.
Repeat steps 1 through 3 two more times.

PwbN =

Cloud file access: time to download 10GB file from Box.com

Running the test

Navigate to Box.com with the Edge browser, and log in with the test account.
Navigate to the test file you will download.

Start the timer, and click Download.

Stop the timer when the download completes, and record the result.

a s wn =

Repeat steps 1 through 4 two more times.

Read the report at https://facts.pt/aNé35le

This project was commissioned by HP.

‘ Principled

Technologies®

Principled Technologies is a registered trademark of Principled Technologies, Inc.
All other product names are the trademarks of their respective owners.

DISCLAIMER OF WARRANTIES; LIMITATION OF LIABILITY:

Principled Technologies, Inc. has made reasonable efforts to ensure the accuracy and validity of its testing, however, Principled Technologies, Inc. specifically disclaims
any warranty, expressed or implied, relating to the test results and analysis, their accuracy, completeness or quality, including any implied warranty of fitness for any
particular purpose. All persons or entities relying on the results of any testing do so at their own risk, and agree that Principled Technologies, Inc., its employees and its
subcontractors shall have no liability whatsoever from any claim of loss or damage on account of any alleged error or defect in any testing procedure or resullt.

In no event shall Principled Technologies, Inc. be liable for indirect, special, incidental, or consequential damages in connection with its testing, even if advised of
the possibility of such damages. In no event shall Principled Technologies, Inc.’s liability, including for direct damages, exceed the amounts paid in connection with
Principled Technologies, Inc.’s testing. Customer's sole and exclusive remedies are as set forth herein.
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