Responsiveness of Outlook 2007 SP2 vs. previous Outlook versions

**Executive summary**
Microsoft Corporation (Microsoft) commissioned Principled Technologies (PT) to determine whether Outlook 2007 SP2 is more responsive than Outlook 2007 SP1. To do so, we measured the time to conduct a set of real-world email tasks and run some typical user workflows. We found Outlook 2007 SP2 was noticeably more responsive to user input and actions than the earlier version and took less time to perform the standard operations.

We tested three versions of Microsoft Office Outlook:
- Outlook 2003 SP3
- Outlook 2007 SP1
- Outlook 2007 SP2

We measured how responsive each Outlook version was when performing a set of common email tasks. We ran these tests on two systems:
- Dell OptiPlex 755 with Intel Core 2 Duo E4500 2.2 GHz (desktop)
- Lenovo ThinkPad T61 with Intel Core 2 Duo T7100 1.8 GHz (notebook)

The results in this report are the averages of the results for the desktop and notebook systems. (For detailed information on these systems and the Microsoft Exchange server we used, see Appendix A.) We conducted all tests with two mailbox sizes: 250 MB and 5 GB.

**KEY FINDINGS**
- Outlook 2007 SP2 was notably faster (26 percent) than Outlook 2007 SP1 on a set of common email tasks and was even faster (35 percent) with larger mailboxes. (See Figure 1.)
- Users will experience considerable responsiveness and speed improvements with Outlook 2007 SP2 on such common day-to-day operations as launching, synchronizing, and searching, particularly with large mailboxes. (See Test results.)
- Outlook 2007 SP2 delivered some of these performance improvements in part by reducing writes to the hard drive by as much as 62 percent vs. Outlook 2007 SP1 and 82 percent vs. Outlook 2003. (See Figures 16 and 17.)

In Appendix B, we list these tasks and provide the results for each Outlook version running with the two mailbox sizes.

As Figure 1 shows, with the smaller mailbox, Outlook 2007 SP2 completed the tasks in 7.1 seconds, 26 percent less time than Outlook 2007 SP1’s 9.6 seconds, and 8 percent more time than Outlook 2003 SP3’s 6.6 seconds. With the larger mailbox, Outlook 2007 SP2 completed the tasks in 6.6 seconds, 35
Principled Technologies, Inc.: Responsiveness of Outlook 2007 SP2 vs. previous Outlook versions

percent less time than Outlook 2007 SP1’s 10.2 seconds, and 1 percent more time than Outlook 2003 SP3’s 6.5 seconds.

We tested each Outlook version running with both mailbox sizes on a set of common email tasks including launching Outlook, creating messages and meeting requests, replying to email, switching folder arrangements, and closing Outlook.

Launching Outlook
Microsoft introduced the To-Do Bar, a feature that is on by default, with Outlook 2007. Because having the To-Do Bar on increases the time to launch Outlook, we timed this operation two ways: with the To-Do Bar on, and with it off.

Outlook 2003 does not have a To-Do Bar. The Outlook 2003 feature that most closely approximates the To-Do Bar is Task view; however, the two features are very different. Task view, which is an alternative to the Inbox view, presents only a list of tasks the user has entered into Outlook 2003. By contrast, when Outlook 2007 launches with the To-Do Bar on, it presents a view of a list of tasks the user has entered (the To-Do list), the calendar with its associated appointments, and the Inbox.

With To-Do Bar off and the smaller mailbox, Outlook 2007 SP2 launched 52 percent faster than Outlook 2007 SP1, and 67 percent slower than Outlook 2003 SP3; with To-Do Bar off and the larger mailbox, Outlook 2007 SP2 launched 61 percent faster than Outlook 2007 SP1, and 30 percent slower than Outlook 2003 SP3.

With the smaller mailbox, launching Outlook 2007 SP1 with the To-Do Bar on was 340 percent slower than Outlook 2003 SP3 in Task view. With the To-Do Bar on, Outlook 2007 SP2 launched 113 percent slower than Outlook 2003 SP3. Turning the To-Do Bar off reduced that margin to 252 percent for Outlook 2007 SP1, and 67 percent for Outlook 2007 SP2.

With the larger mailbox, turning the To-Do Bar off reduced the percentage loss to Outlook 2003 SP3 from 277 percent for Outlook 2007 SP1 down to 230 percent and from 118 percent down to 30 percent for Outlook 2007 SP2.

We present our launch Outlook results with Task View or To-Do Bar off in Figure 2 and on in Figure 13.

Closing Outlook
We timed how long it took Outlook to close after synchronization tasks were complete. With the smaller mailbox, Outlook 2007 SP2 closed 2 percent faster than Outlook 2007 SP1 and 4 percent faster than Outlook 2003 SP3; with the larger mailbox, Outlook 2007 SP2 closed 21 percent faster than Outlook 2007 SP1 and 31 percent slower than Outlook 2003 SP3. We present these results in Figure 12.

Additional operations
We timed additional operations in each Outlook version running with both mailbox sizes. These included the following:

- synchronizing (time for a new OST to completely download)
- searching for 200 or fewer message results in a single folder
- searching for thousands of message results in a single folder
- searching for thousands of message results in all mail folders

With the smaller mailbox, Outlook 2007 SP2 synchronized a new OST (an offline folder in Outlook) download 14 percent faster than Outlook 2007 SP1; with the larger mailbox, Outlook 2007 SP2 synchronized a new OST download 34 percent faster than Outlook 2007 SP1. We present these results in Figures 14 and 15.

During the synchronization test, we measured the number of total reads and writes to the disk. With the smaller mailbox, Outlook 2007 SP2 produced 46 percent fewer writes to the hard drive than Outlook 2007 SP1 and 65 percent fewer writes than Outlook 2003. With the larger mailbox, Outlook 2007 SP2 produced 62 percent fewer
writes than Outlook 2007 SP1 and 82 percent fewer writes than Outlook 2003. We present these results in Figures 16 and 17.

With the smaller mailbox, Outlook 2007 SP2 required 65 percent fewer reads from the hard drive than Outlook 2007 SP1 and 96 percent fewer reads than Outlook 2003. With the larger mailbox, Outlook 2007 SP2 required 5 percent more reads than Outlook 2007 SP1 and 97 percent fewer reads than Outlook 2003. We present these results in Figures 18 and 19.

With the smaller mailbox, Outlook 2007 SP1 performed searches for messages from 79 to 85 percent faster than Outlook 2003 SP3, and Outlook 2007 SP2 performed searches for messages from 46 to 82 percent faster than Outlook 2003. With the larger mailbox, the improvement of both Outlook 2007 SP1 and SP2 over Outlook 2003 remained consistent at 96 to 100 percent. We present these results in Figures 20 through 25.

We provide more details of these tests in our Test results section, and list all test results for each version of Outlook running with both mailbox sizes in Appendix B.

Test results

Common email tasks

Launch Outlook with Task View or To-Do Bar off

Figure 2 shows the average system response time to launch Outlook with Task View or To-Do Bar off. We consider Outlook to have launched when the reading pane is visible and message text appears.

With the smaller mailbox, Outlook 2007 SP2 launched in 1.69 seconds, 52.4 percent less time than Outlook 2007 SP1, which took 3.54 seconds, and 67.4 percent more time than Outlook 2003 SP3, which took 1.01 seconds. With the larger mailbox, Outlook 2007 SP2 launched in 1.60 seconds, 60.5 percent less time than Outlook 2007 SP1, which took 4.04 seconds, and 30.2 percent more time than Outlook 2003 SP3, which took 1.23 seconds.

Figure 2: Average system response time, in minutes:seconds, to launch Outlook with Task View or To-Do Bar off. Smaller numbers, reflecting quicker response times, are better.
Launch reply to email while synchronizing

Figure 3 shows the average system response time to launch a reply to email while synchronizing. With the smaller mailbox, Outlook 2007 SP2 launched a reply to email while synchronizing in 0.69 seconds, 29.8 percent less time than Outlook 2007 SP1, which took 0.99 seconds, and 5.8 percent less time than Outlook 2003 SP3, which took 0.74 seconds. With the larger mailbox, Outlook 2007 SP2 launched a reply to email while synchronizing in 0.43 seconds, 2.1 percent less time than Outlook 2007 SP1, which took 0.43 seconds, and 25.7 percent less time than Outlook 2003 SP3, which took 0.57 seconds.

Launch reply to email after synchronization is complete

Figure 4 shows the average system response time to launch a reply to email after synchronization is complete. With the smaller mailbox, Outlook 2007 SP2 launched a reply to email after synchronization is complete in 0.51 seconds, 8.9 percent less time than Outlook 2007 SP1, which took 0.56 seconds, and 9.3 percent less time than Outlook 2003 SP3, which took 0.57 seconds. With the larger mailbox, Outlook 2007 SP2 launched a reply to email after synchronization is complete in 0.35 seconds, 31.3 percent less time than Outlook 2007 SP1, which took 0.44 seconds.
Launch new email while synchronizing
Figure 5 shows the average system response time to launch a new email while synchronizing.

![Launch new email while synchronizing](image)

Figure 5: Average system response time, in minutes:seconds, to launch a new email while synchronizing. Smaller numbers, reflecting quicker response times, are better.

With the smaller mailbox, Outlook 2007 SP2 launched a new email while synchronizing in 0.56 seconds, 20.6 percent less time than Outlook 2007 SP1, which took 0.71 seconds, and 12.5 percent less time than Outlook 2003 SP3, which took 0.64 seconds. With the larger mailbox, Outlook 2007 SP2 launched a new email while synchronizing in 0.37 seconds, 4.4 percent less time than Outlook 2007 SP1, which took 0.39 seconds, and 32.2 percent less time than Outlook 2003 SP3, which took 0.55 seconds.

Launch new email after synchronization is complete
Figure 6 shows the average system response time to launch a new email after synchronization is complete.

![Launch new email after synchronization is complete](image)

Figure 6: Average system response time, in minutes:seconds, to launch a new email after synchronization is complete. Smaller numbers, reflecting quicker response times, are better.

With the smaller mailbox, Outlook 2007 SP2 launched a new email after synchronization is complete in 0.46 seconds, 9.9 percent less time than Outlook 2007 SP1, which took 0.51 seconds, and 2.1 percent less time than Outlook 2003 SP3, which took 0.47 seconds. With the larger mailbox, Outlook 2007 SP2 launched a new email after synchronization is complete in 0.28 seconds, 28.7 percent less time than both Outlook 2007 SP1 and Outlook 2003 SP3, both of which took 0.39 seconds.
Launch new meeting request
Figure 7 shows the average system response time to launch a new meeting request.

Figure 7: Average system response time, in minutes:seconds, to launch a new meeting request. Smaller numbers, reflecting quicker response times, are better.

With the smaller mailbox, Outlook 2007 SP2 launched a new meeting request in 0.44 seconds, 12.2 percent less time than Outlook 2007 SP1, which took 0.50 seconds, and 4.5 percent more time than Outlook 2003 SP3, which took 0.42 seconds. With the larger mailbox, Outlook 2007 SP2 launched a new meeting request in 0.46 seconds, 8.8 percent less time than Outlook 2007 SP1, which took 0.50 seconds, and 6.8 percent less time than Outlook 2003 SP3.

Switch folder to Conversation arrangement
Figure 8 shows the average system response time to switch the folder to Conversation arrangement.

Figure 8: Average system response time, in minutes:seconds, to switch the folder to Conversation arrangement. Smaller numbers, reflecting quicker response times, are better.

With the smaller mailbox, Outlook 2007 SP2 switched the folder to Conversation arrangement in 0.34 seconds, 1.7 percent less time than Outlook 2007 SP1, which took 0.35 seconds, and 3.7 percent less time than Outlook 2003 SP3, which took 0.36 seconds. With the larger mailbox, Outlook 2007 SP2 switched the folder to Conversation arrangement in 0.41 seconds, 7.5 percent more time than Outlook 2007 SP1, which took 0.39 seconds.
Switch folder to Date arrangement
Figure 9 shows the average system response time to switch the folder to Date arrangement.

![Switch folder to Date arrangement](image)

Figure 9: Average system response time, in minutes:seconds, to switch the folder to Date arrangement. Smaller numbers, reflecting quicker response times, are better.

Outlook 2003 SP3, which took 0.27 seconds.

Switch folder to From arrangement
Figure 10 shows the average system response time to switch the folder to From arrangement.

![Switch folder to From arrangement](image)

Figure 10: Average system response time, in minutes:seconds, to switch the folder to From arrangement. Smaller numbers, reflecting quicker response times, are better.

Outlook 2003 SP3, which took 0.25 seconds.
Switch folder to Calendar arrangement

Figure 11 shows the average system response time to switch the folder to Calendar arrangement.

With the smaller mailbox, Outlook 2007 SP2 switched the folder to Calendar arrangement in 0.39 seconds, 5.4 percent more time than both Outlook 2007 SP1 and Outlook 2003 SP3, both of which took 0.37 seconds. With the larger mailbox, Outlook 2007 SP2 switched the folder to Calendar arrangement in 0.30 seconds, 20.8 percent less time than Outlook 2007 SP1, which took 0.38 seconds, and 7.8 percent more time than Outlook 2003 SP3, which took 0.28 seconds.

Close after synchronization is complete

Figure 12 shows the average system response time to close Outlook after synchronization is complete.

With the smaller mailbox, Outlook 2007 SP2 closed after synchronization was complete in 1.35 seconds, 1.8 percent less time than Outlook 2007 SP1, which took 1.37 seconds, and 4.3 percent less time than Outlook 2003 SP3, which took 1.41 seconds. With the larger mailbox, Outlook 2007 SP2 closed after synchronization was complete in 1.96 seconds, 20.7 percent less time than Outlook 2007 SP1, which took 2.47 seconds, and 31.2 percent more time than Outlook 2003 SP3, which took 1.49 seconds.
Additional operations
Launch Outlook with Task View or To-Do Bar on

Figure 13 shows the average system response time to launch Outlook with Task View or To-Do Bar on. We consider Outlook 2007 to have launched when the reading pane of the Inbox with the message text appears, and the To-Do Bar is visible with task list, the calendar date picker, and the calendar. We consider Outlook 2003 to have launched when the single Task View with the task list appears. For Outlook 2007, Microsoft added the To-Do Bar feature, which shows daily tasks, appointments, and a calendar. The To-Do Bar is not present in Outlook 2003.

With the smaller mailbox, Outlook 2007 SP2 launched in 1.81 seconds, 51.7 percent less time than Outlook 2007 SP1, which took 3.73 seconds, and 112.6 percent more time than Outlook 2003 SP3, which took 0.85 seconds. With the larger mailbox, Outlook 2007 SP2 launched in 2.65 seconds, 42.3 percent less time than Outlook 2007 SP1, which took 4.59 seconds, and 117.5 percent more time than Outlook 2003 SP3, which took 1.22 seconds.
**Synchronization time for new OST to completely download (250MB mailbox)**

Figure 14 shows the average system response time to synchronize the complete download of a new OST in each version of Outlook with the smaller mailbox.

With the smaller mailbox, Outlook 2007 SP2 synchronized the complete download of a new OST in 1 minute and 21.92 seconds, 13.8 percent less time than Outlook 2007 SP1, which took 1 minute and 35.03 seconds, and 35.4 percent less time than Outlook 2003 SP3, which took 2 minutes and 6.76 seconds.

**Synchronization time for new OST to completely download (5GB mailbox)**

Figure 15 shows the average system response time to synchronize the complete download of a new OST in each version of Outlook with the larger mailbox.

With the larger mailbox, Outlook 2007 SP2 synchronized the complete download of a new OST in 29 minutes and 35.79 seconds, 33.6 percent less time than Outlook 2007 SP1, which took 44 minutes and 36.27 seconds, and 27.9 percent less time than Outlook 2003 SP3, which took 41 minutes and 2.40 seconds.
Average number of disk writes during synchronization (250MB mailbox)
Figure 16 shows the average number of total disk writes during synchronization with the smaller mailbox. Lower numbers are better.

![Bar chart showing average number of disk writes during synchronization (250MB mailbox)](chart.png)

With the smaller mailbox, Outlook 2007 SP2 produced 4,018 disk writes during synchronization, 46.1 percent less than Outlook 2007 SP1, which produced 7,454 disk writes, and 65.3 percent less than Outlook 2003 SP3, which produced 11,593 disk writes.

Average number of disk writes during synchronization (5GB mailbox)
Figure 17 shows the average number of total disk writes during synchronization with the larger mailbox. Lower numbers are better.

![Bar chart showing average number of disk writes during synchronization (5GB mailbox)](chart.png)

With the larger mailbox, Outlook 2007 SP2 produced 104,979 disk writes during synchronization, 61.7 percent less than Outlook 2007 SP1, which produced 273,835 disk writes, and 82.2 percent less than Outlook 2003 SP3, which produced 590,304 disk writes.
Search for a message (200 or fewer, single folder) (250MB mailbox)
Figure 20 shows the average system response time to search for a message among 200 or fewer, within a single
folder, in each version of Outlook with the smaller mailbox.

![Graph showing search response time for 250MB mailbox](image)

With the smaller mailbox, Outlook 2007 SP2 searched for a message among 200 or fewer, within a single folder, in 0.84 seconds, the same amount of time as Outlook 2007 SP1. Both of these took 81.7 percent less time than Outlook 2003 SP3, which took 4.59 seconds.

Search for a message (200 or fewer, single folder) (5GB mailbox)
Figure 21 shows the average system response time to search for a message among 200 or fewer, within a single
folder, in each version of Outlook with the larger mailbox.

![Graph showing search response time for 5GB mailbox](image)

With the larger mailbox, Outlook 2007 SP2 searched for a message among 200 or fewer, within a single folder, in 0.89 seconds, 28.6 percent less time than Outlook 2007 SP1, which took 1.25 seconds, and 97.1 percent less time than Outlook 2003 SP3, which took 30.58 seconds.
Search for a message (thousands of results, single folder) (250MB mailbox)
Figure 22 shows the average system response time to search for a message among thousands of results, within a single folder, in each version of Outlook with the smaller mailbox.

With the smaller mailbox, Outlook 2007 SP2 searched for a message among thousands of results, within a single folder, in 0.83 seconds, 4.8 percent more time than Outlook 2007 SP1, which took 0.80 seconds, and 78.0 percent less time than Outlook 2003 SP3, which took 3.78 seconds.

Search for a message (thousands of results, single folder) (5GB mailbox)
Figure 23 shows the average system response time to search for a message among thousands of results, within a single folder, in each version of Outlook with the larger mailbox.

With the larger mailbox, Outlook 2007 SP2 searched for a message among thousands of results, within a single folder, in 0.92 seconds, 2.8 percent more time than Outlook 2007 SP1, which took 0.90 seconds, and 96.9 percent less time than Outlook 2003 SP3, which took 29.63 seconds.
Search for a message (thousands of results, all mail items) (250MB mailbox)
Figure 24 shows the average system response time to search for a message among thousands of results, within all mail items, in each version of Outlook with the smaller mailbox.

With the smaller mailbox, Outlook 2007 SP2 searched for a message among thousands of results, within all mail items, in 3.02 seconds, 259.6 percent more time than Outlook 2007 SP1, which took 0.84 seconds, and 45.9 percent less time than Outlook 2003 SP3, which took 5.59 seconds.

Search for a message (thousands of results, all mail items) (5GB mailbox)
Figure 25 shows the average system response time to search for a message among thousands of results, within all mail items, in each version of Outlook with the larger mailbox.

With the larger mailbox, Outlook 2007 SP2 searched for a message among thousands of results, within all mail items, in 4.36 seconds, 320.4 percent more time than Outlook 2007 SP1, which took 1.04 seconds, and 98.5 percent less time than Outlook 2003 SP3, which took 4 minutes and 53.48 seconds.
Workflow tests
In this section, we present response times for a series of 79 common tasks from a typical workday, which we explain in the Test methodology section. Because Step 1, launching Outlook and synchronizing the mailbox, takes a significant amount of time on the larger mailbox, we break this step out. Figure 27 shows the average system response time on the 79-step workflow test. The average system response time for the workflow decreased with each version of Outlook.

With the smaller mailbox, Outlook 2007 SP2 completed the total workflow in 17 percent less time than Outlook 2007 SP1 and 36 percent less time than Outlook 2003 SP3. With the larger mailbox, Outlook 2007 SP2 completed the total workflow in 23 percent less time than Outlook 2007 SP1 and 47 percent less time than Outlook 2003 SP3.

Test methodology
This section outlines the tests PT conducted to compare the performance of Outlook 2003 SP3, Outlook 2007 Outlook 2007 SP1, and Outlook 2007 Outlook 2007 SP2.

Installing and configuring the mail server
To set up this server, you must install several software components. The following subsections detail the necessary installation processes. Before following these instructions, make sure to statically assign an IP address for the server under test, and then plug that port into another system or router. This allows the server to correctly add the domain server function. We recommend making the IP address 192.168.1.250.

Installing and setting up the operating system
2. Finish the installation procedure using default settings.
3. Right-click the desktop, and select Personalize.
4. Click the Screen Saver link.
5. Click the Screen saver drop-down menu, and select (None).
6. Click Apply.
7. Click Change power settings.
8. Under Balanced, click Change plan settings.
9. Change the Turn off monitor drop-down menu to Never.
10. Click Save changes, and close the Power Options, Screen Saver Settings, and Personalization windows.
11. Open the Start menu, type regedit in the search field, and press Enter.
12. To allow the server to automatically log into the OS after a system reboot, change the Registry key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon] to have the following values:
   - DefaultPassword=Password1
   - AutoAdminLogon=1
   - DefaultUsername=administrator

13. Restart the server.

Installing the domain controller

1. Set a static IP address using the following steps:
   a. Right-click the network icon in the quick-launch bar, and choose Network and Sharing Center.
   b. Click Manage network connections.
   c. Right-click the local area connection, and click Properties.
   d. Select Internet Protocol Version (TCP/IPv4), and click Properties.
   e. Select the Use the following IP address radio button, and type 192.168.0.250 in the IP address field.
   f. Press Tab to auto-fill 255.255.255.0 in the Subnet mask field.
   g. In the Preferred DNS server field, type 127.0.0.1 and click OK to close the IPv4 properties window.
   h. Click Close.

2. Give the computer a name:
   a. Click Start, right-click Computer, and select Properties.
   b. Click Change Settings.
   c. Click Change.
   d. Type mailserver in the Computer name field, and click OK.
   e. In the Computer Name/Domain Changes pop-up window, click OK.
   f. Click OK.
   g. In the Microsoft pop-up window, click Restart Now.

3. Promote the mailserver to domain controller:
   a. Select Start → Command Prompt.
   b. Type dcpromo
   c. At the Welcome pop-up window, click Next.
   d. At the Operating System Compatibility screen, click Next.
   e. At the Choose a Deployment Configuration screen, select the Create a new domain in a new forest radio button, and click Next.
   f. At the Name the Forest Root Domain screen, type a domain name (i.e., mailserver.com), and click Next.
   g. At the Set Forest Functional Level screen, choose Windows Server 2008 from the drop-down menu, and click Next.
   h. At the Additional Domain Controller Options screen, accept the defaults, and click Next.
   i. When the Static IP assignment window pops up, click Yes, the computer will use a dynamically assigned IP address.
   j. When the Active Directory domain Services Installation Wizard window pops up, click Yes.
   a. At the Location for Database, Log Files, and SYSVOL screen, accept the defaults. Click Next.
   b. At the Directory Services Restore Mode Administrator Password screen, enter a password, and click Next.
   c. At the Summary screen, review the selections, and click Next.
   d. When the installation software prompts you to do so, insert the OS CD, and click OK.
   e. At the Completing the Active Directory Installation Wizard screen, click Finish.
   f. When the system prompts you to reboot the server, click Restart Now.
   g. After the server reboots, log into the system.

Installing Internet Information Services 6.0

1. Select Start → Administrative Tools → Server Manager.
2. On the left side bar, click Roles.
3. In the right frame, click Add Roles.
4. At the Select Server Roles screen, click Web Server (IIS).
5. In the Add features required for Web Server (IIS) pop-up window, click Add Required Features.
6. Click Next.
7. At the Web Server (IIS) screen, click Next.
8. At the Select Role Services screen, select the IIS 6 Metabase Compatibility, IIS 6 Management Console, Basic Authentication, Windows Authentication, Digest Authentication, and Dynamic content Compression checkboxes, and click Next.
9. At the Confirm Installation Selections screen, click Install.
10. At the Installation Results screen, click Close.

Installing Exchange Server 2007
1. Insert the Microsoft Exchange Server 2007 SP1 CD.
2. In the AutoPlay pop-up window, click Run Setup.EXE.
3. Click Step 3: Install Microsoft Windows PowerShell. Note: The installer should have steps 1 and 2 grayed out because it considers them complete. Select Start→Command Prompt.
4. In the Command Prompt window, type ServerManagerCmd –I PowerShell and press Enter.
5. When the installation completes, close the Command Prompt window.
6. Click the link to Step 4: Install Microsoft Exchange Server 2007 SP1.
7. Click Next to go past the introduction screen.
8. Accept the license agreement, and click Next.
9. Select No for error reporting, and click Next.
10. Select Typical Exchange Server Installation, and click Next.
11. Leave the organization name at default (First Organization), and click Next.
12. Select Yes to the question about client computers running Outlook 2003 and earlier, and click Next.
13. If a warning about a lack of SMTP appears after the check finishes, ignore it.
14. Click Install to start the installation process.
15. Once installation is complete, click Finish. Exchange should automatically open the Exchange Management Console.
16. Click the link to Step 5: Get critical updates for Microsoft Exchange.
17. Click Accept the license agreement.
18. Click Install.
19. When the install is complete, close Internet Explorer.
20. Run Windows Update, and download all available updates through 02/26/2009.

Configuring Exchange Server 2007
1. If Exchange does not automatically open the Exchange Management Console, select Start→All Programs→Microsoft Exchange Server 2007→Exchange Management Console.
2. In the left pane, expand Organization Configuration, and select Hub Transport.
3. In the action pane on the far right, select New Send Connector.
4. Name the send connector SMTP, select the intended use as Internet, and then click Next.
5. In the Address space window, click Add.
6. In the SMTP Address Space window, put * as the address, make sure a check appears beside Include all subdomains, and click OK.
7. Click Next.
8. Accept defaults for the next two pages by clicking Next.
9. At the New Connector page, click New to create the connector.
10. Click Finish to close the New SMTP Send Connector wizard.
11. In the left pane of the Exchange Management Console window, expand Server Configuration, and select Mailbox.
12. In the Database Management tab, right-click First Storage Group, and select New Public Folder Database.
13. Name the new public folder database Public Folder Database and click New.
14. In the Completion page, click Finish to close the New Public Folder Database window.
15. Close the Exchange Management Console, and reboot the server.
16. Once the server successfully reboots, log in, and select Start→All Programs→Administrative Tools→Active Directory Users and Computers.
17. In the Active Directory Users and Computers window, select mailserver.com in the left pane, and open Users in the right pane.
18. Right-click a blank area in the Users folder, and select New→User.
19. In the New Object – User window, complete the name fields as you wish (we used first name: test, last name: tester, logon name: tester), and select Next.
20. Enter a secure password (we used “Password1”), and check Password never expires.
21. In the information pop-up window, click Accept.
22. Select Next to confirm.
23. Click Finish to close the New Object – User window.
24. Double-click the new user to bring up the Properties window.
25. Under the Member Of tab, click Add.
26. In the Enter the object names to select dialog box, type Domain Admins; Exchange Organization Administrators, select Check Names to verify, and click OK.
27. Click OK to close the user Properties window, and then close the Active Directory Users and Computers window.
29. In the left pane of the Exchange Management Console window, select Recipient Configuration, and in the right pane, select New Mailbox.
30. In the New Mailbox window, select User Mailbox, and click Next.
31. In the User Type page, select Existing users, and click Add.
32. Select the new account you created earlier, and click OK to add it to the selection box.
33. Click Next.
34. In the Mailbox Settings page, leave the Alias textbox with default settings, and select Browse in the Mailbox database selection spot.
35. In the Select Mailbox database window, select Mailbox Database, and click OK.
36. Click through the next screens to create the new mailbox, and click Finish to close the mailbox and save your changes when you have done so.
38. Select Start→All Programs→Microsoft Exchange Server 2007→Exchange Management Console.
39. In the left windowpane, expand Server Configuration and Mailbox so the First Storage Group is visible.
40. Right-click First Storage Group, and select Properties.
41. Check the box beside This database can be overwritten by a restore.
42. Click Customize beside Maintenance interval.
43. Remove all blue from the boxes so the system will not perform maintenance, and click OK.
44. Click the Limits tab, and uncheck Issue warning at, Prohibit send at, Prohibit send, and Receive at.
45. At the Mailbox Database Properties window, click Apply.
46. Click OK to close the Mailbox Database Properties window.
47. Right-click Public folder Database under Second Storage Group, and select Properties.
48. Check the box beside This database can be overwritten by a restore.
49. Click Customize beside Maintenance interval.
50. Remove all blue from the boxes so the system will not perform maintenance, and click OK.
51. At the Public Folder Database Properties window, click Apply.
52. Click OK to close the Public Folder Database Properties window.

Capturing the base test image
We used Symantec’s Ghost product to capture a sector image of the hard disk to an external USB hard drive. Each time we ran a test on a machine, we used the Ghost image to return that machine to the above configuration. After re-imaging, we installed the software necessary to run each test and rebooted. We followed this process to capture the image.

1. Insert a bootable Ghost CD.
2. Power off the computer.
3. Attach the secondary hard disk.
4. Power on the computer.
5. At the Symantec Ghost screen, click OK.
6. Select Options → Image/Tape tab → Image All → Accept.
7. Select Local → Disk → To Image.
8. Click OK.
9. Select the Primary disk, and click OK.
10. Select the secondary hard disk in the copy image to drop-down box, name the file BASE and click Save.
11. At the Compress Image dialog, select High.
12. At the Proceed dialog, select Yes.
13. When the ghost image is complete, click OK, and exit Ghost.
14. Power off the computer.
15. Remove the secondary hard disk.
16. Reboot the computer.

**Installing and configuring the client system**

To get the most accurate and repeatable results possible, start with a clean hard disk, and set up all the test systems using the following procedures. This test does not attempt to account for every possible post-installation customization an end user could choose to perform. To compare the products with as similar settings as possible, change the settings so all products index as much as possible the same set of data.

**Installing Microsoft Windows Vista Enterprise with Service Pack 1**

During installation of the operating system, connect the computers to the production network to download Windows updates, drivers, and Office 2007 updates. Use the following process to install and configure a clean version of Windows Vista Enterprise on each system:

1. Install Windows Vista Enterprise:
   a. Boot to a Windows Vista Enterprise DVD.
   b. When the installer prompts you to do so, press any key to boot from CD or DVD.
   c. At the Language and preference screen, accept the default options, and click Next.
   d. Click Install now.
   e. Check I accept the license terms.
   f. Click Next.
   g. At the Which type of installation do you want? screen, select Custom (advanced).
   h. Click Drive options (advanced).
   i. Select the destination disk for the operating system.
   j. Click Format.
   k. At the All data stored will be permanently deleted dialog, click OK.
   l. Once the system finishes formatting the disk, click Next.
   m. Fill in the Username field, and click Next.
   n. Fill in the Computer name field, and click Next.
   o. When the option to enable Automatic Updates appears, click Ask me later.
   p. Select the correct time zone, date, and time; and click Next.
   q. At the Select your computer’s current location screen, click Work location.
   r. At the Thank you screen, click Start.
   s. When the Windows Vista Enterprise with Service Pack 1 installation completes, close the Welcome Center Dialog.
   t. At the Set network location screen, click Work location.
   u. Click Close.

2. Set the test resolution:
   a. Right-click the desktop.
   b. Select Personalize.
   c. Click Display Settings.
   d. Set the resolution to the maximum supported resolution.
   e. Click OK.
3. Verify that Windows Automatic Updates are off:
   a. Click Start→All Programs→Windows Updates.
   b. Click Change settings, located in the left panel.
   c. Select Never check for updates and Include recommended updates.
   d. Click OK.
   e. Click Get updates for more products.
   f. In the Microsoft Update window that opens, select I accept the Terms of Use, and click Install.
   g. Click Security.
   h. Under Security Center, select Turn automatic updating off.
   i. Select the Never check for updates radio button.
   j. Click OK.

4. Set the Power Management settings:
   a. Click Start→Control Panel.
   b. Select Appearance and Personalization.
   c. Under Personalization, click Change screen saver.
   d. Select None from the Screen saver drop-down menu.
   e. In the Screen Saver Settings dialog box, click Change power settings.
   f. Click Change plan settings.
   g. From the Turn off the display and Put the computer to sleep drop-down menus, select Never.
   h. Click Save changes.
   i. Close the Power Options window.
   j. On the Screen Saver Settings, click OK.
   k. Close the Appearance and Personalization window.

5. Disable system notifications:
   a. Click Start.
   b. Select Control Panel.
   c. Click Security.
   d. Select Security Center.
   e. Select Change the way Security Center alerts me from the left panel.
   f. Select Don’t notify me and don’t display the icon.
   g. Close the Windows Security Center window.
   h. Close the Security window.

6. Disable User Account Control (UAC):
   i. Click Start.
   j. Select Control Panel.
   k. Click User Accounts.
   l. In the main window, click Turn User Account Control on or off.
   m. Uncheck Use User Account Control (UAC) to help protect your computer.
   n. Click OK.
   o. Click Restart Now.

7. Run Windows Update, and download all available updates through 02/26/2009.
8. Capture the Base test image as we describe in the Capturing the base test image section above.

**Installing Microsoft Office 2003**
1. Insert the Microsoft Office 2003 installation DVD.
2. At the AutoPlay dialog box, click Run SETUP.exe.
3. Enter your CD key, and click Next.
4. Accept defaults for user info by clicking Next.
5. Click I accept the terms in the License Agreement, and click Next.
6. Accept defaults for installation type and path by clicking Next.
7. Click Install to continue with installation.
8. Once installation is complete, click Finish.
9. If the installer prompts you to do so, reboot the system.
10. Run the update for SP3.
11. Click Yes to install the update.
12. Click Yes to accept the License Agreement.
13. If the installer prompts you to shut down applications to complete installation, click OK.
14. Once you have successfully installed the update, click Yes to reboot the system.
15. Run Windows Update, and install all recommended and critical updates for Office 2003 through 02/26/2009, rebooting if required.

**Setting up Microsoft Outlook 2003**
1. Connect to the mail server using a static IP address:
   a. Ensure that you have plugged in both the client and the mail server into the same network.
   b. Click StartÆNetwork.
   c. Click Network and Sharing Center.
   d. Click Manage network connections.
   e. Right-click Local Area Connection, and click Properties.
   f. Double-click Internet Protocol Version 4 (TCP/IPv4) to open the Properties window.
   g. Click the Use the following IP address radio button.
   h. In the IP address field, type 192.168.0.251
   i. Press Tab to automatically complete the Subnet mask field with 255.255.255.0
   j. In the Default gateway and Preferred DNS server fields, type 192.168.0.250
   k. Leave the Alternate DNS server field blank, and click OK.
   l. In the Local Area Connection Properties window, click OK.
   m. If the installer prompts you to Set Network Location, select Work, and click Close.
   n. Close all related windows.
2. Open Control PanelÆUser AccountsÆMail.
3. Click Add…
4. Type exchange and click OK.
5. Click Next to add a new account.
6. Select Microsoft Exchange Server, and click Next.
7. Type mailserver.com in the Microsoft Exchange Server box.
8. Uncheck Use Cached Exchange Mode.
9. Type Test Tester into the User Name box, and click Check Name.
10. Type tester for the user name and Password1 for the password, and click OK.
11. Click Next.
12. Click Finish to complete the account setup.
14. Launch Outlook: StartÆEmail.
15. Type Password1 for the password, and check Remember Password.
17. Capture the Outlook 2003 base image as we describe in the Capturing the base test image section above.

**Installing Microsoft Office Outlook 2007**
1. Insert the Microsoft Office 2007 installation DVD.
2. At the AutoPlay dialog box, click Run SETUP.EXE.
3. Click Install Now.
4. At the conclusion of installation, close the Internet Explorer window, and close the Microsoft Office Enterprise 2007 window.
5. Run the update for SP1.
6. Click the check box to accept the License Agreement, and click Continue.
7. Click Yes to reboot the system.
8. Run Windows Update, and install all recommended and critical updates for Office 2007 through 02/26/2009, rebooting if required.

**Setting up Microsoft Outlook 2007**
1. Connect to the mail server using a static IP address:
a. Ensure that you have plugged both the client and the mail server into the same network.
b. Click Start → Network.
c. Click Network and Sharing Center.
d. Click Manage network connections.
e. Right-click Local Area Connection or Wireless Network Connection, and click Properties.
f. Double-click Internet Protocol Version 4 (TCP/IPv4) to open the Properties window.
g. Click the Use the following IP address radio button.
h. In the IP address field, type 192.168.0.251
i. Press Tab to automatically complete the Subnet mask field with 255.255.255.0
j. In the Default gateway and Preferred DNS server fields, type 192.168.0.250
k. Leave the Alternate DNS server field blank, and click OK.
l. In the Local Area Connection Properties window, click OK.
m. If the installer prompts you to Set Network Location, select Work, and click Close.
n. Close all related windows.

2. Open Control Panel, and open Mail.
3. Click Add…
4. Type exchange and click OK.
5. Check the checkbox beside Manually configure server settings or additional service types, and click Next.
6. Select the Microsoft Exchange radio button, and click Next.
7. Type mailserver.com in the Microsoft Exchange Server box.
8. Uncheck the box beside Use Cached Exchange Mode.
9. Type Test Tester into the User Name box, and click Check Name.
10. Type tester for the user name and Password1 for the password, and click OK.
11. Click Next.
12. At the Congratulations box, click Finish.
13. Click OK to close the Mail window.
14. Launch Outlook: Start → Email.
15. Type Password1 for the password, and check Save password.
16. At the setup RSS Feeds dialog, click No.
17. Uncheck the box beside Search Microsoft Office Online for Help content when I’m connected to the Internet, and click OK.
18. Close Outlook.
19. Capture the Outlook 2007 base image as we describe in the Capturing the base test image section above.

Setting up the Exchange Server mail database
1. Reset the client system to the Outlook 2003 SP3 base image.
2. Copy the 250 MB PST file to the client system.
3. Launch Outlook: Start → Email.
4. Ensure that the client connects to the server by pressing F9 (Send/Receive).
5. Go to File → Import and Export…
6. Click Next.
7. Scroll through the list, select Personal Folder File (PST), and click Next
8. Click Browse, and navigate to the test PST file. Select it, and click Open.
9. Click Next.
10. Click Finish to Import the test mailbox database.
11. Once the database is complete, dismiss any reminders, and verify by pressing Yes.
12. Allow the mailbox to sync with the Exchange Server.
13. Capture the Exchange Server with 250MB mail database image.
14. Repeat these steps with a duplicate Exchange Server using a 5GB mailbox and a clean client system.

Setting up and indexing the mailbox on the client
1. Reset the client system to the Outlook 2003 SP3 base image.
2. Launch Outlook: Start → Email.
3. Connect the client system to the 250MB Exchange Server.
4. Ensure that the client connects to the server by pressing F9 (Send/Receive).
5. Allow for the creation of the OST file on the test system.
6. Open the Indexing Options control panel, and wait until Windows Vista completes indexing the system.
7. Capture the fully indexed Outlook 2003 SP3 test image as we describe in the Capturing the base test image section above.
9. Reset the client system to the Outlook 2007 SP1 base image, and repeat steps 1 through 7.
10. Reset the client system to the Outlook 2007 SP2 base image, and repeat steps 1 through 7.
11. Repeat steps 1 through 10, connecting the system to the 5GB Exchange Server.

Setting up and running a trace with the Windows Performance Toolkit 4.1.1 (WPT)
1. Reset the system to the base test image.
3. Install the Windows Performance Toolkit using the Complete option.
4. Perform the following steps to turn on the correct providers in the trace:
   a. Open an elevated command prompt:
      i. Press the Windows key.
      ii. Type cmd in the Start Search field.
      iii. Press Ctrl+Shift+Enter.
   b. Type xperf.exe –on base+cswitch+fileio+networktrace in the elevated command prompt window to start the trace.
5. Run test in Outlook.
7. Stop the trace by typing xperf.exe –stop in the command prompt.
9. Perform the following steps to open the trace using Xperfview:
   a. Select Trace from the list of menu items.
   b. Select Open.
   c. Browse to locate the kernel.etl file at the root of c:
   d. Click Open.
10. Right-click Disk I/O graph.
11. Select Select View.
12. Right-click Disk I/O graph/chart again.
13. Select Summary Table.
14. Drag Path Name and Process to the left of the yellow line, if they are not already there.
15. Find the row with outlookOST.
16. Copy and paste the row into Excel by selecting it and typing Ctl+CÆCtl+V
17. Verify the following columns are present:
   • Read counts
   • Read size
   • Write counts
   • Write size
18. Right-click ProviderIds graph.
19. Select Select View.
20. Right-click ProviderIds graph/chart again.
21. Select Summary Table.
22. Drag Path Name and Process to the left of the yellow line, if they are not already there.
23. Copy and paste the tcpip row into Excel by selecting it and typing Ctl+CÆCtl+V
24. Copy and paste the udpip row into Excel by selecting it and typing Ctl+CÆCtl+V

Running the tests
We conducted two main groups of tests: individual or atomic tests, and workflow tests. Before we ran the individual tests, we reset the system with the test image, and we ran the individual tests a total of seven times.
We considered the first two runs conditioning runs, and dropped them. We took the average of the last five hand-timed results. We ran these tests as individual units. We captured disk I/O and network traffic measurements on three of the individual tests.

We ran the workflow tests as a set of tasks or actions that a typical user performs in the course of a workday. We performed the actions listed, in order, as quickly as a typical user would perform them, hand-timed the entire process, and measured disk I/O and network traffic over the course of the entire workflow. Before each run of the workflow tests, we reset the system with the test image, and we ran the tests.

**Individual tests**

This section details a set of individual test runs. We ran each test seven times. We collected the last five results. These steps apply to both Office 2003 and Office 2007, unless we note otherwise. These tests require an initial reset of the system image and OST file. Each system has six base system images, one each with Outlook 2003 SP3 using the 250MB mailbox, Outlook 2003 SP3 using the 5GB mailbox, Outlook 2007 SP1 using the 250MB mailbox, Outlook 2007 SP1 using the 5GB mailbox, Outlook 2007 SP2 using the 250MB mailbox, and Outlook 2007 SP2 using the 5GB mailbox.

1. Reset the client system to the fully indexed Outlook 2003 SP3 image.
2. Reset the server to the OL03_mailboxsize_client image.
3. Launch Outlook with To-Do Bar on.
   a. For Outlook 2003 (Note: Outlook 2003 does not have a To-Do Bar. To set the Tasks view on, do the following):
      i. Tools→Options→Other tab→Advanced Options.
      ii. Change "Startup in this folder:" to Tasks by clicking Browse, scrolling down to Tasks, and clicking OK.
      iv. Start the WPT trace as we describe in Setting up and running a trace with the Windows Performance Toolkit 4.1.1.
      v. Click Start.
      vi. From the Start menu, simultaneously click Email and start the timer.
      vii. Stop the timer when Outlook completes loading.
      viii. Stop the trace.
      ix. Repeat steps 3a-iv through 3a-viii six times, and record the last five results, renaming kernel.etl to OL03_mailboxsize_client_ToDoON_RUNn.etl after each run.
      x. At the conclusion of the seventh run, close the To-Do Bar by clicking the X to prepare for the next test.
   b. For Outlook 2007:
      i. Start the WPT trace as we describe in Setting up and running a trace with the Windows Performance Toolkit 4.1.1.
      ii. Click Start.
      iii. From the Start menu, simultaneously click Email and start the timer.
      iv. Stop the timer when Outlook completes loading.
      v. Stop the trace.
      vi. Repeat steps 3a-i through 3a-v six times, and record the last five results, renaming kernel.etl to OL07_mailboxsize_client_ToDoON_RUNn.etl after each run.
      vii. At the conclusion of the seventh run, close the To-Do Bar to prepare for the next test.
4. Launch Outlook with To-Do Bar off:
   a. Start the WPT trace as we describe in Setting up and running a trace with the Windows Performance Toolkit 4.1.1.
   b. Click Start.
   c. From the Start menu, simultaneously click Email and start the timer.
   d. Stop the timer when Outlook completes loading.
   e. Stop the trace.
   f. Repeat steps 4a through 4e six times, and record the last five results, renaming kernel.etl to OL03_mailboxsize_client_ToDoOFF_RUNn.etl after each run.
5. FolderSwitch to Conversation arrangement:
   a. Launch Outlook if it is not already open.
   b. Select View→Arrange By from the menu.
   c. Simultaneously choose Conversation and start the timer.
   d. Stop the timer when the FolderSwitch completes.
   e. Select View→Arrange By→From from the menu.
   f. Repeat steps 5a through 5e six times, and record the last five results.

6. FolderSwitch to Date arrangement:
   a. Launch Outlook if it is not already open.
   b. Select View→Arrange By from the menu.
   c. Simultaneously choose Date and start the timer.
   d. Stop the timer when the FolderSwitch completes.
   e. Select View→Arrange By→From from the menu.
   f. Repeat steps 6a through 6e six times, and record the last five results.

7. FolderSwitch to From arrangement:
   a. Launch Outlook if it is not already open.
   b. Select View→Arrange By from the menu.
   c. Simultaneously choose From and start the timer.
   d. Stop the timer when the FolderSwitch completes.
   e. Select View→Arrange By→Date from the menu.
   f. Repeat steps 7a through 7e six times, and record the last five results.

8. FolderSwitch to Calendar:
   a. Launch Outlook if it is not already open.
   b. Simultaneously press Ctrl+2 and start the timer.
   c. Stop the timer when the calendar appears.
   d. Switch back to mail view (Ctrl+1).
   e. Repeat steps 8a through 8d six times, and record the last five results.

9. Click Reply (while synchronizing):
   a. Close Outlook.
   b. Delete the local OST file on the client found at C:\Users\User\Appdata\Local\Microsoft\Outlook.
   c. Launch Outlook, and allow it to start to synchronize.
   d. Select an email.
   e. Simultaneously click Reply and start the timer.
   f. Stop the timer when the reply completes opening.
   g. Repeat steps 9a through 9f six times, and record the last five results.
   h. Allow Outlook to finish updating all folders in preparation for the next test.

10. Click Reply (after synchronization is complete):
    a. Launch Outlook if it is not already open.
    b. Select an email.
    c. Simultaneously click Reply and start the timer.
    d. Stop the timer when the reply completes opening.
    e. Repeat steps 10a through 10d six times, and record the last five results.

11. Click New (while synchronizing):
    a. Close Outlook.
    b. Delete the local OST file on the client found at C:\Users\User\Appdata\Local\Microsoft\Outlook.
    c. Launch Outlook, and allow it to start to synchronize.
    d. Simultaneously click New and start the timer.
    e. Stop the timer when the new email message completes opening.
    f. Repeat steps 11a through 11e six times, and record the last five results.
    g. Allow Outlook to finish updating all folders in preparation for the next test.

12. Click New (after synchronization is complete):
    a. Launch Outlook if it is not already open.
    b. Simultaneously click New and start the timer.
    c. Stop the timer when the new email message completes opening.
    d. Repeat steps 12a through 12c six times, and record the last five results.
13. New meeting request:
   a. Launch Outlook if it is not already open.
   b. Simultaneously press Ctrl+Shift+Q and start the timer.
   c. Stop the timer when the new meeting request completes opening.
   d. Repeat steps 13a through 13c six times, and record the last five results.

14. Search for a message (200 or less - single folder):
   a. Launch Outlook if it is not already open.
   b. Select the first folder under Inbox.
      • For Outlook 2003:
         i. Press Ctrl+E to open the Find tool.
         ii. Type London into the Look for field.
         iii. Simultaneously click Find Now and start the timer.
         iv. Stop the timer when search completes. (Note: When Outlook 2003 begins a search, a
             search icon appears to the left of the Look for field. When Outlook 2003 finishes a
             search, the icon disappears.)
         v. Clear the results.
         vi. Repeat steps i through v six times, and record the last five results.
      • For Outlook 2007:
         i. Simultaneously type London into the Search field and start the timer. (Note: This may
             require a second person on the timer to account for word wheeling.)
         ii. Stop the timer when the search completes.
         iii. Clear the results.
         iv. Repeat steps i to iii six times, and record the last five results.

15. Search for a message (thousands of results - single folder):
   a. Launch Outlook if it is not already open.
   b. Select the folder named Active.
      • For Outlook 2003:
         i. Press Ctrl+E to open the Find tool.
         ii. Type Workplan into the Look for field.
         iii. Simultaneously click Find Now and start the timer.
         iv. Stop the timer when search completes. (Note: When Outlook 2003 begins a search, a
             search icon appears to the left of the Look for field. When Outlook 2003 finishes a
             search, the icon disappears.)
         v. Repeat steps i through iv six times, and record the last five results.
      • For Outlook 2007:
         i. By default, Office 2007 limits search results to no more than 200 items. To remove this
            limit, use the following steps:
            a. Click the drop-down menu next to the Search field.
            b. Click Search Options…
            c. Uncheck the box beside Make searches faster by limiting the number of results
               shown, and click OK.
         ii. Simultaneously type Workplan into the search field and start the timer. (Note: This
             may require a second person on the timer to account for word wheeling.)
         iii. Stop the timer when the search completes.
         iv. Repeat steps i to ii six times, and record the last five results.

16. Search for a message (thousands of results - All Mail Items):
   a. Launch Outlook if it is not already open.
      • For Outlook 2003:
         i. Press Ctrl+E to open the find tool.
         ii. Click the Search In drop-down menu.
         iii. Select Search All Mail Items.
         iv. Type Workplan into the Look for field.
         v. Simultaneously click Find Now and start the timer.
vi. Stop the timer when the search completes. (Note: When Outlook 2003 begins a search, a search icon appears to the left of the Look for field. When Outlook 2003 finishes a search, the icon disappears.)

vii. Repeat steps i through vi six times, and record the last five results.

• For Outlook 2007:
  i. Click All Mail Items under Mail Folders on the left-hand side of the screen.
  ii. Simultaneously type Workplan into the Search All Mail Items field and start the timer. (Note: This may require a second person on the timer to account for word wheeling.)
  iii. Stop the timer when the search completes.
  iv. Repeat steps i through iv six times, and record the last five results.

17. Synchronization time for new OST to completely download:
   a. Close Outlook.
   b. Delete the local OST file on the client found at C:\Users\User\AppData\Local\Microsoft\Outlook.
   c. Start the WPT trace as we describe in Setting up and running a trace with the Windows Performance Toolkit 4.1.1.
   d. Simultaneously launch Outlook and start the timer.
   e. Stop the trace, and the timer when synchronization completes, as indicated by the all folders are up to date status message.
   f. Repeat steps 17a to 17f six times, and record the last five results, renaming kernel.etl to OL03_mailboxsize_client_OSTsync_RUNn.etl after each run.
   g. Close Outlook.

18. Close Outlook (after synchronization is complete):
   a. Launch Outlook, and allow it to start to synchronize by waiting 30 seconds.
   b. Close Outlook: Simultaneously close Outlook and start the timer.
   c. Stop the timer when the Outlook window disappears.
   d. Wait for 5 minutes.
   e. Repeat steps 19a to 19d six times, and record the last five results.

19. Copy trace results off the computer from the root of C:\

20. Reset the client and server with the paired Outlook 2007 SP1 images, and repeat steps 3 through 19.

21. Reset the client and server with the paired Outlook 2007 SP2 images, and repeat steps 3 through 19.

Workflow tests
This section details running a set of workflow tests. We ran each set of workflow tests a total of three times. Before each full run, we reset both the client system and the Exchange Server to their respective unindexed, base test image. (Note: indexing the 250MB mailbox takes over 30 minutes. Indexing the 5GB mailbox takes several hours. We stopped timing during the indexing process. We also stopped the trace.) These steps apply to both Office 2003 and Office 2007, unless we note otherwise.

Note: The workflow tests assume that the Reading Pane is on and visible in the right panel. We had one system not under test connected to the test network for the purpose of sending email messages, and sending/receiving meeting requests.

1. Reset the server with the Outlook 2003 SP3 250MB test image, and the system with the base Outlook 2003 SP3 image.
2. Connect it to the Exchange Server.
3. Launch Outlook: Start ➔ Email.
4. Set Cached mode to on (Accounts ➔ Microsoft Exchange ➔ Check Use Cached Exchange Mode).
5. Close Outlook.
6. Start the WPT trace as we describe in the Setting up and running a trace with the Windows Performance Toolkit 4.1.1 (WPT) section.
7. Start the timer.
8. Launch Outlook: Start ➔ Email.
9. Allow Outlook to fully synchronize the mailbox.
10. If the reminder dialog box appears with three appointments, click Dismiss All.
11. Stop the timer and the trace.
12. If this is a 5GB mailbox database:
   a. Collect the .ETL file that the trace created in the Windows Performance Toolkit folder to a thumb drive.
   b. Restart the system, and restore the fully indexed image.
   c. Skip the next step.
13. Open the Indexing Options control panel, and wait until the system completes indexing.
14. Launch Outlook: Start ➔ Email.
15. Create five new tasks by pressing CTRL+SHIFT+K to open the new task dialog, typing New Task as the subject, and clicking Save and Close. You must do this five times.
17. Start the WPT trace as we describe in the Setting up and running a trace with the Windows Performance Toolkit 4.1.1 (WPT) section.
18. Start the timer.
19. Launch Outlook: Start ➔ Email.
20. Perform an incremental synchronization of 20 email messages:
   a. Click the Connected to Microsoft Exchange status message in the lower right corner of Outlook.
   b. Select Work offline.
   c. Send 20 messages to Test Tester from a third system.
   d. Click the Offline status message, and deselect Work offline.
21. Read the first five emails, remaining on each email for around 2 seconds.
22. Select the second and third email, and delete both by right-clicking the two selected emails and choosing Delete.
23. Select the fourth email (now the second in order because Outlook deleted two emails in step 22), and click the Reply button located in the toolbar.
24. Type This is a test as the reply, and click Send.
25. Select the first email, and click the Reply button located in the toolbar.
26. Type This is a test as the reply, and click Send.
27. Select the first email, and click the Forward button located in the toolbar.
28. Type Test2 Tester in the To... field, type I have already replied to this email in the email body, and click Send.
29. Select the eighth email, and click the flag button located to the right of the date.
30. Select the 15th email, and click the flag button located in to the right of the date.
31. Select the first folder, and select the third email message in that folder.
32. Pause for around 2 seconds while reading the email message in preview pane.
33. Select the eighth email in the first folder.
34. Pause for around 2 seconds while reading the email message in preview pane.
35. Select the second folder, and double-click the ninth email message in that folder.
36. Pause for around 2 seconds while reading the email message, and then close the message.
37. Double-click the 10th email message in the second folder, pause for around 2 seconds while reading the email message, and then close the message.
38. Select the first five email messages in the inbox, and move these messages to the first folder by dragging and dropping them.
39. Select the first six email messages in the inbox folder, and move these messages to the second folder by dragging and dropping them.
40. Select the Inbox, and arrange the email messages by conversation: View ➔ Arrange By ➔ Conversation.
41. Arrange the email messages in the inbox by from: View ➔ Arrange By ➔ From.
42. Select the first five email messages from the first user and categorize them:
   a. For Outlook 2003:
      i. Right-click the selected email messages, and select Categorize.
      ii. Select the Business check box in the Categories dialog box, and click OK.
   b. For Outlook 2007:
      i. Right-click the selected email messages, and select Categorize.
      ii. Select Red Category from the list of choices.
43. Create a new folder, and name it User2
a. Right-click the Inbox, and select New Folder.
b. Type User2 into the Create New Folder dialog box, and click OK.

44. Select the first 10 email messages from Jessica Tester in the inbox, and move them to the folder you recently created and named User2 by dragging and dropping.

45. Arrange the email messages in the inbox by date: View→Arrange By→Date.

46. Mark the first 10 email messages as unread by right-clicking the selected email messages, and selecting Mark as Unread.

47. Send three meeting requests from the non-tested system to the system under test.

48. Click Dismiss all on the test machine, and click Yes to dismiss.

49. Right-click each new request, and click Accept.

50. Read the first 10 email messages from Test2 Tester in Preview Pane:
   a. Select each email in sequence.
   b. Pause for around 2 seconds to simulate reading each in the Reading Pane.

51. Select the sixth message you just read, click Reply in the toolbar, type That’s okay as a response, click the Save button to save a draft of the message, and close the response without sending it.

52. Switch to the calendar by pressing Ctrl+2.

53. Switch to full-week view by clicking the Week button in Outlook 2003, and the Show full week radio button in Outlook 2007.

54. Switch to week view by clicking the Work week button in the Outlook 2003 toolbar, and clicking the Week button in Outlook 2007.

55. Create an appointment on Wednesday:
   • For Outlook 2003:
     i. Double-click Wednesday, 9:00AM.
     ii. Type Doctor in the Subject field.
     iii. Click the Save and Close button.
   • For Outlook 2007:
     i. Place the mouse cursor over Wednesday, 9:00AM.
     ii. Click once in that time slot, and type Doctor.
     iii. Press Enter.

56. Create a New Meeting request:
   • For Outlook 2003:
     i. Open the drop-down menu associated with the New button in the toolbar, and select Meeting Request.
     ii. Type Test2 Tester in the To... field.
     iii. Type Meeting in the Subject field.
     iv. Click Recurrence, and select 10:00 AM as the Start time and 11:30 AM as the End time.
     v. Select Weekly from the options in the Recurrence pattern section, and click OK.
     vi. Set the Reminder to 30 minutes, and click Send.
   • For Outlook 2007:
     i. Open the drop-down menu associated with the New button in the toolbar, and select Meeting Request.
     ii. Type Test2 Tester in the To... field.
     iii. Type Meeting in the Subject field.
     iv. Click Recurrence, and select 10:00 AM as the Start time and 11:30 AM as the End time.
     v. Select Weekly from the options in the Recurrence pattern section, and click OK.
     vi. Set the Reminder to 30 minutes, click Send, and click Yes when Outlook prompts you about not providing a location.

57. Create the following appointments:
   • For Outlook 2003:
     i. Double-click the grey area below the word Thursday.
     ii. Type All day in the Subject field.
     iii. Click the Save and Close button.
     iv. Double-click 2:00 PM Friday.
     v. Type Meeting 1 in the Subject field.
vi. Set the End time to 4:00 PM.
vii. Click the Save and Close button.
viii. Double-click 11:00 PM Friday.
ix. Type Overnight trip in the Subject field.
x. Set the End time to 9:00 AM.
xi. Click the Save and Close button.
xii. Double-click 10:00 AM Thursday.
xiii. Type Meeting 2 in the Subject field.
xiv. Set the End time to 11:00 AM.

• For Outlook 2007:
  i. Place the cursor over the blue area below the word Thursday.
  ii. Click To add event, and type All day.
  iii. Press Enter.
  iv. Place the cursor over 2:00 PM Friday.
  v. Click to add event, type Meeting 1 in the time field, and press Enter.
  vi. Drag the end time to 4:00 PM.
  vii. Place the cursor over 11:00 PM Friday.
  viii. Type Overnight trip in the time field, and press Enter.
  ix. Drag the end time to 8:00 AM.
  x. Place the cursor over 8:00 AM Saturday.
  xi. Click to add event, type Meeting 2 in the time field, and press Enter.
  xii. Drag the end time to 11:00 AM.

58. Switch back to inbox by pressing Ctrl+1.
59. Double-click message 12, and flag it for Follow-up tomorrow:
  • For Outlook 2003:
    i. Click the flag button in the toolbar.
    ii. Select the following day’s date for the Due by: selection.
    iii. Click OK.
  • For Outlook 2007:
    i. Click the flag button in the toolbar.
    ii. Select tomorrow from the drop-down menu.
    iii. Close the email message.

60. Double-click message 13, forward it to Test2 Tester, and close the message.
61. Arrange the email messages in the inbox by conversation: ViewÆArrangeByÆConversation.
62. Delete the fourth and fifth conversations by right-clicking the conversation, choosing Delete, and clicking Yes to delete.
63. Arrange the email messages in the inbox by date: ViewÆArrangeByÆDate.
64. Mark five items as completed:
  • For Outlook 2003:
    i. Click Tasks.
    ii. Double-click each item one at a time, change the status to Completed, and click Save and Close.
  • For Outlook 2007:
    i. Select five items listed in the To-Do Bar.
    ii. Right-click those items, and select Mark Complete from the list of choices (or Follow upÆMark Complete).
65. Add a new task for today:
  • For Outlook 2003:
    i. Click Tasks.
    ii. Right-click anywhere in the Tasks section, and select New Task.
    iii. Type New task for today in the Subject, and click Save and Close.
  • For Outlook 2007:
i. With the To-Do Bar open, right-click anywhere in the lower section of the To-Do Bar, and select New Task.
ii. Type New task for today in the Subject, and click Save and Close.

66. Search for the word workplan in Folder1:
   • For Outlook 2003:
     i. Select Folder1.
     ii. Click Find.
     iii. Type workplan into the Look For field.
   • For Outlook 2007:
     i. Select Folder1.
     ii. Type workplan into the Search Folder1 field.

67. Forward the third search result to Test2 Tester (replacing the name already there).
68. Press Send.
69. Clear the Search results.
70. Select Folder3.
71. Arrange the email messages in Folder3 by from: View → Arrange By → From.
72. Move the Folder3 slider halfway down.
73. Select an email message, and pause around 2 seconds to read it in the Reading Pane.
74. Read the next five messages in the Reading Pane by moving to each in succession using the down arrow, and pausing at each for around 2 seconds each.
75. Perform an incremental synchronization of 10 email messages:
   a. Click the Connected to Microsoft Exchange status message in the lower right corner of Outlook.
   b. Select Work offline.
   c. Send 10 messages to Test Tester from a third system.
   d. Click the Offline status message, and deselect Work offline.
76. Search for a message (thousands of results - All Mail):
   • For Outlook 2003:
     i. Select Search All Mail Folders.
     ii. Type Workplan into the Look For field.
   • For Outlook 2007:
     i. Click the drop-down menu in the Search Inbox field of Windows Desktop Search 4.0, located in the upper-right corner of the message list.
     ii. Select Search All Mail Items.
     iii. Type Workplan into the Search All Mail Items field.
77. Forward the third search result to Test2 Tester (replacing the name already there).
78. Press Send.
79. Clear the Search results.
80. Select the inbox.
81. Read the first five unread email messages in the Reading Pane by selecting each in succession using the mouse, and pausing at each for around 2 seconds each.
82. Mark the first two of these messages for follow-up:
   • For Outlook 2003:
     i. Right-click both messages, and select Follow Up.
     ii. Select the red flag.
   • For Outlook 2007:
     i. Right-click both messages, and select Follow Up.
     ii. Select Tomorrow.
83. Select the next three messages, and move them to Folder 3 by dragging and dropping them.
84. Select the next email message.
85. Click Reply to create a reply to the currently open email.
86. Type Thanks in the body of the message, and press Send.
87. Close Outlook by clicking the red X in the upper-right corner.
88. Stop the timer.
89. Stop the trace by typing xperf.exe –stop in the command prompt window.
90. Reset the server with the Outlook 2007 SP1 250MB test image and the system with the base Outlook 2007 SP1 image, and repeat steps 2 through 75.

91. Reset the server with the Outlook 2007 SP2 250MB image and the system with the base Outlook 2007 SP2 image, and repeat steps 2 through 75.

92. Reset the server with the Outlook 2003 SP3 5GB test image and the system with the base Outlook 2003 SP3 image, and repeat steps 2 through 75.

93. Reset the server with the Outlook 2007 SP1 5GB image and the system with the base Outlook 2007 SP1 image, and repeat steps 2 through 75.

94. Reset the server with the Outlook 2007 SP2 5GB test image and the system with the base Outlook 2007 SP2 image, and repeat steps 2 through 75.
Appendix A—Test system configurations

Figure 28 provides detailed configuration information about each of the desktop and notebooks systems we used to conduct our tests of Outlook. Figure 29 provides detailed configuration information about the Exchange server we used.

<table>
<thead>
<tr>
<th>System</th>
<th>Dell OptiPlex 755 Intel Core 2 Duo E4500 2.20 GHz</th>
<th>Lenovo ThinkPad T61 Intel Core 2 Duo T7100 1.8 GHz</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Processor and OS kernel:</td>
<td>1P2C2L/MP</td>
<td>1P2C2L/MP</td>
</tr>
<tr>
<td>(physical, core, logical)/(UP, MP)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Number of physical processors</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>Single/Dual/Quad-Core processors</td>
<td>Dual</td>
<td>Dual</td>
</tr>
<tr>
<td>System Power Management Policy</td>
<td>Balanced</td>
<td>Energy Star</td>
</tr>
<tr>
<td>Processor power-saving option</td>
<td>Enhanced Intel SpeedStep Technology</td>
<td>Enhanced Intel SpeedStep Technology</td>
</tr>
<tr>
<td>System dimensions (length x width x height)</td>
<td>NA</td>
<td>13 1/4&quot; x 10 1/2&quot; x 1 1/4&quot;</td>
</tr>
<tr>
<td>System weight</td>
<td>NA</td>
<td>5 lbs. 7 oz.</td>
</tr>
<tr>
<td><strong>CPU</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vendor</td>
<td>Intel</td>
<td>Intel</td>
</tr>
<tr>
<td>Name</td>
<td>Core 2 Duo</td>
<td>Core 2 Duo</td>
</tr>
<tr>
<td>Model number</td>
<td>E4500</td>
<td>T7100</td>
</tr>
<tr>
<td>Stepping</td>
<td>D</td>
<td>D</td>
</tr>
<tr>
<td>Socket type and number of pins</td>
<td>Socket LGA775</td>
<td>Socket P</td>
</tr>
<tr>
<td>Core frequency (GHz)</td>
<td>2.20</td>
<td>1.8</td>
</tr>
<tr>
<td>Front-side bus frequency (MHz)</td>
<td>800</td>
<td>800</td>
</tr>
<tr>
<td>L1 cache</td>
<td>32 KB + 32 KB (per core)</td>
<td>32 KB + 32 KB (per core)</td>
</tr>
<tr>
<td>L2 cache</td>
<td>2 MB</td>
<td>2 MB (shared)</td>
</tr>
<tr>
<td><strong>Platform</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Motherboard model number</td>
<td>0PU052</td>
<td>7658CTO</td>
</tr>
<tr>
<td>Motherboard chipset</td>
<td>Intel Q35</td>
<td>Intel GM965</td>
</tr>
<tr>
<td>Motherboard revision number</td>
<td>A2</td>
<td>C0</td>
</tr>
<tr>
<td>System/motherboard serial number</td>
<td>CN7443182O3DBF</td>
<td>L3-D5889</td>
</tr>
<tr>
<td>BIOS name and version</td>
<td>Dell A12</td>
<td>7LET5WW(2.25)</td>
</tr>
<tr>
<td>BIOS settings</td>
<td>Default</td>
<td>Default</td>
</tr>
<tr>
<td><strong>Memory module(s)</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vendor and model number</td>
<td>2 x 1,024 MB Hyundai Electronics HYMP112U64CP8-Y5</td>
<td>2 x 1,024 Samsung M470T2953EZ3-CE6</td>
</tr>
<tr>
<td>Type</td>
<td>PC2-5300</td>
<td>PC2-5300</td>
</tr>
<tr>
<td>Speed (MHz)</td>
<td>667</td>
<td>667</td>
</tr>
</tbody>
</table>
| System                                  | Dell OptiPlex 755
|                                        | Intel Core 2 Duo E4500
|                                        | 2.20 GHz                      | Lenovo ThinkPad T61
<p>|                                        | Intel Core 2 Duo T7100       | 1.8 GHz                      |
| Speed running in the system (MHz)       | 667                           | 333                           |
| Timing/latency (tCL-tRCD-tRP-tRASmin)   | 5-5-5-15                      | 5-5-5-15                      |
| Size (MB)                               | 2,048                         | 2,048                         |
| Number of memory module(s)              | 2 x 1,024 MB                  | 2 x 1,024 MB                  |
| Chip organization (single-sided,       | Single-sided                  | Double-sided                  |
| double-sided)                           |                               |                               |
| Channel (single/dual)                   | Dual                          | Dual                          |
| Hard disk                               |                               |                               |
| Vendor and model number                 | WDC WD800JD-75MSA3            | Hitachi HTS541680J9A00        |
| Size (GB)                               | 80                            | 80                            |
| Buffer Size (MB)                        | 8                             | 8                             |
| RPM                                     | 7,200                         | 5,400                         |
| Type                                    | SATA 3.0 Gb/s                 | SATA 1.5 Gb/s                 |
| Controller                              | Intel ICH9                    | Intel ICH8-M                  |
| Driver                                  | Intel 8.3.0.1008              | Intel 8.2.0.1011               |
| Operating system                        |                               |                               |
| Name                                    | Windows Vista Enterprise SP1  | Windows Vista Enterprise SP1  |
| Build number                            | 6.1.6001                      | 6.1.6001                      |
| File system                             | NTFS                          | NTFS                          |
| Kernel                                  | ACPIx86-based PC              | ACPIx86-based PC              |
| Language                                | English                       | English                       |
| Microsoft DirectX version                | DirectX 10                    | DirectX 10                    |
| Graphics                                |                               |                               |
| Vendor and model number                 | Intel GMA 3100                | Intel GMA X3100                |
| Type                                    | Integrated                    | Integrated                    |
| Chipset                                 | Intel Q35 Express Chipset     | Intel 965 Express Chipset     |
| BIOS version                            | 1459                          | 1436                          |
| Total available graphics memory (MB)     | 287                           | 358                           |
| Dedicated video memory (MB)              | 0                             | 0                             |
| System video memory (MB)                | 128                           | 128                           |
| Shared system memory (MB)               | 159                           | 230                           |
| Resolution                              | 1,280 x 1,024                 | 1,280 x 800                   |
| Sound card/subsystem                    |                               |                               |
| Vendor and model number                 | SoundMAX Integrated Digital   | SoundMAX Integrated Digital   |
|                                        | HD Audio                      | HD Audio                      |
| Driver                                  | AnalogDevices 6.10.1.5491     | Analog Devices 6.10.1.5510    |
|                                        | (8/3/2007)                    |                               |
| Ethernet                                |                               |                               |
| Vendor and model number                 | Intel 82566DM-2 Gigabit       | Intel 82566MM Gigabit         |
|                                        | Network Connection            |                               |
| Driver                                  | Microsoft 9.11.5.7 (6/21/2006)| Intel 9.7.255.0 (3/5/2008)    |
| Wireless                                |                               |                               |
| Vendor and model number                 | NA                            | Intel PRO/Wireless 3945ABG    |</p>
<table>
<thead>
<tr>
<th>System</th>
<th>Dell OptiPlex 755</th>
<th>Lenovo ThinkPad T61</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Intel Core 2 Duo E4500 2.20 GHz</td>
<td>Intel Core 2 Duo T7100 1.8 GHz</td>
</tr>
<tr>
<td>Driver</td>
<td>NA</td>
<td>Intel 11.5.0.36</td>
</tr>
<tr>
<td><strong>Optical drive(s)</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Vendor and model number</td>
<td>Sony CRX880A</td>
<td>Matshita UJDA775</td>
</tr>
<tr>
<td>Type</td>
<td>CD-RW/DVD-RW</td>
<td>DVD-ROM/CD-RW</td>
</tr>
<tr>
<td><strong>USB ports</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Number</td>
<td>8</td>
<td>3</td>
</tr>
<tr>
<td>Type</td>
<td>2.0</td>
<td>2.0</td>
</tr>
<tr>
<td><strong>IEEE 1394 ports</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Number</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td><strong>Monitor/Display</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Type</td>
<td>ViewSonic Optiquest Q7b</td>
<td>WXGA</td>
</tr>
<tr>
<td>Screen size (inches)</td>
<td>17</td>
<td>14.1</td>
</tr>
<tr>
<td>Refresh rate (Hz)</td>
<td>60</td>
<td>60</td>
</tr>
<tr>
<td><strong>Battery</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Type</td>
<td>NA</td>
<td>42T5229 Lithium Ion</td>
</tr>
<tr>
<td>Size (length x width x height)</td>
<td>NA</td>
<td>8 3/4&quot; x 2 3/4&quot; x 3/4&quot;</td>
</tr>
<tr>
<td>Rated capacity</td>
<td>NA</td>
<td>5200mAh/10.8V (56Wh)</td>
</tr>
<tr>
<td>Weight</td>
<td>NA</td>
<td>13 oz.</td>
</tr>
</tbody>
</table>

Figure 28: Detailed system configuration information for the two test systems.
<table>
<thead>
<tr>
<th>Server</th>
<th>HP ProLiant DL320 1U Rack Server G3</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General</strong></td>
<td></td>
</tr>
<tr>
<td>Processor and OS kernel: (physical, core, logical)/(UP, MP)</td>
<td>1P1C2L/MP</td>
</tr>
<tr>
<td>Number of physical processors</td>
<td>1</td>
</tr>
<tr>
<td>Single/Dual-Core processors</td>
<td>Single</td>
</tr>
<tr>
<td>System Power Management Policy</td>
<td>Balanced</td>
</tr>
<tr>
<td><strong>CPU</strong></td>
<td></td>
</tr>
<tr>
<td>Vendor</td>
<td>Intel</td>
</tr>
<tr>
<td>Name</td>
<td>Intel Pentium 4 650</td>
</tr>
<tr>
<td>Stepping</td>
<td>3</td>
</tr>
<tr>
<td>Socket type</td>
<td>775 LGA</td>
</tr>
<tr>
<td>Core frequency (GHz)</td>
<td>3.4</td>
</tr>
<tr>
<td>Front-side bus frequency (MHz)</td>
<td>800</td>
</tr>
<tr>
<td>L1 cache</td>
<td>16 KB + 12 K μops</td>
</tr>
<tr>
<td>L2 cache (MB)</td>
<td>2</td>
</tr>
<tr>
<td><strong>Platform</strong></td>
<td></td>
</tr>
<tr>
<td>Vendor</td>
<td>HP</td>
</tr>
<tr>
<td>Motherboard model number</td>
<td>374295-405</td>
</tr>
<tr>
<td>Motherboard chipset</td>
<td>Intel E7221 Chipset</td>
</tr>
<tr>
<td>Motherboard revision number</td>
<td>A03</td>
</tr>
<tr>
<td>Motherboard serial number</td>
<td>USE617N1VL</td>
</tr>
<tr>
<td>BIOS name and version</td>
<td>HP D18 (08/16/2005)</td>
</tr>
<tr>
<td>BIOS settings</td>
<td>Default</td>
</tr>
<tr>
<td><strong>Memory module(s)</strong></td>
<td></td>
</tr>
<tr>
<td>Vendor and model number</td>
<td>Micron MT18VDDT12872AG-40BD1</td>
</tr>
<tr>
<td>Type</td>
<td>PC3200</td>
</tr>
<tr>
<td>Speed (MHz)</td>
<td>400</td>
</tr>
<tr>
<td>Speed in the system currently running @ (MHz)</td>
<td>200</td>
</tr>
<tr>
<td>Timing/latency (tCL-tRCD-iRP-tRASmin)</td>
<td>3-3-3-8</td>
</tr>
<tr>
<td>Size (MB)</td>
<td>2,048</td>
</tr>
<tr>
<td>Number of RAM modules</td>
<td>2</td>
</tr>
<tr>
<td>Chip organization</td>
<td>Double-sided</td>
</tr>
<tr>
<td>Channel</td>
<td>Single</td>
</tr>
<tr>
<td><strong>Hard disk</strong></td>
<td></td>
</tr>
<tr>
<td>Vendor and model number</td>
<td>Maxtor 6L160M0</td>
</tr>
<tr>
<td>Number of disks in system</td>
<td>2</td>
</tr>
<tr>
<td>Size (GB)</td>
<td>160</td>
</tr>
<tr>
<td>Buffer size (MB)</td>
<td>8</td>
</tr>
<tr>
<td>RPM</td>
<td>7,200</td>
</tr>
<tr>
<td>Type</td>
<td>SATA</td>
</tr>
<tr>
<td>Controller</td>
<td>Intel 82801FB Ultra ATA Storage</td>
</tr>
<tr>
<td>Controller driver</td>
<td>Microsoft 6.0.6001.18000 (06/21/2006)</td>
</tr>
<tr>
<td><strong>Operating system</strong></td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Microsoft Windows Server 2008 Enterprise without Hyper-V x64</td>
</tr>
<tr>
<td>Build number</td>
<td>6001</td>
</tr>
<tr>
<td>Service Pack</td>
<td>SP1</td>
</tr>
<tr>
<td>File system</td>
<td>NTFS</td>
</tr>
</tbody>
</table>
### System Information

<table>
<thead>
<tr>
<th>Server</th>
<th>HP ProLiant DL320 1U Rack Server G3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Kernel</td>
<td>ACPI x64-based PC</td>
</tr>
<tr>
<td>Language</td>
<td>English</td>
</tr>
<tr>
<td>Microsoft DirectX version</td>
<td>10</td>
</tr>
<tr>
<td><strong>Graphics</strong></td>
<td></td>
</tr>
<tr>
<td>Vendor and model number</td>
<td>ATI MACH64</td>
</tr>
<tr>
<td>BIOS version</td>
<td>01.00</td>
</tr>
<tr>
<td>Type</td>
<td>Integrated</td>
</tr>
<tr>
<td>Memory size</td>
<td>8 MB shared</td>
</tr>
<tr>
<td>Resolution</td>
<td>800 x 600</td>
</tr>
<tr>
<td>Driver</td>
<td>Microsoft 6.0.6001.18000 (06/21/2006)</td>
</tr>
<tr>
<td><strong>Network card/subsystem</strong></td>
<td></td>
</tr>
<tr>
<td>Vendor and model number</td>
<td>Broadcom NetXtreme Gigabit Ethernet</td>
</tr>
<tr>
<td>Type</td>
<td>Integrated</td>
</tr>
<tr>
<td>Driver</td>
<td>Microsoft 10.10.0.1 (08/01/2006)</td>
</tr>
<tr>
<td><strong>Optical drive</strong></td>
<td></td>
</tr>
<tr>
<td>Vendor and model number</td>
<td>Teac DW-224E-C</td>
</tr>
<tr>
<td>Type</td>
<td>DVD-ROM/CD-RW</td>
</tr>
<tr>
<td><strong>USB ports</strong></td>
<td></td>
</tr>
<tr>
<td>Number</td>
<td>3</td>
</tr>
<tr>
<td>Type</td>
<td>2.0</td>
</tr>
</tbody>
</table>

*Figure 29: Detailed system information for the Exchange server.*
Appendix B – Detailed results

Figure 30 presents the average systems response times, in hours:minutes:seconds, to complete email tasks for the three Outlook versions with 250MB and 5GB mailboxes.

<table>
<thead>
<tr>
<th>Test</th>
<th>Average system response time</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>250MB mailbox</td>
</tr>
<tr>
<td></td>
<td>Outlook 2003 SP3</td>
</tr>
<tr>
<td>Launch Outlook with Task View or To-Do Bar off</td>
<td>00:00:01.01</td>
</tr>
<tr>
<td>Launch reply to email while synchronizing</td>
<td>00:00:00.74</td>
</tr>
<tr>
<td>Launch reply to email after synchronization is complete</td>
<td>00:00:00.57</td>
</tr>
<tr>
<td>Launch new email while synchronizing</td>
<td>00:00:00.64</td>
</tr>
<tr>
<td>Launch new email after synchronization is complete</td>
<td>00:00:00.47</td>
</tr>
<tr>
<td>Launch new meeting request</td>
<td>00:00:00.42</td>
</tr>
<tr>
<td>Switch folder to Conversation arrangement</td>
<td>00:00:00.36</td>
</tr>
<tr>
<td>Switch folder to Date arrangement</td>
<td>00:00:00.28</td>
</tr>
<tr>
<td>Switch folder to From arrangement</td>
<td>00:00:00.31</td>
</tr>
<tr>
<td>Switch folder to Calendar arrangement</td>
<td>00:00:00.37</td>
</tr>
<tr>
<td>Close after synchronization is complete</td>
<td>00:00:01.41</td>
</tr>
<tr>
<td>Launch Outlook with Task View or To-Do Bar on</td>
<td>00:00:00.85</td>
</tr>
<tr>
<td>Synchronization time for new OST to completely download</td>
<td>00:02:06.76</td>
</tr>
<tr>
<td>Search for a message (200 or less - single folder)</td>
<td>00:00:04.59</td>
</tr>
<tr>
<td>Search for a message (thousands of results - single folder)</td>
<td>00:00:03.78</td>
</tr>
<tr>
<td>Search for a message (thousands of results - All Mail Items)</td>
<td>00:00:05.59</td>
</tr>
</tbody>
</table>

Figure 30: Average system response time, in hours:minutes:seconds, to complete a variety of email tasks for three Outlook versions with two mailbox sizes. Smaller numbers, reflecting quicker response times, are better.

Figure 31 presents the average number of disk writes during synchronization for the three Outlook versions with 250MB and 5GB mailboxes.

<table>
<thead>
<tr>
<th>Test</th>
<th>Average number of disk writes during synchronization</th>
</tr>
</thead>
<tbody>
<tr>
<td>250MB mailbox</td>
<td>5GB mailbox</td>
</tr>
<tr>
<td>Outlook 2003 SP3</td>
<td>Outlook 2007 SP1</td>
</tr>
<tr>
<td>Average number of disk writes during synchronization</td>
<td>6,233.80</td>
</tr>
</tbody>
</table>

Figure 31: Average number of disk writes during synchronization. Smaller numbers are better.
Figure 33 presents the response times for a series of 79 common tasks from a typical workday for the three Outlook versions with 250MB and 5GB mailboxes.

<table>
<thead>
<tr>
<th></th>
<th>250MB mailbox</th>
<th></th>
<th>5GB mailbox</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Outlook 2003 SP3</td>
<td>Outlook 2007 SP1</td>
<td>Outlook 2007 SP2</td>
<td>Outlook 2003 SP3</td>
</tr>
<tr>
<td>Step 1: Launch Outlook and sync mailbox</td>
<td>00:02:47.77</td>
<td>00:02:19.46</td>
<td>00:01:39.60</td>
<td>01:12:40.17</td>
</tr>
<tr>
<td>Steps 2-79: Remainder of workflow</td>
<td>00:20:07.52</td>
<td>00:15:30.49</td>
<td>00:13:06.53</td>
<td>00:20:30.04</td>
</tr>
<tr>
<td>Total</td>
<td>00:22:55.30</td>
<td>00:17:49.95</td>
<td>00:14:46.13</td>
<td>01:33:10.20</td>
</tr>
</tbody>
</table>

Figure 33: Response times for a series of 79 common tasks from a typical workday. Smaller numbers are better.
About Principled Technologies
We provide industry-leading technology assessment services. We bring to every assignment extensive experience with and expertise in all aspects of technology testing and analysis, from research into new technologies, to the development of new methodologies, to testing with existing and new tools.

When the assessment is complete, we know how to present the results to a broad range of target audiences. We provide our clients with the materials they need, from market-focused data to use in their own collateral to custom sales aids, such as test reports, performance assessments, and white papers. Every document reflects the results of our trusted independent analysis.

We provide customized services that focus on our clients’ individual needs. Whether the technology involves hardware, software, Web sites, or services, we offer the experience, expertise, and tools to help you assess how it will fare against its competition, its performance, whether it’s ready to go to market, and its quality and reliability.

Our founders, Mark Van Name and Bill Catchings, have worked together in technology assessment for over 20 years. As journalists, they published over a thousand articles on a wide array of technology subjects. They created and led the Ziff-Davis Benchmark Operation, which developed such industry-standard benchmarks as Ziff Davis Media’s Winstone and WebBench. They founded and led eTesting Labs, and after the acquisition of that company by Lionbridge Technologies were the head and CTO, respectively, of VeriTest.