Principled
Technologies®

Responsiveness of Windows Vista' and
Windows XP" on common home tasks

Executive summary

Microsoft Corporation (Microsoft) commissioned Principled
Technologies (PT) to develop and run a set of tests that
compare the responsiveness of Windows Vista RTM and
Windows XP on common home tasks. The goal of the
tests was to provide buyers a sense of the differences in
the response time that users would experience when
performing the same home functions on each operating
system. We measured how responsive each operating
system was when performing a set of common home
operations after rebooting, returning from standby, and in
ongoing operation. We ran the tests on five systems:

Dell XPS 600 (desktop)

Dell XPS M170 (notebook)
Hewlett-Packard a1320y (desktop)
Hewlett-Packard d4100e (desktop)
Toshiba Tecra M4 (tablet)

KEY FINDINGS

® Windows Vista was noticeably more

responsive after rebooting than Windows XP
on several common home operations.

Overall, Windows Vista and Windows XP
were roughly equally responsive on most test
operations. When Windows Vista was
slower, it was typically less than a second
slower.

Windows Vista Aero had little effect on the
responsiveness of Windows Vista. Over 80
percent of the response-time differences
between tests we ran with and without Vista
Aero were under a tenth of a second, and the
majority were faster with Aero enabled.

Microsoft provided the test systems and test settings. PT set up the systems, specified and developed the tests
and test procedures, and executed all the tests. We ran all the tests on the final version of Windows Vista
Ultimate, the one that Microsoft recently released to manufacturing (RTM). We also ran the same tests on one
system with and without Windows Vista Aero to get a sample of the effect of that user interface on Windows

Vista's response time.
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Figure 1: Average response-time improvements of Windows Vista over Windows XP on a variety of operations on five
systems in a cold state. Numbers above zero indicate Windows Vista was more responsive. Differences of more than a
second are outside the yellow band. We provide a description of each of those operations.




Figure 1 compares the performance of the two operating systems on five systems on over thirty common home
operations in three typical home computing projects. Each bar represents the average of the differences in
response time between Windows Vista and Windows XP. The bars appear in the order in which the operations
appear in the scenarios, which we detail below. Bars above the 0.00 midline indicate tests in which Windows
Vista was faster; bars below that line mark those tests on which Windows XP was faster. The yellow band
contains all differences that were less than a second; we believe most users would not notice such small
differences in performance times.

We could not label the individual operations in Figure 1 or Figure 2 due to space constraints. We instead called
out the most significant response time differences. We also labeled them all in the Test results section and in the
Detailed test results appendix.

As you can see in Figure 1, Windows Vista was slower than Windows XP on just under 60 percent of the
operations in a cold state, though half of those differences were under a tenth of a second. On a few operations,
notably the launch of Quicken and finding and marking all transactions in Quicken, Windows Vista was
dramatically more responsive.

To execute these operations, we ran a test script we developed to execute on both Windows Vista and Windows
XP. Each bar on the X-axis in Figure 1 represents the difference in performance between Windows Vista and
Windows XP on one operation. We used a Microsoft-supplied utility, ScenCap, to script these operations.
ScenCap is an application that uses the Windows accessibility interfaces to create and replay scenarios
containing user actions.

We tested the response time of the test systems in two different states:

e cold: the state of a system after rebooting or after a program or set of programs has performed enough
RAM and disk operations to make the operating system have to reload any test application before it can
run that application. To execute these tests, the test script rebooted the systems, waited 120 seconds,
and then began the timed operations.

e warm: the state of a system after it has already run a set of programs, possibly after returning from
standby. To execute these tests, the test script ran a second time after returning from standby and then a
third time immediately afterwards.

We averaged the two different types of warm test results for Windows Vista and Windows XP and compared them
in Figure 2. As it shows, almost all of the differences were under a second, and most were under half of a second.
Four operations—opening Acrobat, launching Quicken, launching Word, and previewing a page in Word--were
more than a second slower on Windows Vista.

The over thirty operations come from a realistic home scenario that we created and scripted. This scenario covers
part of the day of the three members of the Forrester family, who share a family PC in the den. Gail Forrester is
an IT manager in charge of a network security group. Her husband, Doug, is a middle school social studies
teacher. They have one child, 11-year old Sonny, who is in the 6" grade. Gail has a company notebook PC that
she uses for business; she uses the computer in the den mainly for managing family finances. Doug and Sonny
use the home computer exclusively.

The scenario includes the following projects, each of which involves a different member of the family. For ease of
reference, we refer to these projects by name (e.g., Project 1) elsewhere in this report.

« Project 1: Doug handles email related to his soccer coaching responsibilities.
o Project 2: Gail updates and reviews the family financial records and bills.
« Project 3: Sonny works on a Web page for a language arts project.

Each of these projects involves a number of basic operations, such as opening, editing, and closing files. The
results of the scenario are the response times for each of these tasks. The number of timed operations in each
project ranges from 9 to 12 and depends on the complexity of the project. We used realistic operations and
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content for all tests. The Scenario descriptions section provides more details on each project, the files it uses, and

the operations we timed.
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Figure 2: Average response-time improvements of Windows Vista over Windows XP on a variety of operations on five

systems after continuous operation. Numbers above zero indicate Windows Vista was more responsive. Differences of more

than a second are outside the yellow band. We provide a description of each of those operations.
On four of the five test systems, Windows Vista Aero was active by default. We chose one of the systems to
examine the impact of Windows Vista Aero on performance. Our results showed that Windows Vista Aero had
little or no negative effect on Windows Vista's performance. Most of the 93 measurements (31 measurements in
each of the cold, warm, and hot states, with each measurement being the average of five runs) showed only slight
differences between running with Windows Vista Aero on or off. Over 80 percent differed by less than a tenth of a
second. Almost two-thirds were faster with Windows Vista Aero enabled.

Our goal in this report is to examine the performance characteristics of the two versions of Windows, not the
differences among systems. So, though all five systems were shipping units whose configurations we detail in

E

Appendix A, we refer to them in the bulk of the report as System A, System B, System C, System D, and System
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Test results

In the following subsection, we examine the test results by project and with Windows Vista Aero on and off. The
Project results subsection reduces the number of operations in each chart so that we can view them by name in
those charts. The Windows Vista Aero results subsection looks at the differences on one system with Windows
Vista Aero on and off. Appendix C contains a table of the average time for each operation on each system.

Each result we report for a system is the average of five runs on that system. Before conducting the timed runs on
a given PC and operating system combination, we ran the same workload three times on that system. We did so
to allow each operating system to "learn" and, if it could do so, to tune itself for the work it would be facing. This
approach allowed us to mimic what would occur on many users' PCs over the first few days they use their
systems (and after each time they introduce a new application into their work mix). See the Test methodology
section for more details on how we conducted the tests.

Project results

The following figures show the results in a cold state and after continuous operation for each of the three projects.
In each figure, the operations appear in the order in which they occurred in the project. We first look at the cold
results.

Cold results

Figure 3 shows the cold results of Project 1. The Outlook launch was a win for Windows Vista, with Windows
Vista averaging slightly more than a second faster than Windows XP on this operation. The other nine operations
in this project showed minimal response-time differences between Windows Vista and Windows XP, with five of
the differences within a tenth of a second and all within about a third of a second.
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Figure 3: Average response-time differences between Windows Vista and Windows XP on a variety of operations in Project 1 on
five systems when in a cold state. Differences of more than a second are outside the yellow band.
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Figure 4 shows the cold state results of Project 2. The launch of Quicken and the Quicken mark all task were
significantly faster on Windows Vista than on Windows XP. None of the other operations performed noticeably
differently on Windows Vista and Windows XP.
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Figure 4: Average response-time differences between Windows Vista and Windows XP on a variety of operations in Project 2
on five systems when in a cold state. Differences of more than a second are outside the yellow band.
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Figure 5 shows the cold results of Project 3. Average response-time differences between Windows Vista and
Windows XP were all under a second on the operations in this project. The Word launch averaged just under a
second slower on Windows Vista than on Windows XP,
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Figure 5: Average response-time differences between Windows Vista and Windows XP on a variety of operations in Project 3 on
five systems when in a cold state. Differences of more than a second are outside the yellow band.
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Warm results

Figure 6 shows the continuous operation (warm, after return from standby, and after a previous run) results of
Project 1. The open of Acrobat from within Outlook was over one second slower on Windows Vista than on
Windows XP. None of the other operations performed noticeably differently on Windows Vista and Windows XP.
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Figure 6: Average response-time differences between Windows Vista and Windows XP on a variety of operations in Project 1 on
five systems when in a warm state. Differences of more than a second are outside the yellow band.
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Figure 7 shows the continuous operation results of Project 2. Launching Quicken was just over a second slower
on Windows Vista than on Windows XP. None of the other operations performed noticeably differently on
Windows Vista and Windows XP.
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Figure 7: Average response-time differences between Windows Vista and Windows XP on a variety of operations in Project 2 on
five systems when in a warm state. Differences of more than a second are outside the yellow band.
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Figure 8 shows the continuous operation results of Project 3. Word launch and Word Web page preview were
over a second slower on Windows Vista than on Windows XP. None of the other operations performed noticeably
differently on Windows Vista and Windows XP.
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Figure 8: Average response-time differences between Windows Vista and Windows XP on a variety of operations in Project 3 on
five systems when in a warm state. Differences of more than a second are outside the yellow band.
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Aero results

We chose one of the systems to examine the impact of Windows Vista Aero on performance. Our results showed
that Windows Vista Aero had little or no negative effect on Windows Vista's performance. Most of the 93
measurements (each the average of five runs) showed only slight differences between running with Windows
Vista Aero on or off. Over 80 percent differed by less than a tenth of a second. Almost two-thirds were faster with
Windows Vista Aero enabled. Of those that were slower with Windows Vista Aero enabled, only 6 were more than
a tenth of a second slower and only one was more than a half second slower. None was over a second slower
with Windows Vista Aero enabled. Figure 9 shows the frequencies of each time difference. See Appendix C for
complete results.

Time <-0.4 -0.4 -0.3 -0.2 -0.1 0.0 0.1 0.2 0.3 0.4 >04

Frequency 1 1 1 3 28 0 49 3 6 0 1

Figure 9: Frequency of response-time differences, in seconds, on the Windows Vista Aero tests on one system. Numbers above 0.0
indicate that running with Windows Vista Aero was faster; those below 0.0 indicate that running with Windows Vista Aero off was
faster.

These numbers indicate that almost all of the differences were small. Most differences actually favored running
with Windows Vista Aero on rather than off.
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Scenario descriptions

This home scenario covers part of the day of various members of the Forrester family, who share a family PC in
the den. Gail Forrester is an IT manager in charge of a network security group. Her husband, Doug, is a middle
school social studies teacher. They have one child, 11-year old Sonny, who is in the 6" grade. Gail has a
company notebook PC that she uses for business; she uses the computer in the den mainly for managing family
finances. Doug and Sonny use the home computer exclusively. This scenario includes the following projects,
each of which involves a different member of the family:

e Doug handles email related to his soccer coaching responsibilities.
e Gail updates and reviews the family financial records and bills.
e Sonny works on a Web page for a language arts project.

Each of these projects involves a number of basic tasks, such as opening, editing, and closing files. The results of
the scenario will be times for each of these tasks.

For each of the family member’s projects, we include a short title, a brief summary of the story behind the project,
a list of the applications the person uses in that task, a description of the content we propose to use, and a list of
operations we timed.

The number of operations in each project ranges from 9 to 12 and depends on the complexity of the project.
Project 1: Doug handles emails related to his soccer coaching responsibilities

Story summary

Doug is Sonny’s coach in the county soccer league. The league staff sent Doug a copy of the team roster. Doug
creates an email message for the team parents. He attaches to that message the roster and a picture of two
members of the team practicing. Another email message from the league includes a PDF that outlines rules for
the upcoming soccer tournament. He opens that PDF.

Applications
e Microsoft Outlook 2003
e Microsoft Word 2003
e Adobe Acrobat Reader 7

Content
e Microsoft Outlook 2003: two messages (one Doug creates, and one he reads; the latter has an
attachment) in an approximately 110MB Outlook database).
e Microsoft Word 2003: a 1 — 2 page Word document listing team members and contact information.
e Adobe Acrobat Reader 7: a 60KB — 90KB PDF document of soccer rules.
¢ Image: an approximately 1MB JPEG image of a moment from a soccer practice.

Timed operations

1. Doug opens Outlook. We time the open.

2. He reads a message from the soccer league. The message has a Word attachment. To open the
attachment, he right-clicks the message, selects View—>Attachments, and selects the attachment. We
time the document open.

3. In Word, he adds the team's name, the Panthers, to the roster title and selects File>Exit. When Word
asks if he wants to save the changes, he clicks Yes, names the file “2006 Panthers Team Roster” (we
append a random number to the name so that he saves the file to a unique name each time), and clicks
Save. We time the combined save and exit.

4. In Outlook, Doug clicks New to create a new mail message. We time the message creation.

5. He addresses the message to the soccer parents and types a short message. He selects Insert->File,
browses to the Word file he just saved, selects it, and clicks Insert. We time the attachment.
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6. He clicks the selects Insert->File button again, browses to the JPEG image, clicks it, and clicks Insert. We
time the attachment.

7. He selects Send File>Exit. When Outlook asks if he wants to save the message, he selects No. (We
select No here because we want the Outlook database to stay the same for each run.)

8. In Outlook, he scrolls down to the message that has a PDF attachment of the tournament rules. To open
the attachment, he right-clicks the message, selects View—>Attachments, and selects the attachment. We
time the Acrobat open.

9. He selects File>Exit to exit from Adobe Acrobat. We time the exit.

10. He selects File>Exit to exit from Outlook. We time the exit.

Project 2: Gail updates and reviews the family financial records

Story summary

Gail wants to catch up on the family's financial records. She adds paycheck information to her Quicken files,
reconciles her checkbook with her Quicken records, edits her records, looks at monthly spending reports, and
finally saves the report in PDF format. She also wants to track payments for Sonny’s upcoming orthodontia
separately from the ongoing payments for Katie’s orthodontia; to make that task easier, she decides to edit the
past orthodontia records to include Katie’s name. She makes an edit to the payee information on past orthodontia
records. Quicken backs up its data files when Gail exits.

Applications
e Quicken Deluxe 2006

Content
e Quicken Deluxe 2006: an approximately 6MB Quicken database.

Timed operations

1. Gail opens Quicken. We time the open.

2. Quicken shows several overdue scheduled transactions, including Gail’s paycheck. She clicks the Enter
button for the paycheck. The Edit Current Paycheck and Enter into Register dialog shows the correct
information for the paycheck, so she clicks Enter. We time the register entry operation.

3. She selects Cash Flow->Reconcile. She puts the ending balance from her checkbook into the Statement
Summary: Checking dialog and presses OK. The Statement Summary: Checking report shows a balance
that matches her checkbook balance. She clicks Mark All. We time that process. She clicks Finished.

4. She clicks Find & Replace. On the Find and Replace dialog, she types “orthodontist” in the Find field, and
clicks Find All. She selects Mark All, leaves payee selected as the selected field, types “Katie’s
Orthodontist” as the replacement value, and clicks Replace. We time the replacement operation. She
clicks Done to return to the Monthly Budget window. She clicks the Close button to close the Monthly
Budget window.

5. Gail selects Reports—>Graphs—>Spending by category. We time the appearance of the report. She clicks
the Close button and the Don’t Save button.

6. She selects Reports—>Spending—-> Current Spending vs. Average Spending by Category. She clicks Print
Report. On the Print dialog, she selects Quicken PDF Printer on LPT1: as the printer, checks Print in
color, and clicks OK. On the Save to PDF File dialog, she types “September 2006 spending” (we append
a random number to the name so that she saves the file to a unique name each time) and clicks Save.
We time the print. She clicks the close button.

7. She selects Reports> Spending->Budget. In the Column pull-down, she selects Two weeks. We time the
appearance of the report.

8. She selects File>Backup. She gives the path to the Quicken database as the path to the backup folder
and clicks OK to start the backup. We time the backup. She clicks OK on the message box that says that
the backup was successful.

9. She selects File>Exit. We time the exit.

Project 3: Sonny works on a Web page for a language arts project
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Story summary

Sonny is making a Web page for a language arts project on animals. His teacher has required that the project
include a short book report on a novel featuring the animal, information on the scientific classification of the
animal, and at least two photos of the animal. Sonny chose the jaguar as his animal and has written a report
about Jaguar, a novel by Roland Smith. He has included the report and the other required elements in a Word
document. Because he will get extra credit for additional elements on the Web page, he plans to add a WordArt
title to the page as well as 2 more images of jaguars and an audio file of a jaguar roar that he found on a public-
domain Web site. In this scenario, he opens the Word document, adds these additional elements, does a Web
page preview, and saves the file as a Web page.

Applications
e Microsoft Word 2003
o Internet Explorer 7 (IE)

Content
o Microsoft Word 2003: a 300KB — 400KB Word file.
e Images: two 800KB — 1000KB JPEG images of jaguars.
o Audio: a 43KB Wave sound file.

Timed operations

1. Sonny opens his Documents folder in Windows Explorer, browses to the Word document, and clicks
Enter to open it. We time the open.

2. He tabs to the second cell of the table he’s used to layout the page. There he selects
Insert->Picture>WordArt.... On the WordArt Gallery dialog, Sonny selects a brown WordArt design that
reminds him of Jaguar fur and clicks OK. In the Edit WordArt text dialog, he types “Jaguars” and clicks
OK. We time the appearance of the WordArt Gallery dialog. Because the WordArt insertion is effectively
instantaneous, we do not time it.

3. He tabs to the next blank cell, types “Press here to listen to a jaguar”. and selects Insert->Object. On the
Object dialog, he selects Create from file. We time the appearance of the Object dialog.

4. Sonny selects the Create from File tab on the Object dialog, locates and highlights the name of the audio
wave file of the jaguar roar, and clicks open. We time the wave file insertion.

5. He tabs to the next blank cell and selects Insert->Picture>From File. He highlights the name of one of
the Jaguar JPEG images he downloaded and clicks Insert. We time the insertion.

6. He selects Format->Picture and changes the height of the object to 25%. He clicks OK. We time the
resize.

7. Sonny repeats the insertion step with the next jaguar picture. We time the insertion.

8. He repeats the resize step with this picture. We time the resize.

9. He selects File>Web Page Preview to preview the page. We time the preview open.

10. He closes the IE window. In Word, Sonny selects File>Save as Web Page..., changes the Save as type
to Single File Web Page, and clicks Save. We time the save.

11. Sonny selects File>Exit to exit Word. We time the exit.

12. Sonny selects File>Exit to exit Windows Explorer. We time the exit.
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Test methodology

PT developed the scenarios and the test script we used for this evaluation. The script uses ScenCap to execute a
variety of common operations and runs on both Windows Vista and Windows XP. ScenCap is a Microsoft-
developed application that uses the Windows accessibility interfaces to create and replay scenarios containing
user actions. ScenCap also lets developers mark the start and end times of functions it performs.

Instructions for running the test script

This section details the steps you must follow to set up and run the test script, which we called PTVistaXPPerf.
We include instructions for running on both Windows Vista and Windows XP. For most functions the process is
the same on the two operating systems, but it is unavoidably sometimes slightly different.

Software this test requires
This test requires licensed copies of the following applications, which we list in alphabetical order. Testers must
install these applications on each test system:

Adobe Acrobat Reader 7.0.8

Intuit Quicken Deluxe Edition 2006

Microsoft Internet Explorer 7.0.5730.11 Version 7.0.5730.11 (Windows XP only)
Microsoft Office Professional Edition 2003

Microsoft Windows Vista Ultimate RTM (Build 6000)

Microsoft Windows XP Professional with Service Pack 2

In our tests, we used Symantec Norton Ghost 2003 to create sector-by-sector disk images of the systems after
we had installed the operating system and applications. We created one image for Windows Vista and one for
Windows XP for each test system. Before testing, we used Norton Ghost 2003 to restore the appropriate image to
the hard drive on the test system.

Hardware this test requires

All test systems must meet the Microsoft Windows Vista Ultimate RTM or Microsoft Windows XP Professional
with Service Pack 2 minimum requirements, as appropriate. In addition, each must have a network adapter and a
valid network path to the Web server.

We recommend that all machines under test have the latest available drivers for their particular hardware
configuration.

Setting up a system for test using these scripts

To get the most accurate and repeatable results possible, you must set up all test systems carefully, starting with
a clean hard disk. Each test system must be able to access the Internet during setup so it can download software
updates.

Installing Microsoft Windows Vista Ultimate
Use the following process to install a clean version of Windows Vista Ultimate with updated drivers and Windows
Updates on each system under test:

1. Install Windows Vista Ultimate Build 6000.

Boot to a Windows Vista Ultimate Build 6000 DVD.

When prompted to press any key to boot from CD or DVD, press any key.

At the language and preference screen, accept the default options, and click Next.

Click Install now.

Do not enter a Product key. Uncheck Automatically activate Windows when I’'m online, and click Next.
At the Do you want to enter your product key now screen, click No.

Select Windows Vista Ultimate, and check | have selected the edition of Windows that | purchased.
Click Next.

@ poo0oTw
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Check | accept the license terms, and click Next.

Select Custom (advanced) at the Which type of installation do you want screen.
Click Drive options (advanced).

Select the Disk you want to install Windows Vista Ultimate on, and click Format.
Click OK at the all data stored will be permanently deleted dialog.

Once the system finishes formatting the disk, click Next.

Leave the password blank. Type User in the Username field, and click Next.
Type a computer name, and click Next.

Click Use recommended settings.

Select the correct Time zone, date, and time, and click Next.

Click Public location at the Select your computer’s current location screen.
Click Start at the Thank you screen.

When the Windows Vista installation completes, close the Welcome Center Dialog.
Click Public location at the Set network location screen, and click Close.

llow active content and close the information bar dialog in Internet Explorer 7.0:

Open Internet Explorer 7.0.

Click on Tools—>Internet Options.

Click on the Advanced tab.

Under the Security section, check Allow active content to run in files on My Computer, and click OK.
Close Internet Explorer.

3. Disable Hide extensions for known file types and set up folders.

S@r0 a0 T

i.
j-
k.

On the desktop, click Start, Computer.

Select Organize->Folder and Search Options.

Select the View tab.

Uncheck Hide extensions for known file types.

Uncheck Use check boxes to select, if it is not already unchecked.

Check Show hidden files and folders.

Click OK.

Select Organize->Layout->Menu Bar. (Note: When you finish, the Menu Bar should appear on the
folder view.)

In the address bar, type C:\ and press Enter.

The script will not run if the Folder view is collapsed in the lower left-hand pane. If it is collapsed, click
the up arrow to reopen the Folder view.

Close the Explorer window.

Installing Microsoft Windows XP Professional with Service Pack 2
Use the following process to install Windows XP Professional with Service Pack 2 with updated drivers and
Windows Updates on each system under test:

1. Install Windows XP Professional with Service Pack 2.

T T oD@ o00TR

Boot to a Windows XP Professional with Service Pack 2 CD.

Press Enter at the Welcome to Setup screen.

Press F8 at the EULA screen.

Select the C: partition, and press Enter.

Select Format the partition using the NTFS file system (Quick), and press Enter.

Press F to format the selected partition.

Click Next at the Regional and Language Options screen.

Enter a user name into the Name field, leave Organization blank, and click Next.

Enter the Windows XP product key, and click Next.

Enter a Computer name, and click Next.

Enter the correct date, time, and time zone area, and click Next.

Select Typical settings, and click Next.

Select No, this computer is not on a network, or is on a network without a domain. Make this
computer a member of the following workgroup: leave the default workgroup, and click Next.
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After the installer reboots the system, click OK to have Windows automatically adjust the screen
resolution.

Click OK at the Can you see this text at this resolution dialog (before the timer gets to zero).
Click Next at the Welcome to Microsoft Windows screen.

Select Not right now at the Help protect your PC screen, and click Next.

Enter your username at the Who will use this computer? screen, and click Next.

Click Finish at the Thank you screen.

Install all High-Priority Updates from the Microsoft Updates site.
Download and install Internet Explorer 7.0 (IE7). Note: IE7 should be a part of the Windows Update

package. If it is already installed, skip to the next step to set up the Internet Explorer home page.

~0 a0 o
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Download IE7 from http://www.microsoft.com/windows/ie/downloads/default. mspx.

Double-click the IE7 executable.

Click Next at the welcome screen.

Click I Accept at the license agreement screen.

Click Validate at the validation screen.

Check Install the latest updates for Internet Explorer and the Microsoft Windows Malicious Software
Removal Tool, and click Next.

Click Restart Now at the installation complete screen.

etup Internet Explorer 7.0.

Open Internet Explorer 7.0.

At the Run Once page, check Keep my current default search provider, and click Save settings.
Click Go to your home page.

Check Turn off automatic Phishing Filter, and click OK.

Click on Tools—~>Internet Options.

Click on the Advanced tab.

Under the Security section, check Allow active content to run in files on My Computer, and click OK.
Close Internet Explorer.

sable Hide extensions for known file types.

On the desktop, click Start, My Computer.
Select Tools>Folder Options.

Select the View tab.

Uncheck Hide extensions for known file types.
Check Show hidden files and folders

Click OK.

Close My Compuiter.

6. Turn off Windows Service Pack 2 Security Center Pop-up Alerts. Doing so prevents such alerts from
occurring during testing and affecting results.

a.
b.

C.

d.
e.

f.

Open the system Control Panel.

Double-click Security Center.

Click Change the way Security Center Alerts me on the left.
Uncheck Firewall, Automatic Updates, and Virus Protection.
Click OK.

Close the Security Center main page.

7. Verify that Windows Automatic Updates are off. Turning off Windows Automatic Updates prevents such
updates from occurring during testing and affecting results. (We would have preferred to set the updates
to occur at a far future date, but we are not aware of an option for doing so.)

a. Click Start.
b. Right-click My Computer, and select Properties.
c. Select the Automatic Updates tab.
d. Select Turn off Automatic Updates.
e. Click OK.
a.
8. Turn off System Restore. Doing so prevents such events from occurring during testing and affecting
results.
a. Click Start.
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Right-click My Computer, and select Properties.

Select the System Restore tab.

Check the box to the left of Turn off System Restore on all drives.
Click OK.

~ooo0mo

Copying the Code and Content files to the system under test

1.
2.

Unzip the PTVistaXPPerf code and content file (PTVistaXPPerf.zip).
Copy the PTVistaXPPerf code and content folder (PTVistaXPPerf) to the C:\PTVistaXPPerf folder.

Installing Adobe Acrobat Reader 7.0.9
Use the following process to install Adobe Acrobat Reader 7.0.9 on both Windows Vista and Windows XP test
systems:

1.
2.

Download Adobe Acrobat Reader 7.0.9 from: http://www.adobe.com/products/acrobat/readstep2.html.
Install Adobe Acrobat Reader 7.0.9 with default settings.

Double-click the Adobe Acrobat Reader executable.

Click Next at the Setup screen.

Click Next at the Welcome screen.

Accept the default installation path and click Next.

Click Install.

Click Finish.

Set Adobe Acrobat Reader 7.0.9 to open PDFs from an Internet Explorer session only in the Acrobat
Reader.

Click Start>All Programs->Adobe Reader 7.0.

Click Accept at the License Agreement screen.

From the top menu, select Edit->Preferences.

Select the Internet category.

Uncheck Display PDF in browser.

Click OK.

Close Adobe Acrobat Reader.
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Installing Intuit Quicken Deluxe Edition 2006

Use the following process to install Intuit Quicken Deluxe Edition 2006 on both Windows Vista and Windows XP

test systems.

1.

For a downloaded software installation, double-click the Intuit Quicken Deluxe Edition 2006 installation

A warning screen will appear and ask if you are sure you want to turn off system restore. Click Yes.

executable (Quicken_Deluxe_for_Win_2006.exe) to begin installation. For a CD-based installation, insert

the CD.
a. Click Run at the Open File — Security Warning dialog.
b. Click Next at the Welcome to the InstallShield Wizard for Quicken 2006 dialog.

c. Click the | accept the terms in the license agreement radio button at the License Agreement dialog.

Doing this activates the Next button.

Click Next.

Accept the default installation path, and click Next at the Destination Folder dialog box.

Click Install at the Ready to Install the Program dialog.

Click Get updates at the Check for Quicken Updates dialog.

Leave the Launch Quicken 2006 box checked, and click Done at the Installation Complete dialog.

Se oo

After the installation is complete, begin the configuration by selecting the radio button next to | am already

a Quicken user at the Welcome to Quicken 2006 dialog.
a. Click Next.

b. Select the radio button next to Open a file located on this computer at the Select your data file dialog.

c. Click Next.
d. Select the Forrester.QDF database.

Principled Technologies, Inc.: Responsiveness of Windows Vista and
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e.

Click OK.

3. To register Intuit Quicken, do the following:

a.

Choose Help—>Register Quicken.

b. Fillin all required fields in the Quicken Registration form.

C.
d.
e.
Close Quicken.

If a dialog appears to backup the Quicken data, click Exit.
Double-click the Quicken Deluxe 2006 desktop icon.
Change the default backup settings.

a.

No ok

Click Register.
Click Skip Quicken.com registration at Step Two of the Quicken Registration form.
Click Finish at the final page of the Quicken Registration form.

Click Edit>Preferences—>Quicken Program.

b. Select Backup.

c.
d.

Change the Remind after running Quicken to 99 times.
Click OK

8. Click Reports—>Banking—>Banking Summary.

9. Atthe What's New popup, click Do not show this screen again.
10. Close the Banking Summary report screen by clicking the X.
11. Close Quicken.

Installing Microsoft Office Professional Edition 2003
Use the following process to install a clean version of Microsoft Office Professional Edition 2003 on both Windows
Vista and Windows XP test systems:

1. Insert the Microsoft Office Professional Edition 2003 CD.

Enter the Product Key, and click Next.

Enter User Information, and click Next.

Click the check box next to | accept the terms in the License Agreement on the End-User License
Agreement screen, and click Next.

Select Typical Install, accepting the default installation location, and click Next.

Click Install.

Click Finish at the Setup Completed screen.

9. Apply all high-priority Microsoft Office 2003 updates from the Microsoft Office update Web site.

10. After the Microsoft Office update process completes, reboot and re-run update for Microsoft Office to
verify that you have applied all available high-priority updates.

11. Open Excel to set up folders.

a.
b.

Click Start>All Programs—>Microsoft Office>Microsoft Office Excel 2003.
Close Microsoft Excel.

12. Copy the Microsoft Excel setup files to the proper folders.

a.

b.

On Windows Vista, copy C:\PTVistaXPPerf\benchmark\XLUSRGAL.XLS to
C:\Users\<User>\Appdata\Roaming\Microsoft\Excel.

On Windows XP, copy C:\PTVistaXPPerf\benchmark\ XLUSRGAL.XLS to C:\Documents and
Settings\User\Application Data\Microsoft\Excel.

Installing PTVistaXPPerf on the system under test
Use the following process to install PTVistaXPPerf on both Windows Vista and Windows XP test systems:

1. Prepare the Outlook Database:

a. Click Start->Computer (or Start>My Computer for Windows XP), and navigate to
C:\PTVistaXPPerf\benchmark\documents\outlook.
b. Right-click and delete Mail.pst if it exists.
c. Right-click Officemail.pst.
d. Click copy.
e. Press Cirl-v to create a copy of the file.
f.  Right-click the copy.
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g. Click Rename.
h. Enter Mail.pst, and press Enter.
i. Close the C:\PTVistaXPPerf\benchmark\documents\outlook folder by clicking the X in the upper right-
hand corner.
2. Bring up a command-line interface, which you will use to perform the rest of this installation.
a. On Windows Vista, click Start->All Programs->Accessories. Right-click Command Prompt-> Select
Run as Administrator to open the command-line interface window as Administrator.
b. On Windows XP, click Start>Run, and type cmd to open the command-line interface window.
Type cd\PTVistaXPPerf, and press Enter.
Type setup, and press Enter.
The test script will now install on the system.
The setup script reboots the system as the final setup step.
After the reboot, open Outlook, and set it to show the Advanced toolbar:
Open Outlook by clicking Start->All Programs—>Microsoft Office>Microsoft Office Outlook 2003.
Select View—>Toolbars.
Check Advanced.
n Windows XP, change the Power Options.
Click Start=>Control Panel.
Click Performance and Maintenance.
Click Power Options
Select the Advanced Tab.
Uncheck Prompt for password when computer resumes from standby.
Click OK.
Close the Performance and Maintenance window.
n Windows Vista, change the Power Options.
Click Start->Control Panel.
Click Hardware and Sound.
Click Power Options.
Under Preferred plans, High Performance, click Change plan settings.
Verify that Turn off the display: and Put the computer to sleep options are all set to Never. Note: if you
make changes to these settings, click Save changes, and then click Change plan settings under High
Performance.
Click Change advanced power settings.
g. Click the plus (+) sign next to Additional settings.
h. Change the Require a password on wakeup setting to No. If the machine is a laptop, change this
setting to No for both On battery and Plugged in.
i. Click OK.
j.  Click File>Close to exit the Edit Plan Settings dialog.
10. Set Microsoft Office Picture Manager as the default handler for JPG files.
e On Windows Vista:
a. Using Explorer, open the C:\PTVistaXPPerf\benchmark\Documents\Docs folder.
b. Right-click one of the JPG images in C:\PTVistaXPPerf\benchmark\Documents\Docs.
Select Open With->Choose Default Program.
On the Open With dialog, select Microsoft Office Picture Manager.
Check Always use the selected program to open this kind of file.
Select OK to confirm the default file types.
Close Microsoft Office Picture Manager.
e On Windows XP:
a. On the desktop, click Start, My Computer.
b. Select Tools>Folder Options.
c. Select the File Types tab.
d. Browse to JPG in the alphabetical list of extensions.
e. Click Change.
f
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On the Open With dialog, select Microsoft Office Picture Manager.
Check Always use the selected program to open this kind of file.
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h. Click OK.

i. Using Explorer, open the C:\PTVistaXPPerf\benchmark\Documents\Docs folder.

j- Right-click one of the JPG images in C:\PTVistaXPPerf\benchmark\Documents\Docs.
k. Select Open.

I.  Select OK to confirm the default file types.

m. Close Microsoft Office Picture Manager

11. On Windows Vista, verify that Windows Aero is the default color scheme by following these steps:

a. Right-click the desktop, and select Personalize.

b. Click Window Color and Appearance.

c. If an Appearance Settings dialog with a Color scheme drop-down appears, select Windows Aero
from the Color Scheme drop-down list, and press OK. If a Windows Color and Appearance dialog
displays, then Windows Aero is already the default Color Scheme.

Running the test script
Use the following process to run the test script on either Windows Vista or Windows XP test systems:

1.
2.

Reboot the system.

Bring up a command-line interface, which you will use to run the script.

a. On Windows Vista, click Start->All Programs—>Accessories. Right-click Command Prompt-> Select
Run as Administrator to open the command-line interface window as Administrator.

b. On Windows XP, click Start->Run, and type cmd to open the command-line interface window.

Type cd\PTVistaXPPerf, and press Enter.

Type run —p —results c:\results (to set the directory in which the tool will place its results), and press Enter.

To run the scenario type: run —i 1 —s 8 —ir 1 —nopurge 1 —wab 120 —scenariotype home —label

[MachineNameandQOS], and press Enter. (This command runs the Home scenario a total of 8 times: 1 run

after rebooting, 1 run after return from standby, and 1 run immediately after the previous run. It waits 120

seconds after an initial reboot before starting, does not purge memory, and identifies the results files with

MachineNameandOS.)

At the completion of the run, check the results in c:\results. Each set of results is in a separate

subdirectory there. A status.ixt file states whether the set of runs passed or failed. A log file gives

information about the run, including an error message for failed sets of runs. The IndividualRunCSV folder

includes a CSV file containing the results for the set of runs.
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Appendix A — Test system configurations

This appendix provides detailed configuration information about each of the test systems, which we list in
alphabetical order, and about the server we used to supply the test Web pages.

Dell XPS Toshiba Tecra
System M170 Dell XPS 600 HP a1320y HP d4100e M4
General
Processor and OS
kernel: (physical, 1P1CIL/UP | 1P2C2L/MP | 1P1C2L/MP | 1P2C2L/MP | 1P1CIL/UP
core, logical) / (UP,
MP)
Number of physical 1 1 y 1 1
processors
Single/Dual-Core Single Dual Single Dual Single
processors
Processor HT Status | NA NA Enabled NA NA
System Power . ; . . .
Management Policy ngfh H'?,fh H'?,fh ngfh H'?,fh
(Vista) performance performance performance performance performance
System Power . Minimal Power | Minimal Power | Minimal Power | Minimal Power | Minimal Power
Management Policy M t M t M M t M t
(XP) anagemen anagemen anagement anagemen anagemen
Notebook processor Enhanced Intel Enhanced Intel

oor Savﬁ] o | SpeedStep NA NA NA SpeedStep
P gop Technology Technology
Notebook dimensions | 15 %2 x 11 ¥z x 13x 11 x 1 %
(Length x Width x 2 (min) 12 NA NA NA (min) 12 (ma;)
Height) (max)
Notebook weight 8 Ibs. 10 oz. NA NA NA 6 Ibs. 2 oz.
CPU
System type Laptop Desktop Desktop Desktop Tablet PC
Vendor Intel Intel Intel AMD Intel
Name Pentium M 760 | Pentium D 940 | Pentium 516 /;gz)'gf 64 X2 | pentium M 740
Stepping 8 2 9 1 8
Socket type mPGA-479M LGA775 LGAT775 Socket 939 mPGA-479M
Core frequency
(GHz) 2.0 3.2 2.93 2.0 1.73
. 2000 MHz
Front-side bus 533 800 533 HyperTransport | 533
frequency (MHz)
Technology
L1 Cache 32KB +32KB | [OKB+12 16 KB +12 64KB +64KB | 35 kg +32KB
Kuops Kuops per core
L2 Cache 2 MB 2 MB 1 MB S12KBper |5 \p
core

Platform
Vendor and model | po) xps M170 | Dell XPS 600 | HP a1320y HP d4100e | Joshiba Tecra
number M4
Motherboard model Asus Amberine | Toshiba
number Dell 0F8460 Dell OUH741 Asterope ASAE-LE Portable PC
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Motherboard chipset | 'Nte! NFored SLi | ATIRS400 foresazop | Intel
otherboard chipse . nForce i ress .
P i915PM/GM ol Bt (F?s 480, i915PM/GM
Motherboard revision 03 A3 01 10 03
number
Motherboard serial MXG61801W2 | MXG61802G4
number 8MV5S91 3YRJS91 NAG20 NAG60 46053511H
BIOS name and American . ,
; Dell A05 Dell A11 Megatrends Phoenix v3.14 | Toshiba v3.20
version v3.07
BIOS settings Default Default Default Default Default
Memory module(s)
Hyundai Samsung M3 Hyundai Infineon Hyundai
Vendor and model Electronics Electronics Electronics
number HYMP564S64 2%22953023' HYMP564U64 g4D64320HU5 HYMP564S64
BP6-C4 P8-C4 BP6-C4
Type PC2-4200 PC2-5300 PC2-4200 PC3200 PC4200
Speed (MHz) 533 667 533 400 533
Speed running in the 266 333 266 200 266
system (MHz)
Timing/Latency (tCL-
{RCD-tRP-tRASMin) 4-4-4-12 5-5-5-13 4-4-4-12 3-3-3-8 4-4-4-12
Size 1 GB 2 GB 512 MB 1 GB 1 GB
Number of memory | 5, 515 \g 2x1GB 1x512 MB 2x 512 MB 2 x 512 MB
module(s)
Chip organization Double-sided Double-sided Single-sided Double-sided Double-sided
Channel Dual Dual Single Dual Dual
Hard disk
V . Western Digital :
endor and model Fujitsu Seagate \WD400BD- Seagate Toshiba
number MHV2080AH ST3160828AS 60LRAOD ST3160023AS | MK4032GSX
Number of disks in 1 1 y 1 1
system
Size 80 GB 160GB 40GB 160 GB 40 GB
Buffer Size 8 MB 8 MB 2 MB 8 MB 8 MB
RPM 5400 7200 7200 7200 5400
Type Ultra ATA SATA 300 SATA 300 SATA 150 SATA 150
Mb/s Mb/s Mb/s Mb/s
Intel Intel
Controller 82801FBM nForce4 MCP | ATI SB400 ATI SB400 82801FBM
(ICH6-M) (ICH6-M)
Microsoft NVIDIA Microsoft Microsoft Microsoft
Driver (Vista) 6.0.6000.1638 5 10.2600.931 6.0.6000.1638 | 6.0.6000.1638 | 6.0.6000.1638
6 T ' 6 6 6
ATI
Driver (XP) Microsoft NVIDIA Technologies, | Microsoft Intel
5.1.2600.2180 | 5.10.2600.552 | Inc 5.1.2600.2180 | 6.1.0.1004
5.10.1000.7
Graphics
NVIDIA NVIDIA NVIDIA NVIDIA
Xsr?q(:grand model GeForce Go GeForce 7800 Q;:ezzdzeooon GeForce 7300 | GeForce Go
7800 GTX GTX LE 6200 TE
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GeForce Go

GeForce 7800

ATl Radeon

GeForce 7300

GeForce Go

Chipset 7800 GTX GTX Xpress 200 | p 6200 TE
Series
BK-ATI
BIOS version 5.70.02.19.12 5.70.02.11.15 VERO008.0461. | 5.72.22.34.21 5.43.02.49.E2
003.000
Type PCI-E PCI-E Integrated PCI-E PCI-E
Memory size 256 MB 256MB 256MB 256 MB 64 MB
Resolution 1920 x 1200 1280 x 1024 1280 x 1024 1280 x 1024 1400 x 1050
. . NVIDIA NVIDIA NVIDIA NVIDIA
Driver (Vista) 715109746 | 715100746 | AT1833300 | 245109746 | 7.15.10.9752
. NVIDIA NVIDIA NVIDIA NVIDIA
Driver (XP) 6.14.10.8469 | 6.14.100371 | AT183300 1 514100371 | 6.14.10.7144
Audio
. . Realtek High SoundMax
Xsrr;%%rrand model |\S/|Ig'r2 f;ﬁldi% 2L%?t|v922888 Definition Realtek AC’'97 | Integrated
! 9y Audio Digital Audio
Realtek
. . SigmaTel Creative Semiconductor Realftek Ana!og
Driver (Vista) Semiconductor | Devices
5.10.0.4255 6.0.1.1241 Corp. 6.0.1.6213 512 1.5410
6.0.1.5372 T e
Realtek
. SigmaTel Creative Semiconductor Real?ek Ana!og
Driver (XP) Semiconductor | Devices
5.10.0.4255 5.12.4.1196 Corp. 510.0.6120 512 1 5240
5.10.0.5366 U e
Ethernet
Marvell Yukon
Vendor and model ?;%idéfr‘;bit E\e/t'vtv’g:k?force Realtek Realtek 88E8053
number 9 9 RTL8139 RTL8139 Gigabit
Controller Controller
Controller
Type Integrated Integrated Integrated Integrated PCI-E
. Microsoft Microsoft .
. . Microsoft NVIDIA Microsoft
Driver (Vista) 92003 65.5 5.0 2.640.630.200 2.640.630.200 90323
Broadcom Microsoft ggr?wlgcezlgnductor Marvell
Driver (XP) 7 86.3.0 NVIDIA 4.8.2.0 2.398.613.200 5649 615.200 | 82433
6
Modem
Vendor and model Conexant Conexant CXT Data Fax Toshiba
number D110 MDC D850 56K V.90 | SoftModem NA Software
V.9x DFVc Modem with SmartCP Modem
. . Microsoft Microsoft
Driver (Vista) 73960 73960 CXT 7.61.0.0 NA Agere 2.1.73.0
. Conexant Conexant
Driver (XP) 79310 7 6.0.50 CXT 7.20.0.50 | NA Agere 2.1.51.0
Optical drive(s)
Vendor and model TSSTcorp Sony Asus DVD- TSSTcorp TS- | Matshita
number TSL462C DDU1615 E616A H552D UJDAT750
Type DVD-ROM/CD-| pyp-rRom | DVD-ROM | DVD-RW DVD-ROM/CD-
RW RW
Single / Dual Layer NA NA NA Dual NA

USB ports
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# of ports 6 8 6 6 3
Type of ports
(USB1.1, USB2.0) USB2.0 USB2.0 USB2.0 USB2.0 USB2.0
IEEE 1394 ports
# of ports 1 | 3 | 2 [2 1
Monitor
ViewSonic ViewSonic ViewSonic
CRT/LCD UXGALCD Optiquest Q7 Optiquest Q7 Optiquest Q7 SXGALCD
Screen size 17” 177 17” 17" 14.1”
Refresh rate 60 Hz 60 Hz 60 Hz 60 Hz 60 Hz
Wireless
Vendor and model Intel . Intel )
number PRO/Wireless NA NA NA PRO/Wireless
2200BG 2200BG
. . Microsoft Microsoft
Driver (Vista) 9.1.0.111 NA NA NA 9.1.0.111
Driver (XP) Intel 9.0.4.26 NA NA NA Intel 9.0.1.9
Battery
Type Lithium lon NA NA NA Lithium lon
Size (Length x Width | g1/ 3 4 NA NA NA 5x2%x 1
x Height)
7200 mAh/ 4700 mAh /
Rated capacity 11.1V NA NA NA 10.8vV
80WHTr 50WHTr
Weight 11b. NA NA NA 11 oz.

Figure 10: Detailed system configuration information for each of the test systems.
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Appendix B — Windows updates

This appendix lists all the updates we applied to the test systems from the Windows Update site on 02/15/2007.

Windows Vista Critical and Recommended Updates

Update for Windows Vista (KB929735)

Definition Update for Windows Defender — KB915597 (Definition 1.15.2240.5)

Update for Windows Mail Junk E-mail Filter [February 2007] (KB905866)

Update for Windows Vista (KB930857)

Windows Malicious Software Removal Tool — February 2007 (KB890830)

Update for Windows Vista (KB9280089)

Update for Windows Vista (KB929427)

Update for Windows Vista (KB931573)

Figure 11: The Windows Vista updates we applied to each test system.

Windows XP Professional High Priority Updates

Cumulative Security Update for Internet Explorer for Windows XP (KB928090)

Security Update for Internet Explorer 7 for Windows XP (KB929969)

Windows Malicious Software Removal Tool - February 2007 (KB890830)

Update for Windows XP (KB93 1836)

Cumulative Security Update for Internet Explorer for Windows XP (KB928090)

Security Update for Windows XP (KB926436)

Security Update for Windows XP (KB918 118)

Security Update for Windows XP (KB927779)

Security Update for Windows XP (KB924667)

Security Update for Windows XP (KB927802)

Security Update for Windows XP (KB928843)

I~~~ [~

Security Update for Windows XP (KB928255)

Windows Internet Explorer 7.0 for Windows XP

Security Update for Windows XP (KB929969)

Security Update for Windows XP (KB923689)

Security Update for Windows Media Player 6.4 (KB925398)

Cumulative Security Update for Outlook Express for Windows XP (KB923694)

Security Update for Windows XP (KB926255)

Security Update for Windows XP (KB923980)

Security Update for Flash Player (KB923789)

MSXML 4.0 5P2 Security Update (KB927978)

Security Update for Windows XP (KB924270

(
Security Update for Windows XP (KB920213
Security Update for Windows XP (KB922819

e — — —

Security Update for Windows XP (KB924191

Security Update for Windows XP (KB923 191)

Security Update for Windows XP (KB924496)

Security Update for Windows XP (KB923414)

Update for Windows XP (KB920872)

Security Update for Windows XP (KB920685)

Security Update for Windows XP (KB919007)

Update for Windows XP (KB916595)

Security Update for Windows XP (KB911280)

Security Update for Windows XP (KB917953)

Security Update for Windows XP (KB913580)
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Security Update for Windows XP (KB918439)

Security Update for Windows XP (KB917344)

Security Update for Windows XP (KB914389)

Security Update for Windows Media Player 9 (KB917734)

Security Update for Windows XP (KB908531)

Update for Windows XP (KB900485)

Security Update for Windows XP (KB911562)

Cumulative Security Update for Outlook Express for Windows XP (KB911567)

Security Update for Windows Media Player Plug-in (KB911564)

Security Update for Windows XP (KB911927)

Security Update for Windows XP (KB912919)

Security Update for Windows XP (KB908519)

Security Update for Windows XP (KB904706)

Update for Windows XP (KB910437)

Security Update for Windows XP (KB896424)

Security Update for Windows XP (KB900725)

Security Update for Windows XP (KB905749)

Security Update for Windows XP (KB901017)

(
(
Security Update for Windows XP (KB905414)
(
(

Security Update for Windows XP (KB899589)

Security Update for Windows XP (KB902400)

Update for Windows XP (KB894391)

Security Update for Windows XP (KB896423

Security Update for Windows XP (KB899587

Security Update for Windows XP (KB899591

e — [~ —

Security Update for Windows XP (KB893756

Security Update for Windows XP (KB896358)

Security Update for Windows XP (KB901214)

Security Update for Windows XP (KB896428)

Security Update for Windows XP (KB890046)

Security Update for Windows XP (KB885835)

(
(
E
Security Update for Windows XP (KB890859)
(
(
(
(
(

Security Update for Windows XP (KB888113)

Security Update for Windows XP (KB891781)

Security Update for Windows Messenger (KB887472)

Security Update for Windows XP (KB888302)

Security Update for Windows XP (KB885836)

Critical Update for Windows XP (KB886185)

Security Update for Windows XP (KB873339)

Windows Genuine Advantage Validation Tool (KB892130)

Update for Windows XP (KB898461)

Microsoft Windows Installer 3.1

Figure 12: The Windows XP updates we applied to each test system.
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Appendix C — Detailed test results
Figure 13 details the performance results for each of the test operations on each system in each system state.

Each result is how long the operation took to complete on the test operating system. Each result is the average of
five runs of the same operation in the same system state on each system.

System A System B System C System D System E
Operating system XP [Vista [|XP |[Vista [XP |[Vista |[XP |Vista | XP | Vista
Cold
Outlook launch 3.96 145 | 5.84 243 | 2.85 6.77 | 2.68 144 | 3.54 1.74
Word launch 1.17 0.81] 1.58 0.83 | 2.01 3.15| 1.69 0.75 ] 2.41 4.81
Outlook save attachment | 0.64 0.25 | 1.21 0.51 ] 1.18 1.75] 0.90 0.31 ] 1.32 0.70
Outlook new message 0.51 0.36 | 0.57 0.34 | 0.73 1.89 | 0.61 0.31| 0.72 0.41
Outlook add Word file 0.19 0.25] 0.38 0.31] 0.25 0.54 | 0.14 0.23 ] 0.33 0.35
Outlook add JPEG
attachment 0.03 0.03 ] 0.03 0.03 | 0.03 0.03 | 0.02 0.03 | 0.02 0.04
Outlook message exit 0.16 0.17 ] 0.22 0.20 | 0.21 0.31]| 0.16 0.17 ] 0.18 0.21
Acrobat launch 2.65 0.66 | 3.27 0.90 | 2.05 7.50 | 1.10 0.64 | 3.09 1.15
Acrobat exit 1.21 0.20 [ 1.69 0.24 | 0.23 2.33 | 0.14 0.16 | 0.29 0.36
Outlook exit 0.50 0.21] 0.35 0.31] 0.65 0.36 | 0.39 0.20 | 0.40 0.38
Quicken launch 4.78 149 | 7.01 1.86 | 6.29 9.51 | 4.80 1.61 | 7.08 1.79
Quicken register entry 0.88 1.08 [ 1.09 1.34 | 0.79 1.18 | 1.05 0.71 | 1.15 1.28
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Quicken mark all 0.03 0.02 | 4.55 7.66 | 0.03 0.04 | 0.02 1.68 3 0.03
Quicken replace 0.32 0.55| 0.48 0.49 | 042 0.85] 0.31 0.45| 0.66 0.53
Quicken spending report 1.1 0.86 | 1.20 0.87 | 1.18 1.02 ] 1.13 0.86 | 0.92 0.89
Quicken save to PDF 1.05 0.86 | 1.48 0.92 | 1.06 1.31] 1.04 0.84 | 1.57 1.10
Quicken budget report 0.12 0.15 | 0.30 0.13 | 0.14 0.23 | 0.08 0.12 | 0.14 0.17
Quicken backup 0.98 1.03 | 2.24 1.76 | 1.71 243 | 1.45 1.50 | 1.94 2.03
Quicken exit 0.22 0.34 ]| 0.74 0.51 | 0.60 1.04 | 0.42 0.47 | 0.84 0.64
Word launch 2 0.89 1.10 | 1.57 1.50 | 1.15 5.02 | 0.74 0.99 | 1.26 1.67
Word insert WordArt
dialog 0.34 0.13] 0.28 0.11] 0.48 0.39 | 0.32 0.12 | 0.35 0.12
Word insert sound dialog | 0.08 0.05| 0.13 0.04 | 0.09 0.18 | 0.07 0.04 | 0.12 0.04
Word insert sound object | 0.09 0.41 | 0.22 0.47 | 0.37 1.08 | 0.11 0.40 | 0.47 0.52
Word insert JPEG 1 1.56 210 | 1.72 230 | 1.79 2.67 | 1.64 2.13 ] 1.82 2.43
Word resize JPEG 1 0.35 0.12 | 0.34 0.28 | 0.42 0.15| 0.28 0.11] 0.31 0.42
Word insert JPEG 2 1.80 1.94 | 1.58 2.25| 1.99 246 | 1.82 217 ] 1.89 2.35
Word resize JPEG 2 0.46 0.33 | 0.34 0.31] 0.55 0.40 | 0.36 0.28 | 0.34 0.32
Word Web page preview | 4.14 3.46 | 4.09 3.06 | 5.90| 12.73 | 4.03 3.05| 5.35 3.64
Word save as Web page 1.38 1.31 ] 1.24 145 | 1.37 211 1.14 1.10 | 1.38 1.32
Word exit 0.54 0.40 | 0.35 0.48 | 0.68 0.75| 0.43 0.36 | 0.37 0.62
Explorer exit 0.03 0.02 | 0.06 0.07 | 0.05 0.05| 0.03 0.02 | 0.05 0.12
Warm (after return from standby)
Outlook launch 0.99 1.11] 1.34 1.60 | 1.12 3.61 | 1.03 1.25 | 1.26 1.66
Word launch 0.19 0.54 | 0.36 0.66 | 0.29 241 | 0.18 0.58 | 0.39 0.70
Outlook save attachment | 0.18 0.22 | 0.47 0.49 | 0.26 0.59 | 0.16 0.42 | 0.45 0.61
Outlook new message 0.26 0.35| 0.23 0.33 | 0.34 0.88 | 0.20 0.31 | 0.25 0.42
Outlook add Word file 0.18 0.25| 0.32 0.30 | 0.25 0.54 | 0.16 0.24 | 0.30 0.36
Outlook add JPEG
attachment 0.04 0.03 | 0.10 0.03 | 0.03 0.04 | 0.02 0.03 | 0.09 0.04
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Outlook message exit 0.14 0.17 | 0.24 0.21 | 0.21 0.29 | 0.13 0.17 | 0.20 0.21
Acrobat launch 0.23 0.58 | 0.06 0.09 | 0.36 7.68 | 0.17 0.57 | 0.06 0.11
Acrobat exit 0.14 0.21] 0.25 0.23 | 0.20 1.55| 0.11 0.15| 0.26 0.31
Outlook exit 0.50 0.23 | 0.39 0.27 | 0.64 0.30 | 0.39 0.19 [ 0.39 0.38
Quicken launch 0.87 1.20 | 0.86 1.34 | 1.57 718 | 1.47 148 | 1.63 1.59
Quicken register entry 0.45 0.71 | 0.63 0.89 | 0.66 140 [ 0.75 0.95| 0.89 1.01
Quicken mark all 0.03 0.02 | 4.52 7.67 | 0.03 0.04 | 0.02 0.02 | 0.03 0.03
Quicken replace 0.29 0.56 | 0.47 0.49 | 0.33 0.84 | 0.29 0.45| 0.44 0.53
Quicken spending report 1.07 0.86 | 1.12 0.87 | 1.10 1.02 | 1.07 0.87 | 0.87 0.90
Quicken save to PDF 1.04 0.83 | 1.44 145] 1.05 1.24 ] 1.04 0.83 | 1.24 1.43
Quicken budget report 0.12 0.15| 0.28 0.13 | 0.14 0.23 | 0.08 0.13 | 0.14 0.17
Quicken backup 0.69 1.03 | 1.77 1.70 | 1.35 245 | 1.54 146 | 1.56 2.14
Quicken exit 0.17 0.34 | 0.57 0.51 | 0.48 1.05 | 0.31 0.56 | 0.65 0.68
Word launch 2 0.52 1.04 | 1.00 149 ] 0.70 484 | 0.46 1.01 | 1.01 1.71
Word insert WordArt
dialog 0.26 0.13 | 0.16 0.14 | 0.31 0.39 | 0.21 0.12 | 0.18 0.12
Word insert sound dialog | 0.06 0.05| 0.09 0.04 | 0.07 0.13 | 0.05 0.04 | 0.08 0.05
Word insert sound object | 0.06 0.41 ] 0.57 0.47 | 0.08 0.92 | 0.05 0.39 | 0.59 0.49
Word insert JPEG 1 1.50 2.24 | 1.59 2.32 | 1.68 263 | 1.65 228 | 1.78 2.41
Word resize JPEG 1 0.35 0.12 | 0.33 0.24 | 0.42 0.16 | 0.28 0.11 ] 0.35 0.27
Word insert JPEG 2 1.77 1.94 | 1.51 2.25| 1.96 248 | 1.78 2.06 | 1.86 2.34
Word resize JPEG 2 0.46 0.33 | 0.34 0.31 ] 0.55 0.43 | 0.36 0.27 | 0.35 0.33
Word Web page preview | 2.72 2.85| 2.09 258 | 340 | 11.71| 217 246 | 2.22 2.93
Word save as Web page 1.36 1.14 | 1.23 1.21 | 1.34 1.73 | 1.10 1.22 | 1.36 1.44
Word exit 0.54 0.41 ] 0.36 0.52 | 0.67 0.79 | 0.43 0.37 | 0.36 0.54
Explorer exit 0.03 0.04 | 0.06 0.07 | 0.04 0.05 | 0.03 0.05 | 0.06 0.13
Warm (after previous run
Outlook launch 0.98 1.12 ] 1.13 1.64 | 1.13 3.54 | 1.02 1.13 | 1.15 1.72
Word launch 0.23 0.54 | 0.33 0.65 | 0.26 1.00 | 0.20 0.57 | 0.34 0.75
Outlook save attachment | 0.19 0.21 | 0.50 0.52 | 0.21 0.53 | 0.14 0.31 | 0.48 0.57
Outlook new message 0.26 0.35| 0.26 0.41| 0.35 0.75 | 0.20 0.32 | 0.25 0.41
Outlook add Word file 0.18 0.26 | 0.31 0.29 | 0.24 0.46 | 0.15 0.23 | 0.27 0.34
Outlook add JPEG
attachment 0.04 0.03 | 0.10 0.03 | 0.03 0.03 | 0.02 0.02 | 0.09 0.03
Outlook message exit 0.14 0.18 | 0.24 0.21 | 0.21 0.26 | 0.12 0.18 | 0.19 0.21
Acrobat launch 0.24 0.55 | 0.06 0.11 | 0.36 6.87 | 0.18 0.58 | 0.06 0.11
Acrobat exit 0.14 0.21 | 0.25 0.22 | 0.20 1.41 ] 0.11 0.16 | 0.26 0.30
Outlook exit 0.50 0.21] 0.38 0.28 | 0.64 0.35| 0.38 0.17 | 0.38 0.41
Quicken launch 0.82 1.17 | 0.81 1.33 ]| 1.49 5.51 | 1.02 1.33 | 1.57 1.59
Quicken register entry 0.67 0.94 | 0.83 1111 115 1.66 | 0.69 0.68 | 0.67 1.27
Quicken mark all 0.02 0.02 | 4.55 7.66 | 0.03 0.04 | 0.02 0.02 | 0.02 0.03
Quicken replace 0.29 0.55 | 0.44 0.48 | 0.33 0.86 | 0.28 0.45 | 0.41 0.53
Quicken spending report 1.07 0.86 | 1.12 0.87 | 1.10 1.00 | 1.07 0.86 | 0.87 0.90
Quicken save to PDF 1.04 0.84 | 1.51 145 | 1.05 1.19 | 1.03 0.83 | 1.18 1.43
Quicken budget report 0.12 0.15| 0.14 0.16 | 0.14 0.23 | 0.08 0.13 | 0.14 0.17
Quicken backup 0.68 1.04 | 1.53 1.76 | 1.37 245 | 1.07 146 | 1.50 2.15
Quicken exit 0.18 0.33 | 0.57 0.54 | 0.46 1.00 | 0.33 0.36 | 0.64 0.65
Word launch 2 0.51 1.03 | 0.98 1.61 ] 0.69 2.86 | 0.47 0.99 | 1.01 1.64
Word insert WordArt
dialog 0.26 0.14 | 0.16 0.11 | 0.31 0.39 | 0.20 0.11 | 0.17 0.12
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Word insert sound dialog | 0.06 0.05] 0.10 0.04 | 0.07 0.12 ] 0.05 0.05| 0.08 0.04
Word insert sound object | 0.06 0.42 ] 0.78 0.47 | 0.08 1.09 | 0.05 0.38 | 0.60 0.51
Word insert JPEG 1 1.51 2.23 | 1.60 2.31| 1.68 276 | 1.54 2.27 | 1.68 2.42
Word resize JPEG 1 0.35 0.12 | 0.34 0.23 | 042 0.16 | 0.28 0.11] 0.35 0.27
Word insert JPEG 2 1.76 2.06 | 1.53 225| 1.97 247 | 1.78 2.05] 1.89 2.35
Word resize JPEG 2 0.46 0.31] 0.35 0.31] 0.55 0.40 | 0.35 0.27 | 0.35 0.33
Word Web page preview | 2.71 2.82 | 2.09 258 | 3.37 | 10.09 | 2.18 242 | 2.24 2.92
Word save as Web page 1.36 1.10 [ 1.25 1.21 | 1.35 242 | 1.11 1.06 | 1.32 1.37
Word exit 0.54 0.40 | 0.35 0.51 | 0.68 0.70 | 0.43 0.35| 0.36 0.53
Explorer exit 0.03 0.03 | 0.05 0.07 | 0.04 0.05 | 0.03 0.02 | 0.06 0.14

Figure 13: Results for a variety of operations on all five systems on both operating systems in both system states. Each result is the
average of five runs on a given system, operating system, and system state.

Figure 14 details the performance results for each of the test operations on one PC (System A) in each system
state under Windows Vista with Windows Vista Aero enabled and disabled. Each result is the average of five runs

of the same operation.

System A

Without With
Presence of Windows Vista Aero Windows Windows

Vista Aero | Vista Aero
Cold
Outlook launch 1.41 1.45
Word launch 0.69 0.81
Outlook save attachment 0.27 0.25
Outlook new message 0.36 0.36
Outlook add Word file 0.26 0.25
Outlook add JPEG attachment 0.03 0.03
Outlook message exit 0.22 0.17
Acrobat launch 0.68 0.66
Acrobat exit 0.19 0.20
Outlook exit 0.25 0.21
Quicken launch 1.38 1.49
Quicken register entry 1.10 1.08
Quicken mark all 0.03 0.02
Quicken replace 0.55 0.55
Quicken spending report 1.14 0.86
Quicken save to PDF 1.14 0.86
Quicken budget report 0.16 0.15
Quicken backup 1.07 1.03
Quicken exit 0.37 0.34
Word launch 2 1.06 1.10
Word insert WordArt dialog 0.14 0.13
Word insert sound dialog 0.05 0.05
Word insert sound object 0.41 0.41
Word insert JPEG 1 2.10 2.10
Word resize JPEG 1 0.12 0.12
Word insert JPEG 2 2.06 1.94
Word resize JPEG 2 0.30 0.33
Word Web page preview 3.38 3.46
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Word save as Web page 0.92 1.31
Word exit 0.48 0.40
Explorer exit 0.03 0.02
Warm (after return from standby)

QOutlook launch 1.12 1.11
Word launch 0.55 0.54
Outlook save attachment 0.23 0.22
Outlook new message 0.36 0.35
QOutlook add Word file 0.25 0.25
Outlook add JPEG attachment 0.03 0.03
Outlook message exit 0.23 0.17
Acrobat launch 0.57 0.58
Acrobat exit 0.21 0.21
Outlook exit 0.24 0.23
Quicken launch 1.16 1.20
Quicken register entry 0.66 0.71
Quicken mark all 0.03 0.02
Quicken replace 0.54 0.56
Quicken spending report 1.14 0.86
Quicken save to PDF 1.12 0.83
Quicken budget report 0.15 0.15
Quicken backup 1.06 1.03
Quicken exit 0.37 0.34
Word launch 2 1.02 1.04
Word insert WordArt dialog 0.14 0.13
Word insert sound dialog 0.05 0.05
Word insert sound object 0.41 0.41
Word insert JPEG 1 2.22 2.24
Word resize JPEG 1 0.12 0.12
Word insert JPEG 2 2.05 1.94
Word resize JPEG 2 0.31 0.33
Word Web page preview 2.78 2.85
Word save as Web page 1.33 1.14
Word exit 0.47 0.41
Explorer exit 0.04 0.04
Warm (after previous run)

Outlook launch 1.12 1.12
Word launch 0.55 0.54
Outlook save attachment 0.18 0.21
Outlook new message 0.35 0.35
Outlook add Word file 0.25 0.26
Outlook add JPEG attachment 0.03 0.03
Outlook message exit 0.21 0.18
Acrobat launch 0.55 0.55
Acrobat exit 0.22 0.21
Outlook exit 0.25 0.21
Quicken launch 1.17 1.17
Quicken register entry 0.80 0.94
Quicken mark all 0.03 0.02
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Quicken replace 0.55 0.55
Quicken spending report 1.14 0.86
Quicken save to PDF 1.12 0.84
Quicken budget report 0.15 0.15
Quicken backup 1.11 1.04
Quicken exit 0.37 0.33
Word launch 2 1.09 1.03
Word insert WordArt dialog 0.14 0.14
Word insert sound dialog 0.05 0.05
Word insert sound object 0.41 0.42
Word insert JPEG 1 1.59 2.23
Word resize JPEG 1 0.12 0.12
Word insert JPEG 2 1.82 2.06
Word resize JPEG 2 0.33 0.31
Word Web page preview 2.81 2.82
Word save as Web page 1.50 1.10
Word exit 0.47 0.40
Explorer exit 0.03 0.03

Figure 14: Results for operations on one system under Windows Vista with and
without Windows Vista Aero enabled in both system states. Each result is the
average of five runs.
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About Principled Technologies

We provide industry-leading technology assessment services. We bring to every assignment extensive
experience with and expertise in all aspects of technology testing and analysis, from research into new
technologies, to the development of new methodologies, to testing with existing and new tools.

When the assessment is complete, we know how to present the results to a broad range of target audiences. We

provide our clients with the materials they need, from market-focused data to use in their own collateral to custom
sales aids, such as test reports, performance assessments, and white papers. Every document reflects the results
of our trusted independent analysis.

We provide customized services that focus on our clients’ individual needs. Whether the technology involves
hardware, software, Web sites, or services, we offer the experience, expertise, and tools to help you assess how
it will fare against its competition, its performance, whether it's ready to go to market, and its quality and reliability.

Our founders, Mark Van Name and Bill Catchings, have worked together in technology assessment for over 20
years. As journalists they published over a thousand articles on a wide array of technology subjects. They created
and led the Ziff-Davis Benchmark Operation, which developed such industry-standard benchmarks as Ziff Davis
Media’'s Winstone and WebBench. They founded and led eTesting Labs, and after the acquisition of that company
by Lionbridge Technologies were the head and CTO, respectively, of VeriTest.

B Principled Technologies, Inc.
st 1007 Slater Road, Suite 250
PI'II’ICIp'&d - Durham, NC 27703

I TGChﬂOlOgIES www.principledtechnologies.com
info@principledtechnologies.com

Principled Technologies is a registered trademark of Principled Technologies, Inc.
All other product names are the trademarks of their respective owners

Disclaimer of Warranties; Limitation of Liability:

PRINCIPLED TECHNOLOGIES, INC. HAS MADE REASONABLE EFFORTS TO ENSURE THE ACCURACY AND VALIDITY OF ITS
TESTING, HOWEVER, PRINCIPLED TECHNOLOGIES, INC. SPECIFICALLY DISCLAIMS ANY WARRANTY, EXPRESSED OR
IMPLIED, RELATING TO THE TEST RESULTS AND ANALYSIS, THEIR ACCURACY, COMPLETENESS OR QUALITY, INCLUDING
ANY IMPLIED WARRANTY OF FITNESS FOR ANY PARTICULAR PURPOSE. ALL PERSONS OR ENTITIES RELYING ON THE
RESULTS OF ANY TESTING DO SO AT THEIR OWN RISK, AND AGREE THAT PRINCIPLED TECHNOLOGIES, INC., ITS
EMPLOYEES AND ITS SUBCONTRACTORS SHALL HAVE NO LIABILITY WHATSOEVER FROM ANY CLAIM OF LOSS OR DAMAGE
ON ACCOUNT OF ANY ALLEGED ERROR OR DEFECT IN ANY TESTING PROCEDURE OR RESULT.

IN NO EVENT SHALL PRINCIPLED TECHNOLOGIES, INC. BE LIABLE FOR INDIRECT, SPECIAL, INCIDENTAL, OR
CONSEQUENTIAL DAMAGES IN CONNECTION WITH ITS TESTING, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
IN NO EVENT SHALL PRINCIPLED TECHNOLOGIES, INC.’S LIABILITY, INCLUDING FOR DIRECT DAMAGES, EXCEED THE
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