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Moving to new servers and storage can bring myriad benefits to your 
business, from saving space to running more applications. But when 
you’re considering an upgrade, how do you know which new solution is 
right for you?

In the datacenter at Principled Technologies, we compared a bare-metal 
legacy solution with a new solution featuring Intel processor-powered Dell 
PowerEdge R730 servers, a VMware vSphere 6 virtual environment, and 
Dell Storage SC4020. 

Both solutions ran the same mixed workload of database, email, 
and simulated file server work, but the upgraded solution handled a 
staggering 18 times the work of the older one. That means you can 
consolidate many workloads from multiple user groups or departments. 
You can also do significantly more work in the same amount of 
rack space, leaving room in the datacenter for growth, and can use 
virtualization to maximize the value of your resources. 

We used the Dell Performance Analysis Collection Kit 
(DPACK) to evaluate and understand the performance 

of the new environment. By running DPACK in your own datacenter, you can 
characterize your environment’s performance and identify bottlenecks. 

Then, take a look at the DPACK results for our newer solution to see its 
performance metrics. In your environment, using DPACK can highlight 

upgrade opportunities and help you better understand specific 
performance requirements.

Run more applications without expanding your datacenter
when you upgrade to a Dell™ PowerEdge™ R730 and VMware® vSphere® 
solution powered by Intel® Xeon® processors 

Do the work of  
18 legacy solutions

Get performance data with DPACK
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Your time to upgrade
Legacy infrastructure woes
As they get older, legacy infrastructures may struggle to keep up with the growth of business. Components in legacy 
hardware can degrade and begin to malfunction from use over time. What’s more, legacy hardware lacks new processors 
that can speed up applications; new designs that can lower power consumption; and new, effective management 
features that can save time for IT staff and reduce downtime for users.

Do more work in the same space 
In hands-on work in our datacenter, we determined that by upgrading from a legacy solution to the new Intel processor-
based Dell PowerEdge R730 and VMware vSphere solution, you could do 18 times the work without taking up any more 
rack space. By completing so much more work in the same amount of space, your company can consolidate workloads 
from multiple departments. For instance, we centralized multiple Exchange mail servers, SQL databases, and file 
servers into one location while keeping them separate on VMs. At the same time, your business can grow without costly 
datacenter expansions. 

Take full advantage of your resources
Virtualizing with VMware vSphere can help you maximize the value of your newer, more powerful hardware and better 
utilize compute, networking, and storage resources that would otherwise go unused. It gives you a more efficient 
environment and more control over precisely how your applications utilize your newly increased resources. With this 
control, you can use a single server to run multiple workloads, each of which might have maxed out a single server in 
your legacy environment. 

Your current infrastructure may already be fully or partially virtualized, or you may be working with a bare-metal 
environment. Whatever your starting point, VMware vSphere can help you make the most of your investment in an 
upgraded environment.
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Keep your favorite parts of your 
current infrastructure
By moving to newer physical servers 
and centralized storage, you gain the 
benefits of the latest technologies while 
maintaining the hardware features on 
which you rely, including the flexibility of 
general-purpose servers and centralized 
storage features such as snapshots and 
compression. At the same time, your 
company has new opportunities for added 
density, faster workload processing, and 
better resource management.

This solution also enables you to 
use a management tool that may 
already be familiar to your IT staff: Dell 
OpenManage™ Essentials (OME). If you 
were previously using OME to manage a Dell server and storage infrastructure from five or six years ago, the new version 
of OME will allow you to manage your new servers in a similar way to how you managed your old ones. Newer hardware, 
such as the Dell PowerEdge R730 powered by Intel Xeon processors, can take advantage of the new features and 
functions in the latest version of OME while maintaining the familiar management interface your IT administrators may 
already use. In previous studies, we found OME can save time and improve efficiency in datacenter management.1 These 
advantages may help enable a more straightforward transition from the old hardware to the new.

Take a look at DPACK
DPACK measures the throughput, disk I/O, memory, capacity, and CPU utilization of your servers and storage. Its reports 
present this data to help you better understand what hardware you’ll need when you upgrade.

Using the DPACK online viewer, you can review your results in two ways: Aggregate or Individual. Aggregate results offer 
performance data for the full environment, while Individual results provide numbers for a specific server. When we ran 
DPACK on the new Dell and VMware solution, we viewed Aggregate results. 

In addition to simply running DPACK in your own environment, you can contact a Dell salesperson who can help you 
interpret your DPACK results and size your upgraded environment. We did not test this service.
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How we navigated the path to an upgraded datacenter
Our legacy environment
We created our legacy solution to approximate an infrastructure that a small enterprise might have 
purchased five or six years ago and still use today. This bare-metal (non-virtualized) environment 
contained three Dell PowerEdge R710 legacy servers with one legacy Dell EqualLogic™ PS6110 
storage array. Appendix C has complete details on the solution.

Our upgraded environment
Our upgraded environment represents 
a possible next step for an enterprise 
moving from the legacy environment we 
chose. It contains newer products with an 
architecture and functionality similar to 
those in the legacy environment.

Our new solution contained three Dell 
PowerEdge R730 servers powered by Intel 
Xeon processors E5-2660 v4 and one all-
flash Dell Storage SC4020 array powered 
by an Intel Xeon processor E3-1265L v2. 
We utilized VMware vSphere 6 for the 
hypervisor with VMware vCenter Server™ 
and VMware vRealize® Operations 
Manager™ for hypervisor management. 
This tool provides customizable 
dashboards you can use to analyze risk, 
monitor capacity issues, and check on 
your virtual environment’s health. See 
Appendix C for more details.

What we did
On the legacy environment, each application of the mixed workload had a dedicated server. We tuned each application 
to its maximum performance while maintaining acceptable thresholds for storage latency—a measure of how fast storage 
can complete a request. For our purposes, those thresholds were under 20ms.

Then, we virtualized all legacy application servers on the upgraded solution and increased the number of VMs in sets  
until we reached 80 percent utilization of at least one hardware resource. In this case, that was storage capacity and 
allocated RAM. With additional storage capacity and RAM, you could potentially obtain an even higher consolidation 
ratio because CPU and storage latency thresholds were not at full capacity.

To capture data on the upgraded environment’s performance, we ran DPACK. (For our DPACK results, see Appendix D.)
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Our workloads
We generated the workloads for each application using industry-standard tools. 
For a database workload, we chose Microsoft® SQL Server® 2014 running the 
DVD Store 2 benchmarking tool; for email, we chose Microsoft Exchange 2013 
running a Microsoft Exchange Load Generator 2013 workload; and for simulated 
file server, we chose the Iometer tool, which generates synthetic data streams 
mimicking a file server workload. 

This mixed workload may reflect many companies’ operations. In a traditional 
legacy setup, IT may assign a single application to a single server. That 
application uses the hardware resources it needs, but the rest of the server’s 
resources are wasted. This problem grows with the company; as the organization 
splits into multiple departments with distributed IT staff, it can get even worse. 

With a virtualized solution like the one from Dell, Intel, and VMware, IT can 
consolidate multiple different workloads onto virtualized clusters, making the 
most out of their storage and compute resources and letting fewer resources go 
to waste. 

Conclusion
By upgrading from the legacy solution we tested to the new Intel processor-
based Dell and VMware solution, you could do 18 times the work in the same 
amount of space. Imagine what that performance could mean to your business: 
Consolidate workloads from across your company, lower your power and 
cooling bills, and limit datacenter expansion in the future, all while maintaining a 
consistent user experience—the list of potential benefits is huge.   

Try running DPACK, which can help you identify bottlenecks in your environment 
and inform you about your current performance needs. Then consider how the 
consolidation ratio we proved could be helpful for your company. The Intel 
processor-powered Dell PowerEdge R730 solution with VMware vSphere and 
Dell Storage SC4020, also powered by Intel, could be the right destination for 
your upgrade journey. 

DVD Store 2
We used DVD Store Version 2.1, or 
DS2.2 DS2 is a database performance 
tool. It models an online store where 
customers log in, search for products, 
and make purchases. It also performs 
other actions, such as adding new 
customers, to exercise a wide range of 
everyday database functions. 

Microsoft Exchange Load 
Generator 2013

Microsoft Exchange Server is an email 
application that businesses use widely 
across multiple industries. To test 
how well the solutions could run an 
Exchange server workload, we used 
Microsoft Exchange Load Generator 
2013 (LoadGen), which functions as 
a sample Exchange workload and 
simulates a large number of users 
generating email activity.3

Iometer
Many businesses use file servers, so 
we simulated a file server workload 
using Iometer 1.1.4  Iometer uses action 
profiles to perform input/output (I/O) 
operations that approximate data 
operations such as reading files, writing 
files, and updating files.

1 See the Principled Technologies reports Systems management savings with Dell 
OpenManage on 13G Dell PowerEdge servers and Dell OpenManage Essentials: 
Improve efficiency with fewer tools, more benefits.

2 http://en.community.dell.com/techcenter/extras/w/wiki/dvd-store

3 https://www.microsoft.com/en-us/download/details.aspx?id=14060

4 http://www.iometer.org/

http://www.principledtechnologies.com/Dell/13G_systemsmgmt_savings_1114.pdf
http://www.principledtechnologies.com/Dell/13G_systemsmgmt_savings_1114.pdf
http://www.principledtechnologies.com/Dell/OME_comparison_0615.pdf
http://www.principledtechnologies.com/Dell/OME_comparison_0615.pdf
http://en.community.dell.com/techcenter/extras/w/wiki/dvd-store
https://www.microsoft.com/en-us/download/details.aspx?id=14060
http://www.iometer.org/
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On May 1, 2016, we finalized the hardware and software configurations we tested. Updates for current and recently 
released hardware and software appear often, so unavoidably these configurations may not represent the latest versions 
available when this report appears. For older systems, we chose configurations representative of typical purchases of 
those systems. We concluded hands-on testing on May 24, 2016.

Appendix A – Test systems
Server configuration information 3x Dell PowerEdge R710 3x Dell PowerEdge R730

BIOS name and version Dell 6.4.0 Dell 2.0.2

Non-default BIOS settings N/A N/A

Operating system name and version/build 
number Windows Server® 2012 R2 VMware ESXi™ 6.0 Update 2

Date of last OS updates/patches applied 03/31/16 04/14/2016

Power management policy Performance Performance

Processor

Number of processors 2 2

Vendor and model Intel Xeon E5520 Intel Xeon E5-2660 v4

Core count (per processor) 4 14

Core frequency (GHz) 2.26 2.0

Stepping D0 M0

Memory module(s)

Total memory in system (GB) 48 256

Number of memory modules 6 16

Vendor and model Samsung® M393B1K70DH0-YH9 Hynix HMA42GR7MFR4N-TF

Size (GB) 8 16

Type PC3-10600 PC4-17000

Speed (MHz) 1,333 2,133

Speed running in the server (MHz) 1,333 2,133

Storage controller

Vendor and model Dell PERC 6/i Dell PERC H730P Mini

Cache size 256MB 2GB

Firmware version 6.3.3.0002 25.3.0.0016

Driver version 6.600.21.8 6.606.12.00-1OEM
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Server configuration information 3x Dell PowerEdge R710 3x Dell PowerEdge R730

Local storage

Number of drives 2 2 (R730s 1 and 2)

Drive vendor and model Western Digital® WD3000BKHG Seagate ST9300653SS

Drive size (GB) 300 300

Drive information (speed, interface, type) 10K, 6Gb SAS, 2.5” HDD 15K, 6Gbps SAS, 2.5” HDD

Local storage 2

Number of drives N/A 2 (R730 3)

Drive vendor and model N/A Seagate® ST9300653SS

Drive size (GB) N/A 300

Drive information (speed, interface, type) N/A 15K, 6Gbps SAS, 3.5” HDD

Network adapter

Vendor and model Broadcom® BCM5709C Intel I350-t rNDC

Number and type of ports 4 x 1GbE 2 x 1GbE

Driver version 7.4.23.2 5.3.0

Network adapter 2

Vendor and model Intel Ethernet Server Adapter X520 Intel 82599 10GbE Controller

Number and type of ports 2 x 10GbE 2 x 10GbE

Driver version 3.9.58.9101 3.21.6iov

HBAs

Vendor and model N/A QLogic® QLE2562

Number and type of ports N/A 2 x 8Gbps Fibre Channel

Driver version N/A 2.1.24.0-1OEM

Power supplies

Vendor and model Dell N870P-S0 Dell N870P-S0

Number of power supplies 2 2

Wattage of each (W) 870 870



Run more applications without expanding your datacenter August 2016 | 8

Detailed configuration information for the legacy storage solution.

Storage configuration information Dell EqualLogic PS6110

Controller firmware revision V7.0.5 (R390599)

Number of storage controller modules 2 x 70-0477 (TYPE 14)

Number of drives 24

Drive vendor and model number Seagate® ST9900805SS

Drive size (GB) 900

Drive information (speed, interface, type) 10K, 6Gb SAS, HDD 

Detailed configuration information for the upgraded storage solution.

Storage configuration information Dell Storage SC4020

Controller firmware revision 6.5.2

Number of storage controller modules 2 x CT-SC4020

Number of drives 24

Storage disk 1

Drive vendor and model number 12 x Dell SanDisk LB1606R

Drive size (TB) 1.6

Drive information (speed, interface, type) Read-Intensive, 6Gb SAS, SSD 

Storage disk 2

Drive vendor and model number 12 x Dell SanDisk LB406S

Drive size (GB) 400 

Drive information (speed, interface, type) Write-Intensive, 6Gb SAS, SSD 
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Appendix B – How we tested
Legacy environment
We used the following steps to configure our legacy Dell PowerEdge R710 mixed workload environment. We included 
notes on the VMDK settings where applicable because these steps were also used in the creation of the of the upgraded 
environment’s virtual machines.

Performing the initial OS install and setup
Installing Windows Server 2012 R2
1. Insert the installation media into the CD/DVD drive, and restart the server.
2. When prompted to boot from DVD, press any key.
3. When the installation screen appears, click My language is English (United States).
4. Leave language, time/currency format, and input method as default, and click Next.
5. Click Install now.
6. When the installation prompts you, enter the product key.
7. Select Windows Server 2012 R2 Datacenter (Server with a GUI), and click Next.
8. Check I accept the license terms, and click Next.
9. Click Custom: Install Windows only (advanced).
10. Select Drive 0 Unallocated Space, and click Next.
11. When the Settings page appears, fill in the Password and Reenter Password fields with the same password.
12. Log in with the password you set up previously.

Configuring the operating system
1. Enable remote desktop access.
2. Change the hostname, and reboot when the installer prompts you.
3. Set up networking:

a. Click Start→Control Panel, right-click Network Connections, and select Open.
b. Right-click the management traffic NIC, and select Properties.
c. Select TCP/IP (v4), and select Properties.
d. Set the IP address and subnet for the NIC, which will handle management traffic, and click OK.
e. Click OK, and click Close.

4. Install all available Windows updates. Restart as necessary.

Configuring the Microsoft Active Directory® and Iometer server
For the legacy environment, we created a large dedicated LUN on the Dell EqualLogic PS6110 storage for the Iometer 
workload file. For the upgraded VMware environment, we added a 120GB VMDK for Iometer to the AD VM using the 
Dell Storage SC4020 datastore.

Installing Active Directory and DNS services
1. Launch Server Manager.
2. Click Manage→Add Roles and Features.
3. At the Before you begin screen, click Next.
4. At the Select installation type screen, leave Role-based or feature-based installation selected, and click Next.
5. At the Server Selection Screen, select the server from the pool, and click Next.
6. At the Select Server Roles screen, select Active Directory Domain Services. Click Add Features when prompted, and click Next. 
7. At the Select Features screen, click Next.
8. At the Active Directory Domain Services screen, click Next.
9. At the Confirm installation selections screen, check Restart the destination server automatically if required, and click Install.

Configuring Active Directory and DNS services
1. After the installation completes, a screen should pop up with configuration options. If it does not, click the Tasks flag in the upper-right section of 

Server Manager.
2. Click Promote this server to a Domain Controller.
3. At the Deployment Configuration screen, select Add a new forest. In the Root domain name field, type test.local, and click Next.
4. At the Domain Controller Options screen, leave the default values, and enter a password twice.
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5. To accept default settings for DNS, NetBIOS, and directory paths, click Next four times.
6. At the Review Options screen, click Next.
7. At the Prerequisites Check dialog, allow the check to complete. If there are no relevant errors, check Restart the destination server automatically if 

required, and click Install.
8. When the server restarts, log on using test\Administrator and the specified password.

Configuring the Windows Time Service on the domain controller
To ensure reliable time, we pointed our Active Directory server to a local NTP server.

1. Open a command prompt.
2. Type the following:

W32tm /config /syncfromflags:manual /manualpeerlist:”<ip address of a NTP server>” 
W32tm /config /reliable:yes 
W32tm /config /update 
W32tm /resync 
Net stop w32time 
Net start w32time

Preparing AD for Microsoft Exchange
1. Create a reverse lookup zone:

a. Click the start button, and in the search field, type DNS.
b. Open the DNS manager by clicking on it in the results field.
c. Expand your Active Directory domain, and click Reverse Lookup Zones.
d. Click Action→New Zone.
e. On the Welcome screen, click Next.
f. Chose Primary Zone, and click Next.
g. Leave default replication scope, and click Next.
h. Choose IPv4, and click Next.
i. Enter the IP address of your domain (192.168.1 for our example).
j. Choose Allow both nonsecure and secure dynamic updates, and click Next.
k. Click Finish.

2. Insert the Exchange 2013 R2 Installation ISO in the AD DVD drive.
3. In Windows Explorer, double-click the Exchange DVD icon.
4. In the Exchange installation folder, hold down shift, and right-click. 
5. Choose Open a command window here.
6. Run the following command: 

Setup.exe /PrepareSchema /IAcceptExchangeServerLicenseTerms

7. When the previous command completes, run the following command:

Setup.exe /PrepareAD /OrganizationName:”organization name” /
IAcceptExchangeServerLicenseTerms

8. Close the command window when the setup finishes.

Installing Active Directory Certificate Services
1. Launch Server Manager, and select Add roles and features.
2. At the Add Roles and Features Wizard, click Next.
3. Select Role-based or feature-based installation, and click Next.
4. Choose Active Directory Certificate Services.
5. Click Add Features, if prompted, to install any required features.
6. Click Next three times.
7. Choose Certificate Authority and Certification Authority Web Enrollment.
8. Click Add Features, if prompted, to install any required features.
9. Click Next.
10. Leave defaults, and click Next.
11. Click Install.
12. When the install finishes, click Close.
13. Click the yellow warning symbol in the Server Manager, and click Configure Active Directory Certificate Services.
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14. Leave defaults, and click Next.
15. Check both Certification Authority and Certification Authority Web Enrollment, and click Next.
16. Choose Enterprise CA, and click Next.
17. Choose Root CA, and click Next.
18. Choose Create a new private key, and click Next.
19. Leave defaults, and click Next.
20. Leave defaults, and click Next.
21. Leave 5 years, and click Next.
22. Leave default locations, and click Next.
23. Click Configure.
24. Close when the configuration finishes.
25. Open Internet Explorer® and navigate to localhost/certsrv/Default.asp to verify that the installation succeeded.

Installing Iometer
1. Download the Iometer 1.1.0 package for Windows from http://www.iometer.org/doc/downloads.html.
2. Double-click the installer, and click Run. 
3. At the Welcome window, click Next. 
4. At the License Agreement window, click I Agree. 
5. At the Choose Components window, leave the defaults selected, and click Next. 
6. At the Choose Install Location window, leave it at defaults, and click Install. 
7. When the installation is complete, click Finish.

Setting up the Iometer workload
We used the following settings for each test:

1. Open Iometer.exe.
2. Create the following access specification:

a. Transfer Delay: 0ms
b. Burst Length: 1 I/O
c. Outstanding I/Os: 1
d. Under Reply Size, select No Reply. 
e. 100% random
f. 80% reads
g. Under Align I/Os, select Sector Boundaries. 

3. Under Disk Targets, set the # of Outstanding I/Os to 1. 
4. Set the disk size to 209715200 (100GB). 
5. Under Results Display, make sure that Iometer has selected Start of Test. 
6. Under Test Setup, set the Run Time to 60 minutes and the Ramp Up Time to 600 seconds. 
7. Exit Iometer.  

Configuring the Microsoft Exchange 2013 Server
Joining the domain
1. Set a static IP.
2. Select Start→Control Panel→Network Connections→Local Area Connection.
3. Click Properties.
4. Highlight Internet Protocol (TCP/IP), and click Properties.
5. Select Use the following DNS server addresses, and enter the IP of the DNS server in the Preferred DNS server field. Click OK.
6. Right-click My Computer, and select Properties.
7. Under the Computer Name tab, click Change.
8. In the Computer Name Changes screen, under the Member of section, select the Domain radial box, and type test.local
9. To start joining the domain, select OK.
10. When the screen appears asking for a person qualified on the domain, type Administrator as the username and Password1 as the password.
11. At the Welcome pop-up window and the window warning that you must reset the computer for the changes to take effect, click OK.
12. At the System Properties screen, click OK.
13. When a pop-up appears asking if you want to restart now, click Yes to restart your computer.

http://www.iometer.org/doc/downloads.html
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Installing Exchange Server 2013 SP1 Mailbox and Client Access Server roles
For the legacy environment, we created large dedicated LUNs on the Dell EqualLogic PS6110 for the Exchange 
database, logs, and backup. For the upgraded VMware environment, we added a 110GB VMDK for the database, a 
10GB VMDK for logs, and a 110GB VMDK for backup to the Exchange VM using the Dell Storage SC4020 datastore.

1. On the Exchange Server, log into the server using domain administrator credentials.
2. Open Windows PowerShell®, and run the following command:

Install-WindowsFeature AS-HTTP-Activation, Desktop-Experience, NET-Framework-45-Features, 
RPC-over-HTTP-proxy, RSAT-Clustering, RSAT-Clustering-CmdInterface, RSAT-Clustering-Mgmt, 
RSAT-Clustering-PowerShell, Web-Mgmt-Console, WAS-Process-Model, Web-Asp-Net45, Web-
Basic-Auth, Web-Client-Auth, Web-Digest-Auth, Web-Dir-Browsing, Web-Dyn-Compression, Web-
Http-Errors, Web-Http-Logging, Web-Http-Redirect, Web-Http-Tracing, Web-ISAPI-Ext, Web-
ISAPI-Filter, Web-Lgcy-Mgmt-Console, Web-Metabase, Web-Mgmt-Console, Web-Mgmt-Service, 
Web-Net-Ext45, Web-Request-Monitor, Web-Server, Web-Stat-Compression, Web-Static-Content, 
Web-Windows-Auth, Web-WMI, Windows-Identity-Foundation

3. Restart the server.
4. Download the Microsoft Unified Communications Managed API 4.0, Core Runtime 64-bit (go.microsoft.com/fwlink/p/?linkId=258269).
5. Run UcmaRuntimeSetup.exe.
6. When the installation completes, click Finish.
7. Navigate to the location of the Exchange installation media, and double-click Setup.exe.
8. At the Check for Updates? screen, check the Connect to the Internet and check for updates checkbox, and click Next.
9. When the updates complete, click Next.
10. At the Introduction screen, click Next.
11. At the License Agreement screen, check the box to accept the terms, and click Next.
12. At the Recommended Settings screen, check the Don’t use recommended settings checkbox, and click Next.
13. At the Server Role Selection, select Mailbox and Client Access role, and click Next.
14. At the Installation Space and Location screen, leave the default location for the installation, and click Next. 
15. At the Malware Protection Settings, select Yes to disable, and click Next. 
16. At the Readiness Checks screen, allow the verification to complete. If there are no failures, click Install. 
17. When the installation completes, click Finish, and restart the server.

Configuring Exchange
1. On the Exchange server, open the Exchange Admin Center by using a browser and navigating to https://localhost/ecp
2. Enter the domain administrator credentials, and click Sign in.
3. If prompted, select the language and time zone, and click Save.
4. In the left pane, click Mail Flow, and then click Send Connectors. 
5. On the Send Connectors page, click the New icon.
6. In the New Send Connector wizard, specify SMTP as the name and select Internet as the type. Click Next.
7. In the Network settings screen, choose MX record associated with recipient domain, and click Next.
8. In the Address space screen, click the Add icon. 
9. In the Add domain window, enter * in the Fully Qualified Domain Name (FQDN) field, and click Save.
10. Click Next.
11. In the Source Server screen, click the Add icon. 
12. In the Select a Server window, select the Exchange server, click Add, and click OK.
13. Click Finish.
14. In the left pane of the EAC, click servers, select the name of the Exchange server, and click Edit.
15. Click Outlook Anywhere, and enter the appropriate FQDN of the Client Access Server for the external and internal hostname field. For example, 

exchangeserver.test.local

16. As the authentication method, choose NTLM, and click Save. 
17. Click Virtual Directories, and then click the Configure external access domain icon.
18. In the Select the Client Access servers to use with the external URL window, click the Add icon.
19. Select the Exchange server, and click Add. Click OK.
20. Enter the FQDN of the Exchange server in the Enter the domain field, and click Save.

http://go.microsoft.com/fwlink/p/?linkId=258269
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21. Log into the Active Directory server using administrator credentials, and complete the following steps:
a. Open Server Manager, then click Tools→DNS.
b. In DNS Manager, in the left pane, expand the Active Directory server name→Forward Lookup Zones→test.local.

c. In the right pane, verify or create the DNS records as presented below. 

22. Log back into your Exchange server.
23. In the Exchange PowerShell, run the following commands, replacing $HostName with the host name (not FQDN) of your Exchange server:

Set-EcpVirtualDirectory “$HostName\ECP (Default Web Site)” -InternalUrl ((Get-
EcpVirtualDirectory “$HostName\ECP (Default Web Site)”).ExternalUrl)

Set-WebServicesVirtualDirectory “$HostName\EWS (Default Web Site)” -InternalUrl ((get-
WebServicesVirtualDirectory “$HostName\EWS (Default Web Site)”).ExternalUrl)

Set-ActiveSyncVirtualDirectory “$HostName\Microsoft-Server-ActiveSync (Default Web Site)” 
-InternalUrl ((Get-ActiveSyncVirtualDirectory “$HostName\Microsoft-Server-ActiveSync 
(Default Web Site)”).ExternalUrl)

Set-OabVirtualDirectory “$HostName\OAB (Default Web Site)” -InternalUrl ((Get-
OabVirtualDirectory “$HostName\OAB (Default Web Site)”).ExternalUrl)

Set-OwaVirtualDirectory “$HostName\OWA (Default Web Site)” -InternalUrl ((Get-
OwaVirtualDirectory “$HostName\OWA (Default Web Site)”).ExternalUrl)

Set-PowerShellVirtualDirectory “$HostName\PowerShell (Default Web Site)” -InternalUrl 
((Get-PowerShellVirtualDirectory “$HostName\PowerShell (Default Web Site)”).ExternalUrl)

Get-OfflineAddressBook | Set-OfflineAddressBook -GlobalWebDistributionEnabled $True 
-VirtualDirectories $Null

Get-OutlookAnywhere | Set-OutlookAnywhere -ExternalHostname mail.ives.lan -InternalHostname 
mail.ives.lan -ExternalClientsRequireSsl $true -InternalClientsRequireSsl $true 
-DefaultAuthenticationMethod NTLM

24. Create a folder at the root of C: on the Exchange server, and share it to Everyone with read/write permissions.
25. Log back into the Exchange admin center, and navigate to Servers→certificates.
26. In the drop-down menu, choose the Exchange server, and to create a new certificate, click the plus sign.
27. Choose Create a request for a certificate from a certification authority, and click Next.
28. Name the certificate, and click Next.
29. Do not request a wildcard certificate, and click Next.
30. Click Browse, choose the Exchange server, and click OK. Click Next.
31. Leave defaults, and click Next.
32. Leave defaults, and click Next.
33. Enter your organization information, and click Next.
34. Enter the path to the share you created on the Exchange server, and click Finish. Example: \\exchange\share\myrequest.REQ
35. Log into the AD server, and open Internet Explorer.
36. Browse to localhost/CertSrv
37. Click Request a certificate.
38. Choose advanced certificate request.
39. Choose Submit a certificate request by using a base-64-endcoded CMC…
40. Open Windows Explorer, and navigate to the share folder on the Exchange server where the certificate request is stored.
41. Open the certificate with Notepad, and copy the content between BEGIN NEW CERTIFICATE REQUEST and END NEW CERTIFICATE REQUEST.

Type
Host or child 
domain/alias 

name
FQDN FQDN of mail server

Mail Exchanger (MX) Leave blank domain.com exchangeserver.domain.com 

Alias (CNAME) Autodiscover Autodiscover.domain.com exchangeserver.domain.com 

Alias (CNAME) Owa Owa.domain.com exchangeserver.domain.com
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42. Paste the copied content into the Saved Request window. 
43. Choose Web Server in the Certificate Template drop-down menu, and click Submit.
44. Choose Base 64 encoded, and download the certificate.
45. Copy the new certificate into the share folder on the Exchange server.
46. Log back into the Exchange server and open the Exchange Admin Center.
47. Go to Servers→Certificates, and highlight the certificate you began before (should say Pending request in the status column).
48. Click Complete on the right side.
49. Type the path to the certificate, including the certificate name, and click OK. Example: \\exchange\share\certnew.CER
50. Verify that the status has changed to Valid.
51. Edit the new entry, and click Edit.
52. Go to Services, check SMTP and IIS, and click Save.
53. On the warning message, click Yes.
54. Run the following steps on the Exchange and AD servers:

a. Click Start, and type MMC
b. Click File→Add/Remove Snap-in.
c. Choose Certificates, and click Add. 
d. Choose Computer account, and click Next.
e. Choose Local computer, and click Finish.
f. Click OK.
g. Expand Certificates→Trusted Root Certificate Authorities→Certificates.
h. Click Action→All Tasks→Import.
i. Click Next.
j. Browse to the share folder on the Exchange server, and choose the new certificate you created. Click Next.
k. Leave defaults, and click Next.
l. Click Finish.
m. On the Import was successful message, click OK.

55. Log into the Exchange server, and open the Exchange admin center.
56. Navigate to Servers→Databases.
57. Restart the Microsoft Exchange Information Store service on the MB server.
58. Using the Edit button, disable the maintenance schedule, and enable circular logging for each mailbox database.
59. Dismount and remount the databases.
60. Open the Exchange Management shell, and enter the following to move the paths of the default mailbox: 

Move-Databasepath “DatabaseName” –EdbFilepath “E:\Newlocation\DBname.edb” –LogFolderpath 
“F:\Newlocation”

61. When prompted, type A, and press Enter.
62. Open Exchange Management Shell, and enter the following: 

Get-OutlookAnywhere |Set-OutlookAnywhere -ExternalHostname exchange.domain.com 
-DefaultAuthenticationMethod NTLM -ExternalClientsRequireSsl $true

Configuring the Microsoft SQL Server 2014 server
For the legacy environment, we created large dedicated LUNs on the Dell EqualLogic PS6110 for the SQL database, 
logs, and backup. For the upgraded VMware environment, we added a 60GB VMDK for the database, a 30GB VMDK for 
logs, and a 50GB VMDK for backup to the SQL VM using the Dell Storage SC4020 datastore.

Installing SQL Server 2014 with Service Pack 1
1. Prior to installing, add the .NET Framework 3.5 feature to the server.
2. Mount the installation DVD for SQL Server 2014. 
3. Click Run SETUP.EXE. If Autoplay does not begin the installation, navigate to the SQL Server 2014 DVD, and double-click it.  
4. In the left pane, click Installation. 
5. Click New SQL Server stand-alone installation or add features to an existing installation. 
6. Select the Enter the product key radio button, and enter the product key. Click Next. 
7. To accept the license terms, click the checkbox, and click Next. 
8. Click Use Microsoft Update to check for updates, and click Next.  
9. To install the setup support files, click Install. 
10. If there are no failures displayed, click Next.  
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11. At the Setup Role screen, choose SQL Server Feature Installation, and click Next.  
12. At the Feature Selection screen, select Database Engine Services, Full-Text and Semantic Extractions for Search, Client Tools Connectivity, Client 

Tools Backwards Compatibility, Management Tools – Basic, and Management Tools – Complete. Click Next. 
13. At the Installation Rules screen, after the check completes, click Next. 
14. At the Instance configuration screen, leave the default selection of default instance, and click Next. 
15. At the Server Configuration screen, choose NT Service\SQLSERVERAGENT for SQL Server Agent, and choose NT Service\MSSQLSERVER for SQL 

Server Database Engine. Change the Startup Type to Automatic. Click Next. 
16. At the Database Engine Configuration screen, select the authentication method you prefer. For our testing purposes, we selected Mixed Mode. 
17. Enter and confirm a password for the system administrator account. 
18. Click Add Current user. This may take several seconds. 
19. Click Next. 
20. At the Error and usage reporting screen, click Next. 
21. At the Installation Configuration Rules screen, check that there are no failures or relevant warnings, and click Next. 
22. At the Ready to Install screen, click Install. 
23. After installation completes, click Close. 
24. Run through the installation again, creating a new installation of SQL with the same settings.
25. Close the installation window. 

Generating the DVD Store 2 data
We generated the data using the Install.pl script included with DVD Store version 2.1 (DS2), providing the parameters 
for our 40GB database size and the Microsoft SQL Server 2014 platform. We ran the Install.pl script on a utility system 
running Linux.® The Install.pl script also generated the database schema. 

After processing the data generation, we transferred the data files and schema creation files to a Windows-based system 
running SQL Server 2014. We built the 40GB database in SQL Server 2014, then performed a full backup, storing the 
backup file on the SQL backup LUN for quick access. We used that backup file to restore the server between test runs.

The only modifications we made to the schema creation scripts were the specified file sizes for our database. We 
explicitly set the file sizes higher than necessary to ensure that no file-growth activity would affect the outputs of the 
test. Apart from this file size modification, we created and loaded the database schema according to the DVD Store 
documentation. Specifically, we followed these steps:

1. Generate the data and create the database and file structure using database creation scripts in the DS2 download. Make size modifications specific 
to the 40GB database and the appropriate changes to drive letters. 

2. Transfer the files from a Linux data generation system to a Windows system running SQL Server.  
3. Create database tables, stored procedures, and objects using the provided DVD Store scripts.  
4. Set the database recovery model to bulk-logged to prevent excess logging.  
5. Load the generated data into the database. For data loading, use the import wizard in SQL Server Management Studio. Where necessary, retain 

options from the original scripts, such as Enable Identity Insert. 
6. Create indices, full-text catalogs, primary keys, and foreign keys using the database-creation scripts. 
7. Update statistics on each table according to database-creation scripts, which sample 18 percent of the table data. 
8. On the SQL Server instance, create a ds2user SQL Server login using the following Transact-SQL (T-SQL) script: 

USE [master]  
GO  
CREATE LOGIN [ds2user] WITH PASSWORD=N’’,  
 DEFAULT_DATABASE=[master],  
 DEFAULT_LANGUAGE=[us_english],  
 CHECK_EXPIRATION=OFF,  
 CHECK_POLICY=OFF  
GO 

9. Set the database recovery model back to full. 
10. Create the necessary full text index using SQL Server Management Studio. 
11. Create a database user and map this user to the SQL Server login. 

12. Perform a full backup of the database. This backup allows a restore of the database to a pristine state relatively quickly between tests.
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Our initial file size modifications.

Logical name Filegroup Initial size (MB)

primary PRIMARY 3

cust1 DS_CUST_FG 6,144 

cust2 DS_CUST_FG 6,144 

cust3 DS_CUST_FG 6,144 

cust4 DS_CUST_FG 6,144 

ind1 DS_IND_FG 3,280 

ind2 DS_IND_FG 3,280

ind3 DS_IND_FG 3,280

ind3 DS_IND_FG 3,280

ds_misc DS_MISC_FG 200

orders1 DS_ORDERS 3,072

orders2 DS_ORDERS 3,072

orders3 DS_ORDERS 3,072

orders4 DS_ORDERS 3,072

Log files

ds_log Not applicable 25,375

Upgraded Dell PowerEdge R730 environment
We used the following steps to configure the Dell PowerEdge R730 environment with VMware vSphere. For the 
backing storage, we created an 18TB LUN on the Dell Storage SC4020 and mapped the LUN to our three PowerEdge 
R730 servers via fibre channel. Once the virtual infrastructure was in place, we used the same steps from the legacy 
environment to create VMs identical to each server role.

Installing VMware ESXi 6 Update 2
1. Attach the installation media.
2. Boot the server. 
3. At the VMware Installer screen, press Enter. 
4. At the EULA screen, to Accept and Continue, press F11. 
5. Under Storage Devices, select the appropriate virtual disk, and press Enter. 
6. As the keyboard layout, select US, and press Enter.
7. Enter the root password twice, and press Enter.
8. To start installation, press F11. 
9. After the server reboots, press F2, and enter root credentials. 
10. Select Configure Management Network, and press Enter.
11. Select the appropriate network adapter, and select OK. 
12. Select IPv4 settings, and enter the desired IP address, subnet mask, and gateway for the server.
13. Select OK, and restart the management network.
14. Repeat steps 1 through 13 on all 24 servers.
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Deploying the VMware vCenter Server 6 Update 2
We used a client server running VMware ESXi to host our clients and virtualized management servers. For the VMware 
vCenter server VM, we installed Windows Server 2012 R2 and performed the following steps to install and configure 
vCenter.

1. Log into the vCenter VM.
2. From the VMware vCenter Server 6.0 install media, click Run to start the install wizard.
3. Select vCenter Server, and click Install.
4. At the Install wizard welcome screen, click Next.
5. Agree to the License Agreement, and click Next.
6. Select the Embedded Deployment option, and click Next.
7. Enter the system IP address.
8. Enter and confirm the password you wish to use with the Administrator account for vCenter Single Sign On, and click Next.
9. Click Next.
10. Accept the default database settings, and click Next.
11. Accept the default https port, and click Next.
12. Accept the default installation path, and click Next.
13. Uncheck Join the VMware Customer Experience Improvement Program, and click Next.
14. Click Install.
15. To exit the wizard, click Finish.
16. On the installer, click Exit.
17. Restart the server. 
18. Once completed, log into the first vCenter’s web client at https://vcenter-ip-address/vsphere-client/?csp.
19. Add all the necessary ESXi and vCenter licenses to the vCenter.

Creating the cluster and adding the hosts to VMware vCenter
We used the following steps to create each of the three clusters in each site and add the desired servers to the vCenter. 
The clusters on each site are management, edge, and compute.

1. Once logged into the vCenter, navigate to Hosts and Clusters.
2. Select the primary site management vCenter.
3. Right-click the vCenter object, and select New Datacenter…
4. Enter a name for the new datacenter, and click OK.
5. Right-click the new datacenter, and click New Cluster…
6. Enter a name for the new cluster.
7. Click OK.
8. Once the cluster has been created, right-click the cluster, and click Add Host.
9. Enter the IP address for the first PowerEdge R730 server, and click Next.
10. Enter the root credentials for the server, and click Next.
11. To accept the server’s certificate, click Yes.
12. Review the server details, and click Next.
13. Assign the desired license, and click Next.
14. Disable Lockdown mode, and click Next.
15. Click Finish.
16. Complete steps 9 through 15 for the remaining PowerEdge R730 servers.
17. Once all the servers are added to the cluster, right click a host, and click Storage→New Datastore.
18. Select VMFS, and click Next.
19. Enter a name for the new datastore, select the Dell Storage SC4020 LUN, and click Next.
20. Accept the defaults for the partition configuration, and click Next.
21. Click Finish.
22. Once the create datastore task is complete, ensure that all the hosts in the cluster are mounted on the new datastore.
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Configuring the VMware vSphere Distributed Switch for the cluster
For our networking configuration, we utilized vSphere Distributed Switches for the cluster. We then created port groups: 
Management, vMotion, and a port group for each Exchange VM network. Each port group utilized VLANs: 128 for 
Management, 1020 for vMotion, and 1001-1018 for Exchange.

1. Navigate to the Networking tab.
2. Expand the vCenter for the cluster.
3. Right-click the datacenter, and click Distributed Switch→New Distributed Switch.
4. Enter a name for the vDS, and click Next.
5. Select Distributed switch: 6.0.0, and click Next.
6. Set the number of uplinks to 2, and enter a name for the new default port group.
7. Click Next.
8. Review the settings, and click Finish.
9. Select the new vDS, and click the manage tab.
10. Under Properties, click Edit…
11. Click Advanced, and for the MTU setting, enter 9000.
12. Click OK.
13. On the left-hand side, right click the new port group that was created along with the new vDS.
14. Click Edit Settings.
15. Click VLAN, and for the VLAN (for the management port group), enter 128.
16. Click Teaming and Failover.
17. Set all the two uplinks to active.
18. Click OK.
19. Right-click the vDS, and click Distributed Port Group→New Distributed Port Group.
20. Enter a name for the new port group (e.g., vMotion), and click Next.
21. Under VLAN, set the VLAN to 1020 for vMotion.
22. Under Advanced, check the box Customize default policies configuration.
23. Click Next.
24. For Security, click Next.
25. For Traffic Shaping, click Next.
26. For Teaming and Failover, assign the two uplinks as active ports.
27. Click Next.
28. For Monitoring, click Next.
29. For Miscellaneous, click Next.
30. For Edit additional settings, click Next.
31. Review the port group settings, and click Finish.
32. Repeat steps 19-31, creating individual port groups for VLANs 1001-1018 to be used for individual Exchange environment networks.
33. Right-click the vDS, and click Add and Manage Hosts…
34. Select Add hosts, and click Next.
35. Click + New hosts…
36. Select all the hosts in the vCenter, and click OK.
37. Click Next.
38. Select Manage physical adapters and Manage VMkernel adapters, and click Next.
39. For each host, select each of the two 10Gb ports, click Assign uplink, and assign them to the two uplink ports.
40. Click Next.
41. Select the first host, and click +New adapter.
42. Click select an existing network, and click Browse.
43. Select the vMotion port group, and click OK.
44. Click Next.
45. Check the vMotion traffic box, and click Next.
46. Enter the desired network information for the new VMKernel, and click Next.
47. Click OK.
48. Select the new adapter, and click Edit adapter.
49. Click NIC settings.
50. Set the MTU to 9000.
51. Click OK.
52. Repeat steps 41-51 for each host.
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53. Click Next.
54. Analyze the impact, and click Next.
55. Review the settings, and click Next.

Creating the VMs
We created three gold image VMs for each of the workloads: SQL, Exchange, and AD with Iometer. We then used these 
gold images to clone out three workloads multiple times until we reached capacity on our storage array for a total of 18 
sets of the legacy environment. 

1. In VMware vCenter, navigate to Virtual Machines.
2. To create a new VM, click the icon.
3. Leave Create a new virtual machine selected, and click Next.
4. Enter a name for the virtual machine, and click Next. 
5. Place the VM on the desired host with available CPUs, and click Next.
6. Select the Dell Storage SC4020 LUN for the 40GB OS VMDK, and click next.
7. Click Next.
8. Select the guest OS as Windows Server 2012 R2, and click Next.
9. In the Customize Hardware section, use the following settings for each VM type:

a. For the SQL VM:
i. Set the vCPU count to 4.
ii. Set the Memory to 24GB, and check the Reserve all guest memory box.
iii. Add a 60GB VMDK for the database, a 30GB VMDK for logs, and a 50GB VMDK for SQL backup. Set all VMDKs to thick provision eager 

zeroed.
iv. For the NIC connection, select the default VM Network.
v. Attach a Windows Server 2012 R2 ISO to the CD/DVD drive.

b. For the Exchange VM:
i. Set the vCPU count to 4.
ii. Set the Memory to 12GB, and check the Reserve all guest memory box.
iii. Add a 120GB VMDK for the database, a 10GB VMDK for logs, and a 110GB VMDK for Exchange backup. Set all VMDKs to thick 

provision eager zeroed.
iv. Select the VLAN 1001 port group for the network adapter connection. This setting will change for each cloned Exchange VM in the order 

of VLAN 1002, VLAN 1003, etc.
v. Add a second network adapter, and set the connection to the default VM Network.
vi. Attach a Windows Server 2012 R2 ISO to the CD/DVD drive.

c. For the AD/Iometer VM:
i. Set the vCPU count to 4.
ii. Set the Memory to 2GB, and check the Reserve all guest memory box.
iii. Add a 120GB VMDK for Iometer. Set all VMDKs to thick provision eager zeroed.
iv. Select the VLAN 1001 port group for the network adapter connection. This setting will change for each cloned AD/Iometer VM in the 

order of VLAN 1002, VLAN 1003, etc.
v. Add a second network adapter, and set the connection to the default VM Network.
vi. Attach a Windows Server 2012 R2 ISO to the CD/DVD drive.

10. Click Next.
11. Click Finish.
12. Power on the VMs, and follow the steps outlined in the Legacy Environment section to install and configure each workload. 
13. Once each configuration is complete, clone out all three VMs until capacity is reached on the Dell Storage SC4020 LUN.
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Configuring the clients and running the test
We ran all test clients on a server running VMware ESXi. We used the following steps to configure each client VM.

Installing and configuring the Microsoft Exchange 2013 mail test clients and completing LoadGen 
configuration on Exchange 2013
For our testing, we used one virtual client machine to run LoadGen 2013. To create the mail clients, we installed several 
software components. We followed this process for each installation:

Installing Windows Server 2012 R2
1. Insert the installation media into the CD/DVD drive, and restart the server.
2. When prompted to boot from DVD, press any key.
3. When the installation screen appears, click My language is English (United States).
4. Leave language, time/currency format, and input method as default, and click Next.
5. Click Install now.
6. When the installation prompts you, enter the product key.
7. Select Windows Server 2012 R2 Datacenter (Server with a GUI), and click Next.
8. Check I accept the license terms, and click Next.
9. Click Custom: Install Windows only (advanced).
10. Select Drive 0 Unallocated Space, and click Next.
11. When the Settings page appears, fill in the Password and Reenter Password fields with the same password.
12. Log in with the password you set up previously.

To set up this server, we had to install several additional software components. The following subsections detail the 
necessary installation processes.

Joining the domain
1. Set a static IP.
2. Select Start→Control Panel→Network Connections→Local Area Connection.
3. Click Properties.
4. Highlight Internet Protocol (TCP/IP), and click Properties.
5. Select Use the following DNS server addresses, and enter the IP of the DNS server in the Preferred DNS server field. Click OK.
6. Right-click My Computer, and select Properties.
7. Under the Computer Name tab, click Change.
8. In the Computer Name Changes screen, select the Domain under the Member of section, and type test.local
9. To start joining the domain, select OK.
10. When the screen appears asking for a person qualified on the domain, type Administrator as the username and Password1 as the password.
11. At the Welcome pop-up window and the window warning that you must reset the computer for the changes to take effect, click OK.
12. At the System Properties screen, click OK.
13. When a pop-up appears asking if you want to restart now, click Yes to restart your computer.

Installing Internet Information Services
1. Click Start→Administrative Tools→Server Manager.
2. On the left pane, click Roles.
3. Click Add Roles.
4. Click the Application Server checkbox.
5. When the Add features required for Application Server? screen appears, click Add Required Features.
6. Click Next.
7. Click Next.
8. At the Select Role Services page for Application Server, click the Web Server (IIS) Support checkbox.
9. Click Add Required Support Role Services.
10. Click Next.
11. Click Next.
12. At the Select Role Services page for Web Server (IIS), click the IIS 6 Management Compatibility, ASP, and CGI checkboxes, and click Next.
13. Click Install.
14. Click Close.
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Importing the certificate and editing the hosts file
1. Click Start, and type MMC
2. Click File→Add/Remove Snap-in.
3. Choose Certificates, and click Add. 
4. Choose Computer account, and click Next.
5. Choose Local computer, and click Finish.
6. Click OK.
7. Expand Certificates→Trusted Root Certificate Authorities→Certificates.
8. Click Action→All Tasks→Import.
9. Click Next.
10. Browse to the share folder on the Exchange server, and choose the new certificate you created. Click Next.
11. Leave defaults, and click Next.
12. Click Finish.
13. On the Import was successful message, click OK.
14. Open the Notepad program, and use File→Open to open the hosts file stored at C:\Windows\System32\drivers\etc.
15. Add the IP and FQDN of the Exchange server.
16. Save and close Notepad.

Preparing Load Generator
1. Log into the mail client.
2. Download and install Load Generator 2013 using all defaults.
3. Select Start→All Programs→Microsoft Exchange→Exchange Load Generator 2013.
4. When the Load Generator screen appears, select Start a new test.
5. Select Create a new test configuration, and click Continue.
6. Change the total length of simulation to 1 hour.
7. In the Specify test settings screen, type Password1 as the Directory Access Password and Mailbox Account Master Password, and click Continue 

with recipient management.
8. Create 500 users in the Mailbox Database, and click Continue.
9. To accept defaults for Advanced recipient settings, click Continue.
10. In the Specify test user groups screen, select the plus sign to add a user group.
11. Change the Client Type to Outlook 2007 Cached, the action profile to Outlook_250, and the Mailbox size to 250 MB, and click Continue.
12. In Remote configurations, leave the checkbox to enable distributing the workload unchecked, and click Continue.
13. Click Save the configuration file as, and name it testcfg.xml
14. Click Start the initialization phase (recommended before running the test).
15. Once you have initialized the database, create a backup copy of the Exchange mailbox databases.

Configuring the database workload client
For our testing, we used a virtual client for the Microsoft SQL Server client. To create this client, we installed Windows 
Server 2012 R2 and assigned a static IP address. We then copied over the DS2 driver executable and the associated 
test scripts.

Running the tests
We ran all three tests simultaneously, using a script to kick off the final step of each of the following methodologies. 

Running the DVD Store test 
We created a series of batch files, SQL scripts, and shell scripts to automate the complete test cycle. DVD Store outputs 
an orders per minute (OPM) metric, which is a running average calculated through the test. In this report, we report the 
last OPM reported by each client/target pair. Each complete test cycle consisted of the following general steps: 

1. Clean up prior outputs from the target system and the client driver system. 
2. Drop the database from the target. 
3. Restore the database on the target. 
4. Shut down the target. 
5. Reboot the system under test and client system. 
6. Wait for a ping response from the system under test and the client system. 
7. Let the system under test idle for 10 minutes. 
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8. Start the DVD Store driver on the client. 
We used the following DVD Store parameters for testing:  

ds2sqlserverdriver.exe --target=<target_IP> --ramp_rate=10 --run_time=60 --n_threads=16 
--db_size=40GB --think_time=0.100 --detailed_view=Y --warmup_time=10 --report_rate=5 --csv_
output=<drive path>

Running the Iometer test
1. Reboot the system under test. 
2. Log in, and let the system idle for 10 minutes.
3. Open Iometer, and load the test file you made earlier during setup. 
4. To kick off the Iometer test, click the start button.

Running Load Generator
1. Log into the mail client.
2. Select Start→All Programs→Microsoft Exchange→Exchange Load Generator 2013.
3. When the Load Generator screen appears, select Start a new test.
4. Select load a test configuration, and click Continue.
5. Leave the settings at their already determined settings, and click continue, until you get to the last stage.
6. 10 minutes after you start the DVD Store and Iometer tests, click Skip initialization and start test.

Installing and configuring the management tools
We used the following steps to configure our management tool VMs for Dell Performance Analysis Collection Kit, 
VMware vRealize Operations Manager, and Dell OpenManage Essentials on the client servers. Each VM started with a 
base install of Windows Server 2012 R2.

Installing and configuring Dell OpenManage Essentials
1. Download Dell OpenManage Essentials. Open the installation media. 
2. Leave Dell OpenManage Essentials checked, and click Install.
3. At the Critical Prerequisites screen, click Install All Critical Prerequisites. When the warning dialog appears, to continue installation of the critical 

prerequisites, click Yes.
4. At the next prerequisites screen, click Install Essentials. To install Essentials on a local database, click Yes.
5. Click Install Essentials. 
6. Accept the license agreement for Dell OpenManage Essentials, and click Next. 
7. Leave the Typical setup type selected, and click Next.
8. Review the installation settings, and click Install.
9. When installation completes, leave Launch Dell OpenManage Essentials checked, and click Finish.
10. When Dell OpenManage Essentials launches, click the Manage tab.
11. Click the Discovery and Inventory subtab.
12. Click Add Discovery Range.
13. At the Discovery Range Configuration wizard, enter the IP address range for the first Dell servers. 
14. Click Add.
15. Click Next.
16. Leave the default Timeout and Retries ICMP parameters, and click Next.
17. Ensure the WS-Man discovery type is selected, and click Next.
18. Enter the iDRAC User ID and Password for discovery (root / calvin). Ensure that Secure Mode and Trusted Site are checked, and click Next.
19. Review the summary, and click Finish. 
20. From the Manage tab, click the Discovery and Inventory subtab.
21. Click Add Discovery Range.
22. At the Discovery Range Configuration wizard, enter the IP address range for the second Dell servers. 
23. Click Add.
24. Click Next.
25. Leave the default Timeout and Retries ICMP parameters, and click Next.
26. Ensure the WS-Man discovery type is selected, and click Next.
27. Enter the iDRAC User ID and Password for discovery (root / calvin). Ensure that Secure Mode and Trusted Site are checked, and click Next.
28. Review the summary, and click Finish. 
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Configuring Dell Performance Analysis Collection Kit (DPACK)
For this report, Dell gave us a DPACK account to download the tool and upload DPACK projects. We followed the steps 
below to perform DPACK data collection for each environment.

1. Download the Windows DPACK executable file to a Windows Server 2012 R2 client system.
2. Launch the executable file.
3. To agree to the license terms, click Yes.
4. Review the customer data, and click Yes.
5. To automatically upload DPACK collections to the web account, select Establish a secure (HTTPS) connection to the DPACK Web Service.
6. To generate a local IOKIT file, select Do not connect to the DPACK Web Service.
7. Click OK.
8. If DPACK has been configured previously, it will prompt you to decide if you want to use the previous setting. Click No.
9. Select the local drive listed, and click Ignore Disk.
10. Click Add Remote Server.
11. For the legacy environment, select Connect to a Windows server, and enter the IP of the first server. Then click Connect, and enter in the login 

credentials of the server. Repeat these steps to add the remaining two servers.
12. For the upgraded R730 environment, select Connect to a VMware vCenter Server, and enter the IP address of the vCenter server. Then click 

Connect. Click OK at the warning, and enter in the vCenter credentials. Select the R730 cluster, and click OK.
13. Once all desired servers are connected, select any undesired disks from the list, and click Ignore Disk.
14. Change the capture duration to 4 hours.
15. Click Start capture.

Note: For our testing, we started the capture right before kicking off each test run. We cancelled the capture at the 
end of roughly 1 hour, capturing data only when the servers were under load.

Installing and configuring VMware vRealize Operations Manager (vROPS)
Installing vROPS
1. Download the vRealize Operations Manager Appliance from VMware.
2. Open a browser, and connect to the vSphere Web Client.
3. Enter administrative credentials, and click Login.
4. In the left menu pane, click vCenter.
5. In the left menu pane, click Hosts and Clusters.
6. At the top of the center pane, select Actions->Deploy OVF Template…
7. Select Local File, and to locate the vRealize Operations Appliance OVA file, click the Browse button. Select the file, and click Open. Click Next.
8. Check the box “Accept extra configuration options”, and click Next.
9. To accept the EULA, click Accept, and click Next.
10. Select the vSphere datacenter to which you want to deploy the appliance, and click Next.
11. Accept the default configuration “Small”, and click Next.
12. Select the virtual disk format “Thin Provision”. Choose the datastore for housing the virtual machine files, and click Next.
13. Select the destination virtual network from the pull-down list, and click Next.
14. In Customize template, select Networking Properties and provide the IP address information for the virtual machine. Leave it blank if you prefer to 

use DHCP. Click Finish.

Configuring vROPS
1. Power on the virtual machine, and open the console in vSphere client.
2. Verify the IP address of the vROPs server, open a web browser, and connect to the vROPs page to begin configuration.
3. Click Express Installation.
4. Click Next.
5. Enter and re-enter a password for the default “admin” user. Click Next.
6. Click Finish.
7. When the initialization process completes, enter the username admin and the password you created for that user. Click Login.
8. Continue the configuration by clicking Next.
9. To accept the terms of the agreement, check the box, and click Next.
10. Enter the product key or accept the default for a product evaluation, and click Next.
11. Click Next.
12. Click Finish.
13. In the solutions section, select the VMware vSphere solution. To configure, click the gears icon in the top of that section.
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14. Select vCenter Adapter. For Instance settings, enter a display name and a description. Enter the vCenter Server address, and to add a new 
credential, click the green plus sign.

15. Enter a credential name, like vCenter Administrator, and enter the username and password for the user. We used administrator@vsphere.local and 
the relevant password. Click OK.

16. Click Test Connection.
17. To accept the certificate, click OK. Click OK.
18. Click Save Settings. Click OK.
19. Select the vCenter Python Actions Adapter.  
20. Select vCenter Adapter. For Instance settings, enter a display name and a description. Enter the vCenter Server address, and to add a new 

credential, click the green plus sign.
21. Enter a credential name, like vCenter Administrator, and enter the username and password for the user. We used administrator@vsphere.local and 

the relevant password. Click OK.
22. Click Test Connection.
23. To accept the certificate, click OK. Click OK.
24. Click Save Settings. Click OK.
25. Click Next.
26. Accept default settings for monitoring pools, and click Next.
27. Click Finish.
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Appendix C – Our setup
Legacy environment
For our legacy environment, we configured three identical Dell PowerEdge R710 servers. Each server contained 48 
GB of RAM and dual Intel Xeon E5520 processors. We installed Windows Server 2012 R2 with updates on each server 
and configured each server for its individual workload purpose. For the database workload server, we installed SQL 
Server 2014 SP1 with updates and configured a single SQL instance with a 40GB database for the DVD Store 2 server 
to target. For the mailbox workload server, we installed Microsoft Exchange 2013 with updates. We then generated a 
typical 500-mailbox environment using a Load Generator 2013 client. Finally, we configured the file server with Iometer 
and configured it to act as the Active Directory server for the Exchange environment. We cabled all three servers to a 
standard 1Gb Ethernet switch using the onboard NICs for client and management traffic. For information on our test 
methodology, see Appendix B.

For the backing legacy storage, we configured a Dell EqualLogic PS6110 array with 24 10K HDDs and 10Gb iSCSI 
connectivity. We cabled each of the EqualLogic’s controllers to a 10Gb Dell Networking S4810 switch with redundant 
paths. We then installed an Intel Ethernet Server Adapter X520 in each PowerEdge R710 and cabled both ports on each 
card to the S4810. We then configured each port for iSCSI traffic and multipath I/O using native Windows tools and the 
EqualLogic HIT Kit software. We presented each server with individual LUNs on the EqualLogic PS6110 for their specific 
workloads: three LUNs for the SQL database, logs, and backups to the database server; three LUNs for the Exchange 
mailbox database, logs, and backups to the mailbox server; and one LUN for the Iometer work file to the file server. See 
below for a detailed diagram of our legacy environment test bed.

Our legacy environment test bed

1Gb switch

Clients

Dell EqualLogic PS6110

Dell Networking S4810

Dell PowerEdge R710: SQL Dell PowerEdge R710: Exchange Dell PowerEdge R710: Iometer

1Gb

10Gb
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Upgraded environment
For our upgraded environment, we configured three identical Dell PowerEdge R730 servers. Each server contained 
256 GB of RAM and dual Intel Xeon E5-2660 v4 processors. We installed VMware vSphere 6 Update 2 on each server 
and created a three-node cluster in VMware vCenter Server. We cabled each server to a standard 1Gb switch using the 
onboard 1Gb NICs for client, management, and VM traffic. Additionally, we cabled the onboard 10Gb NICs to a Dell 
Networking S4810 switch for vMotion traffic. We configured all networks using VMware best practices.

For the backing storage, we configured a Dell Storage SC4020 array with twelve write-intensive SSDs and twelve mixed-
used SSDs. For storage connectivity, we connected two 8Gb fibre channel ports from each of the two storage controller 
modules to a Brocade 300 fibre switch with NPIV enabled. We then installed a QLogic GLE2562 8Gb fibre channel card 
in each PowerEdge R730 and cabled both ports to the Brocade switch. We created a single 18TB LUN on the storage 
and mapped the LUN to the PowerEdge R730 servers for VM storage with read and write cache enabled on the storage. 
See below for a detailed diagram of our upgraded environment test bed. 

Our upgraded environment test bed

Each server hosted a mix of database workload VMs, mailbox workload VMs, and file workload VMs, with each VM 
matching the software configuration of the legacy servers. With load-balancing, each PowerEdge R730 ran six sets of 
legacy workload VMs. We resized the VMs resources lower than the legacy environment servers to allow for maximum 
resource utilization and workload consolidation because our test VMs were performing at the level of the legacy 
environment or better. We also reserved all RAM for each VM to avoid memory contention. All VMDKs were thick 
provisioned eager zeroed. For each VM type, we used the following VM hardware settings:

Workload vCPU RAM 
(GB)

OS VMDK 
(GB)

Data VMDK 
(GB)

Log VMDK 
(GB)

Backup VMDK 
(GB)

Database 4 24 40 60 30 50

Mailbox 4 12 60 120 10 120

File 4 2 40 120 N/A N/A

1Gb switch

Clients

Brocade 300

Dell Storage SC4020

Dell Networking S4810

Dell PowerEdge R730: VMware vSphere Dell PowerEdge R730: ESXi Dell PowerEdge R730: ESXi

1Gb

8Gb Fibre

10Gb
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Appendix D – DPACK data
While we were testing, we ran DPACK on the upgraded Dell and VMware environment. Below are screenshots of 
the DPACK reports covering an hour-long test run in which the new solution is doing 18 times the work of the legacy 
solution. We used this data for the performance analysis of our test runs, specifically CPU, IOPS, and storage latency.

CPU
In the screenshot below, the upgraded environment achieved a peak CPU of 52.7 percent with an average of 
approximately 33 percent at a steady state. Storage capacity became our bottleneck. If we had added more storage 
capacity, we could have provisioned additional VMs on each host to get the most out of the compute resources because 
this environment was virtualized. 

IOPS
The upgraded environment with the all-flash array peaked at 17,576 IOPS during our testing. 
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Latency
Though the upgraded environment hit a peak of 56.7ms read and 25.1ms write latency early during the Exchange 
workload ramp-up, the latency during a steady performance state remained fairly even, at approximately 5ms write and 
9ms read latency.
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Additional DPACK counters
DPACK also provides many other graphs showing metrics like memory utilization, network and storage throughput, I/O 
size, and more. We did not use these graphs in our analysis. When you examine all the graphs together, the data they 
provide can give you a clear picture of your current environment’s performance needs as well as potential bottlenecks 
and limitations.
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