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Executive summary

At the time of the release of Windows Vista, Microsoft KEY FINDINGS

Corporation (Microsoft) commissioned Principled

Technologies (PT) to develop and run a set of tests that ® Overall, Windows Vista SP1 and Windows

compared the responsiveness of Windows Vista and XP performed comparably on most test

Windows XP SP 2 on common business tasks. Now, with operations. Performance differences

the release of Windows Vista Service Pack 1 (SP1), between the two operating systems were

Microsoft has commissioned an update that compares typically less than a half second and thus

those earlier test results to results of the same tests on insignificant. Significant differences of over a

Windows Vista SP1. second occurred on only nine of 128
measures; Windows Vista SP1 led on eight

The goal of the tests is to provide buyers with a sense of of those.

the differences in response time they would experience
when performing the same typical business operations on
each operating system (OS). We measured how
responsive each OS was when performing a set of

® \Windows Vista SP1 was noticeably more
responsive after rebooting than Windows XP
on several common business operations.

common business operations after rebooting, returning ® Overall, Windows Vista SP1 was more
from standby, and in ongoing operation. We ran the tests responsive than Windows Vista on most
on four systems : comparisons. Performance differences
between the two operating systems were
e Dell XPS 600 (desktop) typically less than a quarter second and thus
e Dell XPS M170 (notebook) insignificant.
e Hewlett-Packard d4100e (desktop)
e Toshiba Tecra M4 (tablet)

Microsoft provided the test systems and test settings. PT set up the systems, specified and developed the tests
and test procedures, and executed all the tests. We ran all the tests on the following three operating systems:

e Windows Vista Ultimate Version 6.0, build 6000 (Vista), the one that Microsoft released to manufacturing

e Microsoft Windows XP Version 5.1, build 2600.xpsp_sp2_gdr.050301-1519: Service Pack 2 (Windows
XP)

e Windows Vista Ultimate Version 6.0, build 6001, Service Pack 1, build 17128 (Vista SP1), a near-final
version of Windows Vista 6.0 Service Pack 1

We used the results from last year’s study for Windows Vista and Windows XP; we did not retest the systems with
those operating systems. The results from Windows Vista SP1 are from tests we conducted in January, 2008.

In this report, we examine the performance characteristics of the three versions of Windows, not the differences
among systems. So, though all four systems were shipping units whose configurations we detail in Appendix A,
we refer to them in the bulk of the report as System A, System B, System C, and System D.

The 64 test operations come from a realistic business scenario that we created and scripted.

We tested the response time of the test systems in two different states:

' The original testing included a Hewlett-Packard a1320y (desktop). We omitted that system from the charts and
analysis in this report because it produced unacceptably high variability in its test results. Appendix D provides
configuration information and detailed test results for this system.



e Cold: the state of a system after rebooting or after a program or set of programs has performed enough
RAM and disk operations to make the operating system have to reload any test application before it can
run that application. To execute these tests, the test script rebooted the systems, waited 120 seconds,
and then began the timed operations.

e Warm: the state of a system after it has already run a set of programs, possibly after returning from
standby. To execute these tests, the test script ran a second time after returning from standby and then a
third time immediately afterwards.

Figures 1 and 2 compare the cold state performance of Windows Vista SP1 and the two earlier operating systems
on four systems on 64 common business operations in four typical business computing projects.

Each bar in Figure 1 represents the average of the differences in response time on the four test systems between
Windows Vista SP1 and Windows Vista on one operation. The bars appear in the order in which the operations
appear in the scenarios, which we detail below. Bars above the 0.00 midline indicate tests in which Windows
Vista SP1 was faster. The yellow band contains all differences of less than a second; we believe most users
would not notice such small differences in performance times.

Space constraints prevent us from labeling the individual operations in the figures in this section. We instead call
out the most noticeable response time differences. We have labeled all the operations in the Test results section
and in the Detailed test results appendix.

As Figure 1 shows, Windows Vista SP1 was faster than Windows Vista on two-thirds of the operations in a cold
state. The differences were small, with none more than a half second. In tasks in which Vista led, the leads were
all under a fifth of a second.
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Figure 1: Average response time differences of Windows Vista SP1 over Windows Vista on a variety of operations on four
systems in a cold state. Numbers greater than zero indicate Windows Vista SP1 was more responsive. Differences greater
than one second are outside the yellow band. We describe each of those operations in the Scenarios descriptions section.
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Figure 2 shows that Windows Vista SP1 was faster on two-thirds of the operations in a cold state than Windows
XP. Vista SP1 was faster by more than a second on 6 of the 64 tasks, leading by more than 10 seconds on the
QuickBooks launch task and 4.5 seconds on the Explorer search task. On tasks where Windows XP was faster it
led by at most just over a half second.

The range for the y-axis that displays the response time difference in seconds is 5 to -5 except for the graphs
such as Figure 2 that shows the QuickBooks open task comparison. Because the response time difference for
that task is more than 10 seconds, the range for the y-axis for graphs displaying that task is 11 to -11.
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Figure 2: Average response time differences of Windows Vista SP1 over Windows XP on a variety of operations on four
systems in a cold state. Numbers greater than zero indicate Windows Vista SP1 was more responsive. Differences greater
than one second are outside the yellow band. We describe each of those operations in the Scenarios descriptions section.

The 64 operations come from a realistic business scenario that we created and scripted. This scenario covers
part of the day of Bob, the head of Sales and Marketing at Acme Ventures, a company that makes network
hardware and provides network services, including installation and testing. Acme Ventures has recently acquired
a small company, WileyBeep, which, like Acme Ventures, makes network hardware. WileyBeep specialized in
servers. Bob looks over WileyBeep’s income reports, which are in QuickBooks, to find ways to increase sales of
its products. In the process, he checks to see which companies are currently their biggest clients. He notes that
the biggest clients seem to jump on the leading-edge products, particularly servers, and that those products are
not coming to market as quickly as he would like. Bob is working on a plan to address the problem.

The scenario follows Bob as he works on the following four projects on his to-do list for the day. For ease of
reference, we refer to these projects by name (e.g., Project 1) elsewhere in this report.

o Project 1 — Bob reviews the income data in WileyBeep’s QuickBooks files.
e Project 2 — Bob finishes a draft of a document that describes his plan and emails that document for
review.
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e Project 3 — Bob edits a photo of the test network and adds it to the PowerPoint deck that will accompany
the plan.

e Project 4 — On the Acme Ventures Web site, Bob checks the PDF of the company brochure he must
update.

Each of these projects involves a number of basic operations, such as opening, editing, and closing files. The
results of the scenario are the response times for each of these tasks. The number of timed operations in each
project ranges from 6 to 33 and depends on the complexity of the project. We used realistic sizes and content for
all tests. The Scenario descriptions section provides more details on each project, the files it uses, and the
operations we timed.

To execute the common business operations, we ran a test script we developed to execute on both Windows
Vista and Windows XP. We used a Microsoft-supplied utility, ScenCap, to script these operations. ScenCap uses
the Windows accessibility interfaces to create and replay scenarios containing user actions.

We averaged the two different types of warm test results for Windows Vista and Windows XP and compared them
in Figures 3 and 4.

As Figure 3 shows, Windows Vista SP1 was faster than Windows Vista on nearly 83 percent of the operations in
a warm state. The differences were small, with most of them under a tenth of a second and with the greatest
difference under six-tenths of a second.
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Figure 3: Average response time differences of Windows Vista SP1 over Windows Vista on a variety of operations on four
systems after continuous operation. Numbers greater than zero indicate Windows Vista SP1 was more responsive.

Figure 4 shows that Windows Vista SP1 was faster than Windows XP on just over 54 percent of the operations in
a warm state. Differences were under a tenth of a second for 40 tasks, under a half second for 60 tasks and over
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a second for three tasks. Vista SP1 was more than 3.4 seconds faster on the Word file open task and just over a
second faster on the Outlook exit task; Windows XP led on the QuickBooks launch task by 1.7 seconds.
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Figure 4: Average response time differences of Windows Vista SP1 over Windows XP on a variety of operations on four
systems after continuous operation. Numbers greater than zero indicate Windows Vista SP1 was more responsive.
Differences of more than a second are outside the yellow band.

Test results

In the following subsection, we examine the test results by project. Because the charts in the Project results
subsection show fewer operations, we have space to label each operation by name. Appendix C contains a table
of the average time for each operation on each system.

Each result we report for a system is the average of five runs on that system. Before conducting the timed runs on
a given PC and operating system combination, we ran the same workload three times on that system. We did so
to allow each operating system to “learn” and, if possible, to tune itself for the work it would be facing. This
approach allowed us to mimic what would occur on many users’ PCs over the first few days they use their
systems (and after each time they introduce a new application into their work mix). See the Test methodology
section for greater detail on how we conducted the tests.

Project results
The following figures show the results in a cold state and after continuous operation for each of the four projects.
In each figure, the operations appear in the order in which they occurred in the project. We first look at the cold

results.

In each figure, the operations appear in the order in which they occurred in the projects. We first look at the cold
results.
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Cold state results for Project 1: Bob reviews the income data in WileyBeep’s QuickBooks files
Figures 5 and 6 show the cold state (after a reboot) operation results of Project 1.

Figure 5 compares cold state response time for Windows Vista SP1 and Windows Vista on Project 1. The
operations in this project showed little response time differences between Windows Vista SP1 and Windows
Vista. Windows Vista SP1 led on four of the six tasks in this project. All of the differences were under a second,
and four were under a tenth of a second. The greatest difference was the approximately third of a second Vista
SP1 lead on the QuickBooks exit task.
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Figure 5: Average response time differences between Windows Vista SP1 and Windows Vista on a variety of operations in
Project 1 on four systems when in a cold state.
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Figure 6 compares cold state response time for Windows Vista SP1 and Windows XP on Project 1. Windows
Vista SP1 led on four tasks in this project. The greatest response time difference for all the tasks in this project
was on the QuickBooks launch task, on which Vista SP1 led by over 10 seconds. None of the other differences
were dramatic; all were under three-fourths of a second, and four were under a tenth of a second.
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Figure 6: Average response time differences between Windows Vista SP1 and Windows XP on a variety of operations in
Project 1 on four systems when in a cold state.
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Cold state results for Project 2: Bob finishes a draft of a document that describes his plan and emails that
document for review

Figures 7 and 8 compare cold state response time for Windows Vista SP1 and Windows Vista on Project 2. .
(There were too many operations in this project to fit them all in one chart, so we split the project’s operations into
two charts.) None of the differences were dramatic; all were under a quarter of a second, and 29 of the 33 tasks
showed less than a tenth of a second difference. Windows Vista led on 20 tasks.
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Figure 7: Average response time differences between Windows Vista SP1 and Windows Vista on a variety of operations in
the first half of Project 2 on four systems when in a cold state.
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Figure 8: Average response time differences between Windows Vista SP1 and Windows Vista on a variety of operations in
the second half of Project 2 on four systems in a cold state.
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Figures 9 and 10 compare cold state response time for Windows Vista SP1 and Windows XP on Project 2.

Windows Vista SP1 was faster by more than a second on three tasks, leading by one second on the Word launch,
over two seconds on the Outlook launch task, and by 4.5 seconds on the Explorer search task. None of the other
differences were dramatic; 28 of the 33 differences were under a half second, and 16 of those were under a tenth
of a second. Three of the project tasks showed significant, over a second, response differences. All of those were

Windows Vista SP1 wins. Windows Vista led by 2.1 seconds, on the Outlook launch task, by 1.1 second on the

Word launch task, and 4.5 seconds on the Explorer search task.
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Figure 9: Average response time differences between Windows Vista SP1 and Windows XP on a variety of operations in the
first half of Project 2 on four systems when in a cold state.
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Figure 10: Average response time differences between Windows Vista SP1 and Windows XP on a variety of operations in
the second half of Project 2 on four systems in a cold state.
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Cold state results for Project 3: Bob edits a photo of the test network and adds it to the PowerPoint deck

that will accompany the plan

Figures 11 and 12 show the cold state (after a reboot) operation results of Project 3.

Figure 11 compares cold state response time for Windows Vista SP1 and Windows Vista on Project 3. Windows

Vista SP1 led on 11 of the 16 tasks. None of the differences were significant; 15 were under a tenth of a second,

and all were under a quarter of a second.
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Figure 11: Average response time differences between Windows Vista SP1 and Windows Vista on a variety of operations in
Project 3 on four systems when in a cold state.
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Figure 12 compares cold state response time for Windows Vista SP1 and Windows XP on Project 3. Windows

SP1 led on 11 of the 16 tasks. None of the differences were dramatic; nine were under a tenth of a second and all

but one, the .56 second Vista SP1 win for the PowerPoint launch task, were under a half second. The biggest
time difference was on the PowerPoint launch task where Windows Vista SP1 was faster by over half a second.
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Figure 12: Average response time differences between Windows Vista SP1 and Windows XP on a variety of operations in
Project 3 on four systems when in a cold state.
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Cold state results for Project 4: On the Acme Ventures Web site, Bob checks the PDF of the company
brochure he must update

Figures 13 and 14 show the cold state (after a reboot) operation results of Project 4.

Figure 13 compares cold state response time for Windows Vista SP1 and Windows Vista on Project 4. Windows
Vista SP1 was faster on all but one of the nine operations, although none of the operations performed noticeably
differently on the two operating systems. Eight of the differences were under a tenth of a second, and all were
under half a second.
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Figure 13: Average response time differences between Windows Vista SP1 and Windows Vista on a variety of operations in
Project 4 on four systems when in a cold state.
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Figure 14 compares cold state response time for Windows Vista SP1 and Windows XP on Project 4. Windows
Vista SP1 was faster on seven of the nine tasks in this project. The Windows XP leads were all under a tenth of a
second. Windows Vista SP1 led by over 2 seconds on the Adobe exit task and over a second on the Adobe
launch PDF project. All other differences were under a second, with six under a half second and four under a
tenth of a second.
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Figure 14: Average response time differences between Windows Vista SP1 and Windows XP on a variety of operations in
Project 4 on four systems when in a cold state.
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Warm state results for Project 1: Bob reviews the income data in WileyBeep’s QuickBooks files

Figures 15 and 16 show the continuous operation (warm, after return from standby, and after a previous run)

results of Project 1.

Figure 15 compares warm state response time for Windows Vista SP1 and Windows Vista on Project 1. None of

the differences were dramatic. Windows Vista SP1 was faster by 0.57 seconds on the QuickBooks launch task.

All other differences were under a tenth of a second.
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Figure 15: Average response time differences between Windows Vista SP1 and Windows Vista on a variety of operations in
Project 1 on four systems after continuous operation.

Principled Technologies, Inc.: Responsiveness of Windows Vista™, Windows Vista™
SP1, and Windows XP™ on common business tasks

16



Figure 16 compares warm state response time for Windows Vista SP1 and Windows XP on Project 1. In contrast

to its cold result, the QuickBooks launch, which starts the application and opens a data file, was noticeably, 1.8
second, faster for Windows XP. None of the other operations performed noticeably differently on Windows Vista
SP1 and Windows XP.
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Figure 16: Average response time differences between Windows Vista SP1 and Windows XP on a variety of operations in
Project 1 on four systems after continuous operation.
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Warm state results for Project 2: Bob finishes a draft of a document that describes his plan and emails
that document for review

Figures 17 through 18 show the continuous operation results of Project 2. (There were too many operations in this
project to fit them all in one chart, so we split the project’s operations into two charts.)

Figures 17 and 18 compare warm state response time for Windows Vista SP1 and Windows Vista on Project 2.
Windows Vista SP1 led on 26 of the 33 tasks. Average response time differences between Windows Vista SP1
and Windows Vista were under a tenth of a second on 27 of the operations in this project and under a quarter of a
second on all of the operations.

Average warm operation time differences between
Windows Vista SP1 and Windows Vista

5 00 on Project 2 (first half) A

' ey
T 4.00 8
L] e
§ 300 o
£ 200 =
0 w
E 1.00 S
E 0.00 S— S T T T S T T — T T T T T |
1]
:-_E- -1.00 E
B0 8
= ]
@ -3.00 E
§ -4.00
£ -5.00 \/

: @
o o Q&&‘* P Iy FEACIC I
& 5 @ A . @
o@# O éd“é & & ® o°°e¢ S ?}*"& & @ o S a{@@
AT I i C R S NSRS P AC I S
KN W Ca .@é\ <
Operations in the project <F

Figure 17: Average response time differences between Windows Vista SP1 and Windows Vista on a variety of operations in
the first half of Project 2 on four systems after continuous operation.
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Figure 18: Average response time differences between Windows Vista SP1 and Windows Vista on a variety of operations in
the second half of Project 2 on four systems after continuous operation.
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Figures 19 and 20 compare warm state response time for Windows Vista SP1 and Windows XP on Project 2.
Windows Vista SP1 led on 22 of the 33 tasks in this project. The average response time differences between
Windows Vista SP1 and Windows XP were under a tenth of a second on 18 of the operations in this project and
under a half second on all of the operations. The Word file open task was the only task where the difference was
more than a second. On that task, Windows Vista SP1 led by 3.4 seconds due to the poor task performance of
one of the systems. Only one task, the Word file open, showed a significant response time difference, with
Windows Vista SP1 leading by 3.4 seconds on the Word file open task.
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Figure 19: Average response time differences between Windows Vista SP1 and Windows XP on a variety of operations in
the first half of Project 2 on four systems after continuous operation.
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Average warm operation time differences between
Windows Vista SP1 and Windows XP
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Figure 20: Average response time differences between Windows Vista SP1 and Windows XP on a variety of operations in
the second half of Project 2 on four systems after continuous operation.

Warm state results for Project 3: Bob edits a photo of the test network and adds it to the PowerPoint deck
that will accompany the plan

Figures 21 and 22 show the continuous operation results of Project 3.
Figure 21 compares warm state response time for Windows Vista SP1 and Windows Vista on Project 3. None of

these operations performed noticeably differently on the two operating systems. Differences were under a tenth of
a second on 15 of the 16 tasks and under a quarter of a second on all tasks.
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Figure 21: Average response time differences between Windows Vista SP1 and Windows Vista on a variety of operations in
Project 3 on four systems after continuous operation.

Principled Technologies, Inc.: Responsiveness of Windows Vista™, Windows Vista™
SP1, and Windows XP™ on common business tasks

22



Figure 22 compares warm state response time for Windows Vista SP1 and Windows XP on Project 3. None of the
16 operations performed noticeably differently on the two operating systems with each operating systems being
faster on half of the tasks. All of the differences were under a quarter of a second and 13 were under a tenth of a
second.

Average warm operation time differences between
Windows Vista SP1 and Windows XP

5.00 on Project 3 A
2} v
'§ 4.00 8
S 300 o
i w
£ 2.00 ©
@ o
m 1.00 =
= ==
E OOO T T T T T T
£
ES -1.00 E
4] (]
E -2.00 8
w300 &
s 400
{= 8
é -5.00 \/

\
q\a\ﬁ il \‘6@ -o&&e 9@6.6\ @9@ &(\\G .\\rb éa.is\ Q‘F{CL
O é A Y @07 oo & o0 e &g e
o @999 % & @8 L RS
o d\"“\\ o ?0‘0 6\":@9 Qp‘b"{\ oﬂ"‘qd S 0&"“@ \&6\!\ ¢

. N ‘\ v
< Gl@&@dﬂ@ d‘ G“d Q\o Q\G &3 ‘!@ < o\’&#\@ 06\. N
Q & Q\o‘&

Operations in the project

Figure 22: Average response time differences between Windows Vista SP1 and Windows XP on a variety of operations in
Project 3 on four systems after continuous operation.
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Warm state results for Project 4: On the Acme Ventures Web site, Bob checks the PDF of the company

brochure he must update

Figures 23 and 24 show the continuous operation results of Project 4.

Figure 23 compares warm state response time for Windows Vista SP1 and Windows Vista on Project 4. Windows

Vista SP1 led on all nine tasks in this project. None of the differences were dramatic; all were under a third of a

second, and eight were under a tenth of a second.
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Figure 23: Average response time differences between Windows Vista SP1 and Windows Vista on a variety of operations in
Project 4 on four systems after continuous operation.
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Figure 24 compares warm state response time for Windows Vista SP1 and Windows XP on Project 4. Only two of

the differences were over a half second: Vista SP1 led on the Adobe exit task by just over a half second and on
the Outlook exit task by a second. None of the other operations performed noticeably differently on Windows
Vista and Windows XP.
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Figure 24: Average response time differences between Windows Vista SP1 and Windows XP on a variety of operations in
Project 4 on four systems after continuous operation.
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Scenario descriptions

The business scenario covers part of the day of Bob, the head of Sales and Marketing at Acme Ventures, a
company that makes network hardware and provides network services, including installation and testing. Acme
Ventures has recently acquired a small company, WileyBeep, which, like Acme Ventures, makes network
hardware. WileyBeep specialized in servers. Bob looks over WileyBeep’s income reports, which are in
QuickBooks, to find ways to increase sales of its products. In the process, he checks to see which companies are
currently their biggest clients. He notes that the biggest clients seem to jump on the leading-edge products,
particularly servers, and that those products aren’t coming to market as quickly as he’d like. Bob is working on a
plan to address the problem.

The scenario follows Bob as he works on the following projects on his to-do list for the day:

Review the income data in WileyBeep’s QuickBooks files.

Finish a draft of a document that describes his plan and email that document for review.

Edit a photo of the test network and add it to the PowerPoint deck that will accompany the plan.
On the Acme Ventures Web site, check the PDF of the company brochure he must update.

Each of these projects involves a number of basic tasks, such as opening, editing, and closing files. The results of
the scenario will be times for each of these tasks.

For each of Bob’s projects, we include a short title, a brief summary of the story behind the project, a list of the
applications he uses in that task, a description of the content we used, and a list of tasks we timed.

The number of tasks in each project ranges from 6 to 28 and depends on the complexity of the project.

Project 1: Review the income data in WileyBeep’s QuickBooks files

Story summary

Acme Ventures has recently acquired a small company, WileyBeep. Bob looks over WileyBeep’s Asset, Income,
and Expense graphs, which are in QuickBooks, to find ways to increase sales of its products. In the process, he
checks to see which companies are currently WileyBeep’s biggest clients.

Applications
e QuickBooks Pro 2006

Content
¢ QuickBooks: an approximately 10MB sample_product-based business.gbw file that Intuit includes with
QuickBooks

Timed operations

1. Bob opens QuickBooks. We time the application open.

2. He selects File>Open Company. In the open company dialog, he highlights sample-product based
business and clicks Open. A QuickBooks Information dialog displays, and he clicks OK. We time the file
open.

3. He selects Reports>Company & Financial->Income & Expense Graph. We time the appearance of the
graph.

4. He clicks the Dates button. On the Change Graph Dates dialog, he selects All for Graph Dates and clicks
OK. We time the appearance of the graph.

5. He clicks the By Customer button. We time the appearance of the graph.

6. He selects File>EXxit to exit QuickBooks. We time the exit.
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Project 2: Finish a draft of a document that describes his plan and email that document
for review

Story summary

Bob asks Gail, the head of R&D, to see if she can find a way to decrease product development cycles for the
WileyBeep team. Gail was already on this job. After studying the situation, she had realized that the best target for
optimization was product testing. She had learned that WileyBeep’s biggest testing bottleneck was its test
network, which its testers use to run an industry-standard benchmark, WebBench, on servers. Her department
has completed a report, which she had commissioned earlier, that demonstrates that she can get equally valid
results from smaller networks. This means she can split the test network into three smaller nets and triple their
effective network testing throughput potential without increasing anyone’s budget. She emails the appendix for the
report to Bob so he can include it in his supporting document for the plan.

Bob needs to add Gail's appendix to the document, make a few changes, and then send it back to Gail for her
final review. As this project’s section of the scenario opens, he sees the email message from Gail with the Word
document of the appendix attached. He opens the attachment in Outlook, searches in Windows Explorer for a
JPEG image of a network diagram, and copies both that image file and the appendix document into a local work
folder. He then pastes the JPEG image and the appendix text into his supporting document. Bob then edits a
chart in the draft, switches to Excel to create a chart of the results of a benchmark test of the network’s
performance, and adds that chart to the document. He saves the file in XML format and emails it to Gail for
review. Then he creates a zip file of the files he has been using and copies that zip file to an archive folder.

Applications
e Microsoft Outlook 2003
e Microsoft Word 2003
e Microsoft Excel 2003

Content
e Microsoft Outlook: a message with an attachment in an approximately 110MB Outlook database
e Microsoft Word: two large Word files (an approximately 1MB draft appendix attachment and a 2MB - 4MB
working supporting document draft file Bob opens)
Microsoft Excel: an approximately 300KB — 600KB Excel file with the benchmark results
Windows Explorer: an approximately 700KB JPEG image of a Visio diagram

Timed operations

1. Bob opens Outlook. We time the Outlook open.

2. He reads a message from Gail with a Word attachment. To open the attachment, he right-clicks the
message, selects View-> Attachments, and selects the attachment. We time the document open.

3. He opens Windows Explorer on a local folder. We time the Windows Explorer open.

4. He selects search and searches for JPG files. We time the search.

5. He selects the file containing the JPEG version of the Visio diagram for the supporting document. He
copies it and the appendix document into the folder for his latest version of the supporting document. We
time the copy of the doc file.

6. Bob copies the JPEG image file and selects Edit->Paste to insert it into the Word document. We time the
insertion.

7. In Word, Bob selects File>Save to save the Word document locally. When Word prompts him for a file

name, he names the file and presses Enter. We time the save.

He selects File>Open. We time the appearance of the Open dialog.

He names his supporting document and clicks Open. We time the file open.

0. He switches to the appendix document, chooses Edit->Select All to highlight the entire file, and then
presses Ctrl-C to copy the file contents. He switches to the main document, scrolls to the end, and
presses Ctrl-V to paste. We time the paste action.

= © @

Principled Technologies, Inc.: Responsiveness of Windows Vista™, Windows Vista™ 27
SP1, and Windows XP™ on common business tasks



11. In Outlook, Bob scrolls to a message from Gail with an Excel file attachment. To open the attachment, he
right-clicks the message, selects View->Attachments, and selects the attachment. We time the Excel file
open.

12. In Excel, he right-clicks the chart and selects Chart Options. He changes the title of the chart in the Chart
Options dialog and clicks OK. We time the appearance of the Chart Options dialog.

13. Bob selects File>Print Preview in Excel. We time the appearance of the Print Preview display.

14. He presses the Close button to close the Print Preview. We time the close.

15. He selects File>Page Setup in Excel. We time the appearance of the Page Setup dialog.

16. He closes Page Setup. He selects a table on an Excel worksheet and selects Insert Chart. The Chart
Wizard displays. We time the appearance of the Chart Wizard dialog.

17. Bob selects finish on the Chart Wizard. We time the chart creation.

18. Bob copies the chart, switches to the Word document, chooses Edit->Paste Special to insert the chart as
a Microsoft Office Excel Chart Object, and clicks OK. We time the insertion.

19. He selects Format->Object to edit the chart he just inserted. We time the appearance of the Format
Object dialog.

20. He goes to the Size tab and changes the scale to 150 percent. He selects Lock aspect ratio and clicks
OK. We time the object resize.

21. He selects File>Save As in Word. We time the appearance of the Save dialog.

22. He selects XML as the file type and clicks Save. We time the save.

23. Bob switches focus to Gail's message in Outlook and selects Reply. We time the message open.

24. On the new message, Bob selects Insert->File and highlights the document he just saved. He then
selects Insert. We time the insertion.

25. He selects File>Exit and then No when the application asks if he wants to save the changes. We time
the Exit.

26. He selects File>Close to close the original message from Gail. We time the close.

27. In Outlook, Bob selects Outlook Today. We time the appearance of the Outlook Today display.

28. Bob selects Mail to display the Inbox. We time the appearance of the Inbox.

29. Bob selects File>Exit to exit Excel. We time the exit.

30. Bob selects File>Exit to exit Word. We time the exit.

31. Bob opens Windows Explorer and locates the folder that holds the files he’s been using. He right-clicks
the folder name and selects Send To>Compressed (zipped) Folder. We time the compression.

32. He then copies the zip file to an archive folder. We time the copy.

33. He selects File>Exit to exit Windows Explorer. We time the exit.

Project 3: Edit a photo of the test network and add it to the PowerPoint deck that will
accompany the plan

Story summary

Bob is also nearly done working on a PowerPoint deck that summarizes the plan. He wants to present this deck to
the rest of the management team. To complete the deck, he must edit a photo of the network test bed and insert it
into the PowerPoint deck. He starts with a version of the deck that he received as an attachment from Gail. Bob
opens the PowerPoint deck and inserts a new slide. He then opens the photo in Microsoft Office Picture Manager,
edits it, and inserts the edited photo into the PowerPoint slide. He saves the file and sends it to Gail to review.

Applications
e Microsoft Office Picture Manager
e Microsoft Outlook 2003
e Microsoft PowerPoint 2003

Content
e Picture Manager: an approximately 1MB JPEG image of a photo of a network
e Outlook: a 110MB Outlook database we described in the Project 1
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e PowerPoint: a 3MB — 4MB PowerPoint summary of the network strategy evaluation white paper

Timed operations
The tasks are unavoidably slightly different in the two photo editors. We give instructions for each
of the editors in the task descriptions for the photo editing tasks.

1. In Outlook, Bob scrolls to the message from Gail that includes the PowerPoint attachment. To open the
attachment, he right-clicks the message, selects View—>Attachments, and selects the attachment. We
time the file open.

2. In PowerPoint, Bob selects View—>Slide Sorter to change the view to slide sorter. We time the view
change.

3. He selects Insert->New Slide to add a slide for the photo. We time the slide creation.

4. He selects View—>Normal to view the new slide. We time the view change.

5. He opens Windows Explorer and locates the picture he wants to add. The picture opens in Microsoft
Office Picture Manager. We time the open.

6. In Microsoft Office Picture Manager, he clicks Edit Picture and then Auto Correct. We time the auto
correction.

7. He clicks Crop and enters 50 pixels for the left and right crop handles and 100 for the top and bottom
handles. He then clicks OK. We time the crop operation.

8. In Microsoft Office Picture Manager, he selects File->Save As. In the Save As dialog, he types “Net” and
presses Save. He clicks Yes to confirm the save. We time the save.

9. In PowerPoint, He selects Insert->Picture>From file, highlights the photo he wants to insert, and clicks
Insert to insert the photo into the new slide he created. We time the insertion.

10. He selects File>Save As to save the file. He names the file and clicks yes to confirm the save. We time
the save.

11. In Outlook, he selects New to create a new message. We time the message creation.

12. He addresses the message to Gail and types a brief message. He selects Insert->File, highlights the
PowerPoint file he just saved, and selects Insert.

13. He selects File>Exit. A dialog asks if he wants to save the changes, and he selects No. We time the
message exit.

14. He selects File>Exit to Microsoft Office Picture Manager. We time the exit.

15. He selects File>Exit to exit Windows Explorer. We time the exit.

Project 4: On the Acme Ventures Web site, check the PDF of the company brochure he
must update

Story summary

Bob also wants to promote this new testing capability on the company’s Web site. Starting with the home page,
he reviews part of the site to find the right place to tout this new capability and the faster time to market it can help
Acme Ventures achieve. While he’s browsing the site, he also checks the PDF of the company brochure, because
he realizes it's old and something he should update soon.

He opens the Acme Ventures home page, which is also his IE home page. He browses through three additional
pages to one that has the PDF. He then opens the PDF on that page and to see how old the file is checks its
creation date on its document properties.

Applications
o Internet Explorer 7 (IE)
e Adobe Reader 7.0.8

Content
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o Internet Explorer: four pages from Acme Ventures’ Web site, including the home page. The HTML file
sizes range from 60 — 90KB for each page. The Web pages and the PDF to which one of them links
reside on a Web server that all five test clients share. To minimize the possibility of network traffic
affecting test results, the test clients and the Web server will be on an isolated network.

e Acrobat: a 300KB — 600KB PDF file of a brochure for Acme Ventures

Timed operations

1. Bob opens IE, which displays his company’s own home page. We time how long |E takes to launch and

display the page.

2. He clicks a link to another page on the site. We time how long IE takes to launch and display the page.

3. He follows a link on that page to another page on the site. We time that launch and display.

4. He clicks a link on that page as well. We time that launch and display.

5. He clicks a link for a PDF on that page, which opens the PDF in Adobe Reader. We time the PDF open.

6. He selects File>Document Properties in Adobe Reader. We time the appearance of the Document
Properties dialog.

7. He selects File>Exit to exit Adobe Reader. We time the exit.

8. He selects File>Exit to exit IE. We time the exit.

Test methodology

PT developed the scenarios and the test script we used for this evaluation. The script uses ScenCap to execute a
variety of common operations and runs on both Windows Vista and Windows XP. ScenCap is a Microsoft-
developed application that uses the Windows accessibility interfaces to create and replay scenarios containing
user actions. ScenCap also lets developers mark the start and end times of functions it performs.

Instructions for running the test script

This section details the steps you must follow to set up and run the test script, which we called PTVistaXPPerf.
We include instructions for running on both Windows Vista and Windows XP. For most functions the process is
the same on the two operating systems, but it is unavoidably sometimes slightly different.

Software this test requires
This test requires licensed copies of the following applications, which we list in alphabetical order. Testers must
install these applications on each test system:

Adobe Acrobat Reader 7.0.8

Adobe Flash Player 9.0

Intuit QuickBooks Pro Edition 2006

Microsoft Internet Explorer 7.0.5730.11 Version 7.0.5730.11 (Windows XP only)
Microsoft Office Professional Edition 2003

Microsoft Windows Server 2003 R2 Enterprise Edition

Windows Vista Ultimate Version 6.0, build 6000

Windows Vista Ultimate Version 6.0, build 6001, Service Pack 1, build 17128
Microsoft Windows XP Professional with Service Pack 2

In our tests, we used Symantec Norton Ghost 2003 to create sector-by-sector disk images of the systems after
we had installed the operating system and applications. We created one image for Windows Vista and one for
Windows XP for each test system. Before testing, we used Norton Ghost 2003 to restore the appropriate image to
the hard drive on the test system.

Hardware this test requires

This test requires an Internet Information Service (11S) 6.0 Web server running on Microsoft Windows Server 2003
R2 Enterprise Edition to test certain aspects of the performance of Internet Explorer 7.0. While other versions of
Windows and IIS may work, we have tested these scripts only against these versions of 1IS and Windows Server.
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We also recommend that the Web server and the machine under test be on the same network switch and IP
subnet.

All test systems must meet the Microsoft Windows Vista Ultimate Vista Ready requirements and the minimum
requirements for Microsoft Windows XP Professional with Service Pack 2, as appropriate. In addition, each must
have a network adapter and a valid network path to the Web server.

We recommend that all machines under test have the latest available drivers for their particular hardware
configuration.

Setting up a system for test using these scripts

To get the most accurate and repeatable results possible, you must set up all test systems carefully, starting with
a clean hard disk. Each test system must be able to access the Internet during setup so it can download software
updates.

Installing Microsoft Windows Vista Ultimate
Use the following process to install a clean version of Windows Vista Ultimate with updated drivers and Windows
Updates on each system under test:

1. Install Windows Vista Ultimate Build 6000.

a. Boot to a Windows Vista Ultimate Build 6000 DVD.

b. When prompted to press any key to boot from CD or DVD, press any key.

c. Atthe language and preference screen, accept the default options, and click Next.

d. Click Install now.

e. Do not enter a Product key. Uncheck Automatically activate Windows when I’'m online, and click Next.

f. At the Do you want to enter your product key now screen, click No.

g. Select Windows Vista Ultimate, and check | have selected the edition of Windows that | purchased.
Click Next.

h. Check | accept the license terms, and click Next.

i. Select Custom (advanced) at the Which type of installation do you want screen.

j.  Click Drive options (advanced).

k. Select the Disk you want to install Windows Vista Ultimate on, and click Format.

I.  Click OK at the all data stored will be permanently deleted dialog.

m. Once the system finishes formatting the disk, click Next.

n. Leave the password blank. Type User in the Username field, and click Next.

o. Type a computer name, and click Next.

p. Click Use recommended settings.

g. Select the correct Time zone, date, and time, and click Next.

r. Click Public location at the Select your computer’s current location screen.

s. Click Start at the Thank you screen.

t.  When the Windows Vista installation completes, close the Welcome Center Dialog.

u. Click Public location at the Set network location screen, and click Close.

2. Add the Web Server to the hosts file.

a. On the desktop, click Start, All Programs, Accessories, and then right-click Notepad.

b. Select Run as administrator.

c. Select Continue at the User Account Control screen to allow the Run as administrator action to
continue.

. Click File>Open, and enter c:\windows\system32\drivers\etc\hosts as the filename.

e. Enter the IP address of the Web server at the beginning of the first empty line at the bottom of the
hosts file. Note: Install the Web server by following the Installing the Internet Information Services
(IIS) Test bed Server steps below. Your Web server IP address will be unique to your installation. For
example, if your Web server IP address is 10.41.1.49, then the last line of the hosts file would read:
“10.41.1.49 webserver”.
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f
9.

h.

Press the tab key and then enter the Web server name “webserver”.
Click File>Exit.
Click Yes to save the changes to the hosts file.

3. Allow active content and close the information bar dialog in Internet Explorer 7.0:

i.
j-
k.

&
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Open Internet Explorer 7.0.

Click on Tools—>Internet Options.

Click on the Advanced tab.

Under the Security section, check Allow active content to run in files on My Computer, and click OK.
Enter the following in the Address bar: http://webserver/acmeventures.htm. Press Enter.

At the Did you notice the information bar dialog, check Don’t show this again, and click Close.
Widen the Internet Explorer window so that the five buttons from Home to Contact all show

Close Internet Explorer.

sable Hide extensions for known file types and set up folders.

On the desktop, click Start, Computer.

Select Organize->Folder and Search Options.

Select the View tab.

Uncheck Hide extensions for known filetypes.

Uncheck Use check boxes to select, if it is not already unchecked.

Check Show hidden files and folders.

Click OK.

Select Organize—~>Layout->Menu Bar. (Note: When you finish, the Menu Bar should appear on the
folder view.)

In the address bar, type C:\ and press Enter.

The script will not run if the Folder view is collapsed in the lower left-hand pane. If it is collapsed, click
the up arrow to reopen the Folder view.

Close the Explorer window.

5. Close the welcome screens for Windows Media Player:

a.
b.
c.

Click Start>All Programs—>Windows Media Player.
Check Do not show this screen at startup.
Click OK to close the welcome screen.

Installing Microsoft Windows Vista Ultimate Service Pack 1
Use the following process to apply Windows Vista Critical and Recommended Updates and driver updates and
then install Windows Vista Ultimate Service Pack 1 on the Vista Image:

1. Install all Windows Vista Critical and Recommended Updates and driver updates from the Microsoft
Updates site.

2. Install available driver updates form vendor websites.

3. Install Windows Vista SP1

@ poooTw

Insert the Windows Vista Service Pack 1 update DVD.

In Computer\DVD Drive (D:), double-click the Windows 6.0-KB936330-X86 executable file.
At the User Account Control dialog box, click Continue.

At the Install Windows Service Pack dialog box, click Next.

Check | accept the license terms, and click Next.

Close any open programs and click Install. The installation will take up to an hour.

At the Installation was successful dialog box, click Finish.

Installing Microsoft Windows XP Professional with Service Pack 2
Use the following process to install Windows XP Professional with Service Pack 2 with updated drivers and
Windows Updates on each system under test:

1. Install Windows XP Professional with Service Pack 2.

a.

Boot to a Windows XP Professional with Service Pack 2 CD.
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Press Enter at the Welcome to Setup screen.
Press F8 at the EULA screen.
Select the C: partition, and press Enter.
Select Format the partition using the NTFS file system (Quick), and press Enter.
Press F to format the selected partition.
Click Next at the Regional and Language Options screen.
Enter a user name into the Name field, leave Organization blank, and click Next.
Enter the Windows XP product key, and click Next.
Enter a Computer name, and click Next.
Enter the correct date, time, and time zone area, and click Next.
Select Typical settings, and click Next.
m. Select No, this computer is not on a network, or is on a network without a domain. Make this
computer a member of the following workgroup: leave the default workgroup, and click Next.
After the installer reboots the system, click OK to have Windows automatically adjust the screen
resolution.
Click OK at the Can you see this text at this resolution dialog (before the timer gets to zero).
Click Next at the Welcome to Microsoft Windows screen.
Select Not right now at the Help protect your PC screen, and click Next.
Enter your username at the Who will use this computer? screen, and click Next.
Click Finish at the Thank you screen.
2. Install all High-Priority Updates from the Microsoft Updates site.
3. Add the Web Server to the hosts file.
a. On the desktop, click Start, All Programs, Accessories, and then select Notepad.
b. Click File>Open, and enter c:\windows\system32\drivers\etc\hosts as the file you want to edit.
c. Enter the IP address of the Web server at the beginning of the first empty line at the bottom of the
hosts file.
d. Press the tab key, and then enter the Web server name “webserver”. Note: Install the Web server
by following the Installing the Internet Information Services (IIS) Test bed Server steps below. Your
Web server IP address will be unique to your installation. For example, if your Web server IP address
is 10.41.1.49, then the last line of the hosts file would read: “10.41.1.49 webserver”.
e. Click File=>Exit.
f. Click Yes to save the changes to the hosts file.
4. Download and install Internet Explorer 7.0 (IE7). Note: IE7 should be a part of the Windows Update
package. If it is already installed, skip to the next step to set up the Internet Explorer home page.

mT T TQ@meano
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a. Download IE7 from http://www.microsoft.com/windows/ie/downloads/default. mspx.
b. Double-click the IE7 executable.
c. Click Next at the welcome screen.
d. Click I Accept at the license agreement screen.
e. Click Validate at the validation screen.
f. Check Install the latest updates for Internet Explorer and the Microsoft Windows Malicious Software
Removal Tool, and click Next.
g. Click Restart Now at the installation complete screen.
5. Setup Internet Explorer 7.0.
a. Open Internet Explorer 7.0.
b. Atthe Run Once page, check Keep my current default search provider, and click Save settings.
c. Click Go to your home page.
d. Check Turn off automatic Phishing Filter, and click OK.
e. Click on Tools—>Internet Options.
f.  Click on the Advanced tab.
g. Under the Security section, check Allow active content to run in files on My Computer, and click OK.
h. Enter the following in the Address bar: http://webserver/acmeventures.htm. Press Enter.
i. Widen the Internet Explorer window so that the five buttons from Home to Contact all show
j-  Close Internet Explorer.
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6. Disable Hide extensions for known file types.

On the desktop, click Start, My Computer.

Select Tools—>Folder Options.

Select the View tab.

Uncheck Hide extensions for known filetypes.

Check Show hidden files and folders

Click OK.

Close My Computer.

7. Turn off Windows Service Pack 2 Security Center Pop-up Alerts. Doing so prevents such alerts from
occurring during testing and affecting results.

a. Open the system Control Panel.

b. Double-click Security Center.

c. Click Change the way Security Center Alerts me on the left.
d. Uncheck Firewall, Automatic Updates, and Virus Protection.
e. Click OK.

f. Close the Security Center main page.

8. Verify that Windows Automatic Updates are off. Turning off Windows Automatic Updates prevents such
updates from occurring during testing and affecting results. (We would have preferred to set the updates
to occur at a far future date, but we are not aware of an option for doing so.)

a. Click Start.
b. Right-click My Computer, and select Properties.
c. Select the Automatic Updates tab.
d. Select Turn off Automatic Updates.
e. Click OK.
9. Turn on auto logon.
a. On the desktop, click Start->Run.
b. Type control userpasswords2, and click OK.
c. Select the appropriate user account, and uncheck Users must enter a user name and password to
use this computer.
d. Click OK.
e. Leave the password fields blank, and click OK.

10. Turn off System Restore. Doing so prevents such events from occurring during testing and affecting
results.

Click Start.

Right-click My Computer, and select Properties.

Select the System Restore tab.

Check the box to the left of Turn off System Restore on all drives.

Click OK.

A warning screen will appear and ask if you are sure you want to turn off system restore. Click Yes.

~0 o0 o
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Copying the Code and Content files to the system under test
1. Unzip the PTVistaXPPerf code and content file (PTVistaXPPerf.zip).
2. Copy the PTVistaXPPerf code and content folder (PTVistaXPPerf) to the C:\PTVistaXPPerf folder.

Installing Adobe Acrobat Reader 7.0.8
Use the following process to install Adobe Acrobat Reader 7.0.8 on both Windows Vista and Windows XP test
systems:

1. Download Adobe Acrobat Reader 7.0.8 from: http://www.adobe.com/products/acrobat/readstep2.html.
2. Install Adobe Acrobat Reader 7.0.8 with default settings.

a. Double-click the Adobe Acrobat Reader executable.

b. Click Next at the Setup screen.
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c. Click Next at the Welcome screen.
d. Accept the default installation path and click Next.
e. Click Install.
f.  Click Finish.
3. Set Adobe Acrobat Reader 7.0.8 to open PDFs from an Internet Explorer session only in the Acrobat
Reader.
a. Click Start->All Programs—>Adobe Reader 7.0.
b. Click Accept at the License Agreement screen.
c. From the top menu, select Edit->Preferences.
d. Select the Internet category.
e. Uncheck Display PDF in browser.
f. Click OK.
g. Close Adobe Acrobat Reader.

Installing Adobe Flash Player 9.0
Use the following process to install Adobe Flash Player 9.0 on both Windows Vista and Windows XP test
systems:

1. For Windows Vista
a. Install Adobe Flash Player 9 from http://labs.adobe.com/downloads/flashplayer9.htmil.
b. Click the first link under the Flash Player 9 Installers titled Download installer for Windows Active X
(IE and AOL).
Click Run at the File Download — Security Warning dialog.
Click Run at the Internet Explorer — Security Warning dialog.
Click Yes at the Adobe Flash Player 9 dialog.
Click OK at the Installation Complete! dialog.
or Windows XP
Install Adobe Flash Player 9 from
http://www.adobe.com/shockwave/download/download.cgi?P1 Prod Version=ShockwaveFlash&pro
moid=BIOW.
b. Uncheck the box next to YAHOO! toolbar, and click Install Now.
c. Click Install at the security warning dialog.
d. Flash Player is successfully installed when the flash installation completion movie plays.

2.

® N0 a0

Note: We install Flash because Intuit QuickBooks Pro 2006 requires this application.

Installing Intuit QuickBooks Pro Edition 2006
Use the following process to install Intuit QuickBooks Pro Edition 2006 on both Windows Vista and Windows XP
test systems. This installation includes an automatic installation of the Microsoft .NET 1.1 Runtime.

Note: On the Windows Vista systems, we occasionally received the following message near the end of the Intuit
QuickBooks install: “Error 1904.Module C:\QB.ocx failed to register”. This error reflects a known QuickBooks

issue (see
http://www.quickbooks.com/Helpcenter/DoSearch.aspx?docType=DT APPROVEDCONTENT&p=SG QuickBook

s$2006Pro&q=1904). We clicked Ignore to bypass this error.

After the installation completes, open the C:\Program Files\Intuit\QuickBooks 2006 directory and double-click
reboot.bat.

1. Insert the Intuit QuickBooks Pro 2006 installation CD.
a. Click Install at the Welcome to QuickBooks screen.
b. Click Next at the .NET 1.1 Runtime installation screen.
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Click Next at the Welcome to QuickBooks Installation Wizard screen.
Select Accept and click Next at the License Agreement screen.
Enter the Intuit QuickBooks License Number and Product Number, and click Next.
Click Next on the Select Installation Folder screen to install QuickBooks to the default installation
folder.
Click Install at the Ready to install QuickBooks screen.
Click Finish at the QuickBooks Installation Complete screen.
Click OK at the QuickBooks 2006 Configuration verifying configuration dialog.
2. After Intuit QuickBooks successfully installs, begin the configuration by double-clicking the QuickBooks
desktop icon.
a. Click OK to close the auto update dialog.
b. Click File>Open Company.
c. Select sample_product-based_business.gbw, and click Open.
d. Click OK at the QuickBooks Information dialog.
3. Click Begin Registration (you must register).
a. Atthe registration screen, choose the following options from the drop-down menus, and then click

=0 a0
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Next:

e Yes

e Other

e More than 50
e Other

e No, No, No

Check Do not display this message in the future, and click OK at the Launch Web browser dialog.
Fill out the Web registration form, and then click Register QuickBooks.
Click Continue.
e. Click No thanks to ordering QuickBooks checks, and close Internet Explorer.
4. At the QuickBooks Learning Center Welcome to QuickBooks screen, uncheck Show this window at
startup and close the Welcome screen.
5. Turn off automatic updates by doing the following. (We would have preferred to set the updates to occur
at a far future date, but we are not aware of an option for doing so.)
Click Help~>Update QuickBooks—>Options.
Select No to Automatic Update.
Click Save.
Click the Update Now tab.
Click Get Updates.
When the Update QuickBooks screen status bar reports Update Complete, click Close.
Close QuickBooks.
To install the updates, open QuickBooks, and click Install Now on the QuickBooks Update Service
window. Note: On Windows Vista you will have to start QuickBooks as Administrator to install the
updates.
i. Tolaunch the QuickBooks Update utility, click Yes on the QuickBooks update information window.
j.  Click OK on the Update Complete dialog.
k. When QuickBooks opens, verify that a single window with the titte No Company Open appears.
I.  Click Close to exit QuickBooks
6. Intuit QuickBooks Pro 2006 installs .NET 1.1, which then requires the system to log on using a username
and password. To set the PC to log on automatically after a reboot, do the following:
a. Click the Windows Start button, type control userpasswords2 in the run command, and click OK.
b. On the Users tab, uncheck the box next to Users must enter a user name and password to use this
computer.
c. Click OK.
d. On both operating systems, Intuit QuickBooks must appear in the primary Start menu. If Intuit
QuickBooks does not appear in the Start menu, do the following:
i. Click Start->All Programs—>QuickBooks.

Qoo
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ii. Right-click QuickBooks Pro 2006, and select Pin to Start menu.

Installing Microsoft Office Professional Edition 2003
Use the following process to install a clean version of Microsoft Office Professional Edition 2003 on both Windows
Vista and Windows XP test systems:

1.

wn

Insert the Microsoft Office Professional Edition 2003 CD.

a. Enter the Product Key, and click Next.

b. Enter User Information, and click Next.

c. Click the check box next to | accept the terms in the License Agreement on the End-User License
Agreement screen, and click Next.

d. Select Typical Install, accepting the default installation location, and click Next.

e. Click Install.

f.  Click Finish at the Setup Completed screen.

Apply all high-priority Microsoft Office 2003 updates from the Microsoft Office update Web site.

After the Microsoft Office update process completes, reboot and re-run update for Microsoft Office to

verify that you have applied all available high-priority updates.

Open Excel to set up folders.

a. Click Start>All Programs—>Microsoft Office>Microsoft Office Excel 2003.

b. Close Microsoft Excel.

Copy the Microsoft Excel setup files to the proper folders.

a. On Windows Vista, copy C:\PTVistaXPPerf\benchmark\ XLUSRGAL.XLS to
C:\Users\<User>\Appdata\Roaming\Microsoft\Excel.

b. On Windows XP, copy C:\PTVistaXPPerf\benchmark\XLUSRGAL.XLS to C:\Documents and
Settings\User\Application Data\Microsoft\Excel.

Installing Microsoft Windows Server 2003 R2 Enterprise Edition and Microsoft Internet

Information Services 6.0 on the test server
As we mentioned earlier, the Business scenario requires a test server that acts as a Web server. Install Internet
Information Services 6.0 on that server using the following process:

1.

On the IIS Server system, insert the Microsoft Windows Server 2003 R2 Enterprise Edition CD into the
CD-ROM drive.

2. When a screen appears prompting you to press any key to boot from the CD, press any key.

3. Press Enter at the Welcome to Setup screen to setup Windows Server 2003.

4. Press F8 at the Windows Licensing Agreement screen.

5. If a previous version of Windows Server is already present, you will get a prompt asking if you would like
to repair the damaged installation. Press Esc to continue installing a fresh copy of Windows without
repairing.

6. Atthe Windows Server 2003 Setup screen, delete any existing C: partitions by selecting the partition to
delete and pressing the D key.

7. Press Enter to confirm the deletion.

8. Press L to reconfirm the deletion.

9. Back at the Windows Server 2003 Setup screen, select the Unpartitioned Space, and press Enter.

10. Using the arrow keys, select Format the partition using the NTFS file system (Quick), and press Enter.

11. Once Windows Server finishes the formatting and the file copy, it prompts you to restart your computer.
Press Enter to restart.

12. A Windows Server 2003 loading screen and then a Windows installation screen will appear. Wait for both
of those windows to go away.

13. Click Next at the Regional and Language Options screen.

14. When the installation software prompts you to Personalize Your Software, enter “server” as the name,
leave the organization field blank, and click Next.

Principled Technologies, Inc.: Responsiveness of Windows Vista™, Windows Vista™ 37

SP1, and Windows XP™ on common business tasks



15.
16.
17.

18.

19.

20.
21.
22.
23.

24.
25.
26.

27.
28.
29.

30.
31.
32.
33.
34.
35.
36.
37.
38.
39.
40.

At the Your Product Key screen, enter the product key, and click Next.

Leave the default settings at the Licensing Modes screen, and click Next.

For computer name, type “server”, and for administrator’s password, type “password”. Type “password”
again to confirm the password. Then click Next.

A Windows Setup Alert window will warn that the password you selected is not strong. Select Yes to
continue.

At the Date and Time Settings screen, select the current date and time and the appropriate time zone.
Leave the “Automatically adjust clock for daylight savings changes” checked, and click Next.

Windows will automatically complete the installation process and restart the server.

Press Ctrl-Alt-Delete when the system prompts you to begin running Windows Server.

Log on to Windows Server using the password you selected earlier.

At the Windows Setup Screen, the system will prompt you to insert Windows Server CD 2. Insert the CD,
and click OK.

At the Windows Server 2003 R2 Setup Wizard Welcome Screen, click Next.

At the Windows Server 2003 R2 Setup Wizard Setup Summary, click Next.

The Installer will copy more files to the server. When the Windows Server 2003 R2 Setup Wizard
Completing Windows Server Setup screen appears, click Finish.

At the Windows Server Post-Setup Security Updates screen, click Finish.

At the Windows Server Post-Setup Security Updates WARNING pop-up, click Yes to close the page.
At the Manage Your Server screen, check the box next to Don’t display this page at logon, and click the X
in the top right corner to close the screen.

After the system reboots, press Ctrl+Alt+Delete to begin, then enter your user name and password.

At the Manage Your Server screen, click Add or remove a role next to the small green arrow.

Click Next.

Select Application Server (IS ASP.NET) from the Server Role list, and click Next.

Leave the FrontPage Server Extensions and Enable ASP.NET options unchecked, and click Next.
Click Next again.

Click Next at the Windows Components Wizard pop-up window.

Insert the Windows Server 2003 R2 Enterprise Edition Disk 1 when the system prompts you to do so.
Exit the Microsoft Windows Server 2003 family window.

At the This Server is Now an Application server screen, click Finish.

Copy the contents of the PTVistaXPPerf\webserver folder (from the release files) to c:\inetpub\wwwroot.

Installing PTVistaXPPerf on the system under test
Use the following process to install PTVistaXPPerf on both Windows Vista and Windows XP test systems:

1.

Prepare the Outlook Database:

a. Click Start->Computer (or Start>My Computer for Windows XP), and navigate to
C:\PTVistaXPPerf\benchmark\documents\outlook.

Right-click and delete Mail.pst if it exists.

Right-click Officemail.pst.

Click copy.

Press Ctrl-v to create a copy of the file.

Right-click the copy.

Click Rename.

Enter Mail.pst, and press Enter.

Close the C:\PTVistaXPPerf\benchmark\documents\outlook folder by clicking the X in the upper right-
hand corner.

TJ@moao0T

2. Bring up a command-line interface, which you will use to perform the rest of this installation.
a. On Windows Vista, click Start->All Programs—>Accessories. Right-click Command Prompt-> Select
Run as Administrator to open the command-line interface window as Administrator.
b. On Windows XP, click Start->Run, and type cmd to open the command-line interface window.
3. Type cd\PTVistaXPPerf, and press Enter.
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Type setup, and press Enter.

The test script will now install on the system.

The setup script reboots the system as the final setup step.

After the reboot, open Outlook, and set it to show the Advanced toolbar:

Open Outlook by clicking Start->All Programs—>Microsoft Office>Microsoft Office Outlook 2003.
Select View—>Toolbars.

Check Advanced.

Windows XP, change the Power Options.

Click Start->Control Panel.

Click Performance and Maintenance.

Click Power Options

Select the Advanced Tab.

Uncheck Prompt for password when computer resumes from standby.

Click OK.

Close the Performance and Maintenance window.

Windows Vista, change the Power Options.

Click Start>Control Panel.

Click Hardware and Sound.

Click Power Options.

Under Preferred plans, High Performance, click Change plan settings.

Verify that Turn off the display: and Put the computer to sleep options are all set to Never. Note: if you
make changes to these settings, click Save changes, and then click Change plan settings under High
Performance.

Click Change advanced power settings.

Click the plus (+) sign next to Additional settings.

Change the Require a password on wakeup setting to No. If the machine is a laptop, change this
setting to No for both On battery and Plugged in.

Click OK.

Click File=>Close to exit the Edit Plan Settings dialog.

J-
10. Set Microsoft Office Picture Manager as the default handler for JPG files.

On

o
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On

Windows Vista:
Using Explorer, open the C:\PTVistaXPPerf\benchmark\Documents\Docs folder.
Right-click one of the JPG images in C:\PTVistaXPPerf\benchmark\Documents\Docs.
Select Open With->Choose Default Program.
On the Open With dialog, select Microsoft Office Picture Manager.
Check Always use the selected program to open this kind of file.
Select OK to confirm the default file types.
Close Microsoft Office Picture Manager.
ndows XP:
On the desktop, click Start, My Computer.
Select Tools>Folder Options.
Select the File Types tab.
Browse to JPG in the alphabetical list of extensions.
Click Change.
On the Open With dialog, select Microsoft Office Picture Manager.
Check Always use the selected program to open this kind of file.
Click OK.
Using Explorer, open the C:\PTVistaXPPerf\benchmark\Documents\Docs folder.
Right-click one of the JPG images in C:\PTVistaXPPerf\benchmark\Documents\Docs.
Select Open.
Select OK to confirm the default file types.
Close Microsoft Office Picture Manager.
Wmdows Vista, verify that Windows Aero is the default color scheme by following these steps:
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Right-click the desktop, and select Personalize.

Click Window Color and Appearance.

c. If an Appearance Settings dialog with a Color scheme drop-down appears, select Windows Aero
from the Color Scheme drop-down list, and press OK. If instead a Windows Color and
Appearance dialog displays, then Windows Aero is already the default Color Scheme.

oo

Running the test script
Use the following process to run the test script on either Windows Vista or Windows XP test systems:

1.

Reboot the system.

2. Bring up a command-line interface, which you will use to run the script.

a. On Windows Vista, click Start->All Programs->Accessories. Right-click Command Prompt-> Select
Run as Administrator to open the command-line interface window as Administrator.
b. On Windows XP, click Start>Run, and type cmd to open the command-line interface window.

3. Type cd\PTVistaXPPerf, and press Enter.

4. Type run —p —results c:\results (to set the directory in which the tool will place its results), and press Enter.

5. On Windows Vista, click Start->All Programs->Accessories. Right-click Command Prompt-> Select Run
as Administrator to open the command-line interface window as Administrator.

6. On Windows XP, click Start->Run, and type cmd to open the command-line interface window.

7. To run the scenario type: run —i 1 —s 8 —ir 1 —nopurge 1 —wab 120 —scenariotype office —label
[MachineNameandQOS], and press Enter. (This command runs the Business Scenario a total of 8 times: 1
run after rebooting, 1 run after return from standby, and 1 run immediately after the previous run. It waits
120 seconds after an initial reboot before starting, does not purge memory, and identifies the results files
with MachineNameandOS.)

8. At the completion of the run, check the results in c:\results. Each set of results is in a separate
subdirectory there. A status.txt file states whether the set of runs passed or failed. A log file gives
information about the run, including an error message for failed sets of runs. The IndividualRunCSy folder
includes a CSV file containing the results for the set of runs.

9. For subsequent runs on a different scenario, you must be sure the Outlook Mail.pst file is correct before
you start over at step 1 of this section.

a. Click Start>Computer (or Start->My Computer for Windows XP), and navigate to
C:\PTVistaXPPerf\benchmark\documents\outlook.

b. Right-click and delete Mail.pst if it exists.

c. Right-click Officemail.pst.

d. Click copy, and type Ctrl-v to create a copy of the file.

e. Right-click the copy.

f. Click Rename.

g. Enter Mail.pst, and press Enter.

h. Close the C:\PTVistaXPPerflbenchmark\documents\outlook folder by clicking the X in the upper right-
hand corner.
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Appendix A — Test system configurations

This appendix provides detailed configuration information about each of the test systems, which we list in
alphabetical order, and about the server we used to supply the test Web pages.

System

Dell XPS M170

Dell XPS 600

HP d4100e

Toshiba Tecra M4

General

Processor and OS
kernel: (physical,
core, logical)/(UP,
MP)

1P1C1L/UP

1P2C2L / MP

1P2C2L / MP

1P1C1L/UP

Number of physical
processors

—_

Single/dual-core
processors

Single

Dual

Dual

Single

Processor HT
status

NA

NA

NA

NA

System Power
Management
Policy (Vista)

High performance

High performance

High performance

High performance

System Power

Minimal Power

Minimal Power

Minimal Power

Minimal Power

number

ABAE-LE

Management
Policy (XP) Management Management Management Management
Notebook Enhanced Intel Enhanced Intel
processor power SpeedStep NA NA SpeedStep
saving option Technology Technology
Notebook ] : : .
dimensions (length (1::‘":2) )1(21 zm/;:(()z NA NA B E(rr:a1x))( 1% (min)
X width x height)
Notebook weight 8 Ibs. 10 oz. NA NA 6 Ibs. 2 oz.
CPU
System type Laptop Desktop Desktop Tablet PC
Vendor Intel Intel AMD Intel
Name Pentum M760  |PentumD 940 |Ah 10N 64X Pentium M 740
Stepping 8 2 1 8
Socket type mPGA-479M LGA775 Socket 939 mPGA-479M
Core frequency
(GHz) 2.0 3.2 2.0 1.73
Front-side bus 2,000 MHz
frequency (MHz) 533 800 HyperTransport 533

q y Technology
L1 cache 32KB+32KB |16 KB+ 12Kuops |on i " 04 EPe 137 4B 4+ 30 kB
L2 cache 2 MB 2 MB 512 KB per core 2 MB
Platform
vendorandmodel | pei xps M170 | Dell XPS 600 HP d4100e Toshiba Tecra M4
Motherboard model Dell OF8460 Dell OUH741 Asus Amberine Toshiba Portable

PC
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System

Dell XPS M170

Dell XPS 600

HP d4100e

Toshiba Tecra M4

Motherboard . NVIDIA nForce4 ATI Radeon Xpress .
chipset Intel I915PMIGM | g E e | 200 (Rs480) | ntel 1915PMIGM
Mof[h.erboard 03 A3 10 03
revision number
Motherboard serial 8MV5591 3YRJS91 MXG61802G4NA6 46053511H
number 60
BIOS name and  1p ) Ags5 Dell A11 Phoenix v3.15 Toshiba v3.20
version (Vista SP1)
BIOS name and
version (Vista and |Dell A0S Dell A11 Phoenix v3.14 Toshiba v3.20
XP)
BIOS settings Default Default Default Default
Memory module(s)
Hyundai Hyundai
Vendor and model | Electronics Samsung M3 Infineon Electronics
number HYMP564S64BP6- | 78T2953CZ3-CE6 [64D64320HU5C HYMP564S64BP6-
C4 C4
Type PC2-4200 PC2-5300 PC3200 PC4200
Speed (MHz) 533 667 400 533
Speed running in
the system (MHz) 266 333 200 266
Timing/Latency
(tCL-tRCD-tRP- 4-4-4-12 5-5-5-13 3-3-3-8 4-4-4-12
tRASmIn)
Size 1 GB 2 GB 1 GB 1 GB
Number of memory |, . 545 g 2x1GB 2 x 512 MB 2 x 512 MB
module(s)
Chip organization | Double-sided Double-sided Double-sided Double-sided
Channel Dual Dual Dual Dual
Hard disk
Vendor and model | Fujitsu Seagate Seagate Toshiba
number MHV2080AH ST3160828AS ST3160023AS MK4032GSX
Number of disks in
1 1 1 1
system
Size 80 GB 160GB 160 GB 40 GB
Buffer size 8 MB 8 MB 8 MB 8 MB
RPM 5400 7200 7200 5400
Type Ultra ATA SATA 300 Mb/s SATA 150 Mb/s SATA 150 Mb/s
Controller l(?ée;g_zl\%MFBM nForce4 MCP ATI SB400 l(?ée;g_zl\?;MFBM
Driver (Vista SP1) Microsoft Microsoft Microsoft Microsoft
6.0.6001.17128 6.0.6001.17128 6.0.6001.17128 6.0.6001.17128
Driver (Vista) Microsoft NVIDIA Microsoft Microsoft
6.0.6000.16386 5.10.2600.931 6.0.6000.16386 6.0.6000.16386
. Microsoft NVIDIA Microsoft
Driver (XP) 5.1.2600.2180  |5.10.2600.552  |5.1.2600.2180 Intel 6.1.0.1004
Graphics
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System

Dell XPS M170

Dell XPS 600

HP d4100e

Toshiba Tecra M4

Vendor and model

NVIDIA GeForce

NVIDIA GeForce

NVIDIA GeForce

NVIDIA GeForce

number Go 7800 GTX 7800 GTX 7300 LE Go 6200 TE
Chipset et oroe Go 7890 | GeForce 7800 GTX | GeForce 7300 LE | SeF ©7® G0 6200
BIOS version 5.70.02.19.12 5.70.02.11.15 5.72.22.34.21 5.43.02.49.E2
Type PCI-E PCI-E PCI-E PCI-E
Memory size 256 MB 256 MB 256 MB 64 MB
Resolution 1,920 x 1,200 1,280 x 1,024 1,280 x 1,024 1,400 x 1,050
Driver (Vista SP1) NVIDIA NVIDIA NVIDIA NVIDIA
7.15.10.9746 7.15.11.6371 7.14.10.9687 7.14.10.9686
Driver (Vista) NVIDIA NVIDIA NVIDIA NVIDIA
7.15.10.9746 7.15.10.9746 7.15.10.9746 7.15.10.9752
Driver (XP) NVIDIA NVIDIA NVIDIA NVIDIA
6.14.10.8469 6.14.10.9371 6.14.10.9371 6.14.10.7144
Audio
Vendor and model |SigmaTel Creative Realtek ﬁ\?ggr(ja'}/leacixDigital
number C-Major Audio SB Audigy 2ZS AC’97 Audio
. . Realtek .
. . SigmaTel Creative . Analog Devices
Driver (Vista SP1) | 500 4955 6.0.1.1220 Semiconductor | 5550 0%
6.0.1.6183
. . Realtek .
. . SigmaTel Creative . Analog Devices
Driver (Vista) 5.10.0.4255 6.0.1.1241 Semiconductor |55 5P 0%
6.0.1.6213
. . Realtek .
. SigmaTel Creative . Analog Devices
Driver (XP) Semiconductor
5.10.0.4255 5.12.4.1196 510.0.6120 5.12.1.5240
Ethernet
Vendor and model |Broadcom 570x NVIDIA PFO“’e Realtek Marvell Yuk_on .
number Gigabit Controller getworkmg RTL8139 88E8053 Gigabit
ontroller Controller
Type Integrated Integrated Integrated PCI-E
Driver (Vista SP1) Microsoft NVIDIA Microsoft Microsoft
10.10.0.1 65.7.4.0 5.640.630.2006 9.0.32.3
Driver (Vista) Microsoft NVIDIA Microsoft Microsoft
9.20.0.3 65.5.5.0 5.640.630.2006 9.0.32.3
Realtek
Driver (XP) ?g)g%cgm E\éIZDI(')A Semiconductor gﬂgzglg
T T 5.649.615.2006 T
Modem
Vendor and model |Conexant D110 Conexant D850 Toshiba Software
number MDC V.9x 56K V.90 DFVe NA Modem
Modem
Driver (Vista SP1) |Microsoft 7.39.6.1 | Microsoft 7.39.6.1 |NA Agere 2.1.73.0
Driver (Vista) Microsoft 7.39.6.0 |Microsoft 7.39.6.0 |NA Agere 2.1.73.0
Driver (XP) Conexant 7.23.1.0 |Conexant 7.6.0.50 |NA Agere 2.1.51.0
Optical drive(s)
Vendlor and model Eﬂggg’ Sony DDU1615 L?g;g‘”p Ts- Matshita UJDA750
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System Dell XPS M170 Dell XPS 600 HP d4100e Toshiba Tecra M4
Type DVD-ROM/CD-RW |DVD-ROM DVD-RW DVD-ROM/CD-RW
Single / Dual Layer |NA NA Dual NA
USB ports
Number of ports 6 8 6 3
Type of ports
(USB1.1, USB2.0) USB2.0 USB2.0 USB2.0 USB2.0
IEEE 1394 ports
Number of ports |1 [3 [2 [1
Monitor
ViewSonic ViewSonic

CRT/LCD UXGA LCD Optiquest Q7 Optiquest Q7 SXGA LCD
Screen size 17’ 17’ 17’ 14.1”
Refresh rate 60 Hz 60 Hz 60 Hz 60 Hz
Wireless
Vendor and model [Intel PRO/Wireless NA NA Intel PRO/Wireless
number 2200BG 2200BG
Driver (Vista SP1) |Microsoft 9.1.0.111 |NA NA Microsoft 9.1.0.111
Driver (Vista) Microsoft 9.1.0.111 |NA NA Microsoft 9.1.0.111
Driver (XP) Intel 9.0.4.26 NA NA Intel 9.0.1.9
Battery
Type Lithium lon NA NA Lithium lon
Size (length x width | g1/ 30y > NA NA 5" x 2% x 1"
x height)

. 7,200 mAh/11.1V 4,700 mAh /10.8V
Rated capacity 80WHTr NA NA 50WHr
Weight 11b. NA NA 11 oz.

Figure 25: Test system configurations.

Server

Microsoft IIS server

System configuration information

General

Processor and OS kernel:
(physical, core, logical) / (UP, MP)

1P1C1L/UP

Number of physical processors 1

Single/Dual-Core processors Single
System Power Management Policy | Always on
CPU

Vendor Intel

Name Celeron 346
Stepping 1

Socket type LGA775
Core frequency (GHz) 3.06

Front-side bus frequency (MHz) 533

L1 Cache

16 KB + 12 Kuops
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Server

Microsoft IIS server

L2 Cache 256 KB

Platform

Vendor and model number ASUSTeK

Motherboard model number Grafito

Motherboard chipset Intel 915G

Motherboard revision number B1

Motherboard serial number MXG5480JQYNA540
BIOS name and version American Megatrends 3.04
BIOS settings Default

Memory module(s)

Vendor and model number

Hyundai Electronics HYMP532U64P6-E3

Type

PC2-3200

Speed (MHz) 400

Speed in the system currently 200

running @ (MHz)

Timing/Latency (tCL-tRCD-iRP-

RASTID) ( 3-3-3-8

Size 512 MB
Number of RAM modules 2 x 256 MB
Chip organization Single-sided
Channel Single

Hard disk

Vendor and model number Seagate ST380013AS
Number of disks in system 1

Size 80 GB

Buffer size 8 MB

RPM 7,200

Type SATA 150MB/s
Controller Intel 82801FB

Controller driver

Microsoft 5.2.3790.1830

Operating system

Name

Microsoft Windows Server 2003 Enterprise Edition

Build number

3790

Service Pack

1

File system NTFS

Kernel ACPI Uniprocessor PC
Language English

Microsoft DirectX version 9.0c

Graphics

Vendor and model number

Standard VGA Graphics Adapter

BIOS version

Hardware Version 0.0

Type Integrated

Memory size 8 MB

Resolution 1,280 x 1,024 x 32
Driver Microsoft 5.2.3790.0
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Server

Microsoft IIS server

Network card/subsystem

Vendor and model number

Intel PRO/100 VE

Type Integrated

Driver Intel 8.0.27.0

Optical drive

Vendor and model number TSSTcorp. TS-H292C
Type CD-RW

Dual/single layer NA

Number of ports 6

Type of ports (USB 1.1, USB 2.0) 2.0

IEEE 1394 ports

Number 1

IEEE 1394 ports

CRT/LCD ViewSonic Optiquest Q7
Screen size 17”

Refresh rate 60 Hz

Figure 26: Detailed system configuration information for the Microsoft IIS server.
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Appendix B — Windows updates

This appendix lists all the updates we applied to the test systems from the Windows Update site.

Windows Vista Critical and Recommended Updates

Definition Update 1.14.1652.4 for Beta Windows Defender (KB915597)

Windows Update software 6.0.5520.16388

Figure 27: The Windows Vista updates we applied to each test system.

Windows XP Professional High Priority Updates

Security Update for Microsoft .NET Framework, Version 1.1 Service Pack 1 (KB886903)

Microsoft NET Framework 1.1 Service Pack 1

Windows Malicious Software Removal Tool - July 2006 (KB890830)

Security Update for Windows XP (KB917159)

Security Update for Windows XP (KB914388)

Update for Windows XP (KB916595)

Windows Genuine Advantage Notification (KB905474)

Security Update for Windows XP (KB911280)

Security Update for Flash Player (KB913433)

Security Update for Windows XP (KB917953)

Security Update for Windows XP (KB913580)

Cumulative Security Update for Internet Explorer for Windows XP (KB916281)

Security Update for Windows XP (KB918439)

Security Update for Windows XP (KB917344)

Security Update for Windows XP (KB914389)

Security Update for Windows Media Player 9 (KB917734)

Security Update for Windows XP (KB908531)

Update for Windows XP (KB900485)

Security Update for Windows XP (KB911562)

Cumulative Security Update for Outlook Express for Windows XP (KB911567)

Security Update for Windows Media Player Plug-in (KB911564)

Security Update for Windows XP (KB911927)

Security Update for Windows XP (KB912919)

Security Update for Windows XP (KB908519)

Security Update for Windows XP (KB904706)

Update for Windows XP (KB910437)

Security Update for Windows XP (KB896424)

Security Update for Windows XP (KB900725)

Security Update for Windows XP (KB905749)

Security Update for Windows XP (KB901017)

(
(
Security Update for Windows XP (KB905414)
(
(

Security Update for Windows XP (KB899589)

Security Update for Windows XP (KB902400)

Update for Windows XP (KB894391)

Security Update for Windows XP (KB896423

Security Update for Windows XP (KB899587

— — [~ ~—

(
Security Update for Windows XP (KB899591
Security Update for Windows XP (KB893756
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Security Update for Windows XP (KB896358)

Security Update for Windows XP (KB890859)

Security Update for Windows XP (KB901214)

Security Update for Windows XP (KB890046)

Security Update for Windows XP (KB885835)

(
(
(
Security Update for Windows XP (KB896428)
(
(
(

Security Update for Windows XP (KB888113)

Security Update for Windows XP (KB891781)

Security Update for Windows Messenger (KB887472)

Security Update for Windows XP (KB888302)

Security Update for Windows XP (KB885836)

Critical Update for Windows XP (KB886185)

Security Update for Windows XP (KB873339)

Windows Genuine Advantage Validation Tool (KB892130)

Update for Windows XP (KB898461)

Microsoft Windows Installer 3.1

Figure 28: The Windows XP updates we applied to each test system.

Windows Vista SP1 Critical and Recommended Updates (applied on 01/08/2008)

Service Pack for Microsoft Windows (KB936330)

Update for Microsoft Windows (KB938371)

Update for Microsoft Windows (KB935509)

Update for Microsoft Windows (KB937954)

Update for Microsoft Windows (KB937287)

Cumulative Update for Media Center for Windows Vista (KB941229)

Cumulative Update for Media Center for Windows Vista (KB935652)

Hotfix for Microsoft Windows (KB932471)

Security Update for Microsoft Windows (KB925902)

Security Update for Microsoft Windows (KB929123

Security Update for Microsoft Windows (KB929916

Security Update for Microsoft Windows (KB930178

Security Update for Microsoft Windows (KB931213

Security Update for Microsoft Windows (KB933579

Security Update for Microsoft Windows (KB933729

Security Update for Microsoft Windows (KB935807

Security Update for Microsoft Windows (KB936021

Security Update for Microsoft Windows (KB938127

Security Update for Microsoft Windows (KB941202

Security Update for Microsoft Windows (KB941568

Security Update for Microsoft Windows (KB941569

Security Update for Microsoft Windows (KB942615

Security Update for Microsoft Windows (KB942624

)
)
( )
( )
( )
( )
( )
( )
Security Update for Microsoft Windows (KB936782)
Security Update for Microsoft Windows (KB938123)
( )
( )
( )
( )
( )
( )
( )

Security Update for Microsoft Windows (KB943078
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Security Update for Windows XP (KB911562)

Update for Microsoft Windows (KB905866

Update for Microsoft Windows (KB929399

Update for Microsoft Windows (KB929735

Update for Microsoft Windows (KB930857

Update for Microsoft Windows (KB931099

Update for Microsoft Windows (KB931573

Update for Microsoft Windows (KB933928

Update for Microsoft Windows (KB935280

Update for Microsoft Windows (KB936357

Update for Microsoft Windows (KB938194

Update for Microsoft Windows (KB938952

Update for Microsoft Windows (KB938979

Update for Microsoft Windows (KB941600

Update for Microsoft Windows (KB941649

Update for Microsoft Windows (KB941651

Update for Microsoft Windows (KB942763

)
( )
( )
( )
( )
( )
( )
( )
( )
Update for Microsoft Windows (KB936824)
Update for Microsoft Windows (KB936825)
( )
( )
( )
( )
( )
( )
( )
( )

Update for Microsoft Windows (KB939159

Figure 29: The Windows Vista SP1 updates we applied to each test system.
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Appendix C — Detailed test results

Figure 30 details the performance results for each of the test operations on each system in each system state.

Each result is how long the operation took to complete on the test operating system. Each result is the average of

five runs of the same operation in the same system state on each system.

System A System B System C System D
Operating system XP Vista \S/';'ﬁa XP Vista \Sn;za XP Vista \S/I;za XP Vista \S/;.fﬁa
Cold
QuickBooks launch 8.51 3.22 3.50 17.61 | 4.71 4.36 12.52 | 3.40 3.19 17.73 | 5.70 4.99
QuickBooks open
database 0.94 0.63 0.60 1.67 0.63 0.51 1.05 0.43 0.60 1.82 0.67 0.65
QuickBooks graph 0.01 0.02 0.02 0.01 0.04 0.02 0.01 0.02 0.02 0.01 0.04 0.03
QuickBooks change graph
dates 0.03 0.05 0.03 0.12 0.07 0.07 0.05 0.03 0.03 0.10 0.11 0.08
QuickBooks graph by
customer 0.03 0.02 0.03 0.08 0.12 0.13 0.17 0.02 0.02 0.10 0.13 0.13
QuickBooks exit 1.27 1.94 1.45 2.50 2.38 2.63 1.55 1.45 1.52 2.49 3.86 2.56
Outlook launch 3.62 1.96 1.18 4.16 1.80 1.64 2.97 1.18 1.49 4.09 1.70 2.08
Word launch 1.57 0.82 0.68 2.23 1.32 1.10 1.44 0.71 0.82 2.79 0.90 1.22
Explorer launch 1.03 0.72 0.85 1.39 1.07 1.12 0.80 0.80 1.01 1.09 1.32 1.30
Explorer search 3.72 0.01 0.02 4.45 0.03 0.02 2.23 0.02 0.01 7.83 0.03 0.07
Explorer copy files 0.01 0.03 0.02 0.02 0.07 0.08 0.01 0.02 0.02 0.02 0.08 0.13
Word copy and paste
JPEG 0.15 0.08 0.07 0.15 0.16 0.25 0.11 0.07 0.07 0.18 0.10 0.17
Word save appendix 0.50 0.49 0.46 1.16 0.62 0.67 0.93 0.53 0.60 1.19 1.31 0.72
Word open dialog 0.24 0.20 0.20 0.23 0.20 0.18 0.19 0.18 0.18 0.24 0.22 0.21
Word file open 0.43 0.54 0.44 1.39 0.80 0.61 0.34 0.49 0.41 1.60 0.71 0.74
Word paste appendix 0.15 0.08 0.08 0.13 1.09 1.10 0.12 0.07 0.07 0.13 1.24 1.34
Excel launch 0.76 0.47 0.43 1.02 0.62 0.50 0.72 0.47 0.40 1.22 0.58 0.53
Excel chart options 0.24 0.13 0.13 0.25 0.15 0.16 0.21 0.12 0.12 0.25 0.15 0.16
Excel print preview open 0.46 0.27 0.27 0.46 0.28 0.28 0.35 0.25 0.24 0.42 0.26 0.24
Excel print preview close 0.03 0.04 0.03 0.02 0.08 0.09 0.02 0.03 0.03 0.01 0.05 0.05
Excel page setup 0.41 0.21 0.22 0.32 0.17 0.18 0.34 0.20 0.20 0.31 0.21 0.21
Excel insert chart dialog
open 0.30 0.13 0.14 0.38 0.11 0.11 0.24 0.11 0.11 0.37 0.13 0.12
Excel insert chart finish 0.19 0.05 0.06 0.17 0.11 0.09 0.16 0.05 0.05 0.15 0.09 0.10
Word paste special chart
object 0.04 0.03 0.03 0.07 0.30 0.29 0.03 0.03 0.03 0.06 0.32 0.32
Word format dialog open 0.49 0.16 0.16 0.43 0.14 0.14 0.42 0.14 0.14 0.45 0.17 0.16
Word format object 0.36 0.11 0.12 0.34 0.27 0.25 0.29 0.10 0.10 0.25 0.29 0.29
Word save as dialog open 0.29 0.20 0.21 0.23 0.18 0.18 0.22 0.19 0.19 0.24 0.22 0.21
Word save as dialog finish | 0.27 0.22 0.24 0.43 0.27 0.29 0.58 0.24 0.23 0.54 0.31 0.99
Outlook reply to message 0.55 0.27 0.36 0.62 0.75 0.73 0.38 0.44 0.45 0.60 0.77 0.80
Outlook add word file 0.28 0.25 0.25 0.34 0.42 0.31 0.20 0.41 0.27 0.32 0.52 0.34
Outlook message exit 0.05 0.04 0.04 0.17 0.06 0.05 0.06 0.04 0.04 0.09 0.07 0.08
Outlook message exit 2 0.05 0.05 0.06 0.25 0.21 0.21 0.06 0.05 0.04 0.08 0.27 0.21
Outlook display today 0.72 0.25 0.20 1.30 0.29 0.27 1.00 0.25 0.19 1.17 0.32 0.29
Outlook display inbox 0.48 0.33 0.13 0.58 0.43 0.40 0.38 0.23 0.22 0.55 0.44 0.50
Excel exit 0.09 0.21 0.20 0.58 0.42 0.45 0.32 0.17 0.19 0.56 0.47 0.43
Word exit 0.19 0.10 0.13 0.29 0.52 0.51 0.19 0.08 0.11 0.29 1.02 0.60
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System A System B System C System D
Operating system XP Vista \Sllsga XP Vista \Sfllia XP Vista \Slls';a XP Vista \S/'FS,ﬁa
Explorer zip 1.41 1.33 1.09 1.36 1.42 1.37 1.30 1.22 1.03 1.52 1.28 1.21
Explorer archive zip 0.16 0.20 0.20 0.63 0.23 0.22 0.15 0.19 0.23 0.54 0.30 0.29
Explorer exit 0.09 0.09 0.08 0.15 0.10 0.09 0.06 0.09 0.07 0.14 0.13 0.12
PowerPoint launch 0.61 0.55 0.30 1.30 0.54 0.51 0.73 0.65 0.39 1.41 0.89 0.63
PowerPoint slide sorter
view 0.09 0.07 0.06 0.17 0.09 0.09 0.07 0.06 0.08 0.14 0.12 0.10
PowerPoint insert new
slide 0.08 0.07 0.06 0.16 0.12 0.12 0.06 0.06 0.06 0.14 0.16 0.15
PowerPoint normal view 0.09 0.06 0.06 0.51 0.51 0.54 0.06 0.07 0.07 0.52 0.59 0.51
Picture Manager launch 0.92 0.86 0.88 1.67 1.14 1.09 0.93 0.86 0.91 1.71 1.31 1.13
Picture Manager auto
correct 0.19 0.21 0.19 0.43 0.37 0.25 0.23 0.25 0.21 0.35 0.34 0.24
Picture Manager crop 0.12 0.15 0.16 0.38 1.03 0.83 0.09 0.14 0.14 0.53 0.87 1.00
Picture Manager save as 0.10 0.06 0.06 0.27 0.34 0.40 0.07 0.06 0.06 0.12 0.84 0.80
Picture Manager insert
picture 0.35 0.39 0.39 1.07 0.50 0.51 0.44 0.42 0.43 0.92 0.49 0.46
PowerPoint file save 0.35 0.67 0.70 0.66 0.61 0.56 0.42 0.59 0.66 0.59 0.63 0.57
PowerPoint exit 0.57 0.23 0.22 0.33 0.23 0.25 0.42 0.30 0.21 0.35 0.29 0.26
Outlook new message 0.18 0.16 0.15 0.30 0.16 0.23 0.13 0.16 0.15 0.23 0.19 0.25
Outlook insert PowerPoint
file 0.03 0.03 0.03 0.13 0.03 0.10 0.02 0.03 0.03 0.13 0.04 0.14
Outlook message exit 3 0.05 0.06 0.07 0.13 0.13 0.13 0.05 0.07 0.07 0.11 0.13 0.14
Picture Manager exit 0.03 0.05 0.05 0.09 0.11 0.11 0.04 0.07 0.05 0.09 0.15 0.12
Explorer exit 2 0.04 0.03 0.03 0.10 0.07 0.08 0.03 0.02 0.03 0.09 0.06 0.07
IE launch home page 2.38 1.10 1.01 1.69 1.93 1.28 1.33 1.50 0.96 1.56 1.93 1.54
IE launch second page 0.20 0.13 0.13 0.24 0.21 0.17 0.62 0.13 0.13 0.24 0.22 0.21
IE launch third page 0.13 0.13 0.13 0.11 0.19 0.17 0.10 0.15 0.14 0.13 0.22 0.21
IE launch fourth page 0.16 0.11 0.12 0.20 0.16 0.14 0.16 0.12 0.11 0.20 0.18 0.17
Adobe launch PDF 1.81 1.06 0.94 2.63 1.20 1.29 2.03 1.07 1.04 2.74 1.30 1.30
Adobe document
properties 0.25 0.31 0.31 0.30 0.32 0.29 0.17 0.30 0.27 0.30 0.40 0.42
Adobe exit 217 0.20 0.39 3.25 1.22 1.22 2.47 0.19 0.18 3.46 1.29 1.28
IE exit 0.09 0.10 0.08 0.14 0.12 0.11 0.09 0.09 0.09 0.13 0.14 0.14
Outlook exit 0.52 0.20 0.19 0.40 0.24 0.23 0.42 0.19 0.18 0.41 0.31 0.29
Warm (after standby)
QuickBooks launch 1.43 2.49 2.60 1.25 4.50 3.24 1.16 3.14 2.35 1.35 4.59 4.30
QuickBooks open
database 0.54 0.60 0.53 0.51 0.57 0.46 0.39 0.59 0.45 0.58 0.60 0.61
QuickBooks graph 0.01 0.02 0.02 0.05 0.04 0.02 0.01 0.02 0.02 0.02 0.03 0.03
QuickBooks change graph
dates 0.03 0.03 0.03 0.22 0.07 0.07 0.02 0.05 0.03 0.15 0.08 0.08
QuickBooks graph by
customer 0.02 0.03 0.02 0.08 0.12 0.13 0.01 0.02 0.03 0.09 0.13 0.13
QuickBooks exit 1.08 1.35 1.42 2.72 245 2.40 1.93 2.37 2.03 2.86 2.55 2.53
Outlook launch 1.08 1.12 1.13 1.17 1.86 1.55 1.15 1.22 1.22 1.24 1.61 1.53
Word launch 0.24 0.82 0.68 0.48 1.04 0.80 0.24 1.06 0.67 0.48 0.99 0.92
Explorer launch 0.25 0.46 0.41 0.57 0.96 0.84 0.18 0.65 0.42 0.56 0.79 0.83
Explorer search 0.42 0.01 0.02 0.53 0.02 0.02 0.29 0.01 0.02 0.58 0.03 0.03
Explorer copy files 0.01 0.03 0.02 0.54 0.05 0.13 0.01 0.02 0.02 0.45 0.13 0.15
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System A System B System C System D

Operating system XP Vista \Sllsga XP Vista \Sfllia XP Vista \Slls';a XP Vista \S/'FS,?
Word copy and paste

JPEG 0.14 0.08 0.08 0.55 0.16 0.18 0.11 0.07 0.07 0.48 0.17 0.17

Word save appendix 0.31 0.47 0.44 0.80 0.63 0.74 0.58 0.94 0.53 0.78 0.98 0.76

Word open dialog 0.23 0.20 0.20 0.22 0.18 0.17 0.19 0.19 0.18 0.23 0.22 0.21

Word file open 0.20 0.49 0.44 1.56 0.63 0.60 0.16 0.21 0.44 12.66 | 0.78 0.74

Word paste appendix 0.15 0.08 0.08 0.97 1.23 1.25 0.12 0.08 0.08 1.07 1.36 1.21

Excel launch 0.27 0.48 0.42 0.46 0.55 0.45 0.23 0.39 0.39 0.49 0.59 0.53

Excel chart options 0.21 0.14 0.13 0.20 0.15 0.13 0.17 0.12 0.12 0.21 0.16 0.15

Excel print preview open 0.36 0.27 0.26 0.24 0.28 0.23 0.29 0.25 0.25 0.25 0.24 0.23

Excel print preview close 0.03 0.03 0.03 0.03 0.08 0.06 0.03 0.03 0.03 0.03 0.05 0.05

Excel page setup 0.37 0.21 0.21 0.23 0.18 0.17 0.29 0.20 0.20 0.24 0.21 0.19
Excel insert chart dialog

open 0.19 0.13 0.12 0.15 0.10 0.10 0.15 0.11 0.12 0.17 0.13 0.12
Excel insert chart finish 0.19 0.05 0.06 0.23 0.11 0.09 0.16 0.05 0.05 0.18 0.09 0.09
Word paste special chart

object 0.04 0.03 0.03 0.35 0.29 0.29 0.03 0.03 0.03 0.31 0.31 0.26
Word format dialog open 0.38 0.16 0.16 0.23 0.13 0.13 0.30 0.15 0.15 0.24 0.17 0.16
Word format object 0.37 0.11 0.12 0.33 0.25 0.25 0.29 0.10 0.10 0.35 0.29 0.29

Word save as dialog open 0.29 0.20 0.21 0.22 0.18 0.18 0.22 0.19 0.20 0.21 0.23 0.21

Word save as dialog finish | 0.24 0.22 0.21 0.99 0.26 0.27 0.55 0.26 0.23 1.15 0.25 0.90

Outlook reply to message 0.14 0.16 0.26 0.44 0.75 0.72 0.09 0.56 0.36 0.43 0.78 0.78

Outlook add word file 0.29 0.25 0.25 0.33 0.46 0.30 0.24 0.56 0.27 0.35 0.45 0.33
Outlook message exit 0.06 0.04 0.04 0.12 0.06 0.06 0.04 0.04 0.04 0.10 0.07 0.08
Outlook message exit 2 0.07 0.05 0.05 0.23 0.22 0.21 0.03 0.05 0.05 0.19 0.23 0.23
Outlook display today 0.21 0.24 0.22 0.18 0.29 0.28 0.20 0.23 0.19 0.20 0.32 0.31
Outlook display inbox 0.42 0.34 0.14 0.49 0.37 0.36 0.29 0.23 0.22 0.51 0.39 0.50
Excel exit 0.08 0.20 0.19 0.59 0.43 0.40 0.28 0.21 0.20 0.60 0.43 0.45
Word exit 0.13 0.13 0.13 0.36 0.53 0.50 0.10 0.14 0.12 0.45 0.74 0.64
Explorer zip 1.27 1.19 1.05 1.40 1.33 1.36 1.40 1.13 1.05 1.47 1.56 1.13
Explorer archive zip 0.18 0.21 0.18 0.51 0.23 0.22 0.14 0.18 0.17 0.50 0.32 0.30
Explorer exit 0.07 0.09 0.08 0.13 0.12 0.09 0.06 0.12 0.08 0.12 0.13 0.12
PowerPoint launch 0.20 0.58 0.29 0.52 0.57 0.53 0.18 0.67 0.31 0.51 0.77 0.65
PowerPoint slide sorter

view 0.10 0.07 0.07 0.17 0.09 0.09 0.07 0.07 0.06 0.16 0.13 0.11
PowerPoint insert new

slide 0.08 0.07 0.07 0.16 0.12 0.12 0.06 0.07 0.07 0.14 0.15 0.14
PowerPoint normal view 0.08 0.07 0.07 0.51 0.52 0.54 0.07 0.06 0.06 0.56 0.53 0.51
Picture Manager launch 0.66 0.87 0.87 1.07 1.25 1.05 0.64 0.86 0.86 1.05 1.17 1.18
Picture Manager auto

correct 0.15 0.22 0.18 0.33 0.36 0.25 0.21 0.25 0.21 0.30 0.31 0.22
Picture Manager crop 0.12 0.15 0.15 0.65 0.84 0.84 0.09 0.14 0.14 0.82 0.88 0.86

Picture Manager save as 0.10 0.06 0.06 0.45 0.33 0.35 0.08 0.09 0.06 0.88 0.81 0.81

Picture Manager insert

picture 0.33 0.40 0.38 0.50 0.50 0.45 0.33 0.42 0.41 0.51 0.49 0.45
PowerPoint file save 0.30 0.54 0.53 0.56 0.58 0.62 0.40 0.59 0.54 0.58 0.60 0.59
PowerPoint exit 0.55 0.20 0.21 0.44 0.23 0.22 0.45 0.21 0.20 0.39 0.29 0.26
Outlook new message 0.16 0.16 0.16 0.22 0.13 0.12 0.12 0.14 0.14 0.21 0.15 0.23
Outlook insert PowerPoint

file 0.03 0.03 0.03 0.13 0.03 0.14 0.02 0.03 0.04 0.12 0.05 0.17
Outlook message exit 3 0.05 0.06 0.07 0.13 0.13 0.12 0.05 0.08 0.08 0.11 0.12 0.12
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System A System B System C System D

. ) Vista ) Vista ’ Vista ) Vista
Operating system XP Vista SP1 XP Vista SP1 XP Vista SP1 XP Vista SP1
Picture Manager exit 0.06 0.05 0.05 0.10 0.14 0.13 0.04 0.05 0.05 0.11 0.14 0.13
Explorer exit 2 0.04 0.03 0.02 0.10 0.09 0.05 0.03 0.03 0.03 0.09 0.16 0.09
IE launch home page 0.52 0.87 0.72 0.53 1.34 0.93 0.43 1.02 0.78 0.57 1.39 1.10
IE launch second page 0.18 0.12 0.12 0.23 0.21 0.18 0.52 0.12 0.11 0.25 0.23 0.22
IE launch third page 0.12 0.15 0.13 0.11 0.19 0.18 0.11 0.15 0.13 0.14 0.21 0.20
IE launch fourth page 0.12 0.11 0.11 0.19 0.17 0.15 0.11 0.12 0.12 0.17 0.18 0.17
Adobe launch PDF 0.84 0.88 0.89 0.97 1.19 1.01 0.83 1.07 0.87 0.90 1.23 1.30
Adobe document
properties 0.24 0.31 0.30 0.34 0.29 0.28 0.17 0.27 0.26 0.32 0.42 0.39
Adobe exit 1.21 0.20 0.18 1.31 1.21 1.21 1.15 0.19 0.18 1.28 1.27 1.27
IE exit 0.09 0.11 0.09 0.12 0.11 0.11 0.07 0.09 0.09 0.12 0.15 0.14
Outlook exit 0.52 0.20 0.17 0.37 0.23 0.23 0.41 0.20 0.18 0.40 0.31 0.30
Warm (after previous run)
QuickBooks launch 1.40 2.52 2.57 1.31 4.34 3.61 1.14 3.11 2.25 1.36 4.62 3.82
QuickBooks open
database 0.53 0.59 0.53 0.52 0.71 0.49 0.38 0.46 0.49 0.55 0.62 0.49
QuickBooks graph 0.01 0.03 0.02 0.05 0.02 0.02 0.01 0.02 0.02 0.02 0.03 0.03
QuickBooks change graph
dates 0.03 0.03 0.09 0.15 0.07 0.07 0.02 0.03 0.04 0.14 0.08 0.08
QuickBooks graph by
customer 0.02 0.03 0.02 0.08 0.27 0.13 0.01 0.02 0.02 0.09 0.13 0.13
QuickBooks exit 1.08 1.28 1.41 2.70 2.60 2.52 1.27 1.42 1.48 2.69 2.61 2.57
Qutlook launch 1.15 1.13 1.12 1.23 1.93 1.58 1.14 1.18 1.15 1.23 1.55 1.47
Word launch 0.24 0.81 0.64 0.48 1.07 0.80 0.22 0.54 0.70 0.48 0.82 0.95
Explorer launch 0.25 0.37 0.44 0.56 0.56 0.52 0.20 0.48 0.40 0.56 0.68 0.64
Explorer search 0.36 0.01 0.02 0.48 0.02 0.02 0.39 0.01 0.02 0.58 0.03 0.03
Explorer copy files 0.01 0.03 0.02 0.55 0.05 0.14 0.01 0.02 0.02 0.53 0.06 0.15
Word copy and paste
JPEG 0.15 0.08 0.07 0.51 0.33 0.25 0.11 0.07 0.07 0.51 0.17 0.18
Word save appendix 0.31 0.46 0.44 0.73 1.01 0.59 0.52 0.53 0.57 0.74 1.02 0.80
Word open dialog 0.23 0.20 0.20 0.24 0.17 0.17 0.19 0.18 0.18 0.22 0.21 0.20
Word file open 0.20 0.49 0.43 1.60 0.46 0.59 0.15 0.49 0.42 15.35 | 0.84 0.77
Word paste appendix 0.15 0.08 0.08 0.97 1.29 1.25 0.11 0.07 0.07 0.91 1.30 1.21
Excel launch 0.31 0.47 0.37 0.52 0.60 0.43 0.23 0.52 0.35 0.48 0.57 0.53
Excel chart options 0.21 0.13 0.14 0.17 0.15 0.13 0.17 0.12 0.12 0.19 0.15 0.15
Excel print preview open 0.36 0.26 0.26 0.23 0.26 0.23 0.28 0.25 0.25 0.26 0.25 0.23
Excel print preview close 0.02 0.03 0.03 0.02 0.07 0.06 0.02 0.03 0.03 0.02 0.05 0.05
Excel page setup 0.37 0.21 0.22 0.23 0.17 0.17 0.28 0.20 0.20 0.24 0.21 0.19
Excel insert chart dialog
open 0.19 0.13 0.13 0.16 0.11 0.11 0.15 0.11 0.11 0.17 0.13 0.12
Excel insert chart finish 0.19 0.05 0.06 0.16 0.11 0.10 0.15 0.05 0.05 0.17 0.09 0.09
Word paste special chart
object 0.04 0.03 0.03 0.33 0.31 0.29 0.03 0.03 0.03 0.26 0.31 0.31
Word format dialog open 0.38 0.16 0.16 0.23 0.13 0.13 0.29 0.14 0.14 0.23 0.17 0.16
Word format object 0.38 0.11 0.11 0.32 0.25 0.25 0.29 0.10 0.10 0.34 0.28 0.28
Word save as dialog open 0.29 0.20 0.20 0.24 0.18 0.18 0.22 0.19 0.19 0.23 0.23 0.21
Word save as dialog finish 0.23 0.22 0.29 1.07 0.24 0.54 0.52 0.24 0.24 1.15 0.27 1.03
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System A System B System C System D

Vista Vista Vista Vista
Operating system XP Vista | sp1 XP Vista | sp1 XP Vista | gp1 XP Vista | sp1
Outlook reply to message 0.14 0.16 0.37 0.23 0.76 0.76 0.10 0.34 0.35 0.22 0.77 0.81
Outlook add word file 0.29 0.25 0.26 0.34 0.51 0.30 0.24 0.36 0.24 0.33 0.44 0.35
Outlook message exit 0.07 0.05 0.05 0.11 0.05 0.06 0.03 0.04 0.04 0.09 0.08 0.07
Outlook message exit 2 0.06 0.05 0.05 0.21 0.22 0.21 0.04 0.05 0.05 0.18 0.21 0.25
Outlook display today 0.21 0.26 0.21 0.17 0.30 0.28 0.20 0.22 0.20 0.20 0.32 0.30
Outlook display inbox 0.42 0.33 0.15 0.49 0.39 0.45 0.29 0.22 0.22 0.51 0.50 0.49
Excel exit 0.08 0.20 0.18 0.59 0.46 0.41 0.27 0.17 0.17 0.57 0.43 0.43
Word exit 0.13 0.10 0.13 0.40 0.77 0.58 0.11 0.12 0.11 0.44 0.74 0.60
Explorer zip 1.28 1.20 1.04 1.35 1.30 1.10 1.48 1.11 1.10 1.48 1.61 1.12
Explorer archive zip 0.17 0.21 0.18 0.51 0.22 0.21 0.14 0.18 0.19 0.50 0.32 0.28
Explorer exit 0.07 0.08 0.08 0.14 0.11 0.09 0.06 0.08 0.08 0.12 0.13 0.12
PowerPoint launch 0.20 0.53 0.29 0.52 0.62 0.49 0.18 0.60 0.32 0.54 1.07 0.62
PowerPoint slide sorter
view 0.09 0.07 0.06 0.17 0.09 0.09 0.08 0.07 0.07 0.14 0.12 0.11
PowerPoint insert new
slide 0.08 0.07 0.06 0.16 0.12 0.11 0.06 0.06 0.07 0.14 0.15 0.14
PowerPoint normal view 0.08 0.07 0.06 0.51 0.53 0.54 0.06 0.06 0.06 0.52 0.52 0.51
Picture Manager launch 0.66 0.87 0.88 1.07 1.26 1.05 0.63 0.86 0.86 1.07 1.19 1.19
Picture Manager auto
correct 0.15 0.22 0.19 0.34 0.37 0.25 0.21 0.25 0.21 0.31 0.31 0.22
Picture Manager crop 0.12 0.15 0.15 0.66 0.86 0.84 0.09 0.13 0.14 0.82 0.89 0.86
Picture Manager save as 0.10 0.06 0.06 0.47 0.33 0.35 0.08 0.06 0.06 0.89 0.86 0.83
Picture Manager insert
picture 0.33 0.39 0.41 0.50 0.50 0.47 0.38 0.42 0.40 0.51 0.49 0.51
PowerPoint file save 0.30 0.53 0.56 0.52 0.63 0.57 0.40 0.54 0.53 0.61 0.66 0.58
PowerPoint exit 0.56 0.21 0.21 0.44 0.22 0.23 0.43 0.20 0.21 0.39 0.29 0.26
Outlook new message 0.16 0.16 0.15 0.21 0.16 0.16 0.12 0.15 0.14 0.20 0.16 0.15
Outlook insert PowerPoint
file 0.03 0.03 0.03 0.13 0.03 0.13 0.02 0.03 0.04 0.12 0.04 0.16
Outlook message exit 3 0.05 0.06 0.07 0.13 0.13 0.13 0.05 0.07 0.08 0.10 0.14 0.13
Picture Manager exit 0.05 0.05 0.05 0.11 0.10 0.12 0.04 0.05 0.04 0.10 0.13 0.12
Explorer exit 2 0.04 0.03 0.02 0.10 0.09 0.07 0.03 0.03 0.03 0.09 0.09 0.07
IE launch home page 0.52 0.89 0.70 0.55 1.32 1.00 0.42 1.01 0.75 0.58 1.35 1.15
IE launch second page 0.18 0.11 0.13 0.22 0.20 0.19 0.61 0.13 0.12 0.25 0.23 0.22
IE launch third page 0.12 0.13 0.13 0.13 0.20 0.17 0.11 0.14 0.13 0.15 0.22 0.20
IE launch fourth page 0.12 0.11 0.11 0.18 0.16 0.15 0.11 0.12 0.12 0.19 0.19 0.17
Adobe launch PDF 0.84 0.88 0.90 0.95 1.19 1.05 0.87 1.07 0.86 0.88 1.29 1.16
Adobe document
properties 0.26 0.31 0.30 0.34 0.29 0.30 0.17 0.27 0.26 0.33 0.35 0.37
Adobe exit 1.19 0.23 0.19 1.31 1.22 1.23 1.16 0.19 0.18 1.27 1.28 1.27
IE exit 0.08 0.10 0.09 0.12 0.12 0.11 0.06 0.09 0.09 0.11 0.14 0.15
Outlook exit 0.53 0.21 0.18 0.37 0.28 0.29 0.41 0.20 0.17 0.39 0.30 0.28

Figure 30: Performance results for each of the test operations on each system in each system state.
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Appendix D — Configuration and test results for the HP a1320y

Figure 31 provides detailed configuration information about the Hewlett-Packard a1320y desktop system. We
omitted that system from the body of this report because it produced unacceptably high variability in its test

results.

System

Hewlett-Packard a1320y

General

Processor and OS kernel: (physical, core,

logical)/(UP, MP) 1P1C2L/MP
Number of physical processors 1
Single/dual-core processors Single
Processor HT status Enabled

System Power Management Policy (Vista)

High performance

System Power Management Policy (XP)

Minimal Power Management

Notebook processor power saving option NA

Notebook dimensions (length x width x NA

height)

Notebook weight NA

CPU

System type Desktop

Vendor Intel

Name Pentium 516
Stepping 9

Socket type LGA775

Core frequency (GHz) 2.93

Front-side bus frequency (MHz) 533

L1 cache 16 KB + 12 Kuops
L2 cache 1 MB

Platform

Vendor and model number HP a1320y
Motherboard model number Asterope
Motherboard chipset ATl RS400
Motherboard revision number 01

Motherboard serial number MXG61801W2NA620
BIOS name and version American Megatrends v3.07
BIOS settings Default

Memory module(s)

Vendor and model number

Hyundai Electronics HYMP564U64P8-C4

Type

PC2-4200

Speed (MHz) 533

Speed running in the system (MHz) 266
Timing/Latency (tCL-tRCD-tRP-tRASmin) 4-4-4-12
Size 512 MB
Number of memory module(s) 1x512 MB
Chip organization Single-sided
Channel Single
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System

Hewlett-Packard a1320y

Hard disk

Vendor and model number

Western Digital WD400BD-60LRAOQ

Number of disks in system

1

Size 40GB

Buffer size 2 MB

RPM 7200

Type SATA 300 Mb/s

Controller ATI SB400

Driver (Vista) Microsoft 6.0.6000.16386

Driver (XP) ATI Technologies, Inc 5.10.1000.7
Graphics

Vendor and model number ATI Radeon Xpress 200

Chipset ATl Radeon Xpress 200 Series

BIOS version BK-ATI VER008.0461.003.000

Type Integrated

Memory size 256MB

Resolution 1280 x 1024

Driver (Vista) ATI 8.383.0.0

Driver (XP) ATI18.33.0.0

Audio

Vendor and model number Realtek High Definition Audio

Driver (Vista) Realtek Semiconductor Corp. 6.0.1.5372
Driver (XP) Realtek Semiconductor Corp. 5.10.0.5366
Ethernet

Vendor and model nhumber Realtek RTL8139

Type Integrated

Driver (Vista) Microsoft 5.640.630.2006

Driver (XP) Microsoft 5.398.613.2003

Modem

Vendor and model number CXT Data Fax SoftModem with SmartCP
Driver (Vista) CXT 7.61.0.0

Driver (XP) CXT 7.20.0.50

Optical drive(s)

Vendor and model number

Asus DVD-E616A

Type DVD-ROM
Single / Dual Layer NA

USB ports

Number of ports 6

Type of ports (USB1.1, USB2.0) USB2.0
IEEE 1394 ports

Number of ports | 2

Monitor

CRT/LCD ViewSonic Optiquest Q7
Screen size 17”
Refresh rate 60 Hz
Wireless

Vendor and model number | NA
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System Hewlett-Packard a1320y
Driver (Vista) NA

Driver (XP) NA

Battery

Type NA

Size (length x width x height) NA

Rated capacity NA

Weight NA

Figure 31: Test system configuration.

Figure 32 details the performance results for each of the test operations on a Hewlett-Packard a1320y desktop

PC in each system state. We omitted that system from the body of this report because it produced unacceptably

high variability in its test results. Each result is how long the operation took to complete on the test operating
system. Each result is the average of five runs of the same operation in the same system state on the system.

Hewlett-Packard a1320y

Operating system XP Vista Vista SP1
Cold

QuickBooks launch 12.52 3.40 3.19
QuickBooks open database 1.05 0.43 0.60
QuickBooks graph 0.01 0.02 0.02
QuickBooks change graph dates 0.05 0.03 0.03
QuickBooks graph by customer 0.17 0.02 0.02
QuickBooks exit 1.55 1.45 1.52
Outlook launch 2.97 1.18 1.49
Word launch 1.44 0.71 0.82
Explorer launch 0.80 0.80 1.01
Explorer search 2.23 0.02 0.01
Explorer copy files 0.01 0.02 0.02
Word copy and paste JPEG 0.11 0.07 0.07
Word save appendix 0.93 0.53 0.60
Word open dialog 0.19 0.18 0.18
Word file open 0.34 0.49 0.41
Word paste appendix 0.12 0.07 0.07
Excel launch 0.72 0.47 0.40
Excel chart options 0.21 0.12 0.12
Excel print preview open 0.35 0.25 0.24
Excel print preview close 0.02 0.03 0.03
Excel page setup 0.34 0.20 0.20
Excel insert chart dialog open 0.24 0.11 0.11
Excel insert chart finish 0.16 0.05 0.05
Word paste special chart object 0.03 0.03 0.03
Word format dialog open 0.42 0.14 0.14
Word format object 0.29 0.10 0.10
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Hewlett-Packard a1320y

Operating system XP Vista Vista SP1
Word save as dialog open 0.22 0.19 0.19
Word save as dialog finish 0.58 0.24 0.23
Qutlook reply to message 0.38 0.44 0.45
Outlook add word file 0.20 0.41 0.27
Outlook message exit 0.06 0.04 0.04
Outlook message exit 2 0.06 0.05 0.04
Outlook display today 1.00 0.25 0.19
Outlook display inbox 0.38 0.23 0.22
Excel exit 0.32 0.17 0.19
Word exit 0.19 0.08 0.11
Explorer zip 1.30 1.22 1.03
Explorer archive zip 0.15 0.19 0.23
Explorer exit 0.06 0.09 0.07
PowerPoint launch 0.73 0.65 0.39
PowerPoint slide sorter view 0.07 0.06 0.08
PowerPoint insert new slide 0.06 0.06 0.06
PowerPoint normal view 0.06 0.07 0.07
Picture Manager launch 0.93 0.86 0.91
Picture Manager auto correct 0.23 0.25 0.21
Picture Manager crop 0.09 0.14 0.14
Picture Manager save as 0.07 0.06 0.06
Picture Manager insert picture 0.44 0.42 0.43
PowerPoint file save 0.42 0.59 0.66
PowerPoint exit 0.42 0.30 0.21
Outlook new message 0.13 0.16 0.15
Outlook insert PowerPoint file 0.02 0.03 0.03
Outlook message exit 3 0.05 0.07 0.07
Picture Manager exit 0.04 0.07 0.05
Explorer exit 2 0.03 0.02 0.03
IE launch home page 1.33 1.50 0.96
IE launch second page 0.62 0.13 0.13
IE launch third page 0.10 0.15 0.14
IE launch fourth page 0.16 0.12 0.11
Adobe launch PDF 2.03 1.07 1.04
Adobe document properties 0.17 0.30 0.27
Adobe exit 2.47 0.19 0.18
IE exit 0.09 0.09 0.09
Outlook exit 0.42 0.19 0.18
Warm (after standby)

QuickBooks launch 1.16 3.14 2.35
QuickBooks open database 0.39 0.59 0.45
QuickBooks graph 0.01 0.02 0.02
QuickBooks change graph dates 0.02 0.05 0.03
QuickBooks graph by customer 0.01 0.02 0.03
QuickBooks exit 1.93 2.37 2.03
Outlook launch 1.15 1.22 1.22
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Hewlett-Packard a1320y

Operating system XP Vista Vista SP1

Word launch 0.24 1.06 0.67
Explorer launch 0.18 0.65 0.42
Explorer search 0.29 0.01 0.02
Explorer copy files 0.01 0.02 0.02
Word copy and paste JPEG 0.11 0.07 0.07
Word save appendix 0.58 0.94 0.53
Word open dialog 0.19 0.19 0.18
Word file open 0.16 0.21 0.44
Word paste appendix 0.12 0.08 0.08
Excel launch 0.23 0.39 0.39
Excel chart options 0.17 0.12 0.12
Excel print preview open 0.29 0.25 0.25
Excel print preview close 0.03 0.03 0.03
Excel page setup 0.29 0.20 0.20
Excel insert chart dialog open 0.15 0.11 0.12
Excel insert chart finish 0.16 0.05 0.05
Word paste special chart object 0.03 0.03 0.03
Word format dialog open 0.30 0.15 0.15
Word format object 0.29 0.10 0.10
Word save as dialog open 0.22 0.19 0.20
Word save as dialog finish 0.55 0.26 0.23
Outlook reply to message 0.09 0.56 0.36
Outlook add word file 0.24 0.56 0.27
Outlook message exit 0.04 0.04 0.04
Outlook message exit 2 0.03 0.05 0.05
Outlook display today 0.20 0.23 0.19
Outlook display inbox 0.29 0.23 0.22
Excel exit 0.28 0.21 0.20
Word exit 0.10 0.14 0.12
Explorer zip 1.40 1.13 1.05
Explorer archive zip 0.14 0.18 0.17
Explorer exit 0.06 0.12 0.08
PowerPoint launch 0.18 0.67 0.31
PowerPoint slide sorter view 0.07 0.07 0.06
PowerPoint insert new slide 0.06 0.07 0.07
PowerPoint normal view 0.07 0.06 0.06
Picture Manager launch 0.64 0.86 0.86
Picture Manager auto correct 0.21 0.25 0.21
Picture Manager crop 0.09 0.14 0.14
Picture Manager save as 0.08 0.09 0.06
Picture Manager insert picture 0.33 0.42 0.41
PowerPoint file save 0.40 0.59 0.54
PowerPoint exit 0.45 0.21 0.20
Outlook new message 0.12 0.14 0.14
Outlook insert PowerPoint file 0.02 0.03 0.04
Outlook message exit 3 0.05 0.08 0.08
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Hewlett-Packard a1320y

Operating system XP Vista Vista SP1
Picture Manager exit 0.04 0.05 0.05
Explorer exit 2 0.03 0.03 0.03
IE launch home page 0.43 1.02 0.78
IE launch second page 0.52 0.12 0.11
IE launch third page 0.11 0.15 0.13
IE launch fourth page 0.11 0.12 0.12
Adobe launch PDF 0.83 1.07 0.87
Adobe document properties 0.17 0.27 0.26
Adobe exit 1.15 0.19 0.18
IE exit 0.07 0.09 0.09
Outlook exit 0.41 0.20 0.18
Warm (after previous run)

QuickBooks launch 1.14 3.1 2.25
QuickBooks open database 0.38 0.46 0.49
QuickBooks graph 0.01 0.02 0.02
QuickBooks change graph dates 0.02 0.03 0.04
QuickBooks graph by customer 0.01 0.02 0.02
QuickBooks exit 1.27 1.42 1.48
Outlook launch 1.14 1.18 1.15
Word launch 0.22 0.54 0.70
Explorer launch 0.20 0.48 0.40
Explorer search 0.39 0.01 0.02
Explorer copy files 0.01 0.02 0.02
Word copy and paste JPEG 0.11 0.07 0.07
Word save appendix 0.52 0.53 0.57
Word open dialog 0.19 0.18 0.18
Word file open 0.15 0.49 0.42
Word paste appendix 0.11 0.07 0.07
Excel launch 0.23 0.52 0.35
Excel chart options 0.17 0.12 0.12
Excel print preview open 0.28 0.25 0.25
Excel print preview close 0.02 0.03 0.03
Excel page setup 0.28 0.20 0.20
Excel insert chart dialog open 0.15 0.11 0.11
Excel insert chart finish 0.15 0.05 0.05
Word paste special chart object 0.03 0.03 0.03
Word format dialog open 0.29 0.14 0.14
Word format object 0.29 0.10 0.10
Word save as dialog open 0.22 0.19 0.19
Word save as dialog finish 0.52 0.24 0.24
Outlook reply to message 0.10 0.34 0.35
Outlook add word file 0.24 0.36 0.24
Outlook message exit 0.03 0.04 0.04
Outlook message exit 2 0.04 0.05 0.05
Outlook display today 0.20 0.22 0.20
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Hewlett-Packard a1320y

Operating system XP Vista Vista SP1

Outlook display inbox 0.29 0.22 0.22
Excel exit 0.27 0.17 0.17
Word exit 0.11 0.12 0.11
Explorer zip 1.48 1.11 1.10
Explorer archive zip 0.14 0.18 0.19
Explorer exit 0.06 0.08 0.08
PowerPoint launch 0.18 0.60 0.32
PowerPoint slide sorter view 0.08 0.07 0.07
PowerPoint insert new slide 0.06 0.06 0.07
PowerPoint normal view 0.06 0.06 0.06
Picture Manager launch 0.63 0.86 0.86
Picture Manager auto correct 0.21 0.25 0.21
Picture Manager crop 0.09 0.13 0.14
Picture Manager save as 0.08 0.06 0.06
Picture Manager insert picture 0.38 0.42 0.40
PowerPoint file save 0.40 0.54 0.53
PowerPoint exit 0.43 0.20 0.21
Outlook new message 0.12 0.15 0.14
Outlook insert PowerPoint file 0.02 0.03 0.04
Outlook message exit 3 0.05 0.07 0.08
Picture Manager exit 0.04 0.05 0.04
Explorer exit 2 0.03 0.03 0.03
IE launch home page 0.42 1.01 0.75
IE launch second page 0.61 0.13 0.12
IE launch third page 0.11 0.14 0.13
IE launch fourth page 0.11 0.12 0.12
Adobe launch PDF 0.87 1.07 0.86
Adobe document properties 0.17 0.27 0.26
Adobe exit 1.16 0.19 0.18
IE exit 0.06 0.09 0.09
Outlook exit 0.41 0.20 0.17

Figure 32: Performance results for each of the test operations on the system in each system state.
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About Principled Technologies

We provide industry-leading technology assessment services. We bring to every assignment extensive
experience with and expertise in all aspects of technology testing and analysis, from research into new
technologies, to the development of new methodologies, to testing with existing and new tools.

When the assessment is complete, we know how to present the results to a broad range of target audiences. We

provide our clients with the materials they need, from market-focused data to use in their own collateral to custom
sales aids, such as test reports, performance assessments, and white papers. Every document reflects the results
of our trusted independent analysis.

We provide customized services that focus on our clients’ individual needs. Whether the technology involves
hardware, software, Web sites, or services, we offer the experience, expertise, and tools to help you assess how
it will fare against its competition, its performance, whether it's ready to go to market, and its quality and reliability.

Our founders, Mark Van Name and Bill Catchings, have worked together in technology assessment for over 20
years. As journalists they published over a thousand articles on a wide array of technology subjects. They created
and led the Ziff-Davis Benchmark Operation, which developed such industry-standard benchmarks as Ziff Davis
Media’'s Winstone and WebBench. They founded and led eTesting Labs, and after the acquisition of that company
by Lionbridge Technologies were the head and CTO, respectively, of VeriTest.
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Disclaimer of Warranties; Limitation of Liability:

PRINCIPLED TECHNOLOGIES, INC. HAS MADE REASONABLE EFFORTS TO ENSURE THE ACCURACY AND VALIDITY OF ITS
TESTING, HOWEVER, PRINCIPLED TECHNOLOGIES, INC. SPECIFICALLY DISCLAIMS ANY WARRANTY, EXPRESSED OR
IMPLIED, RELATING TO THE TEST RESULTS AND ANALYSIS, THEIR ACCURACY, COMPLETENESS OR QUALITY, INCLUDING
ANY IMPLIED WARRANTY OF FITNESS FOR ANY PARTICULAR PURPOSE. ALL PERSONS OR ENTITIES RELYING ON THE
RESULTS OF ANY TESTING DO SO AT THEIR OWN RISK, AND AGREE THAT PRINCIPLED TECHNOLOGIES, INC., ITS
EMPLOYEES AND ITS SUBCONTRACTORS SHALL HAVE NO LIABILITY WHATSOEVER FROM ANY CLAIM OF LOSS OR DAMAGE
ON ACCOUNT OF ANY ALLEGED ERROR OR DEFECT IN ANY TESTING PROCEDURE OR RESULT.

IN NO EVENT SHALL PRINCIPLED TECHNOLOGIES, INC. BE LIABLE FOR INDIRECT, SPECIAL, INCIDENTAL, OR
CONSEQUENTIAL DAMAGES IN CONNECTION WITH ITS TESTING, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
IN NO EVENT SHALL PRINCIPLED TECHNOLOGIES, INC.’S LIABILITY, INCLUDING FOR DIRECT DAMAGES, EXCEED THE
AMOUNTS PAID IN CONNECTION WITH PRINCIPLED TECHNOLOGIES, INC.’S TESTING. CUSTOMER'’S SOLE AND EXCLUSIVE
REMEDIES ARE AS SET FORTH HEREIN.
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