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Technologies®

vConsolidate performance and power on quad-processor
Intel processor-based servers

Executive summary
Intel® Corporation (Intel) commissioned Principled
Technologies® (PT) to measure power and performance
with Intel's vConsolidate version 2.0 (Profile 2) workload
using Microsoft Windows Server 2008 Hyper-V on quad-
processor servers using the following processors:

e Intel Xeon® processor X7460

e Intel Xeon processor X7350

The servers were similarly configured with four Intel Xeon
processors, 16 4GB FBDIMMs, and identical PCI-e NICs
and HBAs. Figure 1 provides a normalized comparison for
the test servers with the optimal number of vConsolidate
work units, which it calls consolidation stack units (CSUs).
The Intel Xeon processor X7460-based server achieved
optimal performance with six CSUs while the Intel Xeon
processor X7350-based server achieved optimal

KEY FINDINGS

e The Intel Xeon processor X7460-based

server produced 52.1 percent better
performance per watt than the Intel Xeon
processor X7350-based server with
redundant power supplies active at the
optimal number of CSUs (see Figure 1).

The Intel Xeon processor X7460-based
server delivered 39.8 percent more
performance running vConsolidate with the
optimum number of CSUs than the Intel
Xeon processor X7350-based server (see
Figure 2).

performance with five CSUs. (See the Workload section and later sections for more on CSUs.) This chart
normalizes the results to the lower-performing server, the Intel Xeon processor X7350-based server. That
system’s score is thus 1.00. Normalizing makes each data point in the chart a comparative number, with higher

numbers indicating better performance.

In this section, we discuss the best results for all servers. For complete details of the performance of each server

at its optimum number of CSUs, see the Test results section.

As Figure 1 illustrates, the Intel Xeon processor X7460-based server delivered 52.1 percent greater vConsolidate
performance per watt at the optimal number of CSUs than the Intel Xeon processor X7350-based server.

We calculated performance per
watt by dividing the vConsolidate
score for each server at the

optimal number of CSUs by the
measured power when running
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Figure 1: Relative vConsolidate performance/watt results at the optimal number of CSUs
for the two servers we tested.

the optimal number of CSUs for a
minimum 30-minute interval. We
measured power at 208 V on both
servers.

Figure 2 shows the Intel Xeon
processor X7460-based server
delivered 39.8 percent better
overall performance at the optimal
number of CSUs than did the Intel
Xeon processor X7350-based
server.



Workload
vCon results Intel defined, implemented, and

5.0 supplied the vConsolidate version
2.0 workload. vConsolidate
includes four different
performance tests—database,
Java, mail, and Web—that run

Intel Xeon simultaneously in different virtual
ProgSREse (350 machines (VMs) on a server. A
fifth, idle VM is also present during
the test. vConsolidate refers to a
single collection of these five
virtual machines as a consolidate
stack unit (CSU). Depending on
the type of server and its available
resources, testers can choose to
Server run one or more CSUs. The
typical goal is to run enough
CSUs to push the server under
test to its maximum capacity by
Figure 2: vConsolidate results at the optimal number of CSUs for the two servers we consuming close to 100 percent of
tested. the CPU capacity.

Score

(5 CSUs)

vConsolidate sums the throughput results of each type of work across all CSUs in a test. Then it amalgamates the
combined throughputs of all CSUs to create an overall score for the server under test. See the Test results
section for more information on this process.

vConsolidate uses the following four performance tests:

LoadSim

Microsoft Exchange Server 2003 Load Simulator (LoadSim) is a benchmark that measures a server’s
performance handling email. LoadSim uses the MAPI Messaging Benchmark 3 (MMB-3) to simulate MAPI email
clients. The simulated clients issue requests to an Exchange server to generate an email load. LoadSim
measures both the server’s response time and the number of messages it delivers. LoadSim is available for free
download from www.microsoft.com/downloads/details.aspx?Familyld=92EB2EDC-3433-47 CA-A5F 8-
0483C7DDEAS85&displaylang=en.

SPECjbb2005®

SPECjbb2005 is an industry-standard benchmark from the Standard Performance Evaluation Corp. (SPEC) that
measures a server’s Java performance. (Note: SPEC and SPECjbb2005 are trademarks of the Standard
Performance Evaluation Corporation.) SPEC modeled SPECjbb2005 on the three-tier client/server architecture,
with the middle layer as the primary focus. According to SPEC, “Random input selection represents the first (user)
tier. SPECjbb2005 fully implements the middle tier business logic. The third tier is represented by tables of
objects, implemented by Java Collections, rather than a separate database.” For more information about
SPECjbb2005, see www.spec.org/jbb2005/docs/UserGuide.html.

The results we quote here for this workload are not official SPECjbb2005 results because the vConsolidate
workload uses a slightly modified version of the benchmark. These results are not comparable to SPECjbb2005
results on SPEC’s Web site.

SysBench

The developers at SourceForge (www.sourceforge.net) created SysBench to test various aspects of the
performance of servers running database systems. The benchmark’s original target was the MySQL database
system (see www.mysql.com). Intel created a version of SysBench 0.4.0 that would work with Microsoft SQL
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Server 2005 Enterprise Edition (www.microsoft.com/sql/editions/enterprise/default.mspx). We ran that version in
our test. In the vConsolidate workload, SysBench created a 100,000-row SQL database and executed a batch of
online transaction processing (OLTP) transactions against that data.

WebBench

WebBench 5.0 (128-bit US version) is an industry-standard benchmark for Web server software and hardware. It
uses PC clients to send Web requests to the server under test. It generates performance results by incrementally
increasing the number of clients making HTTP 1.0 GET requests to the Web server; the result is a curve showing
the server’s performance under increasing load. The peak of that curve represents the peak throughput of the
server. WebBench reports both the total number of requests per second the server handled and the server’s total
throughput in bytes per second. To be certain that we found the true peak performance in our testing, we verified
that the server’s processor utilization reached or was extremely close to 100 percent during the test.

vConsolidate profiles
The vConsolidate workload comes with four sets of VM specifications, which it calls profiles. These profiles define
five key factors for each workload VM:
e number of virtual CPUs (vCPUs) the workload should receive
amount of virtual RAM (vMemory) the workload should receive
the operating system (OS) the workload should run
the key application the workload should run
the workload itself

As we noted earlier, vConsolidate refers to a single collection of these five virtual machines as a consolidate stack
unit (CSU). Depending on the type of server and its available resources, you may choose to run one or more
CSUs. The typical goal is to run enough CSUs to push the server under test to its maximum capacity by
consuming close to 100 percent of the CPU capacity.

vConsolidate offers four profiles; we tested with Profile 2, which we detail in Figure 3.

Profile 2
vCPUs vMemory 0S Application
WebBench (Web) 2 1.5 GB Windows 32-bit s
LoadSim (mail) 1 1.5 GB Windows 32-bit Exchange
SysBench (database) 2 1.5 GB Windows 64-bit SQL Server
SPECjbb2005 (Java) 2 2.0GB Windows 64-bit BEA JVM
Idle 1 0.4 GB Windows 32-bit NA

Figure 3: The vConsolidate profile we used in our testing.

For further information on vConsolidate, please contact Intel.

Test results
The result for an execution of the vConsolidate workload amalgamates the results of all four of the workloads it
includes. To calculate a final score for a vConsolidate run, we used the following four steps, as vConsolidate
specifies:
1. Benchmark throughput = benchmark’s raw results/benchmark duration (for each of the four benchmarks)
2. Total benchmark throughput = add benchmark throughput for all CSUs in test
3. Normalized throughput = total benchmark throughput/reference system’s benchmark throughput
4. vConsolidate score = geomean (normalized throughput of all four benchmarks)
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The first step in this process uses whatever raw results a benchmark produces, such as number of transactions or
operations, and the benchmark’s duration in seconds. We calculate a benchmark’s duration by subtracting the
start time of the vConsolidate test from its stop time and converting that time to seconds.

WebBench is an exception to this process because it automatically produces a score in requests per second. For
this benchmark, we calculate the average requests per second for the three WebBench mixes that run while the
other benchmarks are running and record this result as its throughput.

The second step is to sum the throughput for a given benchmark across all CSUs. In the one-CSU case, there is
no need for this step. For the two-, three-, four-, five-, and six- CSU tests, we summed the throughput of each
individual benchmark across all CSUs to obtain that benchmark’s final score.

The third step is to normalize the throughput. We use the Profile 2 reference score defined in the vConsolidate
installation guide and assign it a normalized score of 1.00. We then divide the summed throughput for a given
type of work by the reference score for that benchmark. This produces the normalized score for that type of work
in this test.

The last step is to take the geometric mean of the normalized throughput for all four benchmarks.

Figure 4 shows the final score (the median of three runs) and CPU utilization of the test servers by number of
CSUs. The CPU utilization percentage is the average over the period the vConsolidate workload ran.

Server Intel Xeon processor X7460 Intel Xeon processor X7350
ggm:er of Score CPU Score CPU

1 1.22 22% 1.17 33%

2 2.33 43% 2.23 65%

3 3.26 65% 2.85 89%

4 3.92 86% 3.03 96%

5 4.23 94% 3.10 98%

6 4.34 97% 3.10 99%

7 4.34 98% 3.03 100%

8 4.34 99%

Figure 4: vConsolidate results for the test systems with varying numbers of CSUs with corresponding CPU
utilizations. Higher scores are better.

Figure 5 details the power consumption, in watts, of the test servers while idle and during the median peak
number of CSUs.

Server Idle power (watts) Average power (watts)
Intel Xeon processor X7460 534.77 757.91
Intel Xeon processor X7350 539.38 824.60

Figure 5: Average power usage (in watts) of the test servers while idle and during the median peak CSU runs.
Lower numbers are better.

Figure 6 shows the optimum CSU test results, by benchmark and CSU, for the Intel Xeon processor X7460-based
server.
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Q?tz:iz)(?b(:;:;oscee:?:r Database Java Mail Web Final score
CSu 1 80.80 18,247.28 14.67 445.98

Csu 2 80.99 18,186.89 14.86 444 86

CSuU3 81.10 18,319.26 16.18 454.22

CSu 4 82.69 18,249.15 15.51 448.64

CSuU 5 80.70 18,305.59 14.01 445.79

CSU 6 81.58 18,343.71 15.35 451.73 4.34

Figure 6: vConsolidate optimum CSU median results, by benchmark and CSU, for the Intel Xeon processor X7460-based server.
Higher scores are better.

Figure 7 shows the optimum CSU test results, by benchmark and CSU, for the Intel Xeon processor X7350-based
server.

?;g;gszgggos?:se?r Database Java Mail Web Final score
CSuU 1 60.61 15,208.48 15.29 383.43

CSu 2 60.02 15,270.64 15.18 380.69

CSU 3 59.99 15,209.45 15.14 388.93

CSu 4 60.63 15,307.38 15.67 380.86

CSuU 5 61.38 15,346.50 15.56 389.91 3.10

Figure 7: vConsolidate optimum CSU median results, by benchmark and CSU, for the Intel Xeon processor X7350-based server.
Higher scores are better.

We include complete results for all three runs on the two test systems in Appendix B.

Note: Due to the complexity and number of components the vConsolidate benchmark uses (e.g., network
interfaces, client computers, storage sub-system, configuration of VMs and benchmark components), Intel does
not recommend directly comparing test results from this report with results from other vConsolidate reports.
Unless the benchmark and its components have identical configurations, results may vary, providing an
inadequate basis for direct comparison.

Test methodology

Intel configured and provided both servers.

With the following exception, we used the default BIOS settings on each server: we enabled Intel Virtualization
Technology on all servers.

To be sure we could push the processors of each of the two system configurations to their maximum capacities,
we tested each server with as many vConsolidate CSUs as the server could handle, starting with one CSU, up to
or extremely close to 100 percent processor utilization. The rest of this section details how we set up the servers
and the vConsolidate workload.

Hardware and software the test involved

Software
We used the following software to configure and run the vConsolidate workload:
e Windows Server 2008 Hyper-V

e Microsoft Windows Server 2003 R2, Enterprise Edition
e Microsoft Windows Server 2003 R2, Enterprise x64 Edition
e Microsoft Exchange Server 2003
e Microsoft SQL Server 2005
Principled Technologies, Inc.: vConsolidate performance and power on quad- S
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BEA JRockit 1.6.0_02-b05
WebBench 5.0

SPECjbb2005 v1.07
SysBench v0.4.0
Intel vConsolidate framework version 2.0

Hardware
Our test bed consisted of the following hardware:
e The server under test

Microsoft Exchange Server Load Simulator (LoadSim) 06.05.7775

e Eleven custom-built Intel Desktop Board D915GMH with Intel Pentium® 4 3.0GHz w/HT systems, which
we used for all WebBench clients, LoadSim clients, and WebBench controllers (CSU 2 and CSU 3).
e One custom-built Intel Server Board D945GTP system, which we used as both the main vConsolidate

controller and the CSU 1 WebBench controller

e NETGEAR GS724T, which we set up into two VLANs (one for external network and one for internal

network)
e EMC CLARIiion CX3 storage

e Three EMC CX-4PDAE-FD disk enclosures, with 15 x Hitachi HUS151473VLF4EO 73.4 GB disk drives

each

e QLogic SANblade QLE2462 Dual Port 4-Gbps Fibre Channel Host Bus Adapter (HBA) installed in the

server under test

Figure 8 illustrates the test bed.

vConsolidate test bed

CSU #n Combined
client
(WebBench
controller,
WebBench client,
and LoadSim
client)

Internal network
switch

{__Internal network n _ G——

{  External network

Server under test
with one active NIC for
external network and one
NIC per CSU for
WebBench and LoadSim
traffic

Main controller

Figure 8: Our vConsolidate test bed.

IP addresses
Server under test
« External network IP address: 192.168.0.250

Main controller
« External network IP address: 192.168.0.100
« Internal network IP address for each CSU's
Load3im and WebBench traffic: in form
192.168.n1.100, where n is CSU number (e.g.,
CSU #1 =192.168.11.100)

Internal network IP addresses
« Combined client: in form 192.168.n1.110, where n
is CSU # (e.g., CSU #1 = 192.168.11.110)

VM IP addresses
« Mail server VMs: in form 192.168.n1.115, where n
is CSU # (e.g., CSU #1=192.168.11.115)
« Web server VMs: in form 192.168.n1.215, where n
is CSU# (e.g., CSU #1 =192.168.11.215)
« JavaServer1 - n, DBServer1 - n, ldleServer! —n
(where n is highest CSU#) = DHCP
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Server installation

We configured all servers with the same disk setup using the NetApp FAS960 filer. We split the storage into four
volumes, one with 10 GB and five with 130 GB. For each server, we installed Windows Server 2008 Hyper-V on
the 10GB volume and installed a CSU on each of the five 130GB volumes. We installed the boot loader on the
hard drive installed in the server’s drive chassis on the server under test.

Adding the Hyper-V role to Windows Server 2008

Note: Make sure you have installed all the latest critical and recommended updates for Windows Server 2008
from Windows Update. Specifically, you must install the update that upgrades Hyper-V from beta to release
software. (As of 07/21/2008, this update is KB950050 on 64-bit Windows.)

9.

N>R~ ®LN =

Click Server Manager->Roles>Add Roles.

Check the box beside the Hyper-V role, and click Next.

Click Next.

Check the box beside the Ethernet card you wish to use, and click Next.
Click Install. Installation begins.

When installation finishes, click Close.

When the system prompts you to restart, click Yes.

Once the system finishes rebooting (this might happen twice), log in.
The Resume Configuration Wizard should start automatically.

Once the Resume Configuration Wizard completes, the installation results should appear with a message
that the installation succeeded.

10. Click Close.
11. Restart the server.

Adding logical unit numbers (LUNs)
Note: Make sure the Fibre Channel/iSCSI LUN is mapped to the card in your system.

1.
2.

Nooh~w

®

Click Server Manager-> Storage—>Disk Management.

When the wizard prompts you to initialize new disks, click OK. Note: If you must select a partition table,
select MBR.

Right-click the first unallocated disk partition, and select New Simple Volume...

Click Next.

Use the entire LUN storage space (this should be the default), and click Next.

Select the drive letter to assign to the new partition, and click Next.

Label the volume appropriately (i.e., LUNO, LUN1, etc.), make sure Perform a quick format is checked,
and click Next.

Click Finish.

Configure Hyper-V default options

1

2.
3.

4.

5.
6.

Click Start->Administrative Tools>Hyper-V Manager.

From the Actions menu, select Hyper-V Settings...

From the left menu of the Settings screen, select Virtual Hard Disks, and enter the default folder to store
virtual hard disk files (e.g., E:\Hyper-V\Virtual Hard Disks).

From the left menu of the Settings screen, select Virtual Machines, and enter the default folder to store
virtual hard disk files (e.g., E:\Hyper-V).

Click OK.

You may also want to configure any VM network switch settings at this time.

Creating a virtual machine

prOND~

o

Click Start->Administrative Tools->Hyper-V Manager.

From the Actions menu, select New->Virtual Machine...

Click Next.

Enter a name for the virtual machine, and browse to the location where you want to store the VM files The
New Virtual Machine Wizard will automatically create a subfolder with the name of the VM).

Click Next.

Principled Technologies, Inc.: vConsolidate performance and power on quad- 7
processor Intel processor-based servers



Specify the amount of memory to allocate to the virtual machine, and click Next.
Select the network connection for the virtual machine to use, and click Next.
Select Attach a virtual hard disk later, and click Next.

Click Finish.

© N

Modifying the Virtual Machine (Creating the virtual HDD)

Click Start>Administrative Tools=>Hyper-V Manager.

Right-click the Virtual Machine on which you want to install Windows, and click “Settings...”
From the menu on the left, select IDE Controller 0, and click Add to add a new hard drive to the IDE
Controller.

4. Click New to create a new virtual hard disk file.

5. Click Next.

6. Select Fixed size, and click Next.

7. Specify the name and location of the virtual hard disk file.

8

9.

1

W=

Specify the size of the new blank virtual hard disk (in GB).
Click Finish. The server begins creating the new virtual hard disk.
0. Once it finishes creating the new virtual hard disk, click OK.

Modifying the Virtual Machine (adding an additional hard disk)

Note: Do not use this method to configure the VM primary hard disk; for that you must use a virtual IDE hard disk.
However, we recommend that you perform high-usage 1/O tasks (i.e., database server, file server, mail server,
etc.) on a secondary disk whenever feasible.

Click Start->Administrative Tools->Hyper-V Manager.

Right-click the Virtual Machine on which you want to install Windows, and click Settings...

From the menu on the left, select Add Hardware.

Choose the “SCSI Controller” device and click Add.

Click “Add” to add a new hard drive to the virtual SCSI Controller.

Click New to create a new virtual hard disk file.

Click Next.

Select “Fixed size” and click Next.

Specify the name and location of the virtual hard disk file.

10 Specify the size of the new blank virtual hard disk (in GB).

11. Click Finish. The server will then begin creating the new virtual hard disk.

12. Once it finishes creating the new virtual hard disk, click OK.

N>R~ WLN =

Installing Windows on the VM
Note: We have tested this using Windows Server 2003 R2 Enterprise x64 Edition with SP2.

1. Click Start>Administrative Tools>Hyper-V Manager.

2. Right-click the Virtual Machine on which you want to install Windows, and click Connect...

3. From the menu, select Media->DVD Drive->Insert Disk...

4. Select the ISO image file for the version of Windows you are installing, and click Open.

5. To start the virtual machine, select Start from the Action menu.

6. Click the screen, and begin installing Windows as you normally would.

7. Once installation is complete, select action = Ctrl-Alt-Delete.

8. Enter your password, and press Enter.

9. Select Media->Eject CD.

10. Select Media-~>Insert CD and choose the second installation disk.

11. When the Windows installation completes select Action—>Insert Integration Services Setup Disk from the
menu. Installation should begin automatically.

12. At the prompt to restart, click Yes.

13. Once the system has restarted, log in, and verify that all configured devices (mouse, keyboard, video,
network, etc.) are working.

14. Once you are sure all your devices are working, from the menu select Media->DVD Drive>Eject

vmguest.iso.
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Installing vmbus.sys patch
Note: We installed an updated version of vmbus.sys on both systems to provide optimum performance. The
version we installed was 6.0.6001.18018.
1.  On both 64-bit and 32-bit virtual machines, copy the vmbus.sys file to C:\WINDOWS\system32\drivers.
2. On all virtual machines, copy the vmbus.sys file to c:\WINDOWS\Virtualizationi\6.0.6001.18016.
3. On the Hyper-V server, open a command prompt and type bcdedit /set testsigning on.
4. Copy the 64-bit vmbus.sys file to c:\WINDOWS\system32\drivers.

To create one vConsolidate CSU, we had to create the five virtual machines that CSU describes:
e mail server

Web server

Java application server

database server

idle server

The following subsections detail how we created and configured each of these VMs.

Copying the VMs
Use the following steps to create VMs with the same base OS:

1. Navigate to the Virtual Hard Disk folder on the server where the Virtual Hard Disks are stored.

2. Highlight your base VM, and use the copy/paste method to create the appropriate number of copies for
your VMs.

3. Right click each Hard Disk and rename them according to the VM for which they are to be used.

4. Select Start->Administrative Tools>Hyper-V Manager...

5. Choose New->Virtual Machine.

6. Click Next.

7. Enter a name for the virtual machine, and select the location to store the VM files The New Virtual
Machine Wizard will automatically create a subfolder with the name of the VM).

8. Click Next.

9. Specify the amount of memory to allocate to the virtual machine, and click Next.

10. Select the network connection for the virtual machine to use, and click Next.

11. Select Attach a virtual hard disk later, and click Next.

12. Click Finish.

13. Select the newly created VM and choose Settings—>IDE Controller 0.

14. Choose Add to add a Hard Disk to the VM.

15. Choose Browse.

16. Select the appropriate Hard Disk and click Okay.

17. Click OK.

Installing and configuring the mail server VM
1. Follow the steps in the earlier Copying the VMs section using the following VM specifications:

e Base VM: Base32
Name: MailServer1
Virtual processors: 1
Virtual memory: 1.5 GB
Virtual disk size: 10 GB
Virtual network: Internal Network (set the IP address to 192.168.11.115 in Windows within the VM)

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Installing the domain controller
1. Select Start->Administrative Tools->Manage Your Server.
2. Click Add or remove a role.
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15.

16.
17.
18.
19.
20.

At the Configure Your Server window, click Next.

At the Configuration and Options screen, select Custom Configuration, and click Next.

At the Server Role screen, select Domain Controller, and click Next.

At the Summary of Selections screen, click Next.

At the Welcome pop-up window, click Next.

At the Operating System Compatibility screen, click Next.

For the Domain Controller Type, leave the default option (Domain controller for a new domain), and click
Next.

. At the Create New Domain screen, leave the default (Domain in a new forest), and click Next.

. At the Install or Configure DNS window, select No, and click Next.

. At the New Domain Name screen, type a domain name (vcon . com), and click Next.

. At the NetBIOS Domain Name screen, enter a NETBIOS domain name (vcon), and click Next.

. Click Next through the following screens: Database and Log Folders, Shared System Volume, and

Permissions. Doing so accepts the default options for each of those screens.

At the Directory Services Restore Mode Administrative Password screen, enter a password (password),
and click Next.

When the installation software prompts you to do so, insert the OS CD, and click OK.

At the Completing the Active Directory Installation Wizard screen, click Finish.

When the system prompts you to reboot the VM, click Restart Now.

After the VM reboots, log in to the system.

At the This Server is Now a Domain Controller window, click Finish.

Installing Internet Information Services 6.0

COENO>ORA~ON =

10
11.

Select Start->Control Panel>Add or Remove Programs.

Click Add/Remove Windows Components.

Select Application Servers, and click Details.

Click ASP.NET, and make sure a check appears in the check box.
Select Internet Information Services (IIS), and click Details.

Click NNTP Services and SMTP Services, make sure a check appears in both check boxes, and click OK.
Click OK to close the Application Server window.

At the Windows Components Wizard, click Next to begin the installation.
When the system prompts you to do so, insert the OS CD, and click OK.
At the Completing the Windows Components Wizard window, click Finish.
Close the Add or Remove Programs window.

Installing Exchange Server 2003

1.

Nook~wON

Insert the Microsoft Exchange Server 2003 CD. The CD should automatically launch the installation
software.

Choose Exchange Server Enterprise Edition.

Run the Setup application.

Click the Exchange Deployment Tools link.

Click the Deploy the first Exchange 2003 Server link.

Click the New Exchange 2003 Installation link.

Click the Run ForestPrep now link.

a. When the compatibility issue notice appears, click Continue, and check the Don’t display this
message again box.

At the Welcome screen, click Next.

Accept the End User License Agreement, and click Next.

At Component Selection Screen, keep the defaults, and click Next.

Leave the default account information, and click Next.

Installation should start. (This process may take a while to complete.)

When the installation completes, click Finish.

Return to the Exchange Server Deployment Tools screen, and click the Run DomainPrep now link.
a. Atthe Welcome screen, click Next.

b. Accept the End User License Agreement, and click Next.

@*0o00C
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c. At Component Selection Screen, keep the defaults, and click Next.
d. Atthe insecure domain notice, click OK.
e. When the installation completes, click Finish.
9. Return to the Exchange Server Deployment Tools screen, and click Run Setup Now.
a. Atthe Welcome screen, click Next.
b. Accept the End User License Agreement, and click Next.
c. Atthe Component Selection screen, the action for Microsoft Exchange should by default be Typical.
(If it is not, use the drop-down box to set it to Typical.)
Click Next.
For the Installation Type, select Create new Exchange Organization, and click Next.
Enter vcon as the Organization Name, and click Next.
Accept the Microsoft Exchange Server Licensing Agreement, and click Next.
Review the installation summary, and click Next.
The installation should start. (This process may take a while to complete.)
When the installation completes, click Finish.
10. Close the Exchange Server Deployment Tools window.
11. Install Microsoft Exchange Server 2003 Service Pack 2.
Insert the SP2 CD, and double-click update exe.
Accept the default location to extract the file, and click OK.
After the extraction finishes, open Windows Explorer, and browse to the update.exe executable.
At the Welcome screen, click Next.
Select | agree to accept the License Agreement, and click Next.
At the Component Selection window, leave the default option (Update), and click Next.
Verify the installation Summary, and click Next.
When the installation completes, click Finish.
12. In the Virtual Infrastructure Client console, add a new 40GB virtual hard disk to this VM by doing the
following:
Right-click the MailServer1 VM, and select Settings from the menu.
On the Hardware Tab, click Add Hardware.
Choose the “SCSI Controller” device and click Add.
Click “Add” to add a new hard drive to the virtual SCSI Controller.
Click New to create a new virtual hard disk file.
Click Next.
Select “Fixed size” and click Next.
Specify the name and location of the virtual hard disk file.
Specify the size of the new blank virtual hard disk (in GB).
Click Finish. The server will then begin creating the new virtual hard disk.
Once it finishes creating the new virtual hard disk, click OK.
13. Restart the VM by selecting Start->Shut down—->Restart inside the MailServer VM.
14. In the MailServer VM, right-click My Computer, and select Manage.
15. In the Computer Management Console, select Disk Management.
16. When a Welcome to Initialize and Convert Disk Wizard window appears, click Next.
17. Select Disk 1 to initialize.
18. At the Select Disk to Convert screen, leave the disk unchecked.
19. At the Completing the Initialize and Convert Disk Wizard screen, click Finish.
20. Right-click the Disk 1 unallocated box, and select New Partition.
21. At the Welcome screen, click Next.
22. Leave the partition type as Primary, and click Next.
23. Accept the default Partition Size, which should be the same as the Maximum disk space, and click Next.
24. Assign the drive letter E, and click Next.
25. Format the partition with the NTFS File system, enter Mail Store for the volume label, and click Next.
26. At the Completing the New Partition Wizard screen, click Finish.
The partition should begin formatting.
27. When the formatting completes, close the Computer Management console.
28. Select Start->All Programs->Microsoft Exchange—> System Manager.

T Temea

S@ 0o T

AT T TQT0Q0 oW

Principled Technologies, Inc.: vConsolidate performance and power on quad-
processor Intel processor-based servers



29. In the left window pane, expand Servers and MailServer so the First Storage Group is visible.
30. Right-click First Storage Group, and select Properties.

31. Click Browse, and change the Transaction log and System path location to E:\.

32. Check the Enable circular logging box, and click Apply.

33. When the pop-up message appears asking if you want to perform this task, click Yes.

34. When the message appears saying that all mounted stores are back online, click OK.

35. Right-click Mailbox Store under First Storage Group, and select Properties.

36. Select the Database tab.

37. Click Browse, and move the Exchange database and Exchange streaming database to E:\.
38. Check the This database can be overwritten by a restore box.

39. Click Customize next to Maintenance interval.

40. Remove all blue from the boxes so the system will not perform maintenance, and click OK.
41. At the Mailbox Store Properties window, click Apply.

42. When a warning message appears, click Yes.

43. When the message that the database files have been moved appears, click OK.

44. Click OK to close the Mailbox Store Properties window.

45. Right-click Public Store under First Storage Group, and select Properties.

46. Select the Database tab.

47. Click Browse, and move the Exchange database and Exchange streaming database to E:\.
48. Check the This database can be overwritten by a restore box.

49. Click Customize next to Maintenance interval.

50. Remove all blue from the boxes so the system will not perform maintenance, and click OK.
51. At the Public Store Properties window, click Apply.

52. When a warning message appears, click Yes.

53. When the message that the database files have been moved appears, click OK.

54. Click OK to close the Public Store Properties window.

55. Reboot the virtual machine.

Installing and configuring the Web server VM
1. Follow the steps in the earlier Cloning the base VMs section using the following VM specifications:

e Source VM: Base32
Name: WebServer1 (use WebServer for the Host Name in the VM)
Virtual processors: 2
Virtual memory: 1.5 GB
Virtual Disk Size: 10GB
Virtual Network: Internal Network (set the IP address to 192.168.11.215 in Windows within the VM)

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Installing Microsoft Internet Information Server
1. Select Start->Administrative Tools>Manage Your Server.
2. Select Add or remove a role.
3. At the Configure Your Server window, click Next.
4. At the Configuration Options screen, select Custom configuration, and click Next.
5. At the Server Role screen, select Application Server, and click Next.
6. At the Application Server Options screen, select Enable ASP.NET, and click Next.
7. At the Summary of Selections screen, click Next.
8. When the installation software prompts you to do so, insert the Operating System CD, and click OK.
9. When the installation completes, click Finish.
10. Close the Manage Your Server window.

Installing WebBench 5.0
1. Insert the WebBench 5.0 CD into the Virtual Client, and connect with the Virtual CDROM.
2. Copy wbtree.exe from the \wb50\workload directory on the CD to C:\inetpub\wwwroot.
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12.
13.
14.
15.

16.
17.
18.
19.
20.
21.
22.
23.
24.
25.

26.

0.
1. Using Windows Explorer, browse to C:\Inetpub\wwwroot\cgi-bin, right-click simcgi.exe, and select

Double-click wbtree.exe to expand the workload. (This step will create a wbtree folder with all the test
data WebBench required.)

Create a cgi-bin folder in c:\inetpub\wwwroot.

After installing the WebBench controller, copy simcgi.exe from the controller machine in
C:\WebBench\Controller\Suites\WebBench\Examples directory to the Web server VM’s
C:\Inetpub\wwwroot\cgi-bin\ directory.

Right-click My Computer, and select Manage.

Expand Services and Applications, Internet Information Services, and Web Sites in the left window pane.
Click Default Web Sites.

Right-click the cgi-bin directory in the right pane, and select Properties from the drop-down menu.

In the Execute permissions field, select Scripts and Executables, and click OK.

Properties from the drop-down menu.

Select the Security tab, and grant Read/Read & Execute permissions to the user, Internet Guest Account.
Click OK to close simcgi.exe properties.

Close Windows Explorer.

In the Computer Management window, right-click the Default Web Server, and select properties from the

drop-down menu.

Select the HTTP Headers tab, and click MIME Types.

In the MIME Types window, click New.

In the Extension text box, enter . ex

In the MIME type text box, enter application/octet-stream, and click OK.

Click OK again to close the MIME Types window and the Default Web Site Properties window.

If a notification window about a child node pops up, click OK.

In the Computer Management console, select Web Service Extension.

Select All unknown CGI Extensions in the right pane, and click Allow.

Click Yes, you do want to allow All Unknown CGI Extensions in the pop-up window.

Open a Web browser, and type the URL http://localhost/cgi-bin/simcgi.exe to verify you correctly installed
the WebBench files. Text about the system should appear in the browser window.

Close the Web browser.

Installing Certificate Server

COENOIORAWLN =

10
11.

Select Start->Control Panel->Add or Remove Programs.

Click Add/Remove Windows Components.

Select Certificate Servers, and accept the CA Service warning.

Click Next.

Select Standalone root CA in the CA Type Windows, and click Next.

Enter WEBBENCH in the common name field, and click Next.

At the Certificate Database Settings screen, leave the default options, and click Next.
When the warning about stopping IS appears, click Yes.

When the installation software prompts you to do so, insert the OS CD, and click OK.
Click Yes to enable Active Server Pages.

When the installation completes, click Finish.

Creating a certificate request

1.
2.

®ND>O AW

In the Computer Management Console, right-click the Default Web site, and select Properties.

Select the Directory Security tab, and then click Server Certificate under Secure Communications to start
the Web Server Certificate Wizard.

At the Welcome screen, click Next.

Select Create a new certificate, and click Next.

Select Prepare the request now, but send it later, and click Next.

Type Default Web Site for the certificate name.

Use the default bit length (1024), and click Next.

Type MyWeb for the organization name and Development Dept for the organizational unit, and click
Next.
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9.

10.
11.
12.

13.
14.

Type the server name as the common name, and click Next.

Enter your location information, and click Next.

Save the certificate information to the default path and file name, and click Next.

Verify the information that you have typed, and then click Next to complete the process and create the
certificate request.

Click Finish to close the IS Certificate Wizard.

Click OK to close the Default Web Site Properties window.

Submitting a certificate request

1.

2.
3.
4

o o
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0.

Open a Web browser, navigate to http://localhost/CertSrv/, and press Enter.

Click Request a cetrtificate.

Click Advanced certificate request.

Click Submit a certificate request by using a base-64-encoded CMC or PKCS #10 file, or submit a
renewal request by using a base-64-encoded PKCS #7 file.

Open the request document that you created in the Create a certificate request section.

Copy the contents of the document to a text box with the following format.

I BEGIN NEW CERTIFICATE REQUEST-----

L END NEW CERTIFICATE REQUEST-------

Note: If you saved the document with the default name and location, it is located at C:\Certreq.txt. Be sure
to copy all of the content as we illustrated above.

Paste the contents of the document into the Web form’s Base64 Encoded Certificate Request text box.
Click Submit.

You should receive a Certificate Pending message in the Web browser.

Close the Web browser window.

Issuing and downloading a certificate

PN~

Select Start->All Programs—>Administrative Tools—> Certificate Authority.

In the Certificate Authority window, expand the server name.

Click the Pending Requests folder.

In the pending request folder, right-click the pending certificate request that you just submitted, select All
Tasks, and then click Issue. (Note: After you select Issue, the certificate no longer appears in this window
and folder. It now resides in the Issued Certificate folder.)

Close the Certificate Authority window.

Open a Web browser, and type http://localhost/CertSrv/.

Click View the status of a pending certificate request.

Click the certificate request that you can see.

Click Download Certificate.

. Click Save in the File Download window.

. Save the certificate to C:\.

. Close the download complete pop-up window.
. Close the Web browser window.

Installing the certificate and setting up an SSL Web site

1. Open the Computer Management console by right-clicking My Computer, and selecting Manage.

2. Right-click the Default Web site, and select Properties.

3. Select the Directory Security tab.

4. Under Secure Communications, click Server Certificate. This step will start the Certificate Installation
Wizard.

5. At the Welcome screen, click Next.

6. Select Process the pending request and install the certificate, and click Next.

7. Browse to the location of the certificate that you downloaded in the Issue and download a certificate
section, and click Next.

8. Keep the default SSL Port, and click Next.

9. Verify the information is correct on the Certificate Summary page, and click Next.
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10. Click Finish to complete the installation.
11. Click OK to close the Default Web Site Properties window.
12. Close the Computer Management window.

Configuring and testing the certificate

1.
2.

3.
4.

Open a Web browser, and type https://webserver/cgi-bin/simcgi.exe.

You may receive a security alert that states that the certificate is not from a trusted root CA. Click Yes to
continue to the Web page.

If the page appears, you have successfully installed the certificate.

Close the Web browser.

Installing and configuring the Java application server VM

1.

Follow the steps in the earlier Cloning the base VMs section using the following VM specifications:
e Base VM: Base64

Name: JavaServer1

Virtual processors: 2

Virtual memory: 2 GB

Virtual Disk Size: 10 GB

Virtual Network: External Network (keep the default Windows Network DHCP settings)

To finish setting up this VM for vConsolidate, we had to install and modify an additional software component. The
following subsections detail the necessary installation processes.

Installing SPECjbb2005

1.
2.
3.

seeNooas

Copy the BEA JRockit JVM 1.6.0_02 folder to the root of C: in the VM.
Install SpecdBB2005 in the VM directory: c:\vSpecJBB2005.
Add the BEA JRockit JVM to the Windows system path by doing the following:
Right-click My Computer, and select Properties.
b. Select the Advanced tab, and click Environment Variables.
c. Inthe System variables section, select Path, and click Edit.
d. Add the following to the end of the Variable value string: C:\jrockit-jdk1.6.0_02 \bin (jrockit-
jdk1.6.0_02 is the folder name of the JVM installation).
e. Click OK to close the Edit System Variable, Environment Variables, and System Properties
windows.
Open a command prompt by selecting Start>Run.
Type cmd, and click OK.
Change to the vSpecdBB2005 directory by typing cd C:\vSpecdBB2005, and then press Enter.
Type runit .bat, and press Enter to verify SPECjbb2005 starts.
Press Ctrl-C to stop the benchmark.
Confirm that you do want to stop the run by typing Y and pressing Enter.

o

O Copy the following files from the vConsolidate package to the VM directory C:\:

e Daemon.exe
e Kkillapp.exe.

Modifying SPECjbb2005
To run the vConsolidate benchmark, you must modify SPECjbb2005 as follows:

1.

Modify the following three original source files in the SPECjbb directory (C:\SPECjbb2005\src\spec\jbb\)
by opening each file with WordPad and making the changes below. Save each file after you have made
the changes.
e Company.java

Change private long measurement time; to public long measurement time;

Change JBButil.SecondsToSleep ( (int) measurement time); to
JBButil.SecondsToSleep (Long.MAX VALUE/1000) ;

o DeliveryTransaction.java
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After the line customerPtr.adjustBalance (matchingOrder.getTotalAmount ()) ;, add the

following lines:
int timerCount = 0;
timerCount = (short)JBButil.random(1,100) ;
if (timerCount == 1)
JBButil.milliSecondsToSleep (company.measurement time) ;
e TransactionManager.java
Change myTimerData.updateTimerData (txntype, txntime) ; to the following lines:

myTimerData.updateTimerData (txntype, txntime) ;
if (txntype==0 && myTimerData.getTransactionCount (0) %1000 == 0)
int sum = 0;
for (int k=0; k<=5; k++)
sum += myTimerData.getTransactionCount (k) ;
System.out.println("===="+this+":"+"===="+sum) ;

2. Open the command prompt by clicking Start>Run, type cmd, and press Enter.
3. At the command prompt, type cd C:\SPECjbb2005\src\spec\jbb\.
4. At the command prompt, type the following commands. Press Enter after each command:
e mkdir class
e "C:\Program Files\Java\jrockit-jdkl.5.0\bin\javac" -cp "C:\Program
Files\Java\jrockit-jdk1.5.0\jre\lib\rt.jar" -d class\ *.java
infra\Util\*.java validity\*.java ..\reporter\*.java
cd class\
"C:\Program Files\Java\jrockit-jdk1l.5.0\bin\jar" -cf jbb.jar
spec\jbb\*.class spec\jbb\infra\Util\*.class spec\reporter\*.class
e "C:\Program Files\Java\jrockit-jdk1l.5.0\bin\jar" -cf check.jar
spec\jbb\validity\*.class
Type exit to close the command prompt.
Open Windows Explorer from the start menu.
Copy the jbb.jar and check.jar files from C:\SPECjbb2005\src\spec\jbb\class to C:\vSpecJBB2005\.
When the system asks if you want to overwrite files, click Yes to overwrite the original jbb.jar and
check.jar files.
Using Windows Explorer, navigate to C:\vSpecJBB2005, and open the SPECjbb.props file.
0. Make the following changes to the SPECjbb.props file:
e Change input.starting number warehouses=1 to
#input.starting number warehouses=1
e Change input.increment number warehouses=1to
#input.increment number warehouses=1
e Change #input.sequence of number of warehouses=1 2 3 4 5 6 7 8to
input.sequence of number of warehouses=2
Note: Set the above parameter to be equal to the number of vCPUs you configured for Java
server VM.
e Change input .measurement seconds=240 to input .measurement seconds=10
11. In the C:\vSpecJBB2005 directory, right-click runit.bat, and change set JAVAOPTIONS=-Xms256m -
Xmx256mto set JAVAOPTIONS=-Xmsl000m -Xmx1000m -Xxthroughputcompaction -
XXallocprefetch -XXallocRedoPrefetch -XXcompressedRefs -XxlazyUnlocking -
XXtlasizel28k

© NG

- ©

Installing and configuring the database server VM
1. Follow the steps in the earlier Cloning the base VMs section using the following VM specifications.
e Base VM: Base64
Name: DBServer1
Virtual processors: 2
Virtual memory: 1.5 GB
Virtual disk size: 10 GB
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o Virtual network: External Network (keep the default Windows Network DHCP settings)

To finish setting up this VM for vConsolidate, we had to install several additional software components. The
following subsections detail the necessary installation processes.

Installing Microsoft Internet Information Server

N>R~ ®LN =

Select Start->Administrative Tools->Manage Your Server.

Select Add or remove a role.

At the preliminary steps screen, click Next.

At the Server Role screen, select Application Server, and click Next.

At the Summary of Selections screen, click Next.

When the installation software prompts you to do so, insert the OS CD, and click OK.
When the installation completes, click Finish.

Close the Manage Your Server window.

Installing Microsoft SQL Server 2005

SOoNoOoORWN =

Insert the SQL Server 2005 CD into the controller, and connect with the Virtual CD ROM.

Click the Server Components link under the Install section to begin the installation.

Accept the license agreement, and click Next.

Click Next to install the prerequisites.

After the prerequisites complete installing screen, click Next.

At the Welcome screen, click Next.

At the System Configuration Check, assuming everything has a status of success click Next.
Enter the registration information, and click Next.

At the Components to Install screen, select SQL Server Database Services, then click Advanced.

. Instruct the software to install both the Database Services and Client Components by clicking the drop-

down arrow on both and selecting Entire feature will be installed on local hard drive.

. Click Next to start the installation.

. For Instance Name, leave the default option, and click Next.

. At the Service Account screen, select Use the built-in system account (Local system), and click Next.

. Keep the default option for Authentication Mode, and click Next.

. For Collation Settings, leave the defaults, and click Next.

. Accept the default Error and Usage Report Settings, and click Next.

. At the Ready to Install screen, click Install to begin the installation.

. When the installation software prompts you to do so, insert Microsoft SQL Server 2005 disk 2. Use the

Virtual CDROM to connect it to the VM, and click OK.

. When the setup process completes, click Next.

. Click Finish to complete the initial installation.

. Install Service pack 2 by copying SQLServer2005SP2-KB921896-x64-ENU.exe to the virtual machine
. Double-click the executable to launch the installer.

. At the Welcome screen, click Next.

. At the License Terms screen, accept the license agreement.

. At the Feature Selection screen, click Next to accept all defaults.

. At the Authentication screen, click Next to accept all defaults.

. At the Error and Usage Reporting Settings screen, click Next to accept all defaults.

. At the Running Processes screen, click Next.

. Click install on the Ready To Install screen.

. Click OK, on the Computer Reboot Requires message box.

. Click Next at the Installation Complete Screen.

. At the Additional Information screen, deselect Launch the User Provisioning Tool for Windows Vista after

SP2 installation completes.

. Click Finish.
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Creating the test database and generating data

1.
2.
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18.
19.

Select Start>Microsoft SQL Server 2005->SQL Server Management Studio.

In the Connect to Server window, use the drop-down menu next to Server name to select <Browse for
more>.

In the Browse for Server window, select the Network Servers tab, and wait for it to retrieve data.
When Database Engine appears, expand the menu, select DBSERVER1, and click OK.

At the Connect to Server window, the server name should be present.

Click Connect to connect to the server.

Right-click the Database folder in the left window, and select New Database from the pop-up menu.
In the Database name field, type sbtest, and click OK.

Copy the following files from the vConsolidate package to the VM C:\ directory:

e vSysbench.exe

e Daemon.exe

e Kkillapp.exe

. Open a command prompt by selecting Start->Run, type cmd, and click OK.
. In the command prompt, type cd \ to change to C:\.
. To prepare the database, type vsysbench.exe --test=oltp --oltp-table-size=100000

prepare, and press Enter.

. When the command finishes, the C:\ prompt appears.
. Type exit, and press Enter to close the command prompt.
. In SQL Server 2005 Management Studio, stop the database service by right-clickihg DBSERVER1 in the

left window pane, and then select Stop from the drop-down menu.

. Using Windows Explorer, create the folder C:\backup.
. With Windows Explorer, copy all sbtest files from C:\Program File\Microsoft SQL

Server\MSSQL.1\MSSQL\Data\ to c:\backup. (You should see two files: sbtest. mdf and sbtest_log.Idf.)
Close Windows Explorer once the copy completes.

Restart the database service using SQL Server 2005 Management Studio by right-clicking DBSERVER1
and selecting start.

Installing and configuring the idle server VM

1.
2.

Follow the steps in the earlier Cloning the base VMs section using the following VM specifications.
Use the VM Specifications below:

e Base VM: Base32

Name: IdleServer1

Virtual processors: 1

Virtual memory: 0.4 GB

Virtual disk size: 5 GB

Virtual network: External Network (keep the default Windows Network DHCP settings)

Installing and configuring the second CSU

To create the VMs the second CSU requires, we copied the existing virtual Hard Disks from the first CSU and
directed the new VMs to point to the copied hard disks. We then started each VM and entered a new IP address
or name depending on the need of each VM.

1.
2.
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Navigate to the Virtual Hard Disk folder on the server where the Virtual Hard Disks are stored.
Highlight the first VM hard disk, and use the copy/paste method to create the appropriate number of
copies for your CSUs.

Right click each Hard Disk and rename them according to the CSU for which they are to be used.
Select Start->Administrative Tools>Hyper-V Manager...

Choose New->Virtual Machine.

Click Next.

Enter a name for the virtual machine, and select the location to store the VM files The New Virtual
Machine Wizard will automatically create a subfolder with the name of the VM).

Click Next.

Specify the amount of memory to allocate to the virtual machine, and click Next.
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10.
11.
12.
13.
14.
15.
16.
17.
18.

Select the network connection for the virtual machine to use, and click Next.
Select Attach a virtual hard disk later, and click Next.

Click Finish.

Select the newly created VM and choose Settings—>IDE Controller 0.
Choose Add to add a Hard Disk to the VM.

Choose Browse.

Select the appropriate Hard Disk and click Okay.

Click OK.

Repeat the steps for each VM for the appropriate number of CSUs.

Client installation
In addition to setting up the server under test, we also had to set up the client systems we show in Figure 8. Both
the WebBench and LoadSim workloads require test clients. Each CSU requires one consolidated test client.

Installing the WebBench 5.0 test client system
To run WebBench, you need two types of test systems. WebBench clients use WebBench software engines to
send HTTP requests to stress the server under test. A WebBench controller system manages the clients during
as the benchmark runs. Both systems run on the same physical client.

Installing a WebBench 5.0 client

1.
2.
3.
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21.

22.
23.
24.
25.
26.
27.
28.

Install Windows 2003 Enterprise Edition 32-bit. Use mailclient as the system name.

Install Windows Server 2003 Service Pack 2 with the default settings.

Open the Network Connections window by right-clicking My Network Places and selecting Properties from
the menu.

Right-click the network connection, and click Properties.

Highlight TCP/IP, and select Properties.

Select Use the following IP address, and enter the following information: IP address 192.168.11.211,
Subnet 255.255.255.0.

Click OK to close the two Properties windows.

Insert the WebBench CD, and open it with Windows Explorer.

Run setup.exe from the location /wb50/client/setup.exe.

. Click Next through all screens, a process that accepts the defaults.
. When the installation completes, copy the WebBench shortcut icon from the open window to the system’s

desktop.

. With WordPad, open the file c:\Windows\system32\drivers\etc\hosts.
13.

After the last text in that file, enter the following additional lines, and click Save.
e 192.168.11.211 controller
e 192.168.11.215 server

. Close the hosts file and Windows Explorer.

. Run /wb50/controlr/setup.exe.

. Click Next through the installation, which accepts all default options.

. With Windows Explorer, open C:\WebBench\Controller\Clientids\client.cdb.

. Add the client’s IP address to the top of the file. Enter Tab twice, and type the number 1.
. Click File>Save, and close the client.cdb file.

. Copy vConsolidate.tst file from the vVCON\WebBench directory to

C:\WebBench\controller\suites\WebBench.

Copy ecommerce_cgi_template_w2k3.tst and ecommerce_cgi_template_w2k3.wl files from
vCON\WebBench directory to C:\WebBench\controller\suites\WebBench.

Copy all files from \vCON_framework\WebBench_daemon in the vConsolidate package to C:\.
Select Start->All Programs—>PC Magazine Benchmarks>WebBench 5.0 Controller.

Click Create/Edit from the Suites drop-down menu.

Browse to the vConsolidate.tst file, and click Open.

Highlight the first Mix, and click Edit.

On the General tab, change Engines per client to 8.

Select the Workload tab.
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29.
30.
31.
32.
33.

Change the number of threads to 1.

Click Copy across.

Select the Engines per client and Number of threads check boxes, and click OK.
Click OK to close the suites windows.

Close the WebBench Controller window.

Installing the mail test client
Install the mail client on the same consolidated client at WebBench client and controller. We performed the
following steps to set up the system:

Right-click My Computer, and select Properties.

Click the Computer Name tab.

Click Change.

Select Domain in the member of section, and type the domain vcon . com into the text box.

In the pop-up window, enter administrator for user name, password for password, and click OK.
At the Welcome to the domain screen, click OK.

When the warning that you must restart dialog appears, click OK.

Click OK to close the System Properties window.

Click Yes to the pop-up message to restart the computer.

. Login to the domain by using administrator and password.
. Install Microsoft Outlook 2003 with the default settings. (Outlook 2003 doesn’t require any configuration.)
. Install LoadSim 2003 by double-clicking the loadsim.msi installation file. Accept all defaults.
. Open LoadSim 2003, and make sure no error messages appear.

. Copy c:\Program Files\LoadSim\Islog.exe file to a floppy disk or USB thumb drive. You will need this file

during the vConsolidate controller installation.

Conflgurlng LoadSim 2003

14.
15.
16.
17.
18.

Start LoadSim by clicking Start Menu->All Programs—->Exchange LoadSim—>LoadSim 2003.
From the LoadSim menu bar, select Configuration->Topology Properties.

Click the Servers tab.

In the left pane, click the + next to the name of this server.

In the left pane, select the First Storage Group.

In the right pane, set the number of users to 500.

Select the Security and Credentials tab.

Leave the Credentials choice set to Login to users using the account LoadSim is running on.
In the password portion of the tab, enter the password Passwordil, and click OK.

. From the LoadSim menu bar, select Configuration-> Test Properties, and click Add.
. Click Customize Tasks.

. Select the Initialization tab.

. Enter the following settings:

e Number of messages in Inbox: 150

Number of messages in Deleted items: 1

Number of new folders: 2

Messages per new folder: 100

Number of Smart Folders: 3

Number of Rules in Inbox: 5

Initialize Free/Busy Information: Leave it unselected

Number of appointments: 25

Number of contacts: 64

Cllck OK.

In the Test Properties window, change the run time to 2 hours, and click OK.
From the LoadSim menu bar, choose File->Save As.

Save a backup copy of the simulation file as C:\loadsim.sim.

From the LoadSim menu bar, select Run->Create Topology, and wait until the Creating Users and
Creating DLs tasks complete.
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19.
20.

21.

22.
23.

From the LoadSim menu bar, select Run—>Initialize Test.

When a dialog box appears with the question Do you want to initialize Public Folders from this client
machine?, click Yes.

The run is complete when the bottom left corner of the LoadSim window shows Status: Idle. This task
typically takes about 2 to 3 hours to complete.

From the LoadSim menu bar, select Run—>Run Simulation.

The run is complete when the bottom left corner of the LoadSim window shows Status: Idle. This task
typically takes a little over 2 hours to complete.

Back up the mail and database server files

For test consistency we made backup copies of the Mail and Database Server’'s database files. Once you've set
up LoadSim and created its initial mail database, you need to back up that database so you can have clean
copies for each test. Do the same on the database server. We created a folder called backup on the C: drive of
each VM for the backup files. For testing we used scripts to perform a restore before each run so we started at
the same point for each run. An example of the scripts we used for an 8-CSU restore follows:

Restore 8 CSU script
Set CSU COUNT=8

Set SHUTDOWN CMD=-r

Set PREPEXCHANGE=restore reboot exchange.bat
Set PREPSYSBENCH=restore_ sysbench.bat

Set DBSERVER WAIT=90

Set /A I=1
pause
CSU_LOOP

copy $PREPSYSBENCHS% \\DBServer$I%\C$\servicecontent.bat /y
copy %$PREPEXCHANGE% \\192.168.%I%1.115\CS\servicecontent.bat /vy

shutdown %SHUTDOWN CMD% -f -t
shutdown %SHUTDOWN CMD% -f -t

DBSERVER WAIT% -m \\DBServer$I%
-m \\JavaServer$%$I1$%

5
shutdown $SHUTDOWN CMD% -f -t 5 -m \\IdleServer%I%
5

shutdown %SHUTDOWN CMD% -f -t

shutdown %SHUTDOWN CMD% -f -t

-m \\192.168.%I%1.110

(2}

-m \\192.168.%I%1.215

Set /A I+=1
if $I% LEQ $CSU_COUNT$ GOTO _CSU_LOOP

pause

Restore SysBench script
net stop mssglserver

sleep

1

del /F /Q "C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data\sbtest*"

sleep

1

copy /Y /V C:\sysbench backup\sbtest* "C:\Program Files\Microsoft SQL
Server\MSSQL.1\MSSQL\Data\"

sleep

1

net start mssqglserver

Restore Exchange script
dismount.vbs

sleep

5

del /F /Q E:\publ.*
del /F /Q E:\privl.~*
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copy /Y "E:\backup\publ.*" E:\
copy /Y "E:\backup\privli.*" E:\

mount .vbs

REM - While we are waiting for the main Exchange services to stop,
REM - Some peripheral services will be closed in the background.
start /min net stop MSExchangeMGMT /yes

start /min net stop RESvc /yes

start /min net stop POP3Svc /yes

start /min net stop IMAP4Svc /yes

start /min net stop NntpSvc /yes

start /min net stop SMTPSVC /yes

REM - Stop Exchange main services before shutdown to avoid timing conflicts.

net stop MSExchangeES /yes
net stop MSExchangeIS /yes
net stop MSExchangeMTA /yes
net stop MSExchangeSA /yes

REM - Well, why not stop other services in the background just for fun?
REM - Stopping IISADMIN will stop other dependant services like W3SVC, and
HTTPFilter (SSL).

start /min net stop IISADMIN /yes

start /min net stop MSSEARCH /yes

start /min net stop Spooler /yes

shutdown -r -f -t 15

vConsolidate controller
You use a separate physical system, the controller, to manage the vConsolidate workload. We used a single
section both for this function and as the controller system for the first CSU’s WebBench benchmark. This
controller offers a graphical user interface (GUI) to start and stop the vConsolidate workload. After the workload
finishes, the controller copies the independent benchmark result files from all the VMs and combines their results
into a single file, results.txt. We performed the following steps to set up this vConsolidate controller:

1. With Windows explore, create a C:\vCON directory.

2. Copy all files from the \vCON _ framework\controller directory of the vConsolidate package to c:\vCON.

3. Copy the Islog.exe file the mail client installation created to c:\vCON.

The vCON directory contains a Profiles sub-directory. The Profiles directory contains four sample profiles,
1CSU.profile, 2CSU.profile, 3CSU.profile, 4CSU.profile and a blank template, Profile.template. vConsolidate uses
these files to identify the number and name of the VMs a test should include. An example 1CSU.profile contains

the following:

<Profile>

<Name>1 CSU</Name>
<CSUNum>1</CSUNum>

<Servers>

<DB>

<0S>Win</0S>
<Host>DBServerl</Host>

</DB>

<Loadsim>
<Host>192.168.202.110</Host>
</Loadsim>

<Java>

<0S>Win</0S>
<Host>JavaServerl</Host>
</Java>

<WebBench>
<Host>192.168.202.210</Host>
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</WebBench>
</Servers>
</Profile>

Running vConsolidate

To run vConsolidate and get consistent results, you must first prepare the VMs with clean copies of the test data.
We outline below the process for getting ready to run the workload. We then explain how to start and stop the
workload. Finally, we detail how to find its results.

Preparing the vConsolidate run
Prior to running vConsolidate we restore the backup Mail and Database Server backup files, so we can ensure
consistent results.

Verify connectivity and setting profiles

1.
2.

Open a command prompt by selecting Start>Run, type cmd, and click OK.

Type the following commands at command prompt:

e net use \\loadsim client IP Address\c$

e net use \\JavaServerl\c$

e net use \\DBServerl\c$

e net use \\WebBench Controller IP Address\c$

Verify that the vConsolidate controller can read and write remote files to all VMs with the following
commands:

With Windows Explorer, create an empty file, dummy:.txt.

copy dummy.txt \\loadsim client IP Address\c$

copy dummy.txt \\JavaServerl\cs$

copy dummy.txt \\DBServerl\c$

e copy dummy.txt \\WebBench Controller IP Address\c$

Modify the profile file by entering the VM name or IP address appropriate to each VM in the test. For the
one-CSU test, enter four server names or IP addresses; for the two-CSU test, enter eight.

Starting and stopping vConsolidate

1. Shut down all VMs by selecting Start->Shutdown and then selecting Shutdown from the window.
2. In the left pane of the Virtual Infrastructure Client window, highlight localhost.localdomain.
3. Select the Summary tab in the right pane.
4. Click Reboot under the Commands section.
5. While the server is rebooting, reboot all clients in the test bed.
6. After the Hyper-V Server has rebooted, login using the Virtual Infrastructure Client, and start all VMs in
the test.
7. Once the VMs are up, log the LoadSim client(s) into the appropriate domain(s).
8. Double-click Daemon.exe manually on the following VMs and systems:
a. DataServer1
b. JavaServer1
c. LoadSim client
d. WebBench controller
9. Start the WebBench Controller application on the WebBench controller system by selecting Start>All
Programs—>PC Magazine Benchmarks.
10. In the WebBench Controller application, choose the Clients menu, and click Start Log In.
11. Double-click the WebBench 5.0 client shortcut on all the WebBench test client desktops.
12. Once all the client machines are logged into WebBench, click OK.
13. At the Would you like to add a test suite? dialog, click Yes.
14. In the Select a test suite window, choose vConsolidate.tst, and click OK.
15. When the Would you like to start executing the test suites? window appears, do NOT click Yes or No. The
vConsolidate controller application will handle that task that at the start of the test.
16. Double-click c:\vCON\vconsolidate.exe.
17. Select the profile name you want to run.
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18. Wait 10 minutes to allow all virtual machines and Hyper-V Server to load all processes and become
completely idle.

19. Click start.

20. The vConsolidate controller software will immediately start the LoadSim application. LoadSim will take
about 60 to 80 seconds to log 500 users onto the Exchange Server. The remaining benchmarks will start
once all the LoadSim users have logged in.

21. After about 30 minutes, vConsolidate controller application will stop the benchmark and collect their
results.

Locating and interpreting the results file
vConsolidate places all result data in the following location:

c:\vCON\vCONMM-dd-hh-mm

where MM is the month, dd is the day, hh is the hour, and mm is the minute of the test. The file result.txt in that
directory summarizes all the results. It contains the following information:

Java transaction score

Database transaction score

Mail transaction score

Web server throughput

Start and stop times

Figure 9 shows an example results.txt file for a test with one CSU. We have labeled each score with a brief
description. See the Test results section for more information on how we used these individual results to calculate
each server’s overall score on the workload.

B result.txt [ZI EI g|

File Edit Format Wiew Help

ul "
JET sum—32354673 1 Java Score
DB Trans Number=231093— Database Score

’—LuadSim Score
—————————— TEMP. TXT
weighted avg 60 14015 122 215 132 [} <--"score"

—————————— VCONSOLIDATE. RLG

A,4_client, 8,/1706. 959, 6908069, 563, 0,
A,4_client, 8,[1622.183, 6576748. 875, 0,
A,4_client, 8,/1558. 335, 6241389. 500, 0,

11:44:39.921
12:15:44.140

WebBench Score

Figure 9: Example of vConsolidate results file.

Power measurement procedure

To record each server’s power consumption during each test, we used an Extech Instruments (www.extech.com)
380803 Power Analyzer / Datalogger. We connected the power cord from the server under test to the Power
Analyzer’s output load power outlet. We then plugged the power cord from the Power Analyzer’s input voltage
connection into a power outlet.

We used the Power Analyzer's Data Acquisition Software (version 2.11) to capture all recordings. We installed the
software on a separate Intel-processor-based PC, which we connected to the Power Analyzer via an RS-232
cable. We captured power consumption at one-second intervals.

To gauge the idle power usage, we recorded the power usage while each server was running the operating
system but otherwise idle. To ensure the server was idle, we allowed the server to boot and power on all virtual
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machines. Once the virtual machines had booted, we waited for 15 minutes to allow everything to stabilize. Then
we recorded two minutes of idle power (in watts) at one-second intervals.

To compute the average power usage, we averaged the power usage during the time the server was producing
its peak performance results. We call this time the power measurement interval. See Figure 5 (idle and average
peak power) for the results of these measurements.
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Appendix A — Test system configuration information
Figure 10 provides detailed configuration information about each of the test server systems, which we list in

alphabetical order by processor name.

Servers

Intel Xeon processor X7460-
based server

Intel Xeon processor X7350-
based server

General processor setup

Number of processor packages 4 4

Number of cores per processor 6 4

package

Number of hardware threads per core | 1 1

System Power Management Policy Always on Always on
CPU

Vendor Intel Intel

Name Intel Xeon processor X7460 Intel Xeon processor X7350
Stepping 1 B

Socket type Socket P (478) Socket P (478)
Core frequency 2.66 GHz 2.93 GHz
Front-side bus frequency 1,066 MHz 1,066 MHz

L1 cache

32 KB + 32 KB (per core)

32 KB + 32 KB (per core)

3 x 3 MB (each 3 MB shared by 2

2 x4 MB (each 4 MBs shared by

BIOS name and version

SFC4UR.868.01.00.0024.061320
082253

L2 cache

cores) 2 cores)
L3 cache 16 MB N/A
Platform
Vendor and model number Intel Fox Cove Intel Fox Cove
Motherboard model number S7000FC4UR S7000FC4UR
Motherboard chipset Intel ID3600 Intel ID3600
Motherboard revision number 01 01

Intel Intel

SFC4UR.868.01.00.0024.061320
082253

BIOS settings

Enabled Intel Virtualization
Technology

Enabled Intel Virtualization
Technology

Chipset INF driver

Intel 8.4.0.1015

Intel 8.4.0.1015

Memory module(s)

Vendor and model number

Kingston KVR667D2D4F5/4GlI

Kingston KVR667D2D4F5/4GlI

Type PC2-5300 FB-DDR2 PC2-5300 FB-DDR2
Speed 667 MHz 667 MHz

Spegd in the system currently 667 MHz 667 MHz

running @

Timing/Latency (tCL-tRCD-iRP-

tRASMIn) 5-5-5-15 5-5-5-15

Size 64 GB 64 GB

Number of RAM modules 16 x 4GB 16 x 4GB

Chip organization Double-sided Double-sided

Hard drive

Vendor and model number Seagate ST973401SS Seagate ST973401SS
Number of disks in system 2 2

Size 73.4 GB 73.4 GB

Buffer size 8 MB 8 MB

RPM 10,000 10,000
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Intel Xeon processor X7460-

Intel Xeon processor X7350-

SEETE based server based server

Type SAS SAS

Controller Integrated Intel RAID Controller Integrated Intel RAID Controller
SROMBSASFC SROMBSASFC

Driver LSI 2.13.0.64 LSI 2.13.0.64

Operating system

Microsoft Windows Server 2008

Microsoft Windows Server 2008

Name Enterprise x64 Edition Enterprise x64 Edition
Build number 6001 6001

Service Pack Service Pack 1 Service Pack 1

File system NTFS NTFS

Kernel ACPI x64-based PC ACPI x64-based PC
Language English English

Microsoft DirectX version 10 10

Graphics

Vendor and model number ATI ES1000 ATI ES1000

Chipset ES1000 ES1000

BIOS version BK-ATI VER008.005.031.000 BK-ATI VER008.005.031.000
Type Integrated Integrated

Memory size 32 MB 32 MB

Resolution 1,024 x 768 1,024 x 768

Network card/subsystem

Vendor and model number

Intel PRO/1000 EB

Intel PRO/1000 EB

Type Integrated Integrated

Driver version Intel 1.2.79.9 Intel 1.2.79.9

Vendor and model number Intel PRO/1000 PT Intel PRO/1000 PT
Type PCle PCle

Driver version Intel 10.2.28.0 Intel 10.2.28.0

Optical drive

Vendor and model nhumber | Optiarc DVD-ROM DDU810A | Optiarc DVD-ROM DDU810A
USB ports

Number 5 5

Type USB 2.0 USB 2.0

Power supplies

Total number 2 2

Wattage of each 1,570W 1,570W

Cooling fans

Total number 8 8

Dimensions 4x80mm+4x120 mm 4x80mm+4x120 mm
Voltage 12V 12V

Amps 4x176 A+4x3.3A 4x176 A+4x3.3A

Figure 10: Detailed system configuration information for the test servers.
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Appendix B — Complete test and power results

Figures 11 and 12 show the complete results for all three runs on the two test systems.

Intel Xeon processor X7460

| Score | CPU utilization | Idle power | Average power

1CSU

Run 1 1.19 22 534.13 606.41

Run 2 1.23 22 532.80 603.64

Run 3 1.22 22 536.38 606.73
2 CSUs

Run 1 2.33 42 532.27 662.59

Run 2 2.33 43 531.68 663.83

Run 3 2.32 42 532.02 664.06
3 CSUs

Run 1 3.26 65 536.93 719.03

Run 2 3.26 65 533.15 715.86

Run 3 3.30 65 531.45 715.54
4 CSUs

Run 1 3.92 86 537.52 770.09

Run 2 3.92 85 568.33 794.08

Run 3 3.95 86 535.99 754.53
5 CSUs

Run 1 4.20 93 533.06 756.23

Run 2 4.23 94 534.18 754.68

Run 3 4.26 93 532.89 752.03
6 CSUs

Run 1 4.33 97 534.18 757.49

Run 2 4.24 97 534.77 757.91

Run 3 4.37 97 533.18 755.18
7 CSUs

Run 1 4.35 98 536.42 757.85

Run 2 4.34 98 537.30 758.29

Run 3 3.91 98 537.25 758.17
8 CSUs

Run 1 4.34 99 536.89 757.01

Run 2 4.31 99 537.47 757.03

Run 3 4.34 99 537.45 756.79

Figure 11: Complete results for all three runs on the Intel Xeon processor X7460 server.
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Intel Xeon processor X7350

| Score | CPU utilization | Idle power | Average power

1CSU

Run 1 33 547.72 683.32

Run 2 33 546.21 679.45

Run 3 33 544.13 676.94
2 CSUs

Run 1 2.22 65 543.13 784.24

Run 2 2.23 65 542.63 785.49

Run 3 2.23 65 547.43 793.12
3 CSUs

Run 1 2.86 89 538.52 820.38

Run 2 2.82 89 538.78 822.12

Run 3 2.85 89 546.18 833.54
4 CSUs

Run 1 3.03 96 543.11 830.11

Run 2 3.02 96 542.03 827.24

Run 3 3.05 96 539.63 826.62
5 CSUs

Run 1 3.12 97 547.32 840.38

Run 2 3.10 98 539.38 824.60

Run 3 3.07 98 539.97 823.53
6 CSUs

Run 1 3.12 99 524.50 802.92

Run 2 3.10 99 524.48 801.04

Run 3 3.09 99 525.82 805.72
7 CSUs

Run 1 3.04 100 525.05 799.08

Run 2 3.03 100 525.97 799.59

Run 3 2.73 100 528.53 798.60

Figure 12: Complete results for all three runs on the Intel Xeon processor X7350 server.
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