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Performance of the Intel® Modular Server on
simultaneous email, Web server, Java, and
database workloads

Executive summary

Intel® Corporation (Intel) commissioned Principled
Technologies (PT) to measure the system performance of
the Intel Modular Server built on Intel Multi-Flex
Technology while running multiple workloads individually
and simultaneously on the Server Compute Modules. The
goal of the study was to determine how much the
performance of each Server Compute Module degraded
from when each module was running alone to when all the

modules were running at the same time.

KEY FINDING

® The Intel Modular Server delivered
comparable performance across all Server
Compute Modules whether they were all
running at the same time or each was running
its test alone; the performance difference was
less than 3 percent.

Figure 1 shows the Intel Modular Server used for testing. The housing contains six Server Compute Modules, an
onboard SAN, which contains 14 SAS disk drives, two Ethernet Switch Modules, and a Management Module.
Each Server Compute Module is an independent
dual-processor server. The Server Compute
Modules share the SAN and Ethernet according to
the configuration set up by the administrator. The
configuration that PT used is detailed in the Test

Figure 1: Picture of Intel Modular Server used for testing.

methodology s

ection.

We ran benchmarks that simulated four types of
typical business server workloads with four industry-

standard tools:

Workload
Web
email
Java
Database

Tool

WebBench
LoadSim

SPECjbb2005

SysBench

The Workload section provides more information on
each of these benchmarks.

Figure 2 presents two different median results for each Server Compute Module:
e Single-benchmark result. The score when one Server Compute Module runs a benchmark while the
other five Server Compute Modules are powered off.

e Multiple-benchmark result. The score when all six Server Compute Modules are powered on and
running benchmarks simultaneously.

Single- Multiple- Difference
Benchmark benchmark benchmark

results results [PEEEmEETE)
Server Compute Module 1 LoadSim 150 milliseconds 154 milliseconds 2.67
Server Compute Module 2 WebBench 49,590.1 rps 49,963.7 rps 0.75
Server Compute Module 3 SPECjbb2005 215,609 bops 214,623 bops 0.46
Server Compute Module 4 SPECjbb2005 214,999 bops 215,248 bops 0.12
Server Compute Module 5 SysBench 792.4 tps 792.8 tps 0.05
Server Compute Module 6 SysBench 795.6 tps 796.1 tps 0.06

Figure 2: Single and multiple benchmark results for all Server Compute Modules we tested.




As Figure 2 shows, the difference between the single benchmark results and the multiple benchmarks results for
the Server Compute Modules is less than 3 percent; in five of the six cases, the difference is less than 1 percent.
This indicates almost no performance decline when all servers are running simultaneously.

Workload

LoadSim

Microsoft Exchange Server 2003 Load Simulator is a benchmark that measures a server’s performance handling
email. LoadSim uses the MAPI Messaging Benchmark 3 (MMB-3) to simulate MAPI email clients. The simulated
clients issue requests to an Exchange server to generate an email load. LoadSim measures both the server’s
response time and the number of messages it delivers. LoadSim is available for free download from
www.microsoft.com/downloads/details.aspx?Familyld=92EB2EDC-3433-47CA-A5F 8-
0483C7DDEA85&displaylang=en.

SPECjbb2005

SPECjbb2005 is an industry-standard benchmark from the Standard Performance Evaluation Corp. (SPEC) that
measures a server’s Java performance. SPEC modeled SPECjbb2005 on the three-tier client/server architecture,
with the middle layer as the primary focus. According to SPEC, “Random input selection represents the first (user)
tier. SPECjbb2005 fully implements the middle tier business logic. The third tier is represented by tables of
objects, implemented by Java Collections, rather than a separate database.” For more information about
SPECjbb2005, see www.spec.org/jbb2005/docs/UserGuide.html.

SysBench

The developers at SourceForge.net (www.sourceforge.net) created SysBench to test various aspects of the
performance of servers running database systems. The benchmark’s original target was the MySQL database
system (see www.mysql.com). Intel created a version of SysBench 0.4.0 that would work with Microsoft SQL
Server 2005 Enterprise Edition (www.microsoft.com/sql/editions/enterprise/default.mspx). We ran that version in
our test. SysBench created a 100,000-row SQL database and executed a batch of online transaction processing
(OLTP) transactions against that data.

WebBench

WebBench 5.0 (128-bit US version) is an industry-standard benchmark for Web server software and hardware. It
uses PC clients to send Web requests to a server under test. It generates performance results by incrementally
increasing the number of clients making HTTP 1.0 GET requests to the Web server; the result is a curve showing
the server’s performance under increasing load. The peak of that curve represents the peak throughput of the
server. WebBench reports both the total number of requests per second the server handled and the server’s total
throughput in bytes per second. To be certain that we found the true peak performance in our testing, we verified
that the server’s processor utilization reached or was extremely close to 100 percent during the test.

Test results

For testing, we staggered the starting times of the benchmarks to allow the Intel Modular Server to ramp up
slowly. We began the benchmarks in the following order: WebBench, Microsoft LoadSim, SysBench, and
SPECjbb2005. Figure 3 shows a timeline for the benchmark runs. To obtain the final results, we removed the first
and last parts of each benchmark run, except SPECjbb2005, and computed the results based on the 22 minutes
of peak performance during the SPECjbb2005 run. All other benchmarks ran longer so we could guarantee each
benchmark was at maximum performance during this 22-minute period.
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Multiple benchmark timeline
1.5 hours total time

WebBench 00:53-01:15
00:00 01:30

LoadSim 00:53-01:15
00:15 01:30

SysBench 00:53 - 01:15
00:30 01:30

SPECjbb2005 00:53 - 01:15

00:51 01:15

Figure 3: The timeline we followed when starting the benchmarks for the multiple-benchmark runs on
Server Compute Modules. The shaded areas from 00:53 to 01:15 represent the period that we
measured performance.

LoadSim results

LoadSim results show the response time each for each server, the time in milliseconds it took to complete a
request. Since the server’s goal is to handle as many requests as possible, lower scores, which show a server
able to handle more requests in a given time, are better. Generally the most important point is the median 95th
percentile, which means 95 percent of the time the server handled request at that level.

Figure 4 shows the median LoadSim single and multiple benchmark results for Server Compute Module 1. For
testing we used 500 Microsoft Exchange mailboxes.

Server Compute Module 1
Single-benchmark results Multiple-benchmark results
Median 50th percentile 106 106
Median 95th percentile 150 154
Median mean 104 104

Figure 4: LoadSim results in milliseconds for Server Compute Module 1. Lower numbers are better.

SPECjbb2005 results

Figure 5 shows the median SPECjbb2005 results for all three servers. In each test, we ran four JVMs at the same
time, a common practice on servers with many processors. To compute the overall score for the system,
SPECjbb2005 sums the scores of all the JVMs. SPECjbb2005 computes the score of each JVM by taking the
average of the results during mixes when the server is running at peak performance. (In SPEC’s terms, these
results are from “compliant” runs, which means we can disclose them publicly though we are not posting them on
the SPEC Web site with all the files SPEC requires. We do present here all the data necessary to reproduce
these results.)
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Server Compute Module 3

Server Compute Module 4

Single-benchmark

Multiple-benchmark

Single-benchmark

Multiple-benchmark

results results results results
JVM 1 108,170 107,441 107,688 107,901
JVM 2 107,439 107,182 107,311 107,347
Total score 215,609 214,623 214,999 215,248

Figure 5: SPECjbb2005 results for each server by JVM in bops. Higher numbers are better.

Figure 6 shows the median results by warehouse for the Server Compute Module 3.

Server Compute Module 3
Single-benchmark results | Multiple-benchmark results
Warehouse JVM 1

1 28,326 28,176

2 66,828 66,073

3 90,917 90,285

4 109,617 108,896

5 108,960 108,018

6 108,285 107,937

7 107,241 106,488

8 106,747 105,866
Score 108,170 107,441

Warehouse JVM 2

1 28,623 27,777

2 61,418 61,848

3 89,879 89,690

4 109,033 108,704

5 108,229 107,951

6 107,693 107,366

7 106,480 106,412

8 105,758 105,476
Score 107,439 107,182
Total Score 215,609 214,623

Figure 6: SPECjbb2005 results for the Server Compute Module 3. Higher numbers are better.
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Figure 7 shows the median results by warehouse for Server Compute Module 4 (Single and Multiple
benchmarks).

Server Compute Module 4
Single-benchmark results | Multiple-benchmark results
Warehouse JVM 1
1 28,207 28,047
2 67,170 61,747
3 90,371 90,348
4 108,886 109,563
5 108,428 108,914
6 108,128 108,301
7 106,813 106,957
8 106,186 105,767
Score 107,688 107,901
Warehouse JVM 2
1 28,996 29,319
2 65,004 66,399
3 90,192 90,050
4 108,654 108,664
5 108,135 108,104
6 107,712 107,657
7 106,406 106,603
8 105,650 105,709
Score 107,311 107,347
Total Score 214,999 215,248

Figure 7: SPECjbb2005 results for the Server Compute Module 4. Higher numbers are better.

WebBench results

We ran WebBench'’s default ecommerce API test suite, which generates both secure and non-secure static and
dynamic HTTP 1.0 GET requests. While running the ecommerce suite, the clients must negotiate to a secure
Web server port using the Secure Socket Layer (SSL) protocol. A default WebBench test suite incrementally
increases the number of clients making the HTTP 1.0 GET requests to the Web server. As the workload
increases the number of clients, the Web server’s processor utilization also increases, until the processor in the
Web server is saturated with work. Each workload point with a fixed number of clients is a WebBench “mix.” The
ecommerce API test suite begins with a mix that involves one client; the next mix has four clients, and each
subsequent mix increases the number of clients by four to a total of 60 clients. We modified the test suite so it
would run 60 clients and seven engines per client for the entire test, except for the first mix. This allowed us to
keep a constant Web load on the server. We performed the standard 16 mixes for testing.

A WebBench run reports the total requests per second a server can perform and the total throughput, in bytes per
second, that the server delivered. WebBench reports these results for each mix. To obtain the results below, we
averaged the requests per second and throughput from the mixes that ran during the middle 22 minutes of the
benchmark run.

Figure 8 shows the WebBench average results in requests per second and in throughput (bytes per second) for
the server compute modules. Each result below is the median of three runs.
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Server Compute Module 2
Single-benchmark Multiple-benchmark
results results
Requests per second 49,590.1 49,963.7
Throughput (bytes per second) 200,968,429.8 202,509,950.2

Figure 8: WebBench results for each server compute module. Higher numbers are better.

SysBench results

For testing, we created a script so each system would perform as many transactions as possible in a given time.
The script processed 10,000 transactions as quickly as possible and then started over again. The output shows
the completion time in seconds for each group of 10,000 transactions. We calculated the transactions per second
by using the following formula:

total transactions = transactions per second

time in seconds

Figure 9 shows the median SysBench single and multiple benchmark results for Server Compute Module 3 and 4.
Worth noting, the results are for the 22 minutes as outlined in the figure 2 timeline, so the completion time is the
same for all systems.

Server Compute Module 5 Server Compute Module 6
Single-benchmark Multiple- Single-benchmark Multiple-
results benchmark results results benchmark results

Completion time

(seconds) 1320 1320 1320 1320
Transactions

completed 1,045,922 1,046,458 1,050,186 1,050,816
Transactions

per second 792.4 792.8 796.6 796.1

Figure 9: SysBench results for each server compute module. Higher numbers are better.
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Test methodology

Before we could install an operating system, we had to configure the storage. Figure 10 shows the disk layout by
storage pool. The SAS PHYS refers to the SAS channel the Server Computer Module used for communication
with the disk subsystem. For each SAS channel we tried to balance workloads with heavy disk traffic with those
with lighter disk utilization.

Storage Total disk Server Compute Module SAS
pool Number of drives space # Configuration Size PHYS
A 3 203.96 GB 5 SysBenF:h 10S 45 GB 2

1 LoadSim logs 155 GB 1
6 SysBench 2 OS 45 GB 3
B 2 135.97 GB 1 LoadSim OS 45 GB 1
2 WebBench OS 45 GB 2
c 2 135.9 GB 3 SPECjbb2005 1 OS 45 GB 3
5 SysBench 1 Data 90 GB 2
D 5 135.97 GB 4 SPECjbb2005 2 OS 45 GB 1
6 SysBench 2 Data 90 GB 3
E S 339.93 GB 1 LoadSim Data 335 GB 1

Figure 10: LoadSim results for each server compute module. Lower numbers are better.

To set up the disk, we used the Modular Server Control Web interface software, which the Intel Modular Server
included. After logging in, we used the following steps:

From the module control, click Storage from the left navigation menu.
Click “Create Storage Pool”.

Select the drives you want to use.

Give the pool a name.

Select the newly created storage pool from the storage dashboard.
Click “Create Virtual Drive”.

Enter a name for the drive.

Select a RAID level (RAID O for all our testing).

. Enter the size in gigabytes (GB).

10. Select the Server Compute Module to which you want to map the drive.
11. Select the drive number you want the drive to appear as on the server.
12. You have successfully created and assigned a new virtual drive to a server.

N>R~ WLN =

Figure 11 illustrates the storage layout the Modular Server Control console reports.
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Figure 11: Intel Modular Server disk layout for testing.
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Server installation

We configured each Server Compute Module differently depending on its task. For all Server Compute Modules
except the one running email, we began by installing a fresh copy of Microsoft Windows Server 2003 R2,
Enterprise x64 Edition Service Pack 2. On the email Server Compute Module we installed a fresh copy of
Microsoft Windows Server 2003 R2, Enterprise Edition Service Pack 2 due to the 32-bit Exchange Server
requirement of the test. We followed this process for each installation:

Assign a computer name of “Server”.

For the licensing mode, use the default setting of five concurrent connections.
Enter a password for the administrator log on.

Select Eastern Time Zone.

Use typical settings for the Network installation.

Use “Testbed” for the workgroup.

oA ON =

We applied the following updates from the Microsoft Windows Update site to the 64-bit (x64) installations:

Windows Internet Explorer 7 for Windows Server 2003 x64 Edition and Windows XP x64 Edition
Security Update for Outlook Express for Windows Server 2003 x64 Edition (KB941202)
Cumulative Security Update for Internet Explorer 6 for Windows Server 2003 x64 Edition (KB939653)
Security Update for Windows Server 2003 x64 Edition (KB933729)

Windows Malicious Software Removal Tool x64 - October 2007 (KB890830)

Security Update for Windows Server 2003 x64 Edition (KB936021)

Update for Windows Server 2003 x64 Edition (KB933360)

Security Update for Windows Server 2003 x64 Edition (KB938127)

Security Update for Windows Server 2003 x64 Edition (KB921503)

Security Update for Windows Server 2003 x64 Edition (KB936782)

Update for Windows Server 2003 x64 Edition (KB932596)

Security Update for Windows Server 2003 x64 Edition (KB926122)

Security Update for Windows Media Player 6.4 (KB925398)

Update for Windows Server 2003 x64 Edition (KB936357)

Cumulative Security Update for Outlook Express for Windows Server 2003 x64 Edition (KB929123)
Security Update for Windows Server 2003 x64 Edition (KB935839)

Security Update for Windows Server 2003 x64 Edition (KB935840)

Security Update for Windows Server 2003 x64 Edition (KB924667)

Update for Windows Server 2003 x64 Edition (KB927891)

Security Update for Windows Server 2003 x64 Edition (KB932168)

Security Update for Windows Server 2003 x64 Edition (KB930178)

Security Update for Windows Server 2003 x64 Edition (KB925902)

We applied the following updates from the Microsoft Windows Update site to the 32-bit installation:

Windows Internet Explorer 7 for Windows Server 2003

Windows Malicious Software Removal Tool - October 2007 (KB890830)

Cumulative Security Update for Internet Explorer 6 for Windows Server 2003 (KB939653)
Security Update for Outlook Express for Windows Server 2003 (KB941202)

Security Update for Windows Server 2003 (KB933729)

Security Update for Microsoft .NET Framework, Version 1.1 Service Pack 1 (KB933854)
Security Update for Windows Server 2003 (KB936021)

Update for Windows Server 2003 (KB933360)

Security Update for Windows Server 2003 (KB938127)

Security Update for Windows Server 2003 (KB921503)

Security Update for Windows Server 2003 (KB936782)

Security Update for Windows Server 2003 (KB926122)
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Security Update for Windows Media Player 6.4 (KB925398)
Update for Windows Server 2003 (KB936357)

Security Update for Windows Server 2003 (KB935839)
Security Update for Windows Server 2003 (KB935840)
Cumulative Security Update for Outlook Express for Windows Server 2003 (KB929123)
Security Update for Windows Server 2003 (KB924667)
Update for Windows Server 2003 (KB927891)

Security Update for Windows Server 2003 (KB932168)
Security Update for Windows Server 2003 (KB931784)
Security Update for Windows Server 2003 (KB930178)
Security Update for Windows Server 2003 (KB925902)

After installing the operating system, we configured each Server Compute Module depending on the setup
requirements. We configured the six Server Compute Modules as follows:

Server Compute Module 1: Mail server
Server Compute Module 2: Web server
Server Compute Module 3: Java server
Server Compute Module 4: Java server
Server Compute Module 5: SQL server
Server Compute Module 6: SQL server

Installing and configuring the mail server
To set up this Server Compute Module we had to install several additional software components. The following
subsections detail the necessary installation processes.

Installing the domain controller

©CoNooOA~WON =

15.

16.
17.
18.
19.
20.

Select Start->Administrative Tools->Manage Your Server.

Click Add or remove a role.

At the Configure Your Server window, click Next.

At the Configuration and Options screen, select Custom Configuration, and click Next.

At the Server Role screen, select Domain Controller, and click Next.

At the Summary of Selections screen, click Next.

At the Welcome pop-up window, click Next.

At the Operating System Compatibility screen, click Next.

For the Domain Controller Type, leave the default option (Domain controller for a new domain), and click
Next.

. At the Create New Domain screen, leave the default (Domain in a new forest), and click Next.

. At the Install or Configure DNS window, select No, and click Next.

. At the New Domain Name screen, type a domain name (loadsim. com), and click Next.

. At the NetBIOS Domain Name screen, type a NETBIOS domain name (1oadsim), and click Next.

. Click Next through the following screens to accept the default options: Database and Log Folders, Shared

System Volume, and Permissions.

At the Directory Services Restore Mode Administrative Password screen, enter a password (password),
and click Next.

When the installation software prompts you to do so, insert the OS CD, and click OK.

At the Completing the Active Directory Installation Wizard screen, click Finish.

When the system prompts you to reboot the server, click Restart Now.

After the server reboots, log in to the system.

At the This Server is Now a Domain Controller window, click Finish.
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Installing Internet Information Services 6.0

©CoNooOA~WON =

Select Start->Control Panel->Add or Remove Programs.

Click Add/Remove Windows Components.

Select Application Servers, and click Details.

Click ASP.NET, and make sure a check appears in the check box.

Select Internet Information Services (IIS), and click Details.

Click NNTP Services and SMTP Services, make sure a check appears in both check boxes, and click OK.
Click OK to close the Application Server window.

At the Windows Components Wizard, click Next to begin the installation.

When the system prompts you to do so, insert the OS CD, and click OK.

10 At the Completing the Windows Components Wizard window, click Finish.
11. Close the Add or Remove Programs window.

Installing Exchange Server 2003

1.

Nookr~ON

T Taemeo

Insert the Microsoft Exchange Server 2003 CD. The CD should automatically launch the installation
software.
Choose Exchange Server Enterprise Edition.
Run the Setup application.
Click the Exchange Deployment Tools link.
Click the Deploy the first Exchange 2003 Server link.
Click the New Exchange 2003 Installation link.
Click the Run ForestPrep now link.
a. When the compatibility issue notice appears, click Continue, and check the Don’t display this
message again box.
At the Welcome screen, click Next.
Accept the End User License Agreement, and click Next.
At Component Selection Screen, keep the defaults, and click Next.
Leave the default account information, and click Next.
Installation should start. (This process may take a while to complete.)
When the installation completes, click Finish.
turn to the Exchange Server Deployment Tools screen, and click the Run DomainPrep now link.
At the Welcome screen, click Next.
Accept the End User License Agreement, and click Next.
At Component Selection Screen, keep the defaults, and click Next.
At the insecure domain notice, click OK.
When the installation completes, click Finish.
turn to the Exchange Server Deployment Tools screen, and click Run Setup Now.
At the Welcome screen, click Next.
Accept the End User License Agreement, and click Next.
At the Component Selection screen, the action for Microsoft Exchange should by default be Typical.
(If it is not, use the drop-down box to set it to Typical.)
Click Next.
For the Installation Type, select Create new Exchange Organization, and click Next.
Type 1loadsim as the Organization Name, and click Next.
Accept the Microsoft Exchange Server Licensing Agreement, and click Next.
Review the installation summary, and click Next.
The installation should start. (This process may take a while to complete.)
When the installation completes, click Finish.

cPoPVOLOTEI@T0R0T

10. Close the Exchange Server Deployment Tools window.
11. Install Microsoft Exchange Server 2003 Service Pack 2.

a. Insert the SP2 CD, and double-click setup exe.

b. Accept the default location to extract the file, and click OK.

c. After the extraction finishes, open Windows Explorer, and browse to the update.exe executable.
d. Atthe Welcome screen, click Next.

Principled Technologies, Inc.: Performance of the Intel® Modular Server on 11
simultaneous email, Web server, Java, and database workloads



12.
13.
14.
15.
16.
17.
18.
19.
20.

e. Select | agree to accept the License Agreement, and click Next.

f. At the Component Selection window, leave the default option (Update), and click Next.
g. Verify the installation Summary, and click Next.

h. When the installation completes, click Finish.

Select Start->All Programs—>Microsoft Exchange—> System Manager.

In the left-hand window pane, expand Servers and MailServer so the First Storage Group is visible.
Right-click First Storage Group, and select Properties.

Check the Enable circular logging box.

Click Apply.

Right-click Mailbox Store under First Storage Group, and select Properties.

Select the Database tab.

Next to Maintenance interval, click Customize.

Remove all blue from the boxes so the system will not perform maintenance, and click OK.

Installing and configuring the Web server

Installing Microsoft Internet Information Server

1
2
3
4.
5.
6
7
8
9.
1

0.

Select Start->Administrative Tools->Manage Your Server.

Select Add or remove a role.

At the Configure Your Server window, click Next.

At the Configuration Options screen, select Custom configuration, and click Next.

At the Server Role screen, select Application Server, and click Next.

At the Application Server Options screen, select Enable ASP.NET, and click Next.

At the Summary of Selections screen, click Next.

When the installation software prompts you to do so, insert the Operating System CD, and click OK.
When the installation completes, click Finish.

Close the Manage Your Server window.

Deploying WebBench data
WebBench includes data that must reside on the server and that the Web server must use. We loaded that data
and set the Web server to use it with the following procedure:

1.

o RN

© oo N

Copy the file wbtree.exe from the WebBench CD to the wwwroot directory on the server under test. (The
wbtree.exe file is on the WebBench CD at \wb50\workload).

On the server, execute the wbtree.exe file. This program will copy the WebBench workload to the server.
In the wwwroot folder on the server, create a new folder with the name CGI-BIN.

Copy the file simisapi.dll to the CGI-BIN folder.

Click Start button->Programs->Administrative Tools->Computer Management to open the management
console.

Go to Services and Application->Internet Information Services->Default Web Site>CGI-BIN, right-click to
bring up a menu, and select Properties.

Go to the Directory Tab, and Set Execute Permissions to Scripts and Executables.

When the 1IS WWW Configuration popup window appears, click Yes.

Close the Computer Management window.

Configuring Internet Information Services (lIS)
We configured the Windows Internet Information Services Web server as follows:

agrON =

Open Computer Management.

Go to Services and Application->Internet Information Services.
Right click to bring up a menu. Select Properties.

Click the MIME Types button.

In the MIME Types window, click New.
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21.

22.

In the Extension field, type *.

In the MIME type field, type application/octet-stream, and click OK.

Click OK to exit the MIME Types window.

Click OK to exit the Internet Information Services (1IS) Manager Properties window.

. In the Computer Management window, go to Web Sites->Default Web Site under Internet Information

Services, right-click to bring up a menu, and select Properties.

. Select the Home Directory tab.

. Check the following boxes: Script source access, Read, Write, and Directory browsing.

. Uncheck the following boxes: Log visits and Index this resource.

. In the Execute permissions field, select Scripts and Executables.

. Click Apply.

. Select the Web Site tab.

. Uncheck Enable Logging.

. Click OK to close the Default Web Site Properties window.

. In the Computer Management window, go to the Web Service Extensions item under Internet Information

Services.

. In the right panel, highlight All Unknown ISAPI Extensions and click the Allow button. Acknowledge the

IIS Manager warning that appears by clicking the Yes button.

In the right panel, highlight All Unknown CGI Extensions and click the Allow button. Acknowledge the IS
Manager warning that appears by clicking the Yes button.

Close the Computer Management window.

Installing certificate services
Because WebBench includes tests that involve security, we installed Windows Certificate Services as follows:

Nook~wh =

8.
9.
10.
11.
12.
13.

Click Start->Control Panel->Add/Remove Programs.

Select Add/Remove Windows Components.

Put a check mark by Certificate Services.

Accept the notice that the server’'s name cannot be changed after you install this service.

Press Next.

Select Stand Alone Root CA, and click Next.

On the CA Identifying Information window, enter the server name in the Common name for this CA field,
and click Next.

Leave the default Certificate Database Settings as they are, and click Next.

Click Yes at the prompt asking if you want to enable Active Server Pages (ASP) in IIS.

Click Yes at the prompt that explains that Internet information Services will be temporarily stopped.
Click Next.

Click Finish.

Click Close.

Setting up Internet Explorer
We had to set up Internet Explorer on the server as follows to be able to get the necessary certificates:

aorON=

Click the Internet Explorer icon on the Quick Launch toolbar.
Select the Tools—>Internet Options menu item.

On the Connections tab, click the LAN Settings button.
Check Automatically detect settings, and click OK.

Click OK to exit the Internet Options window.

Requesting the server certificate
We had to set up Internet Explorer on the server as follows to be able to get the necessary certificates:

1.

Open Internet Explorer and enter the following website, http://server/certsrv. This should bring up a page
called Microsoft Certificate Services — server.
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Select Request a Certificate link.
Select Advanced Certificate Request link.
Select the Create and submit a certificate request to this CA link.

aorwN

e Name: Performance
e Company: PT
o Type of certificate needed: Server Authentication Certificate
e Key Options:
o CSP: Microsoft Base Cryptographic Provider v1.0
o Usage: Exchange and Signature — select both
o Key size: 512
o Check Automatic key container name
o Check Store certificate in the local computer certificate store
e Additional Options:
o Hash Algorithm: SHA-1
e Otherwise use default
6. Click Submit.
7. Acknowledge the Potential Scripting Violation by clicking Yes.
8. A page should now appear informing you that there is a Certificate Pending.

Issuing the server certificate
Next we had to issue a server certificate as follows:

Select Start->Programs—>Administrative Tools—> Certification Authority.
Click the server’s name.

Select Pending Requests.

Right-click Pending Requests, select All Tasks, and choose Issue.
Close Certification Authority.

arON=

Installing the server certificate
We then installed the server certificate as follows:

Open Internet Explorer.

Go to the page http://server/certsrv again.

Click the View the status of a pending certificate link.

Click the Server Authentication Certificate link.

Click the Install this Certificate link.

Acknowledge the Potential Scripting Violation warning by clicking OK.
A message will note that a certificate has been successfully installed.
Close Internet Explorer.

N>R~ ON =

Setting IIS to use the server certificate
We then set IS to use the server certificate as follows:

Fill out the appropriate |dentifying Information details on the Advanced Certificate Request.

1. Click Start>Programs->Administrative Tools->Computer Management to open the management console.
2. Select Services and Applications—>Internet Information Services>Web Sites.

3. Right-click the Default Web site, and select Properties.

4. Select the Directory Security tab, and click Server Certificate.

5. When the Welcome to the Web Server Certificate Wizard window appears, click Next.

6. Select Assign an Existing Certificate, and click Next.

7. Select your server certificate (Intended Purpose: Server Authentication), and click Next.

8. Accept the default SSL port (443) in the next window that appears, and click Next.

9. On the Certificate Summary screen, click Next.

10. Click Finish.
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Creating SSL Communication
Finally, we had to enable SSL communication as follows:

1. Go to Computer management-> Services and Application—>Internet Information Services.
2. Expand the Default Web site.

3. Expand wbtree.

4. Right-click Wbssl, and select Properties.

5. Select the Directory Security tab.

6. Under Secure communications, click Edit.

7. Check Require secure channel (SSL).

8. Check Require 128-bit encryption.

9. Click OK.

10. Click OK.

We then set the following operating system tuning parameters to reflect the WebBench recommendation in the
Microsoft performance Tuning Guidelines for Windows Server 2003 document, which is available on Microsoft's
Web site. When creating the following parameters, ensure that they are DWORD files, with decimal coding (rather
than hexadecimal)

HKLM\System\CurrentControlSet\Services\Inetinfo\Parameters\MaxCachesFileSize to 1048576
HKLM\System\CurrentControlSet\Services\HT TP\Parameters\UriMaxUriBytes to 1048576
HKLM\System\CurrentControlSet\Control\FileSystem\NtfsDisableLastAccess to 1
HKLM\System\CurrentControlSet\Services\Tcpip\Parameters\MaxHashTableSize to 65535

Installing and configuring the Java application server

To improve Java performance, we enabled large pages in memory on all servers. To enable this service, the
administrator must first assign additional privileges to the user who will be running the application. We assigned
this privilege only to the administrator, because we used that account for our tests. To enable large pages, we
selected the following:

e Control Panel->Administrative Tools—>Local Security Policy
e Local Policies>User Rights Assignment
e “Lock pages in memory,” add users and/or groups

Installing SPECjbb2005

We used SPECjbb2005 version 1.07, dated March 15, 2006. We followed SPEC'’s run rules. (For more
information about SPECjbb2005 and its run rules, see www.spec.org/jbb2005/docs/RunRules.html.) We installed
SPECjbb2005 by copying the contents of the SPECjbb2005 CD to the directory C:\SPECjbb2005v1.07 on the
server’s hard disk.

SPECjbb2005 requires a Java Virtual Machine on the system under test. We used the BEA JRockit 6.0 (build
P27.4.0-10-90053-1.6.0_02-20071009-1827-windows-x86_64 JDK for Microsoft Windows) JVM for this testing
and left the default installation settings.

After installation, as per the run rules, we edited the SPECjbb_config.props file in the root SPECjbb2005 directory
to include disclosure information about the server and our license information. SPECjbb2005 uses this file when
generating the results output for each run. We also modified the SPECjbb.props file to change the number of JVM
instances to two. This change allows a server to run two JVM instances during testing.

We created a batch file, which we placed in the root SPECjbb2005 directory, to issue the Java run command to
launch the benchmark. During testing, we used the command prompt window within Microsoft Windows Server
2003 x64 Edition to run this batch file. Figure 12 shows the contents of this file, which we used on all servers.
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7 runit-affinity.bat. B ElEEs
' File Edit Format View Help i
@echo off -

et IvM=2

11 Set JAVA_HOME to Java.exe path.
set JAVA_HOME="C:\jrockit-jdkl.&.0_02%bin"

set path=%JAvA_HOMES; %pathi

:stagel

set PROPFILE=SPECjbb.props

set JAVAOPTIONS= —-Xms256m —-xXmx256m

rem set JBBJARS=.‘jbb.jar;.‘\check. jar

set JBBJARS=."“jbb. jar;.%jbb_no_precompile. jar;."‘check. jar;.\reporter. jar

set CLASSPATH=%IBBIARSH; MCLASSPATH:
‘stage?

echo Using CLASSPATH entries:

for %%c in { BCLASSPATHY ) do echo %%cC

@echo on

start /b java %IAVAOPTIONSY: spec. jbb.Controller -propfile %PROPFILE%
@echo off

set I=0

set 1=F

:LOOP

set /a I=%1I + 1

echo.

EEEO Starting JvM Number %I% with affinity to CPU %1%
echo.

@echo on

start /AFFINITY %1% /B java -Xms3500m -Xns3000m -Xmx3500m -XXaggressive -X¥largepages -
*xcallprofiling -Xgc:genpar -xXxXthroughputCompaction -xXlazyunlocking -
*¥xtlasize:min=dk,preferred=128k 5pec.jgb.JBBma1n -propfile %¥PROPFILE% -id %I% > multi.%I%
@echo off

set 1=31%0

IF %I% == %IVM% GOTO END

GOTO LOOP

END

.egress

Figure 12: The text of the batch file we used to execute the SPECjbb2005 benchmark on all servers.

In the batch file we set the Java options that control the performance of the JVM.

e -Xms3500m This option sets the minimum heap size. We set the minimum and maximum heap sizes to
be the same, so the heap size would stay a constant 3500MB.

-Xns3200m This option sets the JVM nursery size.

-Xmx3500m This option sets the maximum heap size.

-XXaggressive This option basically tells the JVM to perform at maximum speed.

-XXlargepages This option tells the JVM to use large pages.

-XXcallprofiling This option enables call profiling for code optimizations.

-Xgc:genpar This option sets generational parallel garbage collection.

-XXthroughputCompaction This option adjusts the compaction ratio dynamically based on live data in the
heap.

e -XXlazyUnlocking This option affects when the JVM releases locks.
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-XXtlasize This option sets the thread-local area size the JVM uses.

Installing and configuring the database server

Installing Microsoft Internet Information Server

NGO ALN =

Select Start->Administrative Tools->Manage Your Server.

Select Add or remove a role.

At the preliminary steps screen, click Next.

At the Server Role screen, select Application Server, and click Next.

At the Summary of Selections screen, click Next.

When the installation software prompts you to do so, insert the OS CD, and click OK.
When the installation completes, click Finish.

Close the Manage Your Server window.

Installing Microsoft SQL Server 2005

SOoNooA~LN =

Insert the SQL Server 2005 CD into the server.

Click the Server Components link under the Install section to begin the installation.

Accept the license agreement, and click Next.

Click Next to install the prerequisites.

After the prerequisites complete installing screen, click Next.

At the Welcome screen, click Next.

At the System Configuration Check, assuming everything has a status of success, click Next.
Enter the registration information, and click Next.

At the Components to Install screen, select SQL Server Database Services, and click Advanced.

. Instruct the software to install both the Database Services and Client Components by clicking the drop-

down arrow on both and selecting Entire feature will be installed on local hard drive.

. Click Next to start the installation.

. For Instance Name, leave the default option, and click Next.

. At the Service Account screen, select Use the built-in system account (Local account), and click Next.

. Keep the default option for Authentication Mode, and click Next.

. For Collation Settings, leave the defaults, and click Next.

. Accept the default Error and Usage Report Settings, and click Next.

. At the Ready to Install screen, click Install to begin the installation.

. When the installation software prompts you to do so, insert Microsoft SQL Server 2005 disk 2, and click

OK.

. When the setup process completes, click Next.
. Click Finish to complete the installation.

Creating the test database and generating data

1.

S20oNO A

12.

0.
1. To prepare the database, type vsysbench.exe --test=oltp --oltp-table-size=100000

Select Start>Microsoft SQL Server 2005->SQL Server Management Studio.

In the Connect to Server window, use the drop-down menu next to Server name to select Browse for
more.

In the Browse for Server window, select the Network Servers tab, and wait for it to retrieve data.
When Database Engine appears, expand the menu, select Server, and click OK.

At the Connect to Server window, the server name should appear.

Click Connect to connect to the server.

Right-click the Database folder in the left-hand window, and select New Database from the pop-up menu.
In the Database name field, type sbtest, and click OK.

Open a command prompt by selecting Start>Run, type cmd, and click OK.

In the command prompt, type cd to change to C:\.

prepare, and press Enter.
When the command finishes, you see the C:\ prompt.
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13. Type exit, and press Enter to close the command prompt.

14. In SQL Server 2005 Management Studio, stop the database service by right-clicking Server in the left-
hand window pane, and then select Stop from the drop-down menu.

15. Using Windows Explorer, create the folder C:\backup.

16. With Windows Explorer, copy all sbtest files from C:\Program File\Microsoft SQL
Server\MSSQL.1\MSSQL\Data\ to c:\backup. (You should see two files: sbtest. mdf and sbtest_log.Idf.)

17. Close Windows Explorer once the copy completes.

18. Restart the database service using SQL Server 2005 Management Studio by right-clicking server and
selecting start.

We created a batch file, which we placed in the root directory, to issue the command to launch SysBench. During
testing, we used the command prompt window within Microsoft Windows Server 2003 x64 Edition to run this
batch file. Figure 13 shows the contents of this file, which we used on all servers.

File Edit Format View Help
logman start agate_sysbenchl_perflog_single_run

echo %time% => C:'sysbench_%_RUN%. Tog

Set START_HOUR=%TIME:~0,2%
52t START_MINUTE=XTIME:~3,2%
Set START_SECOND=%TIME:~&,2%

Set /A END_HOUR=%START_HOURS + 1
Set EMD_MINUTE=X%START_MIMUTES:
Set END_SECOND=%START_SECONDS
:_LOoP

Set HOUR=%TIME:-~0,2%

Set MINUTE=%TIME:~2,2%

Set SECOND=%TIME:~6,2%

If %HOUR% GTR HBEND_HOURY (

goto _exit

If %HOUR% GEQ %MEND_HOURZ: (
IF X3MINUTE®S GTR XEND_MIMUTEX (
goto _exit
)
J
c:hsysbench. exe --test=0ltp --oltp-table-size=100000 --num-threads=64 run
1==C:%sysbench_%_RUN%. log 2==C:%sysbench_%_RUN%.err
echo %rtimeX% >> C:\sysbench_%_RUN%. log
goto _LOOP
I_EXIT
logman stop agate_sysbenchl_perflog_single_run

echo DONE

[

Figure 13: The text of the batch file we used to execute SysBench on all servers.
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Installing the mail test client

The LoadSim benchmark requires one physical test client system. We used the following process to set up the

test client.
1. Install Microsoft Windows Server 2003 R2 Enterprise Edition, using mailclient as the system name.
2. Install Windows Server 2003 Service Pack 2 with the default settings.
3. Open the Network Connections window by right-clicking My Network Places and selecting Properties.
4. Right-click the network connection, and click Properties.
5. Highlight TCP/IP, and select Properties.
6. Select Use the following IP address, and enter the correct information
7. Click OK to close the two Properties windows.
8. Right-click My Computer, and select Properties.
9. Click the Computer Name tab.
10. Click Change.
11. Select Domain in the member of section, and type the domain test . com into the text box.

. In the pop-up window, enter administrator for user name and password for password, and click OK.

. At the Welcome to the domain screen, click OK.

. When the warning that you must restart dialog appears, click OK.

. Click OK to close the System Properties window.

. Click Yes to the pop-up message to restart the computer.

. Log in to the domain by using administrator and password.

. Install Microsoft Outlook 2003 with the default settings. (Outlook 2003 doesn’t require any configuration.)
. Install LoadSim 2003 by double-clicking the loadsim.msi installation file. Accept all defaults.

. Open LoadSim 2003, and make sure no error messages appear.

Configuring LoadSim 2003

©CoNooOA~WON =

15.

Start LoadSim by clicking Start Menu—>All Programs->Exchange LoadSim->LoadSim 2003.
From the LoadSim menu bar, select Configuration->Topology Properties.

Click the Servers tab.

In the left pane, click the + next to the name of this server.

In the left pane, select the First Storage Group.

In the right pane, set the number of users to 500.

Select the Security and Credentials tab.

Leave the Credentials choice set to Login to users using the account LoadSim is running on.
In the password portion of the tab, enter the password "Password1", and click OK.

. From the LoadSim menu bar, choose File->Save As
. Save a backup copy of the simulation file as C:\loadsim.sim.
. From the LoadSim menu bar, select Run->Create Topology, and wait until the Creating Users and

Creating DLs tasks complete.

. From the LoadSim menu bar, select Run—>Initialize Test.
. When a dialog box appears with the question Do you want to initialize Public Folders from this client

machine?, click Yes.
The run is complete when the bottom left corner of the LoadSim window shows Status: Idle. This task
typically takes about 2 to 3 hours to complete.

Backing up the mail database
Once you've set up LoadSim and created its initial mail database, you need to back up that database so you can
have clean copies for each test. Use this process to back up that database.

Ponp~

Select Start-> All Programs—-> Microsoft Exchange—> System Manager in the mail server.

In the left pane, expand Servers until First Storage Group appears highlighted.

In the right pane, right-click Mailbox Store, and select Dismount Store from the menu.

Click Yes on the Do you want to continue? pop-up message. When you’ve dismounted the Mailbox Store,
a red arrow appears in the window pane.
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7.
8.
9.
10.
11.
12.
13.
14.

Right-click Public Folder Store, and select Dismount Store from the menu.

Click Yes on the Do you want to continue? pop-up message. The red arrow appears when you've
dismounted the Public Folder Store.

Using Windows Explorer, create a new folder e:\backup.

With Windows Explorer, copy all files from C:\ to C:\backup. This process may take several minutes.
Close Windows Explorer.

In Exchange System Manager, right-click Mailbox Store, and select Mount Store from the menu.
Click OK on the pop-up message, The store was successfully mounted.

Right-click Public Folder Store, and select Mount Store from the menu.

Click OK on the pop-up message, The store was successfully mounted.

Close Exchange System Manager.

Network test bed configuration

To generate the workload, we used a network with 62 client PCs. Each PC contained an Intel Pentium 4 3.0GHz
with HT Technology processor, 512MB of system memory, a 40GB hard drive, and a Gigabit Ethernet network
adapter. We configured each client with Windows XP Professional with Service Pack 2 and all critical updates
available as of June 7, 2007.

We split 60 of the clients into four segments, or subnets, of 15 clients each. We connected each segment to the
server under test via one NETGEAR* GS724T Gigabit Smart Switch*. To balance the load on the server and to
prevent a network throughput bottleneck, we connected each segment to a separate network port. We used the
remaining two clients for the WebBench controller and LoadSim client. Figure 14 illustrates the test bed
configuration.

Intel Modular
Sarver

LoadSim

WebBench
ontroller
G-

Figure 14: lllustration of the test network we used to generate the WebBench and LoadSim
workload.
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Appendix A — Test system configuration information

This appendix provides detailed configuration information about the 64-bit and 32-bit Server Compute Module

configurations we tested.

Server Compute Module with

Server Compute Module with

Server Windows Server 2003 R2, Microsoft Windows Server
Enterprise x64 Edition 2003 R2, Enterprise Edition

General

Number of processor packages

Number of cores per processor 4 4

package

Number of hardware threads per y 1

core

gygtem Power Management Always on Always on

olicy

CPU

Vendor Intel Intel

Name Intel Xeon E5345 Intel Xeon E5345

Stepping 7 7

Socket type LGA 771 LGA 771

Core frequency (GHz) 2.33 GHz 2.33 GHz

Front-side bus frequency (MHz) | 1,333 MHz 1,333 MHz

L1 cache 4 x 32 KB 4 x 32 KB

2 x 4MB (each 4MB shared by

2 x 4MB (each 4MB shared by

BIOS name and version

SB5000.86B.10.00.0032.111220
071613

L2 cache

two cores) two cores)
Platform
Vendor and model number Intel MFSYS25 Intel MFSYS25
Motherboard model number MF5000SI MF5000SI
Motherboard chipset Intel 5000P Intel 5000P
Motherboard revision number B1 B1

Intel Intel

SB5000.86B.10.00.0032.111220
071613

BIOS settings Default Default
Chipset INF driver Intel 8.1.1.1010 Intel 8.1.1.1010
Memory module(s) SysBench LoadSim

Vendor and model number

Kingston KVR667D2D4F5/2G

Kingston KVR667D2D4F5/2G

Type

PC2-5300

PC2-5300

Speed (MHz) 667 MHz 667 MHz
Speed in the system currentl

ru‘;ning @ (Mgz) Y | 667 MHz 667 MHz
Timing/Latency (tCL-tRCD-iRP-

R Asgin) y( 5-5-5-15 5-5-5-15
Size 8 GB (4 x 2GB) 8 GB (4 x 2GB)
Number of RAM modules 4 4

Chip organization Double-sided Double-sided
Memory module(s) SPECjbb2005

Vendor and model number Kingston KVR667D2D8F5/1G N/A

Type PC2-5300 N/A

Speed (MHz) 667 MHz N/A
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Server

Server Compute Module with
Windows Server 2003 R2,
Enterprise x64 Edition

Server Compute Module with
Microsoft Windows Server
2003 R2, Enterprise Edition

Speed in the system currently
running @ (MHz)

667 MHz

N/A

Timing/Latency (tCL-tRCD-iRP-

4-port with 1064E-StorPort

tRASMIn) 5-5-5-15 N/A

Size 8 GB (8 x1 GB) N/A

Number of RAM modules 8 N/A

Chip organization Double-sided N/A

Memory module(s) WebBench

Vendor and model number g/légrgng\iTQHTFGMZFY- N/A

Type PC2-5300 N/A

Speed (MHz) 667 MHz N/A
rSuzi?rc]igm@th(?wsgzs;[em currently 667 MHz N/A
:[F&rxgr%/ihe;tency (tCL-tRCD-iRP- 5.5-5-15 N/A

Size 4 GB (8 x 512 MB) N/A

Number of RAM modules 4 N/A

Chip organization Double-sided N/A

Hard disk

Vendor and model number Seagate ST973451SS Seagate ST973451SS
Number of disks in system 14 14

Size 73.4 (each) GB 73.4 (each) GB
Buffer size 16 MB 16 MB

RPM 15,000 RPM 15,000 RPM
Type SAS SAS

Controller LSI Adapter, SAS 3000 series, LS| Adapter, SAS 3000 series,

4-port with 1064E-StorPort

Controller driver

LSI1 1.25.5.0

LS11.25.5.0

Operating system

Microsoft Windows Server 2003

Microsoft Windows Server 2003

Name R2 x64 Edition R2

Build number 3790 3790
Service Pack SP2 SP2
Microsoft Windows update date 10/19/07 10/19/07
File system NTFS NTFS

Kernel

ACPI Multiprocessor x64-based
PC

ACPI Multiprocessor-based PC

Language

English

English
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Server

Server Compute Module with
Windows Server 2003 R2,
Enterprise x64 Edition

Server Compute Module with
Microsoft Windows Server
2003 R2, Enterprise Edition

Microsoft DirectX version 9.0c 9.0c

Graphics

Vendor and model number ATI ES1000 ATI ES1000

Chipset ATI ES1000 ATI ES1000

BIOS version BK-ATI.VER008.005.030.000 BK-ATI.VER008.005.030.000
Type Integrated Integrated

Memory size 16 MB 16 MB

Resolution 1,280 x 1,024 1,280 x 1,024

Driver ATI 8.24.3.0 ATI 8.24.3.0

Network card/subsystem

Vendor and model number

Intel Pro 1000 EB

Intel Pro 1000 EB

Type Integrated Integrated
Driver Intel 9.7.34.0 Intel 9.7.34.0
Optical drive

Vendor and model number

None installed

None installed

USB ports

Number of ports

2

Type of ports (USB 1.1, USB
2.0)

USB 2.0

USB 2.0

Figure 15: Detailed system configuration information for the test servers.
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Appendix B — Intel Modular Server enclosure configuration

information

This appendix provides detailed configuration information about the Intel Modular Server enclosure.

Enclosure

Intel Modular Server chassis

General dimension information

Height (inches) 10.5
Width (inches) 19
Depth (inches) 28

U size in server rack 6
Number of compute modules 6
Power supplies

Total number 4
Wattage of each 1,050W
Cooling fans

Total number 4
Dimensions (H x W) of each 5" x 5"
Voltage 12V
Amps 4.8A

Additional cooling

I/0 cooling module (module w/ six small fans)

Figure 16: Detailed system configuration information for the Intel Modular Server enclosure.
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Appendix C — SPECjbb2005 output

This appendix provides the SPECjbb2005 output files from the median run for the two Server Compute Modules

running this benchmark.

Server Compute Module 3 single-benchmark run

SPECjbb2005

Intel Server Compute Module

SPECjbb2005 bops = 215609,
SPECjbb2005 bops/JVM = 107805

BEA JRockit 6.0 (build P27.4.0-10-90053-1.6.0_02-
20071009-1827-windows-x86 64 JDK for Microsoft

Windows)
JVM run JVM Scores
108170
2 107439

SPECjbb2005 bops = 215609,
SPECjbb2005 bops/JVM =

107805
Hardware

Hardware
Vendor Intel
Vendor URL http://www.Intel.com
Model Server Compute Module
Processor Intel Xeon E5345
MHz 2330
# of Chips 2
# of Cores 8

# of Cores/Chip 4

SCOoLEx

210000 1+

L0000+

1H0000 1

120000 4

20000 =

o000 -+

200004

Software Vendor
Vendor URL

JVM Version

JVM Command
Line

T T
3 -]
warehouses

- In=tance ce=ult
- Aggregated result

Software
BEA
http://www.bea.com

JRockit 6.0 (build P27.4.0-10-90053-
1.6.0_02-20071009-1827-windows-
x86_64 JDK for Microsoft Windows)

start /AFFINITY %J% /B C:\jrockit-
jdk1.6.0_02\bin\java.exe -Xms3500m -
Xns3000m -Xmx3500m -XXaggressive -
XXlargepages —Xxcallprofiling -
Xgc:genpar -XXthroughputCompaction -
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HW Threading

Enabled? No
Procs Avail to
8
Java
Memory (MB) 8192
Memory Details 4 x 2GB PC2-5300
Primary cache 32 KB + 32 KB

2 x 4MB (each 4MB shared

Secondary cache by two cores)

Other cache
Filesystem
Disks

Other hardware

NTFS

Test Information

Principled Technologies,
Inc.

3184
Durham, NC
Jan 10, 2008

Tested by

SPEC license #
Test location
Test date

H/w available
JVM available
OS available

Other s/w
available

JVM Initial Heap
Memory (MB)

JVM Maximum
Heap Memory
(MB)

JVM Address bits

JVM CLASSPATH

JVM

BOOTCLASSPATH

OS Version

Other software

XXlazyUnlocking -
XXtlasize:min=4k,preferred=128k
spec.jbb.JBBmain

3500

3500

64

Ajbb.jar;

A\jbb_no_precompile jar;

Acheck jar;

Areporter jar;

C:\jrockit-
jdk1.6.0_02\jre\bin\jrockit\jrockit1.6.0.jar;
C:\jrockit-
jdk1.6.0_02\jre\bin\jrockit\jmapi.jar;
C:\jrockit-
jdk1.6.0_02\jre\bin\jrockit\jmxmapi.jar;
C:\jrockit-
jdk1.6.0_02\jre\bin\jrockit\rmp.jar;
C:\jrockit-
jdk1.6.0_02\jre\bin\jrockit\latency jar;
C:\jrockit-
jdk1.6.0_02\jre\lib\resources.jar;
C:\jrockit-jdk1.6.0_02\jre\lib\rt.jar;
C:\jrockit-
jdk1.6.0_02\jre\lib\sunrsasign.jar;
C:\jrockit-jdk1.6.0_02\jre\lib\jsse.jar;
C:\jrockit-jdk1.6.0_02\jre\lib\jce. jar;
C:\jrockit-jdk1.6.0_02\jre\lib\charsets jar;
C:\jrockit-jdk1.6.0_02\jre\classes

Microsoft Server 2003 R2 Enterprise
x64 Edition, Service Pack 2

None

AOT Compilation

Tuning

“lock pages in memory” was enabled for the user running
the benchmark. Each JVM instance was bound to a single

CPU node

Notes

Principled Technologies, Inc.: Performance of the Intel® Modular Server on
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JVM 1

scores

No errors. Valid run.

Warehouses

1
2
3
4
5
6
7
8

SPECjbb2005
bops

28326
66828

90917
109617
108960
108285
107241
106747

Incl. in metric

108170

SPECjbb2005 (from 4 to 8) SPECjbb2005

SPEC license # 3184

bops

Tested by: Principled Technologies

Inc

SCOLET

100000

S0000 -

EO000 <

0000 -

20000 -

| -
- Not included in score calculation

JVM 2 scores

No errors. Valid run.

Warehouses
1
2
3
4
5
6
7

8
SPECjbb2005

SPECjbb2005
bops

28623
61418
89879
109033
108229
107693
106480
105758

(from 4 to 8)

Incl. in metric

*

*

107439
SPECjbb2005

Principled Technologies, Inc.: Performance of the Intel® Module
simultaneous email, Web server, Java, and database workloads

SCores

100000 -

0000 -

E0000 -

0000 -

f f
4 &

Included in score calculation macthonses

" Test date: Jan 10, 2008




bops

SPEC license # 3184
Inc

Tested by: Principled Technologies

SPECjbb2005 Version: [SPECjbb2005 1.07, March 15, 2006]
Reporting page, Copyright © 2005 SPEC. All rights reserved

Server Compute Module 3 multi-benchmark run

SPECjbb2005

Intel Server Compute Module

’ Test date: Jan 10, 2008

SPECjbb2005 bops = 214623,
SPECjbb2005 bops/JVM = 107312

BEA JRockit 6.0 (build P27.4.0-10-90053-1.6.0_02-
20071009-1827-windows-x86 64 JDK for Microsoft

Windows)
JVM run JVM Scores
107441
2 107182
SPECjbb2005 bops = 214623,
SPECjbb2005 bops/JVM =
107312
Hardware
Hardware
Vendor Intel
Vendor URL http://www.Intel.com
Model Server Compute Module
Processor Intel Xeon E5345
MHz 2330

SCOoLEx

210000 4

150000 1+

150000+

120000 1

20000 =

o000 -+

Software Vendor
Vendor URL

JVM Version

JVM Command

- In=tance ce=ult
- Aggregated result

T
3 -]
warehouses

Software
BEA
http://www.bea.com

JRockit 6.0 (build P27.4.0-10-90053-
1.6.0_02-20071009-1827-windows-
x86_64 JDK for Microsoft Windows)

start /AFFINITY %J% /B C:\jrockit-

Principled Technologies, Inc.: Performance of the Intel® Modular Server on
simultaneous email, Web server, Java, and database workloads
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# of Chips 2
# of Cores 8
# of Cores/Chip 4
HW Threading

Enabled? No

Procs Avail to 8

Java

Memory (MB) 8192

Memory Details 4 x 2GB PC2-5300
Primary cache (32 KB + 32 KB

2 x 4MB (each 4MB shared

Secondary cache by two cores)

Other cache
Filesystem
Disks

Other hardware

NTFS

Test Information

Principled Technologies,
Inc.

3184
Durham, NC
Jan 10, 2008

Tested by

SPEC license #
Test location
Test date

H/w available
JVM available
OS available

Other s/w
available

Line

JVM Initial Heap
Memory (MB)

JVM Maximum
Heap Memory
(MB)

JVM Address bits

JVM CLASSPATH

JVM
BOOTCLASSPATH

OS Version

Other software

jdk1.6.0_02\bin\java.exe -Xms3500m -
Xns3000m -Xmx3500m -XXaggressive -
XXlargepages —Xxcallprofiling -
Xgc:genpar -XXthroughputCompaction -
XXlazyUnlocking -
XXtlasize:min=4k,preferred=128k
spec.jbb.JBBmain

3500

3500

64

\jbb.jar;

\jbb_no_precompile jar;

\check.jar;

Areporter.jar;

C:\jrockit-
jdk1.6.0_02\jre\bin\jrockit\jrockit1.6.0.jar;
C:\jrockit-
jdk1.6.0_02\jre\bin\jrockit\jmapi.jar;
C:\jrockit-
jdk1.6.0_02\jre\bin\jrockit\j}mxmapi.jar;
C:\jrockit-
jdk1.6.0_02\jre\bin\jrockit\rmp.jar;
C:\jrockit-
jdk1.6.0_02\jre\bin\jrockit\latency jar;
C:\jrockit-
jdk1.6.0_02\jre\lib\resources.jar;
C:\jrockit-jdk1.6.0_02\jre\lib\rt.jar;
C:\jrockit-
jdk1.6.0_02\jre\lib\sunrsasign.jar;
C:\jrockit-jdk1.6.0_02\jre\lib\jsse.jar;
C:\jrockit-jdk1.6.0_02\jre\lib\jce jar;
C:\jrockit-jdk1.6.0_02\jre\lib\charsets.jar;
C:\jrockit-jdk1.6.0_02\jre\classes

Microsoft Server 2003 R2 Enterprise
x64 Edition, Service Pack 2

None

AOT Compilation

Tuning

“lock pages in memory” was enabled for the user running
the benchmark. Each JVM instance was bound to a single

CPU node

Notes

Principled Technologies, Inc.: Performance of the Intel® Modular Server on
simultaneous email, Web server, Java, and database workloads
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JVM 1 scores

No errors. Valid run.

Warehouses

1
2
3
4
5
6
7
8

SPECjbb2005
bops

28176
66073

90285
108896
108018
107937
106488
105866

Incl. in metric

107441

SPECjbb2005 (from 4 to 8) SPECjbb2005

SPEC license # 3184

bops

Tested by: Principled Technologies

Inc

SCores

100000 -

GO00n -

GO00n -

0000 -

20000 -

- -
- WNot included in score calculaticon

JVM 2 scores

No errors. Valid run.

Warehouses
1
2
3
4
5
6
7

8
SPECjbb2005

SPECjbb2005
bops

27777
61848
89690
108704
107951
107366
106412
105476
(from 4 to 8)

Incl. in metric

*

107182

Principled Technologies, Inc.: Performance of the Intel® Module
simultaneous email, Web server, Java, and database workloads

=ZCorex

100000 -

GO0on -

GOp0n -

0000 -

f f
4 g

Included in score calculaticon marekinmes

" Test date: Jan 10, 2008




SPECjbb2005
bops

SPEC license # 3184
Inc

Tested by: Principled Technologies

SPECjbb2005 Version: [SPECjbb2005 1.07, March 15, 2006]
Reporting page, Copyright © 2005 SPEC. All rights reserved

Server Compute Module 4 single-benchmark run

SPECjbb2005

Intel Server Compute Module

" Test date: Jan 10, 2008

SPECjbb2005 bops = 214999,
SPECjbb2005 bops/JVM = 107500

BEA JRockit 6.0 (build P27.4.0-10-90053-1.6.0_02-
20071009-1827-windows-x86 64 JDK for Microsoft

Windows)
JVM run JVM Scores
107688
2 107311
SPECjbb2005 bops = 214999,
SPECjbb2005 bops/JVM =
107500
Hardware
Hardware
Vendor Intel
Vendor URL http://www.Intel.com
Model Server Compute Module
Processor Intel Xeon E5345

SCOoLEx

210000 4
150000 1
150000+
120000 1

20000 =

goonn - /
200004

P

Software Vendor
Vendor URL

JVM Version

- In=tance ce=ult
- Aggregated result

T T
3 -]
warehouses

Software
BEA
http://www.bea.com

JRockit 6.0 (build P27.4.0-10-90053-
1.6.0_02-20071009-1827-windows-
x86_64 JDK for Microsoft Windows)

Principled Technologies, Inc.: Performance of the Intel® Modular Server on
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MHz 2330
# of Chips 2
# of Cores 8
# of Cores/Chip 4
HW Threading No
Enabled?
Procs Avail to
8
Java
Memory (MB) 8192
Memory Details 4 x 2GB PC2-5300
Primary cache 32 KB + 32 KB

2 x 4MB (each 4MB shared

Secondary cache by two cores)

Other cache
Filesystem
Disks

Other hardware

NTFS

Test Information
Principled Technologies,

Tested by |

nc.
SPEC license # 3184
Test location Durham, NC
Test date Jan 10, 2008
H/w available
JVM available

OS available

JVM Command
Line

JVM Initial Heap
Memory (MB)
JVM Maximum

Heap Memory
(MB)

JVM Address bits

JVM CLASSPATH

JVM

BOOTCLASSPATH

OS Version

Other software

start /AFFINITY %J% /B C:\jrockit-
jdk1.6.0_02\bin\java.exe -Xms3500m -
Xns3000m -Xmx3500m -XXaggressive -
XXlargepages —Xxcallprofiling -
Xgc:genpar -XXthroughputCompaction -
XXlazyUnlocking -
XXtlasize:min=4k,preferred=128k
spec.jbb.JBBmain

3500

3500

64

\jbb.jar;

\jbb_no_precompile jar;

\check.jar;

Areporter.jar;

C:\jrockit-
jdk1.6.0_02\jre\bin\jrockit\jrockit1.6.0.jar;
C:\jrockit-
jdk1.6.0_02\jre\bin\jrockit\jmapi.jar;
C:\jrockit-
jdk1.6.0_02\jre\bin\jrockit\jmxmapi.jar;
C:\jrockit-
jdk1.6.0_02\jre\bin\jrockit\rmp.jar;
C:\jrockit-
jdk1.6.0_02\jre\bin\jrockit\latency jar;
C:\jrockit-
jdk1.6.0_02\jre\lib\resources.jar;
C:\jrockit-jdk1.6.0_02\jre\lib\rt.jar;
C:\jrockit-
jdk1.6.0_02\jre\lib\sunrsasign.jar;
C:\jrockit-jdk1.6.0_02\jre\lib\jsse.jar;
C:\jrockit-jdk1.6.0_02\jre\lib\jce jar;
C:\jrockit-jdk1.6.0_02\jre\lib\charsets.jar;
C:\jrockit-jdk1.6.0_02\jre\classes

Microsoft Server 2003 R2 Enterprise
x64 Edition, Service Pack 2

None

AOT Compilation

Tuning

“lock pages in memory” was enabled for the user running
the benchmark. Each JVM instance was bound to a single

CPU node

Notes

Principled Technologies, Inc.: Performance of the Intel® Modular Server on
simultaneous email, Web server, Java, and database workloads
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Other siw
available

JVM 1 scores

No errors. Valid run.

Warehouses SPECjbb2005 Incl. in metric
bops = N
1 28207 100000 -+
2 67170
3 90371 B
4 108886 *
5 108428 *
6 108128 * 50000+
7 106813 *
8 106186 *
20000 4
20000+
107688
SPECjbb2005 | (from 4 to 8) SPECjbb2005
bops _ _
a 5
B - Included in score caleulation macthonses
- Not included in score calculation

Tested by: Principled Technologies

SPEC license # 3184 |
nc

" Test date: Jan 11, 2008

JVM 2 scores

No errors. Valid run.

Warehouses SPECjbb2005 Incl. in metric
bops = o
1 28996 SR AL
2 65004
3 90192
s0000 4
4 108654 *
5 108135 *
6 107712 * sonoo 4
7 106406 * i
Principled Technologies, Inc.: Performance of the Intel® Modular Server on 33
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8 105650 *

107311
SPECjbb2005  (from 4 to 8) SPECjbb2005
bops

SPEC license # 3184
Inc

Tested by: Principled Technologies

SPEC|jbb2005 Version: [SPECjbb2005 1.07, March 15, 2006]
Reporting page, Copyright © 2005 SPEC. All rights reserved

Server Compute Module 4 multi-benchmark run

SPECjbb2005

Intel Server Compute Module

' Test date: Jan 11, 2008

SPECjbb2005 bops = 215248,
SPECjbb2005 bops/JVM = 107624

BEA JRockit 6.0 (build P27.4.0-10-90053-1.6.0_02-
20071009-1827-windows-x86 64 JDK for Microsoft

Windows)
JVM run JVM Scores
107901
2 107347
SPECjbb2005 bops = 215248,
SPECjbb2005 bops/JVM =
107624
Hardware
Hardware Intel
Vendor
Vendor URL http://www.Intel.com
Model Server Compute Module

SCores

210000 1
150000
LE0000 4
10000+

20000 =

EO000 - //
200004

/.__._"—l‘u

7

Software Vendor
Vendor URL

JVM Version

- Instance cesult
- Aggregated result

[

g

mwmarehouse=

Software
BEA
http://www.bea.com

JRockit 6.0 (build P27.4.0-10-90053-
1.6.0_02-20071009-1827-windows-

Principled Technologies, Inc.: Performance of the Intel® Modular Server on
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Processor

MHz

# of Chips

# of Cores

# of Cores/Chip

HW Threading
Enabled?

Procs Avail to
Java

Memory (MB)
Memory Details
Primary cache

Secondary cache

Other cache
Filesystem
Disks

Other hardware

Intel Xeon E5345
2330

2

8

4

No

8

8192
4 x 2GB PC2-5300
32 KB + 32 KB

2 x 4MB (each 4MB shared
by two cores)

NTFS

Test Information

Tested by

SPEC license #
Test location
Test date

H/w available
JVM available
OS available

Principled Technologies,
Inc.

3184
Durham, NC
Jan 10, 2008

JVM Command
Line

JVM Initial Heap
Memory (MB)
JVM Maximum
Heap Memory
(MB)

JVM Address bits

JVM CLASSPATH

JVM

BOOTCLASSPATH

OS Version

Other software

x86_64 JDK for Microsoft Windows)

start /AFFINITY %J% /B C:\jrockit-
jdk1.6.0_02\bin\java.exe -Xms3500m -
Xns3000m -Xmx3500m -XXaggressive -
XXlargepages —Xxcallprofiling -
Xgc:genpar -XXthroughputCompaction -
XXlazyUnlocking -
XXtlasize:min=4k,preferred=128k
spec.jbb.JBBmain

3500

3500

64

Ajbb.jar;

A\jbb_no_precompile jar;

Acheck jar;

Areporter jar;

C:\jrockit-
jdk1.6.0_02\jre\bin\jrockit\jrockit1.6.0.jar;
C:\jrockit-
jdk1.6.0_02\jre\bin\jrockit\jmapi.jar;
C:\jrockit-
jdk1.6.0_02\jre\bin\jrockit\jmxmapi.jar;
C:\jrockit-
jdk1.6.0_02\jre\bin\jrockit\rmp.jar;
C:\jrockit-
jdk1.6.0_02\jre\bin\jrockit\latency jar;
C:\jrockit-
jdk1.6.0_02\jre\lib\resources.jar;
C:\jrockit-jdk1.6.0_02\jre\lib\rt.jar;
C:\jrockit-
jdk1.6.0_02\jre\lib\sunrsasign.jar;
C:\jrockit-jdk1.6.0_02\jre\lib\jsse.jar;
C:\jrockit-jdk1.6.0_02\jre\lib\jce. jar;
C:\jrockit-jdk1.6.0_02\jre\lib\charsets jar;
C:\jrockit-jdk1.6.0_02\jre\classes

Microsoft Server 2003 R2 Enterprise
x64 Edition, Service Pack 2

None

AOT Compilation

Tuning

“lock pages in memory” was enabled for the user running
the benchmark. Each JVM instance was bound to a single

CPU node

Notes

Principled Technologies, Inc.: Performance of the Intel® Modular Server on
simultaneous email, Web server, Java, and database workloads
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Other siw
available

JVM 1 scores

No errors. Valid run.

Warehouses SPECjbb2005 Incl. in metric
bops
1 28047 100000
2 61747
3 90348
S0000 4
4 109563 *
5 108914 *
6 108301 * so000 -+
7 106957 *
8 105767 *
20000 4
20000+
107901
SPECjbb2005 | (from 4 to 8) SPECjbb2005
bops _ _
a 5
B - Included in score caleulation macthonses
- Not included in score calculation

Tested by: Principled Technologies

SPEC license # 3184 |
nc

" Test date: Jan 21, 2008

JVM 2 scores

No errors. Valid run.

Warehouses SPECjbb2005 Incl. in metric
bops = L
1 29319 SR AL
2 66399
3 90050
s0000 4
4 108664 *
5 108104 *
6 107657 * Eo000 4
7 106603 * ]
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| 8 105709 | *

107347
SPECjbb2005 | (from 4 to 8) |[SPECjbb2005
bops

Tested by: Principled Technologies,

SPEC license # 3184
Inc

Test date: Jan 21, 2008

SPECjbb2005 Version: [SPECjbb2005 1.07, March 15, 2006]
Reporting page, Copyright © 2005 SPEC. All rights reserved

Principled Technologies, Inc.

» . . 1007 Slater Road, Suite 250
Principled Durham, NC 27703

‘ ITechnoIogies® www.principledtechnologies.com
info@principledtechnologies.com

Principled Technologies is a registered trademark of Principled Technologies, Inc.
Intel, Xeon, and Pentium are registered trademarks of Intel Corporation or its subsidiaries in the United States
and other countries.*All other product names are the trademarks of their respective owners.

Disclaimer of Warranties; Limitation of Liability:

PRINCIPLED TECHNOLOGIES, INC. HAS MADE REASONABLE EFFORTS TO ENSURE THE ACCURACY AND VALIDITY OF ITS
TESTING, HOWEVER, PRINCIPLED TECHNOLOGIES, INC. SPECIFICALLY DISCLAIMS ANY WARRANTY, EXPRESSED OR
IMPLIED, RELATING TO THE TEST RESULTS AND ANALYSIS, THEIR ACCURACY, COMPLETENESS OR QUALITY, INCLUDING
ANY IMPLIED WARRANTY OF FITNESS FOR ANY PARTICULAR PURPOSE. ALL PERSONS OR ENTITIES RELYING ON THE
RESULTS OF ANY TESTING DO SO AT THEIR OWN RISK, AND AGREE THAT PRINCIPLED TECHNOLOGIES, INC., ITS
EMPLOYEES AND ITS SUBCONTRACTORS SHALL HAVE NO LIABILITY WHATSOEVER FROM ANY CLAIM OF LOSS OR DAMAGE
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